Subject: [MMUSIC] Re: SDP QoS Mechanism Identification

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 25 Jan 2007 13:30:50 +0200

Hi Flemming,

thanks for your comments. I intend to add the following section in order 
to address your last comment:

4.4.  Subsequent Offer/answer Exchanges

    If, during an ongoing session that uses QoS, an endpoint receives a
    subsequent offer that does not contain the 'qos-mech-send' and 'qos-
    mech-recv' attributes, the endpoints SHOULD continue using the same
    QoS mechanism or mechanisms used up to that moment.

Would that work for you?

Thanks,

Gonzalo

Flemming Andreasen wrote:
> Thanks for the update - it addresses my previous concerns. The only
> other thing you may want to consider is to add a section for subsequent
> offer/answer exchanges - I presume you will simply do what that O/A
> exchange now specifies, and in the absence of parameter inclusion in
> this subsequent exchange, it is up to the local implementation what to
> do (e.g. try the mechanisms in the previously negotiated order or a
> completely different order, including using mechanisms not previously
> specified).
> 
> -- Flemming
> 
> 
> Gonzalo Camarillo wrote:
> 
>  > Hi,
>  >
>  > last time we presented this draft, Flemming had some concerns about its
>  > semantics. We have just submitted a new revision of the draft that tries
>  > and addresses Flemming's concerns. Now the result of the offer/answer
>  > exchange is a hint of which QoS mechanisms can be used because they are
>  > supported by the remote endpoint. However, it does not keep the
>  > endpoints from trying different mechanisms that may not be supported by
>  > the endpoint but may be supported by the network (e.g., thru an RSVP
>  > proxy).
>  >
>  > Until the draft appears in the official archives, you can fetch it from:
>  >
>  > 
> http://users.piuha.net/gonzalo/temp/draft-polk-mmusic-qos-mechanism-identification-02.txt
>  >
>  >
>  > Let us know if this revision addresses your concerns.
>  >
>  > Cheers,
>  >
>  > Gonzalo
>  >
> 

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 25 Jan 2007 19:18:43 -0500

Gonzalo Camarillo wrote:
> Hi Flemming,
>
> thanks for your comments. I intend to add the following section in 
> order to address your last comment:
>
Sounds good.

Thanks

-- Flemming