Subject: [MMUSIC] comments on draft-ietf-mmusic-sdp-capability-negotiation-06.txt

From: "Robert R. Gilman" <[email-masked]>
Date: Tue, 23 Oct 2007 16:11:48 -0600

Flemming-
I have one minor suggestion for the acap attribute definition.  Insofar as
the contents must be an attribute, why not omit the "a=" part?  Thus,
for example, the line
	a=acap:1 a=ptime:20
would become
	a=acap:1 ptime:20

Magnus Westerlund used the acap attribute in an example like
	a=acap:2 b=AS:128
when he was exploring the use of cap-neg for AMR parameter negotiation,
but I'd much prefer we define a different capability attribute - call
it bcap - that can be used to specify a bandwidth parameter for a pcfg
attribute.  Something like
	a=acap:1 ptime:20
	a=bcap:1 AS:128
	a=pcfg:1 a=1 b=1 ....
I believe we plan to define that in the upcoming version of the media-
capabilities draft (along with several other attributes.)
Comments?
-Bob
----------------------------------------------------
Bob Gilman       [email-masked]      +1 303 538 3868

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 24 Oct 2007 15:44:41 -0400

Hi Bob

I agree we should have different attributes for other types of 
capabilities (such as bandwidth) and hence the "a=" part of the "acap" 
attribute is redundant as you noted.

I'm fine with removing it, unless anybody has any objections (e.g. due 
to an existing deployed implementation). If so please let me know.

-- Flemming

---

From: "Stach, Thomas" <[email-masked]>
Date: Thu, 25 Oct 2007 11:43:24 +0200

Flemming, Bob,

I don't object but I remember some early discussion where it was claimed
that the a=acap: attribute should carry the whole capability attribute
including the "a=". 
I think the reason was to facilitate the construction of the SDP for
potential configurations.
If that really matters much is questionable.

Regards
Thomas

> -----Original Message-----
> From: Flemming Andreasen [mailto:[email-masked]] 
> Sent: Wednesday, October 24, 2007 9:45 PM
> To: Robert R. Gilman
> Cc: Even, Roni; 'mmusic'
> Subject: Re: [MMUSIC] comments 
> ondraft-ietf-mmusic-sdp-capability-negotiation-06.txt
> 
> Hi Bob
>