Subject: Re: [MMUSIC] File transfer issue 50: Single hash

From: Eric Rescorla <[email-masked]>
Date: Sat, 20 Oct 2007 07:42:21 -0700

At Mon, 13 Aug 2007 14:57:40 +0300,
Miguel Garcia wrote:
> 
> During the IETF meeting in Chicago, Jonathan indicated that the way the 
> draft allows multiple hash algorithms creates an extra unneeded 
> complexity. It would be easier to use a single hash algorithm, such as 
> SHA-1.
> 
> Background: The hash is used for a double purpose:
> a) unique file identification
> b) verification of the correct reception of the file.
> 
> Bearing in mind the current complexity the endpoints need to deal with, 
> when they support several hashing algorithms, I am ok with the 
> suggestion. So, I recommend to use SHA-1 as the only hashing algorithm. 
> Do people have concerns?

I think this is fine, but you'll need some text explaining why this is
not a security critical function and that if you want to protect
the integrity of the file you will need another mechanism.

-Ekr

_______________________________________________
mmusic mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mmusic

---

From: Miguel Garcia <[email-masked]>
Date: Mon, 22 Oct 2007 08:12:10 +0300

> the integrity of the file you will need another mechanism.

Thanks. I'll add such explanation. I have already made the changes to 
live with a single hash, so this should fairly simple.

I will be submitting a new version of the draft sometime this week.

/Miguel
-- 
Miguel A. Garcia           tel:+358-50-4804586
Nokia Siemens Networks     Espoo, Finland