Subject: [MMUSIC] I-D Action:draft-ietf-mmusic-sdp-media-capabilities-05.txt

From: [email-masked]
Date: Mon, 14 Jul 2008 00:30:01 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Multiparty Multimedia Session Control Working Group of the IETF.

	Title           : SDP media capabilities Negotiation
	Author(s)       : R. Gilman, et al.
	Filename        : draft-ietf-mmusic-sdp-media-capabilities-05.txt
	Pages           : 50
	Date            : 2008-07-14

Session Description Protocol (SDP) capability negotiation provides a
general framework for indicating and negotiating capabilities in SDP.
The base framework defines only capabilities for negotiating
transport protocols and attributes.  In this document, we extend the
framework by defining media capabilities that can be used to
negotiate media types and their associated parameters.  This
extension is designed to map easily to existing and future SDP media
attributes.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mmusic-sdp-media-capabilities-05.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Ingemar Johansson S" <[email-masked]>
Date: Sun, 27 Jul 2008 23:58:06 +0200

Hi

With the addition of the "Additional Capability Attributes" in section
3.3.4 and esp. the possibility that e.g the c-line may change in the SDP
answer it would be preferrable if the potential configurations are built
up in a layered fashion.
Consider for instance that a middle box may not accept that the c line
is changed in the answer. 
An offer SDP should then provide with a few potential configurations
that does not propose to change the c-line. A policy function in a
middle box will then have the possibility to remove pcfg lines that it
does not approve without removing the entire capability negotiaion
framework.  
Section 3.3.4 suggests the possibility to alter other lines aswell but
for the moment the c-line may have the most serious impacts.

PS..
I am not 100% sure if I kick in open doors here. It may be possible that
I have read something with a similar wording but I fail to find it in
the drafts now.

/Ingemar

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: den 14 juli 2008 09:30
> To: [email-masked]
> Cc: [email-masked]
> Subject: [MMUSIC] I-D 
> Action:draft-ietf-mmusic-sdp-media-capabilities-05.txt
> 
> This draft is a work item of the Multiparty Multimedia 
> Session Control Working Group of the IETF.
> 
> 
> 	Filename        : 
> draft-ietf-mmusic-sdp-media-capabilities-05.txt
> 	Pages           : 50
> 	Date            : 2008-07-14
> 
> Session Description Protocol (SDP) capability negotiation 
> provides a general framework for indicating and negotiating 
> capabilities in SDP.
> transport protocols and attributes.  In this document, we 
> extend the framework by defining media capabilities that can 
> be used to negotiate media types and their associated 
> parameters.  This extension is designed to map easily to 
> existing and future SDP media attributes.
> 
> Below is the data which will enable a MIME compliant mail 
> reader implementation to automatically retrieve the ASCII 
> version of the Internet-Draft.
>