Subject: [MMUSIC] RFC 4566bis - issue 13 - SDP Grammar issues

From: Colin Perkins <[email-masked]>
Date: Mon, 14 Jul 2008 23:58:54 +0100

On 10 Nov 2006, at 00:10, Alfred HÎnes wrote:
> (13)  SDP Grammar issues  (ABNF in Section 9, p. 39 ff.),
>
> a)
> The rule for 'repeat-interval'  (page 41)  could easily have
> re-used (incorporated) the 'integer' rule:
>
>    repeat-interval =     POS-DIGIT *DIGIT [fixed-len-time-unit]
>
> is equivalent to:
>
>    repeat-interval =     integer [fixed-len-time-unit]

Valid, but not necessary. Propose no change.

> b)
> The rule for FQDN, at the bottom of page 42, is wrong;
> FQDNs really should allow up to 255 characters!
>                          v
> |  FQDN =                4*(alpha-numeric / "-" / ".")
>                          ; fully qualified domain name as specified
>                          ; in RFC 1035 (and updates)
>
> Because details are not gived (can be found at other places),
> this rule should perhaps be only minimally corrected to say:
>
> |  FQDN =                *(alpha-numeric / "-" / ".")
>                          ; fully qualified domain name as specified
>                          ; in RFC 1035 (and updates)

Comments from implementers? This looks reasonable at first glance,  
although it is an incompatible change to the ABNF.

-- 
Colin Perkins
http://csperkins.org/

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 15 Jul 2008 14:40:56 +0200

> although it is an incompatible change to the ABNF.

Actually, what the current rule says is that there needs to be at least 
4 character. There is no upper limit specified in this rule. I have no 
idea why 4 characters where chosen as the lower limit. But I don't think 
it is likely to cause issues. As I can see it, only if ICANN allows 
single character TLD or if one runs a machine with a TLD as identifier 
will there be a problem.

Thus, I don't think there will be any issue with leaving the rule as it is.

Cheers

Magnus Westerlund

IETF Transport Area Director & TSVWG Chair
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone +46 8 4048287
Färögatan 6                | Fax   +46 8 7575550
S-164 80 Stockholm, Sweden | mailto: [email-masked]
----------------------------------------------------------------------