Subject: [MMUSIC] question on draft-ietf-mmusic-media-loopback-08

From: "Diego Costantini" <[email-masked]>
Date: Fri, 4 Jul 2008 18:28:29 +0200

Hi,

I have new questions/proposals for the draft, and I would like to discuss them here.

Since the purpose of this draft is to use it for active monitoring, it would result useful not only as on-demand action from the terminal side, but also as periodical test from network side. (e.g, operator testing user's devices for a proactive quality measurement)

In this case, it would be necessary to do it transparently to the users (e.g, not ringing), but with the proposed implementation, at least old devices will ring and treat it as a normal call, making it not only useless but also annoying. (just tested with SIPp and IP Phones)

Isn't it a scenario to include in this draft?

And in such case, shouldn't be considered a transparent behavior of the mirror devices? (of course including security issues, I could not want everyone able to test/flood my phone, especially if they do it silently)

(an answer to questions in my previous mails would be appreciated too ;) )

Diego

=============================

Diego Costantini

NEC Europe Ltd.

NEC Laboratories Europe

Network Research Division

Kurfuersten-Anlage 36

69115 Heidelberg

Germany

[email-masked]

http://www.nw.neclab.eu

=============================

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 04 Jul 2008 14:33:33 -0400

A very early version of this proposal combined the loopback and the auto 
answer into one document. There were intentionally separated because 
they are distinct, though in some ways complementary, issues.

There was already work on automatic answering: draft-ietf-sip-answermode-07.

Note that there are a lot of security issues in automatic answering.

	Thanks,
	Paul

Diego Costantini wrote:
> Since the purpose of this draft is to use it for active monitoring, it 
> would result useful not only as on-demand action from the terminal side, 
> but also as periodical test from network side. (e.g, operator testing 
> user’s devices for a proactive quality measurement)
> 
> In this case, it would be necessary to do it transparently to the users 
> (e.g, not ringing), but with the proposed implementation, at least old 
> devices will ring and treat it as a normal call, making it not only 
> useless but also annoying. (just tested with SIPp and IP Phones)
> 
>  
> 
> Isn’t it a scenario to include in this draft?
> 
> And in such case, shouldn’t be considered a transparent behavior of the 
> mirror devices? (of course including security issues, I could not want 
> everyone able to test/flood my phone, especially if they do it silently)
> 
>  
> 
> ------------------------------------------------------------------------
>

---

From: "Diego Costantini" <[email-masked]>
Date: Mon, 7 Jul 2008 10:03:13 +0200

Thank you Paul,

I understand the reason to separate them, but I think that since an application of the SDP loopback will be a silent test (this is what I really would like to use, the other scenarios don't offer such a big potential value in my opinion), at least something about silent tests may be mentioned/referenced.

I am also wondering if the ringing phone, as it happens in case it doesn't support the SDP loopback extension, wouldn't be a problem.

I will read the draft on answermode as soon as possible, but I am already aware of the big security issues it could raise, and at first glance I would think to that as an option disabled by default on devices and strongly recommend authentication (up to the users to enable that and specify a trusted testing device).

I think security issues shouldn't stop us from developing useful extensions, but (at most) just require a second thought before actually standardize them. :)

Thanks,
Diego

Kurfuersten-Anlage 36
69115 Heidelberg
Germany

-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]] 
Sent: Freitag, 4. Juli 2008 20:34
To: Diego Costantini
Cc: [email-masked]
Subject: Re: [MMUSIC] question on draft-ietf-mmusic-media-loopback-08

	Thanks,
	Paul

Diego Costantini wrote:
> user's devices for a proactive quality measurement)
> 
> And in such case, shouldn't be considered a transparent behavior of the