Subject: [MMUSIC] I-D Action:draft-ietf-mmusic-rfc2326bis-22.txt

From: [email-masked]
Date: Mon, 13 Jul 2009 09:45:02 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Multiparty Multimedia Session Control Working Group of the IETF.

	Title           : Real Time Streaming Protocol 2.0 (RTSP)
	Author(s)       : H. Schulzrinne, et al.
	Filename        : draft-ietf-mmusic-rfc2326bis-22.txt
	Pages           : 282
	Date            : 2009-07-13

This memorandum defines RTSP version 2.0 which obsoletes RTSP version
1.0 which is defined in RFC 2326.

The Real Time Streaming Protocol, or RTSP, is an application-level
protocol for setup and control of the delivery of data with real-time
properties.  RTSP provides an extensible framework to enable
controlled, on-demand delivery of real-time data, such as audio and
video.  Sources of data can include both live data feeds and stored
clips.  This protocol is intended to control multiple data delivery
sessions, provide a means for choosing delivery channels such as UDP,
multicast UDP and TCP, and provide a means for choosing delivery
mechanisms based upon RTP (RFC 3550).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mmusic-rfc2326bis-22.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Jose Rey" <[email-masked]>
Date: Tue, 28 Jul 2009 11:57:40 +0200

Hi.

I've got a question regarding ANNOUNCE and PLAY_NOTIFY. What is the relation between ANNOUNCE,  as per http://tools.ietf.org/id/draft-stiemerling-rtsp-announce-01.txt, and  PLAY_NOTIFY specified in this draft? They have something in common, but ANNOUNCE is much more ellaborated.

Are there plans to merge the two or replace one for the other? 

Thanks,

José

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: Monday, July 13, 2009 6:45 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [MMUSIC] I-D Action:draft-ietf-mmusic-rfc2326bis-22.txt
> 
> This draft is a work item of the Multiparty Multimedia 
> Session Control Working Group of the IETF.
> 
> 
> This memorandum defines RTSP version 2.0 which obsoletes RTSP 
> version 1.0 which is defined in RFC 2326.
> 
> The Real Time Streaming Protocol, or RTSP, is an 
> application-level protocol for setup and control of the 
> delivery of data with real-time properties.  RTSP provides an 
> extensible framework to enable controlled, on-demand delivery 
> of real-time data, such as audio and video.  Sources of data 
> can include both live data feeds and stored clips.  This 
> protocol is intended to control multiple data delivery 
> sessions, provide a means for choosing delivery channels such 
> as UDP, multicast UDP and TCP, and provide a means for 
> choosing delivery mechanisms based upon RTP (RFC 3550).
> 
> Below is the data which will enable a MIME compliant mail 
> reader implementation to automatically retrieve the ASCII 
> version of the Internet-Draft.
> 

Panasonic R&D Center Germany GmbH
63225 Langen, Hessen, Germany
Reg: AG Offenbach (Hessen) HRB 33974
Managing Director: Thomas Micke

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 28 Jul 2009 14:40:43 +0200

> Are there plans to merge the two or replace one for the other? 

PLAY_NOTIFY is based on the Announce draft. The base spec defines the
parts it needs for the defined media control. Additional indications for
reasons to deliver failures etc are not defined. However, note that the
play_notify with end-of-stream message do include error codes for why
delivery was cancelled in the "Request-Status" header.

Cheers

Magnus Westerlund

IETF Transport Area Director
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------

---

From: "Jose Rey" <[email-masked]>
Date: Wed, 29 Jul 2009 08:55:59 +0200

Hi Magnus. 

Still one thing is not clear to me: is the method PLAY_NOTIFY itself going to be kept in 2.0 as is or will it be extended with what's in the ANNOUNCE draft (and so deprecate it)? It would seem to me that if PLAY_NOTIFY and ANNOUNCE address the same functionality and have already some codes in common, like end-of-stream, so the rest of codes could also be added to it (?) 

Thanks,

José

> From: Magnus Westerlund [mailto:[email-masked]] 
> Sent: Tuesday, July 28, 2009 2:41 PM
> To: Jose Rey
> Cc: [email-masked]; [email-masked]
> Subject: Re: [MMUSIC] I-D Action:draft-ietf-mmusic-rfc2326bis-22.txt
> 
> Jose Rey skrev:
> >  
> > Hi.
> > 
> > I've got a question regarding ANNOUNCE and PLAY_NOTIFY. 
> What is the relation between ANNOUNCE,  as per 
> http://tools.ietf.org/id/draft-stiemerling-rtsp-announce-01.tx
> t, and  PLAY_NOTIFY specified in this draft? They have 
> something in common, but ANNOUNCE is much more ellaborated.
> > 
> PLAY_NOTIFY is based on the Announce draft. The base spec 
> defines the parts it needs for the defined media control. 
> Additional indications for reasons to deliver failures etc 
> are not defined. However, note that the play_notify with 
> end-of-stream message do include error codes for why delivery 
> was cancelled in the "Request-Status" header.
> 
> Cheers
> 
> Magnus Westerlund
>

---

From: Alex Giladi <[email-masked]>
Date: Wed, 29 Jul 2009 10:15:39 -0500

FWIW, a lot of STB's and VoD servers use the codes and syntax
specified in draft-stiemerling-rtsp-announce-01 with RTSP 1.0.
Alex

On Wed, Jul 29, 2009 at 1:55 AM, Jose Rey<[email-masked]> wrote:
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 29 Jul 2009 17:19:06 +0200

> Still one thing is not clear to me: is the method PLAY_NOTIFY itself going to be kept in 2.0 as is or will it be extended with what's in the ANNOUNCE draft (and so deprecate it)? It would seem to m…

Hi Jose,

Lets go look at the history from RTSP 1.0 to today for RTSP 2.0.
Announce was removed early in the update history due to uncertanties in
the semantics. Primarily intended to upload session description with
record. As record was removed, announce also disappeard.

Later there was these suggestions for announce as in the draft. This was
not accepted in full, but only the parts that the RTSP 2.0 core
specification do needs. Some things was modified in how they work. For
example error codes for the PLAY request can be included in
Request-Status header in a PLAY_NOTIFY request. Thus a number of the
Notice in the document are covered.

Thus a question to you, which from the ANNOUNCE draft do think needs to
be added to the RTSP core in some way?

Cheers

Magnus Westerlund

---

From: "Jose Rey" <[email-masked]>
Date: Thu, 30 Jul 2009 12:29:33 +0200

Magnus,

Inline...
> Sent: Wednesday, July 29, 2009 5:19 PM
> To: Jose Rey
> > Still one thing is not clear to me: is the method 
> PLAY_NOTIFY itself 
> > going to be kept in 2.0 as is or will it be extended with what's in 
> > the ANNOUNCE draft (and so deprecate it)? It would seem to 
> me that if 
> > PLAY_NOTIFY and ANNOUNCE address the same functionality and have 
> > already some codes in common, like end-of-stream, so the 
> rest of codes 
> > could also be added to it (?)
> 
> Hi Jose,
> 
> Announce was removed early in the update history due to 
> uncertanties in the semantics. Primarily intended to upload 
> session description with record. As record was removed, 
> announce also disappeard.

Ok, I was unaware how some of ANNOUNCE got into the base spec. Thanks for that.

> 
> Later there was these suggestions for announce as in the 
> draft. This was not accepted in full, but only the parts that 
> the RTSP 2.0 core specification do needs. Some things was 
> modified in how they work. For example error codes for the 
> PLAY request can be included in Request-Status header in a 
> PLAY_NOTIFY request. Thus a number of the Notice in the 
> document are covered.
> 
> Thus a question to you, which from the ANNOUNCE draft do 
> think needs to be added to the RTSP core in some way?
> 

I thought of beginning-of-stream but I've been told by your colleague Jan Lindquist that this is already possible with the functionality in RTSP 2.0.

Thanks,

José

---

From: "Jose Rey" <[email-masked]>
Date: Thu, 30 Jul 2009 12:30:58 +0200

Alex,

Thanks for the info. I assume these servers are in walled garden environments? 

Cheers,
José 

> From: Alex Giladi [mailto:[email-masked]] 
> Sent: Wednesday, July 29, 2009 5:16 PM
> To: Jose Rey
> Cc: Magnus Westerlund; [email-masked]
> >> Subject: Re: [MMUSIC] I-D 
> Action:draft-ietf-mmusic-rfc2326bis-22.txt
> >>
> >> Jose Rey skrev:
> >> >
> >> > Hi.
> >> >
> something in 
> >> common, but ANNOUNCE is much more ellaborated.
> >> >
> defines the 
> >> parts it needs for the defined media control.
> >> Additional indications for reasons to deliver failures etc are not 
> >> defined. However, note that the play_notify with end-of-stream 
> >> message do include error codes for why delivery was 
> cancelled in the 
> >> "Request-Status" header.
> >>
> >> Cheers
> >>
> >> Magnus Westerlund
> >>
> ---------------------------------------------------------------------
> >> - Multimedia Technologies, Ericsson Research EAB/TVM
> >> 
> ---------------------------------------------------------------------
> >> - Ericsson AB                | Phone  +46 10 7148287 
> Färögatan 6                
> >> | Mobile +46 73 0949079