Subject: Re: [MMUSIC] draft-jennings-mmusic-adjacent-grouping

From: Paul Kyzivat <[email-masked]>
Date: Wed, 23 Mar 2011 23:01:09 -0400

(Just catching up on my reading...)

One observation about this draft:

The grouping framework permits multiple groups to be formed with the 
same semantics. (E.g. you could define two audio/video groups, each to 
be lip synchronized.)

Analogously, one could presumably use the ADJ grouping semantic to form 
two independent groups of video streams.

OTOH, you might want to form two different groupings of m-lines that 
both map onto the same grid of devices. (For instance, a grouping of 
video m-lines and a corresponding grouping of audio m-lines.)

But the a=media-grid-dims attribute doesn't provide any way to identify 
which group it applies to if there is more than one.

At the very least, the issue of what to do when there are multiple 
adjacency groupings ought to be discussed.

	Thanks,
	Paul

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Thu, 24 Mar 2011 04:22:49 -0700

> -----Original Message-----
> From: Paul Kyzivat (pkyzivat)
> Sent: Thursday, March 24, 2011 4:01 AM
> To: Cullen Jennings (fluffy); Ali C. Begen (abegen)
> Cc: IETF MMUSIC WG
> Subject: Re: draft-jennings-mmusic-adjacent-grouping
> 

Yes. I just replied to Christer's email, he brought up the same thing. We realized this open issue after the revision.
 
> which group it applies to if there is more than one.

So it is a session-level attribute but this still does not solve the audio-video overlay problem (suppose I have 3x2 screens - 6 video streams and 6x2 audio (stereo) streams).

If such an overlay is a desired feature, a general solution needs to be identified.
 
> adjacency groupings ought to be discussed.

-acbegen

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 28 Mar 2011 18:04:30 +0200

Hi, 

>>The grouping framework permits multiple groups to be formed 
>>with the same semantics. (E.g. you could define two audio/video 
>>groups, each to be lip synchronized.)
>> 
>>Analogously, one could presumably use the ADJ grouping semantic to 
>>form two independent groups of video streams.
>> 
>>both map onto the same grid of devices. (For instance, a 
>>grouping of video m-lines and a corresponding grouping of audio m-lines.)
> 
>Yes. I just replied to Christer's email, he brought up the 
>same thing. We realized this open issue after the revision.
> 
>>But the a=media-grid-dims attribute doesn't provide any way to 
>>identify which group it applies to if there is more than one.
> 
>So it is a session-level attribute but this still does not 
>solve the audio-video overlay problem (suppose I have 3x2 
>screens - 6 video streams and 6x2 audio (stereo) streams).
> 

It is also important to remember that there might not always be a 1-to-1 mapping between audio and video.

For example, you might have 3 displays, with one video stream for each display, but only 2 microphones, with one audio stream for each microphone.

Regards,

Christer