Subject: [MMUSIC] SDP comments on draft-singh-avtcore-mprtp-02: General - Connectivity checks

From: Christer Holmberg <[email-masked]>
Date: Wed, 3 Aug 2011 22:54:09 +0200

Hi,

Below are some general comments on the connectivity checks. More specific comments will be found in my e-mails commending the individual sections.

Regards,

Christer

Connectivity checks:

	FU_GEN-1: The document defines a new type of connectivity check. We should have a 
	discussion whether that's a good thing to do or not, but assuming it will be done, 
	as I also indicate in my editorial comments, you need to more clearly define the "RTCP 
	connectivity checks" somewhere in the document, and then refer to it.

	I think you also need to describe the characteristic differences (security etc) 
	compared to STUN connectivity checks, and I think you should have some text on why 
	you define a new type of connectivity check in the first place (rather than relying on 
	STUN).

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Thu, 18 Aug 2011 15:04:08 +0200

As an individual...

Some comments to the connectivity checks of this draft.

I basically agree with Christer. I find confusing several concepts that 
are highly mixed in the draft, namely:

a) Whether ICE is mandatory or not

b) The presence of two mechanisms for doing connectivity checks: ICE and 
the RTP built-in

c) It seems to be mandated to do connectivity checks prior to using the 
MPRTP. This is something that currently is not mandated (unless you 
implement ICE). But if you implement vanilla RTP, you don't need to test 
the connectivity before you send or receive data.

So, the recommendation to the authors is to avoid mandating connectivity 
tests, but having as an option.

Use clear terminology: "STUN connectivity tests" versus "built-in RTP 
connectivity tests".

This, of course, assuming that you still want to support both types of 
connectivity test, something that is arguable.

/Miguel

On 03/08/2011 22:54, Christer Holmberg wrote:
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain