Subject: Re: [MMUSIC] NEED WG CONSENSUS: media-loopback is all-or-nothing

From: Gonzalo Camarillo <[email-masked]>
Date: Wed, 12 Dec 2012 13:29:42 +0200

Hi Hadriel,

the seems to be consensus around the "NO" path. Could you please revise
the draft accordingly so that we can also clear the last discuss?

Thanks,

Gonzalo

On 20/11/2012 8:16 PM, Hadriel Kaplan wrote:
> Howdy,
> during IESG review of the media-loopback draft, a discussion arose regarding the language around indicating media-loopback support per media description (i.e., per m-line), in sections 3.1 and 3.2.
> 
> My interpretation/understanding was we were requiring ALL m-lines to indicate media-loopback; in other words it's an all-or-nothing in both the offer+answer, and either every media stream is looped back, or none are.  However the text currently doesn't make this clear, and it could be argued either way, with pro's/con's either way too; so I'd like the WG's consensus on whether it should in fact be an all-or-none approach, or not.
> 
> Please respond to this email by **Tuesday, December 4th** with a "YES" if the draft should mandate ALL media be looped-back, or "NO" if it should allow a hybrid approach of some streams being looped while others are not.
> 
> For reference, the draft is here:
> http://tools.ietf.org/html/draft-ietf-mmusic-media-loopback-24
> 
> -hadriel
> 
>

---

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 17 Dec 2012 17:04:35 +0000

Howdy,
WG consensus is the "NO" path, and therefore section 3.1 of draft-24 will be changed from this:
"An SDP offerer compliant to this specification and attempting to establish a media session with media loopback MUST include "loopback" media attributes for each individual media description in the offer message.  The offerer will look for the "loopback" media attributes in the media description(s) of the response from the answer for confirmation that the request is accepted."

To this in draft-25:
"An SDP offerer compliant to this specification and attempting to establish a media session with media loopback will include "loopback" media attributes for each individual media description in the offer message that it wishes to have looped back.  Note that the offerer may choose to only request loop back for some media descriptions/streams but not others.  For example it might wish to request loopback for a video stream but not audio, or vice-versa.
 
The offerer will look for the "loopback" media attributes in the media description(s) of the response from the SDP answer for confirmation that the request is accepted."

-hadriel