Subject: Re: [MMUSIC] RFC 6190 Single Session Transport

From: Bernard Aboba <[email-masked]>
Date: Thu, 18 Jul 2013 19:02:16 -0700

Jonathan said: 

"I don't understand how single-session multi-source transmission will work without either a) signaling "a=ssrc-group DDP" decoding dependencies, or b) making various implementation-specific assumptions about the structure of the SVC streams."
 
[BA] In terms of SDP choices for expressing layering within a single m line, you can either go the a=ssrc-group:DDP route, or use distinct payload types for each layer and RFC 5583 a=group:DDP (this is what "Unified Plan" Section 4.7 appears to advocate).  

I'm not sure how "MST within a single session" could be expressed in SDP without BUNDLE.  Was the idea to use multiple m lines and group them together but use the same port?

---

From: Jonathan Lennox <[email-masked]>
Date: Fri, 19 Jul 2013 10:54:26 -0400

On Jul 18, 2013, at 10:02 PM, Bernard Aboba <[email-masked]<mailto:[email-masked]>> wrote:

Jonathan said:

I think the authors of RFC 6190 didn't see a use case for MST within a single RTP session -- all of the interesting MST use cases they saw involved separate transport flows for the separate layers, and if you're sending all the layers on a single transport flow, SST is significantly simpler.

What requirement are you trying to achieve that's met by MST in a single session, but not by SST?

--
Jonathan Lennox
[email-masked]<mailto:[email-masked]>