Subject: [MMUSIC] I-D Action: draft-ietf-mmusic-sdp-g723-g729-04.txt

From: [email-masked]
Date: Sun, 14 Jul 2013 21:42:52 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Multiparty Multimedia Session Control Working Group of the IETF.

	Title           : Offer/Answer Considerations for G723 Annex A and G729 Annex B
	Author(s)       : Muthu Arul Mozhi Perumal
                          Parthasarathi Ravindran
	Filename        : draft-ietf-mmusic-sdp-g723-g729-04.txt
	Pages           : 8
	Date            : 2013-07-14

Abstract:
   RFC4856 describes the annexa parameter for G723 and the annexb
   parameter for G729, G729D and G729E. However, the specification does
   not describe the offerer and answerer behavior when the value of the
   annexa or annexb parameter does not match in the Session Description
   protocol(SDP) offer and answer.  This document provides the offer/
   answer considerations for these parameters and updates RFC4856.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mmusic-sdp-g723-g729

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-mmusic-sdp-g723-g729-04

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-sdp-g723-g729-04

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Muthu Arul Mozhi Perumal (mperumal)" <[email-masked]>
Date: Mon, 15 Jul 2013 04:50:53 +0000

This updated version addresses all comments received during WGLC.

- Muthu, Partha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, July 15, 2013 10:13 AM
To: [email-masked]
Cc: [email-masked]
Subject: I-D Action: draft-ietf-mmusic-sdp-g723-g729-04.txt

Abstract:

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Avasarala, Ranjit (NSN - IN/Bangalore)" <[email-masked]>
Date: Mon, 15 Jul 2013 07:08:04 +0000

Hi Muthu

I have following comments
1. RFC 4856 defines "annexa" and "annexb" as optional parameters. So I agree there could be misinpterpretations.
2. The proposed draft should make these parameters as mandatory, otherwise the implementations would continue to ignore the parameters.
3. Update RFC 4856 moving "annexa" and "annexb" parameters from "optional" to "required".

Regards
Ranjit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Muthu Arul Mozhi Perumal (mperumal)
Sent: Monday, July 15, 2013 10:21 AM
To: [email-masked]
Subject: [MMUSIC] FW: I-D Action: draft-ietf-mmusic-sdp-g723-g729-04.txt

- Muthu, Partha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, July 15, 2013 10:13 AM
To: [email-masked]
Cc: [email-masked]
Subject: I-D Action: draft-ietf-mmusic-sdp-g723-g729-04.txt

Abstract:

mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: <[email-masked]>
Date: Mon, 15 Jul 2013 09:18:19 +0000

Hi

A lot of media subtypes have optional parameters, and as long as a default value is defined, there is no issue.
The problem here is not that annexa/annexb parameters are optional, but that the offer/answer procedure was not defined for these media subtypes.

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Avasarala, Ranjit (NSN - IN/Bangalore)
Envoyé : lundi 15 juillet 2013 09:08
À : ext Muthu Arul Mozhi Perumal (mperumal); [email-masked]
Objet : Re: [MMUSIC] I-D Action: draft-ietf-mmusic-sdp-g723-g729-04.txt

Hi Muthu

Regards
Ranjit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Muthu Arul Mozhi Perumal (mperumal)
Sent: Monday, July 15, 2013 10:21 AM
To: [email-masked]
Subject: [MMUSIC] FW: I-D Action: draft-ietf-mmusic-sdp-g723-g729-04.txt

- Muthu, Partha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, July 15, 2013 10:13 AM
To: [email-masked]
Cc: [email-masked]
Subject: I-D Action: draft-ietf-mmusic-sdp-g723-g729-04.txt

Abstract:

Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Muthu Arul Mozhi Perumal (mperumal)" <[email-masked]>
Date: Mon, 15 Jul 2013 14:28:41 +0000

Agree with Aurelien. In addition, the draft explicitly specifies the behavior for the default case:

   When the offer or answer has G723 and the annexa parameter is absent,
   the offerer or answerer knows that it has implied the default
   "annexa=yes".  This is because the annexa attribute is part of the
   original registration of audio/G723 [RFC4856].  All implementations
   that support G723 understand the annexa attribute.  Hence, this case
   MUST be considered as if the offer or answer has G723 with
   annexa=yes.

This I think should suffice to make sure implementations don't ignore it. So, making these optional parameters mandatory optional isn't needed (and probably isn't right).

Muthu

|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]]
|Sent: Monday, July 15, 2013 2:48 PM
|To: Avasarala, Ranjit (NSN - IN/Bangalore); Muthu Arul Mozhi Perumal (mperumal); [email-masked]
|Subject: RE: I-D Action: draft-ietf-mmusic-sdp-g723-g729-04.txt
|
|Hi
|
|A lot of media subtypes have optional parameters, and as long as a default value is defined, there is
|no issue.
|The problem here is not that annexa/annexb parameters are optional, but that the offer/answer
|procedure was not defined for these media subtypes.
|
|-----Message d'origine-----
|De : [email-masked] [mailto:[email-masked]] De la part de Avasarala, Ranjit (NSN -
|IN/Bangalore)
|Envoyé : lundi 15 juillet 2013 09:08
|À : ext Muthu Arul Mozhi Perumal (mperumal); [email-masked]
|Objet : Re: [MMUSIC] I-D Action: draft-ietf-mmusic-sdp-g723-g729-04.txt
|
|Hi Muthu
|
|I have following comments
|1. RFC 4856 defines "annexa" and "annexb" as optional parameters. So I agree there could be
|misinpterpretations.
|2. The proposed draft should make these parameters as mandatory, otherwise the implementations would
|continue to ignore the parameters.
|3. Update RFC 4856 moving "annexa" and "annexb" parameters from "optional" to "required".
|
|Regards
|Ranjit
|
|
|
|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Muthu Arul Mozhi
|Perumal (mperumal)
|Sent: Monday, July 15, 2013 10:21 AM
|To: [email-masked]
|Subject: [MMUSIC] FW: I-D Action: draft-ietf-mmusic-sdp-g723-g729-04.txt
|
|This updated version addresses all comments received during WGLC.
|
|- Muthu, Partha
|
|-----Original Message-----
|From: [email-masked] [mailto:[email-masked]] On Behalf Of internet-
[email-masked]
|Sent: Monday, July 15, 2013 10:13 AM
|To: [email-masked]
|Cc: [email-masked]
|Subject: I-D Action: draft-ietf-mmusic-sdp-g723-g729-04.txt
|
|A New Internet-Draft is available from the on-line Internet-Drafts directories.
| This draft is a work item of the Multiparty Multimedia Session Control Working Group of the IETF.
|
|	Title           : Offer/Answer Considerations for G723 Annex A and G729 Annex B
|	Author(s)       : Muthu Arul Mozhi Perumal
|                          Parthasarathi Ravindran
|	Filename        : draft-ietf-mmusic-sdp-g723-g729-04.txt
|	Pages           : 8
|	Date            : 2013-07-14
|
|Abstract:
|   RFC4856 describes the annexa parameter for G723 and the annexb
|   parameter for G729, G729D and G729E. However, the specification does
|   not describe the offerer and answerer behavior when the value of the
|   annexa or annexb parameter does not match in the Session Description
|   protocol(SDP) offer and answer.  This document provides the offer/
|   answer considerations for these parameters and updates RFC4856.
|
|The IETF datatracker status page for this draft is:
|https://datatracker.ietf.org/doc/draft-ietf-mmusic-sdp-g723-g729
|
|There's also a htmlized version available at:
|http://tools.ietf.org/html/draft-ietf-mmusic-sdp-g723-g729-04
|
|A diff from the previous version is available at:
|http://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-sdp-g723-g729-04
|
|Internet-Drafts are also available by anonymous FTP at:
|ftp://ftp.ietf.org/internet-drafts/
|
|_______________________________________________
|I-D-Announce mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/i-d-announce
|Internet-Draft directories: http://www.ietf.org/shadow.html or ftp://ftp.ietf.org/ietf/1shadow-
|sites.txt
|_______________________________________________
|mmusic mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/mmusic
|_______________________________________________
|mmusic mailing list
[email-masked]
|https://www.ietf.org/mailman/listinfo/mmusic
|
|______________________________________________________________________________________________________
|___________________
|
|Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et
|ne doivent donc
|pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur,
|veuillez le signaler
|a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant
|susceptibles d'alteration,
|Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
|
|This message and its attachments may contain confidential or privileged information that may be
|protected by law;
|they should not be distributed, used or copied without authorisation.
|If you have received this email in error, please notify the sender and delete this message and its
|attachments.
|As emails may be altered, Orange is not liable for messages that have been modified, changed or
|falsified.
|Thank you.

---

From: "Avasarala, Ranjit (NSN - IN/Bangalore)" <[email-masked]>
Date: Mon, 22 Jul 2013 04:45:24 +0000

Hi
I agree of not making these parameters mandatory. 

Regards
Ranjit

-----Original Message-----
From: ext Muthu Arul Mozhi Perumal (mperumal) [mailto:[email-masked]] 
Sent: Monday, July 15, 2013 7:59 PM
To: [email-masked]; Avasarala, Ranjit (NSN - IN/Bangalore); [email-masked]
Subject: RE: I-D Action: draft-ietf-mmusic-sdp-g723-g729-04.txt

Muthu