Subject: [MMUSIC] Offer/Answer sections in SDP drafts

From: Flemming Andreasen <[email-masked]>
Date: Thu, 02 Oct 2014 16:22:10 -0400

Greetings

One of the things we have tried to emphasize for SDP related drafts is 
the need to have well-defined offer/answer procedures, and as part of 
that, we have been asking people to follow the structure of RFC 3264. 
This means there needs to be the following O/A sections in SDP related 
drafts (in the order shown):

     1. Generating the Initial Offer
     2. Generating the Answer
     3. Offerer Processing of the Answer
     4. Modifying the Session

As part of the bundle-11 draft review, a (general) question came up 
around what actually goes in the "Generating the Answer" section. More 
specifically, should this section
     a) Apply to the initial offer only

     b) Apply to the initial offer and subsequent offers for the parts 
that apply in a general manner to both [parts that apply to subsequent 
offers only would be covered by "Modifying the Session"]

     c) Apply to all offers.

I believe the answer is b), however some feel the answer is c). One of 
the issues I see with that is that you potentially end up depending on 
text/rules from "Modifying the Session", however those procedures have 
not been defined at that point in the document. This can of course be 
solved with forward referencing (as is done in bundle-11), however it 
makes it harder to follow IMO and I also do not believe this is what RFC 
3264 intended.

Comments on the above would be appreciated.

Thanks

-- Flemming

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 2 Oct 2014 20:53:10 +0000

Hi,

In general, I believe the answer is c).

Of course, if there are major differences in the generating-answer procedures, depending on whether the answer is generated for the initial or a modification offer, they could be put in separate places. But, in the case of BUNDLE, the generating-answer procedures are more or less identical (some part may only apply to one case, though), so I see no need to separate them.

And, unless I've missed something, I believe I got rid of the forward references in version -11 :)

Regards,

Christer

-----Original Message-----
From: mmusic [mailto:[email-masked]] On Behalf Of Flemming Andreasen
Sent: 02 October 2014 23:22
To: mmusic
Subject: [MMUSIC] Offer/Answer sections in SDP drafts

Greetings

One of the things we have tried to emphasize for SDP related drafts is the need to have well-defined offer/answer procedures, and as part of that, we have been asking people to follow the structure of RFC 3264. 
This means there needs to be the following O/A sections in SDP related drafts (in the order shown):

As part of the bundle-11 draft review, a (general) question came up around what actually goes in the "Generating the Answer" section. More specifically, should this section
     a) Apply to the initial offer only

     b) Apply to the initial offer and subsequent offers for the parts that apply in a general manner to both [parts that apply to subsequent offers only would be covered by "Modifying the Session"]

     c) Apply to all offers.

I believe the answer is b), however some feel the answer is c). One of the issues I see with that is that you potentially end up depending on text/rules from "Modifying the Session", however those procedures have not been defined at that point in the document. This can of course be solved with forward referencing (as is done in bundle-11), however it makes it harder to follow IMO and I also do not believe this is what RFC
3264 intended.

Thanks

-- Flemming

_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Stach, Thomas" <[email-masked]>
Date: Tue, 7 Oct 2014 13:07:43 +0000

Fleming,

my initial thoughts also leaned towards b) 
However, things got a bit more complex since 3264 and its structure might not be ideal anymore.

With stuff like ICE, CapNeg or Bundle the subsequent offers are 
different from the initial offer although there might be no intent to modify the existing session.
Nevertheless, some specific procedures might be needed.
E.g. ICE needed to deal with resolution of a race condition for the subsequent fix-up offer.

The following structure seems more appropriate 

  1 Initial offer/answer exchange 
  1.1. Generating the Initial Offer
  1.2. Generating the Answer
  1.3. Offerer Processing of the Answer

  2. Subsequent offer/answer exchange
  2.1. Generating the subsequent Offer
  2.2. Generating the subsequent Answer
  2.3. Offerer Processing of the subsequent Answer   

  3. Modifying the Session
  3.1. Generating the modified Offer
  3.2. Generating the Answer
  3.3. Offerer Processing of the Answer 

With this the answer to the question would be " a) Apply to the initial offer only" 

The answer to a subsequent offer is most likely the same or very similar as for the initial offer.
In that case  2.2./2.3. could be rather short and point to 1.2./1.3. for most of the procedures.
Nevertheless this would give space to cover all peculiarities of subsequent offer/answer handling 
and highlights what needs to be different. 

I can also imagine that you can omit 2. completely, when it is not needed.
Similar for the subsections under 3.

Kind Regards/mit freundlichen Grüßen
Thomas Stach

> Sent: Donnerstag, 2. Oktober 2014 22:22
> To: mmusic