Subject: [MMUSIC] SDP Directorate Review: New SDP attribute sections in rfc4566bis

From: Christer Holmberg <[email-masked]>
Date: Sun, 19 Oct 2014 23:49:47 +0000

Hi,

I am performing an SDP directorate review of the SDP attribute sections (6 and 8.2.4) of draft-ietf-mmusic-rfc4566bis-12.

A couple of high level principle issues that needs to be discussed.

Offer/Answer considerations:
========================

Normally, when we define new SDP attributes, we are also supposed to define the associated Offer/Answer procedures (following the rules in RFC 3264).

However, the O/A procedures are missing from the attributes defined in the draft, nor is it anywhere said that they must be defined for new attributes.

BUNDLE considerations:
====================

Should we mandate to indicate which "category" [draft-ietf-mmusic-sdp-mux-attributes] an attribute is associated with.

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Sun, 19 Oct 2014 23:24:14 -0400

On 10/19/14 7:49 PM, Christer Holmberg wrote:
> Hi,
>
> I am performing an SDP directorate review of the SDP attribute sections
> (6 and 8.2.4) of draft-ietf-mmusic-rfc4566bis-12.
>

Hmm. Interesting catch.

> Normally, when we define new SDP attributes, we are also supposed to
> define the associated Offer/Answer procedures (following the rules in
> RFC 3264).
>
> However, the O/A procedures are missing from the attributes defined in
> the draft, nor is it anywhere said that they must be defined for new
> attributes.

Well, a number of them are covered in 3261 and 3264.
But not all. Need to think about it.

> BUNDLE considerations:
>
> ====================
>
> Should we mandate to indicate which “category”
> [draft-ietf-mmusic-sdp-mux-attributes] an attribute is associated with.

I had the impression that the mux draft was going to do that 
specification for all the attributes it has considered.
But attributes defined in the future will have to cover this.

We could decide to fold that into this bis so that it provides an 
example for the future.

Chairs - what do you think?

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 20 Oct 2014 07:01:30 +0000

Hi Paul,

> Well, a number of them are covered in 3261 and 3264.

Correct.

My issue is more about the fact that that there is no text on specifying the O/A procedures for new attributes. Currently we rely on the MMUSIC participants/chairs and SDP directorate to make sure it's there.

>> BUNDLE considerations:
>>
>> ====================
>>
>> Should we mandate to indicate which "category"
> I had the impression that the mux draft was going to do that specification for all the > attributes it has considered.

Correct.

So, again, the issue is more about the guidelines and procedures for defining new attributes.

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 20 Oct 2014 13:07:20 -0400

Chairs:

Do you want to expand the scope of this effort to include O/A and BUNDLE 
considerations for the attributes defined in this draft?

The pro is that this will further set an example for how future 
attributes should be defined.

The con is that this will require reproducing, or moving, information 
that is currently defined in other drafts.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 21 Oct 2014 06:24:28 +0000

Hi,

>Do you want to expand the scope of this effort to include O/A and BUNDLE >considerations for the attributes defined in this draft?
>
>The pro is that this will further set an example for how future attributes should be >defined.
>
>The con is that this will require reproducing, or moving, information that is currently >defined in other drafts.

If the O/A procedures for the attributes already exist elsewhere, I don't think we have to move them into 4566bis. Having a reference should be enough.

Regards,

Christer

On 10/20/14 3:01 AM, Christer Holmberg wrote:
>>> define the associated Offer/Answer procedures (following the rules 
>>> in RFC 3264).
>>>
>>> However, the O/A procedures are missing from the attributes defined 
>>> in the draft, nor is it anywhere said that they must be defined for 
>>> new attributes.
>>

---

From: "Ali C. Begen (abegen)" <[email-masked]>
Date: Tue, 21 Oct 2014 06:28:35 +0000

> On Oct 21, 2014, at 8:24 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi,
> 

Except 3264 I am not aware of any. And individual attributes defined their own stuff. I think Paul is asking for an example or some sort of illustration for the new drafts defining attributes.

> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: Flemming Andreasen <[email-masked]>
Date: Thu, 23 Oct 2014 23:11:49 -0400

> Chairs:
<chair-hat-on>
I don't think this is something the chairs should decide (at least not 
at this point). It would be good to hear what the WG thinks first (maybe 
a discussion point for IETF91 if we don't hear further before then.
</chair-hat-on>

> Do you want to expand the scope of this effort to include O/A and 
> BUNDLE considerations for the attributes defined in this draft?
>
<individual>
I think Christer brings up a really good point on O/A procedures. If we 
can reference 3264 for the ones covered there, and include some text for 
the rest, I think that would be ideal. It would be good to hear from 
others though.

In terms of bundle, the mux-attributes already covers RFC 4566 and its 
attributes and I don't think we want to introduce a dependency on 
4566bis for mux-attributes. In other words, those attributes should 
still be covered in the mux-attributes draft (no change).

I do believe we want Bundle procedures included as part of 4566bis in 
terms of procedures required to register new attributes going forward. 
Since 4566bis will be replacing 4566, I think it makes sense to have 
4566bis include mux-categories for the attributes (the IANA registries 
will need to be updated to point to 4566bis instead of 4566). As you 
note, this sets a good precedence for further drafts as well.

Makes sense ?
</individual>

Thanks

-- Flemming

>> My issue is more about the fact that that there is no text on 
>> specifying the O/A procedures for new attributes. Currently we rely 
>> on the MMUSIC participants/chairs and SDP directorate to make sure 
>> it's there.
>>
>>
>>>> BUNDLE considerations:
>>>>
>>>> ====================
>>>>
>>> specification for all the > attributes it has considered.
> .