Subject: [MMUSIC] WGLC comments on draft-ietf-mmusic-sdp-bundle-negotiation-12 - Offerless re-INVITE

From: "Stach, Thomas" <[email-masked]>
Date: Thu, 23 Oct 2014 15:34:45 +0000

All,

considered the case where a SIP dialog was established and BUNDLE was successfully negotiated in the initial offer/answer exchange.
If now an offerless re-INVITE arrives at one of the UIAs, how should the triggered offer be created?
Like during the initial SDP offer/answer exchange, i.e. in https://tools.ietf.org/html/draft-ietf-mmusic-sdp-bundle-negotiation-12#section-8.2 ?
Or Like in https://tools.ietf.org/html/draft-ietf-mmusic-sdp-bundle-negotiation-12#section-8.5 for modifying a session?

I see merits for both:
The first would be useful in case of call transfer initiated by a B2BUA based on 3PCC procedures.
The second would be useful to trigger a BAS.
Would it be useful to define an indicator that tells the offerer if 1 or 2 is requested?

Regards
Thomas

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 23 Oct 2014 16:48:51 +0000

Hi,

My approach has been that an initial offer is an initial offer no matter in what message it is sent.

In the past, there were discussions (and, if I remember correctly, text in the draft) that one could offer a shared address already in the initial offer, if the offerer "knows" (using some kind of indicator) that the answerer supports BUNDLE. But, that was later removed.

Regards,

Christer

-----Original Message-----
From: Stach, Thomas [mailto:[email-masked]] 
Sent: 23 October 2014 18:35
To: Christer Holmberg
Cc: 'mmusic'
Subject: WGLC comments on draft-ietf-mmusic-sdp-bundle-negotiation-12 - Offerless re-INVITE

All,

I see merits for both:

Regards
Thomas