Subject: [MMUSIC] BUNDLE: Mandating symmetric RTP?

From: Christer Holmberg <[email-masked]>
Date: Wed, 22 Oct 2014 13:08:35 +0000

Hi,

One question, raised as part of Paul's WGLC review of BUNDLE, was whether BUNDLE should mandate usage of symmetric RTP, i.e. using the same address:port for both sending and receiving RTP.

(If ICE is used with BUNDLE, symmetric RTP is obviously required)

Regards,

Christer

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Thu, 23 Oct 2014 13:17:11 +0000

On 22 Oct 2014, at 15:08, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

One question, raised as part of Paul’s WGLC review of BUNDLE, was whether BUNDLE should mandate usage of symmetric RTP, i.e. using the same address:port for both sending and receiving RTP.

I think that make sense. The report from SIPit31 said that 100% of the endpoints supported symmetric RTP
(https://www.sipit.net/SIPit31_summary)

.-.
Pål-Erik

Regards,

Christer
_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mmusic

---

From: "Olle E. Johansson" <[email-masked]>
Date: Thu, 23 Oct 2014 15:21:45 +0200

On 23 Oct 2014, at 15:17, Pal Martinsen (palmarti) <[email-masked]> wrote:

> 
> On 22 Oct 2014, at 15:08, Christer Holmberg <[email-masked]> wrote:
> 
>> Hi,
>>  
Was said to support... At least one did not during tests.

But anyway, I think symmetric RTP is a must in the networks we operate in.

/O

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 23 Oct 2014 10:03:20 -0400

On 10/23/14 9:21 AM, Olle E. Johansson wrote:
>
> On 23 Oct 2014, at 15:17, Pal Martinsen (palmarti) <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>>
>> On 22 Oct 2014, at 15:08, Christer Holmberg
>> <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>>> Hi,
>>> One question, raised as part of Paul’s WGLC review of BUNDLE, was
>>> whether BUNDLE should mandate usage of symmetric RTP, i.e. using the
>>> same address:port for both sending and receiving RTP.
>>

The question isn't whether symmetric RTP is important to you.
The question is whether symmetric RTP is necessary for BUNDLE.

If there is some belief that symmetric RTP is a practical necessity in 
all cases, and that support for asymmetric RTP should be deprecated, 
then ISTM that should be taken under consideration by AVT.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 23 Oct 2014 14:39:12 +0000

Hi,

>>>> One question, raised as part of Paul's WGLC review of BUNDLE, was 
> If there is some belief that symmetric RTP is a practical necessity in all cases, and that support 
> for asymmetric RTP should be deprecated, then ISTM that should be taken under consideration by AVT.

I think we could mandate symmetric RTP for BUNDLE even if AVT does not deprecate it for general use.

Symmetric RTP is assumed for a number of network functions, and it seems to be what most people are using. So, from that perspective, I think we could mandate symmetric RTP for BUNDLE. Less options means less interoperability problems :)

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 23 Oct 2014 11:26:42 -0400

> Symmetric RTP is assumed for a number of network functions, and it seems to be what most people are using. So, from that perspective, I think we could mandate symmetric RTP for BUNDLE. Less options…

We *could*, but should we?

Doing so is a passive/aggressive way of starting to deprecate 
non-symmetric RTP - without really discussing the real issue. The scope 
of this mechanism is potentially much broader than RTCWEB, so such 
decisions should not be made solely on the needs of RTCWEB.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 23 Oct 2014 15:51:46 +0000

Hi,

>>>>>> whether BUNDLE should mandate usage of symmetric RTP, i.e. using 
>>>>>> the same address:port for both sending and receiving RTP.
>>>>>
>>> If there is some belief that symmetric RTP is a practical necessity 
>>> in all cases, and that support for asymmetric RTP should be deprecated, then ISTM that should be taken under consideration by AVT.
>>
>> Symmetric RTP is assumed for a number of network functions, and it 
>> seems to be what most people are using. So, from that perspective, I 
>> think we could mandate symmetric RTP for BUNDLE. Less options means 
>> less interoperability problems :)
>
> Doing so is a passive/aggressive way of starting to deprecate non-symmetric RTP - without really discussing 
> the real issue. The scope of this mechanism is potentially much broader than RTCWEB, so such decisions should 
> not be made solely on the needs of RTCWEB.

For RTCWEB it is not an issue, as the usage of ICE mandates symmetric RTP.

My aim has all the time been to define BUNDLE as a generic mechanism, so my support of symmetric RTP is not because of RTCWEB - it is based on the fact that it seems to be what is being deployed.

So, I am not religious about it.

Regards,

Christer

---

From: Colin Perkins <[email-masked]>
Date: Thu, 23 Oct 2014 19:20:18 +0100

> For RTCWEB it is not an issue, as the usage of ICE mandates symmetric RTP.

Also, section 4.7 of draft-ietf-rtcweb-rtp-usage says “implementations are REQUIRED to implement and use Symmetric RTP”.

> [email-masked]

-- 
Colin Perkins
https://csperkins.org/

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 23 Oct 2014 14:30:12 -0400

Colin,

I don't know how to interpret your response.
Are you saying that it is ok to mandate symmetric RTP because it is 
already required for RTCWEB and BUNDLE is *only* for RTCWEB???

If we consider use of BUNDLE in other contexts, what would the reason be 
to require symmetric RTP?

As I said before - if the current wisdom is that RTP should *always* be 
used in a symmetric fashion, then can we just state that somewhere?

	Thanks,
	Paul

---

From: Colin Perkins <[email-masked]>
Date: Thu, 23 Oct 2014 19:44:34 +0100

Paul,

On 23 Oct 2014, at 19:30, Paul Kyzivat <[email-masked]> wrote:
> Are you saying that it is ok to mandate symmetric RTP because it is already required for RTCWEB and BUNDLE is *only* for RTCWEB???

No, I was merely clarifying that WebRTC requires symmetric RTP, irrespective of whether ICE is used. I made no comment about what should go in the BUNDLE draft.

> If we consider use of BUNDLE in other contexts, what would the reason be to require symmetric RTP?

Don’t know - I haven’t thought about this.

> As I said before - if the current wisdom is that RTP should *always* be used in a symmetric fashion, then can we just state that somewhere?

I have no objection to mandating symmetric RTP for some particular scenarios, but I don’t think a blanket statement that it MUST be used is appropriate, since there could be environments where using RTP in a non-symmetric manner makes sense. 

Colin

-- 
Colin Perkins
https://csperkins.org/

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 23 Oct 2014 14:56:05 -0400

> I have no objection to mandating symmetric RTP for some particular scenarios, but I don’t think a blanket statement that it MUST be used is appropriate, since there could be environments where usin…

Well then, ISTM that if there are scenarios where non-symmetric RTP 
makes sense, then there could well be a reason to use BUNDLE with those 
scenarios.

	Thanks,
	Paul

---

From: Iñaki Baz Castillo <[email-masked]>
Date: Fri, 24 Oct 2014 00:09:30 +0200

2014-10-23 20:44 GMT+02:00 Colin Perkins <[email-masked]>:
> there could be environments where using RTP in a non-symmetric manner makes sense.

May at least somebody give a real example of that? Just curious.

-- 
Iñaki Baz Castillo
<[email-masked]>

---

From: Christian Groves <[email-masked]>
Date: Fri, 24 Oct 2014 11:42:25 +1100

Doesn't CLUE reply on non-symmetric RTP (i.e. media streams are 
described as sendonly)? and given that multiple streams are used also a 
good candidate to use BUNDLE?

Christian

On 24/10/2014 5:56 AM, Paul Kyzivat wrote:
>> No, I was merely clarifying that WebRTC requires symmetric RTP, 
>> irrespective of whether ICE is used. I made no comment about what 
>> should go in the BUNDLE draft.
>>
>>> As I said before - if the current wisdom is that RTP should *always* 
>>> be used in a symmetric fashion, then can we just state that somewhere?
>>
>> I have no objection to mandating symmetric RTP for some particular 
>> scenarios, but I don’t think a blanket statement that it MUST be used 
>> is appropriate, since there could be environments where using RTP in 
>> a non-symmetric manner makes sense.
>
> makes sense, then there could well be a reason to use BUNDLE with 
> those scenarios.
>
>     Thanks,
>     Paul
>

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 23 Oct 2014 22:08:23 -0400

> good candidate to use BUNDLE?

Practically speaking we are talking about 2-party RTP *sessions* here. 
So for BUNDLE it would be for the whole bundle.

And for clue without BUNDLE, two RTP *sessions*, each with one m-line, 
one sendonly and one recvonly, are independent wrt this discussion.

	Thanks,
	Paul

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 24 Oct 2014 07:26:11 +0000

Hi,

Paul is correct. The issue is not about mandating bi-directional media, but whether we mandate symmetric RTP when we DO have bi-directional media associated with a bundled m- line.

Assuming we would not mandate symmetric RTP, are people ok still mandating using a single address:port for sending all bundled media? Or, should we also allow using separate addresses:ports for sending bundled media?

Regards,

Christer

-----Original Message-----
From: mmusic [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: 24 October 2014 05:08
To: [email-masked]
Subject: Re: [MMUSIC] BUNDLE: Mandating symmetric RTP?

On 10/23/14 8:42 PM, Christian Groves wrote:
> described as sendonly)? and given that multiple streams are used also 
> a good candidate to use BUNDLE?

And for clue without BUNDLE, two RTP *sessions*, each with one m-line, one sendonly and one recvonly, are independent wrt this discussion.

	Thanks,
	Paul

>>> Don't know - I haven't thought about this.
>>>
>>>> As I said before - if the current wisdom is that RTP should 
>>>> *always* be used in a symmetric fashion, then can we just state that somewhere?
>>>
>>> scenarios, but I don't think a blanket statement that it MUST be 
>>> used is appropriate, since there could be environments where using 
>>> RTP in a non-symmetric manner makes sense.
>>