Subject: [MMUSIC] draft-ietf-mmusic-sctp-sdp-07 Identifiers

From: Salvatore Loreto <[email-masked]>
Date: Thu, 2 Oct 2014 12:58:05 +0000

Hi there,

the JSEP editors are suggesting that the code point for SCTP over DTLS should 
probably split in two: "UDP/DTLS/SCTP" and "TCP/DTLS/SCTP".

that is to define to different identifiers to be able to distinguish when DTLS run
over TCP or over UDP

I am planning to make the changes in the next version.

br
Salvatore

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 2 Oct 2014 14:05:48 +0000

Hi,

I am ok with the split as such, but where is DTLS over TCP defined?

In addition,  draft-ietf-tsvwg-sctp-dtls-encaps, which defines SCTP over DTLS, says that the DTLS part "MUST be based on DTLS 1.0". Not really sure what is meant by "based on", but does that cover DTLS over TCP?

Regards,

Christer

-----Original Message-----
From: mmusic [mailto:[email-masked]] On Behalf Of Salvatore Loreto
Sent: 2. lokakuuta 2014 15:58
To: <[email-masked]> list
Subject: [MMUSIC] draft-ietf-mmusic-sctp-sdp-07 Identifiers

Hi there,

the JSEP editors are suggesting that the code point for SCTP over DTLS should probably split in two: "UDP/DTLS/SCTP" and "TCP/DTLS/SCTP".

that is to define to different identifiers to be able to distinguish when DTLS run over TCP or over UDP

br
Salvatore
_______________________________________________
mmusic mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Martin Thomson <[email-masked]>
Date: Thu, 2 Oct 2014 09:07:56 -0700

> In addition,  draft-ietf-tsvwg-sctp-dtls-encaps, which defines SCTP over DTLS, says that the DTLS part "MUST be based on DTLS 1.0". Not really sure what is meant by "based on", but does that cover…

I hope that DTLS 1.2 is OK.  We're shipping that.

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 2 Oct 2014 16:25:34 +0000

Hi,

>> In addition,  draft-ietf-tsvwg-sctp-dtls-encaps, which defines SCTP over DTLS, says that the DTLS 
>> part "MUST be based on DTLS 1.0". Not really sure what is meant by "based on", but does that 
>> cover DTLS over TCP?
>

Well, DTLS 1.2 is "based on" DTLS 1.0, so... :)

RFC 6347 (DTLS 1.2) does mention DTLS over TCP, but there is no reference, and the procedures in the RFC seem to assume (please correct me if I'm wrong) UDP.

Regards,

Christer