Subject: [MMUSIC] WGLC comments on draft-ietf-mmusic-sdp-bundle-negotiation-12 - BAS handling

From: "Stach, Thomas" <[email-masked]>
Date: Thu, 23 Oct 2014 15:34:30 +0000

All,

as noted in the draft:
   The main purpose of the BAS offer is to ensure that
   intermediaries, that might not support the BUNDLE extension, have
   correct information regarding the address is going to be used to
   transport the bundled media.
This is the same motivation as for the "ICE updated offer". 

Consequently, BUNDLE and ICE need to behave in the same way.
I don't want to restart the corresponding discussion for BAS again, 
but I personally prefer, that BAS should be optional, with the offerer indicating 
if it will perform BAS or not.

Regards
Thomas

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 23 Oct 2014 16:21:06 +0000

Hi,

Must-send-BAS played a central part in the agreement to merge the pre-merger BUNDLE mechanism with Cullen's mechanism.

And, the reason for sending it is the same as for sending the updated ICE offer.

Also keep in mind that you can use BUNDLE without ICE, in which case SDP is the only way (as you don't send STUN requests) to inform the remote endpoint about the selected address.

Regards,

Christer

-----Original Message-----
From: Stach, Thomas [mailto:[email-masked]] 
Sent: 23 October 2014 18:35
To: Christer Holmberg
Cc: 'mmusic'
Subject: WGLC comments on draft-ietf-mmusic-sdp-bundle-negotiation-12 - BAS handling

All,

as noted in the draft:

Consequently, BUNDLE and ICE need to behave in the same way.
I don't want to restart the corresponding discussion for BAS again, but I personally prefer, that BAS should be optional, with the offerer indicating if it will perform BAS or not.

Regards
Thomas

---

From: "Stach, Thomas" <[email-masked]>
Date: Fri, 24 Oct 2014 13:44:10 +0000

Christer,

> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Donnerstag, 23. Oktober 2014 18:21
> To: Stach, Thomas
> Cc: 'mmusic'
> Subject: RE: WGLC comments on draft-ietf-mmusic-sdp-bundle-negotiation-12 -
> BAS handling
> 
> Hi,
> 
> Must-send-BAS played a central part in the agreement to merge the pre-merger
> BUNDLE mechanism with Cullen's mechanism.
> 
[TS] And for that exact reason it needs to treated in the same way. 
But let's wait for the outcome of that other discussion on the ICE updated offer

> 
> Also keep in mind that you can use BUNDLE without ICE, in which case SDP is
> the only way (as you don't send STUN requests) to inform the remote endpoint
> about the selected address.
[TS] Who is the remote endpoint?
Offerer and Answerer certainly know the selected addresses from the SDP answer.
Regards
Thomas
> I don't want to restart the corresponding discussion for BAS again, but I
> personally prefer, that BAS should be optional, with the offerer indicating if
> it will perform BAS or not.
> 
> Regards
> Thomas

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 24 Oct 2014 15:31:22 +0000

Hi,

>> Must-send-BAS played a central part in the agreement to merge the 
>> pre-merger BUNDLE mechanism with Cullen's mechanism.
>> 

We can wait, but I once again want to remind you that must-send-BAS was probably the main reason why we could agree on a single BUNDLE mechanism.

>> Also keep in mind that you can use BUNDLE without ICE, in which case 
>> SDP is the only way (as you don't send STUN requests) to inform the 
>> remote endpoint about the selected address.
>

Sorry, I meant intermediaries.

Regards,

Christer

> but I personally prefer, that BAS should be optional, with the offerer 
> indicating if it will perform BAS or not.
> 
> Regards
> Thomas