Subject: [MMUSIC] WGLC comments on draft-ietf-mmusic-sdp-bundle-negotiation-12 - Editorial nits

From: "Stach, Thomas" <[email-masked]>
Date: Thu, 23 Oct 2014 15:33:51 +0000

All,

I reviewed bundle-12 and think that it is on a good way to becoming technically mature.
Nevertheless, I have a few issue that I will address in separate mails.

Below are some random editorial nits and clarifying question on some text that was not clear to me.

Section 8.2.2. Request offerer BUNDLE address selection
I can't parse that caption.

Section 8.5.3, 1st para

Typo ...it wants to add a bundled "m=" line to BUNDLE group,
-->  ...it wants to add a bundled "m=" line to a BUNDLE group,

Section 8.5.3, 2nd bullet
I could hardly parse this. 
   o  Place the SDP 'mid' attribute value associated with the "m=" line
      in the SDP 'group:BUNDLE' attribute mid list associated with the
      BUNDLE group [Section 8.2.2].
I think it means that the list of identification-tags (mid-values) in the group-attribute from the previous offer needs to be extended with the identification-tag that is carried in the 'mid' attribute of the additional m-line. Correct?

Section 9.2, 1st para
A typo at the start "If an offer or answerer in offers or answers ..."
->                  "If an offerer or answerer ..."
However, I'd prefer to shorten and change to
" If offers or answers include bundled "m=" lines that represent these protocols, the offerer 
 and answerer MUST support ..."
 ^^^
Section 10.1.2
Typo ... in order for a given payload type value to used inside ...
  -> ... in order for a given payload type value to be used inside ...

IANA consideration appear twice 
14. IANA Considerations
17. IANA Considerations 

Regards
Thomas

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 23 Oct 2014 16:11:03 +0000

Hi Thomas,

Thanks for your review! See inline.

---------------------

> Section 8.2.2. Request offerer BUNDLE address selection I can't parse that caption.

Based on Paul's review, I suggest to change that to "Request the offerer BUNDLE address".

---------------------

> -->  ...it wants to add a bundled "m=" line to a BUNDLE group,

Fixed.

---------------------

> I think it means that the list of identification-tags (mid-values) in the group-attribute from the previous offer 
> needs to be extended with the identification-tag that is carried in the 'mid' attribute of the additional m-line. Correct?

Yes.

I guess I could remove "associated with the BUNDLE group []", if it makes it more clear. That is the wording used for the initial offer, so...

---------------------

> However, I'd prefer to shorten and change to " If offers or answers include bundled "m=" lines 
> that represent these protocols, the offerer  and answerer MUST support ..."
 
Paul commented on the same sentence, and my suggested modification is:

"If an offer or answer includes bundled "m=" lines that represent these protocols, the offerer or answerer MUST support..."

So, it is almost as you suggested :)

---------------------

>  -> ... in order for a given payload type value to be used inside ...

Will be fixed.

---------------------

> IANA consideration appear twice 

17 will be removed.

---------------------

Regards,

Christer

---

From: "Stach, Thomas" <[email-masked]>
Date: Fri, 24 Oct 2014 13:45:31 +0000

Christer, 
thanks for the response.
Two alternative proposal below.

> Based on Paul's review, I suggest to change that to "Request the offerer
[TS] I think this caption does exactly reflect semantics of what's going on in that paragraph.
The offerer does not request a BUNDLE address, it is rather a suggestion.
What about "Suggesting the offerer BUNDLE address"

> > needs to be extended with the identification-tag that is carried in the
> 'mid' attribute of the additional m-line. Correct?
> 
> Yes.
> 
> I guess I could remove "associated with the BUNDLE group []", if it makes it
> more clear. 
[TS] That already helps, but what about:
 "Extend the SDP 'group:BUNDLE' attribute mid list with the additional SDP 'mid' attribute value."
I still think that "mid list" and "mid attribute value " are unfortunate terms though.
Regards
Thomas
>That is the wording used for the initial offer, so...
> 
> ---------------------
<snip/>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 24 Oct 2014 15:44:58 +0000

Hi,

> What about "Suggesting the offerer BUNDLE address"

We would have to go through the text and make sure it doesn't cause misaligned terminology.

In addition, there is a section named "Request a new offerer BUNDLE address", which we also would have to change.

>>> I think it means that the list of identification-tags (mid-values) 
>>> in the group-attribute from the previous offer
>>> needs to be extended with the identification-tag that is carried in 
>>> the 'mid' attribute of the additional m-line. Correct?
>> 
>> Yes.
>> 
>> I guess I could remove "associated with the BUNDLE group []", if it 
>> makes it more clear.

I can do that, but I don't think we need both "Extend" and "additional". 

So, perhaps:

"Extend the SDP 'group:BUNDLE' attribute mid list with the SDP 'mid' 
attribute value associated with the "m=" line."

> I still think that "mid list" and "mid attribute value " are unfortunate terms though.

We'll discuss that in the dedicated thread.

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 24 Oct 2014 12:15:59 -0400

> In addition, there is a section named "Request a new offerer BUNDLE address", which we also would have to change.

It seems that Thomas had the same problem with the title that I did, and 
arrived at the same proposed solution.

So I'm in favor of making this change, and then touching up other text 
if necessary.

	Thanks,
	Paul

> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 24 Oct 2014 19:28:19 +0000

Hi,

>> We would have to go through the text and make sure it doesn't cause misaligned >> terminology.
>>
> It seems that Thomas had the same problem with the title that I did, and arrived at > the same proposed solution.
>
> So I'm in favor of making this change, and then touching up other text if necessary.

Well, I then kindly ask you to help me by checking the other text, to look for possible impacts.

I guess we'd at least have to change the name of the other section I mentioned, but we also need to check the text.

Regards,

Christer

>>>> in the group-attribute from the previous offer needs to be extended 
>>>> with the identification-tag that is carried in the 'mid' attribute 
>>>> of the additional m-line. Correct?
>>>
>>> Yes.
>>>