Subject: Re: [MMUSIC] WGLC comments on draft-ietf-mmusic-sdp-bundle-negotiation-12 - Editorial nits- "requested address" to "suggested address"

From: Christer Holmberg <[email-masked]>
Date: Sun, 26 Oct 2014 13:53:25 +0000

Hi,

I went through the document, and identified the following paragraphs/bullets that would be affected by talking about "suggesting a BUNDLE address" instead of "requesting a BUNDLE address".

Section 8.2.1:
------------------

OLD:

	o  Indicate which unique address the offerer wants the answerer to
      	select as the offerer BUNDLE address [Section 8.2.2].

NEW:

	o   Indicate which unique address the offerer suggests 
	as the offerer BUNDLE address [Section 8.2.2].

Section 8.2.2:
------------------

OLD:

	In the offer, the address assigned to the "m=" line associated with
   	the offerer suggested BUNDLE mid indicates the address that the
   	offerer wants the answer to select as the offerer BUNDLE address
   	[Section 8.3.2].

NEW:

	In the offer, the address assigned to the
   	"m=" line associated with the offerer suggested BUNDLE mid indicates
   	the address that the offerer suggests as the
   	offerer BUNDLE address [Section 8.3.2].

Section 8.3.2:
------------------

OLD:

	In an offer, the address (unique or shared) assigned to the bundled
   	"m=" line associated with the offerer suggested BUNDLE mid indicates
   	the address that the offerer wants the answer to select as the
   	offerer BUNDLE address [Section 8.2.2].  The answerer MUST check
   	whether that "m=" line fulfills the following criteria:

NEW:

	In an offer, the address (unique or shared) assigned to the bundled "m="
   	line associated with the offerer suggested BUNDLE mid indicates the
   	address that the offerer suggests as the
   	offerer BUNDLE address [Section 8.2.2].  The answerer MUST check
   	whether that "m=" line fulfills the following criteria:

Section 8.5.1:
------------------

OLD:

	o  The offerer wants to request the answerer to select a new offerer
      	BUNDLE address [Section 8.5.2];

NEW:

	o  The offerer suggests a new offerer BUNDLE address [Section 8.5.2];

OLD:

	In addition, the offerer MUST select an offerer suggested BUNDLE mid
   	[Section 8.2.2], even if the offerer does not want the answerer to
   	select a new offerer BUNDLE address.

NEW:

	In addition, the offerer MUST select an offerer suggested BUNDLE mid 
	[Section 8.2.2], even if the offerer does not suggest a new offerer BUNDLE address.

Section 8.5.2:
------------------

OLD:

	When an offerer generates an offer, in which it wants the answerer to
   	select a new offerer BUNDLE address [Section 8.2.2], the offerer
  	MUST:

NEW:

	When an offerer generates an offer, in which it suggests
   	a new offerer BUNDLE address [Section 8.2.2], the offerer MUST:

OLD:

	o  Assign a unique address, which the offerer wants the answerer to
      	select as the offerer BUNDLE address, to a bundled "m=" line; and

NEW:

	o  Assign a unique address, which the offerer suggests as the 
	new offerer BUNDLE address, to a bundled "m=" line; and

OLD:

	o  Indicate that the offerer wants the answerer to select the unique
      	address as the offerer BUNDLE address [Section 8.2.2]

NEW:

	o  Indicate that the offerer suggests the unique address as the 
	new offerer BUNDLE address [Section 8.2.2]

OLD:

	NOTE: The offerer can assign a unique address to each bundled "m="
   	line in the offer, or it can assign the previously negotiated offerer
   	BUNDLE address to each "m=" line (except the "m=" line to which it
   	assigns the unique address that it wants the answerer to select as
   	the new offerer BUNDLE address).  

NEW:

	NOTE: The offerer can assign
  	a unique address to each bundled "m=" line in the offer, or it can
   	assign the previously negotiated offerer BUNDLE address to each "m="
   	line (except to the "m=" line to which it assigns the unique address
   	that it suggests as the new offerer BUNDLE address).

Section 8.5.3:
------------------

OLD:

	If the offerer wants the answerer to select the address associated
   	with the added "m=" line as the new offerer BUNDLE address, the
   	offerer suggested BUNDLE mid MUST represent the added "m=" line
   	[Section 8.2.2].

NEW:

	If the offerer suggests the address associated with the added "m=" 
	line as the new offerer BUNDLE address, the offerer suggested 
	BUNDLE mid MUST represent the added "m=" line [Section 8.2.2].

So, as you can see, it's not just about changing a couple of words in a title...

Regards,

Christer

-----Original Message-----
From: mmusic [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: 24 October 2014 19:16
To: [email-masked]
Subject: Re: [MMUSIC] WGLC comments on draft-ietf-mmusic-sdp-bundle-negotiation-12 - Editorial nits

On 10/24/14 11:44 AM, Christer Holmberg wrote:
> Hi,
>
>>>> Section 8.2.2. Request offerer BUNDLE address selection I can't 
>>>> parse that caption.
>>>
>>> Based on Paul's review, I suggest to change that to "Request the 
>>> offerer BUNDLE address".
>> [TS] I think this caption does exactly reflect semantics of what's 
>> going on in that paragraph.
>>
>> The offerer does not request a BUNDLE address, it is rather a suggestion.
>> What about "Suggesting the offerer BUNDLE address"
>
> We would have to go through the text and make sure it doesn't cause misaligned terminology.
>
> In addition, there is a section named "Request a new offerer BUNDLE address", which we also would have to change.

It seems that Thomas had the same problem with the title that I did, and arrived at the same proposed solution.

So I'm in favor of making this change, and then touching up other text if necessary.

	Thanks,
	Paul

---

From: "Stach, Thomas" <[email-masked]>
Date: Mon, 27 Oct 2014 14:59:59 +0000

Christer,

as it's more concise, I like the new text better.
Thanks for your effort of going through the complete document.

Regards	
Thomas

... well, of course, I still don't like the term "BUNDLE mid", but that's the topic of the other thread

> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Sonntag, 26. Oktober 2014 14:53
> To: Paul Kyzivat; [email-masked]; Stach, Thomas
> Subject: RE: [MMUSIC] WGLC comments on draft-ietf-mmusic-sdp-bundle-
> negotiation-12 - Editorial nits- "requested address" to "suggested address"
> 
> Hi,
> 
> I went through the document, and identified the following paragraphs/bullets
> that would be affected by talking about "suggesting a BUNDLE address" instead
> of "requesting a BUNDLE address".
> 
> Section 8.2.1:
> ------------------
> 
> OLD:
> 
> > In addition, there is a section named "Request a new offerer BUNDLE
> address", which we also would have to change.
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 27 Oct 2014 18:30:06 +0000

Hi,

>Thanks for your effort of going through the complete document.

So, does anyone have a problem with this change? Once implemented, I will not change it again...

Regards,

Christer

> I went through the document, and identified the following 
> paragraphs/bullets that would be affected by talking about "suggesting 
> a BUNDLE address" instead of "requesting a BUNDLE address".
> 
> Section 8.2.1:
> ------------------
> 
> OLD:
> 
> It seems that Thomas had the same problem with the title that I did, 
> and arrived at the same proposed solution.
>