Subject: [MMUSIC] WGLC comments on draft-ietf-mmusic-sdp-bundle-negotiation-12 - Terminology

From: "Stach, Thomas" <[email-masked]>
Date: Thu, 23 Oct 2014 15:34:00 +0000

All

Terminology

   Offerer suggested BUNDLE mid: The first mid value in a given SDP
   'group:BUNDLE' attribute mid list in an offer.
and
   Answerer selected BUNDLE mid: The first mid value in a given SDP
   'group:BUNDLE' attribute mid list in an answer.

These terms are not very intuitive and make the reading the related text quite cumbersome.
Since you are talking about the identification-tags from RFC5888
group-attribute = "a=group:" semantics *(SP identification-tag)

mid-attribute   = "a=mid:" identification-tag
may I suggest re-using that terminology and propose using a single, more pregnant term for both
together with additional explanation?
E.g.

BUNDLE-tag: The first element in the list of identification-tags of
            a 'group:' attribute [RFC5888] with BUNDLE semantics.
            This tag has special significance in that it identifies
            the m-line that carries the suggested or selected BUNDLE address.
            The corresponding m-line will carry the same tag in a 'mid' attribute.
            The offerer suggests a BUNDLE tag. The answerer preferably accepts
            the suggested BUNDLE-tag, but could select a different
            BUNDLE-tag, if necessary.
            Example:
            If we have e.g. 'a=group:BUNDLE foo bar', then 'foo' would be the
            BUNDLE-tag and 'a=mid:foo' the m-line with the BUNDLE address.

If there is appetite for changing that terminology, I understand that it would cause quite a few
other editorial changes in the remainder of the document.
In order to not delay progress of the draft, I can only offer to help in any editorial effort and would be happy to propose changed text.

Regards
Thomas

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 23 Oct 2014 16:36:04 +0000

Hi,

There has been many long discussions in order to come up with the terminology. Also,
considering the number of editorial re-structures that have already taken place, and the impact this would have on the document, I would suggest to NOT do the change.

But, if you think the existing definitions can be clarified, we can discuss that.

Regards,

Christer

From: Stach, Thomas [mailto:[email-masked]]
Sent: 23 October 2014 18:34
To: Christer Holmberg
Cc: 'mmusic'
Subject: WGLC comments on draft-ietf-mmusic-sdp-bundle-negotiation-12 - Terminology

All

Terminology

Regards
Thomas

---

From: "Stach, Thomas" <[email-masked]>
Date: Fri, 24 Oct 2014 13:45:16 +0000

Hi,

There has been many long discussions in order to come up with the terminology.
[TS] I know that much effort was already put into that.

Also,
considering the number of editorial re-structures that have already taken place, and the impact this would have on the document, I would suggest to NOT do the change.
[TS] I understand that there is not much appetite for putting more editorial work into the document.
Nevertheless, I still think that understanding the text is still unnecessarily cumbersome,
which in turn could lead to unnecessary misinterpretations during implementation.
But maybe it is just me, who has this problem, in which case I probably just have to  improve my reading skills.  ;-)
But, if you think the existing definitions can be clarified, we can discuss that.
[TS] Well, considering reuse of the RFC5888 terminology might be still worthwhile.
That would e.g. include replacing  "mid attribute value" with "identification-tag", etc.

Regards,

Christer

All

Terminology

Regards
Thomas

---

From: Christer Holmberg <[email-masked]>
Date: Sat, 25 Oct 2014 14:31:28 +0000

Hi,

I'd like to hear Paul's opinions on this, because he is the one who suggested the current terminology.

Regards,

Christer

From: Stach, Thomas [mailto:[email-masked]]
Sent: 24 October 2014 16:45
To: Christer Holmberg
Cc: 'mmusic'
Subject: RE: WGLC comments on draft-ietf-mmusic-sdp-bundle-negotiation-12 - Terminology

Hi,

Also,

Regards,

Christer

All

Terminology

Regards
Thomas

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 31 Oct 2014 14:30:35 -0400

On 10/25/14 10:31 AM, Christer Holmberg wrote:
> Hi,
>
> I’d like to hear Paul’s opinions on this, because he is the one who
> suggested the current terminology.

Sorry to be so slow responding.

I've looked back at the thread, and I am not entirely clear what the 
proposal is. In part it is replacing "BUNDLE mid" with "BUNDLE-tag".

Looking at where "BUNDLE mid" is used, it is mostly in constructs like:

    In the offer, the address assigned to the "m=" line associated with
    the offerer suggested BUNDLE mid indicates the address that the

Given the definition that Thomas proposed, that would still work with 
the change, but ISTM the linkage from "mid" to "m=" line is a little 
more obvious than from "tag" to "m=" line.

I don't know if Thomas was intending that there would still be 
definitions for "Offerer suggested BUNDLE-tag" and "Answerer selected 
BUNDLE-tag". I think we would still need those.

As an alternative, perhaps a definition of "BUNDLE mid" could be added, 
that has much of the text from Thomas' definition of "BUNDLE-tag".

	Thanks,
	Paul

> Regards,
>
> Christer
>
> *From:*Stach, Thomas [mailto:[email-masked]]
> *Sent:* 24 October 2014 16:45
> *To:* Christer Holmberg
> *Cc:* 'mmusic'
> *Subject:* RE: WGLC comments on
> draft-ietf-mmusic-sdp-bundle-negotiation-12 - Terminology
>
> Hi,
>
> */[TS] I know that much effort was already put into that. /*
>
> *//*
>
> Also,
>
> considering the number of editorial re-structures that have already
> taken place, and the impact this would have on the document, I would
> suggest to NOT do the change.
>
> */[TS] I understand that there is not much appetite for putting more
> editorial work into the document./*
>
> */Nevertheless, I still think that understanding the text is still
> unnecessarily cumbersome, /*
>
> */which in turn could lead to unnecessary misinterpretations during
> implementation./*
>
> */But maybe it is just me, who has this problem, in which case I
> probably just have to  improve my reading skills.  ;-) /*
>
> */[TS] Well, considering reuse of the RFC5888 terminology might be still
> worthwhile./*
>
> */That would e.g. include replacing  “mid attribute value” with
> “identification-tag”, etc./*
>
> *//*
>
> Regards,
>
> Christer
>
> *From:*Stach, Thomas [mailto:[email-masked]]
> *Sent:* 23 October 2014 18:34
> *To:* Christer Holmberg
> *Cc:* 'mmusic'
> *Subject:* WGLC comments on draft-ietf-mmusic-sdp-bundle-negotiation-12
> - Terminology
>
> All
>
> Terminology
>
> In order to not delay progress of the draft, I can only offer to help in
> any editorial effort and would be happy to propose changed text.
>
> Regards
>
> Thomas
>