Subject: [MMUSIC] SCTP-SDP: Definition of protocol identifiers

From: Christer Holmberg <[email-masked]>
Date: Wed, 29 Oct 2014 07:34:33 +0000

Hi,

One of the open issues in draft-ietf-mmusic-sctp-sdp is regarding the new protocol identifier values.

It has been suggested to, instead of "DTLS/SCTP", define the following protocol identifiers: "UDP/DTLS/SCTP" and "TCP/DTLS/SCTP".

As we need to reference where the transports are defined, could someone provide me where TCP  over DTLS is defined?

Thanks!

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 29 Oct 2014 07:41:19 +0000

Correction: We need a reference to where DTLS over TCP is defined.

Regards,

Christer

From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 29. lokakuuta 2014 9:35
To: [email-masked]
Subject: [MMUSIC] SCTP-SDP: Definition of protocol identifiers

Hi,

Thanks!

Regards,

Christer

---

From: "Schwarz, Albrecht (Albrecht)" <[email-masked]>
Date: Wed, 29 Oct 2014 10:45:36 +0000

Would be also interested to get that doc which desribes DTLS usage over TCP (as opposed to the native approch of TLS over TCP).
Because there would be actually DTLS*/TCP vs DTLS/UDP, i.e., DTLS* represents a specific configuration of the DTLS protocol (by e.g. disabling mechanism wrt unreliable L4 protocols).

I guess that there will be finally a reference to RFC 6544 / RFC 4571, i.e. an indirect reference.
If RFC 4571 would be that reference, then there would/should be two protocol identifiers:
a) DTLS/Shim/TCP (RFC 4571 Shim header) and
b) DTLS/TCP

in my understanding.

Side note: draft-ietf-rtcweb-transports should provide more detailed information for the option of TCP-based WebRTC traffic transport.

Regards,
Albrecht

From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Mittwoch, 29. Oktober 2014 08:41
To: [email-masked]
Subject: Re: [MMUSIC] SCTP-SDP: Definition of protocol identifiers

Regards,

Christer

From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 29. lokakuuta 2014 9:35
To: [email-masked]<mailto:[email-masked]>
Subject: [MMUSIC] SCTP-SDP: Definition of protocol identifiers

Hi,

Thanks!

Regards,

Christer