Subject: [MMUSIC] draft-ietf-mmusic-data-channel-sdpneg-01: dcsa attribute definition

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Thu, 26 Mar 2015 23:57:51 +0000

For the dcsa attribute the ABNF text currently states:

"
   Syntax:

   dcsa-value      = stream-id SP attribute
   attribute       = <from-RFC4566>
"

We had a concern that this might imply that only the attributes defined in RFC 4566 are appropriate.

Our proposal in the meeting was not supported, because the above is in fact correct, the ABNF for attributes is wholely defined in RFC 4566.

Perhaps the solution is to add some additional text after the above ABNF (leaving the ABNF unchanged) as follows:

"Note that the above reference to RFC 4566 defines were he attribute definition can be found; it does not provide any limitation on support of attributes defined in other documents in accordance with this attribute definition."

Is this proposal acceptable.

Regards

Keith

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 27 Mar 2015 09:49:36 -0400

This WFM.
It wouldn't hurt to refer to the IANA registry as a place where 
attribute definitions might be found. Also maybe a note that not all 
attributes are suitable for use this way.

	Thanks,
	Paul

On 3/26/15 7:57 PM, DRAGE, Keith (Keith) wrote:
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>

---

From: Jonathan Lennox <[email-masked]>
Date: Fri, 27 Mar 2015 14:22:22 +0000

> Is this proposal acceptable.

This sounds good to me.