Subject: [MMUSIC] Review of 4566bis

From: Christer Holmberg <[email-masked]>
Date: Sun, 31 May 2015 13:38:19 +0000

Hi,

Below is my review of the 4566bis-14 document.

General:
------------

QG_1:

There has been some discussions on the list whether we should remove some of the attributes which are either semantically unclear and/or nobody is using.

QG_2:

I think the draft should be checked for consistent terminology. For example, sometimes "SDP session description" is used, and sometimes only "session description".

QG_3:

The "Session Announcement Protocol" enhancement is needed only within the first occurrence. After that "SAP" is enough.

Section 4.1:
---------------

Q4-1_1:

s/the transport protocol/the media transport protocol

Section 4.3:
---------------

Q4-3_1:

My suggestion would be to remove the whole section. I can't remember any discussion where one would have used private vs public sessions. The Security Considerations should then cover encryption etc of SDP information.

Section 4.4:
---------------

Q4-4_1:

The text says:

"A session description should convey enough information to decide whether or not to participate in a session."

I don't think that is true - at least not when SDP is used together with a protocol like SIP. SDP describes the media associated with the session - but there are many other properties which are used to determined whether to participate in a session.

Section 5.2:
----------------

Q5-2_1:

The text says that the o= line contains the address of the host.

But, we've had discussions about not providing the host address once the initial SDP offer is sent, so I wonder whether some relaxing text would be needed here.

Section 5.4:
---------------

The text says:

"There MUST be at most one session-level "i=" field per session description, and at most one "i=" field per media."

...and later:

"A single "i=" field MAY also be used for each media definition."

Q5-4_1:

In the first sentence, I guess it should say "field per media description/definition"?

Q5-4_2:

Is the second sentence really needed? What is the difference from the first sentence?

Q5-4_3:

Similar to e.g. the "c=" line, I guess it would be useful to say that, unless an media level "i=" line is defined, the session level "i=" line applies to that media description.

Section 5.5:
---------------

Q5-5_1:

The text says:

"...but if it is present it MUST be specified before the first media field."

Is that text needed? Session level attributes are always specified before the first media field, aren't they?

Section 5.6:
---------------

Q5-6_1:

The text says:

"Note that the previous version of SDP specified that either an email field or a phone field MUST be specified, but this was widely ignored. The change brings the specification into line with common usage."

In my opinion, any reference to the previous version of SDP, and the justification for change, should be covered in section 10, only in section 10, and nowhere else but in section 10 :)

Q5-6_2:

The text, talking about the name of the person, says:

"This MUST be enclosed in parentheses if it is present."

But, then, when the text talk about the name quoting convention, the name is given without enclosed parentheses.

So, I think some re-wording would be needed.

Section 6:
-------------

Q6_1:

In some of the sub-sections, there is text saying:

"This can be a session-level attribute or a media-level attribute."

I think such text can be removed, as it is already indicated in "Usage level".

Q6_2:

In some of the sub-sections, it is indicated that a media-level attribute value overrides a session-level attribute value. As far as I know, that applies to all attributes (that can be present both on the session-level and media-level), so there should be a generic statement about that.

This is similar to the comment on the c= line.

Section 6.7:
---------------

Q6-7_1:

The text says:

   "If any one of these appears in a media section then it applies for
   that media section.  If none appear in a media section then the one
   from session level, if any, applies to that media section."

There should be a general statement in the draft about session level information applying to the media level.

Section 6.7.4:
-----------------

Q6-7-4_1:

The text says:

"Note that an RTP-based system SHOULD still send RTCP, even if started inactive."

It should be clarified that this applies if RTCP is used to begin with.

Also, is there a reason why we couldn't use MUST instead of SHOULD?

Section 6.11:
-----------------

The text says that the attribute "specifies the language" of the session description.

There has been some confusion about what that really means, so I think it would be good to clarify that it applies to any textual information that may be provided within the description.

It would also be good to explicitly indicate that the attribute is not related to languages used in the actual media streams.

Section 6.12:
-----------------

The text says:

"...., in which case the order of the attributes indicates the order of importance of the various languages in the session or media, from most important to least important."

First, I thought that attribute order has no meaning.

Second, what does "importance of the various languages" really mean? The language is what it is, and the participants decide what is important.

Section 8.2.3:
------------------

The text says:

"Formats cover all the possible encodings that might want to be transported in a multimedia session."

Q8-2-3_1:

I think the "might want to be transported" is confusion, and needs to be re-written.

Q8-2-3_2:

The fmt does not contain the complete list for the session - only the list for the associated media description.

Regards,

Christer

---

From: Paul Kyzivat <[email-masked]>
Date: Sun, 31 May 2015 13:43:29 -0400

On 5/31/15 9:38 AM, Christer Holmberg wrote:

Good list Christer!

I have comments on a few of your issues:

> Q6_2:
>
> In some of the sub-sections, it is indicated that a media-level
> attribute value overrides a session-level attribute value. As far as I
> know, that applies to all attributes (that can be present both on the
> session-level and media-level), so there should be a generic statement
> about that.
>

I used to think this, but I think there are some exceptions. (But I 
don't offhand remember what they are.)

> Section 6.7:
>
> ---------------
>
> Q6-7_1:
>
> The text says:
>
>     “If any one of these appears in a media section then it applies for
>
>     from session level, if any, applies to that media section.”
>

I wish there could be a general statement, but it is hard, given 
exceptions. Perhaps there could be a general statement with note that it 
can be overridden in particular cases.

But in any case, *this* is different, because it says that the presence 
of any *one* of four different attributes at media level overrides the 
presence of any one of those four at session level.

> Section 6.11:
>
> -----------------
>
> The text says that the attribute “specifies the language” of the session
> description.
>
> There has been some confusion about what that really means, so I think
> it would be good to clarify that it applies to any textual information
> that may be provided within the description.
>
> It would also be good to explicitly indicate that the attribute is not
> related to languages used in the actual media streams.

+1

	Thanks,
	Paul