Subject: [MMUSIC] The MMUSIC WG has placed draft-hutton-mmusic-opportunistic-negotiation in state "Call For Adoption By WG Issued"

From: IETF Secretariat <[email-masked]>
Date: Tue, 09 May 2017 02:44:22 -0700

The MMUSIC WG has placed draft-hutton-mmusic-opportunistic-negotiation in
state 
Call For Adoption By WG Issued (entered by Bo Burman)

The document is available at
https://datatracker.ietf.org/doc/draft-hutton-mmusic-opportunistic-negotiation/

Comment:
Based on the feedback we received at the IETF 98 meeting in Chicago, it
seems there is strong consensus for adopting this draft in MMUSIC.

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 9 May 2017 11:08:15 -0400

> seems there is strong consensus for adopting this draft in MMUSIC.

I don't understand why both this draft and draft-ietf-sipbrandy-osrtp 
are needed. Wouldn't one draft do?

	Thanks,
	Paul

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Tue, 9 May 2017 17:13:08 +0000

SIPBRANDY WG is not chartered to produce PS specs, which the original draft (draft-ietf-sipbrandy-osrtp) would have been since it was updating a current PS. The WG made the decision (vetted by AD and IESG) to not re-charter and instead decided split off the piece that updates a PS into a new PS (draft-hutton-mmusic-opportunistic-negotiation).

-G

> On May 9, 2017, at 11:08 AM, Paul Kyzivat <[email-masked]> wrote:
> 
> I don't understand why both this draft and draft-ietf-sipbrandy-osrtp are needed. Wouldn't one draft do?
> 
> 	Thanks,
> 	Paul
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 9 May 2017 13:28:36 -0400

> SIPBRANDY WG is not chartered to produce PS specs, which the original draft (draft-ietf-sipbrandy-osrtp) would have been since it was updating a current PS. The WG made the decision (vetted by AD a…

OK. But then couldn't everything be put into the MMUSIC document?
ISTM that given the limited content in these documents that splitting it 
into two, with a lot of overlap, is confusing.

	Thanks,
	Paul

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Tue, 9 May 2017 17:35:39 +0000

> On May 9, 2017, at 1:28 PM, Paul Kyzivat <[email-masked]> wrote:
> 
> ISTM that given the limited content in these documents that splitting it into two, with a lot of overlap, is confusing.

I see your point but Currently SIPBRANDY is chartered to produce Opportunistic SRTP as a BCP. There is also a milestone to inform MMUSIC or other appropriate WGs of any changes needed to support Opportunistic SRTP (Not expected to be published as an RFC).  I think SIPBRANDY is just carrying out what they are chartered to do.

-G

---

From: Andy Hutton <[email-masked]>
Date: Mon, 15 May 2017 13:48:06 +0100

> I see your point but Currently SIPBRANDY is chartered to produce Opportunistic SRTP as a BCP. There is also a milestone to inform MMUSIC or other appropriate WGs of any changes needed to support Op…

Agree this is largely procedural we started the work in SIPBrandy and
then realised we needed to update RFC 4568 so were forced to go to
MMUSIC to do that. The tidy thing to do now is just finish what we
started in both MMUSIC and SIPBrandy.

Andy

---

From: Flemming Andreasen <[email-masked]>
Date: Fri, 19 May 2017 09:19:50 -0400

Hi Paul

Does this satisfy any concerns you may have had with taking on this work 
and adopting the draft as a WG item ?

Thanks

-- Flemming (as MMUSIC co-chair)

On 5/15/17 8:48 AM, Andy Hutton wrote:
> .

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 19 May 2017 10:10:00 -0400

> and adopting the draft as a WG item ?

I still think this is just a silly artifact of the organizational 
structure. But it doesn't matter much so I have no objection to moving 
forward as-is.

	Thanks,
	Paul

>>>>> SIPBRANDY WG is not chartered to produce PS specs, which the
>>>>> original draft (draft-ietf-sipbrandy-osrtp) would have been since
>>>>> it was updating a current PS. The WG made the decision (vetted by
>>>>> AD and IESG) to not re-charter and instead decided split off the
>>>>> piece that updates a PS into a new PS
>>>>> (draft-hutton-mmusic-opportunistic-negotiation).
>>>> ISTM that given the limited content in these documents that
>>>> splitting it into two, with a lot of overlap, is confusing.
>>> I see your point but Currently SIPBRANDY is chartered to produce
>>> Opportunistic SRTP as a BCP. There is also a milestone to inform
>>> MMUSIC or other appropriate WGs of any changes needed to support
>>> Opportunistic SRTP (Not expected to be published as an RFC).  I think
>>> SIPBRANDY is just carrying out what they are chartered to do.
>>>

---

From: Andy Hutton <[email-masked]>
Date: Wed, 24 May 2017 17:17:21 +0100

Are we good to go and submit the mmusic draft then?

I don't disagree with Paul it is just an artifact of the
organisational structure but this is what SIPBrandy WG, AD's, and
Chairs decided and it has taken far to long already. Lets press ahead
and get it done.

Andy

On Fri, May 19, 2017 at 3:10 PM, Paul Kyzivat <[email-masked]> wrote:
> I still think this is just a silly artifact of the organizational structure.
> But it doesn't matter much so I have no objection to moving forward as-is.
>
>         Thanks,
>         Paul
>
>
>> Thanks
>>