Subject: Re: [MMUSIC] BUNDLE: Pull request to introduce tagged m= section

From: Christer Holmberg <[email-masked]>
Date: Fri, 27 Apr 2018 13:29:50 +0000

Hi,

I have added more changes to the pull request. Basically, the whole SDP Offer/Answer section has now been modified.

I would like people to take a look at the changes. In case it’s difficult to read the text in GitHub, you can download the XML and generate a text version (I have verified that xml2rfc works).

Regards,

Christer

From: mmusic <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Thursday 26 April 2018 at 21:15
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Ben Campbell <[email-masked]<mailto:[email-masked]>>, Eric Rescorla <[email-masked]<mailto:[email-masked]>>
Subject: [MMUSIC] BUNDLE: Pull request to introduce tagged m= section

Hi,

I have put together a pull request, where I start to suggest how to introduce the tagged m= section concept into BUNDLE, and to include more text on how SDP attributes are included in BUNDLE groups.

https://github.com/cdh4u/draft-sdp-bundle/pull/59

Note that there is still work to do, and even the changes I have already done probably need some fine tuning and spell correction.

At this point I would like to know whether people (in particular Ekr – but also others) are ok with the approach in general.

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 27 Apr 2018 18:22:06 +0000

New commit with updated ICE Considerations.

Regards,

Christer

From: Christer Holmberg
Sent: 27 April 2018 15:30
To: Christer Holmberg <[email-masked]>; [email-masked]; [email-masked]; Ben Campbell <[email-masked]>; Eric Rescorla ([email-masked]) <[email-masked]>
Subject: Re: [MMUSIC] BUNDLE: Pull request to introduce tagged m= section

Hi,

I would like people to take a look at the changes. In case it's difficult to read the text in GitHub, you can download the XML and generate a text version (I have verified that xml2rfc works).

Regards,

Christer

Hi,

At this point I would like to know whether people (in particular Ekr - but also others) are ok with the approach in general.

Regards,

Christer

---

From: Taylor Brandstetter <[email-masked]>
Date: Fri, 27 Apr 2018 11:43:29 -0700

I'm happy with this approach in general; I believe it resolves the concerns
I had related to trickle ICE when used with BUNDLE (where "unique address"
may not be meaningful, since every m= section may have an address of "
0.0.0.0:9").

For some more context, see:
https://github.com/w3c/webrtc-pc/issues/1563#issuecomment-385051864

On Fri, Apr 27, 2018 at 11:22 AM, Christer Holmberg <
[email-masked]> wrote:

> *From:* Christer Holmberg
> *Sent:* 27 April 2018 15:30
> *To:* Christer Holmberg <[email-masked]>; [email-masked];
> [email-masked]; Ben Campbell <[email-masked]>; Eric Rescorla (
> [email-masked]) <[email-masked]>
> *Subject:* Re: [MMUSIC] BUNDLE: Pull request to introduce tagged m=
> section
>
>
>
> Hi,
>
>
>
> I have added more changes to the pull request. Basically, the whole SDP
> Offer/Answer section has now been modified.
>
>
>
> I would like people to take a look at the changes. In case it’s difficult
> to read the text in GitHub, you can download the XML and generate a text
> version (I have verified that xml2rfc works).
>
>
>
> Regards,
>
>
>
> Christer
>
>
>
> *From: *mmusic <[email-masked]> on behalf of Christer Holmberg <
> [email-masked]>
> *Date: *Thursday 26 April 2018 at 21:15
> *To: *"[email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>, Ben Campbell <[email-masked]>, Eric Rescorla <
> [email-masked]>
> *Subject: *[MMUSIC] BUNDLE: Pull request to introduce tagged m= section
>
>
>
> Hi,
>
>
>
> I have put together a pull request, where I start to suggest how to
> introduce the tagged m= section concept into BUNDLE, and to include more
> text on how SDP attributes are included in BUNDLE groups.
>
>
>
> Note that there is still work to do, and even the changes I have already
> done probably need some fine tuning and spell correction.
>
>
>
> At this point I would like to know whether people (in particular Ekr – but
> also others) are ok with the approach in general.
>
>
>
> Regards,
>
>
>
> Christer
>
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic
>
>

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 27 Apr 2018 18:53:44 +0000

Hi,

My assumption is that, even with trickle ICE, in the initial offer you would still assign a zero port value to bundle-only m= sections, and once the BUNDLE group has been negotiated would assign a zero port value to all bundled m= sections except the tagged m= sections. Only the tagged m= sections would contain the nine port value (until the host candidate port is eventually assigned to the m= section).

Regards,

Christer

From: Taylor Brandstetter [mailto:[email-masked]]
Sent: 27 April 2018 20:43
To: Christer Holmberg <[email-masked]>
Cc: [email-masked]; [email-masked]; Ben Campbell <[email-masked]>; Eric Rescorla ([email-masked]) <[email-masked]>
Subject: Re: [MMUSIC] BUNDLE: Pull request to introduce tagged m= section

I'm happy with this approach in general; I believe it resolves the concerns I had related to trickle ICE when used with BUNDLE (where "unique address" may not be meaningful, since every m= section may have an address of "0.0.0.0:9<http://0.0.0.0:9>").

For some more context, see: https://github.com/w3c/webrtc-pc/issues/1563#issuecomment-385051864

On Fri, Apr 27, 2018 at 11:22 AM, Christer Holmberg <[email-masked]<mailto:[email-masked]>> wrote:
New commit with updated ICE Considerations.

Regards,

Christer

From: Christer Holmberg
Sent: 27 April 2018 15:30
To: Christer Holmberg <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Ben Campbell <[email-masked]<mailto:[email-masked]>>; Eric Rescorla ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [MMUSIC] BUNDLE: Pull request to introduce tagged m= section

Hi,

Regards,

Christer

Hi,

Regards,

Christer

_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mmusic

---

From: Christer Holmberg <[email-masked]>
Date: Sun, 29 Apr 2018 20:38:59 +0000

Hi,

I have now gone through the whole BUNDLE document, and modified the parts that I think need to be modified.

I would encourage anyone who is interested in BUNDLE to take a look at the pull request (or download the XML and generate a text document), because there have been quite a bit of changes. The good part is that most of the O/A procedures in the document have been simplified.

I'd also like to chairs to give some guidance on how to move forward. Do we need yet another WGLC? Etc.

Regards,

Christer

From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 27 April 2018 20:22
To: [email-masked]; [email-masked]; Ben Campbell <[email-masked]>; Eric Rescorla ([email-masked]) <[email-masked]>
Subject: Re: [MMUSIC] BUNDLE: Pull request to introduce tagged m= section

Regards,

Christer

From: Christer Holmberg

Hi,

Regards,

Christer

Hi,

Regards,

Christer

---

From: Flemming Andreasen <[email-masked]>
Date: Sun, 29 Apr 2018 17:38:12 -0400

On 4/29/18 4:38 PM, Christer Holmberg wrote:
> I would encourage anyone who is interested in BUNDLE to take a look at 
> the pull request (or download the XML and generate a text document), 
> because there have been quite a bit of changes. The good part is that 
> most of the O/A procedures in the document have been simplified.
>
> I’d also like to chairs to give some guidance on how to move forward. 
> Do we need yet another WGLC? Etc.
>
We need input from the WG in general on this, and in particular from 
Ekr, since he is the one that has been asking for a change here. Once we 
understand whether
a) this proposal addresses the concers and
b) the WG participants in general are in favor of it

then we can decide how to proceed.

Thanks

-- Flemming (as MMUSIC co-chair)

> Regards,
>
> Christer
>
> *From:*mmusic [mailto:[email-masked]] *On Behalf Of *Christer 
> Holmberg
> *Sent:* 27 April 2018 20:22
> *To:* [email-masked]; [email-masked]; Ben Campbell 
> <[email-masked]>; Eric Rescorla ([email-masked]) <[email-masked]>
> *From:*Christer Holmberg
> *To:* Christer Holmberg <[email-masked] 
> <mailto:[email-masked]>>; [email-masked] 
> <mailto:[email-masked]>; [email-masked] 
> <mailto:[email-masked]>; Ben Campbell <[email-masked] 
> <mailto:[email-masked]>>; Eric Rescorla ([email-masked] 
> <mailto:[email-masked]>) <[email-masked] <mailto:[email-masked]>>
> I have added more changes to the pull request. Basically, the whole 
> SDP Offer/Answer section has now been modified.
>
> I would like people to take a look at the changes. In case it’s 
> difficult to read the text in GitHub, you can download the XML and 
> generate a text version (I have verified that xml2rfc works).
>
> Regards,
>
> Christer
>
> *From: *mmusic <[email-masked] 
> <mailto:[email-masked]>> on behalf of Christer Holmberg 
> <[email-masked] <mailto:[email-masked]>>
> *To: *"[email-masked] <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>, "[email-masked] 
> <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>, Ben Campbell <[email-masked] 
> <mailto:[email-masked]>>, Eric Rescorla <[email-masked] 
> <mailto:[email-masked]>>
> introduce the tagged m= section concept into BUNDLE, and to include 
> more text on how SDP attributes are included in BUNDLE groups.
>
> Note that there is still work to do, and even the changes I have 
> already done probably need some fine tuning and spell correction.
>
> At this point I would like to know whether people (in particular Ekr – 
> but also others) are ok with the approach in general.
>
> Regards,
>
> Christer
>

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 30 Apr 2018 09:57:51 +0000

Hi,

Ekr also had a comment on the Introduction section, that it is confusing to read.

I have tried to re-structure, and add some sub sections, in order to make it more clear. The changes can be seen in the same pull request.

Regards,

Christer

From: mmusic <[email-masked]<mailto:[email-masked]>> on behalf of Christer Holmberg <[email-masked]<mailto:[email-masked]>>
Date: Sunday 29 April 2018 at 23:38
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Ben Campbell <[email-masked]<mailto:[email-masked]>>, Eric Rescorla <[email-masked]<mailto:[email-masked]>>
Subject: Re: [MMUSIC] BUNDLE: Pull request to introduce tagged m= section

Hi,

I’d also like to chairs to give some guidance on how to move forward. Do we need yet another WGLC? Etc.

Regards,

Christer

From: mmusic [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: 27 April 2018 20:22
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Ben Campbell <[email-masked]<mailto:[email-masked]>>; Eric Rescorla ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [MMUSIC] BUNDLE: Pull request to introduce tagged m= section

Regards,

Christer

From: Christer Holmberg

Hi,

Regards,

Christer

Hi,

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 30 Apr 2018 12:08:49 +0000

Hi Flemming,
 
>> I would encourage anyone who is interested in BUNDLE to take a look at the pull 
>> request (or download the XML and generate a text document), because there have 
>> been quite a bit of changes. The good part is that most of the O/A procedures in the 
>> document have been simplified.
>
> We need input from the WG in general on this, and in particular from Ekr, since he is the one that has 
> been asking for a change here. Once we understand whether

I agree. I guess my questions are:

1) Do we assume that people will be able to comment based on the pull request (or, that people will download the XML and create a text version)? Or, do we need to submit a new "official" version of the draft? That needs to be clear, if e.g., someone is waiting for a new version to be submitted before giving comments.

2) What is the timeline for giving comments? I don't want to end up in a situation where nothing happens for weeks/months.

Regards,

Christer

 

Regards,
 
Christer
 
From: Christer Holmberg 
 
Hi,

 
Regards,
 
Christer
 
From: mmusic <[email-masked]> on behalf of Christer Holmberg <[email-masked]>
Date: Thursday 26 April 2018 at 21:15
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Ben Campbell <[email-masked]>, Eric Rescorla <[email-masked]>
Subject: [MMUSIC] BUNDLE: Pull request to introduce tagged m= section
 
Hi,

 

Regards,
 
Christer

---

From: Ben Campbell <[email-masked]>
Date: Mon, 30 Apr 2018 09:32:10 -0500

> On Apr 30, 2018, at 7:08 AM, Christer Holmberg <[email-masked]> wrote:
> 
> Hi Flemming,
> 

My preference is a new version, followed by a potentially abbreviated WGLC for just the changes. (I take Flemming’s comments to mean he thinks a WGLC.)

Ben.

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 30 Apr 2018 11:15:32 -0400

> My preference is a new version, followed by a potentially abbreviated WGLC for just the changes. (I take Flemming’s comments to mean he thinks a WGLC.)

+1

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 30 Apr 2018 15:23:52 +0000

Hi,
 
>>>> I would encourage anyone who is interested in BUNDLE to take a look 
>>>> at the pull request (or download the XML and generate a text 
>>>> document), because there have been quite a bit of changes. The good 
>>>> part is that most of the O/A procedures in the document have been simplified.
>>> 
>>> Ekr, since he is the one that has been asking for a change here. Once 
>>> we understand whether
>> 1) Do we assume that people will be able to comment based on the pull request (or, that 
>> people will download the XML and create a text version)? Or, do we need to submit a new 
>> "official" version of the draft? That needs to be clear, if e.g., someone is waiting for a new 
>> version to be submitted before giving comments.
>> 

Ok.

However, before I submit a new version I'd like Ekr to take a look at the pull request, and indicate whether it at least looks like what he has been asking for.

Again, the majority of the changes are related to the introduction of the "tagged m= section" concept, but e.g., the change to the Introduction section is mostly in order to re-structure and clarify.

Regards,

Christer

> To: [email-masked]; [email-masked]; Ben Campbell 
> To: Christer Holmberg <[email-masked]>; 
> [email-masked]; [email-masked]; Ben Campbell 
> To: "[email-masked]" <[email-masked]>, "[email-masked]" 
> <[email-masked]>, Ben Campbell <[email-masked]>, Eric 
> Rescorla <[email-masked]>

---

From: Flemming Andreasen <[email-masked]>
Date: Mon, 30 Apr 2018 16:10:20 -0400

> My preference is a new version, followed by a potentially abbreviated WGLC for just the changes. (I take Flemming’s comments to mean he thinks a WGLC.)
Most likely.

-- Flemming