Subject: [MMUSIC] I-D Action: draft-ietf-mmusic-trickle-ice-sip-16.txt

From: [email-masked]
Date: Thu, 07 Jun 2018 12:43:38 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Multiparty Multimedia Session Control WG of the IETF.

        Title           : A Session Initiation Protocol (SIP) Usage for Incremental Provisioning of Candidates for the Interactive Connectivity Establishment (Trickle ICE)
        Authors         : Emil Ivov
                          Thomas Stach
                          Enrico Marocco
                          Christer Holmberg
	Filename        : draft-ietf-mmusic-trickle-ice-sip-16.txt
	Pages           : 47
	Date            : 2018-06-07

Abstract:
   The Interactive Connectivity Establishment (ICE) protocol describes a
   Network Address Translator (NAT) traversal mechanism for UDP-based
   multimedia sessions established with the Offer/Answer model.  The ICE
   extension for Incremental Provisioning of Candidates (Trickle ICE)
   defines a mechanism that allows ICE Agents to shorten session
   establishment delays by making the candidate gathering and
   connectivity checking phases of ICE non-blocking and by executing
   them in parallel.

   This document defines usage semantics for Trickle ICE with the
   Session Initiation Protocol (SIP), defines a new SIP Info Package to
   support this usage together with the corresponding media type, SDP
   attribute and SIP option tag.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mmusic-trickle-ice-sip/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-mmusic-trickle-ice-sip-16
https://datatracker.ietf.org/doc/html/draft-ietf-mmusic-trickle-ice-sip-16

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-mmusic-trickle-ice-sip-16

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Ben Campbell <[email-masked]>
Date: Fri, 15 Jun 2018 16:27:43 -0500

Hi,

A few minor editorial comments on the changes:

- Abstract: The updated 2nd paragraph doesn’t parse. There’s at least one missing conjunction.

- §4.3.2: "
The first case could happen when Half Trickle is used and all candidate were  already in the initial offer.  The second case could happen when Full Trickle is used and the offerer is currently gathering additional candidates, but did not yet get them.  Also, if the initial Offer did not contain any candidates, depending on how the Offerer gathers its candidates and how long it takes to do so, this INFO could still contain no candidates.”

Inconsistent verb tense (e.g. “Half Trickle _is_ used and all candidates _were_ already in the initial offer”)

- §4.4, new text: Run-on sentence. Also, is “pseudo m= lines” the antecedent of “it” in “It is linked…”? If so, “lines” and “it” have plural/singular disagreement. (I suggest “lines/they” or “line/it”)

Thanks!

Ben.

> On Jun 7, 2018, at 2:43 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic