Subject: Re: [MMUSIC] AD Evaluation of draft-ietf-mmusic-data-channel-sdpneg-20

From: Ben Campbell <[email-masked]>
Date: Mon, 26 Nov 2018 16:32:16 -0600

Hi,

Version 22 resolves most, but not all of my comments. I’ve copied the unaddressed comments below for reference. It may be that people disagree with my comments or suggestions, but if so please tell me so we can discuss :-)

> On Aug 27, 2018, at 10:06 PM, Ben Campbell <[email-masked]> wrote:
> 

[...]

> Substantive Comments:
> 
> - There are 6 authors listed. Normally the limit is 5 unless there is a really good reason. Did all of the authors contribute substantial text? Could the author list be reduced to just editors, and have the rest in a “contributors” section?

Please note that, unless I can offer a really good reason why this needs more than 5 authors, this issue is almost certain to generate one or more DISCUSS positions during IESG evaluation.

[...]

> §8: I am skeptical that this adds no security considerations above those in sctp-sdp. In particular, it seems worth mentioning that each subprotocol may come with it’s own security considerations that need to be documented as part of the subprotocol definition. (As an example, MSRP has security considerations about the URL used in the a=path attribute that would apply to any definition of the use of “path” at the dcsa level.)

[...]

> 
> §9.1: What is the rational for sharing the websocket subprotocol registry rather than creating a new one for data channels? The websocket subprotocol name registry has a policy of “First Come First Served”. This draft seems to state requirements for subprotocol specifications, but FCFS does not require specifications.
> 

[...]

> Editorial Comments:
> 
> - Abstract: The abstract will not age well. Years from now, no one will think in terms of what RTCWeb vs some other working group defined. I suggest recasting this in terms of the documents and protocols, not the working groups.  (Comment repeats for introduction.)
> 

[...]

> 
> §9.3, first paragraph: " SDP attributes that are defined for use at the dcsa
>   usage level only SHALL use the dcsa usage level when registering the
>   attribute.”
> 
> I don’t understand this sentence. Consider a MUST NOT/SHALL NOT construction.
>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 27 Nov 2018 14:40:56 -0500

>> §9.1: What is the rational for sharing the websocket subprotocol registry rather than creating a new one for data channels? The websocket subprotocol name registry has a policy of “First Come Firs…

IIRC this choice was made by the rtcweb wg. I don't recall how it was made.

It is my impression there is an expectation that many websocket 
protocols could also be used over data channels in order to get 
multiplexing of the socket.

	Thanks,
	Paul

---

From: Ben Campbell <[email-masked]>
Date: Tue, 27 Nov 2018 16:52:54 -0600

> On Nov 27, 2018, at 1:40 PM, Paul Kyzivat <[email-masked]> wrote:
> 
> It is my impression there is an expectation that many websocket protocols could also be used over data channels in order to get multiplexing of the socket.

I can accept that the reason might be “because that was what the WG wanted”, but isn’t there still a mismatch with the registration policy? This draft seems to expect subprotocol specifications -- is FCFS acceptable?

> 
> 	Thanks,
> 	Paul
> 
> _______________________________________________
> mmusic mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mmusic