Subject: Re: [MOBILE-IP] Macro mobility vs. Micro mobility..

From: Yingchun Xu <[email-masked]>
Date: Fri, 22 Oct 1999 04:45:44 -0500

You are describing the methods for handling these two different types of
mobility managements. Micromobility management is really for local or regional
mobility management which is limited to regional access network. While macro
mobility management is really at internetworking layer across multiple access
networks.

---Yingchun.

Wolfgang Sch

önfeld <[email-masked]> on 10/22/99 03:35:21 AM

Please respond to Wolfgang Schönfeld <[email-masked]>

Sent by:  Wolfgang Schönfeld <[email-masked]>

To:   [email-masked]
cc:    (Yingchun Xu/MW/US/3Com)
Subject:  Re: [MOBILE-IP] Macro mobility vs. Micro mobility..

Jinsuh Shin wrote:

> Hi, all
>
> What is major difference of Macro mobility management and Micro mobility
management??
> I couldn't understand these difference well..
> So, please somebody help me to understand these difference..

Let me start by mentioning that IP addresses
are topologically significant. This means that,
when a host moves, some routes become obsolete,
i.e. addresses in packets become inconsistent with routing tables.

One may change either of the two:
Mobile IP changes the addresses (by encapsulation),
and this is usually called "Macro mobility management".
The complementary method, i.e. changing routing tables,
is called "Micro mobility management".

These notions come from a commonly accepted opinion:
Changing addresses (by encapsulation) is appropriate for handling MACRO
mobility,
i.e. when the mobile host traverses a long distance (in the Internet topology).
Routing table update is appropriate for handling MICRO mobility,
e.g. when the host moves to a neighboring network.

To summarize, the notions you are questioning
are - unfortunately - chosen as to describe the desired EFFECTS,
not the PRINCIPLES of these methods.
This may explain misunderstandings.

--
Wolfgang Schoenfeld
GMD-IPSI, Dolivostr. 15, Room 118, D-64293 Darmstadt
+49-6151-869-865 (Phone), -818 (FAX)
+49-170-2285450 (Mobile Phone)

---

From: Wolfgang Schönfeld <[email-masked]>
Date: Fri, 22 Oct 1999 14:21:35 +0200

> mobility management is really at internetworking layer across multiple access

You are right, my formulation was not precise.
Here is a new attempt (it is also a little bit shorter):

Since IP addresses are topologically significant,
some routes may become obsolete when a host moves,
i.e. addresses in packets do not fit to routing table entries.

It is commonly accepted
that this mobility problem should be divided into
1. one of "micro mobility",
    i.e. if mobile hosts traverse small (in the Internet topology) distances,
    e.g. within a bounded region,
2. one of "macro mobility", i.e. if they traverse larger distances
    within the internet.
Hence the naming "macro" resp. "micro mobility management".

The following techniques to handle these  problems are discussed:
- change routing tables
- change addresses (e.g. by encapsulation as in Mobile IP)
There is a common understanding that
- changing routing tables can solve 1.
- changing addresses can solve 2.