Subject: [MOBILE-IP] Macro mobility vs. Micro mobility..

From: Jinsuh Shin <[email-masked]>
Date: Fri, 22 Oct 1999 09:21:06 +0900

Hi, all

What is major difference of Macro mobility management and Micro mobility management??
I couldn't understand these difference well..
So, please somebody help me to understand these difference..

Thank you in advance..
jinsuh/

=================================================
Jinsuh Shin [[email-masked]]
                  1F Keopyung B-Town, 203,
                  Nonhyun-dong, Kangnam-gu,
                  Seoul, 135-010, Korea

                  TEL)  +82-2-3446-8119 [Ext. 361]
                  FAX)  +82-2-3446-8269
=================================================

---

From: Wolfgang Schönfeld <[email-masked]>
Date: Fri, 22 Oct 1999 10:35:21 +0200

> So, please somebody help me to understand these difference..

Let me start by mentioning that IP addresses
are topologically significant. This means that,
when a host moves, some routes become obsolete,
i.e. addresses in packets become inconsistent with routing tables.

One may change either of the two:
Mobile IP changes the addresses (by encapsulation),
and this is usually called "Macro mobility management".
The complementary method, i.e. changing routing tables,
is called "Micro mobility management".

These notions come from a commonly accepted opinion:
Changing addresses (by encapsulation) is appropriate for handling MACRO mobility,
i.e. when the mobile host traverses a long distance (in the Internet topology).
Routing table update is appropriate for handling MICRO mobility,
e.g. when the host moves to a neighboring network.

To summarize, the notions you are questioning
are - unfortunately - chosen as to describe the desired EFFECTS,
not the PRINCIPLES of these methods.
This may explain misunderstandings.

--
Wolfgang Schoenfeld
GMD-IPSI, Dolivostr. 15, Room 118, D-64293 Darmstadt
+49-6151-869-865 (Phone), -818 (FAX)
+49-170-2285450 (Mobile Phone)