Subject: Re: [MOBILE-IP] Lack of User privacy - IS it a security problem ?

From: Raja Narayanan <[email-masked]>
Date: Fri, 15 Oct 1999 14:27:21 -0500

Hello,

To perhaps take a stab at paraphrasing opinions/comments:-

1.) While it is important not to hold up current work, it is desirous to
protect user confidentiality in the future. This may very well translate
into having to encrypt the user NAI.
2.) The above would result in somehow having to transmit the 'home domain'
info to the FA.

While it is somewhat clear how the confidentiality is maintained within the
existing current cellular networks [the visiting networks are trusted], MIP
implementations will span a whole bunch of heteregenous access networks. In
this context, the visited FA may or may not be trusted and therefore there
needs to an option for the mobile/nomadic user to be guaranteed privacy.

Do we have consensus in the WG that we need to consider taking this in as an
additional requirement into 'Mobile IP requirement for AAA'.

--Raja
Nortel Networks

-----Original Message-----
From: Patrice Calhoun [mailto:[email-masked]]
Sent: Friday, October 15, 1999 12:24 PM
To: [email-masked]
Subject: Re: [MOBILE-IP] Lack of User privacy - IS it a security problem
?

Because routing of AAA packets using an NAI is a well known problem and
is already deployed. Routing of AAA packets using IMSI is *very* specific
to Mobile-IP for cellular networks (read: no other service uses IMSI), and
does not currently have any solution/deployment.

Lastly, if Mobile-IP is run over an etherhet link, 802.11, etc. you would
end up having to using something other than IMSI. Presumably the NAI.

PatC
>
>
>> -----Original Message-----
>> From: Patrice Calhoun [mailto:[email-masked]]
>> Sent: Friday, October 15, 1999 4:38 PM
>> To: [email-masked]
>> Subject: Re: [MOBILE-IP] Lack of User privacy - IS it a
>> security problem
>> ?
>>
>>
>> This was my point all along. An NAI can be as cryptic as an IMSI.
>
>So why use it, when there is a widespread usage of IMSI?
>
>-- Thomas
>
>>
>> PatC
>> >Can anyone be bothered to explain to me why an NAI like
>> >[email-masked] is preferable to [email-masked]? Using
>> the latter
>> >masks the MNs identity from the foreign network (unless there is some
>> >collusion between the foreign network and the home network
>> to associate
>> >number and name). This solution seems to me to be trivial to
>> implement
>> >and probably sufficient to persuade most users (i.e. all but the
>> >ultra-paranoid) that their privacy is protected.
>> >
>> >Mat.
>> >
>> >Emad Qaddoura wrote:
>> >>
>> >> > -----Original Message-----
>> >> > From: n. asokan [mailto:[email-masked]]
>> >> > Sent: Thursday, October 14, 1999 12:28 AM
>> >> > To: [email-masked]
>> >> > Subject: Re: [MOBILE-IP] Lack of User privacy - IS it a
>> >> > security problem
>> >> > ?
>> >> >
>> >> >
>> >> [....]
>> >> >
>> >> > IMHO, privacy concerns are likely to become very
>> important.  At the
>> >> > least, proposed standards should not preclude later
>> applicability of
>> >> > privacy protecting mechanisms. I again suggest this for
>> consideration
>> >> > as an additional 'Mobile IP requirement for AAA'.
>> >>
>> >> I support the statement.
>> >>
>> >> >
>> >> > - Asokan
>> >> >
>> >> >
>> >> > ---
>> >> > N. Asokan, Communication Systems Lab, Nokia Research
>> Center, Helsinki
>> >> >
>>

---

From: Tom Weckström <[email-masked]>
Date: Sun, 17 Oct 1999 23:31:25 +0300

Hi,

> additional requirement into 'Mobile IP requirement for AAA'.

Yes, I support that new requirement.

I would formulate the requirement to something like this:
"Confidentiality of user's identity"

Furthermore, one short comment (which you probably already knew, but
still...):
 Making analogies between Mobile IP access networks and "traditional" 2G
(and 3G) Mobile telephony networks is a little bit hazardous - as we can
see from Raja's trust scheme above. The trust relationships are totally
different in centrally managed, nationwide, proprietary (or at least
"hard-to-clone") networks than in open, diversily maintained, even
chaotically spread access networks. (The most chaotic situation beeing
e.g. that every small boutique along a long street would have its own
privately administered Foreign Network.)

        Tom

--
        Tom Weckström           Dynamics group
                                Helsinki University of Technology
                                [email-masked]
                                http://www.cs.hut.fi/Research/Dynamics/