Subject: [MOBILE-IP] IPv6 Mobile Router again, for Multicast

From: Jiwoong Lee <[email-masked]>
Date: Mon, 5 Feb 2001 10:34:06 +0900

Note: This is the thirdly repeated message for ML server's erroneous processing.

I've browsed the previous discussion in this ML for IPv6 mobile router. Before resolving the unicast problem, MobileIPv6 ID-ver13 seems to block any possibility to support a IPv6 mobile multicast router. I'm not clear enough about this.  Anyone can give me some background explanation? 

Jiwoong.

Please refer:

Multicast packets addressed to a multicast address with link-local scope [9], to which the mobile node is subscribed, MUST NOT be tunneled to the mobile node; such packets SHOULD be silently discarded (after delivering to other local multicast recipients). (pp.68)

---

From: Thierry Ernst <[email-masked]>
Date: Mon, 5 Feb 2001 12:09:22 +0100

Hi Jiwoong,

I cannot reply about Multicast.

What is sure is that if there are some hosts connected to your Mobile
Router, they will never get any unicast packet.

A mobile router basically means a mobile network or mobile subnetwork
since a Router is usually serving a set of hosts.   All the set is
therefore moving together.   Only the Mobile Router ITSELF can receive
packets, not the other nodes in the mobile network.   The reasons are
better explained in my draft that you could find on the IETF web site
http://search.ietf.org/internet-drafts/draft-ernst-mobileip-v6-network-01.txt
(or alternatively on my web page together with my presentation made at
last IETF).

I would be happy to hear any comment from you concerning the multicast
issues.

Hope this helps,
Thierry.

--
* mailto:[email-masked]  Tel +33 (0) 4 76 61 52 69
* INRIA Rhone-Alpes Projet PLANETE       (fax 52 52)
* http://www.inrialpes.fr/planete/people/ernst/Welcome.html

---

From: Jiwoong Lee <[email-masked]>
Date: Tue, 6 Feb 2001 14:23:28 +0900

Thank you Thierry, 

I've read through your ID about IPv6 Mobile Router/Network. I'm thinking of Dynamic Prefix Assignment and Prefix Binding Update for IPv6 Mobile Network. I believe it will help to soothe some technical problems including multi-homing mobile networks, and multi-level mobile networks, flexible mobility of mobile nodes in a mobile network. By the way I have to confess I've not been seriously immersing myself in this topic as you have. 

Rather, I'd like to know the current intention of the authors of Mobile IPv6, in regard to my first question.

Jiwoong