Subject: [mobile-ip] Re: hmip and mobile routers

From: Thierry Ernst <[email-masked]>
Date: Mon, 05 Mar 2001 10:18:08 +0100

[Sorry if you received this email twice or more, but it didn't get
through the list, to my knowledge.  This is a last attempt, now that the
mobile-ip seems to (re)work]

Hi,

> Section 6 describes a mechanism of how mobile
> routers might be supported by HMIP. However, I
> think there is a fundamental category error being
> made here. Namely, it is expected that behind the
> mobile router are, in fact, mobile nodes.

I agree with this and this was already pointed out on this list between
48 and 49th IETF.

> reason why this expectation should be made: there
> is no reason why a non-mobile widget, say a PC,
> should not be able to be attached to a mobile
> router on a moving train. As currently defined,
> mobile IP is only a requirement if the device
> (router, host) is itself mobile. I do not see why
> we should expand that requirement to anything
> which is *behind* something that is mobile. In
> fact there could be a huge downsides to doing so,
> not to mention a whole lot of uncharted territory.

This question is addressed in my draft "Mobile Networks Support in
Mobile" IPv6
(http://search.ietf.org/internet-drafts/draft-ernst-mobileip-v6-network-01.txt).    

In this draft, the mobility of the network is completely transparent to
all nodes located in the mobile network.     Following your instance,
the train is a mobile network and the gateway between the train and the
Internet is a mobile router.    The Mobile Router obtains a new care-of
address at each new point of attachment to the Internet.    There are
basically 2 kinds of nodes in this mobile network:  permanently fixed
ones (TV screens, sensors, on-board computers, seats, ...) and mobile
ones.    Mobile ones may be composed of those belonging to the train
(the ticket-collector ?), and some entering and leaving the train
(Passengers, PDAs, Mobile Phones).

In this proposal, Passengers get a care-of address when they enter the
train (obvious), but they don't need to acquire a new care-of address
every time the train is reachable from a new care-of address.     IP
mobility of the network is therefore hidden to them.

I do see a benefit for Passengers to operate HMIP.   In this case, the
MAP would be located in the Mobile Router.

On the other hand, it also seems obvious to me that fixed nodes should
not operate HMIP.

> Also: what happens if there is more than one
> router in between MR and the stationary host
> in MR's subnet? What happens if there's more
> than one MR? What delineates "my" MR versus
> somebody else's MR?

See my draft as it does address Mobile Networks of arbitrary size (one
or more subnets)

> It's possible I'm misreading that section, but if
> I am it's probably because the section doesn't say
> what needs to happen when the mobile router itself
> moves. 

I agree with Mickael that the HMIP draft does not elaborate much about
this special case, but I must also advocate that it is not the object of
the HMIP draft to discuss about it.   As I see it, the HMIP draft only
outline one instance where HMIP could be used: mobile nodes visiting a
mobile network and I agree with this.   For the more general case
peculiar to mobile networks, I think that the debate turning around HMIP
should now be left out of this thread.

> However, even if nothing catastrophic
> happens, my original issue still stands:
> non-mobile hosts shouldn't be forced to become
> mobile aware by virtue of a mobile router some
> arbitrary number hops away.

As said before, this question is covered by my proposal in
draft-ernst-mobileip-v6-network-01.txt.    The mobility of the network
is transparent to all the nodes located in the mobile network.  The
Mobile Router is the only one that do manage mobility.   The Mobile
Router sends Binding Updates containing the prefix of the Mobile Network
in addtion to a care-of address.  See the draft for details.

May I have your comments on my draft ?

Thanks,
Thierry.

--
* mailto:[email-masked]  Tel +33 (0) 4 76 61 52 69 
* INRIA Rhone-Alpes Projet PLANETE       (fax 52 52) 
* MOTOROLA Labs Paris
* http://www.inrialpes.fr/planete/people/ernst/Welcome.html

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 8 Mar 2001 12:01:00 +0100

>  > 	=> There is no error in that. If they are not mobile 
>  > 	nodes then HMIPv6 does not solve that problem.
>  > 	Clearly there are two cases to consider, 
>  > 
>  > 	a) the nodes behind a router have (H)MIPv6 implementation
>  > 	b) They don't
> 
>    Yes, but they could just as easily be mobile nodes
>    behind mobile routers where the mobile router functions
>    as a home agent for those mobile nodes, ad infinitum.
>    I don't think that HMIP brings much special to that
>    situation: 
> 
	=> It brings the MAP entity which can offer you a COA.

> any place that you could put MIP, you
>    can also put HMIP, but that should go without saying.
> 
	=> This is a bit difficult to follow. But yes wherever
	you have MIP you MAY also have HMIP. 
	Should we stop saying that ? :)

>    In other words, this doesn't look any different
>    that multiple layers of hierarchy
> 
	=> That's the way it is for the MR case.

>    Case (b) is what I would consider to be the "mobile
>    router" problem.
> 
	=> One basic aim is to be reached via your HA and 
	another more ambitious one is to not have triangular
	routing. Two different issues and we address one of them.

>  > > As currently defined,
>  > 	=> What is the down side ? This is an unfinished
>  > 	statement. 
> 
>    Did you read the planet-earth-behind-a-mobile-
>    router question? 
> 
	=> No and even if I read these words they still
	need to be decrypted and put into MIP context.

>  > > > in MR's subnet? 
>  > 	=> The MAP option is propagated as usual.
>  > 
>  > > What happens if there's more
>  > > > than one MR? 
>  > > 
>  > 	=> What happens if there is more than one AR ?
> 
>    Well, that's easy. I forward packets to the first one,
>    and I immediately lose track of what happens from there on out.
>    In the layered ([H]MIP) case, it would seem that each mobile
>    might need to deal with binding updates to the
>    HA for each time a mobile router moves too. 
> 
	=> MIP requires that you update the HA when your CoA
	changes. This is not an HMIP problem. HMIP provides 
	the CoA that can be used for route optimised packets.
	If the MN doesn't want to use it, it doesn't have to
	and no updates to the HA are required when the MR moves.

>    If this isn't what you mean, it's probably
>    because the draft is unclear, and in either
>    case it would be good to clean in up to be
>    explicit with the interactions.
> 
	=> we can make it more detailed, but you should 
	read the latest verson first to see if it still needs 
	cleaning up. If so we're happy to clean up a bit more.

>  > 	=> The section says that the MAP (MR) sends a MAP
>  > 	option to the "mobile network" with its on link
>  > 	CoA (LCoA) as the MAP address. 
>  > 	Does it need more explanation ? We can add 
>  > 	more.
> 
>     What is the mobile network? What happens if
>     the mobile network in turn contains a mobile
>     router? 
> 
	=> A MR is a router obviously. It sends RAs
	that include the MAP option. Have you read
	the dynamic MAP discovery section ? It's 
	explained there.

> Is it a flood fill? 
	=> Please have a look at the section I mentioned
	above. Maybe the Extended mode doesn't repeat 
	the MAP discovery part, but it's there.

> What do the mobile
>     nodes need to do when a mobile router of a 
>     mobile router moves?
> 
	=> Get a new CoA, send BUs. Standard MIPv6

>  > 	=> Does the draft say that ? Please let us know 
>  > 	where it does so we can remove that assumption.
> 
>    The draft doesn't make a differentiation
>    between (a) and (b). 
> 
	=> Ok we can add something to show we only 
	support (a).

	Hesham

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 8 Mar 2001 23:08:53 +0100

Hello Behcet,

I mustn't be explaining this very well. 
I fully supprt Thierry's draft and think it is needed. 
HMIPv6 does NOT address the scenario mentioned 
in Thierry's draft. I hope it becomes a WG draft and 
get standardised soon. 

On the other hand I also fully support the Extended 
mode in HMIPv6 and think it's needed (obviously 
mobile networks in not the only reason for having it). 
As far as Mobile etworks are concerned, 
Thierry's draft does NOT address that scenario. 

Finally both Thierry's draft and HMIPv6 can co-exist as
they don't interfere with each other.

I hope I've done a better job in explaining myself.

Cheers,
Hesham

> -----Original Message-----
> From:	Behcet Sarikaya [SMTP:[email-masked]]
> Sent:	Friday, 9 March 2001 3:23
> To:	[email-masked]
> Subject:	Re: [mobile-ip] Re: hmip and mobile routers
> 
> Hesham and Michael,
>   My suggestion is to drop the part on mobile routers in
> hmipv6. This may clear the way for a separate RFC on mobile routers, probably based
> on Thierry's I-D. I think that the extended mode of hmipv6 could still stand.
> 
> --behcet << File: Card for Behcet Sarikaya >>