Subject: RE: [mobile-ip] AAA/QOS in MIP and SeaMoby

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 8 Mar 2001 23:17:03 +0100

> Why can't AAA server specific stuff be done somewhere else like say
> a AAA group?  Tying AAA specifically to a particular macromobility
> implementation seems like a very bad design approach to me.
> It seems like it is being done to placate particular vendors' interests
> to me.
> 
	=> I can't agree with you more. There is absolutely no need 
	for handling access control/AAA functions in this WG.
	Any node trying to access the Internet should be authorised
	to do so, regardless of whether it uses MIP or not. 
	In fact I'm strongly against doing this access authentication
	and authorisation functions in the MIP WG. 
	I do however think that the MIP WG MUST place the appropriate
	requirements on these functions and that was done. 

	Raj is running a BOF (BURP) in Minneapolis that looks 
	at the interface between a host and the network for AAA
	purposes. I think this is VERY important and that's where 
	the work should be done.

	Hesham

---

From: Patrice Calhoun <[email-masked]>
Date: Thu, 8 Mar 2001 14:17:56 -0800

>a AAA group? 

As far as I can tell, it is. The only thing that really happened in this
WG was to collect requirements. I think this WG was the right place to do
this.

> Tying AAA specifically to a particular macromobility

Again, when the AAA WG was rechartered, they looked at what the market was
looking for. At that time, Mobile IP had requirements for AAA, as did NASREQ.
That was the reason why the AAA WG concentrated on those two specific areas.
There are now other areas that have interest in AAA (e.g. SIP, DHCP, IPv6),
and this is NOT occuring in the AAA WG, but in the respective WG (as far as I
can tell). If another mobility solution gets created, and needs AAA, that WG
would be responsible for handling that task.

PatC