Subject: [mobile-ip] Re: [seamoby] Header compression context extablishment

From: James Kempf <[email-masked]>
Date: Thu, 22 Mar 2001 14:02:05 -0700

Mike,

Thanx for your response. Two questions.

>1) send a small number of IR packets with a header size roughly similar
>to the header size of uncompressed headers. I expect that most
>implementations will send roughly 3 IR packets.
>
>If operating in U-mode or O-mode, this completes the context
>initialization, and minimal packets will be sent henceforth.
>U-mode can do an exponential backoff when sending IR packets, 
>but the typical transition to O-mode or R-mode will prevent 
>those IR packets from being sent. 
>
>If operation in R-mode is desired, the minimal packets will be
>sent until an acknowledgment (containing a mode transition request)
>reaches the compressor. Then, 
>
>2) during an additional roundtrip, non-minimal headers are sent during
>transition to R-mode. 
>
>
>Some parameters are as follows:
>
>link roundtrip for cellular: 120-200 milliseconds.
>(6-10 packets at 50 packets per second).
>

Does the compressor have to start from scratch if the IP address in the
header changes? The issue here is that on a mobile IP handover, the
care of address will change. The mobile IP group is working hard
on low latency handover protocols. If the mobile node is forced to
go through a 120-200 ms compressor initialization period, the benefits
of low latency handoff will be substantially negated.

>Minimal headers are 1 byte. 
>
>Header size in 2) is rougly 4 bytes.
>
>The header sizes indicated above do not include context identifiers,
>which can be omitted completely for context identifier zero. 
>Nor do they include the two-byte UDP checksum, which will not be sent at
>all if disabled. Nor do they include the two byte IPv4 Identifier, 
>which will be sent as-is if it changes randomly. Reasonable IP stacks
>will have it change in increments of one, and then it will be 
>completely removed. 
>

Does this analysis change at all for IPv6? Most of our discussion
has been about IPv6 since the need for header compression is much
more urgent, due to the large header size.

			jak

---

From: James Kempf <[email-masked]>
Date: Thu, 22 Mar 2001 19:28:28 -0700

Michael,

Thanx for your reply.

>We need to talk about exact header formats before I can give
>an exact answer. The answer may be different for IPv4 and IPv6.
>

As we discussed, there will be a difference. For IPv4, the
compressor context will not include the care of address because
the Foreign Agent will strip the tunnel header before compressing. For IPv6,
co-located care-of addresses are implicitly assumed, so 
the care-of address will change.

>Your comment regarding low-latency handoff may be understood to 
>mean that you think that no packet can be sent during the initial 
>120-200 ms. 
>

OK, yes that was a concern, but it will just mean that the first
few packets are uncompressed and so slower. This makes the analysis a bit more
complex, but the upshot is that it would still mean a delay.

>Packets can be sent at any time, it is just that the first 3 are
>normal size packets, without significantly reduced size. After those
>three (or so), headers will be compressed. 
>
>I think we need to talk more. Are you available at 17.30 ?
>Let us meet in the lobby (street level) to talk. Is that 
>possible?
>

Right, as we discussed, I will attempt to locate some
IPv6 headers for you that illustrate the problem.

It would probably be good to co-ordinate between ROHC
and Seamoby context transfer design team so that
we can get this right, since our discussion in the
hotel lobby basically indicated that there may be
some tricky co-ordination issues between the mobile
node and the access router if the CoA header needs
to change.

		jak

---

From: Mikael Degermark <[email-masked]>
Date: Thu, 22 Mar 2001 14:52:16 -0700 (MST)

Hi James, 

Cheers,

Mikael Degermark