Subject: RE: [mobile-ip] FW: I-D ACTION:draft-malinen-mobileip-regreg6-01. txt

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 15 Mar 2001 20:48:40 +0100

> > Hello,
> > 
> > I still do not understand why the ability to place something at an arbitrary point justifies destroying the connectionless nature of a IP or even IP mobility.
> 
> Once we introduce an intermediary point (HA/RMA/MAP) with mobility bindings
> we introduce state used in a similar way as state used for maintaining
> plain next hop forwarding. 
> 
	=> The  next hop forwarding in the MAP depends on the routing 
	protocols in the domain. The next hop forwarding in Regional
	is forced (like a static route). There is a big difference. 
	You might ague that reg6 is part of MIP, hence can be 
	classified as a routing protocol, but I would say that 
	any routing protocol that reserves a "circuit-like" path
	in the IP network is not acceptable.

> I read your use of term connection-oriented to
> mean the use of mobility bindings for forwarding instead of exclusively relying on host/network/default routes. Introducing robustness
> in this form of forwarding is a problem both HMIP and regreg6 face.
> In fact, even basic Mobile IPv6 while forwarding packets via the
> home agent has this feature.
> 
	=> The robustness in terms of introducing a single point 
	of failure may be similar, but adding a less robust path
	to the MN from the GMA is not acceptable, and clearly 
	this is not just my opinion.

	Regards,
	Hesham

---

From: "Jari T. Malinen" <[email-masked]>
Date: Thu, 15 Mar 2001 19:01:17 -0800

>         in the IP network is not acceptable.

It is to be noted that in our current version you can use regular
tunneling or host-based routing (depending on whether you have 
next-hop as regreg-aware router) as well so there is no difference
other than having more than one possible levels of binding-based
forwarding points. Regional forwarding is an optimization not
in the base draft.

The protocol itself considers the basic signaling of using a
hierarchy, forming the hierarchy dynamically and maintaining it
in a way that a router failure can be bypassed is a matter for
a dynamic configuration protocol for the hierarchy. You said you
are working on such a thing for making MAPs not a single point of
failure. Is there some fundamental reason why such a protocol
is possible only for one level of hierarchy?

>         this is not just my opinion.

The robustness is a function dependent on possiblity to have a
configuration protocol. Your extended mode with mobile routers
in some situations uses more than one layer of MAPs. Why then is
that acceptable?

>         Hesham

Best Regards,

-Jari