Subject: RE: [mobile-ip] Re: Comments on Regional Registration

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 16 Mar 2001 01:23:16 +0100

Hello Charlie,

> > > I think it's important to support more than one level of
> > > regionalized care-of address, at least for the organization
> > > of mobility management we have in mind for "All-IP"
> > > networks.
> > >
> >         => Ok, could you please give a reason for this ?
> >         How does All-IP come into this ?
> 
> Do you _really_ not at all understand the need for multiple
> levels of hierarchy? 
> 
	=> Yes. I'm sorry if this is a trivial question but I
	honestly don't see why it's needed and would 
	appreciate an explanation. 

>  Unfortunately, I'm out of time today,
> but I'll try to catch up with you next week.
> 
	=> OK.

> > > I also like that anycast addressing allows the mobile node
> > > to accomplish the regional binding update without having
> > > to know about the topology of the visited domain.
> > >
> >         => Knowing a unicast address does not imply knowledge
> >         of the topology. The MN knows the HA's address,
> >         does that imply that it is aware of the topology of
> >         the home network ?
> 
> One could go around a visited network listening to the
> advertisements and get some pretty good ideas about the topology.
> 
	=> You could also do a trace route and get a good idea
	about the topology.

> >         Anyway, we keep missing the point that the current
> >         reg6 draft does not work. We seem to miss that
> >         you can't setup an SA with an anycast address,
> >         but obviously this is not the only concern I have about the
> >         draft.
> 
> I see that you don't like our draft, but saying that it
> doesn't work isn't very constructive.  Especially in view
> of recent exchanges regarding your re-re-iterated concerns.
> 
	=> I am referring to the standard Key Exchange mechanisms
	available, like IKE. I hope this is more contructive.

> > > Your statement is near tautological.  Of course, we'd also
> > > like to arrive at a robust protocol that uses as much
> > > standard routing as is possible.
> > >
> >         => So what is wrong with the current proposal ?
> 
> When I have more time, I'll try to tabulate a list for easy
> reference.  However, in the meantime, I'd have to refer you
> to previous mail postings.
> 
	=> I'll look forward to your comparison.

>   Please note that I'm not very
> comfortable carrying out this sort of mail exchange in the
> first place.
> 
	=> My aim is to keep a technical discussion going.
	It might be difficult to get this sort of discussion
	in 7 minutes during the meeting. I thought
	this discussion would be encouraged. 

> > > We also wish to allow
> > > betterm localization of binding updates than HMIPv6 could
> > > provide.  That can translate into better scalability for the
> > > foreseeable future.
> > >
> >         => This statement is a bit vague. I'd also like to have
> >         a better solution than HMIPv6 or MIPv6 for that matter.
> >         Not because I think they're bad but because better is always
> >         good. The question is where is that better proposal ?
> >         and why is it better ?
> 
> If we didn't think that our regional registration was better at
> least in certain respects, we wouldn't be bringing it up.
> As it is, we'll try to make refinements and comparisons as
> time goes on.
> 
	=> Looking forward to the outcome. 

	Regards,
	Hesham

---

From: Michael Thomas <[email-masked]>
Date: Sun, 25 Mar 2001 07:42:40 -0800 (PST)

> 	appreciate an explanation. 

One quick note that occurred to me at the meeting
on this subject. We are not the protocol police,
so if there is a way protocolwise to do it, people
can do it and that is that. Frankly, I find the
admonitions against multiple levels of hierarchy
somewhat hollow: MIP at least has a basic
connectivity problem; all the rest of the *MIP's
floating around are for optimization and they all
have single point of failure issues. If you're
willing to live with one failure point for
optimization -- which you've assumedly made
backhoe-proof somehow -- I don't know why you
can't make an induction on all the rest. If you
find that unsettling, well... I can't help you
there.

		 Mike