Subject: RE: [mobile-ip] RE: Problems with header compression in IPv6

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 28 Mar 2001 23:19:05 +0200

> Barring that, I think we are going to need a solution like the
> old FA or like the MPLS solution I described in the email to Claude.
> 
	=> Nothing against your framework of course, but I really 
	hope we don't resort to either option (especially MPLS). 
	This will only delay deployment. 
	Let's wait and see what the ROHC and CT experts say.

> You could would still need header compression for options and for
> UDP/RTP headers in any event.
> 
	=> Of course. I wasn't ruling that out. This will still work in the 
	solution I mentioned. 

	Hesham

> >
> >> -----Original Message-----
> >> From:	Hesham Soliman  (ERA) [SMTP:[email-masked]]
> >> Sent:	Thursday, 29 March 2001 5:58
> >> To:	'James Kempf'
> >> Cc:	[email-masked]
> >> Subject:	[mobile-ip] RE: Problems with header compression in IPv6
> >> 
> >> > >I think what James is saying is that header compression
> >> > >will be difficult for MIPv6...i.e. no packets will be compressed
> >> > >... it is better not using tunnels...
> >> > >Am I right James?
> >> > >
> >> > 
> >> > Exactly!
> >> > 
> >> 	=> Ok this is a bit different from what we've been discussing 
> >> 	and the proposal you mentioned in this mail. So if I can 
> >> 	summarise your concerns I would say you mentioned two
> >> 	issues:
> >> 
> >> 	1. Tunnelling adds one more header and there is a question
> >> 	    whether HC will handle this or not at no extra cost.
> >> 
> >> 	2. Resync of the compressor after handover. 
> >> 
> >> 	I was told several times that issue 1 is not an issue
> >> 	and that current HC does handle this and ROHC 
> >> 	definitely will. The same goes for Extension headers. 
> >> 
> >> 	 As for 2, this is independant from tunnelling and 
> >> 	we need to have some concrete answers on :
> >> 
> >> 	- Whether the impacts are significant (20 packets
> >> 	 or 3)
> >> 
> >> 	- Whether seamoby CT can handle this and minimise
> >> 	that time. That is if there are significant impacts. 
> >> 
> >> 	If the answer is no to both questions (ie impacts are
> >> 	significant and CT will not help), then we need 
> >> 	to seriously consider the impacts on MIP in general
> >> 	including HMIP of course. 
> >> 
> >> 	Hesham

---

From: Michael Thomas <[email-masked]>
Date: Wed, 28 Mar 2001 13:28:27 -0800 (PST)

> 	Let's wait and see what the ROHC and CT experts say.

   I don't think that MPLS helps. The label stack
   is inserted in between the headers, it doesn't
   replace them. After all, labels just reify the
   forwarding equivalence class; once you're done
   label switching, you still need to know how to
   route it to the destination. Also: label
   switching doesn't currently support
   to-the-endpoint as far as I've heard.

		      Mike