Subject: Re: [mobile-ip] QoS Work Item

From: Samita Chakrabarti <[email-masked]>
Date: Thu, 29 Mar 2001 13:35:55 -0800 (PST)

Hi Phil,

> Our charter says:  "In the longer term, the WG needs to address: 
> - QoS in the mobile IP environment using diff-serv and/or int-serv/RSVP." 
> 
> The problem is that MNs may be using QoS mechanisms on their flows and these
> MNs will sometimes move using MIP mechanisms.  We have some options to
> explore about how to address this.  We could address QoS issues related
> specifically to mobile IP in this WG based on QoS work done in other WGs
> (DiffServ, IntServ).  We could just provide requirements from a MIP
> perspective to WGs working on these QoS mechanisms and ask them to solve it.
> We could work jointly with folks in other working groups to produce some
> proposals about how to proceed.  It is clear we don't have the option to
> invent another QoS protocol and we shouldn't be doing this work in
> isolation.
> 

Having requirements from mobile-ip WG is an excellent idea.
In addition to Qos behavior in MNs, we would also need to find 
out Qos requirements in Home agents, access routers  and as well
as qos in hierarchical mobile IP scenarios. An analysis of diffserv and
intserv  cases will be also useful.

Thanks,
-Samita

> So, we'd like to know the working group's opinion on the direction we take.
> 
> 
>

---

From: Michael Thomas <[email-masked]>
Date: Thu, 29 Mar 2001 14:43:22 -0800 (PST)

Samita, 

You might take a look at my draft about RSVP and
mobility if you haven't already
(draft-thomas-seamoby-rsvp-analysis-00). It goes
into some detail trying to make sense of what the
current state of affairs is with the intersection
of Intserv and MIPv6. It's not perfect, but it at
least outlines quite a few of the challenges we
face. The same kind of analysis needs to be done
for diffserv and MIP too, as you suggest.

The one thing I would add to your and Phil's list
is cross-realm policy. QoS models currently are
very single domain oriented. From what I can
gather, how policy based admission control works
when you're visiting a different domain is not
especially well understood. I tried to lay out
some of the issues with it as well (and some of
them probably apply to diffserv as well), but much
more work is needed here. Cross realm policy in
the form of the correct settlement models and user
authentication are going to be interesting
problems for interesting times.

	     Mike