Subject: RE: [mobile-ip] Simplified Hierarchical MIPv6 (was...)

From: James Kempf <[email-masked]>
Date: Thu, 15 Mar 2001 16:40:38 -0800 (PST)

Hesham,

>> I don't want to get into a long discussion over this, since I've
>> got a lot of other stuff to do before I leave for the Mini-Apple
>> on Sun., but the fact remains that both hierarchical proposals introduce
>> extra signalling and also some extra tunneling overhead over the air.
>> Air resources are scarce if the network operator needs to pay for them,
>> and so reducing air time is a significant plus.
>> 
>	=> Sure air resources are scarce and expensive, especially 
>	in many cellular systems where they cost billions. 
>	BUT, even one IPv6 header is too expensive, especially for real
>	time services. So what does every IP based cellular system
>	do, they use Header compression. It can handle tunnelling. 
>

But I've heard that moving tunneling state during a handoff is problematic,
and that it might take some number of messages to reestablish. This
would essentially negate the low latency work currently going on.

I am as wary of making tunnelling the easy answer for eliminating all header
overhead as you are of using an anycast address.

>	There are several other protocols in MIP and outside that 
>	require tunnelling to the host, so why is this a special case ?

It's not a special case, and I don't like requiring the mobile to
handle tunneling in those cases either.

>>> I suppose a good set of requirements would have helped to avoid these
>> problems.
>> 
>	=> Agreed. We've included our requirements in the draft 
>	and in all our IETF presentations and I encourage 
>	others to do the same. 
>	What I do discourage (and it's clearly not my decision)
>	is not highlighting what's missing in an existing WG
>	draft. All I want to see is a valid requirement that we have 
>	missed or a fundamental problem with the proposal. 
>	We normally respond by adding the missing bits 
>	as we've shown in previous revisions.
>
>	Is this so hard to get ? I hope not.Otherwise the 
>	discussions are subjective and not very fruitful.
>

We would like to see elimination of *all* tunnelling overhead over
the air (and that includes HA overhead folks) if possible. For example,
by stripping it on at the last hop router, where it is no longer 
needed.

Barring that, we would like to see an analysis that indicates header
compression will work to eliminate tunnelling overhead, and that
it can be moved quickly enough during handover that it will not
negate the gains of the low latency handover protocol. I do not
get the feeling from the Seamoby context transfer problem statement
draft that this is possible.

These are our requirements.

		jak

---

From: Michael Thomas <[email-masked]>
Date: Sun, 25 Mar 2001 07:47:32 -0800 (PST)

> draft that this is possible.

In particular, I think that the case of mobile
routers needs to be considered closely. The
likelihood of the need for many compression
contexts (which I don't _think_ is possible in
CRTP/ROHC, but could be wrong) may be problematic.
   
	Mike