Subject: RE: [mobile-ip] FW: I-D ACTION:draft-malinen-mobileip-regreg6-01. txt

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 16 Mar 2001 04:38:17 +0100

> > > Once we introduce an intermediary point (HA/RMA/MAP) with mobility
> > > bindings
> > > we introduce state used in a similar way as state used for maintaining
> > > plain next hop forwarding.
> > >
> >         => The  next hop forwarding in the MAP depends on the routing
> >         protocols in the domain. The next hop forwarding in Regional
> >         is forced (like a static route). There is a big difference.
> >         You might ague that reg6 is part of MIP, hence can be
> >         classified as a routing protocol, but I would say that
> >         any routing protocol that reserves a "circuit-like" path
> >         in the IP network is not acceptable.
> 
> It is to be noted that in our current version you can use regular
> tunneling or host-based routing (depending on whether you have 
> next-hop as regreg-aware router) as well so there is no difference
> other than having more than one possible levels of binding-based
> forwarding points. Regional forwarding is an optimization not
> in the base draft.
> 
	=> So in the case where you use tunnelling you basically
	have HMIPv6 in Extended mode. Correct ?
	I don't have a problem with this and it is already supported.
	My criticism was tageting the other case.

> The protocol itself considers the basic signaling of using a
> hierarchy, forming the hierarchy dynamically and maintaining it
> in a way that a router failure can be bypassed is a matter for
> a dynamic configuration protocol for the hierarchy. You said you
> are working on such a thing for making MAPs not a single point of
> failure. Is there some fundamental reason why such a protocol
> is possible only for one level of hierarchy?
> 
	=> It is not really easy to do it for an extended mode 
	MAP, which is what you base your draft on. 

	However, as HW designers say, it's just SW and everything
	is possible, but that's not my point. My point is that 
	the multi-level hierarchy is not justified. Even if we 
	somehow develop a redundancy solution, this will 
	add significant cost and I can't see why it's needed.
	So what's the justification for the additional cost
	and overriding the routing protocols ?

> > > I read your use of term connection-oriented to
> > > mean the use of mobility bindings for forwarding instead of exclusively relying on host/network/default routes. Introducing robustness
> > > in this form of forwarding is a problem both HMIP and regreg6 face.
> > > In fact, even basic Mobile IPv6 while forwarding packets via the
> > > home agent has this feature.
> > >
> >         => The robustness in terms of introducing a single point
> >         of failure may be similar, but adding a less robust path
> >         to the MN from the GMA is not acceptable, and clearly
> >         this is not just my opinion.
> 
> The robustness is a function dependent on possiblity to have a
> configuration protocol. Your extended mode with mobile routers
> in some situations uses more than one layer of MAPs. Why then is
> that acceptable?
> 
	=> It does not require any special routing between
	the MR and the upstream MAP. Normal routing protocols
	can be used. 
	It is also needed to support route optimisation for 
	nodes connected to the MR. 

	Regards,
	Hesham

---

From: "Jari T. Malinen" <[email-masked]>
Date: Thu, 15 Mar 2001 20:28:22 -0800

>         have HMIPv6 in Extended mode. Correct ?

No, the signaling and localizing location update is different.
The load balancing is different. You base it all on cooperation
of the mobile node, we let the network do it automated by the
crossover functionality.

>         MAP, which is what you base your draft on.

I do not believe it is trivial for one level either.

>         and overriding the routing protocols ?

Better optimization of last hop bandwidth usage, network-controlled
load balancing (your scheme has hop count and priority in a MAP
option, these trust MN does something it may not be designed to
do and require more than one MAP options to make a choice even
possible).

>         the MR and the upstream MAP. Normal routing protocols

Having nested mobile routers will bring multiple layers of
MAP-based forwarding.

>         Hesham

Best Regards,

-Jari