Subject: RE: [mobile-ip] Final Agenda for Mobile IP WG meeting at IETF50

From: [email-masked]
Date: Thu, 15 Mar 2001 08:42:25 -0600

Michael,

>I understand that, but this draft in particular is
>positing a completely different way to perform
>signaled QoS admission control which has global
>implications: CN's and interior routers would need
>to implement this as well.
>
>As you may know, I've spent a fair amount of time
>trying to figure out what the implications of our
>current signaled QoS admission control scheme --
>RSVP -- are with MIP and I can tell you as a very
>quick summary that positing a completely different
>signaling scheme is *far* too premature. 

I am aware of your work in this area, but I am not so sure if the
scope of the discussion in the time slot is premature. 

>It would
>be much, much better to analyze what the current
>state of affairs is and compare that to MIP
>requirements before we decide whether a specific
>solution is in order. In fact, even if it is, I
>cannot imagine that the MIP WG is the right place
>to pursue this.
>

Why is the MIP WG not the place to work on QoS aspects that are
related to mobility, especially from a Mobile IP perspective? Where
else in the IETF would you believe this work needs to be done?

>I have volunteered to discuss my analysis (draft-
>thomas-seamoby-rsvp-analysis-00) and will do so
>again at this point, but even if you don't take me
>up on this, I cannot see what will be productive
>about discussing this draft for the second IETF
>in a row: all of the same arguments of scope
>and wholesale reinvention apply.
>

I believe the authors of the chaskar I-D have addressed some of the
concerns that you have raised on the mailing list. We welcome your
input and discussion on the issues. 
I do not believe there is any "wholesale reinvention" being proposed
in the chaskar draft. It is specifically targeted for Mobile IPv6 and
is addressing a specific problem.

>	  Mike

-Basavaraj

---

From: Michael Thomas <[email-masked]>
Date: Thu, 15 Mar 2001 10:02:59 -0800 (PST)

> else in the IETF would you believe this work needs to be done?

   Because it is not just related to MIP! All of the routers and
   correspondent nodes would need to implement this scheme as
   well. Also: it is *far* too premature to throw in the towel
   on RSVP. 

 > is addressing a specific problem.

   As far as I can tell, there are a huge number of things
   that are not addressed by the draft which are extremely
   important to both fixed and mobile IP. In order to
   support them would certainly require a fair if not huge
   amount of reinvention. Also: anything that claims 
   "situation X is different, therefore..." should always
   be viewed with a great deal of skepticism. IETF protocols
   are usually a lot more general purpose than people give
   them credit for. That's why I think that the right thing
   for the next IETF is to actually start gathering requirements
   and analysing the current state of affairs with current
   protocols. Solution space presentations are, IMO, a waste
   of time.

		Mike

---

From: Patrice Calhoun <[email-masked]>
Date: Thu, 15 Mar 2001 12:50:42 -0800 (PST)

> else in the IETF would you believe this work needs to be done?

NSIS perhaps? Or maybe a new Qos for Wireless BOF?

PatC