Subject: RE: [mobile-ip] FW: I-D ACTION:draft-malinen-mobileip-regreg6-01. txt

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 16 Mar 2001 05:56:02 +0100

> > > The protocol itself considers the basic signaling of using a
> > > hierarchy, forming the hierarchy dynamically and maintaining it
> > > in a way that a router failure can be bypassed is a matter for
> > > a dynamic configuration protocol for the hierarchy. You said you
> > > are working on such a thing for making MAPs not a single point of
> > > failure. Is there some fundamental reason why such a protocol
> > > is possible only for one level of hierarchy?
> > >
> >         => It is not really easy to do it for an extended mode
> >         MAP, which is what you base your draft on.
> 
> I do not believe it is trivial for one level either.
> 
	=> You've missed my point, the number of levels 
	is not relevant, it is difficult for the Extended mode.
	We believe it is easy to do it for basic mode. 
	Your proposal relies on using the GMA's address
	which is the same address management as the MAP
	in Extended mode.

> >         So what's the justification for the additional cost
> >         and overriding the routing protocols ?
> 
> Better optimization of last hop bandwidth usage, network-controlled
> load balancing (your scheme has hop count and priority in a MAP
> option, these trust MN does something it may not be designed to
> do and require more than one MAP options to make a choice even
> possible).
> 
	=> Are you referring to the MAP option ?
	I hope this is not the BW argument. This argument is 
	not valid IMO. RAs are designed to have several
	options regardless of the use of MIP. I hope we can agree on that. 

	Now regarding the parameters in the MAP option, 
	I don't see what the MN would have difficulty with.
	If the MN supports HMIPv6 then it MUST understand 
	the option. If it does something wrong, like choosing 
	a MAP with a 255 preference (indicating that it should 
	not be used), the MAP will simply reject the BU.
	What's the problem with that ?

> > > The robustness is a function dependent on possiblity to have a
> > > configuration protocol. Your extended mode with mobile routers
> > > in some situations uses more than one layer of MAPs. Why then is
> > > that acceptable?
> > >
> >         => It does not require any special routing between
> >         the MR and the upstream MAP. Normal routing protocols
> >         can be used.
> 
> Having nested mobile routers will bring multiple layers of
> MAP-based forwarding.
> 
	=>. No. The MNs on the Mobile networks will have a prefix 
	that belongs to the MR. Hence the "further" MAP will
	tunnel to the MR, which will simply decapsulate the 
	packets and forwad them to the MN. Is that what you 
	mean by MAP based forwarding ? 
	Tunnelling to the MR (MAP in this case) is the same 
	as tunnelling to the end node. I don't see the difference,
	the packets can take multiple paths between the higher
	MAP and the MR as per standard routing. 

	So your statement does not state what the disadvantage 
	is with this approach.

	Regards,
	Hesham

---

From: "Jari T. Malinen" <[email-masked]>
Date: Thu, 15 Mar 2001 22:03:19 -0800

> > >         and overriding the routing protocols ?

I believe we are not overriding routing protocols any more than you
are, once we compare with your extended mode.

>         options regardless of the use of MIP. I hope we can agree on that.

We can still try to reduce the size of the RA, i.e. number of extensions
needed for a load-balancing network.

>         What's the problem with that ?

You rely on the MN to behave correctly. Also, you do not specify
the load balancing, you need external box to do that. Also, the
load balancing with static values is questionable. What if you have preferences 1,2,3, and differenc hop counts, all MNs go to 1 until administrator changes the order. Also, MN only SHOULD follow this
order, they thus MAY ignore it. Operator has no control in that case,
he may only speculate which configuration possibility a MAP-aware MN
in question has chosen, does it follow the SHOULD or does it not.
If it simply denies service for those who do not follow the SHOULD,
this has the effect of no operation for those MNs.

Furthermore, a change of MAP means re-registration with every
CN in the Internet while changing a crossover router does not.

>         mean by MAP based forwarding ?

Further MAP has tunneling state. If you have mobile node below
the mobile router, are you not having the mobile router as a MAP ?
Does the MN attached to the mobile network need to register with
the lower MAP to be operational when the lower MAP is at home ?
The MAP is the entry point to the mobile network and is another
"single point of failure" on the path of the packet.
What if you add another mobile router below the mobile router ?

I suspect you also may have multiple layers. In that case, same
robustness arguments apply both ways.

>         MAP and the MR as per standard routing.

So can a tunneled packet from GMA to the next lower RMA follow
any path natural routing might use.

>         So your statement does not state what the disadvantage

Bandwidth usage, more distant target for the localized binding
update. Mobile-controlled load balancing. Designers of networks
may want to exercise more stringent control on how mobile nodes
move in their network. Load balancing should be such that you can
have the same mobile node cause location update with a new box
without signaling out of the visited domain. In HMIP,
when MAP is changed, MN needs to re-register with all CNs.
In fact, you have a solution to newly arriving MNs, not for the
population already attached.

>         Hesham

Best Regards,

-Jari