Subject: RE: [mobile-ip] Re: Comments on Regional Registration

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 15 Mar 2001 21:07:21 +0100

Hello Charlie, 

> > > - Getting the routing part figured out.
> > >
> >         => I don't understand what needs to be solved on the
> >         routing aspect of the problem ? Do you not like
> >         the routing provided by HMIPv6 ? If so why ?
> 
> I think it's important to support more than one level of
> regionalized care-of address, at least for the organization
> of mobility management we have in mind for "All-IP"
> networks.
> 
	=> Ok, could you please give a reason for this ?
	How does All-IP come into this ?

> I also like that anycast addressing allows the mobile node
> to accomplish the regional binding update without having
> to know about the topology of the visited domain.
> 
	=> Knowing a unicast address does not imply knowledge
	of the topology. The MN knows the HA's address,
	does that imply that it is aware of the topology of 
	the home network ? 

	Anyway, we keep missing the point that the current
	reg6 draft does not work. We seem to miss that
	you can't setup an SA with an anycast address, 
	but obviously this is not the only concern I have about the 
	draft.

> >         => I'm not at all trying to discredit anycastl. I'm just
> >         wondering how you could use it in light of the current
> >         standards. You still didn't tell me what the solution
> >         is.
> >         Proposing a solution for setting up an SA with an
> >         anycast group would be a great proposal, but
> >         I don't think we need several standards to solve
> >         this particular problem. We already have a solution
> >         and I'm starting to question the need for alternatives
> >         if nothing is raised against HMIPv6. Especally if
> >         the alternative is a lot less robust and overrides
> >         the use of standard routing between the anchor point
> >         and the MN.
> 
> Your statement is near tautological.  Of course, we'd also
> like to arrive at a robust protocol that uses as much
> standard routing as is possible.  
> 
	=> So what is wrong with the current proposal ?

> We also wish to allow
> betterm localization of binding updates than HMIPv6 could
> provide.  That can translate into better scalability for the
> foreseeable future.
> 
	=> This statement is a bit vague. I'd also like to have 
	a better solution than HMIPv6 or MIPv6 for that matter.
	Not because I think they're bad but because better is always
	good. The question is where is that better proposal ?
	and why is it better ?

	Regards,
	Hesham

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 15 Mar 2001 16:05:28 -0800

Hello Hesham,

<everyone else, please excuse this relatively content-free note,
 feel free to ignore>

>         How does All-IP come into this ?

Do you _really_ not at all understand the need for multiple
levels of hierarchy?  Unfortunately, I'm out of time today,
but I'll try to catch up with you next week.

>         does that imply that it is aware of the topology of

One could go around a visited network listening to the
advertisements and get some pretty good ideas about the topology.

>         but obviously this is not the only concern I have about the

I see that you don't like our draft, but saying that it
doesn't work isn't very constructive.  Especially in view
of recent exchanges regarding your re-re-iterated concerns.

>         => So what is wrong with the current proposal ?

When I have more time, I'll try to tabulate a list for easy
reference.  However, in the meantime, I'd have to refer you
to previous mail postings.  Please note that I'm not very
comfortable carrying out this sort of mail exchange in the
first place.

>         good. The question is where is that better proposal ?

If we didn't think that our regional registration was better at
least in certain respects, we wouldn't be bringing it up.
As it is, we'll try to make refinements and comparisons as
time goes on.

Regards,
Charlie P.