Subject: Re: [mobile-ip] RE: [rohc] RE: Restarting Compressor on Mobile IPv6 Handover

From: James Kempf <[email-masked]>
Date: Thu, 29 Mar 2001 11:58:31 -0800 (PST)

Hesham,

>So I don't know why we (MIP WG) should be involved. 
>It seems to be a ROHC/SEAMOBY issue. 
>

The reason the MIP working group has to be involved is we currently
have a design team working on MIPv6 fast handoff. If it takes
120 ms to restart the header compressor when the mobile node moves,
that work will be negated. We don't have to be involved in the
details, but we at least have to know:

	1) That either header compression can restart fast
	or with context transfer and updating of the context using
	the new CoA.
	
	2) That the same fast restart of header compression will work
	for proposed additions where extra header state is involved,
	such as HMIPv6 extended mode.
	
We can't simply assume that a technology is there and works the way
we want it without verifying the facts.

That said, there is no reason why the MIP group needs to be involved in the 
details of the design. We just need to state our requirements to Seamoby and
ROHC and let them take it from there. The above two points represent
requirements, IMHO.

		jak

---

From: Claude Castelluccia <[email-masked]>
Date: Fri, 30 Mar 2001 09:57:09 +0200

James Kempf wrote:

>  We don't have to be involved in the

just a quick comment: in HMIPv6 basic mode, the MN uses the RCoA as source
address ...this address
only changes when the MN moves from one MAP to another...

HMIPv6 might actually make things easier than MIPv6 concerning header
compression....

regards,

Claude.

--

----------------------------------------
Claude CASTELLUCCIA, INRIA Rhone-Alpes
ph:  +33 4.76.61.52.15 (fax: 52.52)
http://www.inrialpes.fr/planete/