Subject: RE: [mobile-ip] Multiple tunnels over unoptimized route packets f or Extended mode

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 30 Mar 2001 01:37:43 +0200

>    you either don't want to understand what I am saying or the email program
> manages to shuffle my writing so that it arrives
> to you in the way you want to interpret it... :)
> 
	=> I don't normally respond to statements like these but 
	I'll do this one more time, so concentrate.

> The MN's HA has a binding. The first time that the MN moves under the MR/MAP it
> will use as CoA the LCoA. But hey this is the home address of the MR. 
> 
	=> NO. the MN uses the advertised MAP address as an alternate
	COA. That's what the 'T' flag is for. OK ?
	The MN knows that it moved because it receives an RA. This RA
	will "tell" the MN that it MUST use the MAP's address as an alt-COA.
	The MAP's (MR) address is the one obtained from the RA it received
	from the "fixed" AR which has a different prefix from the the MR's 
	home prefix. 

	Now if you read this part of the draft and didn't get that understanding
	tell me where the draft failed to deliver the message. But make sure
	that you say that in a respectable way if you want to get an answer.

> Needless to
> say the protocol couldn't care less about that. It is just a LCoA of the MR/MAP
> (So forget the term home address of the MR in this book..)
> 
> 
> 
> 
> Packets from the MN's HA would arrive tunneled at that LCoA (route unoptimized)
> (one tunnel)
> In that time the vehicle that was carrying that MR/MAP  went away. That means to
> me, that the MR acts as an HMIPv6 node and as a MR/MAP. So what does it do? It
> gets itself a RCoA on a fixed MAP (Hello Basic Mode). That fixed MAP will tunnel
> all packets sent to that RCoA.
> 
	=> For the second time, a fixed MAP does NOT mean basic mode. It 
	can be an Extended mode MAP.

	Hesham

---

From: Theo Pagtzis <[email-masked]>
Date: Thu, 29 Mar 2001 16:09:16 -0800

Hesham,

please don't be irritated by the comments, they are not intended to harm...only to
challenge for elaboration...and the clarity of the spec  :))

>         that you say that in a respectable way if you want to get an answer.

This is crystal clear from the spec. But please continue your elaboration I am dying
to hear the rest of you
description...

>         can be an Extended mode MAP.

Now allow me to say that the spec (v2) mentioned explicitly that the MR case is
explicitly worked through extended mode. In that case I can only assume that the
fixed MAP case is dealt by the Basic mode. If you say that the fixed map case is NOW,
NOT dealt by basic mode, I am left with no option but AGREE with Charlie on his
request that the Basic mode should really go AWAY... I cannot see any point why the
basic mode need stay there anymore. I would be grateful if you could convince me for
the opposite....

I need not emphasize further as negative point of Basic mode,  that the generation of
multiple RCoA for MN so as to sustain unique representation of the MN in the visited
domain, while you have a unique Home Addr already at hand (but you don't divulge that
to the MAP - I wonder why???) is also bound to find problems:

1) by the management of MANY RCoA for no apparent reason
2) DAD checks by the hunderds for no apparent reason

If however the Basic mode is destined for fixed MAPs then, all I am crying out loud
is that when route unoptimized packets leaving from the MN's HA (when that HA has not
received a BU from the MN because it awaits its MR/MAP to get its own LCoA in the
mean time)

towards the MN,  AND the MR is away but the BU from the MN has not reached the MN's
HA (MR/MAP has not got yet  its own LCoA), then the MR/MAP's HA will have to
intercept the packet and tunnel it to the RCoA  (2 tunnels already). Add another
tunnel for the fixed MAP propagation of the packet and there you have it...

Theo

UCL / Mobile Systems