Subject: Re: [mobile-ip] -HMIPv6 draft + Privacy draft-

From: Claude Castelluccia <[email-masked]>
Date: Fri, 16 Mar 2001 17:33:54 +0100

Glenn Morrow wrote:

> Claude,In reference to the privacy draft , I do not see the use of it
> as you do not try to "solve the problem of privacy of a mobile node
> from it's correspondent nodes". You want to hide some information from
> other nodes such as location and true identity but by not handling the
> basic issue with the CN you have done nothing. For instance, any node
> in the world can ping the MN and obtain it's COA because it would then
> be a CN.

If you want to hide your location to your CN, you can either:
-use HMIP (in this case you only reveal your RCoA not your CoA)
- use MIP without route optimization...
-use Mixes, onion routing...
-others?

Anyways you are right, we are not solving this problem in this draft, we
are solving the following one:

-A MN trusts its CN (because they are both belonging to the same
company)
and is willing to reveal its CoA, however it does not want anybody else
(for example its
competitor) in the network to know where it is currently located....

This is not possible with MIPv6, this is what our draft tries to
solve...

> Why would someone bother worrying about eavesdropping and sniffing
> when one can simply ping the node after a DNS or other lookup?

as I said we make the assumption that a MN only sends BU to CNs it
trusts ....

> It seems to me that the recent anonymity extensions to stateless
> autoconfiguration will acheive the same functionality as the TMI
> concept.

not really... with the recent anonymity extensions for stateless auto.
you still reveal your network prefix, you just
use an interface identifier that is random...in our case the TMI (128
bit) is completly random....

> More later on the new HMIP proposal.

this is not a new proposal....just a new version of the old proposal...

> Thanks for the effort, though.Glenn

thanks for your comments...

>
>
>      -----Original Message-----
>      From: Morrow, Glenn [RICH2:C330:EXCH]
>      Sent: Friday, March 16, 2001 8:06 AM
>      To: [email-masked]
>      Subject: RE: [mobile-ip] -HMIPv6 draft + Privacy draft-
>      Thanks Claude,I'll take a look. I am hoping others will
>      follow suit with more candidates as well. This location
>      privacy thing is one of the last "what's missings". I have
>      to say I have found it very uncomfortable going forward on
>      solutions to other aspects of the problem with this issue
>      dangling.
>
>           -----Original Message-----
>           From: Claude Castelluccia
>           [mailto:[email-masked]]
>           Sent: Friday, March 16, 2001 3:48 AM
>           To: [email-masked]
>           Subject: [mobile-ip] -HMIPv6 draft + Privacy
>           draft-
>           Hello,
>
>           We actually have a  (preliminary) draft that tries
>           to tackle the problem of route optimal location
>           privacy in MIPv6.
>           The draft
>           (draft-castelluccia-mobileip-privacy-00.txt) can
>           be retrieved from my web site :
>           http://www.inrialpes.fr/planete/people/ccastel/draft-castelluccia-mobileip-privacy-00.txt
>           or from the IETF
>           ID repository...
>
>           Note also that we have a new version of HMIPv6
>           (version 3) that clarifies some aspects of HMIPv6
>           and
>           highlights some of its advantages (see section 6.5
>           or 6.6 for example). This new version can be
>           retrieved at:
>           http://www.in
>           ialpes.fr/planete/people/ccastel/draft-ietf-mobileip-hmipv6-03.txt
>
>           comments welcome....
>
>           regards,
>
>           Claude.
>
>           Glenn Morrow wrote:
>
>          >
>          >
>          > Yes - there is no accepted or even tabled
>          > proposal yet for route optimal location privacy.
>          > I believe it is a requirement even MIP should
>          > strive for as we move forward.
>          >
>          >
>          >
>          >         => True. But the same goes for any IP
>          > adderss in the hierarchical
>          >         IPv6 world. Right ?
>          >
>          >         Hesham
>
>           --
>
>           ----------------------------------------
>           Claude CASTELLUCCIA, INRIA Rhone-Alpes
>           ph:  +33 4.76.61.52.15 (fax: 52.52)
>           http://www.inrialpes.fr/planete/
>
>
>
--

----------------------------------------
Claude CASTELLUCCIA, INRIA Rhone-Alpes
ph:  +33 4.76.61.52.15 (fax: 52.52)
http://www.inrialpes.fr/planete/

---

From: "Glenn Morrow" <[email-masked]>
Date: Fri, 16 Mar 2001 09:44:05 -0600

Claude,
 
In reference to the privacy draft , I do not see the use of it as you do not
try to "solve the problem of privacy of a mobile node from it's
correspondent nodes". 
 
You want to hide some information from other nodes such as location and true
identity but by not handling the basic issue with the CN you have done
nothing. For instance, any node in the world can ping the MN and obtain it's
COA because it would then be a CN. 
 
Why would someone bother worrying about eavesdropping and sniffing when one
can simply ping the node after a DNS or other lookup?
 
It seems to me that the recent anonymity extensions to stateless
autoconfiguration will acheive the same functionality as the TMI concept.
 
More later on the new HMIP proposal. This will take some time.
 
Thanks for the effort, though.

Glenn

-----Original Message-----
From: Morrow, Glenn [RICH2:C330:EXCH] 
Sent: Friday, March 16, 2001 8:06 AM
To: [email-masked]
Subject: RE: [mobile-ip] -HMIPv6 draft + Privacy draft-

Thanks Claude,
 
I'll take a look. I am hoping others will follow suit with more candidates
as well. This location privacy thing is one of the last "what's missings". I
have to say I have found it very uncomfortable going forward on solutions to
other aspects of the problem with this issue dangling.

-----Original Message-----
From: Claude Castelluccia [mailto:[email-masked]]
Sent: Friday, March 16, 2001 3:48 AM
To: [email-masked]
Subject: [mobile-ip] -HMIPv6 draft + Privacy draft-

Hello, 

We actually have a  (preliminary) draft that tries to tackle the problem of
route optimal location privacy in MIPv6. 
The draft (draft-castelluccia-mobileip-privacy-00.txt) can be retrieved from
my web site :
http://www.inrialpes.fr/planete/people/ccastel/draft-castelluccia-mobileip-p
rivacy-00.txt
<http://www.inrialpes.fr/planete/people/ccastel/draft-castelluccia-mobileip-
privacy-00.txt>  or from the IETF 
ID repository... 

Note also that we have a new version of HMIPv6 (version 3) that clarifies
some aspects of HMIPv6 and 
highlights some of its advantages (see section 6.5 or 6.6 for example). This
new version can be retrieved at: 
http://www.inrialpes.fr/planete/people/ccastel/draft-ietf-mobileip-hmipv6-03
.txt
<http://www.inrialpes.fr/planete/people/ccastel/draft-ietf-mobileip-hmipv6-0
3.txt>  

comments welcome.... 

regards, 

Claude. 

Glenn Morrow wrote: 

Yes - there is no accepted or even tabled proposal yet for route optimal
location privacy. I believe it is a requirement even MIP should strive for
as we move forward. 

        => True. But the same goes for any IP adderss in the hierarchical 
        IPv6 world. Right ? 

        Hesham

-- 

http://www.inrialpes.fr/planete/ <http://www.inrialpes.fr/planete/>