Subject: A question about DHCP for Mobile IP

From: Tao Huang <[email-masked]>
Date: Wed, 15 Mar 2000 12:3:41 +0000

Hello,

I have a question about the ip address of mobile node. 

If a mobile node move into a foreign network and use the foreign agent's ip address as care-of address,
should it obtain a local IP address by DHCP? 
Or when the mobile node use co-located address to register to home agent, how can the mobile node get 
a new address when moves to a new foreign network. From the book"Mobile IP", it say that mobile node can use
any mechanism to detect whether it needs to make a new point of attachment to the internet. Then what 
mechanism available? 
I remember that in win98, you had to reboot your computer after you change your IP address. How can it work 
for the mobile IP if the mobile node had to change its IP address frequently.

cheers

---

From: Steven Glass - Solaris Software <[email-masked]>
Date: Fri, 16 Mar 2001 18:27:41 -0500 (EST)

>I have a question about the ip address of mobile node. 

    Sure - first pleast note the correct list address is 
[email-masked]...

>should it obtain a local IP address by DHCP? 

    In almost all cases it doesn't have to.  The mobile node registers the FA's 
address as its CoA so the HA has a reachable place one-hop away from the mobile 
node to send the MN's traffic.  The MN would have to get a local [DHCP] address, 
AND use the FAs address as a CoA if the MN wants access to local services as if 
it were local, but the only way it can get off the local link is via the FA (and 
hence the FA SHOULD be setting the 'R' bit).

>a new address when moves to a new foreign network.

   The same way, it just tries to get a new address, registers it, then 
(perhaps) deregisers and "throws away" the old address.

> From the book"Mobile IP", it say that mobile node can use

    Either by listening for router or agent advertisements, or [periodically] 
soliciting for them.

>for the mobile IP if the mobile node had to change its IP address frequently.

    Uh - that would make life really hard, since rebooting likely also brings 
down your current connections (which is one of the reasons we want mobile-ip - 
to leave current connections *UP*), so Microsoft's going to have to fix that, 
aren't they.  Seriously, in mobile ip the home address "never" changes, so all 
that's happenning is the care-of address is changing.  Think about it as the HA 
is proxying for the MN, and the FA is loaning (sharing) its address (as a CoA) 
with the mobile node as a "last-hop" for its traffic, then simply handing it 
over.  The Colocated CoA works in exactly the same way - it's the "last-hop" on 
that link, which happens to be already "inside" the mobile node.

                              Cheers,
                                  Steve