Subject: RE: [mobile-ip] RE: Problems with header compression in IPv6

From: James Kempf <[email-masked]>
Date: Wed, 28 Mar 2001 13:33:43 -0800 (PST)

Mike,

> > > Barring that, I think we are going to need a solution like the
> > > old FA or like the MPLS solution I described in the email to Claude.
> > > 
> > 	=> Nothing against your framework of course, but I really 
> > 	hope we don't resort to either option (especially MPLS). 
> > 	This will only delay deployment. 
> > 	Let's wait and see what the ROHC and CT experts say.
>
>   I don't think that MPLS helps. The label stack
>   is inserted in between the headers, it doesn't
>   replace them. After all, labels just reify the
>   forwarding equivalence class; once you're done
>   label switching, you still need to know how to
>   route it to the destination. Also: label
>   switching doesn't currently support
>   to-the-endpoint as far as I've heard.
>
>

My understanding from reading the MPLS framework RFC is that label stripping
was supported as well, just as long as the LDP communicated the header
to the other end somehow.

		jak

---

From: Michael Thomas <[email-masked]>
Date: Wed, 28 Mar 2001 13:44:22 -0800 (PST)

> to the other end somehow.

   That's just the labels, not the inner headers.
   MPLS is just a way of encoding the the forwarding
   decision back upstream so that the FIB lookup can
   be done with a single lookup for the FEC rather
   than the more conventional MTRIE based lookup.
   Once you're done label switching, you still
   need those IP headers to sort everything else
   out (including TTL processing, etc, etc). I'm
   pretty sure that this is why it doesn't make
   much sense to create LSP's to the host.

		  Mike