Subject: [mobile-ip] FW: I-D ACTION:draft-malinen-mobileip-regreg6-01.txt

From: "Glenn Morrow" <[email-masked]>
Date: Fri, 9 Mar 2001 13:39:38 -0600

Hello,

I still do not understand why the ability to place something at an arbitrary
point justifies destroying the connectionless nature of a IP or even IP
mobility.

If arbitrary point is so important, why don't you just tunnel to the
arbitrary point based upon routing policy and leave a natural aggregatable
solution connectionless. People can always tinker with their routes to make
single points of failure if they wish but why build it in.

Have people simply given up on keeping things connectionless? Is there some
sort of graph theory that somehow proves that this is a connection oriented
problem domain?

Respectfully, I wish to be illuminated on this - one way or the other. 

Thanks,

Glenn

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, March 09, 2001 6:35 AM
To: IETF-Announce
Subject: I-D ACTION:draft-malinen-mobileip-regreg6-01.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title		: Mobile IPv6 Regional Registrations
	Author(s)	: J. Malinen, F. Le, C. Perkins
	Filename	: draft-malinen-mobileip-regreg6-01.txt
	Pages		: 28
	Date		: 08-Mar-01
	
This document describes Mobile IPv6 regional registration as an
optional extension to Mobile IPv6.  Regional registration introduces
visited-domain mobility agent functionality for proxying a public
care-of-address which remains the same while the mobile node
moves in the visited domain.  This reduces the binding update
signaling latency for the mobile node and signaling load outside the
visited domain.  The protocol defines regional mobility capability
negotiation, regional binding update signaling, and regional-aware
data routing through a hierarchy of visited-domain mobility agents.
The protocol allows for an arbitrary point in the visited-domain
hierarchy to distribute the connection-state maintenance between
several mobility agents.  IPSec AH is used for securing the protocol
as in basic Mobile IPv6.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-malinen-mobileip-regreg6-01.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-malinen-mobileip-regreg6-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-malinen-mobileip-regreg6-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

Date: Fri, 9 Mar 2001 10:58:59 -0600

---

From: "Eunsoo Shim" <[email-masked]>
Date: Sat, 10 Mar 2001 11:11:27 -0500

FW: I-D ACTION:draft-malinen-mobileip-regreg6-01.txtHi,

Probably the problem is related to the difficulty of mobility management without introducing global per-host routing.
Of course no one is proposing global per-host routing.
Actually the solutions suggested in Mobile IP and Mobile IP Regional Registration are based on tunneling.
And now one of the issues is how to manage/control the tunnels very well.
If you are concerned about the single point of failure introduced by Mobile IP Regional Registration, our I-D might be worth reading since we tried to propose a solution to relieve the problem of single point of failure while keeping the advantages of regional registration.
Our I-D is available at the following URL for now:
http://www.comet.columbia.edu/~eunsoo/paper/draft-shim-mobileip-reliable-reg-00.txt
http://www.comet.columbia.edu/~eunsoo/paper/draft-shim-mobileip-reliable-reg-00.pdf

Thanks.

Eunsoo

  ----- Original Message ----- 
  From: Glenn Morrow 
  To: [email-masked] 
  Sent: Friday, March 09, 2001 2:39 PM
  Subject: [mobile-ip] FW: I-D ACTION:draft-malinen-mobileip-regreg6-01.txt

  Hello, 

  I still do not understand why the ability to place something at an arbitrary point justifies destroying the connectionless nature of a IP or even IP mobility.

  If arbitrary point is so important, why don't you just tunnel to the arbitrary point based upon routing policy and leave a natural aggregatable solution connectionless. People can always tinker with their routes to make single points of failure if they wish but why build it in.

  Have people simply given up on keeping things connectionless? Is there some sort of graph theory that somehow proves that this is a connection oriented problem domain?

  Thanks, 

  Glenn 

  -----Original Message----- 
  From: [email-masked] [mailto:[email-masked]] 
  Sent: Friday, March 09, 2001 6:35 AM 
  To: IETF-Announce 
  Subject: I-D ACTION:draft-malinen-mobileip-regreg6-01.txt 

  A New Internet-Draft is available from the on-line Internet-Drafts directories. 

  Send a message to: 
          [email-masked]. 
  In the body type:

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 12 Mar 2001 11:27:58 -0800

Hello Glenn,

> I still do not understand why the ability to place something at an
> arbitrary point justifies destroying the connectionless nature of a IP
> or even IP mobility.

I'm not sure what the connection is between these two clauses.
Any sort of localized registration is supposed to hide changes of
the care-of address.  The mobile node can consent to such hiding.
Maybe there is something else about our protocol that looks like
an intent to destroy the connectionless nature of IP.  Could you
please be a little more specific about your concerns here?

If I may guess that the mobile node has to keep track of more
network state (what one might call "connection state") then I guess
you would prefer to minimize that.  On this we can agree.  Then
the discussion should center on ways that state is gratuitously
set up as a protocol requirement, and make the tradeoffs.

> arbitrary point based upon routing policy and leave a natural
> aggregatable solution connectionless. People can always tinker with
> their routes to make single points of failure if they wish but why
> build it in.

We basically attempted to do exactly what you suggest, by
allowing an anycast address to be used by the mobile node
for the purposes of making regional registrations.  However,
there may be other solutions that have even less connection
state required.  I agree that getting rid of single points of failure
is a good idea.

> Have people simply given up on keeping things connectionless? Is there
> some sort of graph theory that somehow proves that this is a
> connection oriented problem domain?

I have not at all given up on it.  Some things seem to be "connection-
oriented" -- say, for instance, header compression state or QoS.
Connectionless has universal appeal because of its simplicity and
typically good-enough performance.  I think that regionalized
registrations lies more on the connectionless side, and that we
should aim to make it as connectionless as possible, while still
making it possible.

Regards,
Charlie P.