Subject: [mobile-ip] CNs in/near MN's home subnetwork

From: Erdmann Antonius ICM N MC MI E 3 <[email-masked]>
Date: Fri, 30 Mar 2001 14:34:24 +0200

Hi,

I'm a bit confused about the following problem(s):

Here the possible configuration:

Rx is a router

    CN1                 R                R                 CN2
     |                  |                |                  |
-----+--------+---------+--            --+------+-----------+------
              |                                 |
             R1 (HA1)                          R2 (not HA)
              |                                 |
    --+-------+---------------+-----------------+-------+---
      |                       |                         |
     CN3                     (MN)                       R
                   (home network of MN,
                    but MN is away from home)

1. CN1 has no problems with MN being away from home, because R1-HA1 _can_
   intercept any packets to MN and tunnel them to the CoA

2. CN2 has problemes, because AFAIK R2 will send
   a message "host unreachable" to CN2

3. CN3 has problems, because CN3 himself will find out (by neighbor
discovery)
   that MN is "unreachable". No router is involved in the traffic CN3 <->
MN,
   when MN is at home.

Consequences for a network allowing mobility for its nodes:

- must every leaf-router be a HA to be able to intercept all packets
destined to any MN
  coming from any CN ???

  and/or

- must a MN (being away from home) send BUs to all HAs on its home link ???

  and/or

- must every HA listen for all packets for all MNs that have an entry in the
"binding cache"

What's wrong with my understanding ???

Toni

---

From: Wolfgang Schoenfeld <[email-masked]>
Date: Fri, 30 Mar 2001 15:10:51 +0200

Toni,

it seems to me that your understanding of "intercept" is incorrect.
In the context of MIP, it is not meant topologically
(some router on the packet's path grabs it ...).
Instead, the packet is intercepted
while it is sent on the final link:
HA intercepts packets addressed to MN
by binding its MAC address to the MN's IP address
(very similar to proxy ARP).

This should answer all your questions...
(I remember I had the same problem when working through MIP.)

Wolfgang

---

From: Peter Grimstrup <[email-masked]>
Date: Fri, 30 Mar 2001 15:16:09 +0200

Hi Toni,

Althoug I'm fairly new in this business, I'll try to solve your problem(s) - If
I'm wrong, I'm sure somebody will lead me back on the track.

When the MN sends a BU to R1 asking R1 to be HA, R1 will act as a proxy for MN on
the home network of MN. This means, that other nodes through neighbor-discovery
mechanisms will learn to use the MAC address of R1 as target for traffic to MN.

ad. 2. Thus CN sends the packet destined for MN to R2, R2 learns/has learnt that
MN's MAC now is MAC of R1 and sends packet to R1. R1 tunnels packet to MN.

ad 3. Same mechanism.

/Peter
---------------------------------------

-- 
Peter Grimstrup          Systems Developer
Ericsson Telebit A/S     tel: +45 89 38 52 75
Skanderborgvej 232       fax: +45 89 38 51 01
DK 8260 Viby J, Denmark  e-mail: [email-masked]