Subject: RE: [mobile-ip] Simplified Hierarchical MIPv6 (was...)

From: James Kempf <[email-masked]>
Date: Thu, 15 Mar 2001 17:12:05 -0800 (PST)

Hesham,

>> We would like to see elimination of *all* tunnelling overhead over
>> the air (and that includes HA overhead folks) if possible. For example,
>> by stripping it on at the last hop router, where it is no longer 
>> needed.
>> 
>> Barring that, we would like to see an analysis that indicates header
>> compression will work to eliminate tunnelling overhead, and that
>> it can be moved quickly enough during handover that it will not
>> negate the gains of the low latency handover protocol. 
>> 
>	=> I am not an expert on header compression by any means
>	but based on my several discussions with some experts in
>	the area, I was told that ROHC will handle tunnelling 
>	and Extension headers at no extra cost over the air.
>
>	So if this true,I wonder if tunnelling is a problem.
>

Right, the issue isn't whether compression will handle them, it is the overhead
in reestablishing the state after handover.

>> I do not
>> get the feeling from the Seamoby context transfer problem statement
>> draft that this is possible.
>> 
>	=> I haven't looked into it in detail, have you
>	heard of some reasons ?
>	Perhaps this context transfer discussion needs to be 
>	taken to the seamoby list, but I'm wondering what 
>	the negative impacts are if we do not transfer the 
>	context for header compression. In the worste 
>	case scenario I am told that maybe 2 or 3 packets
>	will be sent with a full header. But that doesn't 
>	mean loss of service, just a short period of inefficiency
>	over the air. Is that true ? Does anynoe know more about 
>	this ?
>

I have heard more than 2 or 3 packets, but I do not know for sure.
Perhaps we can bring this up during the Seamoby meeting next week.

		jak

---

From: Claude Castelluccia <[email-masked]>
Date: Fri, 16 Mar 2001 11:00:20 +0100

> in reestablishing the state after handover.

So this is not a problem of HMIPv6...this is a more general problem? You get this
problem
whenever you are performing header compression...

regards,
Claude.

--

----------------------------------------
Claude CASTELLUCCIA, INRIA Rhone-Alpes
ph:  +33 4.76.61.52.15 (fax: 52.52)
http://www.inrialpes.fr/planete/