Subject: [mobile-ip] [seamoby] RE: [rohc] RE: Restarting Compressor on Mobile IPv6 Handover

From: Michael Thomas <[email-masked]>
Date: Thu, 29 Mar 2001 11:06:05 -0800 (PST)

[email-masked] writes:
 > (Side note: for hisorical and technical reasons, dealing with 
 > realtime VBR over radio links is much a headache than over wired 
 > links. )

   A-ha! That's one of the reasons I question whether
   ROHC is even appropriate on the air except in a
   very small subset of cases (usually long lived streams
   like RTP for which it was originally intended) As
   a general purpose tunnel/header compressor, I suspect it is going
   to have severe thrashing with the way that radio
   resources are doled out by the AP.

	     Mike

---

From: Michael Thomas <[email-masked]>
Date: Thu, 29 Mar 2001 15:02:22 -0800 (PST)

Dr. Carsten Bormann writes:
 > I'm not sure why you are saying that (apart from the fact that we haven't
 > really done anything else but ROHC RTP yet).  How is ROHC worse than
 > uncompressed IP or 2507-compressed IP?

Carsten,

My understanding about cellular traffic channels
-- and I would be happy to find out differently --
is that they do not deal well with variable rate
traffic well. This is unsurprising since they are
heavily optimized for voice traffic which has very
regular periodicity and payload sizes. DOCSIS
cable is somewhat similar (with which I'm much
more familar), and the fixed size slots cause
variable rate coders like CRTP and ROHC much grief
because the MAC scheduler does not have the
ability to occassionally allow larger packets in
real time on an unsolicited grant SID; if you
start a session with packets every 20ms with 80
bytes of payload, that's exactly what you get. If
you occasionally need to send 81 bytes, you cannot
send it on that traffic channel.

This presents a real problem for CRTP and ROHC
when they need to send full headers or first order
changes.  For this reason, the cable folks perform
what they call Payload Header Suppression instead.
Basically, it's just a first order compressor
which is always on (sorry, if I've got your
nomenclature mixed up). This obviously works, but
is not as efficient. Also, I have no idea how it
compares in robustness.

Now, it may be that the cellular MAC's and PHY's
need some retooling in the long run in which case
ROHC will work better, but if they work like I
think they do, it's going to be problematic in the
intervening time.

		Mike