Subject: [mobile-ip] length field

From: "Mohamed Khalil" <[email-masked]>
Date: Tue, 27 Mar 2001 14:21:21 -0600

All,

to remove the confusion of interpreting the meaning of the length field in
MIER and GNAI, we will change the definition slightly  as follows:

MIER:

Length 
 
   8-bit unsigned integer. Length of the extension, in octets,
   excluding the extension Type and the extension Length fields.
   This field MUST be set to 1 plus the total length of the data field.

GNAI:

Length

   8-bit unsigned integer. Length of the extension, in octets,
   excluding the extension Type and the extension Length fields.
   This field MUST be set to 1 plus the total length of the NAI field.

MK

---

From: Phil Roberts <[email-masked]>
Date: Wed, 28 Mar 2001 08:27:40 -0500

-----Original Message-----
From: Mohamed Khalil [mailto:[email-masked]]
Sent: Tuesday, March 27, 2001 3:21 PM
To: [email-masked]'
Subject: [mobile-ip] length field

All, 

MIER: 

Length 
  
[Phil Roberts] 

I'm assuming this is the Length field for the short extension only?

GNAI: 

Length 

MK

---

From: "Mohamed Khalil" <[email-masked]>
Date: Wed, 28 Mar 2001 09:10:41 -0600

-----Original Message-----
From: Phil Roberts [mailto:[email-masked]]
Sent: Wednesday, March 28, 2001 7:28 AM
To: [email-masked]'
Subject: RE: [mobile-ip] length field

-----Original Message-----
From: Mohamed Khalil [mailto:[email-masked]]
Sent: Tuesday, March 27, 2001 3:21 PM
To: [email-masked]'
Subject: [mobile-ip] length field

All, 

MIER: 

Length 

MK> yes

GNAI: 

Length 

MK