Subject: RE: [mobile-ip] Final Agenda for Mobile IP WG meeting at IETF50

From: [email-masked]
Date: Wed, 14 Mar 2001 08:54:46 -0600

Michael,

> Can I ask why we are discussing solution space for QoS
> when the requirements aren't even known?

The requirements may not be explicitly stated as such.  The requirements
for QoS from a Mobile IP perspective are as follows:

1. If QoS has been established for a session between an MN and CN, how do
you
    deal with it when the MN changes it's point of attachment, and as a
result the path of the
    packet flow changes
2. What are the implications on QoS for a session w.r.t fast handoffs. 
3. More? I am not sure.

-Basavaraj

> 
> [email-masked] writes:
>  > 
>  > Final agenda for the Mobile IP WG meeting at IETF50
>  > 
>  > Thursday March 22nd - 9:00 AM - 11.30 AM
>  > ----------------------------------------
>  > 
>  > Agenda bashing					5 Mins
>  > WG Doc Status					5 Mins
>  > 
>  > MIP at Connectathon - Report			5 Mins
>  >  - Alper Yegin
>  > 
>  > Mobile IPv6 Discussion				30 Mins
>  >  - Issues related to using IPSec 
>  >    for binding updates   Jeff Schiller 10 Mins
>  >  - Discussion of draft-bradner-pbk-frame-00.txt
>  >    Jeff Schiller 5 Mins
>  >  - Discussion	 15 Mins
>  > 
>  > Handoffs - Panel discussion			50 Mins
>  >  - V6 handoff design team 20 Mins
>  >  - V4 handoff design team 20 Mins
>  >  - (draft-gwon-mobileip-l3mp-mipv4-00.txt)
>  >    Youngjune Gwon 10 Mins
>  > 
>  > Hierarchical Mobility Schemes			15 Mins
>  >  - HMIPv6 (draft-ietf-mobileip-hmipv6-02.txt)
>  >    Hesham Soliman 8 Mins
>  >  - Comparison/Discussion with 
>  >    draft-malinen-mobileip-regreg6-01.txt 7 Mins
>  > 
>  > Dynamic configuration of Mobile hosts		15 Mins
>  >  - Sandy Thuel 
>  >    draft-thuel-mobileip-tt-01.txt 8 Mins
>  >  - Steve Glass
>  >    draft-glass-mobileip-agent-dhcp-proxy-01.txt 7 Mins
>  > 
>  > QoS Discussion					10 Mins
>  >  - draft-chaskar-mobileip-qos-01.txt
>  >    Hemant Chaskar
>  > 
>  > WG Charter review				10 Mins
>  > 
>  > 
>  > 
>

---

From: Michael Thomas <[email-masked]>
Date: Wed, 14 Mar 2001 11:04:43 -0800 (PST)

I understand that, but this draft in particular is
positing a completely different way to perform
signaled QoS admission control which has global
implications: CN's and interior routers would need
to implement this as well.

As you may know, I've spent a fair amount of time
trying to figure out what the implications of our
current signaled QoS admission control scheme --
RSVP -- are with MIP and I can tell you as a very
quick summary that positing a completely different
signaling scheme is *far* too premature. It would
be much, much better to analyze what the current
state of affairs is and compare that to MIP
requirements before we decide whether a specific
solution is in order. In fact, even if it is, I
cannot imagine that the MIP WG is the right place
to pursue this.

I have volunteered to discuss my analysis (draft-
thomas-seamoby-rsvp-analysis-00) and will do so
again at this point, but even if you don't take me
up on this, I cannot see what will be productive
about discussing this draft for the second IETF
in a row: all of the same arguments of scope
and wholesale reinvention apply.

	  Mike