Subject: [mobile-ip] Date: Fri, 16 Mar 2001 01:42:26 +0100

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 15 Mar 2001 16:42:41 -0800 (PST)

Yes - there is no accepted or even tabled proposal yet for route optimal location privacy. I believe it is a requirement even MIP should strive for as we move forward.

	=> I agree. The problem is that your IP address is the one piece of 
	information needed to route packets to you. So if you want to 
	hide your true location by telling the CN to send packets to another
	IP address, then you need to compromise between location
	privacy and optimal routing. 

	One extreme would be to always use your Home Address, however
	the optimisation of the route will depend on how far you are from
	the HA. However you could argue that even if you do not 
	send BUs to the CN to achieve location privacy, the 
	CN can still know your real address from the source address on your 
	packets. 
	Even if you hide that (like in the case of reverse tunnelling from the 
	FA in MIPv4) a CN who wants to find your location can do a 
	trace route and find you ! Unless you disable the application in
	your HA of course. 

	So, I agree it's a hard problem.

	  Hesham

---

From: "Glenn Morrow" <[email-masked]>
Date: Fri, 16 Mar 2001 09:01:56 -0600

Hesham,

Some more excellent points. I am actually quite positive that tracert would
have to change in order to achieve the functionality. I am very open to
other suggestions.

Thanks,

Glenn

-----Original Message-----
From: Hesham Soliman (ERA) [mailto:[email-masked]]
Sent: Thursday, March 15, 2001 6:43 PM
To: [email-masked]'
Subject: [mobile-ip] Date: Fri, 16 Mar 2001 01:42:26 +0100

	Yes - there is no accepted or even tabled proposal yet for route
optimal location privacy. I believe it is a requirement even MIP should
strive for as we move forward.

	Even if you hide that (like in the case of reverse tunnelling from
the 

	  Hesham