Subject: RE: [mobile-ip] Re: hmip and mobile routers

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 8 Mar 2001 00:51:07 +0100

I don't know if this mail will make it, but I'll try.

I'm not sure who sent the original mail because I 
only received Thierry's response.

> > Section 6 describes a mechanism of how mobile
> > routers might be supported by HMIP. However, I
> > think there is a fundamental category error being
> > made here. Namely, it is expected that behind the
> > mobile router are, in fact, mobile nodes.
> 
	=> There is no error in that. If they are not mobile 
	nodes then HMIPv6 does not solve that problem.
	Clearly there are two cases to consider, 

	a) the nodes behind a router have (H)MIPv6 implementation
	b) They don't

	HMIPv6 addresses a and not b. Thierry's draft 
	addresses b and not a. In case "a" if the MNs 
	use HMIPv6 they will receive route optimised 
	traffic. In the other case they won't
	Both solutions an definitely coexist. The MR
	can always update its HA with the entire 
	mobile network's prefix. Also the MN's attached
	to it can update the CNs/other MAP about their
	COA.

> > reason why this expectation should be made: there
> > is no reason why a non-mobile widget, say a PC,
> > should not be able to be attached to a mobile
> > router on a moving train. 
> 
	=> Yes that's possible, we don't address this case. 

> As currently defined,
> > mobile IP is only a requirement if the device
> > (router, host) is itself mobile. I do not see why
> > we should expand that requirement to anything
> > which is *behind* something that is mobile. In
> > fact there could be a huge downsides to doing so,
> > not to mention a whole lot of uncharted territory.
> 
	=> What is the down side ? This is an unfinished
	statement. 

> > Also: what happens if there is more than one
> > router in between MR and the stationary host
> > in MR's subnet? 
> 
	=> The MAP option is propagated as usual.

> What happens if there's more
> > than one MR? 
> 
	=> What happens if there is more than one AR ?

> What delineates "my" MR versus
> > somebody else's MR?
> 
	=> What delineates my AR vs someone else's
	AR ? Not a MIP issue.

> > It's possible I'm misreading that section, but if
> > I am it's probably because the section doesn't say
> > what needs to happen when the mobile router itself
> > moves. 
> 
	=> The section says that the MAP (MR) sends a MAP
	option to the "mobile network" with its on link
	CoA (LCoA) as the MAP address. 
	Does it need more explanation ? We can add 
	more.

> > However, even if nothing catastrophic
> > happens, my original issue still stands:
> 
> 
> > non-mobile hosts shouldn't be forced to become
> > mobile aware by virtue of a mobile router some
> > arbitrary number hops away.
> 
	=> Does the draft say that ? Please let us know 
	where it does so we can remove that assumption.

	Hesham

---

From: Michael Thomas <[email-masked]>
Date: Wed, 7 Mar 2001 17:41:06 -0800 (PST)

> only received Thierry's response.

   C'est moi.

 > 	a) the nodes behind a router have (H)MIPv6 implementation

   Yes, but they could just as easily be mobile nodes
   behind mobile routers where the mobile router functions
   as a home agent for those mobile nodes, ad infinitum.
   I don't think that HMIP brings much special to that
   situation: any place that you could put MIP, you
   can also put HMIP, but that should go without saying.
   In other words, this doesn't look any different
   that multiple layers of hierarchy.

   Case (b) is what I would consider to be the "mobile
   router" problem.

 > 	addresses b and not a. 

   Thierry's draft addresses one aspect of (b), but
   probably not the whole story. It may have gotten
   lost in the email meltdown, but I wrote a long
   post about some of the detrimental aspects of
   the home address destination option, one of which
   is (b). I'll probably repost it.

 > 	=> What is the down side ? This is an unfinished

   Did you read the planet-earth-behind-a-mobile-
   router question? I thought it was part of this
   post, but maybe it got clipped by the time you
   saw it.

 > 	=> What happens if there is more than one AR ?

   Well, that's easy. I forward packets to the first one,
   and I immediately lose track of what happens from there on out.
   In the layered ([H]MIP) case, it would seem that each mobile
   might need to deal with binding updates to the
   HA for each time a mobile router moves too. 

   If this isn't what you mean, it's probably
   because the draft is unclear, and in either
   case it would be good to clean in up to be
   explicit with the interactions.

 > 	Does it need more explanation ? We can add 

    What is the mobile network? What happens if
    the mobile network in turn contains a mobile
    router? Is it a flood fill? What do the mobile
    nodes need to do when a mobile router of a 
    mobile router moves?

 > 	where it does so we can remove that assumption.

   The draft doesn't make a differentiation
   between (a) and (b). I'm not convinced that
   (b) is very well understood, however, but
   that's probably not HMIP's fault (other than
   claiming to support mobile routers and accidentally
   stepping on a large land mine).

	       Mike