Subject: RE: [mobile-ip] Re: Comments on Regional Registration

From: [email-masked]
Date: Thu, 15 Mar 2001 18:48:53 -0600

IKE requires too many messages to be exchanged so that may be not be the
most optimized solution to set up the security associations between the MN
and Mobility agents: IPsec WG is already designing a new protocol "Son of
IKE". 
In addition, IKE requires either PKI or a pre shared secret between the two
entities that are setting up the SA !
Do you believe that PKI will be ready soon ?
As for the pre-shared secret between the MN and Mobility agents, do you
think that such solutions is really scalable ?
For those reasons, we suggest to use AAA servers.

-----Original Message-----
From: ext Hesham Soliman (ERA) [mailto:[email-masked]]
Sent: 15 March, 2001 6:16 PM
To: [email-masked]'
Subject: RE: [mobile-ip] Re: Comments on Regional Registration

> It seems that in the HMIPv6 draft, you suggest to distribute the session
> keys either using IKE or AAA servers and to authenticate the BUs. The same
> solution can apply to Regional Registration: we suggest to use AAA
servers,
> so I don't think that it is more complex.
> 
	=> Please read your statement above carefully. You just said HMIPv6
	works with either IKE or AAA, but regional only works with AAA.
	I think that's a significant difference. 
	BTW the HMIPv6 draft only talks about AAA in terms of context
	transfer, not for SA establishment. We presented another 
	draft for that purpose and we certainly do NOT want to restrict
	the use of HMIPv6 to the AAA SA generation scenario.

> The only difference when using anycast address is in anti replay attacks:
We
> suggest to use nonces instead of the sequence number defined in AH.
> 
	=> Can you use IKE for a key exchange with an anycast address ???

	Thanks,
	Hesham

> -----Original Message-----
> From: ext Hesham Soliman (ERA) [mailto:[email-masked]]
> Sent: 15 March, 2001 10:10 AM
> To: [email-masked]'
> Subject: RE: [mobile-ip] Re: Comments on Regional Registration
> 
> 
> > >	=> I'm not at all trying to discredit anycastl. I'm just 
> > >	wondering how you could use it in light of the current
> > >	standards. You still didn't tell me what the solution 
> > >	is. 
> > >	Proposing a solution for setting up an SA with an
> > >	anycast group would be a great proposal, but 
> > >	I don't think we need several standards to solve
> > >	this particular problem. We already have a solution
> > >	and I'm starting to question the need for alternatives
> > >	if nothing is raised against HMIPv6. Especally if 
> > >	the alternative is a lot less robust and overrides 
> > >	the use of standard routing between the anchor point
> > >	and the MN.
> > >
> > 
> > actually that there are different proposals on the way to set up
Security
> > Associations and to authenticate the BU using AH in Appendix B of the
> draft.
> > 
> 	=> Yes I saw that, but this is hardly a standard or an accepted 
> 	method, I don't think we can base it on the appendix surely. 
> 	Even if we can, my main point is why are we adding all this 
> 	complication to achieve the same effect that HMIPv6 does ?
> 	I haven't heard an answer till now.
> 
> 	Hesham

---

From: Michael Thomas <[email-masked]>
Date: Thu, 15 Mar 2001 17:07:50 -0800 (PST)

> and Mobility agents: IPsec WG is already designing a new protocol "Son of

   IPsec WG is doing no such thing. They are *thinking* about
   Son of IKE, but nothing is definite now.

   Also: a categorical "too many messages" is a
   tautology. Whether the number of messages is
   excessive is highly dependent on where,
   when and how often. In particular, if SA 
   *establishment* is not in a critical path
   for handoffs, its doubtful that "too many"
   applies.

 > Do you believe that PKI will be ready soon ?

   You really only get into trouble when you start positing
   global PKI's. Crypto using PKI's which do not
   have global implications are currently shipping.

 > For those reasons, we suggest to use AAA servers.

   AAA is *not* the only other choice. In fact,
   using AAA for key distribution isn't even
   standard (yes, Pat, I mean that. a draft is
   not a standard and this area could and should
   change considerably before DIAMETER is
   baked). The current IETF protocol for
   symmetric key distribution is Kerberos.

	     Mike

---

From: Mohan Parthasarathy <[email-masked]>
Date: Thu, 15 Mar 2001 17:19:32 -0800 (PST)

>    for handoffs, its doubtful that "too many"
Agreed. Hopefully, you should not be negotiating SAs that often. In
fast handoffs, you may typically want to forward packets from the
previous care of address as mentioned in the MIipv6 draft (i have
not read the fast handoff draft). This makes you send a binding update
to the previous router. If this needs to be protected using IPsec,
you have to negotiate SAs as you move and also it is during the
fast handoff. May be we can use a different scheme in this case.

-mohan