Subject: RE: [mobile-ip] Re: Comments on Regional Registration

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 15 Mar 2001 01:52:40 +0100

Hello Charlie, 

> We want to get the routing part figured out, and I believe
> we have a pretty good handle on it.
> 
> Setting up security will allow a mobile node to provide
> authentication data that can be checked by one of the
> anycast group members.  I know several ways to do that.
> It will be more productive to start on that task once two
> other things are out of the way:
> - Fixing the authentication mechanism for base Mobile IPv6
> - Getting the routing part figured out.
> 
	=> I don't understand what needs to be solved on the 
	routing aspect of the problem ? Do you not like 
	the routing provided by HMIPv6 ? If so why ?
	We use standard IP routing between the MAP and 
	the MN or the CN for that matter. I think it's as solved 
	as Internet routing today is.

> If you wish to disqualify all anycast-based solutions because
> there are no standards for establishing security between a
> node and the members of an anycast group, then I would
> just prefer to say that we believe the problem is wholly
> solvable for the particular anycast group we have designed.
> We don't intend to get in the business of solving it for the
> general case.
> 
	=> I'm not at all trying to discredit anycastl. I'm just 
	wondering how you could use it in light of the current
	standards. You still didn't tell me what the solution 
	is. 
	Proposing a solution for setting up an SA with an
	anycast group would be a great proposal, but 
	I don't think we need several standards to solve
	this particular problem. We already have a solution
	and I'm starting to question the need for alternatives
	if nothing is raised against HMIPv6. Especally if 
	the alternative is a lot less robust and overrides 
	the use of standard routing between the anchor point
	and the MN.

	Thanks,
	Hesham

> "Hesham Soliman (ERA)" wrote:
> 
> >         Hello Charlie,
> >
> > >
> > > > GM> I agree, I support anycast too. To vilify a solution which employs
> > > > it as magic was wrong and I apologize.
> > >
> > > No need for apology, but I wanted to point out that this particular
> > > use of anycast is easy to implement, assuming that one's IPv6
> > > implementation supports anycast at all.
> > >
> >         => I'm a bit confused by this statement. How can it be easy
> >         to implement a BU to an anycast address ?
> >         BUs have to be secured with AH, so how can you setup this
> >         security association when there are no standards defined
> >         to do so ?
> >
> >         Regards,
> >         Hesham

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 14 Mar 2001 21:16:55 -0800

Hello Hesham,

>         the routing provided by HMIPv6 ? If so why ?

I think it's important to support more than one level of
regionalized care-of address, at least for the organization
of mobility management we have in mind for "All-IP"
networks.

I also like that anycast addressing allows the mobile node
to accomplish the regional binding update without having
to know about the topology of the visited domain.

>         the use of standard routing between the anchor point

Your statement is near tautological.  Of course, we'd also
like to arrive at a robust protocol that uses as much
standard routing as is possible.  We also wish to allow
betterm localization of binding updates than HMIPv6 could
provide.  That can translate into better scalability for the
foreseeable future.

Regards,
Charlie P.