Subject: RE: [mobile-ip] home agent discovery question

From: "Powell, Ken" <[email-masked]>
Date: Thu, 3 May 2001 14:37:57 -0400

> -----Original Message-----
> From: Michael Thomas [mailto:[email-masked]]
> Sent: Thursday, May 03, 2001 1:29 PM
> To: [email-masked]
> Subject: [mobile-ip] home agent discovery question
> 
> 
> Powell, Ken writes:
>  > >    The CN can form the HA's address by forming a 
>  > >    Home Agents Anycast address as described in -13.
>  > >    As for how do you know that the HA is sending
>  > >    the information -- just as well as the CN knows
>  > >    that the MN is sending the information. Meaning,
>  > >    to the degree you trust the integrity of the
>  > >    routing system, you can trust replies from the
>  > >    MN's home agent about as much as replies from
>  > >    the MN itself.
>  > 
>  > This may not work if there are multiple home agents
>  > on the home network. I expect a home agent will be
>  > able to support authentication of the mobile node
>  > only if it has a current home registration binding
>  > for that mobile node. Any message sent to the home
>  > agent's anycast address could go to any of the home
>  > agents on the network, not necessarily the one
>  > with the mobile node's home registration.
> 
>    I would think that that would affect home agent
>    discovery in general.

Not really. When a mobile node does home agent discovery,
it has no home registrations and needs to find a home
agent so it can create one. In this case, any available
home agent on the home network will do.

>    That said, Steve Deering mentioned
>    to me a while ago that he didn't see how the
>    home agent anycast couldn't be formed without
>    the knowledge of the subnet mask to form the
>    prefix correctly. So is the implication that 
>    the mobile node not only needs to know its home
>    address, but the subnet prefix as well when
>    it's doing home agent discovery?

You are right, that a mobile node needs to know the
home subnet prefix length to generate a home agent
anycast address from its own home address.

Normally a mobile node will have both during normal
operation. If a mobile node looses communication with
its current home agent (perhaps the home agent crashed),
it makes sense to use this information to generate the
home agent anycast address and find a new home agent.

On the other hand, when a mobile node boots on a remote
network, it's previously configured home address may have
timed-out. In this case, it should have another technique
to find the home agent anycast address. Appendix B of the
mobile IPv6 spec says this could be handled by storing the
anycast address in DNS.

>    This all sounds rather, well, not very
>    automatic to me, and would have problems with
>    renumbering, etc, etc.

I agree that we want automatic home address
autoconfiguration and renumbering to work. Many of
the details are beyond the scope of the spec.
Appendix B provides one possible approach. T.J.
Kniveton is working on a better method.

Ken

---

From: "T.J. Kniveton" <[email-masked]>
Date: Thu, 03 May 2001 11:59:00 -0700

> home agent on the home network will do.

Wait a minute.. the home agent discovery message might only be
*received* by one home agent, but that home agent will *reply* with the
addresses of all home agents on the link (i.e. the home agent list).
 
> mobile IPv6 spec says this could be handled by storing the

Yes, there was a fair bit of discussion about this a couple of months
ago, but unfortunately the mobile-ip list was fibrillating at the time.

And yes, it is true, that the mobile node must at all times be able to
figure out, at the bare minimum, what its home network prefix is.
Everything else can be bootstrapped from that point.

In 99% of cases, the MN will be configured and the prefix is simply
cached/in context. When the MN is configuring its home address and
doesn't have one cached, i.e. a truly stateless device..or a MN
awakening after a prefix renumbering.. it will have to rely on some
outside authority to retrieve its home prefix. It seems DNS is a good
choice, as Ken has suggested (I believe it's Appendix A, actually?)
> Kniveton is working on a better method.

When I have some free time (grin), I'd like to work out a good approach
to this. As we've discussed before, there is a really prickly problem
which is that IPv6 addresses behave a bit differently than 'v4
addresses, and you can't rely on them for the same properties (such as
prefix stability). I wonder if Steeve Deering would have some comments
on this subject. It might be nice to have some sort of discussion at the
next IETF on renumbering in general, and how it applies to mobility in
particular.

-- 
T.J. Kniveton
NOKIA Research