Subject: RE: [mobile-ip] LMM Requirements

From: Phil Roberts <[email-masked]>
Date: Tue, 1 May 2001 14:38:16 -0400

The advantage in having an I-D that documents the requirements is that you
can easily point to it rather than dragging a thread out of the email
archives.

> -----Original Message-----
> From: Behcet Sarikaya [mailto:[email-masked]]
> Sent: Tuesday, May 01, 2001 2:45 PM
> To: [email-masked]
> Subject: Re: [mobile-ip] LMM Requirements
> 
> 
> This is the requirements fashion.
> Throw away a few items and then collect them in
> I-D format and get them RFCed.
>   IMHO it is for
>      nothing.
>   but probably seamoby mania.
> Remember many protocols including Mobile IP were developed
> with no requirements RFCs.
> 
>   I would call upon a stop on this instead. HMIP people already issued
> a new version. The stage is there for any competing protocols.
> 
> [email-masked] wrote:
> 
> > We've asked Carl Williams to pull together the requirements 
> for LMM that
> > have
> > been agreed upon here into an I-D with some explanatory 
> text.  Thanks to
> > Carl for
> > taking on this responsibility.  We hope to see them in an 
> I-D form in 2-3
> > weeks.
> >
> > If you would like to provide additional requirements, 
> please feel free to
> > send them
> > to Carl or to discuss them on the list.
> >
> > We would also like some feedback on whether or how having a 
> particular draft
> > on LMM
> > as a working group item effects the requirements making 
> process.  Are there
> > example requirements that might be considered if the HMIP 
> draft were not
> > already in place as the working group draft?
> >
> > Basavaraj
> > Phil
> 
> My 0.002 cents.
> 
> --behcet
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 01 May 2001 15:53:04 -0500

But Phil you already posted the final form of the requirements in
one of your earlier emails. One can always refer to that online document.

Theo: I agree but please agree to it that it IS wishful thinking.

--behcet

---

From: Pat Calhoun <[email-masked]>
Date: Tue, 1 May 2001 13:43:33 -0700

> can easily point to it rather than dragging a thread out of the email

and it is much easier to evaluate concensus when there is a document on
which a chair can do a last call. This is, after all, how many IETF WG
work.

[snip]

> > I-D format and get them RFCed.

No one said anything about actually publishing the document. The idea is
that a chair can do a last call on a document. It is a hell of alot
harder to do a last call on an e-mail. The IETF doesn't work that way.

> >      nothing.

I guess we are all entitled to our opinions...

> >   but probably seamoby mania.

hmmm... I have resisted the temptation to reply to your other seamoby
management basing e-mails, but perhaps I should defend myself now in order
to minimize the possibility of any future flames you seem to enjoy writing.

Given that I have been contributing in the IETF a hell of alot longer than
you have, I have seen many WGs document requirements prior to actual
protocol design.

In fact, I would point you to probably the most important of requirement
documents, RFC 1122 and RFC1123, which are in fact full standards. Doing a
quick search in RFC archives, I found 50 published requirements RFCs, so
this isn't seamoby mania.

Now, for those of us that are willing to have a WG review, and modify,
a particular proposal, this isn't a problem. We in fact prefer to create
a protocol that has WG concensus, and therefore will have wider deployment
(and perhaps even applicability).

Then there  are those that prefer that WGs simply rubber stamp their
protocol...

> > with no requirements RFCs.

Remember that the protocol work was initiated over 8 years ago. Things 
change. Networks and protocol become more complex. Furthermore, people
have found many things that they would like to see in MIP, and
we have also found some deficiencies. Don't get me wrong, I do like
Mobile IP, but a protocol design phase without requirements is NOT
necessarily something that we should all strive for.

Basic protocol design, IMHO.

PatC

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 01 May 2001 16:17:38 -0500

I try always to write the correct things or objective
observations, not flames whatever that means.

--behcet