Subject: RE: [mobile-ip] a few more FMIP comments

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Mon, 14 May 2001 11:14:17 +0200

I haven't seen any reply to this.

> 1) ESP friendliness: currently there is text in the
>    draft which speaks of AH headers, but nothing about
>    ESP headers. We should make the language neutral
>    as well as fix any dependencies on AH itself (beyond
>    the BU's which is a seperable issue). This may 
>    require source addresses to be carried in the
>    router solicit/advertizements itself, rather
>    than expecting them to come from outer IP
>    header. Frankly, this is just good modular
>    design.
> 
	=> There is not much in the MIPv6 draft either, so
	why should this be different.

> 2) I have a question as to whether anybody
>    considered combining the Proxy Router
>    Solicit functionality with the binding
>    update for the mobile initiated handoff.
>    Considering the mobile is probably moving
>    out of range, this seems like it's a 
>    pretty critical time and the fewer
>    messages required, the better. As a
> 
	=> A BU to where ? unless you get the proxy
	RA you don't know where you're going 
	so what do you bind the address to ?

	If you mean just a BU that says "buffer packets", 
	then this is not what the BU is used for 
	and there are no semantics for that. 
	Do you think it should be used that way ?

>    MN              oldAR              newAR
>    BU+XOFF+RS------->
>                     [HI---------------->]
>                     [<--------------HACK]
>    <---------BUACK+RA
	=> You'll need another BU though to tell the 
	old AR where you are ?

>    Where XOFF is the buffer bit (to stop packets
>    from flowing) and RS and RA are the pertinent
>    parts of the Fast MIP solicit/advert payloads?
> 
	Hesham

---

From: Michael Thomas <[email-masked]>
Date: Mon, 14 May 2001 08:29:03 -0700 (PDT)

> 	why should this be different.

  Well, unless there is some specific reason to specify AH, 
  it should just say "IPsec protected" or something like
  that. If that's a comment against the -13 draft as well,
  so much the better.

 > 	so what do you bind the address to ?

   Correct. It would require that the BU be able to
   have a mode which allows ARold to pick the new
   CoA (possibly by the HI/HACK). It could transport
   the picked address back in the Alternate CoA in
   the BU. It would sort of be like a DHCP request :-)

 > 	and there are no semantics for that. 

   Actually, after it assigned the address it would be
   a normal BU: the XOFF bit would operate independently.
   This could be used, for example, with CT and where you
   have the ability to tune two radios.

 > 	Do you think it should be used that way ?

   It does seem that combining the functionality
   gives better on-the-air messaging. As I said earlier,
   the number of messages right before it hands over,
   is probably an important thing to consider, less
   being better. If the modularity isn't *too* awful,
   it would seem worth it, IMO.

	    Mike