Subject: RE: [mobile-ip] host routes in the fast mipv6 draft

From: Alper Yegin <[email-masked]>
Date: Thu, 17 May 2001 18:05:04 -0700 (PDT)

> Alper Yegin writes:
>  > Jim,
>  > 
>  > > The draft is very unclear about how and when tunnels are set up. 
>  > > The term "host route" is used to refer to a tunnel being set up.
>  > 
>  > That shouldn't be the case. As George explained out earlier, host routes 
are 
>  > created on the newAR, to point to MN's oldCoA. They are not used on oldAR, 
or 
>  > for tunnels. If you can point us where draft says or implies so, we can fix 
it.

Mike,

> 
> Alper,
> 
> I don't see how this can possibly work unless the
> route is also installed on ARold. Otherwise it
> forward it out the wireless interface as usual.

I should be clear on this. [I thought Jim was referring to host routes on 
newAR]. Yes, a host route is created on the oldAR, that points to the tunnel 
created. So, packets whose destination address is oldCoA will be forwarded to 
this tunnel per this host route. This is what happens when we "forward from a 
previous care-of address". Also same story on Home Agent for home addresses.

And if the tunnel end point is not newCoA but newAR, then another host route is 
created on the newAR to deliver packets to MN at it's topologically incorrect 
oldCoA address (attached to a link on newAR).

> 
> As I've said before, I'm sort of worried about how
> this interacts with other routing protocols, and
> especially how it converges when the routes are
> deleted. What would happen, for example, if the
> host route were propogated by OSPF while the
> tunnel was up?

This must be preventable. Otherwise same OSPF might also propogate the host 
routes (for home addresses) on the Home Agent.

alper

---

From: Michael Thomas <[email-masked]>
Date: Mon, 21 May 2001 13:23:21 -0700 (PDT)

> routes (for home addresses) on the Home Agent.

   This is why I'm worried about this feature of the
   FMIP draft altogether as I don't get the impression
   that the ideas are fully baked. You say that it
   must be prevented, but in fact, if it were propogated
   it would produce least cost routing, and bypass 
   ARold altogether. Under normal circumstances,
   that would be a Good Thing. 
 
   Also: I generally think that this is going
   into the same design territory that got moved
   into the IRTF for the micro mobility work. I
   think there's more at stake here than meets
   the eye.

	Mike