Subject: RE: [mobile-ip] host routes in the fast mipv6 draft

From: George Tsirtsis <[email-masked]>
Date: Mon, 14 May 2001 14:14:29 -0400

-----Original Message-----
From: Michael Thomas [mailto:[email-masked]]
Sent: Monday, May 14, 2001 5:53 PM
To: [email-masked]
Subject: [mobile-ip] host routes in the fast mipv6 draft

I notice that there is provision for installation
of host routes in ARnew if there is a problem with
the IP address the MN wants to use. Two comments:

1) This should not be host route specific since
   there's now provision for moving prefixes

GT> True enough...we should change that.

2) I don't see how this can work as stated. Since
   there's no communication with the intermediate
   routers before the join point, MN's traffic
   will go to ARold first. That implies that there
   would need to be route to MN on ARold as well
   as ARnew. If that's what was intended, it
   should be clarified.  Also: it seems a little
   vague on when the route should be deleted,
   and how the two routers would synchronize.

   I generally question where this requirement
   came from. It seems like it toes the micro
   mobility IRTF line pretty strongly. Would
   there be much harm from just omitting this?
   It doesn't seem to be part of the central
   mission of FMIP.

GT> I think you are missing something here...The host route is used when the
MN needs to use its oldCOA at the newAR. In this case the oldAR needs to
tunnel packets with destination oldCOA to the newAR. The host route (for
oldCOA) is not to be installed anywhere but the newAR...The newAR needs a
route in its routing table pointing towards its wireless interface for the
MN so when packets get tunneled to it (from oldAR), the newAR is able to
delivere them to the MN over the air rather than send them back to the
oldAR...
NOTE: This has nothing to do with micromobility (and/or any of its
denominations)

I this clearer?

George

---

From: Michael Thomas <[email-masked]>
Date: Mon, 14 May 2001 13:30:52 -0700 (PDT)

> I this clearer?

   Nope, I'm really confused now :-)

   Did you actually mean a tunnel between ARold
   and ARnew? I didn't see that anywhere. The
   normal forward tunnel is between ARold and MN,
   afterall. 

   In either case, however, ARold needs
   to place the route in its database as well as
   ARnew. Otherwise, it will keep routing the
   packets out the old (wireless) interface as
   normal, which is obviously not what you'd want.
   I think this is what you're trying to say
   above, but you should probably make it clear
   about the side effect on ARold as well.

	     Mike