Subject: Re: [mobile-ip] MIPv6: Ping-pong between ARs ?

From: Alper Yegin <[email-masked]>
Date: Wed, 30 May 2001 11:42:57 -0700 (PDT)

> Hi all,
> 
> I have a question regarding section "10.9 Establishing forwarding from a
> previous coa" in the MIPv6 spec.
> 
> MN has a COAa on foreing link La
> Then, MN visits foreign link Lb and has COAb
> The specs says that MN may send a BU (COAa -> COAb) to a HAa on foreign
> link La
> Then, MN goes back to link La, and sends a BU (COAb -> COAa) to a HAb on
> foreign link Lb

(not that spec says this, but logically) MN should first send a deregistration 
to HAa, so that it stops tunneling packets to CoAb, but instead forwards them 
directly to MN which is on-link now.

After then, MN can send a BU to HAb to get it's traffic tunneled to CoAa. And it 
should do this only if Mn had sent a BU to HA or CNs using its new CoA, CoAb. 
Otherwise, deregistration sent to HAa should be sufficient.

alper

> 
> What happens if the entry in HAa has not yet expired ?  Any packet sent
> to COAa or COAb enters a routing loop, right ?  Or am I missing
> something ?
> 
> If this is right:
> - what is the experience gained from the implementations ?  
> - Does some implementations establish forwarding from the previous
> care-of address ?  
> - How is this routing loop fixed ?
> - Is section 10.9 going to be amended to address this issue ? 
> 
> 
> Thanks,
> Thierry.
> 
> 
> --
> * mailto:[email-masked]  Tel +33 (0) 4 76 61 52 69 
> * INRIA Rhone-Alpes Projet PLANETE       (fax 52 52) 
> * and MOTOROLA Labs Paris
> * http://www.inrialpes.fr/planete/people/ernst/Welcome.html

alper

---

From: Mattias Pettersson <[email-masked]>
Date: Wed, 30 May 2001 21:46:40 +0200

> Otherwise, deregistration sent to HAa should be sufficient.

Also, when MN turns back to link La, it should do a DAD check for COAa.
HAa is defending that, so the MN must use the same complicated rules for
de-registering that temporary home address as with ordinary home
addresses.

Our (Ericsson) implementation creates a temporary home address out of
COAa with a short lifetime. It lives it's own life independent of the
ordinary home address. La is considered the home link by this temporary
home address and thus de-registration will take place.

COAb is of course treated the same way.

/Mattias