Subject: RE: [mobile-ip] host routes in the fast mipv6 draft

From: James Kempf <[email-masked]>
Date: Tue, 15 May 2001 14:23:31 -0700 (PDT)

Mike & Alper,

>
>Alper Yegin writes:
> > >    In either case, however, ARold needs
> > >    to place the route in its database as well as
> > >    ARnew. Otherwise, it will keep routing the
> > >    packets out the old (wireless) interface as
> > >    normal, which is obviously not what you'd want.
> > 
> > Whether packets destined to oldCoA are tunneled to newCoA or newAR, there 
needs 
> > to be a state on oldAR. Something like "send all packets destined to oldCoA 
> > through tunnel100". In one case tunnel100's end point will be newCoA, in 
other 
> > newAR.
>
>Alper,
>
>Understand that I wasn't on the design team, so
>I'm looking at this sort of like an outside reader
>would look at it. I didn't see where/how the
>tunnel would be terminated on ARnew in the draft.
>Did I miss something? This would be new
>functionality in ipv6 since it sounds like it's
>mimicing v4 FA functionality.
>

The draft is very unclear about how and when tunnels are set up. 
The term "host route" is used to refer to a tunnel being set up.
I've actually never heard the term host route used in this fashion.
Typically, a host route means "even though the dest address doesn't
match the subnet structure topologically, route the packet this way." 
With a tunnel, the dest address will always be topologically correct.

		jak

---

From: Michael Thomas <[email-masked]>
Date: Wed, 16 May 2001 09:02:11 -0700 (PDT)

> With a tunnel, the dest address will always be topologically correct.

Jim,

There seems to be something of a mythology
surrounding the phrase "host routes" that I don't
think they deserve. A host route is nothing more
than a subnet with a /32 or /128 (v4, v6) subnet
mask. They aren't treated by routers any
differently beyond that (ie, they still use the
longest prefix match algorithm). Also: there's
nothing which says that prefixes must be strictly
hierarchical; indeed that is far from the reality
of the current net with its 70k+ prefixes
advertised by BGP and growing.

There is some valid concern about the scalability
of small subnets -- host routes being the
pathological case, but a huge number of /64's or
even /48's wouldn't be good for the net if they
didn't aggregate either. Within a confined bounds,
however, it's mainly the size of the interior
router's routing table you're willing to populate,
as well as the signaling overhead and convergence
times of your network that need to be considered.
Disaggregated small subnets (especially for v6
/64's, say) would have all of the same
considerations though.

	 Mike