Subject: RE: [mobile-ip] host routes in the fast mipv6 draft

From: Alper Yegin <[email-masked]>
Date: Mon, 14 May 2001 18:01:40 -0700 (PDT)

>  > GT> I think you are missing something here...The host route is used when 
the
>  > MN needs to use its oldCOA at the newAR. In this case the oldAR needs to
>  > tunnel packets with destination oldCOA to the newAR. The host route (for
>  > oldCOA) is not to be installed anywhere but the newAR...The newAR needs a
>  > route in its routing table pointing towards its wireless interface for the
>  > MN so when packets get tunneled to it (from oldAR), the newAR is able to
>  > delivere them to the MN over the air rather than send them back to the
>  > oldAR...
>  > NOTE: This has nothing to do with micromobility (and/or any of its
>  > denominations)
> 
>  > I this clearer?
> 
>    Nope, I'm really confused now :-)
> 
>    Did you actually mean a tunnel between ARold
>    and ARnew? I didn't see that anywhere. The
>    normal forward tunnel is between ARold and MN,
>    afterall. 
> 
>    In either case, however, ARold needs
>    to place the route in its database as well as
>    ARnew. Otherwise, it will keep routing the
>    packets out the old (wireless) interface as
>    normal, which is obviously not what you'd want.

Whether packets destined to oldCoA are tunneled to newCoA or newAR, there needs 
to be a state on oldAR. Something like "send all packets destined to oldCoA 
through tunnel100". In one case tunnel100's end point will be newCoA, in other 
newAR.

>    I think this is what you're trying to say
>    above, but you should probably make it clear
>    about the side effect on ARold as well.

This is the usual thing that happens with "forwarding from previous care-of 
address".

> 	     Mike

alper

---

From: Michael Thomas <[email-masked]>
Date: Tue, 15 May 2001 14:12:33 -0700 (PDT)

> through tunnel100". In one case tunnel100's end point will be newCoA, in other 

Alper,

Understand that I wasn't on the design team, so
I'm looking at this sort of like an outside reader
would look at it. I didn't see where/how the
tunnel would be terminated on ARnew in the draft.
Did I miss something? This would be new
functionality in ipv6 since it sounds like it's
mimicing v4 FA functionality.

	   Mike