Subject: RE: [mobile-ip] host routes in the fast mipv6 draft

From: Alper Yegin <[email-masked]>
Date: Thu, 17 May 2001 12:34:29 -0700 (PDT)

Jim,

> The draft is very unclear about how and when tunnels are set up. 
> The term "host route" is used to refer to a tunnel being set up.

That shouldn't be the case. As George explained out earlier, host routes are 
created on the newAR, to point to MN's oldCoA. They are not used on oldAR, or 
for tunnels. If you can point us where draft says or implies so, we can fix it.

alper

> I've actually never heard the term host route used in this fashion.
> Typically, a host route means "even though the dest address doesn't
> match the subnet structure topologically, route the packet this way." 
> With a tunnel, the dest address will always be topologically correct.

> 		jak

alper

---

From: Michael Thomas <[email-masked]>
Date: Thu, 17 May 2001 14:10:19 -0700 (PDT)

> for tunnels. If you can point us where draft says or implies so, we can fix it.

Alper,

I don't see how this can possibly work unless the
route is also installed on ARold. Otherwise it
forward it out the wireless interface as usual.

As I've said before, I'm sort of worried about how
this interacts with other routing protocols, and
especially how it converges when the routes are
deleted. What would happen, for example, if the
host route were propogated by OSPF while the
tunnel was up?

	   Mike