Subject: Re: [mobile-ip] Authenticating BU and PKI

From: Jean-Michel COMBES <[email-masked]>
Date: Wed, 02 May 2001 12:26:52 +0200

Alper Yegin a écrit :

> > Hi,
> >
> > Pekka Nikander a écrit :
> >
> > > [Sorry for this late reply but I am way back in my mail.]
> > >
> > > > I read most of the solutions proposed for authenticating BU, it seems
> > > > that none of you wants to use a PKI for the key distribution.
> > > >
> > > > I wonder why , is it a problem of scalability , computing abilities of
> > > > the MN due to public key cryptography or ...?
> > >
> > > IMHO, experience has (almost) shown that global PKIs just don't work.
> > > Local PKIs (e.g. company wide or maybe even country wide) can be made
> > > to work.  As far as I know, we have only one example of a reasonably
> > > well working global PKI (the SSL certificate infrastructure), but
> > > even that has far too many technical and trust problems.  Just to
> > > take one, have you ever checked how many CAs do you implicitly
> > > trust once you've installed a new version of your Web browser?
> > > What do you think, how many users even understand what are the
> > > security CA settings in your web browser (provided that they can
> > > open the right configuration panel)?
> > >
> > > In this particular case (authenticating BUs), secure reverse
> > > DNS would be the "right" PKI for the purpose.  However, getting
> > > it running seems like quite an obstackle, and even if we had it,
> > > authenticating a random MN
> >
> > JMC :
> > I think you wanted to say 'random CN'
> >
> > > would be quite expensive in terms
> > > of the number of needed DNS queries and signature verifications.
> > >
> > > Just to clarify: A simple infrastructure with some global CA
> > > providing simple certificates is not enough and/or feasible.  The
> > > certificate must include the home address, and the issuer of
> > > the certificate must be authorized to issue certificates
> > > concerning that particular home address, etc.
> >
> > JMC :
> > A possible solution would be to use the HA.
> > Explanation :
> > When the MN receives tunneled packets from its HA, the MN should send BU to
> > the CN (MIPv6, section 10.3). This is the _FIRST TIME_ that the MN will send
> > a BU to a CN and will have to set up SA to authenticate BU. So the HA knows
> > when the MN will have to set up IPsec parameters ... why don't we use this
> > fact ? When the HA encapsulates packets to the MN, it could send MN's
> > certificate to the CN too, including the Home Address that the MN can use
> > (ie. resolving the authorization problem) with the BU.
>
> But MN might also initiate the communcation with the CN....

JMC :
yes, of course ... and what happens (section 4.7) :
1. MN initiates the communication with this new CN but doesn't send a BU (the CN
isn't in MN's Binding Update Cache)
2. CN answers to the MN's Home Address
3. MN receives CN's packet tunneled to it from its HA
4. MN sends BU (ie. SA setting up too)

So, the HA knows always when the MN will send a BU for the first time to a new CN

> But of course if you
> are suggesting that MN should not send BU to CN until MN receives the first
> tunneled packet.

JMC :
I don't think so ... or am I wrong ?

> (even if MN is initiating the traffic, it can send first packet
> without BU, receive [possibly] a response back through HA, and now send a BU)
>
> alper
>
> > Thanks for your comments.
> >
> > JMC.
> >
> > >
> > >
> > > --Pekka Nikander
> >
> > --
> >
> > France Telecom R&D - DTL/SSR
> > Jean-Michel COMBES, Internet/Intranet Security
> > E-Mail : [email-masked]
> > Phone +33 (0)1 45 29 45 94, Fax +33 (0)1 45 29 65 19
> > PGP fingerprint : 07C6 37BF 4DE5 1CE1 EEB1 1F13 5D75 9E33 CFA7 0214
> >
>
> alper

--

France Telecom R&D - DTL/SSR
Jean-Michel COMBES, Internet/Intranet Security
E-Mail : [email-masked]
Phone +33 (0)1 45 29 45 94, Fax +33 (0)1 45 29 65 19
PGP fingerprint : 07C6 37BF 4DE5 1CE1 EEB1 1F13 5D75 9E33 CFA7 0214

---

From: Jean-Michel COMBES <[email-masked]>
Date: Wed, 02 May 2001 13:20:56 +0200

[Sorry if you have already received this reply]

JMC :

> are suggesting that MN should not send BU to CN until MN receives the first

JMC :
I don't think that is a suggestion, the draft doesn't specify that the MN sends a BU
when it initiates communications with a CN, so by default, MN is waiting for
tunneled packet to send BU.
Am I wrong ?

JMC.

--