Subject: RE: [mobile-ip] Mobile-IP and MPLS Integration

From: "Shahrier, Sharif M." <[email-masked]>
Date: Wed, 9 May 2001 10:19:45 -0400

Is there a current internet draft on this. Could someone please send me the
reference.
 
-Sharif

-----Original Message-----
From: Ash h [mailto:[email-masked]]
Sent: Monday, May 07, 2001 5:26 PM
To: [email-masked]
Subject: Re: [mobile-ip] Mobile-IP and MPLS Integration

   I guess we are concurring with the fact that the COA must be that of the
FA and never that of the MN since MN may not participate in MPLS. Hence the
FA should not allow colocated COA if it is in its capacity and instead use
the FA COA to terminate the LSP. Thus the need to carry the FA address in a
different field may not be necessary[ COA = FA's addr]. I don't think this
will hamper any semantics assigned to the LSP (viz QOS, VPN etc).

  [email-masked] wrote: 

Hi,
Please see for my comments.

Ash h on 05/07/2001 02:34:24 PM

Please respond to [email-masked]

Sent by: Ash h 

To: [email-masked]
cc: (Satish Amara/MW/US/3Com)
Subject: Re: [mobile-ip] Mobile-IP and MPLS Integration

Why do you think that the co-located care-of-addr should be treated
differently? If the COA is conveyed to the Ingress LER all that it needs to
do
is to establish a tunnel [LSP] to that address. The mobile node should be
capable of understanding the Label Map Request. If not then I don't know how
the
FA's address will help, since the tunnel is expected to terminate at the MN
but
gets terminated at the FA and the FA doesn't know what it should do with the
datagram after decapsulation. Correct me.

>>I! ! ! ! am assuming mobile nodes doesn't support MPLS as MPLS is still
"core
networks technology". FA would handle
the packet in similar way as it did when COA is of type foreign agent.

>>Also, let say we want to use MPLS for fast forwarding and QOS and not to
eliminate IP tunnel. In this case, we
probably want to fast switch packet from Ingress(HA) to Egress(FA).

Thanks,
Satish

[email-masked] wrote:

Hi,
I have a question regarding LSP tunnel establishment between Ingress LER
of CN and FA-LER of MN in
section 3.4.2 . RFC.
http://search.ietf.org/internet-drafts/draft-choi-mobileip-ldpext-01.txt
(MPLS-based Mobile IP Route Optimization Scenario.) Also, LSP tunnel between
HA-LER and
FA-LER, is not possible if care of address is of type co-located care-of
address. As both the binding and
registration messages doesn't contain address of FA . One solution to the
above
problem
is to mention the FA a! ! ! ! ddress(LER) in registration message and
binding update
when care of address is of
type co-located.

Thanks,
Satish Amara

---------------------------------
Do You Yahoo!?
Yahoo! Auctions - Click and bid on cool stuff like Dave Matthews Band
Tickets &
more!

Why do you think that the co-located care-of-addr should be treated
differently? If the COA is conveyed to the Ingress LER all that it needs to
do is to establish a tunnel [LSP] to that address. The mobile node should be
capable of understanding the Label Map Request. If not then I don't know how
the FA's address will help, since the tunnel is expected to terminate at the
MN but gets terminated at the FA and the FA doesn't know what it should do
with the datagram after decapsulation. Correct me.

  [email-masked] wrote: 

Hi,
I have a question regarding LSP tunnel establishment between Ingress LER
of CN and FA-LER of MN in
section 3.4.2 . RFC.
http://search.ietf.org/internet-drafts/draft-choi-mobileip-ldpext-01.txt
(MPLS-based Mobile IP Route Optimization Scenario.) Also, LSP tunnel between
HA-LER and
FA-LER, is not possible if care of address is of type co-located care-of
address. As both the binding and
registration messages doesn't contain address of FA . One solution to the
above
problem
is to mention the FA address(LER) in registration message and binding update
when care of address is of
type co-located.

Thanks,
Satish Amara

  _____  

Do You Yahoo!?
Yahoo!  <http://auctions.yahoo.com/> Auctions - Click and bid on cool stuff
like Dave
<http://user.auctions.yahoo.com/show/auctions?userID=dave_matthews_band_tick
ets&u=%3adave_matthews_band_tickets> Matthews Band Tickets & more!
<http://auctions.yahoo.com/>  

  _____  

Do You Yahoo!?
Yahoo!  <http://auctions.yahoo.com/> Auctions - Click and bid on cool stuff
like Dave
<http://user.auctions.yahoo.com/show/auctions?userID=dave_matthews_band_tick
ets&u=%3adave_matthews_band_tickets> Matthews Band Tickets & more!
<http://auctions.yahoo.com>

---

From: "Tai-Won Um" <[email-masked]>
Date: Thu, 10 May 2001 12:15:15 +0900

Hello Sharif,

Please take a look at the draft at http://search.ietf.org/internet-drafts/draft-choi-mobileip-ldpext-01.txt . I think this will explain how to build the large-scale Mobile IP network through the MPLS network.  And the draft at http://search.ietf.org/internet-drafts/draft-choi-mobileip-ipv6-mpls-00.txt proposes how to build the large-scale mobile IPv6 network along with the MPLS network.

Thanks

Tai-Won Um 
  ----- Original Message ----- 
  From: Shahrier, Sharif M. 
  To: [email-masked]' 
  Sent: Wednesday, May 09, 2001 11:19 PM
  Subject: RE: [mobile-ip] Mobile-IP and MPLS Integration

  Is there a current internet draft on this. Could someone please send me the reference.
   
  -Sharif
    -----Original Message-----
    From: Ash h [mailto:[email-masked]]
    Sent: Monday, May 07, 2001 5:26 PM
    To: [email-masked]
    Subject: Re: [mobile-ip] Mobile-IP and MPLS Integration

       I guess we are concurring with the fact that the COA must be that of the FA and never that of the MN since MN may not participate in MPLS. Hence the FA should not allow colocated COA if it is in its capacity and instead use the FA COA to terminate the LSP. Thus the need to carry the FA address in a different field may not be necessary[ COA = FA's addr]. I don't think this will hamper any semantics assigned to the LSP (viz QOS, VPN etc).

      Hi,

      Sent by: Ash h 

      Why do you think that the co-located care-of-addr should be treated
      differently? If the COA is conveyed to the Ingress LER all that it needs to do
      is to establish a tunnel [LSP] to that address. The mobile node should be
      capable of understanding the Label Map Request. If not then I don't know how the
      FA's address will help, since the tunnel is expected to terminate at the MN but
      gets terminated at the FA and the FA doesn't know what it should do with the
      datagram after decapsulation. Correct me.

      >>I! ! ! ! am assuming mobile nodes doesn't support MPLS as MPLS is still "core

      Thanks,
      Satish

      Hi,
      I have a question regarding LSP tunnel establishment between Ingress LER
      of CN and FA-LER of MN in
      section 3.4.2 . RFC.
      http://search.ietf.org/internet-drafts/draft-choi-mobileip-ldpext-01.txt
      (MPLS-based Mobile IP Route Optimization Scenario.) Also, LSP tunnel between
      HA-LER and
      FA-LER, is not possible if care of address is of type co-located care-of
      address. As both the binding and
      registration messages doesn't contain address of FA . One solution to the above
      problem
      is to mention the FA a! ! ! ! ddress(LER) in registration message and binding update
      when care of address is of
      type co-located.

      Thanks,
      Satish Amara

      ---------------------------------
      Do You Yahoo!?
      Yahoo! Auctions - Click and bid on cool stuff like Dave Matthews Band Tickets &
      more!

      Why do you think that the co-located care-of-addr should be treated differently? If the COA is conveyed to the Ingress LER all that it needs to do is to establish a tunnel [LSP] to that address. The mobile node should be capable of understanding the Label Map Request. If not then I don't know how the FA's address will help, since the tunnel is expected to terminate at the MN but gets terminated at the FA and the FA doesn't know what it should do with the datagram after decapsulation. Correct me.

        Hi,
        registration messages doesn't contain address of FA . One solution to the above

        Thanks,
        Satish Amara

--------------------------------------------------------------------------

      Do You Yahoo!?
      Yahoo! Auctions - Click and bid on cool stuff like Dave Matthews Band Tickets & more! 

----------------------------------------------------------------------------
    Do You Yahoo!?
    Yahoo! Auctions - Click and bid on cool stuff like Dave Matthews Band Tickets & more!

---

From: "Jun Kyun Choi" <[email-masked]>
Date: Fri, 11 May 2001 11:02:57 +0900

I read the discussion relating to my draft at this time. The proposed draft is only concerned with the backbone network using MPLS.
It means that the re-encapsulation between MN and FA is out of scope in this draft.
I guess that there may be a number of mobile agents inside home network or foreign network. They can help to encapsulate from MN to FA/LER 
if it is needed.

Jun Kyun Choi