Subject: RE: [mobile-ip] a few more FMIP comments

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 15 May 2001 20:25:52 +0200

>  > > 1) ESP friendliness: currently there is text in the
>  > >    draft which speaks of AH headers, but nothing about
>  > >    ESP headers. We should make the language neutral
>  > >    as well as fix any dependencies on AH itself (beyond
>  > >    the BU's which is a seperable issue). This may 
>  > >    require source addresses to be carried in the
>  > >    router solicit/advertizements itself, rather
>  > >    than expecting them to come from outer IP
>  > >    header. Frankly, this is just good modular
>  > >    design.
>  > > 
>  > 	=> There is not much in the MIPv6 draft either, so
>  > 	why should this be different.
> 
>   Well, unless there is some specific reason to specify AH, 
>   it should just say "IPsec protected" or something like
>   that. If that's a comment against the -13 draft as well,
>   so much the better.
> 
	=> Wait a minute :) we already discussed this before
	San Diego and the consensus was that we should only 
	mention AH. Francis Dupont had several reasons 
	back then that we should at least revisit before 
	reissuing the comments.

>  > > 2) I have a question as to whether anybody
>  > >    considered combining the Proxy Router
>  > >    Solicit functionality with the binding
>  > >    update for the mobile initiated handoff.
>  > >    Considering the mobile is probably moving
>  > >    out of range, this seems like it's a 
>  > >    pretty critical time and the fewer
>  > >    messages required, the better. As a
>  > > 
>  > 	=> A BU to where ? unless you get the proxy
>  > 	RA you don't know where you're going 
>  > 	so what do you bind the address to ?
> 
>    Correct. It would require that the BU be able to
>    have a mode which allows ARold to pick the new
>    CoA (possibly by the HI/HACK). It could transport
>    the picked address back in the Alternate CoA in
>    the BU. It would sort of be like a DHCP request :-)
> 
	=> Yes but the semantics of the BU do not allow 
	that. what you're describing really isn't a "binding"
	in anyway, so I'm not sure if it should be a BU.

>  > 	Do you think it should be used that way ?
> 
>    It does seem that combining the functionality
>    gives better on-the-air messaging. As I said earlier,
>    the number of messages right before it hands over,
> 
	=> Not really. It's the same amount of information,
	just sent in larger packets. So the problems are
	the same.

	Hesham

---

From: Michael Thomas <[email-masked]>
Date: Tue, 15 May 2001 11:45:07 -0700 (PDT)

> 	back then that we should at least revisit before 

   You're talking about the -13 draft here, I assume.
   If I recall correctly at San Diego, there was some
   discussion (I think I even instigated some of it),
   but I don't recall that there was a resolution. I
   think that I've got all of the cases covered in my
   ESP draft now and will submit it, so hopefully 
   Francis can chime in if I forgot something.

 > 	in anyway, so I'm not sure if it should be a BU.

   Yes, I agree it's sort of messy, but this is
   one of the problems that modularity poses when
   you need to be fast. I'll see if I can't come
   up with some reasons why this isn't a generally
   useful mechanism for BU's so that it doesn't
   look like a hack.

 > 	just sent in larger packets. So the problems are

   Possibly, but that depends on whether you can get
   L2 blocking. If not, you might have to wait for
   a second transmission opportunity. Jim's analysis
   is pertinent here, I think. The answer to the
   L2 blocking question is probably the right
   thing to find out now, and then plug it back
   into Jim's model.

		Mike