Subject: RE: [mobile-ip] Mult iple flows with single NAI

From: "Haseeb Akhtar" <[email-masked]>
Date: Thu, 10 May 2001 17:16:26 -0500

Hello,

What is needed is an NAI extension of the device to be sent
to the HA along with the user's NAI to be sent in the RRQ. 

The user's home address 0.0.0.0 can then easily be related
with the particular device that the user is trying to use.

The GNAIE (Generalized NAI Extension) format can be used to
define the NAI of the device.

Regards,

Haseeb

> -----Original Message-----
> From: Mukesh Sharma [mailto:[email-masked]]
> Sent: Thursday, May 10, 2001 12:20 PM
> To: [email-masked]
> Subject: RE: [mobile-ip] Re: mobile-ip] Re: mobile-ip] Re: mobile-ip]
> Mult iple flows with single NAI
> 
> 
> 
> > -----Original Message-----
> > From: Madhavi Subbarao [mailto:[email-masked]]
> > Sent: Thursday, May 10, 2001 12:00 PM
> > To: [email-masked]
> > Subject: [mobile-ip] Re: mobile-ip] Re: mobile-ip] Re: mobile-ip]
> > Multiple flows with single NAI
> > 
> > Yes, this draft is specific to Static IP addresses.  We will be
> > submitting another draft detailing the behavior for Dynamic 
> IP address
> > allocation with a single NAI.  At first glance, it might seem 
> > similar, but
> > infact there are other issues.  Another level of 
> abstraction is needed
> > to distinguish between different MIP 'flows'.  For example, 
> if a USER
> > is registering on two different devices, the RRQ's would look 
> > the same...
> > (NAI, 0.0.0.0 as the home address).  But, when introducing
> > another level of identification, additional measures need 
> to be taken
> > to ensure no security hole is being introduced.
> > 
> > Thanks,
> > Madhavi
> > 
> 
> That was the point I was making, need another level of 
> abstraction for it to
> work at all the levels including the FA and HA. Plus at FA, 
> how will FA know
> that if Mobile station is sending multiple requests or just retrying.
> 
> Sharma
>

---

From: Madhavi Subbarao <[email-masked]>
Date: Fri, 11 May 2001 12:24:27 -0400

Hi Haseeb,

> with the particular device that the user is trying to use.

Exactly our thoughts!  We submitted a draft on this a while back,
which we need to revise now.  I'm still pondering on the format of the
Binding ID.

http://search.ietf.org/internet-drafts/draft-subbarao-mobileip-bindingid-00.txt

> define the NAI of the device.

Actually, that's what we wanted to do initially.  I communicated with
Mohamed about this, but it seems that the GNAIE is necessarily a
'skippable' extension.  In this case, the Binding/Device ID must be
'not skippable' else it leads to ambiguity.  So, we were following the
'not skippable' MIER format.

-Madhavi