Subject: [mobile-ip] MIPv6: Ping-pong between ARs ?

From: Thierry Ernst <[email-masked]>
Date: Wed, 30 May 2001 18:49:10 +0200

Hi all,

I have a question regarding section "10.9 Establishing forwarding from a
previous coa" in the MIPv6 spec.

MN has a COAa on foreing link La
Then, MN visits foreign link Lb and has COAb
The specs says that MN may send a BU (COAa -> COAb) to a HAa on foreign
link La
Then, MN goes back to link La, and sends a BU (COAb -> COAa) to a HAb on
foreign link Lb

What happens if the entry in HAa has not yet expired ?  Any packet sent
to COAa or COAb enters a routing loop, right ?  Or am I missing
something ?

If this is right:
- what is the experience gained from the implementations ?  
- Does some implementations establish forwarding from the previous
care-of address ?  
- How is this routing loop fixed ?
- Is section 10.9 going to be amended to address this issue ? 

Thanks,
Thierry.

--
* mailto:[email-masked]  Tel +33 (0) 4 76 61 52 69 
* INRIA Rhone-Alpes Projet PLANETE       (fax 52 52) 
* and MOTOROLA Labs Paris
* http://www.inrialpes.fr/planete/people/ernst/Welcome.html

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 30 May 2001 14:35:36 -0700

hi Thierry,

the MN cannot use 'CoAa' for sending any packet as long as 
HAa is defending 'CoAa'. the MN cannot sent the second BU till
it deregisters 'CoAa' when it comes back to La from Lb.

whether the MN does this deregistration or not, HAa should take 
care not to create a neighbor cache entry for CoAa when it has a 
binding cache entry for CoAa. 

vijay