Subject: Re: [mobile-ip] questions on fast handoffs for MIPv6

From: James Kempf <[email-masked]>
Date: Thu, 7 Jun 2001 09:41:22 -0700 (PDT)

>Can you add the following text to the draft then?
>
>	When the newAR is receiving packets forwarded by the 
>	oldAR for the MN, and the MN hasnt shown up yet, the 
>	newAR SHOULD buffer packets. If the newAR does not 
>	buffer packets, it would the packets meant for the MN.
>

I don't think this text should be added.

It is entirely unclear at this point whether buffering will work without causing
user-perceivable artifacts in real time streams. In fact, I know of
at least one experiment with buffering (in IPv4) that showed it cannot be done.
This experiment was not definitive, of course, but I think it is
not wise to write buffering into the standard until more is known
about whether it will work or not.

There are other alternatives to handoff smoothing, for example bicasting,
that could handle some portion of the handoff smoothing task without
introducing artifacts. We need to leave the standard open on this
until there is more evidence.

		jak

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 07 Jun 2001 09:55:47 -0700

hi,

> until there is more evidence.

you didnt get it. consider this scenario. the MN has sent a F-BU
to the oldAR. lost the link connection. the oldAR starts forwarding
packets to the newAR. MN hasnt shown up yet at the newAR. it hasnt 
sent a F-NA or a NA to the newAR yet. (there is some delay in
the MN moving and establishing a link layer connection). if the 
newAR does not buffer these packets it would have to drop it. 
bicasting does not help here.

vijay

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 07 Jun 2001 10:22:16 -0700

Hello Jim,

There are already familiar cases where buffering occurs with
IP, with good effects.  For instance, typically a packet
will be buffered today if there isn't an ARP cache entry
for a node on the same network as the sender.

I find it very difficult to believe your statement that
an experiment has shown that buffering cannot be done.
Can you provide a citation for this work?  My guess is
that some unnecessary assumption is being made to cause
the particular buffering scheme not to work.  In fact,
I can "prove" that buffering can be made to work, by a
really simple-minded argument that is so silly that I
don't want to repeat it here.  That would cause a lot of
argument about the "proof", and deflect discussion away
from the real point.  Which is, that whether buffering can
work or not depends entirely on the restrictions being made.

I support Vijay's suggestion to incorporate some very
minimal buffering at the new access router during the
time until which a positive indication of link establishment
can be detected.  It seems almost intuitively obvious that
it can work on the tiny timescale that is implied.

Regards,
Charlie P.