Subject: [mobile-ip] behavior on Mobility Agent during Mobile IP handoff

From: "Koichi Ishibashi" <[email-masked]>
Date: Tue, 5 Jun 2001 21:51:40 +0900

Hello all,

I have a question on Low Latency Handoff in Mobile IPv4.
This is as follows.

In the <draft-ietf-mobileip-lowletency-handoff-v4-01.txt>,
the old FA MUST bi-cast all packets destined to the MN
to both the L2 to which the MN is currently connected
and by tunneling to the new FA.

However, when the MN has some microflows (for example,
one microflow supports a real-time service, and
the other supports non-real-time service), 
should the FA apply the same procedure on 
bi-casting & forwarding to all microflows?

Here,
I read the Perkins's comment that the Mobile IP should
be considered to be a protocol that deals (solely)
with terminal mobility.
On the other hand, <draft-ietf-mobileip-3gwireless-ext-06.txt>
proposes the session specific extension that is used to
differentiate the multiple microflows from the same MN.

In my opinion, I think that a future network should
support a QoS mechanism and a mobile network should
need to support a QoS also.
When the mobile network supports a QoS, 
I think that a mobility agent should also support
a QoS and differentiate the microflows.
And the above support of QoS should be applied to
a Handoff procedure as well as a Tunneling and 
Forwarding procedure.
For example, according to an implicit or explicit configuration,
a mobility agent should decide whether to bi-cast the packets
for each microflow or not.

Is that correct?

Any comments will be good enough to me.
Thanks you in advance.

Ishibashi

---

From: James Kempf <[email-masked]>
Date: Tue, 5 Jun 2001 08:47:53 -0700 (PDT)

The tunnelling has strictly to do with terminal mobility. When the
mobile node moves to the new FA, there may be a period of time
in which it does not yet have a new CoA or cannot use
the new CoA. During that period of time,
it should be able to send/receive with the old CoA. Naturally, this
is important primarily for real time traffic, but there is no
reason why other traffic shouldn't be afforded the same benefit.

I don't see what QoS has to do with this. Within the edge wired network,
I don't think capacity will limiting, or, at least, if good network
engineering principles are applied, it should not be. I suppose one could
set up classes of service and afford mobiles that have subscribed
to a higher class the benefit of tunnels while mobiles that subscribe
to best effort don't get them, but I think that is an independent
issue and is up to the network provider.

BTW, both GPRS and IOS use this technique currently, but at L2. In IOS, for
example, if a mobile node moves to a new PDSN while a data session is up, it
extends the PPP tunnel to the new PDSN until it has time to obtain
a new CoA.

		jak

>From: "Koichi Ishibashi" <[email-masked]>
>To: <[email-masked]>
>Cc: "Ishibashi" <[email-masked]>
>Subject: [mobile-ip] behavior on Mobility Agent during Mobile IP handoff
>Date: Tue, 5 Jun 2001 21:51:40 +0900
>X-Priority: 3
>X-MSMail-Priority: Normal
>X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6700
>
>Hello all,
>