Subject: RE: [mobile-ip] New I-D on "Incorporating NAT-Boxes with Mobile I Pv4"

From: Phil Roberts <[email-masked]>
Date: Thu, 14 Jun 2001 09:45:04 -0400

Where can one find a description of the Transition Gateway function
you mention?

> -----Original Message-----
> From: Shahrier, Sharif M. [mailto:[email-masked]]
> Sent: Wednesday, June 13, 2001 3:00 PM
> To: [email-masked]'
> Subject: [mobile-ip] New I-D on "Incorporating NAT-Boxes with Mobile
> IPv4"
> 
> 
> I have submitted a new internet-draft, please find it 
> attached. I would like
> some feedback. It concerns the use of NAT boxes in Mobile IPv4. Now,
> currently, in the Mobile Telecommunications Industry, the 
> UMTS architecture
> is slated to go "all-IP" based according to the R5 of 3GPP 
> specs. The GPRS
> core network is to be connected to the Internet by a 
> Transition Gateway
> (TrGw). Amongst other functions, the TrGw is expected to provide NAT
> functions. Thus, this I-D proposes a solution to the problem 
> of mobility
> management with network address translation.
> 
> 
> 
>

---

From: Phil Roberts <[email-masked]>
Date: Thu, 14 Jun 2001 10:34:19 -0400

23.221 describes the Transitition Gateway as a v6 to v4 function and
the NAT there is NAT-PT.

> Sent: Thursday, June 14, 2001 9:53 AM
> Subject: RE: [mobile-ip] New I-D on "Incorporating NAT-Boxes 
> with Mobile
> I Pv4"
> 
> 
> This is in the document 3GPP TS 23.221. Look at www.3gpp.org
> 
> Sharif
> 
> From: Phil Roberts [mailto:[email-masked]]
> Sent: Thursday, June 14, 2001 9:45 AM
> Subject: RE: [mobile-ip] New I-D on "Incorporating NAT-Boxes 
> with Mobile
> I Pv4"
> 
>

---

From: "Shahrier, Sharif M." <[email-masked]>
Date: Thu, 14 Jun 2001 10:51:45 -0400

There are no terminology in the document that are taken from other
organizations, other than the IETF.
In fact, I just mentioned the transition gateway TrGW in my posting. It is
not present in the actual draft.

-----Original Message-----
From: Pat Calhoun [mailto:[email-masked]]
Sent: Thursday, June 14, 2001 9:51 AM
To: [email-masked]
Subject: Re: [mobile-ip] New I-D on "Incorporating NAT-Boxes with Mobile
I Pv4"

> This is in the document 3GPP TS 23.221. Look at www.3gpp.org

Sharif,

It is typically not customary to include terminology that will require the
reader to sift through other SDO documents just to understand what the
I-D is trying to say. Could you perhaps include an introduction, or at the
very least, a terminology definition, of a Transition Gateway function?

Assume the reader is lazy :)

PatC

---

From: "Qiang Zhang" <[email-masked]>
Date: Thu, 14 Jun 2001 10:56:32 -0400

might be a typo? contrary to private address the global addresses should
be registered  addresses.
 
 Section 1 Introduction
   the private networks 
   can use any any one of the unregistered addresses, without prior 
   approval fro IANA. The public or global addresses are unregistered 
   addresses
  
-----Original Message-----
From: Phil Roberts [mailto:[email-masked]]
Sent: Thursday, June 14, 2001 9:34 AM
To: [email-masked]'
Subject: RE: [mobile-ip] New I-D on "Incorporating NAT-Boxes with Mobile
I Pv4"

---

From: "Shahrier, Sharif M." <[email-masked]>
Date: Thu, 14 Jun 2001 11:02:58 -0400

Global addresses are "registered". Thanks.

-----Original Message-----
From: Qiang Zhang [mailto:[email-masked]]
Sent: Thursday, June 14, 2001 10:57 AM
To: [email-masked]
Subject: RE: [mobile-ip] New I-D on "Incorporating NAT-Boxes with Mobile
I Pv4"

 Section 1 Introduction
   the private networks 
  
-----Original Message-----
From: Phil Roberts [mailto:[email-masked]]
Sent: Thursday, June 14, 2001 9:34 AM
To: [email-masked]'
Subject: RE: [mobile-ip] New I-D on "Incorporating NAT-Boxes with Mobile
I Pv4"