Subject: [mobile-ip] A question on draft-ietf-mobileip-hmipv6-03.txt

From: Karann Chew <[email-masked]>
Date: Fri, 29 Jun 2001 12:37:06 +0100 (BST)

Hi,

I have a question on the HMIPv6 draft.  Please help.

In Section 8 "Comparison Btwn HMIPv6 Modes of Operation"
Paragraph #2 mentions that for the extended mode, MAP will _decapsulate_
the packets and the _encapsulate_ them again to the MN.  

Why decap and encap?  For MIPv6, isn't Routing Header is used instead?  

Regards,
	Karann

On Mon, 30 Apr 2001 [email-masked] wrote:

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the IP Routing for Wireless/Mobile Hosts Working Group of the IETF.
> 
> 	Title		: Hierarchical MIPv6 mobility management
> 	Author(s)	: H. Soliman, C. Castelluccia, K. Malki, L. Bellier
> 	Filename	: draft-ietf-mobileip-hmipv6-03.txt
> 	Pages		: 27
> 	Date		: 27-Apr-01
> 	
> This draft introduces some extensions for MIPv6 and neighbour
> discovery to allow for the introduction of a hierarchical MIPv6
> mobility management model. The proposed hierarchical mobility
> management for MIPv6 will reduce the amount of signalling to CNs and
> the HA and may also improve the performance of MIPv6 in terms of
> handoff speed. Moreover, HMIPv6 is well-suited to implement access
> control and handoffs between different access technologies.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-mobileip-hmipv6-03.txt
> 
> Internet-Drafts are also available by anonymous FTP. Login with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-ietf-mobileip-hmipv6-03.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-mobileip-hmipv6-03.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 29 Jun 2001 13:51:17 +0200

Hello Karann, 

There are two possibilities for receiving a packet at the MAP:

1. The packet was sent from the CN directly to the CoA
    in the Binding Cache. In extended mode this means
    the MAP's address. In this case the packet will contain
    a routing header which will be processed by the MAP. The 
    MAP will see that the final destination is the MN's Home 
    address, do a Binding Cache lookup and tunnel it to the 
    MN's LCoA (Just like a HA would)

2. The packet was encapsulated by the HA and forwarded
    to the MN's CoA. This is the case you're referring to. 
    Since the MN's CoA in the HA's binding cache is the MAP
    address (for Extended mode), The MAP will receive the 
    packet addressed to itself, decapsulate it (normal IP 
    processing for a tunnelled packet), and then find that the 
    real destination is the MN's Home address and follow the 
    same steps above. Hence it will encapsulate and forward 
    to LCoA of the MN. 

Cheers,
Hesham

> -----Original Message-----
> From:	Karann Chew [SMTP:[email-masked]]
> Sent:	Friday, 29 June 2001 1:37
> To:	[email-masked]
> Subject:	[mobile-ip] A question on draft-ietf-mobileip-hmipv6-03.txt
> 
> Hi,
> 
> > Below is the data which will enable a MIME compliant mail reader>