Subject: Re: [mobile-ip] questions on fast handoffs for MIPv6

From: [email-masked]
Date: Fri, 8 Jun 2001 11:05:35 -0700

I agree. It is also not clear on "mobile has not arrived". Has the mobile been
authenticated by the new AR? If not, how the new AR can receive packets for
un-authenticated mobile. We need to check security issues here.

Barani.

James Kempf <[email-masked]> on 06/07/2001 09:41:22 AM

Please respond to [email-masked]

Sent by:  James Kempf <[email-masked]>

To:   [email-masked]
cc:    (Barani Subbiah/HQ/3Com)
Subject:  Re: [mobile-ip] questions on fast handoffs for MIPv6

>Can you add the following text to the draft then?
>
>    When the newAR is receiving packets forwarded by the
>    oldAR for the MN, and the MN hasnt shown up yet, the
>    newAR SHOULD buffer packets. If the newAR does not
>    buffer packets, it would the packets meant for the MN.
>

I don't think this text should be added.

It is entirely unclear at this point whether buffering will work without causing
user-perceivable artifacts in real time streams. In fact, I know of
at least one experiment with buffering (in IPv4) that showed it cannot be done.
This experiment was not definitive, of course, but I think it is
not wise to write buffering into the standard until more is known
about whether it will work or not.

There are other alternatives to handoff smoothing, for example bicasting,
that could handle some portion of the handoff smoothing task without
introducing artifacts. We need to leave the standard open on this
until there is more evidence.

          jak

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 08 Jun 2001 11:17:02 -0700

> I agree. It is also not clear on "mobile has not arrived". Has the mobile been

the newAR has not received any NA or a F_NA (as defined 
in the fast handoff draft, which i assume you havent read
yet). if a link level trigger exists, the newAR hasnt 
received this trigger yet. this means the mobile has
not arrived yet. 

authentication is after that. you dont do authentication before
establishing a link level connection and sending a NA.

and the fast handoff draft is not trying to solve authentication
between the MN and the access router.

vijay