Subject: Re: [mobile-ip] How does HA use routing table?

From: James Kempf <[email-masked]>
Date: Mon, 4 Jun 2001 11:01:25 -0700 (PDT)

I think the spec ought to be clear that the two should not offer
contradictory information. If the binding cache says that there
is a remote binding, then the routing table should not say that
there is a local one, and vice versa.

Hence, it should not matter which source is consulted first.

		jak
		
>From: "Qiang Zhang" <[email-masked]>
>To: <[email-masked]>
>Subject: Re: [mobile-ip] How does HA use routing table?
>Date: Mon, 4 Jun 2001 13:56:31 -0500
>X-Priority: 3
>X-MSMail-Priority: Normal
>X-Mimeole: Produced By Microsoft MimeOLE V5.00.2919.6600
>
>I think for Agent to deliever the packet, the implication is that it should
>follow the routing table, even there is a binding cache for a packet. Does
>MIP have to address the issue?
>
>----- Original Message -----
>From: "Ichiro Okajima" <[email-masked]>
>To: <[email-masked]>
>Sent: Monday, June 04, 2001 1:11 AM
>Subject: [mobile-ip] How does HA use routing table?
>
>
>> Hello all,
>>
>> I would appreciate it if anyone would answer my question.
>> I think that the HA of Mobile IPv6 has a routing table as well as
>> Binding Cache since it is a kind of router. It seems to me that
>> Mobile IPv6 I-D does not say the relationship between the Binding
>> Cache and the routing table, and how to use the routing table.
>> My guess is as follows:
>>
>> 1) When the HA receives a packet, it firstly checks the Binding
>> Cache whether a binding for the destination address of the packet
>> exists or not.
>>
>> 2) If no binding exist in the Binding Cache, it secondly checks
>> the routing table to find the best route for the packet.
>>
>> Is my understanding correct?
>>
>> Ichiro
>>
>

---

From: James Kempf <[email-masked]>
Date: Mon, 4 Jun 2001 12:05:15 -0700 (PDT)

How about;

	The Home Agent MUST assure that the information in the binding
	cache is consistent with routing tables for the local subnet.
	If the Mobile Node as an entry in the routing table for the
	local subnet, then it MUST not have an entry in the binding
	cache, and vice versa.
	
			jak
	
>X-Delivered-For: <[email-masked]>
>X-mProtect: Mon, 4 Jun 2001 11:29:57 -0700 Nokia Silicon Valley Messaging 
Protection
>Date: Mon, 04 Jun 2001 11:29:56 -0700
>From: "Charles E. Perkins" <[email-masked]>
>To: [email-masked]
>Hello,
>First, I concur with Ichiro Okajima's assessment of the intention
>of the home agent procedure.
>
>If the home agent has a binding for the mobile node, then that is
>authoritative.  If there is a clash between the home agent's
>routing table and its Binding Cache entry for the mobile node,
>then that means something has gone wrong.  In fact, if the
>home agent doesn't have a binding cache entry for the mobile
>node, it typically shouldn't get the packet at all except insofar
>as the home agent is a default router for the home network.
>In that case, then its action is well defined, and typically it
>still wouldn't have a host-specific route for the mobile node.
>
>I usually consider the Binding Cache to be like a part of
>the routing table anyway, with special flags.
>
>Can someone suggest an improvement to the wording of the
>Mobile IPv6 specification to clarify this?
>
>Regards,
>Charlie P.
>
>
>Qiang Zhang wrote:
>>