Subject: RE: [mobile-ip] Mobile Prefix Advertisements

From: "Powell, Ken" <[email-masked]>
Date: Tue, 26 Jun 2001 13:13:42 -0400

> -----Original Message-----
> From: T.J. Kniveton [mailto:[email-masked]]
> Sent: Tuesday, June 26, 2001 12:19 PM
> To: Powell, Ken; Perkins Charles (IPRG/MtView)
> Cc: [email-masked]
> Subject: Re: [mobile-ip] Mobile Prefix Advertisements
> 
> 
> "Powell, Ken" wrote:
> > 
> > I think we have a serious issue here.
> > 
> > > > > >  >9.8.1. Building Aggregate List of Home Network Prefixes
> > > > > >  >
> > > > > >  > To support this, the home agent monitors prefixes
> > > > > >  > advertised on
> > > > > >  > the home link by itself and other home agents, and
> > > > > >  > passes the ...
> > > > > >                            =====================
> > > > > >
> > > > > >    Why limit this to prefixes from other home agents
> > > > > >    only? Why not use prefixes from any router?
> > > > >
> > > > > I don't think that was the intention.
> > > >
> > > > Actually it was my intention, so please correct me here
> > > > because this is important. In the general case, I do not
> > > > see how a MN can use a prefix
> > > > being advertised on its home link, unless a home agent 
> is willing to
> > > > "serve" that prefix by accepting registrations for 
> addresses on the
> > > > prefix, and thus forwarding packets to the MN while it 
> is roaming.
> > > >
> > > > So, are you suggesting that a home agent would want to 
> serve mobile
> > > > nodes that do not use a home address on a prefix that the HA is
> > > > advertising?
> > >
> > > No, my wording was bad.  I was trying to say that the 
> intention was
> > > _not_ to use addresses from routers that are not home agents,
> > > but since I was in a hurry I didn't put enough text around it to
> > > be clear.
> > 
> > I disagree. When a mobile node is home, it will autoconfigure
> > to all prefixes advertised by any router. When the mobile node
> > moves off-link, the home agent will need to intercept all
> > traffic for the mobile node, otherwise you will get dropped
> > connections. The reason for creating the aggregate list
> > was to handle this problem.

BTW, the statement above is the part that is critical we
fix and handle consistently. The rest was personal preference.

> > 
> > While playing in the lab, I discovered I could set up a home
> > agent that doesn't set the A or L bits on any prefixes. The
> > mobile node autoconfigures to another router on the home net.
> > I realized this could be a very handy feature, particularly
> > in cases where the network administrator doesn't want the
> > home agent to effect addresses configured on the non-mobile
> > nodes.
> 
> Well first of all, if the home agent is willing to serve home 
> addresses
> that are on prefixes it doesn't advertise (which it probably 
> would be),
> then there is no issue with a mobile node leaving the home network -
> that will work fine regardless of what's in the MPA.

Agreed. I believe its mandatory the home agent be able
to serve addresses it doesn't advertise, particularly for
cases like DHCP served addresses. In most such cases,
I would expect the mobile node to issue binding updates
with a zero prefix length.

> 
> As far as a mobile renewing an address, or configuring a new 
> one, based
> on the MPA: while I'm not sure I agree 100%, I certainly see 
> your point
> and it is valid: it would be very nice for a network 
> administrator to be
> able to drop in an HA without having to reconfigure anything else.

Normally I would expect the home agent and other routers to
advertise the same set of prefixes, so dropping the home agent
is no big deal. I was more interested in the possibility that
a network administrator might want to avoid routing disruptions
caused by possibly misconfigured home agents.

> It doesn't seem great to require every HA to advertise all of the
> prefixes on its link to all MNs (and my intention was to pare the
> aggregate list by removing unnecessary prefixes). Perhaps we 
> could reach
> a compromise of a router rule under "should": add received 
> prefixes that
> have the A bit set to the aggregate list. I would also 
> suggest that the
> rule should specify that the prefixes should be added only if they do
> *not* have the L bit set.

I don't think it matters what the L bit is set to. All the
L bit does is indicate to a host that it should treat the
a prefix as On-Link when sending messages. When a destination
of any scope is on-link, the host will use Neighbor Discovery
to find the destination instead of sending the message to
router.

> To me, it seems problematic for a 
> mobile node
> to be autoconfiguring home-network link-local addresses while roaming.
> How do you feel about that?

Agreed. But that is not what the L bit is used for.

> 
> As far as the rule that the mobile should be able to autoconfigure at
> least all of the prefixes (which are served by HAs) that it 
> would on the
> home network, I think that still holds: the prefix still needs to be
> served by the HA for it to be relevant while roaming, even if 
> the prefix
> is not explicitly advertised by the HA on the home link.

I think this is the key point. The way I see it, the mobile
node can autoconfigure a set of home network addresses while
at home or while roaming. These sets of addresses must match
exactly to each other and to the addresses that the home
agent can serve. I define "serve" to mean the set of addresses
that a home agent can intercept and forward to the mobile node.

Another way we could compromise is to introduce
a concept of home prefixes vs other prefixes on the home
network. Home prefixes could be prefixes advertised by
home agents. Other prefixes are prefixes not advertised
by home agents. A mobile node could autoconfigure to
any prefix while on the home subnet, but would "Prefer"
to use home prefixes only. The other prefixes would be
expected to come and go the same way care-of addresses
do now.

Ken

---

From: "Charles E. Perkins" <[email-masked]>
Date: Sat, 30 Jun 2001 19:45:01 -0700

>>> I think we have a serious issue here.

......

>>>> No, my wording was bad.  I was trying to say that the intention
>>>> was _not_ to use addresses from routers that are not home agents,

I have clarified the wording.  However, your statement about the
reason for creating the aggregate list doesn't match my recollection,
which is admittedly a bit fuzzy.  I thought the aggregate list was
created so that the home agent could deliver prefixes to the mobile
node that supported mobility.

> with a zero prefix length.

Ooohhh... but, still, the home agent wouldn't support any
such address that doesn't live on the subnet.  If DHCPv6 hands
out addresses to a mobile node that don't live on the subnet,
then I think it's just a plain error.

There has to be some restriction here, I'm sure.

> to find the destination instead of sending the message to

If we go for the rule of only aggregating prefixes that have the
'H' bit set, then wouldn't that express the semantics that the mobile
node only gets prefixes that support mobility?

> expected to come and go the same way care-of addresses

I really thought that we already had made this determination,
and that we were only supposed to advertise home prefixes.

If I am missing something here, please let me know!  It's
been a long weekend already!

Regards,
Charlie P.