Subject: RE: [mobile-ip] behavior on Mobility Agent during Mobile IP hando ff

From: "Karim El-Malki (ERA)" <[email-masked]>
Date: Tue, 5 Jun 2001 16:25:04 +0200

Hello

>In the <draft-ietf-mobileip-lowletency-handoff-v4-01.txt>,
>the old FA MUST bi-cast all packets destined to the MN
>to both the L2 to which the MN is currently connected
>and by tunneling to the new FA.
>
>However, when the MN has some microflows (for example,
>one microflow supports a real-time service, and
>the other supports non-real-time service), 
>should the FA apply the same procedure on 
>bi-casting & forwarding to all microflows?

For the basic low latency handoff we've assumed this.
Doing otherwise would require a protocol with which the MN
informs the FA what to do with each traffic flow or having
the FA independently sniff and decide what to do with each
packet. For the moment I think it is appropriate that this
was not considered so as to solve basic handoff improvement
first. Once we conclude on a basic solution we can get to
these enhancements. Currently all traffic flows get the same
(best) treatment.

>In my opinion, I think that a future network should
>support a QoS mechanism and a mobile network should
>need to support a QoS also.
>When the mobile network supports a QoS, 
>I think that a mobility agent should also support
0>a QoS and differentiate the microflows.
>And the above support of QoS should be applied to
>a Handoff procedure as well as a Tunneling and 
>Forwarding procedure.
>For example, according to an implicit or explicit configuration,
>a mobility agent should decide whether to bi-cast the packets
>for each microflow or not.

I'd say that can be considered but only simulations can tell us
how much gain can come out of differentiating the FA behaviour
during a fast handoff. If you don't bicast on some flows will that
gain you much compared to the added FA complexity? It's quite
important to find out before adding this function.

Regards
/Karim

---

From: "Koichi Ishibashi" <[email-masked]>
Date: Fri, 8 Jun 2001 19:23:19 +0900

Thanks Karim,

My comments are following,

> >a QoS and differentiate the microflows.

I agree as to the need of a simulation.
But I have not simulated for comparing each efficiency.

However, I also have a doubt about the efficiency of bi-casting
when considering the TCP behavior.
And I think that a FA is a edge wired Router.
So, in my opinion, the FA may implement some QoS mechanism.

Regards.
Ishibashi