Subject: RE: [mobile-ip] questions on fast handoffs for MIPv6

From: kempf <[email-masked]>
Date: Sat, 23 Jun 2001 07:50:10 -0700 (PDT)

Barani,

What do you mean by "dependency on L2"? IHMO, it is simply not possible
to achieve performance sufficient for real time media without some
form of L2 support. I'm not talking about a specific L2, if you look
at the FMIPv4 paper, you'll see that we have defined an abstraction
layer for L2 that can be applied to a wide variety of L2. 

A similar situation exists with respect to minimum path MTU in IPv6.
IPv6 requires that either the L2 support a minimum path MTU having
a certain value, or that a shim be written in the driver to perform
segmentation and reassembly. The IPv6 spec does not specify one particular
L2 but rather an (admittedly simple) abstraction that an L2 should
support for efficient IPv6 implementation.

W.r.t. FMIP, if a particular L2 does not support the necessary abstractions,
then either a shim layer needs to be written or designers should not
expect to get seamless handoff of real time media over it.

		jak
		
>From: [email-masked]
>X-Lotus-FromDomain: 3COM
>To: [email-masked]
>cc: [email-masked]
>Date: Mon, 18 Jun 2001 10:55:25 -0700
>Subject: RE: [mobile-ip] questions on fast handoffs for MIPv6
>Content-Disposition: inline
>List-Owner: <mailto:[email-masked]>
>
>
>
>Charles: Thanks for the scenario.
>
>Alper: you can think of the same scenario with no GPRS coverage inside the
>building. IMHO, we are going to see scenarios like this more often than a pure
>single access technology wireless data access.
>You can also think of same operator providing WWAN and WLAN (hot spot) coverage
>and like to use fast MIP techniques.
>
>I like to suggest that we remove any dependency of L2 with FMIP techniques.
>
>Barani.
>
>
>
>
>
>Charles Qi Shen <[email-masked]> on 06/18/2001 02:57:39 AM
>
>Please respond to [email-masked]
>
>Sent by:  Charles Qi Shen <[email-masked]>
>
>
>To:   [email-masked]
>cc:    (Barani Subbiah/HQ/3Com)
>Subject:  RE: [mobile-ip] questions on fast handoffs for MIPv6
>
>
>
>Alper,
>
>I am not aware of what kinds of scenarios Barani may have in his mind.
>Please see whether my scenario can be something close to that.
>
>For example, you have a Mobile Node with two interfaces, one GPRS and one
>Wireless LAN, your company is covered by WLAN and you can use it for free
>within the company, while you are outside you will use GPRS. Since you pay
>for your GPRS but not the WLAN. You may wish to use WLAN *only* while
>inside the Company. In this case, it is not really this mobile node
>*cannot* have both interfaces connected, but it is the user choosing so.
>
>Charles
>
>At 05:26 PM 6/15/2001 -0700, you wrote:
>>Barani,
>>
>>Is there any reason why this mobile node cannot have both interfaces
>>connected
>>at the same time? Do you have a scenario where it can or it should have
>>only one
>>connected, although they are using different interfaces?
>>
>>alper
>>
>>
>> >
>> > Alper,
>> >
>> > No. It is a single mobile with multiple links but connects via a single
>> link
>>at
>> > any given time to a single AR. However, after hand off it connects to
>> new AR
>>via
>> > a different link. Example would be WLAN and WWAN or any other combination.
>> >
>> > Barani.
>> >
>> >
>> >
>> >
>> > Alper Yegin <[email-masked]> on 06/14/2001 07:40:23 PM
>> >
>> > Please respond to [email-masked]
>> >
>> > Sent by:  Alper Yegin <[email-masked]>
>> >
>> >
>> > To:   [email-masked]
>> > cc:    (Barani Subbiah/HQ/3Com)
>> > Subject:  RE: [mobile-ip] questions on fast handoffs for MIPv6
>> >
>> >
>> >
>> > Barani,
>> >
>> > > As in the draft and this thread, I like to point out that Link layer
>> address
>> > > based verification across ARs should be avoided as much as possible.
>> > > MN can have two interfaces and also move from one AR to another AR
>> using the
>> > new
>> > > L2 interface.
>> > >
>> > > If we want L2 identifier then there should be a way that MN can
>> indicate to
>> > the
>> > > old AR about the new Link layer ID that it will be using plus the
>> current L2
>> > ID.
>> > >
>> >
>> > If this is a mobile node with multiple links, which can be connected to
>> > different ARs at the same time, you most probably don't need FMIPv6 draft.
>> >
>> > alper
>> >
>> >
>> >
>> >
>> >
>>
>>alper
>
>SHEN, Qi (Charles)
>Centre for Wireless Communications
>National University of Singapore
>20 Science Park Rd. #02-34/37, TeleTech Park
>Singapore Science Park II, Singapore 117674
>Tel: +65 870-9358       Fax: +65 779-5441
>Email: [email-masked]
>URL: http://www.cwc.nus.edu.sg
>
>
>
>
>
>

---

From: Pat Calhoun <[email-masked]>
Date: Sat, 23 Jun 2001 10:21:09 -0700

welcome back. Boy, do I have lots to talk about.

We have a meeting tomorrow at 1pm in menlo somewhere.

I think we should get together around 11 in menlo to chat.

Have a great one.

PatC

---

From: Pat Calhoun <[email-masked]>
Date: Sat, 23 Jun 2001 16:24:38 -0700

All,

I should have known better. this list has bitten me before, and I guess
I haven't learned my lesson yet.

I really wish that this list was configured the way it use to be... as 
I've asked many times, but were ignored. I know others have been bitten
as well.

Oh well,

PatC