Subject: RE: (CLARIFICATION) Re: [mobile-ip] Routing headers: design team recommendation

From: "Glenn Morrow"<[email-masked]>
Date: Mon, 4 Feb 2002 13:33:17 -0600

All,

As I recall, #3 was this:

"3. Try to simplify things by not using Routing Headers for MIPv6."

ZOD and MR. ZOD don't use routing headers either. 

They can also be used with mobile routers as well - even with nested mobile
nodes attached to the mobile routers. 

They can also be used to do local mobility management.  

MR. ZOD is just as robust, as well. 

ZOD eliminates the possibility of interference from firewalls via
transparency; making the arguments related to firewalls, routing headers and
home address options, mute. None of the other proposals have this
transparency property.

Both can be completely end to end and hold to the fatesharing principle.

They are also more efficient in terms of PDU size than any of the other
proposals.

The address space of IPv6 is huge.

With these points in mind, the variants of the two should be included as
options for seriously consideration at this time, as well.

> The chairs already declared consensus on approach #3 (i.e. to 
> define somehing
> new for MIPv6). I'm trying to capture a list of pros and cons for
> 	New RH type
> 	New (ADA) destination option
> 	Deering/Zill tunneling
> 	New extension header
GM]   Zero Overhead Diversion
GM]   More Robust Zero Overhead Diversion
		using flow label bit
		using traffic class bit

regards,
 
Glenn

---

From: Erik Nordmark <[email-masked]>
Date: Tue, 5 Feb 2002 09:43:06 +0100 (CET)

> "3. Try to simplify things by not using Routing Headers for MIPv6."

Glenn,

No, #3 was "define something new instead of using RH type 0".
One of the possible new things would be a new RH type.

  Erik