Subject: [mobile-ip] Valid Period of Home Address?

From: "Youn-Hee Han" <[email-masked]>
Date: Thu, 7 Feb 2002 18:31:14 +0900

Before I read the MIPv6 draft, I believed the followings 
"After the MN acquires a home address, the home address is fixed at the MN and is permanent."
That is, I have assured that the home address of a MN becomes the identifier of the MN.

In many places in the MIPv6 draft, however, I can find that the eternity of home address is not true.
Of course, the home network renumbering and the initial address configuration cause the home address to be configured by using 'ICMP Mobile Prefix Solicitation'. But, the ICMP message is also used in order to refresh home addresses before the expiration of their validity.
Also, I think that the Duplicate Address Detection is also another evidence of the short-lived of home address.

If the home address is not permanent. I am worried about the followings.

1. If the home address is changed, how does a correspondent node open any TCP connection with the MN after the changes?

2. We cannot find any terms about the valid period of home address. Is the period depended of an implementation?

I admit that any temporary home address should be used in some cases. 
However, the temporary home address is conflict with the following goal of Mobile IP.

"Each mobile node is always identified by its home address, regardless of its current point of attachment to the Internet"

Thanks in advance.
Best regards,

---

From: "T.J. Kniveton" <[email-masked]>
Date: Wed, 13 Feb 2002 14:25:28 -0800

> "Each mobile node is always identified by its home address, regardless of its current point of attachment to the Internet"

Hi Youn-Hee. Thanks for your question about home address validity. Since
no one else has commented, I'll take a crack at it..

This is a subject that came up last year when we discussed renumbering.
There is an ongoing question about whether IPv6 addresses have the same
semantics in identifying a node as was the case in IPv4. It seems, as
you observed, that there is a bit less permanence in IPv6 addresses for
this purpose -- or at least *potential* for less permanence.

Nevertheless, my sense of this, so far, is that the goal is to make IPv6
addresses long-lived in a similar way to how they are in IPv4. It is
certainly desirable to be able to have a known and persistent address
for the CN to contact the MN (and vice versa) and other well-known
nodes.

Keep in mind that while a router advertisement or mobile prefix
advertisement from the HA might have a given lifetime for a prefix, that
doesn't mean the prefix will be invalid at the end of that life -- in
the same way a DHCP lease could expire in IPv4 but be renewed before
expiration, the IPv6 prefixes should be constantly refreshed by the
router. Ultimately, all of this will be subject to administrative
policies, since implementations will be tunable by the administrator for
a site. But renumbering and address changes should be an unusual event.

To answer question 2, please take a look at RFC 2461 p. 30 (Valid
Lifetime and Preferred Lifetime), and pp. 78-79 (Renumbering), as well
as RFC 2462, pretty much the whole thing.

These documents focus more on the mechanisms for creating and
deprecating addresses, and focus less on policies for how long an
address should persist for. But there is no reason that IPv6 prefixes
can't be similar to IPv4 subnets - i.e. infinite for all intents and
purposes.

Hope this is at least somewhat helpful.

-TJ

-- 
        T.J. Kniveton 
  Communications Systems Lab
     Nokia Research Center