Subject: RE: (ISSUE) [mobile-ip] Piggybacking - DT recommendation

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 15 Feb 2002 12:53:46 +0100

Glenn,
 
I'm starting to feel like a broken record. It has been 
mentioned several times that a receiver that will be harmed
by piggybacking has no way of stopping this 
unless some negotiation is done. It seems that
most people are against this option. 
 
Hesham

-----Original Message-----
From: Glenn Morrow [mailto:[email-masked]]
Sent: Thursday, February 14, 2002 9:40 PM
To: [email-masked]; [email-masked]
Subject: RE: (ISSUE) [mobile-ip] Piggybacking - DT recommendation 

Why can't we just leave these engineering tradeoffs to particular products? 

> -----Original Message----- 
> From: Erik Nordmark [ mailto:[email-masked] <mailto:[email-masked]> ] 
> Sent: Thursday, February 14, 2002 11:32 AM 
> To: [email-masked] 
> Cc: [email-masked] 
> Subject: Re: (ISSUE) [mobile-ip] Piggybacking - DT recommendation 
> 
> 
> > How can the DT recognize there is a *potential* benefit, but decide 
> > to kill piggybacking? 
> 
> Brian, 
> 
> There is a potential benefit it lots of things - I can 
> envision benefits 
> in carry BUs as XML over http (but there might be some 
> disadvantages as well 
> :-) 
> 
> The issue is the engineering tradeoff. 
> 
>   Erik 
> 
>

---

From: Charlie Perkins <[email-masked]>
Date: Fri, 15 Feb 2002 07:01:06 -0800

Hesham,

A receiver that cannot receive such packets is not obeying
the IPv6 specification.  A receiver that wants to have
specialized handling for control messages has to bear
the burden of further negotiation, since it is no longer
a connectionless (i.e., "IP"-style) link.  Even so, this
is trivially manageable.

It seems to me that most people are in favor of having
this flexibility.  I also wonder why the "anti-" people
are so hard line, when they already can have everything
that they putatively want.

Regards,
Charlie P.

"Hesham Soliman (ERA)" wrote:

>  Glenn,I'm starting to feel like a broken record. It has
> been mentioned several times that a receiver that will be harmedby
> piggybacking has no way of stopping this unless some negotiation is
> done. It seems thatmost people are against this option. Hesham

---

From: Michael Thomas <[email-masked]>
Date: Fri, 15 Feb 2002 09:41:13 -0800 (PST)

Charlie Perkins writes:
 > this flexibility.  

   I think we should let the WG chairs decide this.
   From what I can tell, there has been no movement
   toward consensus here as all of the same arguements
   are being repeated.

 > I also wonder why the "anti-" people

   This statement underscores that the two sides
   are still not communicating.

	     Mike