Subject: RE: [mobile-ip] draft on random interface identifiers available

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 5 Feb 2002 11:14:56 +0100

I really think you should announce this draft
on the ipv6 list and try to discuss it there. 
This is clearly an ipv6 WG issue. Whether it is
motivated by mobility or not is a different 
discussion. 

Hesham

  > -----Original Message-----
  > From: Ignacio Soto Campos [mailto:[email-masked]]
  > Sent: Monday, February 04, 2002 4:52 PM
  > To: [email-masked]
  > Cc: [email-masked]; [email-masked]
  > Subject: [mobile-ip] draft on random interface identifiers available
  > 
  > 
  > Hi all,
  > 
  >     We have submitted the draft "Random generation of interface
  > identifiers" that is available from:
  > 
  > http://www.ietf.org/internet-drafts/draft-soto-mobileip-rand
  > om-iids-00.txt
  > 
  > The abstract is included below. Comments are welcomed.
  > 
  > Abstract
  > 
  >    This document evaluates the use of random numbers to generate the
  >    interface identifier part of an IPv6 address on mobile 
  > environments,
  >    where Duplicate Address Detection (DAD) mechanisms are expensive.
  >    We have estimated the probability of having an address 
  > duplication
  >    using this mechanism and we conclude that the IPv6 
  > addresses created
  >    in this way could be used without previously doing DAD 
  > to test the
  >    uniqueness of the address in a link.
  > 
  > 
  > Best regards,
  > 
  > Ignacio
  > 
  >

---

From: Ignacio Soto Campos <[email-masked]>
Date: Tue, 05 Feb 2002 13:29:15 +0100

Hesham,

We do agree that this draft involves IPv6 issues,
however we think that previous discussion in the
mobileip WG is interesting. The reason is that the
motivation for the draft is a mobileip matter, so we'd
like to know if the described approach are seen as
relevant for mobile environments.

Eventually, if relevance is stated, the presented
approach could be introduced to the ipv6 WG, or
could be proposed as a modification for IPv6 in
mobile nodes, which would be suitable for this WG.

Regards,

Ignacio

---

From: Francis Dupont <[email-masked]>
Date: Wed, 06 Feb 2002 12:36:16 +0100

We'd like to know if the described approach are seen as
   relevant for mobile environments.
   
=> this term "mobile environments" disturbs me because MIPv6
is supposed to work anywhere, i.e. not only in "mobile environments".
BTW I agree this is an IPv6 topic.

[email-masked]

PS: about IMEI, they have 14 decimal digits (7 bytes in BCD, 6 in binary)
so it is possible to build EUI-64 from them...