Subject: [mobile-ip] Is RR only enough ?

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 3 Jan 2002 15:29:52 +0100

=> Probably nothing, but consider this scenario and see
if it is possible:
A MiTM is performing an active attack by sending a BU to 
the CN to direct the MN's traffic to itself. 
Now this Bad Guy happens to be on the path between the 
CN and the HA. In this case, if RR (only) is used, 
Bad Guy will be able to steal all the MN connections 
with the CN, and her can keep refreshing the BU to disallow
future communication with that particular Home address. 
However, if RR, combined with CGAs is used, this can not 
happen (well, or it becomes as hard as it is to generate
a duplicate CGA). 
As far as I can see this situation is an 'addition of harm'
compared to today's Internet, and is due to the BU. 
That's why I think RR and CGA are a good combination. 

Have I missed something ?

Hesham

---

From: Erik Nordmark <[email-masked]>
Date: Fri, 4 Jan 2002 03:51:34 +0100 (CET)

> future communication with that particular Home address. 

Yes this is a possible attack.

But you seem to be implicitly claiming that this is worse than today's
IPv4 network with an attacker on the path between the communicating nodes.
That is the argument I don't understand i.e. why is this any more harmful
than the MiTM attacking every TCP connection and UDP "session"? The MiTM
is on the path between the communicating nodes.

> happen (well, or it becomes as hard as it is to generate

I fully agree that RR+CGA doesn't have this problem thus it is more secure.

> compared to today's Internet, and is due to the BU. 

So why is it worse?

  Erik