Subject: RE: [mobile-ip] Piggybacking - DT recommendation

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 14 Feb 2002 18:56:20 +0100

James, 

I'm having a hard time understanding
why you disagree since you don't 
explain. If this topic is just a 
'voting' one then I understand 
your email. The chairs can clarify.
Some comments below:

  > DISAGREE. The tendency in the MIP group in the past 
  > has been to avoid facing up to cases where the properties of
  > wired networks and wireless networks are different enough
  > that changes are required to efficiently support  IP on 
  > wireless networks. I think this is another such case.

=> I've tried to show several times that the best
way to support MIPv6 signalling on a link with
QoS support is to separate the signalling packets
form the normal traffic. If anyone thinks
this is unreasonable then please explain why. 

As for links with no QoS: Does it matter?
Why? They usually are so overdimensioned that
it isn't an issue. 

  > 
  > As I mentioned previously, DoCoMo uses piggybacking
  > to good effect in i-mode, that indicates to me that it
  > is likely to be useful. Without further analysis, of course,
  > it is hard to say how useful and whether the tradeoff
  > is worth it, 

=> Exactly! imode is a _completely_ different architecture
from what we're discussing here.

but it is one implementation data point. It has 
  > been mentioned  before that Cedric and Charlie's draft 
  > (which I admit to not having read) also lists some possible 
  > benefits of piggypacking. 

=> The only reasons I'm continuing with this
is a 'hope' to convert this from a religious argument
to a technical one. Your statement above seems 
to belong to the former. Please read it and 
consider the earlier discussion and tell us
what you think. We know that claims were made, 
but we need to really analyse and understand 
these claims and then decide whether we 'believe'
in them.  

  > If changes are required in IPsec, then I think we ought
  > to ask for them.

=> I'm not sure about the practicality of that
option. 

  > 
  > > (b) We recommend that when IPsec protection is used, it is
  > >     always used in *addition* to RR (or CGA) methods, not as
  > >     a replacement. Thus RR (or CGA) methods would be used to
  > >     protect MN - CN Route optimization procedures even when IPsec
  > >     is used.
  > > 
  > 
  > DISAGREE. Requring RR for BU security if the BU is between
  > the MN and an AR or LMM agent in the local foreign network
  > will have serious performance impact. Requiring just CGA or
  > something similar would probably have less impact. In any
  > case, the MN should be able to establish a BSA when it
  > enters the foreign network and use that to secure any routing
  > update signaling with entities in the foreign network.

=> A BSA would only exist if an appropriate mechanism
was used. I think that can be done with RR+CGA. 
Just because you have an IPsec SA, doesn't mean you
are authorised to send the BU. It's an address
ownership problem and that's why we need RR. 

Hesham

---

From: "James Kempf" <[email-masked]>
Date: Thu, 14 Feb 2002 11:06:09 -0800

Hesham,

> this is unreasonable then please explain why. 

Sure, radio links would all work *much* better if
we got to use a special channel for IP signaling.
Maybe someday this will happen, but the
fact of the matter is, today it doesn't.

> Why? They usually are so overdimensioned that

Not on the radio.

> ownership problem and that's why we need RR. 

How long do you think a handover
would take if the MN had to do RR in order to
update a binding at a MAP? 

        jak