Subject: Re: [mobile-ip] Mobility Extension Header (was ISSUE: Design team

From: [email-masked]
Date: Thu, 28 Feb 2002 20:11:46 -0500

Vijay Devarapalli wrote:

> 1. New Extension Header Order
> 
>            IPv6 header
>            Hop-by-Hop Options header
>            Destination Options header (1)
>            Routing header
>            Destination Options header (2)
>            Fragment header
>            Authentication header
>            Encapsulating Security Payload header
>            Mobility Options header
>            Destination Options header (3)
>            upper-layer header
> 
> 	   (1) for options to be processed by the first destination
>                that appears in the IPv6 Destination Address field
>                plus subsequent destinations listed in the Routing
>                header.
> 
>            (2) contains only Mobile IPv6 Home Address Option (HAO)
> 
>            (3) for options to be processed only by the final
>                destination of the packet.

So do we dare ask what the IPv6 WG has to say about this proposal?
Obviously we have spent a lot of time looking into the best way to
do this, which can't be ignored...

> 2. Mobility options header
> 3. Mobility Options

Looks good.

> 4. Possible Mobility Options
> 
> Binding Update - remains the same, except for the length field
> Binding Acknowledgement - remains the same, except for the length field
> Binding Request - remains the same, except for the length field
> Return Routability (possibly multiple options)
> PAD1
> PADn

And I'm assuming these sub-options too:

Unique identifier
Alternate Care-of address
Auth data???

Thanks for writing this up,

-Brian

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 28 Feb 2002 17:37:50 -0800

> do this, which can't be ignored...

I guess the new extension header is the way to go....

> Alternate Care-of address

The sub-options remain the same.

Vijay