Subject: Re: (CLARIFICATION) Re: [mobile-ip] Routing headers: design team recommendation

From: [email-masked]
Date: Fri, 08 Feb 2002 18:05:31 -0500

Erik Nordmark wrote:
> > > Do people see strong arguments for/against handling the "source HoA" and 
> > > the destination "HoA" using the same mechanism?
> >
> > One shouldn't impose symmetry on the handling of addresses that
> > are to be used for different purposes entirely.
> 
> We seem to agree that the HoA in a HAO sent *from* a MN serves to
> identify the MN.
> The above statement of "different purpose" seem to say that the HoA in a 
packet
> sent *to* a MN does not identify the MN?  I'm confused - either the home
> address identifies the MN or it does not - this can't depend on what type of
> packet the HoA is contained in.

Erik,

Maybe I mis-understood your second sentence in this reply:

	"... the HoA in a packet sent *to* a MN does not identify the MN?"

Surely the HoA identifies the sending MN, but it can't identify the
receiving MN.  There must be a way to specify the Home Source Address and
Home Destination Address (aka RH right now) independently, since MN to MN
traffic needs this to work (4 addresses in the packet).

I think Charlie might have clarified this, but I've been having mail problems
with this list recently and couldn't find the replies.

-Brian

---

From: Erik Nordmark <[email-masked]>
Date: Mon, 11 Feb 2002 15:02:55 +0100 (CET)

> traffic needs this to work (4 addresses in the packet).

Perhaps acronym confusion? But HoA I mean Home Address which is
different than HAO = Home Address Option.

So restating what I said without acronomyns:
The above statement of "different purpose" seem to say that the home address
in a  packet sent *to* a MN does not identify the MN?

This home address could be contained in a RH or somewhere else - its location
in the packet wasn't the part of this particular issue - but instead
the semantics of the Home Address in packets sent from as well as to a MN.

  Erik