Subject: RE: [mobile-ip] Piggybacking - DT recommendation

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Mon, 18 Feb 2002 13:05:13 +0100

Micheal, 

One addition/question below:

  > -----Original Message-----
  > From: Michael Roe [mailto:[email-masked]]
  > Sent: Thursday, February 14, 2002 11:27 PM
  > To: [email-masked]
  > Subject: Re: [mobile-ip] Piggybacking - DT recommendation
  > 
  >  My current view is that:
  >  - you have to do RR for the CoA in all cases;

=> If you use RR+CGA, and assuming that a user
switched off the address privacy knob so that the 
CoA is CG (same id as the HoA), wouldn't you avoid RR 
for the CoA after the BSA is established?

Hesham

  >  - if you have an IPSec SA, you don't need RR for the HoA;
  >  - if the HoA is cryptographically generated, you still 
  > need to check
  > that
  >    it's RR

  > Mike

---

From: Claude Castelluccia <[email-masked]>
Date: Mon, 18 Feb 2002 14:38:53 +0100

"
Hi Hesham,

> for the CoA after the BSA is established?

using a CGA CoA will prevent a malicious host from using your address as
CoA
in order to bomd you....however a malicious could still register a bogus

CGA address of your network just for the sake of flooding your network
(not
a particular host)....that why RR might still be useful in this case...

Regards,

Claude.

--

----------------------------------------
Claude CASTELLUCCIA, INRIA Rhone-Alpes
ph:  +33 4.76.61.52.15 (fax: 52.52)
http://www.inrialpes.fr/planete/