Subject: RE: [mobile-ip] BU Authorization method: design team recommendati on

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Tue, 5 Feb 2002 16:20:57 +0100

John, 

First, I'd like to say that I fully agree
with the DT's recommendation. Also wasn't 
RFC3041 being update recently ? I didn't 
think it went through last call, so we 
might be able to change it to accomodate
this recommendation.

 > because I still have some concerns about CGA.  CGA may not
  > protect well for IPv4 mapped address, etc.  

=> This is not a good example IMHO. mapped addresses
are only used (on the wire) for SIIT. In this case
you wouldn't need to cryptographically generate
the mapped address. The BU is sent to the 
SIIT router, so a global unicast Home address
and global unicast CoA should be used. 

For more info check:

http://www.ietf.org/internet-drafts/draft-ietf-ngtrans-siit-dstm-01.txt

I think we should standardise CGA based solutions
for MIPv6 at the same time. Of course there is no
need to hold off the spec for them but I don't
see why they should be intentionally delayed 
either. The issues have been analysed for a long
time now by many people. 

Hesham

---

From: Francis Dupont <[email-masked]>
Date: Sat, 09 Feb 2002 19:27:55 +0100

=> This is not a good example IMHO. mapped addresses
   are only used (on the wire) for SIIT.

=> the example is not good but the concern is real.
A standard question in the IPv6 WG mailing list is "may I
assume that IID have 64 bits" and the standard answer is no.
Cf. draft-ietf-ipngwg-addr-arch-v3-07.txt:

   For all unicast addresses, except those that start with binary value
   000, Interface IDs are required to be 64 bits long and to be
   constructed in Modified EUI-64 format.

So ::/3 unicast addresses may use another format.
I don't know if this is a real concern for CGAs (this and
the 1 bit stuff should be presented to the IPv6 WG or
CGAs won't be available for more than MIPv6...).

Regards

[email-masked]