Subject: [mobile-ip] The semantics of the Routing Header?

From: Pekka Nikander <[email-masked]>
Date: Fri, 01 Feb 2002 12:52:03 +0200

Hello all,

Related to the debate on the mobile-ip list on whether
MIPv6 should use Routing Header or some other mechanism
to carry the home address to a mobile node that is
away from home, I'd like to solicit for well grounded
opinions on the intended semantics of the Routing Header.

To properly understand what I am really asking about we
must first make a distinction between two logical
entities, endpoints and locations.  In the current
Internet architecture, both endpoints and locations are
identified with a single mechanism, i.e. with IP addresses.
However, they are conceptually different, as very well
pointed out by Noel Chiappa in
http://users.exis.net/~jnc/tech/endpoints.txt
In essense, a communication endpoint is an active
entity engadged in the communications, i.e. a party
who consumes messages and generates new ones.  A location,
on the other hand, is a topological "place" within the
routing fabric.

Now, my question is fairly simple:  Is the meaning of
the routing header to allow a packet to be sent through
a number of communicating hosts (end-points) or via a
specific path, identified by a set of locations?  Or
is it both?

One way of pondering the question is to imagine that the
endpoints and locations had different name spaces.  For
example, you could imagine that each host has a flat
name tag (HIT in HIP terminology), and the locations
are named according to the routing hierarchy as today.
Under such an architecture, would the routing header
contain addresses or these new name tags, or could
it contain a mixture of both?

The reason why I am asking this is the scenario, which
Charlie Perkins has offered, where a packet is source
routed through a Mobile Node that is away from home.
According to his argumentation, in such case the
routing header should have a route looking like

    .... - Care-of-Address - Home Address - ....

where the Care-of-Address is the current location of
the mobile node, and the Home Address is more like
the end-point identifier of the mobile node.  I am
having hard time in clearly crasping the intended
semantic meaning of this construction.

--Pekka Nikander

---

From: "James Kempf" <[email-masked]>
Date: Fri, 1 Feb 2002 09:03:48 -0800

Pekka,

> on the other hand, is a topological "place" within the

I think there is something missing in this analysis. A 
communication endpoint requires more than just the
address to identify it, it also requires the port.

> specific path, identified by a set of locations?  Or

To me, it is fairly clear that the routing header is just
to route through a determined set of intermediate
forwarding nodes, i.e. routers, regardless of their
communication status. The header does not nor
should it require that a forwarding node be running
a specific protocol and thus support traffic
to a particular port in order to obtain forwarding
service.

> semantic meaning of this construction.

I've been loosely following this discussion, and
I think Charlie's argument has merit but I think
it is orthogonal to what the semantics of the
Routing Header should be. Currently, as
Charlie has pointed out, the two functions
are served by two header options. The MIP
case may be unique enough that perhaps
a new option is needed combining the
CoA and HA. I don't really see
this as being a general problem, though.

            jak

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 01 Feb 2002 14:55:45 +0100

It's fairly clear that architecturally, IPv4 and IPv6 are
at exactly the same place on this: the notions of identifier
and locator are 100% overlaid on each other. So in practical
terms - what can we do, and standardize, *today* - we simply
can't make the distinction. 

The IRTF NameSpace research group has been working inconclusively
on the architectural issue for a couple of years. See
http://www.ietf.org/internet-drafts/draft-irtf-nsrg-report-01.txt
for a snapshot.

imho it is best to disregard the philosophical side if you want
to make progress immediately. What's the practical issue with
embedding the home address in such a routing header?

  Brian