Subject: Re: [mobile-ip] Re: IPv6 ingress filtering early access

From: Francis Dupont <[email-masked]>
Date: Fri, 04 Jan 2002 17:22:20 +0100

=> this depends on what is an IPsec session (AH makes HAO safe,
more details are needed for other cases).

     (I leave it open for now,
     whether the session should be between care of addresses or home
     addresses of MN and CN, but either should work?).
   
=> if the IPsec SA is with a care-of address it has to be rebuilt
after each movement. But the ISAKMP SA can be with the care-of
or the home address (i.e. IKE session can use the care-of or the
home address) at the exception of the IKE session for a first home
registration (i.e. before the home agent - mobile node tunnel is
established, mobile IPv6 drafts have a MUST because of this case).

Regards

[email-masked]

---

From: Pekka Nikander <[email-masked]>
Date: Thu, 03 Jan 2002 12:55:59 +0200

Markku Savela wrote:

> I may have missed some discussion due to high volume on this topic,
> but I like to inject one scenario of Home Address option use...
> 
>   If MN and CN have IPSEC session between them, then I
>   suppose HAO within such session is safe. (I leave it open for now,

Well, that depends on _how_ exactly you have created the IPSEC session,
and, as a consequence, how much you trust the MN.  If you use something
like opportunistic IPSEC (see
http://www.sandelman.ottawa.on.ca/SSW/freeswan/oeid/draft-richardson-ipsec-opportunistic-04-change.txt)
you certainly CANNOT trust the HAO any more than without IPSEC.
On the other hand, if you have a closed user group with strong
internal trust relationships, you may decide to trust the HAO
without any explicit authorization.  However, in the general
case, when you create the IPSEC SA, you have to check that the
MN is _authorized_ to use the Home Address.  Only that makes
it secure to trust on the HAO.

As a side note, the CGA and RR methods are means to check an
MN's authority to use a Home Address.  Basically, RR relies
on the assumption that if a host can answer to messages sent
to an address, it is authorized to use that address.  CGA,
on the other hand, relies on that if a host possesses a private
key that corresponds to the host ID part of an IPv6 address,
it is assumed to be authorized to use that address.  Neither
is perfectly secure, but both are much better than nothing.

(Well, what do I mean with "much better".  In the RR case,
much better means that the number of hosts able to foil the
RR check is much smaller than the number of hosts in the
Internet.  In the CGA case, creating a private key that
corresponds to a given IPv6 interface ID requires so large
amounts of computational capasity that few attackers are
likely willing to spend that much of resources.)

--Pekka Nikander