Subject: Re: [mobile-ip] ISSUE: Design team recommendation: New recommendation on piggybacking

From: [email-masked]
Date: Thu, 28 Feb 2002 11:49:01 -0500

> 3. RECOMMENDATIONS
> 
> The design team recommends the following:
> 
> R1. A Separate protocol and/or port should be used for the BR
>      message, all RR messages, BU message and BA message.  This
>      will allow - but not mandate - the use of current IPsec
>      selectors in protecting BUs to the CN and HA, and RR
>      messages via the HA. The value of next protocol = none
>      must be supported by all MIPv6 compliant nodes in these
>      messages.

I must have been asleep when somone proposed creating an IPPROTO_MIPV6
(or whatever) type, and removing them from a Destination Options header.
Is this really what the DT meant?  BTW, I *strongly* object to using a
port - all of the mipv6 implementations to date are in kernel space,
not daemons.

> R2. Reserve some space for preference bits in the RR messages
>      1a and 1b, to allow the CN and the MN to describe their
>      preferences. Only the space is reserved, but no meaning
>      is assigned to the bits.

Can live with.

> R3. The above two recommendations should be placed in the
>      MIPv6 RFC. This would allow us to quickly proceed to RFC
>      status by bypassing controversial content, have as simple
>      RFC and implementations as possible, but still allow
>      functionality like piggybacking to be specified without
>      interoperability concerns, and used by all nodes who
>      support it.

Agree.

> R4. Separate RFCs would define the use of these bits. For
>      example, their use in piggybacking would need to define
>      the following:

Agree.

> R5. At a future time, IF IPsec selectors can be extended in
>      some manner, the RFC described under R4 could be updated
>      to extend the rules under which piggybacking is possible
>      i.e. no IPsec checks would be necessary any more.

Agree.

-Brian

---

From: Jari Arkko <[email-masked]>
Date: Thu, 28 Feb 2002 18:57:39 +0200

[email-masked] wrote:

> Is this really what the DT meant? 

Yes.

> BTW, I *strongly* object to using a

I agree.

Jari