Subject: RE: [Fwd: Re: [mobile-ip] Piggybacking - DT recommendation]

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 13 Feb 2002 18:48:30 +0100

=> Correct (the argument not the wording).
But you didn't mention the argument I added
later about the harm of piggybacking
on existing connections due to the difference
in channel characteristics which are needed
for the BU and any odd IP packet carrying anything
from HTTP to VoIP. If you want radio QoS
you shouldn't treat them the same way.
It's all in the same thread.

  > 
  > To sum it up, of course, if you chose the right situation 
  > (avaibility of 
  > a control plane
  > and a user plane, like you suggested in the thread), then 
  > there is no 
  > jitter benefit (I even
  > have a better situation with absolutely no benefit from 
  > piggybacking: 
  > prohibit the
  > mobile node from moving :-) But the IETF is not here to 
  > design for the 
  > convenient
  > link layer. 

=> Of course, but this is not something new that 
the IETF needs to design, link layers with QoS
assurances already have these features. 'features'
being the ability to configure a certain bearer
for a certain type of traffic. 

Anyway I don't want to get into another infinite
loop, it was all said before, 
point 1) above is the main issue which makes the 
piggybacking discussion irrelevant, at least when
you're using RR only which is the current recommendation
for the spec.

Hesham

---

From: Cedric Westphal <[email-masked]>
Date: Wed, 13 Feb 2002 10:15:00 -0800

Hesham,

>It's all in the same thread.
thanks for reminding me, I never responded to this point.
I think you forgot BU's have reliability on their own, by way of BAck.
So link layer is not required to provide another level of reliability.

>you're using RR only which is the current recommendation
I hope my (delayed) reply to this point makes you reconsider that you
should not dismiss the piggybacking discussion on this ground.

Take care,

Cedric.