Subject: RE: [mobile-ip] Piggybacking - DT recommendation

From: [email-masked]
Date: Wed, 20 Feb 2002 18:38:09 +0200

Hi Michael,

>    No. This entire subject has to do with whether
>    piggybacking is useful for mac/phy's whose method
>    for allocating bandwidth for elevated QoS is to
>    give fixed sized slots. DOCSIS USG is a perfect
>    example, and is illustrative of how bandwidth
>    can be parceled out on a shared media. Wireless
>    has *many* of the same considerations. For
>    those kinds of media, piggybacking is a
>    distinct disadvantage, especially if it affects
>    downstream flows (which a sender would be
>    clueless about).

So, if a layer 2 API which had QoS info that a MIP implementation
could leverage, there may not be complications.  Of course, this
is an IF ... however, I think Erik did bring NSIS into the
discussion, and I'd be happy to get some input on level 3
MIP QoS needs in NSIS. 

thanks,
John

---

From: Michael Thomas <[email-masked]>
Date: Wed, 20 Feb 2002 09:29:38 -0800 (PST)

> discussion, and I'd be happy to get some input on level 3

   This isn't an issue of information and/or
   signaling. It's an issue of how bits are placed
   on the wire. Many shared media L2 QoS schemes
   like fixed sized slots, and piggybacking is
   harmful when they are used willy-nilly,
   especially by senders who don't know that
   altering the payload size of a flow is harmful.

	   Mike