Subject: RE: [mobile-ip] WG process

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 23 May 2002 14:29:28 +0200

> At some level we do follow one process although the steps in each
  > document may be different as circumstances require.  Abstractly
  > it seems we have a process of problem statement, 
  > requirements, proposals,
  > proposal selection, wg iterations, wg last call.
  > 
  > In some cases we have the luxury that the problem statement 
  > and requirements
  > are clear enough that we get one proposal and are able to 
  > iterate and do
  > a wg last call.  In other cases, it's muddy enough that we 
  > start from the
  > beginning.  In yet other cases it seems clear enough at the 
  > time we start
  > that a proposal is fine, yet as we iterate we realize there may be
  > conflicting
  > requirements, disagreements amongst the constituency, and a 
  > need to step
  > back and look again.  We could force all the steps to occur 
  > on everything
  > we consider, but personally optimizations where possible 
  > seem productive,
  > even
  > though in some cases we have to backtrack.  It is 
  > frustrating in a way that
  > when docs take a long time to get through, there are more 
  > opportunities for
  > finding problems, or thinking about the original problem.

=> OK. Thanks for the clarification, but I hope that
we try to reduce the amount of time it takes to get
an RFC out. I think in some cases (not talking about 
MIPv6) this hasn't been happening and I'm not blaming
the chairs for that, it's a collective effort.

  > 
  > Why was LMM requirements done for v6 and not for v4?  
  > Probably a lot of
  > reasons -
  > the ones that seem clear to me are premature selection of a 
  > proposal,
  > recognized
  > in a disagreement about requirements.

=> The requirement that caused the major disagreement,
was common for both v4 and v6. I think at the time
I made this comment on the list, no less than 4
times and it was never answered. 

As for the maturity of the selection, I don't
agree with your paragraph above, the selection
followed WG concencus procedures, as it was 
requested by the chairs and lasted for 2 
weeks. 

Hesham

---

From: "Carl Williams" <[email-masked]>
Date: Thu, 23 May 2002 14:03:08 -0700

> times and it was never answered. 

The requirements resulted from a discussion over concerns
of the current proposed working group LMM (MIPv6) documents.
An analysis was done and requirements collected as a result.

Requirements may be similar between MIPv4 and MIpv6
but there may be different requirements for the different protocols.

Carl