Subject: RE: [mobile-ip] Feedback on NAT draft

From: "Sami Vaarala" <[email-masked]>
Date: Tue, 14 May 2002 09:50:41 +0300

Hi Madhavi,

>[snip]
> The MN is indicating that it can do UDP tunneling with the
> presence of the UDP Tunnel Request Extension.  The HA can decide
> whether to do UDP tunneling irrespective of NAT.  There doesn't seem
> to be a role for the MN to force UDP tunneling...unless we are missing
> something.  Hence, implementation can be simplified without 'F' bit.

There may be cases where the mobile node knows more about
the network it is using to contact the HA.  It might know
that the UDP tunnelling is absolutely required through the
network;  the HA might not know this.

The feature may be useful if the MN is in a network which
filters packets and neither the HA or the MN know about
this.  The sequence would be as follows:

   1. The MN registers without F-bit.  The registration
      succeeds but the firewall blocks traffic.

   2. The MN re-registers with F-bit, being wiser from
      step 1.

This could also be done by an intelligent HA, but I don't
think the HA has enough context to do this?  (It doesn't
know whether the MN just doesn't want to communicate or
that the communication attempt failed.)

-Sami

---

From: "Madhavi W. Chandra" <[email-masked]>
Date: Fri, 17 May 2002 14:27:47 -0400

Hi Sami,

Thanks for being more specific.  Please see inline...

>       succeeds but the firewall blocks traffic.

On which network is the filtering occuring?  Is this a firewall on the
home network?  If so, the HA will know about it and be able to accept
UDP tunneling regardless of NAT.  If you mean on the foreign network,
this will not affect the MN sending traffic OUT, right?  Something is
missing...

Please clarify.  

Thanks,
Madhavi

---

From: "Madhavi W. Chandra" <[email-masked]>
Date: Fri, 17 May 2002 15:10:02 -0400

Sami,

> this will not affect the MN sending traffic OUT, right?  Something is

Ahh...perhaps you mean FW on foreign side won't let IN the IPinIP or
GRE traffic.  So, the 'F' bit gives flexibility to MN on foreign domain.  
OK...makes sense.

I guess you will clean up the text to remove the dependency of the 
FA 'R' bit case on the 'F' bit.

Thanks for pointing this out.

Regards,
Madhavi