Subject: RE: [mobile-ip] Regional Registration Last Call Resolution Issue #1

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Mon, 13 May 2002 11:51:28 +0200

> 	I agree with James about the requirements aspect. " against the
  > proposed solutions".
  > 
  > 	I have asked the authors question(s) about the real-time impact
  > to the MIP protocol? What is it really?

=> This has nothing to do with this particular
draft. Your question is a general concern about
MIP and real time. Is it not clear that a local
agent will reduce the registration time to the 
HA? I can't see how this could not be obvious.

  > 	Is the added complexity to the overall MIP architecture worth
  > the few MS for a trip to the home network/the added 
  > signaling message to
  > the home? 

=> I can understand that for MIPv4, it is a valid
question to raise. However, I would not say 
'few ms'. This clearly depends on the location
of the HA. Across the atlantic this is easily
in the order of tens of ms at best. That is, 
if the first packet makes it to the HA.

  > 	Also, looking at from a services point view and a direction of
  > how handheld devices with dual access (or more) would be used, I
  > strongly believe (may be only me) that the granularity of 
  > the location
  > to the home network/info-provider would of high importance 
  > for location
  > based services. I don't want to know that my subscriber is 
  > visiting the
  > North section of town, I need to have more information about the
  > location so I can "push/send" more personalized data to 
  > him, i.e. his
  > favorite pizza restaurant.

=> But again, this has nothing to do with what 
is being discussed here. In fact, I would highly
recommend that you consider this type of geographical
location management as an application layer issue. 
There are proposals in SIPPING to handle this. 

Hesham

---

From: "Emad Qaddoura" <[email-masked]>
Date: Mon, 13 May 2002 18:26:54 +0200

Hi Hesham,
 
	Sorry, did not mean to take the list off, too quick on the REPLY
option. I agree with you here, the question may be stated better the way
you did: 

"So the question here is whether people think the 
optimisation is worth the complexity. But I don't
see a question of whether this mechanism will add
benefit or not, it certainly does. The question 
is: How big is the benefit? that's probably a better 
focus for the discussion.

Thx.

> -----Original Message-----
> From: Hesham Soliman (ERA) [mailto:[email-masked]]
> Sent: Monday, May 13, 2002 4:35 PM
> To: [email-masked]'
> Subject: RE: [mobile-ip] Regional Registration Last Call Resolution
Issue
> #1
> 
> Hi Emad,
> 
> I don't know if you accidentally removed
> the list or not, so I won't put it back.
> But feel free to forward.
> 
>   > 	I agree that MIP may not deal directly with services, but what
>   > is the benefit of mobility information? I may not mean exact
>   > geographical location, but what I mean is the service
>   > provider may care
>   > about the proximity of the MN, and GFA will prevent,
>   > depending on the
>   > size of the coverage area, such info from being propagated.
> 
> => Yes, that's true, but the question is whether
> you could rely on IP addresses at all for
> geogrphical location management. 3G systems for
> example have very large coverage areas per FA, which
> would prevent operators from locating MNs to even
> a suburb, so it's difficult to reply on IP
> addresses for this purpose.
> 
>   >
>   > 	In general, I believe the group should follow a mechanism of not
>   > introducing features/enhancements that may add to the real
>   > time impact.
>   > I may be wrong from others point view, but just raising my
concern.
> 
> => I don't think your statement above is wrong, in fact
> I agree, but I don't see that being the case in this
> draft.
> The difference between updating the GFA in Reg reg, and
> the FA in FMIP is the type of optimisation that you
> get. When updating the GFA, you are optimising for
> minimal delays for new packets, but you will be likely
> to introduce more losses (depending on the pipe between
> the GFA and FA). If you rely on updating the FA
> only (FMIP approach) then you could minimise the packet
> losses, but possibly get more delays (depending on the
> pipe between oFA and nFA). So each approach has
> its pro and con, combining both (as outlined in the FMIP)
> draft, would lead to better results than if each
> one is used separately.
> 
> So the question here is whether people think the
> optimisation is worth the complexity. But I don't
> see a question of whether this mechanism will add
> benefit or not, it certainly does. The question
> is: How big is the benefit? that's probably a better
> focus for the discussion.
> 
> Hesham
> 
>   >
>   > Thx.
>   >
>   > > -----Original Message-----
>   > > From: [email-masked] [mailto:owner-mobile-
>   > > [email-masked]] On Behalf Of Hesham Soliman (ERA)
>   > > Sent: Monday, May 13, 2002 11:51 AM
>   > > To: [email-masked]; 'James Kempf'; 'Phil Roberts'; mobile-
>   > > [email-masked]
>   > > Subject: RE: [mobile-ip] Regional Registration Last Call
>   > Resolution
>   > Issue
>   > > #1
>   > >

---

From: "Ahmad Muhanna"<[email-masked]>
Date: Tue, 14 May 2002 09:17:23 -0500

Phil/Annika,

Please see my comments inline.

Regards;
Ahmad Muhanna

> 
> Phil
> 
> "Abstract
> 
> Using Mobile IP, a mobile node registers with its home agent 
> each time it 
> changes care-of address. If the distance between the visited

Well, this statement is correct. 
However, the proposed Regional Registration draft still does exactly what
this sentence states!!!!
 
> network and 
> the home network of the mobile node is large, the signaling 
> delay for these 
> registrations may be long. This document describes a new kind 
> of "regional" 
> registration, i.e., registration local to the visited domain. 
> The regional 
> signaling is performed via a new network entity called a 
> Gateway Foreign 
> Agent and introduces a layer of hierarchy in the foreign 
> domain. Regional 
> registrations reduce the number of signaling messages to the 
> home network, 
> and reduce the signaling delay when a mobile node moves from 
> one foreign 
> agent to another, within the same visited domain. This document is an 
> optional extension to the Mobile IP protocol."
> 
> 
> "Introduction
> 
> This document is an optional extension to the Mobile IP protocol, and 
> proposes a means for mobile nodes to register locally within 
> a visited 
> domain. By registering locally, the number of signaling 
> messages to the 
> home network are keept to a minimum, and the signaling delay 
> is reduced.
> 
> In Mobile IP, as specified in RFC 3220 [9], a mobile node 
> registers with 
> its home agent each time it changes care-of address. If the distance

same comment as above!!!!
 
> between the visited network and the home network of the 
> mobile node is 
> large, the signaling delay for these registrations may be 
> long. We propose 
> a solution for performing registrations locally in the 
> visited domain: 
> regional registrations. The regional registration design 
> introduces new 
> Mobile IP messages - Regional Registrations, new Mobile IP 
> extensions to 
> convey information between the mobile node, foreign agent, 
> and home agent, 
> and a new network entity - Gateway Foreign Agent (GFA). Regional 
> registrations reduce the number of signaling messages to the 
> home network, 
> and reduce the signaling delay when a mobile node moves from 
> one foreign 
> agent to another, within the same visited domain. This will 
> both decrease 
> the load on the home network, and speed up the process of 
> handover within 
> the visited domain. The introduction of a GFA also makes it 
> possible to 
> have different addressing realms in the home and in the 
> visited networks."
> 
> 
> The last three paragraphs of the Introduction are unmodified.
>

---

From: Annika Jonsson <[email-masked]>
Date: Wed, 15 May 2002 11:02:26 +0200

Hi Ahmad,

>However, the proposed Regional Registration draft still does exactly what 

sorry, I don't understand what you want to say. Could you please be more 
specific?

/Annika