Subject: Re: [mobile-ip] MN Returning Home

From: [email-masked]
Date: Sat, 18 May 2002 19:35:59 +0530

Hi Francis,

> yes, to be in trouble the S bit must be zero.
> But even though the 'S' bit is set,
> HA  still defend the use of link local address as part of the proxy
functionality.

Yes I am in trouble for the case either 'S' bit is not set or 'S =1 ' &
'D=1'
How to come out of this loop?

Regards
Pav

                    Francis Dupont                                                                     
                    <Francis.Dupont@enst-bret       To:     [email-masked]              
                    agne.fr>                        cc:     [email-masked]              
                    Sent by:                        Subject:     Re: [mobile-ip] MN Returning Home     
                    [email-masked]                                                          
                    ng.sun.com                                                                         

                    05/14/2002 06:54 PM                                                                

   You wrote  'you really have a problem when the "whole subnet" is
registered
   you mean the case where 'S' bit is not set.

=> yes, to be in trouble the S bit must be zero.

   But even though the 'S' bit is set, HA still defend the use of link
   local address as part of the proxy functionality.

=> no, it doesn't. The current draft is terrible but it doesn't say (yet :
-)
the link-local address is defended against DAD:
 - if the D bit is set a DAD is performed for the link-local address
   before the BU is accepted.
 - if the S bit is set then the proxy address set is reduced to the
   home address else it is the whole set of derived addresses, including
   the link-local one.
 - the proxy function includes the defense against DAD (just because
   it replies to any NS for the proxied addresses).
 - if the R bit is set then it is copied into NAs.
   (at the last IETF meeting I said the R bit was forgotten,
    I-D authors, wake up and PLEASE PUT IT BACK. BTW fix the unicast NS
    to get the home agent link-layer address)

Note an agnostic MN returning at home can fail to perform DAD on
a previous home address registered with D=1, S=1. IMHO 11.6.7
should be more accurate, I propose to add to:

   agent's use of the same address.  If the mobile node returns home
   after the bindings for all of its care-of addresses have expired,
   then it SHOULD perform DAD.

near the end of page 138

   <including for addresses which can have been registered with D and S
    bits set to one>.

Regards

[email-masked]

PS: I-D 17 has more than 170 pages. This is ridiculous, all not finished
features should be moved to other documents. It seems that RR should not
be in the list but I propose to begin with:
 - renumbering support (complex, dubious utility today)
 - home agent address discovery (or make it secure, good luck :-).

---

From: Francis Dupont <[email-masked]>
Date: Sat, 18 May 2002 18:23:08 +0200

=> I believe we should keep the DAD as it is *without* link-local
optimization and we should support only the case where the S bit is one
(i.e. make it always one in the next I-D and move the discussion to
further studies). Read my last message about this (answer to Vijay).

Regards

PS: my main argument is this is too complex and must be KISS ASAP.