Subject: Re: [mobile-ip] comments on MIPv6 draft-17

From: Samita Chakrabarti <[email-masked]>
Date: Thu, 30 May 2002 17:35:48 -0700 (PDT)

Hi Jari,
 
> 
> > - Section 6.1.3: Why is the HA tunnelling the HOT a SHOULD?
> > It seems that this is one of the assumptions that the
> > protocol is based on (see the security design section).
> > Shouldn't this be a MUST? Not making this a MUST will
> > allow attacker on the MNs link to do some nasty stuff.
> 
> There was a separate thread about this a couple months
> ago. It seems that the added benefit of encrypted tunneling
> is quite useful, but mainly for the benefit of the mobile
> node. Not absolutely necessary perhaps for the security
> of other nodes. Hence SHOULD.

I think Hesham has a good point here. If you look at the 
"More comments on Draft16 -CLARIFICATION " thread (issue #19), where
I asked the same question that both HOTI/HOT messages
must use ESP tunnel and I thought the decision was 'yes'.
 
 Here is some excerpt from that old email discussion:

-------------------------------------------------------------------- 
> 2.
> Also, we have had email discussion that only HOT message is sent in
> ESP tunnel mode. For symmetry, we should mandate ESP tunnel mode for
> both HOT/HOTI messages between MN-HA.

Yes. This is especially important given the mobile-side cookies for
weak CoT/HoT authentication (prevention of random nodes from the
internet spoofing these).

> Also, we need to clarify in the draft that ESP tunnel mode must(?) be used
> over the MN-HA tunnel for binding update signalling HOTI/HOT traffic
> only. The regular data traffic through the same MN-HA tunnel may not 
> necessarily be protected by ESP.

Yes.

---------------------------------------------------------------------------

It makes more sense to have MUST for both HOT/HOTI ESP tunnel mode.
If the Mobile node can send HOTI message in ESP tunnel mode, it should
be able to process incoming HOT ESP tunnel data. Otherwise, the protocol
seems very assymetric and lacks required security as well.

> 
> > - Section 8.1,what is the point of mandating the HAO
> >   when the  spec says that it must not be received
> >   without a BCE, and the entire RO is a 'should'.? 
> >   The HAO should follow the same recommendation as RO.
> 
> I agree. Should be the same as the rest.
> 

Are you adding a separate section on "CN behavior" to specify that
all IPv6 nodes that support MobileIPv6 correspondent node functionality,
MUST support Route Optimization ?

This information is necessary to specify in the draft to avoid confusion
on correspondent node implementation.

Do we agree on that ?

Thanks,
-Samita

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 30 May 2002 17:55:36 -0700

hi,

> must use ESP tunnel and I thought the decision was 'yes'.

issue #14 was about "Require encryption on HA-MN tunnel for MH 
messages?". the issues list says the adopted concensus was MUST 
implement and SHOULD be used.

Vijay