Subject: Re: [mobile-ip] issue #25

From: [email-masked]
Date: Thu, 30 May 2002 09:24:19 +0530

hi Arvind,

[email-masked] wrote:

> ==>>
> I am satisfied with this, BU to CN or HA should have HAO and BA should
have
> RH except when BU is for deleting the Binding cache entry.

a small addition to this. the BA should have a routing header when
the BU for deleting the Binding Cache entry is sent from a visited
link. otherwise the BA would not reach the MN. the routing header
is not present only when the MN returns home and sends a
deregistration BU.

Vijay

==>>
Yes, I agree that we have to add routing header when MN is in foreign
network and sends BU for deleting entry.

Arvind

---

From: Jari Arkko <[email-masked]>
Date: Sat, 01 Jun 2002 02:01:01 +0300

Looks like the discussion is converging. Is this the right
conclusion:

Dest  Life   Source   BU/w HAO   BA/w RH
========================================
 HA    >0     CoA       Yes        Yes
 HA    >0     HoA        No         No
 HA    =0     CoA       Yes        Yes
 HA    =0     HoA        No         No
 CN    >0     CoA       Yes        Yes
 CN    >0     HoA        No         No
 CN    =0     CoA       Yes        Yes
 CN    =0     HoA        No         No

Essentially, HAO is included exactly when BU source is
not the home address. RH is included exactly when there
was a HAO in the BU.

The special case requested by Vijay (return home and
de-register) appears to be covered in the above, since
when you return home your source is home address
and. De-registration happens regardless of the lifetime
field.

Jari