Subject: RE: [mobile-ip] Regional Registration Last Call Resolution Issue #4

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Thu, 23 May 2002 14:22:44 +0200

> > I don't understand why certain actions are taken towards
  > > some proposals and not others. Why was their a big LMM
  > > requirements doc done for one WG document and not
  > > for reg reg in MIPv4?
  > > All these things need to be considered. Using a separate
  > > process to handle each proposal is not only confusing,
  > > but will likely lead to no direction for this WG's output.
  > >
  > > Please follow one process!
  > 
  > The explanation is simple.  The Regional Registration
  > specification for IPv4 started much earlier than any
  > such work for IPv6.  You might as well wonder why
  > there isn't a Security Considerations for base IPv4
  > specification.
  > 
  > However, if it actually matters to the discussion, the
  > last time I read the LMM document, I determined that
  > Regional Registration for IPv4 met the requirements
  > very well.

=> I'm not disagreeing with that and I haven't
looked into it to verify it. But my point is, 
having one process, one direction and one
set of requirements will be very helpful
and avoid this confusion. 
Last time I looked at Regional Regv4 it was 
going through (finished) last call with some 'minor'
comments. Now, a year later, we're discussing 
major (allegedly) architectural problems! 

Sigh

Hesham

---

From: "James Kempf" <[email-masked]>
Date: Thu, 23 May 2002 08:35:10 -0700

Hesham,

> major (allegedly) architectural problems!

There's a learing process involved here. Issues that don't look like a
problem become more relevent in light of subsequent events. Real world
example: airport security in the light of 9/11.

There has been a lot of focus over the last year on the architectural
implications of proxies, in particular, application proxies. Sally
Floyd's draft and Brian Carpenter's revision of the Internet
architecture draft to talk about proxies, along with publications by
Internet pioneers such as Dave Clark discussing modifications to end to
end as the Internet evolves have all lead to a closer look at what the
effects of proxies are on the Internet architecture and how to maintain
the spirit of end to end as that architecture evolves.

So expecting the WG and WG chairs to have anticipated this debate last
year is probably a little much to ask. We learn as we go along.

            jak