Subject: RE: [mobile-ip] Issue #23 and Issue #30

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Fri, 31 May 2002 18:49:46 +0200

Sorry for the late  reply.

> => I think the HA must defend all addresses, including
> the link-local one. This is related to RFC3041 and
> Francis' discussion on the IPv6 list. A node implementing
> RFC 3041 might form a global address that belongs to one of
> the other MN's Home addresses. Hence, if the HA does not
> defend all addresses, a MN might 'lose' one of its
> home addresses to another node on the home link.

I'd rather prohibit such behavior.  I don't see the
need for it.  I am surprised that RFC 3041 would
allow such behavior.  Can you point out the offending
part of the specification?  What was the justification
for enabling this?  Aren't there "enough" random numbers
in 2^64 to avoid clobbering addresses used byHi Charlie other
nodes?  sheesh...

=> RFC 2462 makes an optimisation (not a good 
one IMHO) that if a node does DAD on link-local
addresses, it 'owns the interface id' for any other
address with any scope. 
RFC3041 says that a node can generate a new iid
and does DAD for _that_ address which uses the 
new iid. Since this is typically not a link local
address, you could get a conflict if the HA
does not defend all addresses. 

For more info, see Francis' thread on 'diid'. 

I won't be able to relpy quickly at least 
till monday. 

Hesham

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 31 May 2002 10:02:59 -0700

Hello Hesham,

> addresses, it 'owns the interface id' for any other

I think this is a good idea.

> does not defend all addresses.

The problem is that RFC 3041 should require any
such node to first acquire rights to the link-local
address.  I hope that is viewed as an omission, and
one which can be quickly repaired.

Regards,
Charlie P.