Subject: Re: [mobile-ip] Length field definitions - rfc3115

From: Jeff Dyck <[email-masked]>
Date: Mon, 06 May 2002 12:44:15 -0700

Hi Kent,

I realize this is an old topic, however your comment below seems to miss 
the contradiction.  I thought I'd point it out once again to make sure you 
are aware.

The reserved field precedes the length field, i.e. this is not consistent 
with the general definition of the length field where length is equal to 
the # of following bytes.  In the case of the [CN]VSE it is # of bytes 
following + 1 byte (reserved).

However, since 3115 is already standards track, I don't think this should 
be changed.

Jeff

At 03:41 PM 2/18/2002 -0600, Sebastian Thalanany wrote:
>Hello Kent,
>                       Thanks for the confirmation.
>
>Regards,
>    Sebastian
>
>kleung wrote:
>
> > Sebastian Thalanany wrote:
> >
> > > Hello Kent,
> > >                       Since rfc3115 is based on rfc2002, which was
> > > obsoleted last month by rfc3220, it would perhaps be preferrable to
> > > update rfc3115 with the general format specification for a skippable
> > > extension(NVSE) as specified in rfc3220. If the intent of the
> > > "Reserved" field is to extend the Type field, as indicated in section
> > > 1.10 and 1.11 of rfc3220, or for some other purpose, then perhaps the
> > > following definitions for a CVSE element and an NVSE element may avoid
> > > ambiguities in interpretation:
> > >
> > > 1. CVSE
> > >          Length         Length in bytes of the Value(data) field
> > > within
> > >  this extension.  It does NOT include the bytes associated with the
> > >  Type, Length and the Reserved fields.
> > >
> > >
> > > 2. NVSE
> > >        Length         Length in bytes of the Value(data) field within
> > >  this extension.  It does NOT include the bytes associated with the
> > >  Type, Length and the Reserved fields.
> > >
> >
> > Not this.
> >
> > >
> > >  or
> > >
> > >         Length        Length in bytes of the Value(data) field within
> > >  this extension. It does NOT include the bytes associated with the
> > > Type, Length fields. The Length field MUST be set to 2 plus the length
> > >
> > > of the Value(data) field, where the additional two octets are required
> > >
> > >  to include the length of the Reserved field.
> > >
> >
 > This one.  Length is always what follows that field in the
 > extension.  This is consistent with 1.9, 1.10 and 1.11.
> >
> > Thanks.
> >
> > Kent
> >
> > >
> > >         For the NVSE, please confirm one of the two proposed
> > > definitions.
> > >
> > >         Thanks.
> > >
> > > Regards,
> > >    Sebastian

__________________________________________________
Jeffrey Dyck, Engineer
QUALCOMM CDMA Technologies
(858) 845-7548
[email-masked]

---

From: kleung <[email-masked]>
Date: Mon, 06 May 2002 13:47:07 -0700

The fields for CVSE and NVSE are different.  So in summary...

For CVSE
   Length     Length in bytes of this extension, not including the Type,
              Length, and Reserved field bytes.

For NVSE
   Length     Length in bytes of this extension, not including the Type
              and Length field bytes.

So consistency check remains ...

Kent

--
     |           |                   Kent Leung
    :|:         :|:                  IOS Development
   :|||:       :|||:                 Voice: 408.526.5030
  :|||||||:   :|||||||:              Email: [email-masked]
.:|||||||||:.:|||||||||:.            URL  : http://wwwin-mobileip:8000
 c i s c o S y s t e m s             "Enabling the mobile wireless age!"

---

From: Jeff Dyck <[email-masked]>
Date: Tue, 07 May 2002 22:11:14 -0700

Thanks for the clarification.

Is there any plan to update the RFC and if so when might that happen?

Jeff