Subject: RE: [mobile-ip] Regional Registration Last Call Resolution Issue #4

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 22 May 2002 19:15:48 +0200

> > => So assuming we agree on the 'proxy' part, why
  > > is it architecturally different from application
  > > proxies? that is, given the impacts on a particular
  > > application.
  > >
  > 
  > It is different because if an application proxy fails, 
  > there is still
  > the possibilty for the two hosts to continue their session 
  > since a route
  > will exist between the two, perhaps minus the services 
  > provided by the
  > proxy. If a routing proxy fails, the session is terminated.

=> Sure, but where do you draw the line? And what if 
a single node has 10 application proxies? What if 
there were no other applications that the two nodes
could use? 
There is no clear line to draw here.

  > > I would also like to add a note, for the WG in general,
  > > not only to James. Can we _pleeeease_ have some consistency
  > > in the way we assess proposals. Let's consider the RFC being
  > > referenced here (1958). Doesn't the quote used by Phil
  > > state that the intelligence should be in the end hosts?
  > > So why are we accepting proposals that do not follow
  > > these principals?
  > > Yes I'm referring to both FMIPv4 and FMIPv6, and I have
  > > contributed heavily to both drafts, so no bias here ;)
  > >
  > 
  > I do not intend to get into a debate here about whether 
  > modifications of
  > network routing protocols or using MIP's host based routing 
  > is the right
  > way to do fast handover. I believe the data we and others 
  > are collecting
  > about what works will speak for itself.

=> I'm not trying to start the debate, but the point
is,RFC 1958 is being quoted, so either we use that
quote for all the WG docs ( can of worms) or we 
don't quote it. I'm happy with either option.

Again where do we draw the line between allegedly
breaking the architecture of the Internet and 
performance gain. How much performance gain is 
the Internet architecture worth ? :) :)

Hesham

---

From: "James Kempf" <[email-masked]>
Date: Wed, 22 May 2002 13:16:08 -0700

> There is no clear line to draw here.

The line is drawn where the failure of a network element causes the
session between the two hosts to fail.

> the Internet architecture worth ? :) :)

Like I said, I am not going to debate the issue here. Open
a separate thread on the topic if you want to debate.

            jak