Subject: RE: [mobile-ip] Regional Registration Last Call Resolution Issue #4

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 22 May 2002 12:02:56 +0200

James, 

Since I disagree with the 'architecture' argument, I have
to comment on this.

  > The GFA constitutes a routing proxy. RFC 3238 gives architectural
  > considerations for defining services on application 
  > proxies, but many of
  > the considerations involved in introducing fate-sharing between the
  > application proxies and end hosts are difficult to envision for a
  > routing proxy.

=> So assuming we agree on the 'proxy' part, why
is it architecturally different from application
proxies? that is, given the impacts on a particular
application.

  > 
  > One argument I have heard in favor is that the Home Agent functions
  > essentially as a routing proxy, so why is introducing a 
  > routing proxy in
  > the foreign network any different? The answer is that the 
  > Home Agent is
  > architecturally necessary to achieve the separation between node
  > identifier and routing identifier, while the GFA is just a 
  > performance
  > enhancement. 

=> Disagree with the role of the HA. The HA is needed
to allow MNs to be reachable. That's all it's 
needed for. It doesn't separate the locator and identifier
because they are both represented by the home address. 
Architecturally, that may not be a clean thing to do 
but currently there is no other scalable way of
providing reachability. 

Also, regardless of why it's needed, it's already
there. We already have a precedence. BTW, this raises
the issue of HA redundancy. We need to address that 
at some stage.

While there are other ways of achieving the 
  > node/routing
  > identifier separation, they all have more serious problems
  > architecturally and practically than the Home Agent. With 
  > the GFA, there
  > are other ways to achieve the same performance enhancement, 
  > and these
  > are not difficult to implement and probably not particularly more
  > difficult to deploy, since they are based on enhanced edge routing.
  > Their reliability characterstics essentially match those of 
  > the access
  > routers.

=> Like ? Any existig standard?

I would also like to add a note, for the WG in general, 
not only to James. Can we _pleeeease_ have some consistency
in the way we assess proposals. Let's consider the RFC being
referenced here (1958). Doesn't the quote used by Phil
state that the intelligence should be in the end hosts?
So why are we accepting proposals that do not follow
these principals?
Yes I'm referring to both FMIPv4 and FMIPv6, and I have
contributed heavily to both drafts, so no bias here ;)

I don't understand why certain actions are taken towards
some proposals and not others. Why was their a big LMM
requirements doc done for one WG document and not 
for reg reg in MIPv4? 
All these things need to be considered. Using a separate
process to handle each proposal is not only confusing,
but will likely lead to no direction for this WG's output.

Please follow one process!

Hesham

---

From: "Madhavi W. Chandra" <[email-masked]>
Date: Wed, 22 May 2002 09:26:23 -0400

Hi Hesham,

> the issue of HA redundancy. We need to address that 

Good point.  We submitted a draft last year on 
HA Redundancy...which has expired.  We will be revising
and resubmitting soon.
 
> but will likely lead to no direction for this WG's output.

Another good point.  It would helpful to have a requirements
document to compare the solutions...especially, given Alan's
contributions in this arena.  I haven't looked at the LMM draft
lately, but perhaps we can 'extrapolate' from it for MIPv4.

Thanks,
Madhavi

---

From: Milind Kulkarni <[email-masked]>
Date: Wed, 22 May 2002 08:38:16 -0700

> Please follow one process!

Couldn't agree with Hesham more! Some proposals need problem 
statement and/or requirement doc, while some proposals don't 
need any of that. It is not only confusing but may also give an 
impression that things are not equal. I hope the WG addresses 
this confusion. Please elaborate and follow one process.

Thanks,
Milind

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 22 May 2002 11:03:27 -0500

Can we read this as an endorsement of
http://ietf.org/internet-drafts/draft-ietf-mobileip-hmipv6-05.txt?

Regards,

-- 
Behcet

---

From: "James Kempf" <[email-masked]>
Date: Wed, 22 May 2002 09:07:22 -0700

> proxies? that is, given the impacts on a particular

It is different because if an application proxy fails, there is still
the possibilty for the two hosts to continue their session since a route
will exist between the two, perhaps minus the services provided by the
proxy. If a routing proxy fails, the session is terminated.

> but currently there is no other scalable way of

There is still a routing function attached to the home address to get
the first packets to the host. But particularly in MIPv6, that function
is reduced by route optimization, where the home address is not used for
routing until after the first few packets. It is a typical engineering
compromise.

> the issue of HA redundancy. We need to address that

Agree. though I am not sure whether a standard in this area is
warrented.

> => Like ? Any existig standard?

A draft is being prepared on the topic.

> contributed heavily to both drafts, so no bias here ;)

I do not intend to get into a debate here about whether modifications of
network routing protocols or using MIP's host based routing is the right
way to do fast handover. I believe the data we and others are collecting
about what works will speak for itself.

> Please follow one process!

Could not agree with you more here, Hesham.

            jak

---

From: Milind Kulkarni <[email-masked]>
Date: Wed, 22 May 2002 15:03:38 -0700

Apples and oranges Behcet! How did you conclude that
it's an endorsement? It's completely irrelevant and
laughable comment to the present discussion. 

I would like to stick to the issue at hand: the need 
to outline and follow uniform process for all proposals.
I sincerely hope the WG and chairs address that.

Thanks,
Milind

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 22 May 2002 17:20:04 -0500

I resent the language you used.
If your answer is no simply say it.
 
I know the history of events around these two drafts mipv4 regreg and 
mipv6 regreg, that was the reason why I had asked.

---

From: Milind Kulkarni <[email-masked]>
Date: Wed, 22 May 2002 15:27:46 -0700

> mipv6 regreg, that was the reason why I had asked.

Again, I would appreciate if you can tell us how does that 
matter to the present discussion?

Thanks,
Milind

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 22 May 2002 18:22:47 -0500

Hello Hesham,
  Your most popular quote of the day:

>Please follow one process!
Was it not the case that LMM requirements applied to both v4 and v6? The 
present draft

> http://ietf.org/internet-drafts/draft-ietf-mobileip-lmm-requirements-01.txt

is only for IPv6 however it could be revised easily to be for both 
versions.
  I hereby suggest that we kindly request Carl to undertake this 
revision so that his draft could move to the last call. Then and only 
then the justice will be served.

My 0.02 cents.

-- 
Behcet

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 22 May 2002 16:23:36 -0700

Hello Hesham,

> Please follow one process!

The explanation is simple.  The Regional Registration
specification for IPv4 started much earlier than any
such work for IPv6.  You might as well wonder why
there isn't a Security Considerations for base IPv4
specification.

However, if it actually matters to the discussion, the
last time I read the LMM document, I determined that
Regional Registration for IPv4 met the requirements
very well.

Regards,
Charlie P.