Subject: RE: [mobile-ip] Unresolved issue #7: MH format

From: "Karen E Nielsen (TED)" <[email-masked]>
Date: Thu, 2 May 2002 20:58:51 +0200

Hi Francis,

>  In your previous mail you wrote:
> 
>    > => this is *not* true: if the IPsec transform is not AH, the 
>    > HAO is not
>    > covered by the integrity check and it is authenticated 
> only by the SA
>    > lookup (i.e. not by the crypto, only by (reusing Mike 
> Thomas' words)
>    > an access-list mechanism).
>    
>    An why is it that this (SA lookup) isn't good enough ? 
>    
> => an access-list like check is far weaker than a 
> crypto-based integrity
> and authentication check, and IMHO too weak (i.e. not good enough).
> 

If you're saying that not all IPSEC implementations perform the 
(in 2401 mandated) SA selector matching and that
such IPSEC implementations should be allowed,
i.e. do not "stretch" IPSEC to much, then I agree that
crypto is needed. 

However, the fact remains that if the SA selector contains the HoA 
(which I suppose it should unless you want the 
SA to be shared between the receiving node and a range of 
(or all) hosts from which it is accepting BU's) 
and if the SA selector match can be relied on to be performed,
then the HoA IS integrity protected and crypto doesn't buy you any extras. 

BR,
Karen

---

From: "Karen E Nielsen (TED)" <[email-masked]>
Date: Mon, 6 May 2002 12:40:56 +0200

Hi Mike,

> Let me ask a very leading question: do you think
> that IPsec security associations which are
> divorced from the current topology and their
> routing tags (eg, ip addresses) could be an
> interesting property for mobility? I sure do.
> 
> I believe that all you need to do affect this is
> to wildcard the SA ipsrc selectors on the
> receiving end.
> 
>  > > I assume that you're concerned about bandwidth?
>  > > See my question about the possibility of eliding
>  > > the HAO.
>  > 
>  > Unless you want the IPSEC SA's (and SPD's) to be anchored 
> on the CoA you would
>  > need the HoA to be in one of the SA selector fields, or am 
> I missing something ?
> 
> Maybe. If the access control element on the
> receiver is permissive (eg, a valid hash is
> sufficient to let the packet through), it won't be
> anchored *anywhere*. This seems like a very
> interesting property to me.

Thanks a lot for explaining. 

I agree that this is an interesting property. However, with the current 
IPSEC architecture wouldn't this mean that - 
ONE : Policies can now only be anchored on the payload, which in this case is the MH. 
Hence all inbound packets with a MH must be protected in the same manner
wrt. Security Protocol, algorithm, key lengths etc.
Of course, if you can differentiate the MH type (as a payload port number) this only goes
for MH of specific type.
TWO - more important : The SA processing will only check that the correct payload was in the packet. 
Hence, unless you have some way to verify the association between the SPI and the HoA, then when A
has a SA with its HA for the protection of MH of a certain type, i.e. BU's, A
can use this SA (and SPI) to send bogus BU's for all other MN's that the HA serves.
 - ?? -

Karen

---

From: "Karen E Nielsen (TED)" <[email-masked]>
Date: Mon, 6 May 2002 12:58:11 +0200

> => same answer... Your argument seems that firewalls and 
> IPsec give the
> same level of security and I (and many others) disagree.
> AH will be deprecated in IPsec v3 (cf last IETF meeting), HAO is not
> always present, etc, so I believe to make the HoA optional is not
> a good choice (i.e. it is too soon for space optimization of mobility
> signaling).
> 

I am saying that the SA selector check integrity protects all non-wildcard
SA selector items. If you "and many others" have the experience that this is to weak,
(for what ever reason I have still to understand, but so be it) then I suppose that the HoA must be
included in the BU, if the BU (and the HoA) is to be authenticated by IPSEC ESP. 
Whether this is sufficient to mandate the presence of the Hoax in the BU, is up to others to decide.

BR, Karen