Subject: RE: [mobile-ip] Issue #23 and Issue #30

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Wed, 29 May 2002 13:19:52 +0200

> I should clarify: My expectation is that the home agent should
  > ONLY defend the mobile node's link-local address, not its other
  > addresses.  Then, by implication, the other addresses will be
  > unavailable to nodes on the link because they can't form the
  > link-local address to start with.
  > 

=> I think the HA must defend all addresses, including
the link-local one. This is related to RFC3041 and
Francis' discussion on the IPv6 list. A node implementing
RFC 3041 might form a global address that belongs to one of 
the other MN's Home addresses. Hence, if the HA does not
defend all addresses, a MN might 'lose' one of its
home addresses to another node on the home link.

Hesham

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 29 May 2002 08:40:35 -0700

Hello Hesham,

I CC:'d the IPv6 mailing list...

> home addresses to another node on the home link.

I'd rather prohibit such behavior.  I don't see the
need for it.  I am surprised that RFC 3041 would
allow such behavior.  Can you point out the offending
part of the specification?  What was the justification
for enabling this?  Aren't there "enough" random numbers
in 2^64 to avoid clobbering addresses used by other
nodes?  sheesh...

Regards,
Charlie P.

---

From: "Dr. Subrata Goswami" <[email-masked]>
Date: Wed, 29 May 2002 09:02:45 -0700

If  a mobile doing RFC 3041 changes its IID (say after rebooting for
some reason) in a foreign network it has to do the following.
1. Forms a new link-local address based on the new IID.
2. Sends a BU to the HA with the new IID (is there an option for this
?).
3. The HA realizes that the IID has changed (security implications ?).
4. The HA starts defending the new link-local address.

It would be simple if the requirement to defend the l-l address is
dropped.
Moreover, a stateful (DHCP based) assignment of a HoA would not use the
IID anyway.

Subrata

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Hesham Soliman
(ERA)
Sent: Wednesday, May 29, 2002 4:20 AM
To: 'Charles E. Perkins'; Dr. Subrata Goswami
Cc: [email-masked]
Subject: RE: [mobile-ip] Issue #23 and Issue #30

Hesham