Subject: [mobile-ip] RFC 2462 DAD optimization

From: "Richard Draves" <[email-masked]>
Date: Fri, 31 May 2002 10:39:18 -0700

I disagree. I think the problem is in the RFC 2462 optimization. The RFC
2462 optimization also can fail with manually-configured addresses -
it's not just a problem with RFC 3041 temporary addresses.

I'm curious about the implementation status. I know the Windows
implementation does not implement the RFC 2462 optimization - it
performs DAD on every address independently. What about other
implementations?

Rich

> -----Original Message-----
> From: Charles E. Perkins [mailto:[email-masked]] 
> Sent: Friday, May 31, 2002 10:03 AM
> To: Hesham Soliman (ERA)
> Cc: [email-masked] '; 'IPng Working Group '
> Subject: Re: [mobile-ip] Issue #23 and Issue #30
> 
> 
> 
> Hello Hesham,
> 
> "Hesham Soliman (ERA)" wrote:
> 
> > => RFC 2462 makes an optimisation (not a good
> > one IMHO) that if a node does DAD on link-local
> > addresses, it 'owns the interface id' for any other
> > address with any scope.
> 
> I think this is a good idea.
> 
> > RFC3041 says that a node can generate a new iid
> > and does DAD for _that_ address which uses the
> > new iid. Since this is typically not a link local
> > address, you could get a conflict if the HA
> > does not defend all addresses.
> 
> The problem is that RFC 3041 should require any
> such node to first acquire rights to the link-local
> address.  I hope that is viewed as an omission, and
> one which can be quickly repaired.
> 
> Regards,
> Charlie P.
> --------------------------------------------------------------------
> IETF IPng Working Group Mailing List
> IPng Home Page:                      http://playground.sun.com/ipng
> FTP archive:                      ftp://playground.sun.com/pub/ipng
> Direct all administrative requests to [email-masked]
> --------------------------------------------------------------------
>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 31 May 2002 10:44:54 -0700

Hello Richard,

Even manually configured global addresses should be required
to acquire rights to the corresponding link-local address.  Why not?

Regards,
Charlie P.