Subject: RE: [mobile-ip] I-D ACTION:draft-mccann-mobileip-80211fh-01.txt

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 13 Nov 2002 17:47:47 +0100

> >     In HIP, the
  > >   > two are different from the start, in MIP, the node id just
  > >   > happens to also be a
  > >   > routable IP address.
  > >
  > > => No. This is a different argument from HIP. An MN can have
  > > multiple home addresses on the _home_interface_. While at
  > > home these addresses are tied to a physical i/f, while away from
  > > home thwey are tied to a tunnel i/f.
  > >
  > 
  > But it can only have a single address tied to a single name 
  > in the global DNS.

=> No. Any node can have multiple home addresses
and put them all in the DNS.

  > It can, of course, put multiple names into the DNS, just 
  > like it can have
  > multiple public keys, and thus multiple HIP identifiers. I 
  > don't think this
  > invalidates my argument.

=> No, see above.

  > If the MN's default router fails, then it must do RS/RA 
  > once again to find a new
  > router on the same link if it discovers the failure, or 
  > perhaps it gets ICMP
  > Redirect from the new router if there is active failover. 
  > Packets with the old
  > router's link layer address, which is what the MN's routing 
  > tables will assign
  > to the frame, won't be delivered.

=> Ok, but that was not my point. The point is that the 
AR's job is identical to the HA's job. BTW, a host 
does not have a routing table, in IPv6 a host has a destination
cache.

  > 
  > So I think this is exactly analogous to the situation when 
  > the MN changes links
  > but only finds out about it afterwards. Allowing the MN to 
  > put the old router IP
  > address and it's PCoA into the RS allows the MN to treat 
  > the two cases the same,
  > resulting in a cleaner implementation.

=> There are so many architectural and security issues
there. 
Architectural: RS's are NOT designed for this use. This 
is an abuse of an existing message. 
Security: How will you secure the RS? If you answer 
this question, you can answer the exact same question
about the BU. 

  > But it is used by nodes to discover and route packets to 
  > hosts that are on their
  > link. 

=> Right, to discover IP addresses and MAC addresses, 
this is not a routing protocol. Although multi-link
subnets make ND look like DSR or AODV but that's a 
different issue.

Hesham

---

From: "James Kempf" <[email-masked]>
Date: Wed, 13 Nov 2002 12:31:55 -0800

>does not have a routing table, in IPv6 a host has a destination

I disagree. It is perfectly possible to have a server sitting in the middle of
somebody's network with nothing connected to it acting as an HA. That doesn't
make sense for an AR.

> is an abuse of an existing message.

My feeling is that BUs aren't either.

> this question, you can answer the exact same question

Same way as any security is done for any ND message.

            jak