Subject: [mobile-ip] Re: Cached RA v.s. Fast RA

From: "Youn-Hee Han" <[email-masked]>
Date: Wed, 20 Nov 2002 10:56:51 +0900

James Kempf" wrote : 

> The problem with this proposal is that the AP doesn't exist as far as IETF is
> concerned. An AP is not an IP device, and it is not on the map as far as the
> Internet architecture is concerned.. Routers do exist and therefore the fast RA
> could be standardized in the IETF.

Ok. An AP is not an IP device. 
However,  I want to include the AP in the *Mobile IP device*
Although the AP is not on the map of IETF, 
the performance and operability of moble IP will become better
if we consider L2 & L3 combination for fast handoff.
 
"draft-mccann-mobileip-80211fh-00.txt" is a 802.11-related draft
, and it is runring for being a standardization in IETF.
I think that *The AP cahed RAs* can be a standardization in IETF, too. 
  
> 
> That said, I think the proposal is a good one and it should be taken to IEEE
> 802.11. Somehow, we need to figure out a way to get 802.11 to pay more attention
> to MIP.

I agree with you. 
Currently, we have three 802.11-related works in Mobile IP.
1) Fast-Handover MIPv6 over 802.11
2) AP with the cached RA.
3) L2 trigger API (this may be used in Fast-Handover MIP over 802.11)
Maybe, more 802-11 related works will be appeared in the future.

Youn-Hee Han

> ----- Original Message -----
> From: "Youn-Hee Han" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, November 19, 2002 4:05 PM
> Subject: Fw: RE: MIPv6 and ND value changes
> 
> 
> > Richard wrote :
> >
> >  > I'd add the minor points that section 11.5.2 contains a basic version of
> optimistic
> > > DAD (its been there since draft 12) and that there AP cached RAs are an
> > > alternative to fast RAs in yet another separate draft.
> >
> > I agree with Richard.
> > The AP cahed RAs can be esaily implemented and an alternative to fast RAs.
> > IMHO, The AP which cache RAs and sends them to an MN at its association with
> the AP,
> > is more deployable approach than router supporting fast RA.
> > The change of AP is easier than the change of router.
> >
> > Youn-Hee Han
> >
> >
> >
> >
> >
> > --------------------------------------------------------------------
> > IETF IPng Working Group Mailing List
> > IPng Home Page:                      http://playground.sun.com/ipng
> > FTP archive:                      ftp://playground.sun.com/pub/ipng
> > Direct all administrative requests to [email-masked]
> > --------------------------------------------------------------------
> >
> 
>

---

From: Pyungsoo Kim <[email-masked]>
Date: Thu, 21 Nov 2002 08:50:04 +0900

as i know,  there are two 802.11 deployments : with relays APs and with integrated AP/AR.
thus, i think this proposal(APs cache RAs) can be considered in IETF if  802.11 deployments with "integrated AP/AR" is considered. what do you think?

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Wed, 20 Nov 2002 18:07:05 -0800

Hi James,

> > > could be standardized in the IETF.

IMO, wireless access point (AP) is a L2 bridge. For this bridging
functionality,
it doesn't have to have any "IP" presence. But current products come with an
IP stack, and even more. This is for reasons like management, and using them
as network access servers.

AP is similar to broadband access servers (BAS) used in ISP networks. They
are also
used for AAA and more. They are not the "last hop router" in all cases,
sometimes
they tunnel traffic to an ISP router (e.g., L2TP). And for these
functionalities,
they have IP addresses.

So, I think this concept has been around. Not that new.
As far as IETF is concerned, I think it's an on-link host (with respect to
the
mobile terminal) that also performs bridging between wired and wireless
segments.

host ~~~~~~~~~~~~~ AP ----------- AR ------ Internet
   IP1               IP2       IP3  IP4

IP1, IP2, and IP3 are on the same IP link (same prefix).

Does this view address your concerns?

alper

---

From: "Youn-Hee Han" <[email-masked]>
Date: Thu, 21 Nov 2002 11:19:04 +0900

pyungsoo wrote :

> As i know, APs are acting as link-layer relays, which means that they transport
> Ethernet-layer frames between the wireless medium and the subnet.
> In other words, APs don't provide the IP functionality.

Ok. I see.

> Do you mean that APs should provide the IPv6 functionality to "cache RAs"?

I am telling about an advanced MIPv6 issue "Eliminsation of the random delay before sending an RA."
Brett Pentland said that the followings are a number of MIPv6-optimization discussed on the mailing list.

Optimistic DAD -
<http://www.ietf.org/internet-drafts/draft-moore-ipv6-optimistic-dad-00.txt>
Fast router advertisements - 
<http://www.ietf.org/internet-drafts/draft-mkhalil-ipv6-fastra-02.txt>
Fast router discovery with AP notification - 
<http://www.ietf.org/internet-drafts/draft-jinchoi-l2trigger-fastrd-01.txt>
Duplicate Address Detection Optimization using IPv6 Multicast Listener Discovery - 
 <http://www.ietf.org/internet-drafts/draft-daley-ipv6-mcast-dad-01.txt>

I think that the above documents are worth discussing in the next step of mobileip WG.  
The second document is related to *Fast RA*, and the third document is related to *Cached RA*.
In my opinion, the Kempf's *Fast RA* is a good idea 
because it only requires the change of router, IP device.
However, I don't want to combine the idea with the current MIPv6 spec
, since many MIPv6 guys urge MIPv6 to be a standization.
As a seperate draft, we had better discuss the idea. 

The third document is a good idea, too.
'AP cached RA' is a simple and easy-deployable method 
which can reduce the L3 handover time of mobile nodes.
Yes. The idea is to insert the small part of IPv6 functionality into APs.
As far as I understand, the idea can be an alternative to fast RAs in another separate draft.

> thus, i think this proposal(APs cache RAs) can be considered in IETF if  802.11 
> deployments with "integrated AP/AR" is considered. what do you think?

I agree with James Kempf. 
In an integrated AP/AR, 'AP cached RA' is no different than having
the router send the RA after the MN has done the reassociation.

Youn-Hee Han.

----- Original Message ----- 
From: "Pyungsoo Kim" <[email-masked]>
To: "Youn-Hee Han" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, November 21, 2002 8:28 AM
Subject: Re: MIPv6 and ND value changes

> Han wrote:
> > IMHO, The AP which cache RAs and sends them to an MN at its association with the AP, 
> As i know, APs are acting as link-layer relays, which means that they transport
> Ethernet-layer frames between the wireless medium and the subnet.
> In other words, APs don't provide the IP functionality.
> Do you mean that APs should provide the IPv6 functionality to "cache RAs"?
> 
> Rgds,
> -pyungsoo