Subject: [mobile-ip] How MIPv6 handles multiple simultaneous binding

From: "Koojana Kuladinithi" <[email-masked]>
Date: Mon, 18 Nov 2002 18:05:46 +0100

Hello All,

I have been reading the drafts (19 included) to figure out
how MIPv6 handles multiple simultaneous bindings by multiple interfaces in a
single mobile node
(i.e. all interfaces have one home address and multiple CoA).  But I have
had no success.
Can someone please let me know how this should be handled ?

From what I understand, it seems that the S bit does not relate to handling
multiple simultaneous bindings,
unlike IPv4. Is this correct ?

Thanks in Adavance.
Koojana

Koojana Kuladinithi - B.Sc,M.Sc          Kommunikationsnetze FB 1
Universität Bremen
Otto-Hahn-Allee, NW 1
28359 Bremen
EMail: [email-masked]
WWW:   http://www.comnets.uni-bremen.de

Tel.:  ++49 421 218-8264
Fax:   ++49 421 218-3601

---

From: Greg Daley <[email-masked]>
Date: Tue, 19 Nov 2002 03:27:22 +0000

Hello Koojana,

There's a draft by elmalki & soliman about simultaneous
bindings which bicast traffic for one home address at 
two coa's:

draft-elmalki-mobileip-bicasting-v6-02.txt

This is fairly contentious, because of the tcp's default handling
of doubly (actually, triply) received packets.

Typically, the presence of multiple CoA's is seen as giving
backup binding locations, to which the HA can be directed 
if necessary. In MIPv6, bindings only go to one location (one CoA).

It is possible to have different bindings for each HoA, and there
is some work on bindings for individual flows (i.e. not all traffic
from a node goes to the same CoA), but in these cases, the MN only
receives one copy of each packet.

I hope this helps,

Greg Daley

---

From: Claude Castelluccia <[email-masked]>
Date: Mon, 18 Nov 2002 18:42:56 +0100

Hi,
The "Per-flow movement in MIPv6" draft might actually be the solution to
your problem.
http://www.ietf.org/internet-drafts/draft-soliman-mobileip-flow-move-02.txt
cheers,
Claude.

-- 

----------------------------------------
Claude CASTELLUCCIA, INRIA Rhone-Alpes  
ph:  +33 4.76.61.52.15 (fax: 52.52)
http://www.inrialpes.fr/planete/

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 18 Nov 2002 11:17:55 -0800 (PST)

Hello Koojana,
  S-bit is the single address only bit which means
that the BU sent to HA applies to a single address not
to all interfaces of HA with the same link layer
address of MN (in this case S = 0 should be used which
would enable forwarding of all packets coming to any
interface of HA, basically making simultaneous flows).
  If you are using RFC 3041 which means you are faking
your link address then you should set S to 1.
  In general with a single HoA there should be a
single flow that MN would receive to the CoA that is
registered with the latest BU. In wireless links with
intertechnology handovers MN could be under the
coverage of one or another of its interfaces but that
should normally mean a single binding with S=1.

  I think Hesham, Karim contribution relates to the
handover smooting using bicasting from the previous
ARs. Actually a similar technique already standardized
by 3GPP2 in Wireless IP standard.

Regards,

Hope this helps,

behcet
--- Koojana Kuladinithi <[email-masked]>
> WWW:   http://www.comnets.uni-bremen.de

__________________________________________________
Do you Yahoo!?
Yahoo! Web Hosting - Let the expert host your site
http://webhosting.yahoo.com

---

From: "Stuart W. Card" <[email-masked]>
Date: Mon, 18 Nov 2002 13:02:27 -0500

At 06:42 PM 11/18/2002 +0100, Claude Castelluccia wrote:

>... "Per-flow movement in MIPv6" draft might actually be the solution...
>
>Greg Daley wrote:
> >
> > ... There's a draft by elmalki & soliman about simultaneous
> > bindings which bicast traffic for one home address at two coa's...
> >
> > > ... I have been reading the drafts (19 included) to figure out
> > > how MIPv6 handles multiple simultaneous bindings...

In our MIPv4 work for the Air Force, which is actually concerned with
network mobility (NEMO) rather than host mobility (Mobile-IP), we must
not only direct each flow over a specific FA<->MR link (based upon QoS)
but also load balance hi-bandwidth flows over multiple concurrent links.
Multiple wireless links may be reachable via the same FA, but typically
for us, different wireless links are reached via different FAs located
in different domains.  MIPv6, not being FA-based, has stumped us so far.

Stuart W. Card, Chief Scientist & VP, Critical Technologies Inc.
Mohawk Valley Engineers Executive Council 2002 Company of the Year!
Suite 400 Technology Center, 4th Floor 1001 Broad Street, Utica NY 13501
315-793-0248 x141  FAX -9710   <[email-masked]>  www.critical.com

---

From: Thomas Noel <[email-masked]>
Date: Mon, 18 Nov 2002 20:38:38 +0100

Hello Koojana,

The draft "MIPv6 for Multiple Interfaces" proposes a solution to this issue.

ftp://ftp.ietf.org/internet-drafts/draft-montavont-mobileip-mmi-00.txt

Thomas

-- 
Thomas Noel
ULP/LSIIT - CNRS

---

From: "Imed Romdhani" <[email-masked]>
Date: Tue, 19 Nov 2002 01:26:35 +0100

Hello Thomas,

Is there some realistic scenarios where multiple CoAs  of a MN change
simultaneously ?!.

Imed
----------------------------------------------
Imed Romdhani
Phd Student
Centre de Recherche de Motorola de Paris
Université de Technologie de Compiègne
Mobile : (+33) 06 22 86 44 39
Office  : (+33  03 44 23 46 99  Pos. : 4249
----------------------------------------------
----- Original Message -----
From: "Thomas Noel" <[email-masked]>
To: "Koojana Kuladinithi" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, November 18, 2002 8:38 PM
Subject: Re: [mobile-ip] How MIPv6 handles multiple simultaneous binding

> > how MIPv6 handles multiple simultaneous bindings by multiple interfaces
in
> > a

---

From: "Koojana Kuladinithi" <[email-masked]>
Date: Tue, 19 Nov 2002 09:44:55 +0100

Hello Imed & Thomas

What I refered was , changing networks while having multiple interfaces on a
single device.
That means the mobile node's one interface is connected to a WLAN and the
other is connected to a GPRS network.
In this case, MN uses two CoAs simultaneously. And also, these adresses can
be changed simultaneouly, depends
on the connectivity.

Hope, this helps to clarify your doubt.

Koojana

-----Ursprüngliche Nachricht-----
Von: [email-masked]
[mailto:[email-masked]]Im Auftrag von Imed Romdhani
Gesendet: Dienstag, 19. November 2002 01:27
An: Thomas Noel
Cc: [email-masked]
Betreff: Re: [mobile-ip] How MIPv6 handles multiple simultaneous binding

Hello Thomas,

Imed
----- Original Message -----
From: "Thomas Noel" <[email-masked]>
To: "Koojana Kuladinithi" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, November 18, 2002 8:38 PM
Subject: Re: [mobile-ip] How MIPv6 handles multiple simultaneous binding

in

---

From: montavont <[email-masked]>
Date: Tue, 19 Nov 2002 11:04:30 +0100

Hi,

I agree with Koojana that Mobile IPv6 does not really figure out the 
multiple interfaces management, that's why we proposed the draft mmi 
(http://www.ietf.org/internet-drafts/draft-montavont-mobileip-mmi-00.txt)

MMI (Mobile IPv6 for Multiple Interfaces) aims to specify Mobile IPv6 
operations to manage multiple interfaces. It's a generic solution which 
can be performed as well when the MN has an unique Home address for all 
its interfaces, as when it has one home address by interface.

We first proposed this draft to set a basic method to manage 
inter-technology handover. We expect to write version 01, to propose 
extensions et optimizations.

My response to Imed inline.

Regards,
Nicolas

>Is there some realistic scenarios where multiple CoAs  of a MN change
This can happen, but I think it's not the basic scenario. Moreover, if 
the MN simultaneously changes of CoAs on two of its interfaces, this 
doesn't imply a redirection between interfaces.

The two scenarios that might frequently happen are (as explained in 3.2 
in the draft):
    - the MN uses one interface and connects to a new network through 
another one
    - the MN looses an interface in use, while another is or comes up 
(with the network connectivity)

The aim in these scenarios is to redirect flows between the interfaces.

>>The draft "MIPv6 for Multiple Interfaces" proposes a solution to this
>>    
>>
>issue.
>  
>
>>>(i.e. all interfaces have one home address and multiple CoA).  But I
>>>      
>>>
>have
>  
>
>>>had no success.