Subject: RE: [mobile-ip] soft-handover in Mobile IP

From: "KASSI-LAHLOU Mohammed FTRD/DMI/CAE" <[email-masked]>
Date: Tue, 5 Nov 2002 15:52:50 +0100

Hello Byung-Jin,

You could also read the draft MMI:

 http://www.ietf.org/internet-drafts/draft-montavont-mobileip-mmi-00.txt

Best Regards.

Kassi

-----Message d'origine-----
De : Phillip D. Neumiller [mailto:[email-masked]]
Envoye : mardi 5 novembre 2002 14:42
A : Byung-Jin Lee
Cc : [email-masked]
Objet : Re: [mobile-ip] soft-handover in Mobile IP

Hello Byung-Jin,

This was suggested a few years ago by some engineers
from Motorola.  It was called OBAST.  You could read
about this historical idea in the October 2000 ACM MCCR
magazine.  This was also one of the founding ideas of
the SeaMoby WG but it has subsequently been lost in the
IETF.  Suffice it say, that there have been several
MIP drafts supporting bi-casting, edge-tunnelling and
a variety of other techniques that result in a make-before
break handover.  In general, make-before-break is working
its way into the main line MIP drafts.

Thanks,

Phil

Byung-Jin Lee wrote:
> Hello.
> Is it possible that a MN has two links or IP layer connection
> simutanuously?
> The CDMA system supports softhandover which has two links
> simultaneously for handover time.
> Therefore, Softhandover in Mobile IP may possible.
> Also, if a MN has two IP address(oCoA and nCoA) and packets are
> received from oAR(using oCoA) and nAR(using nCoA)
> it is able to receive two IP packet simultaneously.
> 
> Anybody who can comment reply.
> 
> Best Regards.
> Byung-Jin 
>

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Tue, 5 Nov 2002 16:40:47 +0100

> > Is it possible that a MN has two links or IP layer connection

=> Yes, if it has two interfaces visible to the IP layer.

  > > simultaneously for handover time.

=> We have to be careful with where the "links" are visible. 
In CDMA-type soft handover, you will receive the _same_
traffic stream from different APs. Only one stream is 
passed to the IP layer.

  > > Therefore, Softhandover in Mobile IP may possible.

=> I think these are apples and oranges. If you mean 
that we should do the recombination on the IP layer
then it's a different story altogether from your 
first question. And probably has nothing to do with
the Mobile IP protocols.

  > > it is able to receive two IP packet simultaneously.

=> _If_ it has two interfaces visible at the IP layer. 

Hesham

---

From: Montilla Alberto-AMONTIL1 <[email-masked]>
Date: Tue, 5 Nov 2002 18:39:39 +0100

First of all, for clarification; WCDMA uses SHO irrespective of the Core Network Domain i.e. for both CS and PS.

Regarding Jame's comments, I would like to say that SHO, as implemented today is a Layer 2 matter, that is helpful for any kind of data because it increment the reliability of the MN to CN domain connection, basically by reducing BER and drop calls with respect to the break before make schema. As a side note, this is an interesting topic because WCDMA/cdma2000 air interfaces will be in the market for some time, so its integration with Mobile IP should be a matter of study.

The point here is whether it is possible to introduce the SHO management into IP (which I believe was the purpose of the question). This may have some relation with the work on L2 triggers, just expanding the triggers to cover a more general cases of Radio Access Technologies. However I have to admit that I don't fully understand the drivers for such a proposal (L2 simplicity?).

Regards

Alberto

-----Original Message-----
From: James Kempf [mailto:[email-masked]]
Sent: Tuesday, November 05, 2002 5:26 PM
To: Byung-Jin Lee; [email-masked]
Subject: Re: [mobile-ip] soft-handover in Mobile IP

cdma2K doesn't use soft handover for IP traffic, it is just used for circuit
switched voice. I'm not sure about wCDMA.

As a practical matter, an IP node would gain almost nothing from soft handover,
even it were used. As far as the IP stack is concerned, the outstanding soft
handover legs look like a single IP connection, and would have to be changed
when the mobile node moved to a new subnet. Soft handover just makes for more
complexity in the radio access network, because it requires some point back in
the network where macrodiversity must be resolved. In addition, the timing
requirements for soft handover a very stringent, so it imposes constraints on
the radio access network design that lead to higher costs. Finally, for an IP
node, more traffic generally comes on the down link than the up link, but soft
handover gives less db gain on the down link because multiple base stations
transmitting at the same time tend to interfere with each other.

Better for IP is make before break handover, in which the IP stack can maintain
a connection back to the old base station while setting up the connection with
the new. This allows the mobile node's traffic to be continuously delivered
through the old Mobile IP care of address while setting up the care of address
on the new subnet. With make before break handover, no special mobile IP
handover optimizations should be required to maintain good performance.
Flarion's flash OFDM protocol has make before break, and is in this, as in many
other respects, designed to be a good fit with IP.

            jak

----- Original Message -----
From: "Byung-Jin Lee" <[email-masked]>
To: <[email-masked]>
Sent: Monday, November 04, 2002 7:11 PM
Subject: [mobile-ip] soft-handover in Mobile IP

> Hello.
> Is it possible that a MN has two links or IP layer connection simutanuously?
> The CDMA system supports softhandover which has two links simultaneously for
handover time.
> Also, if a MN has two IP address(oCoA and nCoA) and packets are received from
oAR(using oCoA) and nAR(using nCoA)

---

From: "Karim El-Malki (EAB)" <[email-masked]>
Date: Tue, 5 Nov 2002 20:11:02 +0100

James

 > even it were used.

I don't think this is correct. An operator would gain from having soft
handover even when running IP traffic. It's established that soft handover
gives capacity gains and this would also apply to for example real-time
traffic over IP (downlink and uplink). So it's not true that "Soft handover
just makes for more complexity in the radio access network", it has
proven gains.

Don't think this is the right list for this discussion, but I just wanted to
put in a quick comment on this.

Rgds
/Karim