Subject: RE: [mobile-ip] Thoughts on using handover capability extension

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Fri, 8 Nov 2002 20:08:21 +0100

> there has been some discussion on the timing of various
  > messages. It occurred to me that one _could_ make use
  > the handover capability extension to provide some of
  > the information to the MN ahead of time. For instance,
  > a MN may request the map of neighboring APs and ARs
  > via RS much ahead of the actual handover, e.g., when it
  > first attaches to its router. The AR can provide this via
  > handover capability extension in a RA.

=> Absolutely.

  > 
  > With this, the functionality of PrRtSol/PrRtAdv is moved
  > to RS/RA, but also to an earlier time. The MN should be
  > able to send FBU prior to handover, which then triggers
  > HI/HAck sequence.

=> Hmm, why does it have to move to a normal RS? 
The reason for having a different ICMP type is that
we don't want to overload the meaning of an RS. You
can still do this idea in PrRtSol/adv. Changing the 
timing shouldn't affect the carrier. 

  > 
  > Downside is increased message size (due to the whole
  > map being sent). Also, the MN may attach to an AP
  > not in the map, but I guess this can always happen and
  > we need tunnel establishment subsequent to handover.

=> Well you only need to send a map of the neighbouring
APs, not the entire network :) 
I don't think it's a major problem. 

Hesham

---

From: "James Kempf" <[email-masked]>
Date: Fri, 8 Nov 2002 11:35:30 -0800

> I don't think it's a major problem.

The MN should be able to solict and the AR should be able to send unsolicited.
Confining it to "neighboring" APs is a bit of a problem, since it implies some
topological or geographical knowledge on the part of the MN that it might not
have. I suppose the AR could filter if it had additional knowledge about the
topology (I can't see it having any on the geography).

Really, though, this is exactly what Seamoby CT is trying to accomplish. I wish
we could take this discussion to the Seamboy list.

            jak

---

From: Rajeev Koodli <[email-masked]>
Date: Fri, 08 Nov 2002 13:11:13 -0800

> => Hmm, why does it have to move to a normal RS?

Right, there is a choice between having an option in RS
versus a separate message. One reason why RS
might be better is that the MN will likely do RS anyway
upon attaching to the link. If it receives an unsolicited
RA, the MN needs to do RS with a request for handover
capability extension.

> timing shouldn't affect the carrier.

I agree timing and carrier are separate. So, the question is
a new option or a new message (wrt to RS).

> I don't think it's a major problem.

And, we should separate the delivery of map from how the
map is constructed. I am only referring to delivery of map,
and not how the map itself is constructed, which could be
established via CARD, or simply statically pre-configured.

-Rajeev