Subject: [mobile-ip] soft-handover in Mobile IP

From: "Byung-Jin Lee" <[email-masked]>
Date: Tue, 5 Nov 2002 12:11:08 +0900

Hello.
Is it possible that a MN has two links or IP layer connection simutanuously?
The CDMA system supports softhandover which has two links simultaneously for handover time.
Therefore, Softhandover in Mobile IP may possible.
Also, if a MN has two IP address(oCoA and nCoA) and packets are received from oAR(using oCoA) and nAR(using nCoA)
it is able to receive two IP packet simultaneously.

Anybody who can comment reply.

Best Regards.
Byung-Jin

---

From: "Phillip D. Neumiller" <[email-masked]>
Date: Tue, 05 Nov 2002 08:41:46 -0500

Hello Byung-Jin,

This was suggested a few years ago by some engineers
from Motorola.  It was called OBAST.  You could read
about this historical idea in the October 2000 ACM MCCR
magazine.  This was also one of the founding ideas of
the SeaMoby WG but it has subsequently been lost in the
IETF.  Suffice it say, that there have been several
MIP drafts supporting bi-casting, edge-tunnelling and
a variety of other techniques that result in a make-before
break handover.  In general, make-before-break is working
its way into the main line MIP drafts.

Thanks,

Phil

Byung-Jin Lee wrote:
> Also, if a MN has two IP address(oCoA and nCoA) and packets are
> received from oAR(using oCoA) and nAR(using nCoA)

---

From: "James Kempf" <[email-masked]>
Date: Tue, 5 Nov 2002 08:25:53 -0800

cdma2K doesn't use soft handover for IP traffic, it is just used for circuit
switched voice. I'm not sure about wCDMA.

As a practical matter, an IP node would gain almost nothing from soft handover,
even it were used. As far as the IP stack is concerned, the outstanding soft
handover legs look like a single IP connection, and would have to be changed
when the mobile node moved to a new subnet. Soft handover just makes for more
complexity in the radio access network, because it requires some point back in
the network where macrodiversity must be resolved. In addition, the timing
requirements for soft handover a very stringent, so it imposes constraints on
the radio access network design that lead to higher costs. Finally, for an IP
node, more traffic generally comes on the down link than the up link, but soft
handover gives less db gain on the down link because multiple base stations
transmitting at the same time tend to interfere with each other.

Better for IP is make before break handover, in which the IP stack can maintain
a connection back to the old base station while setting up the connection with
the new. This allows the mobile node's traffic to be continuously delivered
through the old Mobile IP care of address while setting up the care of address
on the new subnet. With make before break handover, no special mobile IP
handover optimizations should be required to maintain good performance.
Flarion's flash OFDM protocol has make before break, and is in this, as in many
other respects, designed to be a good fit with IP.

            jak

---

From: Xiaofeng Xu <[email-masked]>
Date: Tue, 05 Nov 2002 11:18:10 -0600

CDMA2000 does support soft/softer handover for IP traffic, not just for
circuit service.
The soft handover technology is originally designed to solve the
near-far problem in cdma radio communications. Make-before-break is the
side-effect of the technology.

Regards,
Xiaofeng

James Kempf wrote:

>>The CDMA system supports softhandover which has two links simultaneously for
>>    
>>
>handover time.
>  
>
>>Also, if a MN has two IP address(oCoA and nCoA) and packets are received from
>>    
>>
>oAR(using oCoA) and nAR(using nCoA)
>  
>

---

From: "James Kempf" <[email-masked]>
Date: Tue, 5 Nov 2002 09:46:15 -0800

Is that true of 1x-EV and 1x-EVDO as well?

            jak

---

From: "James Kempf" <[email-masked]>
Date: Tue, 5 Nov 2002 10:17:19 -0800

> CDMA2000 does support soft/softer handover for IP traffic, not just for

I'm told that cdma2000 uses soft handover for MN to BS in all flavors including
1xEV-DO, but not for the  BS to MN direction for 1xEV-DO or 1xEV-DV. I suspect
what my informant had in mind was the latter, apologies for overgeneralizing.

As for softer handover, that has nothing to do with IP traffic or voice traffic,
it is just a link layer thing.

> side-effect of the technology.

Soft handover is not true make-before-break as far as the IP layer is concerned,
though it could be considered make before break as far as Layer 2 is concerned.
The IP layer doesn't see the outstanding soft handover legs, its all resolved at
Layer 2 (or Layer 1 on the mobile).

Make-before-break for IP means that Mobile IP can set up the care of address on
the new subnet prior to breaking the connection with the old. That can't be done
with soft handover.

So I still don't see any benefit of soft handover for IP, though it might have
benefit for Layer 2.

            jak

---

From: Xiaofeng Xu <[email-masked]>
Date: Tue, 05 Nov 2002 12:21:23 -0600

That should be true for 1xEV-DV, at least necessary for backward 
compatibility with 1x/IS95. 
1xEV-DO forward link uses hybrid CDMA+TDMA, no soft handover is used. 
But softhandover is used on the reverse link.

Regards,
Xiaofeng

James Kempf wrote:

>>>As a practical matter, an IP node would gain almost nothing from soft
>>>      
>>>
>handover,
>  
>
>>>complexity in the radio access network, because it requires some point back
>>>      
>>>
>in
>  
>
>>>node, more traffic generally comes on the down link than the up link, but
>>>      
>>>
>soft
>  
>
>>>Better for IP is make before break handover, in which the IP stack can
>>>      
>>>
>maintain
>  
>
>>>a connection back to the old base station while setting up the connection
>>>      
>>>
>with
>  
>
>>>through the old Mobile IP care of address while setting up the care of
>>>      
>>>
>address
>  
>
>>>Flarion's flash OFDM protocol has make before break, and is in this, as in
>>>      
>>>
>many
>  
>
>>>>Also, if a MN has two IP address(oCoA and nCoA) and packets are received
>>>>        
>>>>
>from
>  
>
>>>>        
>>>>

---

From: "Robert J Marks" <[email-masked]>
Date: Tue, 5 Nov 2002 12:47:03 -0600

For 1xEV-DV, the forward packet data channel (F-PDCH) does not require
soft handoff. The FCH and SCH channels are handled as they are in 1x.
 
Bob

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Xiaofeng Xu
Sent: Tuesday, November 05, 2002 12:21 PM
To: James Kempf
Cc: Byung-Jin Lee; [email-masked]
Subject: Re: [mobile-ip] soft-handover in Mobile IP

Regards,
Xiaofeng

James Kempf wrote:

            jak

----- Original Message -----

From: "Xiaofeng Xu"  <mailto:[email-masked]>
<[email-masked]>

To: "James Kempf"  <mailto:[email-masked]>
<[email-masked]>

Cc: "Byung-Jin Lee"  <mailto:[email-masked]> <[email-masked]>;
<mailto:[email-masked]> <[email-masked]>

  

circuit service.

Regards,

Xiaofeng

James Kempf wrote:

cdma2K doesn't use soft handover for IP traffic, it is just used for
circuit

handover,

even it were used. As far as the IP stack is concerned, the outstanding
soft

handover legs look like a single IP connection, and would have to be
changed

when the mobile node moved to a new subnet. Soft handover just makes for
more

complexity in the radio access network, because it requires some point
back

in

the network where macrodiversity must be resolved. In addition, the
timing

requirements for soft handover a very stringent, so it imposes
constraints on

the radio access network design that lead to higher costs. Finally, for
an IP

node, more traffic generally comes on the down link than the up link,
but

soft

handover gives less db gain on the down link because multiple base
stations

maintain

a connection back to the old base station while setting up the
connection

with

the new. This allows the mobile node's traffic to be continuously
delivered

address

Flarion's flash OFDM protocol has make before break, and is in this, as
in

many

           jak

----- Original Message -----

From: "Byung-Jin Lee"  <mailto:[email-masked]>
<[email-masked]>

To:  <mailto:[email-masked]>
<[email-masked]>

      

Hello.

Is it possible that a MN has two links or IP layer connection
simutanuously?

The CDMA system supports softhandover which has two links simultaneously
for

handover time.

from

      

Best Regards.

Byung-Jin

---

From: Masataka Ohta <[email-masked]>
Date: Wed, 6 Nov 2002 04:30:13 +0859 ()

Byung-Jin;

> Therefore, Softhandover in Mobile IP may possible.

Yes, and it is working without any change to IP mobility protocol.

And, it is essential for link layers with large link latencies
such as IEEE 802.11 ones.

The only interaction between link and mobile-IP layer is that
old links should be disconnected aftter successful mobile IP
registration.

See, draft-ohta-smooth-handover-wlan-00.txt for details.

> it is able to receive two IP packet simultaneously.

Wrong.

MN receives only one copy of a packet on only one IP address currently
recognized by HA.

So, there is no worrying about on duplicate detection and elimination.

It is just easy.

						Masataka Ohta