Subject: RE: [mobile-ip] FMIPv6 questions

From: "Mohamed Khalil" <[email-masked]>
Date: Mon, 11 Nov 2002 15:15:01 -0600

Why not let the MN propose a new host identifier suffix to new AR via the
PrxyRtSol to old AR and HI/HAck from old AR to new AR (or old AR can propose
it if the handover is network triggered), and have new AR either return a
valid address or return an error saying it can't return one? This would
unify the stateless and stateful cases, since the returned address could be
a statefully allocated one, and old AR wouldn't have to know how new AR does
address allocation.

MK>> In the statefull approach the nAR has a pool of unique IP addresses
which are topologically correct with new subnet. If this pool is empty and
an address can't be obtained by a local DHCP then the MN request will be
rejected. Your mechanism is a variation of stateless approach where the
access router will construct an IP address on behalf of the MN and should
check for its uniqueness by running some alg. like DaD. The statefull
approach proposed by the draft is more faster in assigning IP addresses to
the MN.

-Mohamed

---

From: "James Kempf" <[email-masked]>
Date: Mon, 11 Nov 2002 13:56:42 -0800

> approach proposed by the draft is more faster in assigning IP addresses to

If new AR is doing stateful allocation, it ignores the proposed host identifier
and just pulls an address out of the pool.

If the pool is empty, new can either check if the host identifier can be used to
construct an address, or it can return an error (probably the latter, since a
limitation on the number of addresses is one way to limit the number of nodes on
the link and thus manage the radio resource).

            jak

---

From: Greg Daley <[email-masked]>
Date: Tue, 12 Nov 2002 08:10:09 +1100

Hi Mohammed,

I think that there are advantages to proposing a
statful mechanism, but that doesn't mean DHCP
necessarily.  The RFC 2462 statements about requirements
to undertake managed address configuration are too
weak to ensure that everyone uses stateful address
autoconfig.

To provide the sort of guarantees the nAR is giving
in the HAck, there MUST be full allocated address
state on the nAR (for the addresses it can give out),
otherwise it should be telling the MN that the address
is uncertain.

It's advantageous too to allow the MN to select their own
care of address, since this allows some interesting
address ownership mechanisms like CGA to be used.

So a stateful mechanism which allows this would be great.
Unfortunately, while DHCP can allow you to request the
address, it cannot provide address checks for arbitrary
addresses unless it itself performs DAD (for the reason
I mentioned before).

If the nAR can determine that an address is not in use
(as proposed by Alper with an ND related mechanism, or by
myself with MLD based DAD optimization), then generic
addresses can be effectively pre-DAD'ed before the information
is sent in the HAck.  Each of these mechanisms rely on
things which the MN must do to achieve connectivity on the
link. Mandatory authentication could similarly provide
this state.

Then again, it may not matter so much whether the address is
pre-DAD'ed, if optimistic DAD is used.

Greg Daley

Mohamed Khalil wrote:
> 
> 
> 
> Why not let the MN propose a new host identifier suffix to new AR via 
> the PrxyRtSol to old AR and HI/HAck from old AR to new AR (or old AR can 
> propose it if the handover is network triggered), and have new AR either 
> return a valid address or return an error saying it can't return one? 
> This would unify the stateless and stateful cases, since the returned 
> address could be a statefully allocated one, and old AR wouldn't have to 
> know how new AR does address allocation.
> 
> which are topologically correct with new subnet. If this pool is empty 
> and an address can't be obtained by a local DHCP then the MN request 
> will be rejected. Your mechanism is a variation of stateless approach 
> where the access router will construct an IP address on behalf of the MN 
> and should check for its uniqueness by running some alg. like DaD. The 
> statefull approach proposed by the draft is more faster in assigning IP 
> addresses to the MN.
> 
> -Mohamed
> 
>           
> 
> 
>

---

From: "James Kempf" <[email-masked]>
Date: Mon, 11 Nov 2002 13:56:42 -0800

jak