Subject: RE: [mobile-ip] Mipv6 issue #158: When to start RO

From: "Kuntal Chowdhury" <[email-masked]>
Date: Wed, 27 Nov 2002 17:02:07 -0600

> However, we can make definite statements about the probability that a 
> direct path is better than a bent path, and from the standpoint of the 
> routing topology the direct path is almost always better.

I commented on this point before. I am prompted to comment again. The
question, 
whether a path is a direct one or a bent one is not relevant here. The
question
should be, how many "hops" are involved or what is the "cost" of the path in
either 
case? 
Then if we talk about routing protocols, the hop count matters for distance
vector 
schemes, and the path cost matters for link-state schemes. 

Without getting into another round of debate here, I think the time and
reason for 
initiation of RO from the MN should be left open for implementation. IMO the
MN 
cannot guarantee whether RO will be beneficial unless it requests the CN to
run some
kind of test (e.g. ping test). Alternatively MN can ask the AR to perform a
test to 
see whether RO is going to be really beneficial.

Regards,
Kuntal

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 27 Nov 2002 15:40:05 -0800

Hello Kuntal,

Kuntal Chowdhury wrote:

>
> ..........................                                   The
> question,
> should be, how many "hops" are involved or what is the "cost" of the
> path in either
> case?

Of course, I must agree with your second sentence.  But it's
well known (e.g., "triangle inequality") that it DOES matter
whether the path is direct or not.  Moreover, in this case
the real point is to reduce costs and unpredictability (jitter) for
communications between the mobile node and the correspondent.
So, I can confidently say that for any particular communications
path, route optimization will _probably_ show improvement.
As pointed out, there are clearly cases where the gain is
minimal.  As noted below, I already agree that implementations
that can make the determination should be allowed to do so.

> Without getting into another round of debate here, I think the time
> and reason for
> initiation of RO from the MN should be left open for implementation.

This is what "SHOULD" means.  It means that the implementation
should be done a certain way unless there are reasons otherwise, and
as Jari's text indicates, those reasons are out of scope.  Especially
for a document that has already gone through last call.

> IMO the MN
> cannot guarantee whether RO will be beneficial unless it requests the
> CN to run some
> kind of test (e.g. ping test). Alternatively MN can ask the AR to
> perform a test to

Nothing was said about guarantees, and I don't remember previous
discussion about involving the AR.  That would be an interesting
project.

Regards,
Charlie P.

---

From: gabriel montenegro <[email-masked]>
Date: Thu, 28 Nov 2002 08:11:37 +0100

> that can make the determination should be allowed to do so.

Yes, you have also made this point previously:

"1) It typically helps for almost all communications
    patterns."

Do you have any study about this? The problem is that in order to
benefit from RO one must make a certain investment. When is this
investment worth it? If a CN appears in the binding cache, presumably
the MN has already made that decision, but for those CN that don't,
when is this worth doing and when isn't it? Does it depend on the
protocol? Is it a SHOULD for TCP traffic, but a MAY for UDP?
It doesn't seem like it's always beneficial.

The point is that we don't have enough heuristics to know yet,
so the conservative approach is to go with the MAY. Something I said
in private was that there was a paper by Mary Baker and her students
("internet 4X4"??) that for MIPv4 looked into when to use mobileip
and when to use the local CoA directly. Yes, it was not always best
to use mobile ip for all traffic. It seems like this decision of when
to initiate RO could be an extension of that type of study.

> for a document that has already gone through last call.

It's gone through WG last call. Not yet IETF last call. This point came
up as part of AD comments. We have to deal with them in order to prepare
for IETF last call.

-gabriel

---

From: Charlie Perkins <[email-masked]>
Date: Wed, 27 Nov 2002 23:28:58 -0800

Hello Gabriel,

Mary Baker's work is concerned with the choice of
care-of address vs. home address, in the absence of
any possibility for route optimization.  I don't have the
paper in front of me, but if my memory serves correctly
the 4x4 paper observes that route optimization would tilt
the choice considerably towards using the home address
in most instances.

I have read various papers along these lines.  Some of
the work on "friends" had to do with determining the
economics of route optimization, depending on the signaling
cost for the binding updates and the traffic patterns.
The finding are quite intuitive.  If the signaling cost is high,
and the traffic concentrated in short-lived connections,
then the case for route optimization is not clear cut -- but
anyway it's not a major burden either.  If the signaling cost
is low (as it would be for the Mobile IPv6 solution) and if
communications are longer-lived, then the case is clear.

In short, the downside of doing route optimization is pretty
benign, and the downside of not doing it is considerably less
benign.  That pretty much fits the description for SHOULD.

Your question about whether TCP and UDP should be
treated differently isn't easy to answer on that basis.
I'm pretty sure it always depends on the volume of traffic,
not whether or not the traffic is reliable (or rate-limited).

Regards,
Charlie P.

---

From: Pekka Savola <[email-masked]>
Date: Fri, 29 Nov 2002 00:52:45 +0200 (EET)

> communications are longer-lived, then the case is clear.

Those papers and findings probably use the older details wrt. signaling.

The signaling has been radically changed in the last 2 drafts or so.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords