Subject: [mobile-ip] New partial ordering of mobility options in v19

From: "Greg O'Shea" <[email-masked]>
Date: Fri, 29 Nov 2002 18:46:40 -0000

I see that section 6.2 introduces a partial ordering by insisting that
Binding Authorization "MUST" occur last and "MUST NOT" be followed by
padding; but it does not say why these restrictions are necessary or
what they achieve.

Alas, it's not obvious to me. Is there a reason?

---

From: Jari Arkko <[email-masked]>
Date: Sat, 30 Nov 2002 00:47:22 +0200

> Alas, it's not obvious to me. Is there a reason?

If your implementation of packets happens to use a flat
memory buffer, then running the necessary MACs is easy;
if the BAD option can appear anywhere then you'd need to
feed at least two buffers to the MAC function and some
code to figure out where the hole is between them.

Yes, its small.

Jari