Subject: Re: [Seamoby] Re: [mobile-ip] Thoughts on using handover capability extension

From: "Hemant Chaskar" <[email-masked]>
Date: Wed, 13 Nov 2002 15:11:42 +0000

Hi James:

Could you please provide a scenario where and how knowing wireless link type 
will enhance handover performance?

The reverse address translation part is clear to me. But, I do not see why 
only this kind of capability is critical to convey, and others may not be 
important.

Hemant

>From: "James Kempf" <[email-masked]>
>To: "Eunsoo Shim" <[email-masked]>, "Pete McCann" <[email-masked]>,  
>  "Rajeev Koodli" <[email-masked]>, <[email-masked]>
>CC: <[email-masked]>
>Subject: Re: [Seamoby] Re: [mobile-ip] Thoughts on using handover 
>capability extension
>Date: Tue, 12 Nov 2002 05:13:22 -0800
>
>I think that CARD should just focus on router address and wireless link 
>type for
>now, and include a way, like an ICMP option, to extend for later when 
>people
>actually intend to use other capabilities. Better to start simple with a 
>way to
>expand than have something complex initially that people won't use nor
>implement. Is anyone planning on implementing complex capability 
>determination
>as products at this point? I think using CARD for anything more than 
>wireless
>link type and router address information is a research topic.
>
>Therefore, it makes sense to leverage the FMIP signaling. Why have two 
>protocols
>that are about 80% the same when you can have one that does the whole job?
>
>
>             jak
>
>----- Original Message -----
>From: "Eunsoo Shim" <[email-masked]>
>To: "James Kempf" <[email-masked]>; "Pete McCann" 
><[email-masked]>;
>"Rajeev Koodli" <[email-masked]>; <[email-masked]>
>Cc: <[email-masked]>
>Sent: Tuesday, November 12, 2002 12:50 AM
>Subject: Re: [Seamoby] Re: [mobile-ip] Thoughts on using handover 
>capability
>extension
>
>
> > CARD talks about capability which may include more than just IP address 
>(or
> > subnet prefix) and MAC address.
> > So distribution of information about ARs to MN may include more than AP 
>ID,
> > AR MAC, AR IP(or prefix).
> > I wonder whether people want to extent FMIPv6 protocol to cover such a
> > general case.
> > Also one of the requirements for CARD is that it should be independent 
>of
> > any specific mobility management protocol.
> > I'd like to suggest we develop CARD protocol further (it is in its very
> > early stage in terms of protocol spec) and see what is the best way to
> > resolve the partial overlapping between FMIPv6 and CARD.
> > Regards,
> >
> > Eunsoo
> >
> > ----- Original Message -----
> > From: "James Kempf" <[email-masked]>
> > To: "Pete McCann" <[email-masked]>; "Rajeev Koodli"
> > <[email-masked]>; <[email-masked]>
> > Cc: <[email-masked]>; <[email-masked]>;
> > <[email-masked]>
> > Sent: Tuesday, November 12, 2002 3:13 AM
> > Subject: [Seamoby] Re: [mobile-ip] Thoughts on using handover capability
> > extension
> >
> >
> > > I *really* dislike sending email to two lists, but people just don't 
>seem
> > > willing to take this discussion to the Seamoby list, where it properly
> > belongs.
> > > Apologies.
> > >
> > > > I agree FMIPv6 does packet forwarding.  Are we sure we want it to do
> > > > address configuration?  Also, you mentioned router capability
> > > > discovery (which I agree is in scope of CARD) but not router 
>discovery
> > > > itself (which I think is also in scope of CARD).
> > > >
> > >
> > > Yes router discovery is in the scope of CARD.
> > >
> > > > If Seamoby can agree that PrRtAdv is the right container message, 
>then
> > > > I am all for it.  Have those discussions converged yet?
> > > >
> > >
> > > No, which is why I am urging people to take this discussion to the 
>Seamoby
> > list
> > > so that we can get it to converge.
> > >
> > > > Well, I would rather solve a problem once than twice.
> > > >
> > > > Sorry to continue discussing CARD here on mobileip, but can we agree
> > > > that it consists of two things:
> > > >
> > > > 1) an inter-AR protocol for discovering info about neighboring 
>access
> > > >    routers;
> > > > 2) a MN-to-AR protocol for distributing that info to MNs.
> > > >
> > >
> > > These don't have to be separate. You can use the same signaling for 
>both.
> > The
> > > security must be different on them, however.
> > >
> > > > To me it sounds like you think CARD is only (1).  I think it is both
> > > > (1) and (2), and that we shouldn't define two different protocols 
>for
> > (2).
> > > >
> > >
> > > Yes, exactly.
> > >
> > >             jak
> > >
> > > _______________________________________________
> > > Seamoby mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/seamoby
> > >
> >
> >
> >
>
>_______________________________________________
>Seamoby mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/seamoby

_________________________________________________________________
Add photos to your messages with MSN 8. Get 2 months FREE*. 
http://join.msn.com/?page=features/featuredemail

---

From: "James Kempf" <[email-masked]>
Date: Wed, 13 Nov 2002 12:05:44 -0800

In an intertechnology scenerio, the MN could get info on a nonactive interface
through an active one, thus saving power.

            jak

----- Original Message -----
From: "Hemant Chaskar" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, November 13, 2002 7:11 AM
Subject: Re: [Seamoby] Re: [mobile-ip] Thoughts on using handover capability
extension

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 13 Nov 2002 15:26:48 -0600

Hi Jim,

>through an active one, thus saving power.
I think you need IP Paging for this. Thanks for bringing it to the 
attention.

>From: "Hemant Chaskar" <[email-masked]>
--behcet