Subject: RE: [mobile-ip] Thoughts on using handover capability extensio

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Thu, 14 Nov 2002 20:31:02 +0100

> - Should the "handover capability request/response"
  >     messages be options in RS/RA or separate messages ?
  >     There were some arguments that if we propose them
  >     as options, we need them standardized in IPv6 WG.
  >     If this is the case, I would stick with the current types.
  >     Otherwise, I would like to propose making them options,
  >     since that could reduce the number of messages sent.
  > 
  > Comments ?
  > 

=> I haven't seen this argument before. Why should 
we standardise an RS/RA option in IPv6? Of course we 
can standardise a new option here. 

Hesham

---

From: Rajeev Koodli <[email-masked]>
Date: Thu, 14 Nov 2002 11:55:25 -0800

Hi,

> can standardise a new option here.

perhaps my interpretation (specifically of Mohamed Khalil's remark) was
not accurate.

"MK>> I think if you include this extension in RA, then you are asking
all the routers whether they support mobility or not to implement this
extension. I think it is
very difficult to convince the ipng WG with this point of view, but you
are welcome to try. Since, PrRtSol/PrRtAdv are messages  introduced to
extend the router
functionality to support mobility, I think the proper location for this
extension is in PrRtAdv."

So, we could move the PrRtSol/PrRtAdv functionality as options
to RS/RA. Those routers that do not understand them gleefully silently
discard them. Is this OK ? MK ?

-Rajeev