Subject: [mobile-ip] How about modification of DHAAD reply message?

From: Pyungsoo Kim <[email-masked]>
Date: Wed, 27 Nov 2002 11:14:27 +0900

In the processing of DHADD reply message,
if a mobile node knows the number of HA's addresses, it can select easily 
the HA's address according to preference. (because HA's addresses are
listed according to preference).

however, in the current draft, mobile node must find out the number of HA's addresses
before select the preferred HA's address.

although it seems to be trivial,  the processing of the current DHADD reply message
is somewhat inconvenient in real implementation on hardware(especially) as well as software. 

thus, i would like to suggest the following modified message format, where HA will provide information. 

what do you think?

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |           Type        |      Code            |                          Checksum            |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |           Identifier                               | No. of HA Addr  |  Reserved          |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |                                                                                                               |
   +                                                                                                               +
   .                                                                                                                .
   .                                      Home Agent Addresses                                     .
   .                                                                                                                .
   +                                                                                                               +
   |                                                                                                               |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Regards,
pyungsoo

---

From: "Ed Remmell" <[email-masked]>
Date: Tue, 26 Nov 2002 18:45:04 -0700

Pyungsoo -

Good luck. There is a bigger problem than that. The current draft allows the
most preferred HA to not appear in the list, but instead to be the IPv6
source address (i.e. in the base IPv6 header) of the HA that originated the
reply. So, by looking at just the DHAAD reply itself (without the original
IPv6 header that encapsulated it) you won't be able to determine the most
preferred HA.

This, BTW, is a broken algorithm for an embedded systems implementation, but
as far as I can tell it won't be changed. Fortunately, DHAAD doesn't happen
that often...

Thanks.
- Ed Remmell
Elmic Systems, USA

  -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Pyungsoo Kim
  Sent: Tuesday, November 26, 2002 7:14 PM
  To: [email-masked]
  Subject: [mobile-ip] How about modification of DHAAD reply message?

  however, in the current draft, mobile node must find out the number of
HA's addresses
  before select the preferred HA's address.

  although it seems to be trivial,  the processing of the current DHADD
reply message
  is somewhat inconvenient in real implementation on hardware(especially) as
well as software.

  thus, i would like to suggest the following modified message format, where
HA will provide information.

  what do you think?

     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |           Type        |      Code            |
Checksum            |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |           Identifier                               | No. of HA Addr
|  Reserved          |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |
|
     +
+
     .
.
     .                                      Home Agent Addresses
.
     .
.
     +
+
     |
|
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

  Regards,
  pyungsoo

---

From: Jari Arkko <[email-masked]>
Date: Wed, 27 Nov 2002 07:58:52 +0200

> listed according to preference).

I don't think it is wise to add redundant fields to protocol messages.
We already know the length of the IP packet, from which you can calculate
the number of HA addresses. If we add another length field, there'll
be plently of error cases you'll need to deal with. In effect, you'll
have to take in account the IP packet length anyway and in addition
worry about the other length field.

In short, I'll propose to reject this modification.

Jari

P.S. Ed: Some people - like me - agree with you that the optimization
of omitting the responding HA's address adds some processing for a very
small benefit. However, "broken for embedded implementations" is an
exaggeration. The issue was decided earlier - lets move on, life continues
even with a few additional lines of code. Let's worry about real problems
instead.

---

From: Pyungsoo Kim <[email-masked]>
Date: Thu, 28 Nov 2002 09:07:11 +0900

Jari

i am also know the length of the IP packet and thus i can calculate
the number of HA addresses.
i mean, mobile node would like to save resource although it seems to be trival....

ok, anyway, i will implement it according to draft...^.^
thank you..

Regards,
pyungsoo