Subject: [Mobopts] New topics for the RG

From: Rajeev Koodli <[email-masked]>
Date: Mon, 11 Jul 2005 15:48:43 -0700

Hello folks,

we have covered some topics in the RG for a while now. In fact,
some of the documents we have produced are ready or nearly ready
for IETF working groups to take on. Specifically,

o the RO enhancements document has got very good reviews and will
   be revised
o the security association establishment for handovers is now in the
   hands of MIPSHOP. One of the RG documents is a potential solution
   candidate.
o  we have had multiple discussions on using, enhancing FMIP.
o context transfers has been discussed, especially in the context of PANA,
   and I believe there will be a document of some sort.
o there has been discussion about L2 triggers and their implementation for
   handovers. I hope we will be able to wrap up a document.

If I missed anything, please do list.

So, I guess it's okay to say we have had some useful work done

Now, it is time to re-consider our charter items. What sorts of topics
are folks interested in working on?  I would like to broaden our scope to
consider Mobility on the Internet in general. Some possible topics for
discussion below in no preference order. Please comment, suggest your
topics and provide a brief justification.

- multicast and mobility. A specific problem is what address should the MN
  use as its source IP address so that its packets are not discarded due 
to a) RPF checks,
  and b) source-specific multicast. To pass a), you need the MN to use 
CoA, but to
  pass b), you need HoA. How to convice multiple receivers about CoA and 
HoA binding?
  Is RR even an option? :-)

- mobility (and traffic) patterns in a WLAN (e.g., a campus network). 
This should provide
  a better sense of traffic for admission control as well as 
network-controlled handovers.
 
- what is the scope of IP paging in a converged WLAN - WWAN environment?
  Is it a real problem? Worthwhile documenting in any case?

- architectural barriers to optimizing inter-domain handovers. Although 
we have
   some understanding of improving delay and packet loss during 
handovers across
   IP networks, how applicable are they across different autonomous 
systems? Would
   the policy barriers allow optimizations? Is this an example of 
"tussle in cyberspace"?
  
- privacy topics related to mobility

- Others

-Rajeev

_______________________________________________
Mobopts mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mobopts

---

From: Ashutosh Dutta <[email-masked]>
Date: Mon, 11 Jul 2005 23:22:47 -0400

Rajeev, I think you have got a good list of items here.

I think optimization for Multicast Mobility will be a useful area more
so for SSM type.

Mobility  Optimization across  heterogeneous  networks (WLAN-WWAN)  is
another interesting  area although  it may overlap  with MIHEP  BOF to
some extent.

Optimization for Inter-domain mobility taking authentication, security
into account is another interesting area.

Thanks
Ashutosh

> --------------060201050206030108070001
> Content-Type: text/html; charset=us-ascii
> Content-Transfer-Encoding: 7bit
> 
> <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
> <html>
> <head>
>   <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
>   <title></title>
> </head>
> <body bgcolor="#ffffff" text="#000000">
> <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
> <title></title>
> <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
> <title></title>
> <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
> <title></title>
> <br>
> <br>
> Hello folks,<br>
> <br>
> we have covered some topics in the RG for a while now. In fact,<br>
> some of the documents we have produced are ready or nearly ready<br>
> for IETF working groups to take on. Specifically,<br>
> <br>
> o the RO enhancements document has got very good reviews and will <br>
> &nbsp;&nbsp; be revised<br>
> o the security association establishment for handovers is now in the<br>
> &nbsp;&nbsp; hands of MIPSHOP. One of the RG documents is a potential solution<br>
> &nbsp;&nbsp; candidate.<br>
> o&nbsp; we have had multiple discussions on using, enhancing FMIP.<br>
> o context transfers has been discussed, especially in the context of
> PANA,<br>
> &nbsp;&nbsp; and I believe there will be a document of some sort. <br>
> o there has been discussion about L2 triggers and their implementation
> for<br>
> &nbsp;&nbsp; handovers. I hope we will be able to wrap up a document. <br>
> <br>
> If I missed anything, please do list. <br>
> <br>
> So, I guess it's okay to say we have had some useful work done<br>
> <br>
> Now, it is time to re-consider our charter items. What sorts of topics<br>
> are folks interested in working on?&nbsp; I would like to broaden our scope
> to<br>
> consider Mobility on the Internet in general. Some possible topics for <br>
> discussion below in no preference order. Please comment, suggest your <br>
> topics and provide a brief justification.<br>
> <br>
> - multicast and mobility. A specific problem is what address should the
> MN <br>
> &nbsp; use as its source IP address so that its packets are not discarded
> due to a) RPF checks,<br>
> &nbsp; and b) source-specific multicast. To pass a), you need the MN to use
> CoA, but to <br>
> &nbsp; pass b), you need HoA. How to convice multiple receivers about CoA
> and HoA binding?<br>
> &nbsp; Is RR even an option? :-)<br>
> <br>
> This should
> provide<br>
> &nbsp; a better sense of traffic for admission control as well as
> network-controlled handovers.<br>
> &nbsp;
> <br>
> - what is the scope of IP paging in a converged WLAN - WWAN
> environment? <br>
> &nbsp; Is it a real problem? Worthwhile documenting in any case? <br>
> <br>
> we have <br>
> &nbsp;&nbsp; some understanding of improving delay and packet loss during
> handovers across <br>
> &nbsp;&nbsp; IP networks,
> how applicable are they across different autonomous systems? Would <br>
> &nbsp;&nbsp; the
> policy barriers allow optimizations? Is this an example of "tussle in
> cyberspace"? <br>
> &nbsp;&nbsp; <br>
> - privacy topics related to mobility <br>
> <br>
> - Others<br>
> <br>
> -Rajeev<br>
> <br>
> <br>
> </body>
> </html>
> 
> --------------060201050206030108070001--
> 
> 
> 
> --===============1848779144==
> Content-Type: text/plain; charset="us-ascii"
> MIME-Version: 1.0
> Content-Transfer-Encoding: 7bit
> Content-Disposition: inline
> 
> --===============1848779144==--
> 
> 

Ashutosh

---

From: Telemaco Melia <[email-masked]>
Date: Tue, 12 Jul 2005 10:30:53 +0200

Hi Rajeev,

of course we are interested  to provide input on the network initiated 
handover topic.
We are currently revising the draft and we should be able to submit 
version 01 by the end of the week.
In the meanwhile I would like to trigger the discussion on the mailing 
list based on version 00.

regards,
Telemaco

-- 
Telemaco Melia			[email-masked]
Research Staff Member		Tel: +49 (0) 6221 90511-42
Network Laboratories		Fax: +49 (0) 6221 90511-55
NEC Europe Ltd.			Web: http://www.netlab.nec.de
Kurfrsten-Anlage 36
D-69115 Heidelberg
Germany

---

From: "Ji Zhang" <[email-masked]>
Date: Tue, 12 Jul 2005 12:33:34 +0100

Hi Rajeev,

Thanks a lot for your summary.

We would like to recommend the following topic to be considered for the
charter:

Deliver link layer characteristic information (e.g. bandwidth...) to a
mobile node's communication peers using mobility control messages  (i.e.
binding updates or registration requests), so that the communication peers
of the mobile node can control their traffic flows accordingly. The idea is
based on the draft
http://www.ietf.org/internet-drafts/draft-daniel-mip-link-characteristic-02.txt.
With this approach, the potential problems (i.e. capacity overspending or
underutilization) on access link capacity changes (especially on vertical
handovers) can be solved. The proposal is suitable for both MIPv4 and MIPv6,
regardless of the type of the transport protocol used. Simulations will be
done in the near future to test its performance.

Any comments and questions are welcome.

Regards,
Ji

> - privacy topics related to mobility

----------------------------------------------------------------------------
----

---

From: "James Kempf" <[email-masked]>
Date: Tue, 12 Jul 2005 09:55:55 -0700

Rajeev,

One item that has come up in the INT chairs list discussion on localized
mobility management is the scalability of using host routes for lmm.

            jak

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 13 Jul 2005 10:39:20 -0700

Telemaco,

good to hear about your interest. Note however that
I am specifically referring to WLAN mobility and traffic
patterns. This should lead to some interesting control
algorithm design. Of course, networ-controlled handovers
on their own are also interesting.

Regards,

-Rajeev

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 13 Jul 2005 10:52:02 -0700

Hi,

I have seen interest in this topic. However, I think the topic is
more than just end-to-end event notification (Disclaimer: I have not
read the latest version). It could affect traffic on the Internet.
So, before we could go ahead with the solution(s), we need to
carefully look into the broader problem, including "cross-layer
design" implications, congestion-control etc. Would you be
interested in looking into those first?

Regards,

-Rajeev

ps: A while ago, MIP group looked into the problem of end-to-end
     QoS problem definition and requirements. I feel the problems are
     similar.

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 13 Jul 2005 10:53:18 -0700

>mobility management is the scalability of using host routes for lmm.
Sounds like an excellent problem to get some empirical
(i.e., simulation) data on.

-Rajeev

---

From: Conny Larsson <[email-masked]>
Date: Thu, 28 Jul 2005 17:02:10 +0200

Hi Rajeev,

I looked through the proposed topics and would like to ask you about the 
status of simultaneous multi-access support for MIPv6. Some years ago 
Hesham wrote a draft "Flow movement in Mobile IPv6" 
(draft-soliman-mobileip-flow-move-03.txt). I don't know the status of 
the work but if no one has worked on it I would suggest it to be 
considered as one of the topics for the mobopts working group.

/Conny

Rajeev Koodli wrote:

>   use as its source IP address so that its packets are not discarded 
> due to a) RPF checks,
>   pass b), you need HoA. How to convice multiple receivers about CoA 
> and HoA binding?
> - architectural barriers to optimizing inter-domain handovers. 
> Although we have
>------------------------------------------------------------------------
>

---

From: Thierry Ernst <[email-masked]>
Date: Sat, 30 Jul 2005 09:22:15 +0900

Dear Conny,

I'm sorry in advance for repeating an earlier announcement for the
Monami6 BOF http://www.nautilus6.org/ietf I recently made on this ML,
but given the message below it must be worthwhile to point out that this
is exactly what the Monami6 BOF is all about. 

[sorry if this is pointed  before this mail reaches this ML as
I'm writing this mail aboard my flight to Paris]

Regards,
Thierry

 On Thu, 28 Jul 2005 17:02:10 +0200
Conny Larsson <[email-masked]> wrote:

> Hi Rajeev,
> 
> I looked through the proposed topics and would like to ask you about
> the status of simultaneous multi-access support for MIPv6. Some years
> ago Hesham wrote a draft "Flow movement in Mobile IPv6"