Subject: Re: Re: [Mobopts] New topics for the RG

From: Daniel Park <[email-masked]>
Date: Tue, 12 Jul 2005 06:28:56 +0000 (GMT)

(I think this thread should be moved into 6lowpan w.g., not
mobopts)

>Well, once sensors are IP-enabled, NEMO is likely more appropriate than

>MANET, from a complexity point of view:

>- no need to manage mobiility: MR does everything

>- sensors may not be wireless nodes: MANET is pointless

>- MR can deals with security aspects on behalf of sensors

Are you saying that NEMO protocols are be able to be applied for

6lowpan node which has very severe  limited code and resource ?

Or are you assuming any NEMO lightweight version ?

Regarding MANET protocol, it is already enabled on lowpan

network (802.15.4) such as ZigBee. Also, as far as I am

concern, 6lowpan does not have any NEMO issues.

Regards

Daniel (Soohong Daniel Park)

Mobile Platform Laboratory. SAMSUNG Electronics

_______________________________________________
Mobopts mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mobopts

---

From: Syam Madanapalli <[email-masked]>
Date: Tue, 12 Jul 2005 12:10:55 +0530

Hi Daniel,

I think what Thierry has said is NEMO runs on a mobile router behind which
the sensor devices are located. So Mobility is supported for the sensor 
devices
without implementing the mobility protocols on memory constrained sensor 
devices.

But I think there can be a wireless sensor devices which may need MANET 
support.

-Syam

----- Original Message ----- 
From: "Daniel Park" <[email-masked]>
To: "Thierry Ernst" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, July 12, 2005 11:58 AM
Subject: Re: Re: [Mobopts] New topics for the RG

> Samsung Enterprise Portal mySingle(I think this thread should be moved 
> into 6lowpan w.g., not mobopts)
>
>
>

--------------------------------------------------------------------------------

---

From: Thierry Ernst <[email-masked]>
Date: Tue, 12 Jul 2005 16:03:46 +0900

> I think what Thierry has said is NEMO runs on a mobile router behind
> which the sensor devices are located. So Mobility is supported for the
> sensor devices
> without implementing the mobility protocols on memory constrained
> sensor devices.

Correct, this is what I meant. 

The scenario we consider is IPv6 sensors deployed in a vehicle. We do
have such IPv6 sensors developped by WIDE, information is retrieved with
SNMP, and electric supply is provided by a Hub.
 
To answer Daniel's, any IPv6 node that complies to 6lowpan requirements
can be put behind a NEMO-enabled mobile router, at not additional cost
since the MR is doing all the mobility management.

> But I think there can be a wireless sensor devices which may need
> MANET support.

Yes, this may be requested in such situations, but unless I'm mistaken
running an ad-hoc routing protocol is more energy consumming that a
simple IPv6 node behind a NEMO MR (from a sensor's point of view, not
from the overall system's point of view since a MR is also consuming
energy).

Thierry

> > Samsung Enterprise Portal mySingle(I think this thread should be
> > moved into 6lowpan w.g., not mobopts)
> >
> >
> >
> >>Well, once sensors are IP-enabled, NEMO is likely more appropriate
> >than>MANET, from a complexity point of view: