Subject: Re: [Mobopts] Re: [Mip6] MIP and Upper Layer Protocol interaction

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 20 Jun 2006 10:45:17 -0700

Soliman, Hesham wrote:
>  > > One option would be to run Shim6 over MIPv6.  Such usage has
>  > > already been discussed in Shim6 WG.  By mobile node establishing
>  > > Shim6 context with its HA/CN, it could utilize multiple HoAs
>  > > without annoying upper layer protocols.  
>  > 
>  > yes, this can be done. but I would like to restrict
>  > shim6 usage when mip6 is used to the case where the
>  > home link is site multihomed and the mobile node already
>  > has the multiple home addresses configured on it. not
>  > when the mobile node decides to change its home address.
> 
> => There is no difference between the two scenarios. 

your reply is too cryptic.

when shim6 is used, one cannot start using another address
without first adding that address to the list of addresses
that the HA/CN need to be aware of (basically add to the
shim6 state).

also, if both home addresses are from the same prefix,
shim6 shouldn't be used. if the home link is multihomed
and the mobile node has multiple home addresses from the
different prefixes, then shim6 is applicable.

ofcourse, one can do all this with shim6, but then quoting
you "shim6 is trying to solve world hunger". ;) (hope you
don't mind it).

Vijay

_______________________________________________
Mobopts mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mobopts

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Wed, 21 Jun 2006 10:36:52 -0700

> => Of course, which is doable in both scenarios.
> 
>  > 
>  > shim6 shouldn't be used. 
>          ^^^^^^^^^
> => that's your opinion, but the point is it can be used just as easily
> whether it's the same prefix or a different one. It actually 
> makes sense
> to use on solution for both cases.
> 
> 
>   if the home link is multihomed
> => It's applicable in both cases, you want to use it in one case. 

yes. in my first reply to Shinta, I had said, I 
_would like_ to restrict the use of shim6 when MIP6
is used to the scenario when the home link is
multihomed.

this is one of the reasons why folks are still 
confused about the role of shim6 (see recent 
discussion on the shim6 mailing list). 

Vijay

> Hesham