Subject: [Mobopts] Performance and Policy

From: Rajeev Koodli <[email-masked]>
Date: Tue, 06 Jun 2006 17:26:20 -0700

Folks,

with IP mobility plumbing behind us (some might disagree), it's 
inevitable that we look at
performance of Upper Layer Protocols such as TCP and RTP under mobility.

o What's the performance of TCP under handovers (both intra and inter
technology)?
o What _should_ be its performance?
o What's good for the "wireless link as a whole"?
o How to regulate fair sharing of the link during mobility?
o Others?

Any thoughts?

Another topic that comes to mind is policy. Inter-technology mobility is 
subject
to policy controls when crossing provider boundaries. Yet, I am not
sure we are paying enough attention to policy when designing for 
performance.. Perhaps
I am wrong here, but I would like to hear counter-arguments.

Regards,

-Rajeev

_______________________________________________
Mobopts mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mobopts

---

From: Ashutosh Dutta <[email-masked]>
Date: Tue, 06 Jun 2006 20:36:27 -0400

Rajeev, sounds interesting. Going along with the same philosophy we can 
probably study some of the optimization research problems associated  
with some upper layer mobility protocols such as HIP and SIP as well.

Thanks
Ashutosh

Rajeev Koodli wrote:

> Another topic that comes to mind is policy. Inter-technology mobility 
> is subject

---

From: "James Kempf" <[email-masked]>
Date: Wed, 7 Jun 2006 08:16:05 -0700

Rajeev,

There is an extensive academic  literature about TCP performance during 
handover. See for example Andre Gurtov's thesis. I think it might help to 
have someone do a literature survey, similar to the one Bernard did about 
link hints in his IAB draft, and write it up for a draft (unfortunately, I 
can't volunteer as I have too much else to do right now).

Regarding your point about policy, I have always thought that this is likely 
to be a particular issue with inter-technology handover. Another issue is 
that most of the architectures that seem likely to be deployed have a 
variety of boxes between the two types of wireless links (PDG, UMA gateway, 
etc.).

            jak

----- Original Message ----- 
From: "Rajeev Koodli" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, June 06, 2006 5:26 PM
Subject: [Mobopts] Performance and Policy

>
> Folks,
>
> with IP mobility plumbing behind us (some might disagree), it's inevitable 
> that we look at

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 07 Jun 2006 10:21:27 -0700

James Kempf wrote:

> Rajeev,
>
> There is an extensive academic  literature about TCP performance 
> during handover. See for example Andre Gurtov's thesis. I think it 
> might help to have someone do a literature survey, similar to the one 
> Bernard did about link hints in his IAB draft, and write it up for a 
> draft (unfortunately, I can't volunteer as I have too much else to do 
> right now).
>
Thanks for the pointer. I also think there is work on end-to-end basis 
(e.g., using
TCP options), but I have not come across IP layer mechanisms. I would be 
glad to
find out more.

Yes, the idea is to first get hold of what exists and then see how ULP 
performance
blends in with Fast IP routing.

> Regarding your point about policy, I have always thought that this is 
> likely to be a particular issue with inter-technology handover. 
> Another issue is that most of the architectures that seem likely to be 
> deployed have a variety of boxes between the two types of wireless 
> links (PDG, UMA gateway, etc.).
>
Yes, there are complexities. Why don't we recognize them up front and 
say "here are
the issues for the designers" ? :-) The challenge is in formalizing 
these issues I believe..
Take for instance pre-auth. I think it is worthwhile.
I also think it would be tricky to do across provider boundaries; 
perhaps that's not the
focus now. We did discuss it at MobOpts several times..

-Rajeev

>            jak
>
> ----- Original Message ----- From: "Rajeev Koodli" 
> <[email-masked]>
> To: <[email-masked]>

---

From: "James Kempf" <[email-masked]>
Date: Wed, 7 Jun 2006 10:59:03 -0700

> Yes, there are complexities. Why don't we recognize them up front and say 
> "here are
> the issues for the designers" ? :-) The challenge is in formalizing these 
> issues I believe..
> I also think it would be tricky to do across provider boundaries; perhaps 
> that's not the

Perhaps a problem statement?

Also, defining how fast handover interacts with 802.11r preauth sounds 
worthwhile.

            jak

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 07 Jun 2006 12:49:54 -0700

> Perhaps a problem statement?
Sure. That would be good.

> Also, defining how fast handover interacts with 802.11r preauth sounds 
Yes.

Perhaps we should have a good session on this at Montreal.

-Rajeev

---

From: "Vijay Devarapallli" <[email-masked]>
Date: Wed, 7 Jun 2006 16:03:34 -0700

On 6/6/06, Rajeev Koodli <[email-masked]> wrote:

> performance.

I am very interested in this topic. I have been working on this recently.
let me know if you need someone to write up a problem statement.

Vijay

---

From: Soohong Daniel Park <[email-masked]>
Date: Thu, 08 Jun 2006 15:43:21 +0900

Rajeev, 

> inevitable that we look at performance of Upper Layer Protocols 
> such as TCP and RTP under mobility.

Perhaps, you said RTP as one of UDP implication. 

RTP does not address resource reservation and does not 
guarantee quality-of-service for real-time services. RTP
is augmented by a RTCP to monitor data delivery and 
network statistics. So, RTCP can be a facility in order to
optimizing its service disruption unver handover. Although,
RTCP resolves many of the problems in UDP network, such
as lost packets, jitter, and out of sequence packets, it that
reports conditions of session periodically may have difficulty
to guarantee quality-of-service immediately. especially, 
Mobile environments with many participants and low 
bandwidth may cause the long interval of RTCP transmission
(for example, 5-6 seconds or more). RTP and/or RTCP
header options can be available approachs though...There
is more immediate RTCP feedback defined in "Extended
RTP profile for RTCP-based Feedback", RTCP feedback
message is heavy to be used for mobility environment.

Regards.

Daniel (Soohong Daniel Park)
Mobile Convergence Laboratory, SAMSUNG Electronics.

---

From: Rajeev Koodli <[email-masked]>
Date: Thu, 08 Jun 2006 17:32:46 -0700

> let me know if you need someone to write up a problem statement.
I like the idea of putting together a document. We should dedicate some time
in Montreal for this topic.
In the meanwhile, what are the issues? Let's discuss on the ML.

-Rajeev

---

From: Telemaco Melia <[email-masked]>
Date: Sun, 18 Jun 2006 18:23:43 +0200

Hi all,

Here go some first ideas. Feedback is welcome.

Requirements:
==========
- Unified model for both network side and terminal side

- Network mainly interested in:
    + performance optimization (vertical handovers)
    + roaming across boundaries (inter domain handovers)
    + network controlled and network initiated handovers

- (Multi mode) Terminal interested in:
    + Keep best connectivity (depending on radio conditions...)
    + Receive via multiple interfaces (multihoming, multiple bindings...)
       o management of flows
       o soft handover might be more suitable
    + Power saving (imagine a device with HSDPA, Wimax mobile and WLAN)
       o not at MAC level, rather as a policy
    + Influence on mobility of less volatile information such as context 
(applications)

If people are interested I could come up with a fews slides elaborating 
the above.
What do you think?

regards,
telemaco

-- 
Telemaco Melia          	[email-masked]
Research Staff Member		Tel: +49 (0) 6221 4342- 142
Network Laboratories    	Fax: +49 (0) 6221 4342- 155
NEC Europe Ltd.         	Web: http://netlab.nec.de
Kurfrsten-Anlage 36
D-69115 Heidelberg
Germany

---

From: "James Kempf" <[email-masked]>
Date: Mon, 19 Jun 2006 08:30:31 -0700

"Soft handover" is a L2 technique only. If it is in use, the IP layer never 
sees the outstanding hanodever legs.

I think you mean "make before break" handover, in which the terminal gets 
data plane packets via the old leg while configuring on the new AP via the 
new.

            jak

----- Original Message ----- 
From: "Telemaco Melia" <[email-masked]>
To: "Rajeev Koodli" <[email-masked]>
Cc: <[email-masked]>
Sent: Sunday, June 18, 2006 9:23 AM
Subject: Re: [Mobopts] Performance and Policy

>>>> is