Subject: [Model-t] Fwd: [EXT] New Version Notification for draft-bertola-everything-but-the-user-00.txt

From: Vittorio Bertola <[email-masked]>
Date: Tue, 4 Jan 2022 12:19:21 +0100 (CET)

Hello,

after the call we had in December, I eventually had the time to write down my thoughts into a draft. It started as a reflection on the role and definition of intermediaries, but it ended up as my take on a problem statement of what is missing from the RFC 3552 model and on a sort of high level design of a possible solution.

Comments are welcome - perhaps a workshop or other ways of prompting more views on a possible RFC 3552 revision/addition would be useful.

Ciao,

> ---------- Messaggio originale ----------
> Da: [email-masked]
> A: Vittorio Bertola <[email-masked]>
> Data: 04/01/2022 12:09
> Oggetto: [EXT] New Version Notification for draft-bertola-everything-but-the-user-00.txt
> 
>  
> A new version of I-D, draft-bertola-everything-but-the-user-00.txt
> has been successfully submitted by Vittorio Bertola and posted to the
> IETF repository.
> 
> Name:		draft-bertola-everything-but-the-user
> Revision:	00
> Title:		Everything But The User Is An Intermediary
> Document date:	2022-01-04
> Group:		Individual Submission
> Pages:		9
> URL:            https://www.ietf.org/archive/id/draft-bertola-everything-but-the-user-00.txt
> Status:         https://datatracker.ietf.org/doc/draft-bertola-everything-but-the-user/
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-bertola-everything-but-the-user
> 
> 
> Abstract:
>    This document provides the author's perspective on the shortcomings
>    of the Internet threat model defined in RFC 3552 and currently in use
>    at the IETF.  It then proposes the basic conceptual framework for an
>    additional model, the "holistic threat model", describing how it
>    could be used to broaden the analysis of non-technical protocol
>    impacts in the design phase.
> 
>                                                                                   
> 
> 
> The IETF Secretariat

-- 
Vittorio Bertola
Head of Policy & Innovation 

Cell:	 +39 348 7015022	
Direct Chat:	 vittorio.bertola (https://chat.open-xchange.com/direct/vittorio.bertola)	
Email:	 [email-masked]	
	
Twitter: @openxchange (http://twitter.com/openxchange) - Facebook: openxchange (https://www.facebook.com/openxchange) - Web: www.open-xchange.com (http://www.open-xchange.com)	
https://www.open-xchange.com/	 Open-Xchange AG, Hohenzollernring 72, 50672 Cologne, District Court Cologne HRB 95366
Managing Board: Andreas Gauger, Carsten Dirks, Dirk Valbert, Stephan Martin 
Chairman of the Board: Bernhard Wöbker
European Office: 
Open-Xchange GmbH, Olper Huette 5f, D-57462 Olpe, Germany, District Court Siegen, HRB 8718 
Managing Director: Frank Hoberg
US Office: 
Open-Xchange. Inc., 530 Lytton Avenue, Palo Alto, CA 94301, USA	 	
	
Confidentiality Warning: This message and any attachments are intended only for the use of the intended recipient(s), are confidential, and may be privileged. If you are not the intended recipient, you are hereby notified that any review, retransmission, conversion to hard copy, copying, circulation or other use of this message and any attachments is strictly prohibited. If you are not the intended recipient, please notify the sender immediately by return e-mail, and delete this message and any attachments from your system.

---

From: Watson Ladd <[email-masked]>
Date: Tue, 4 Jan 2022 11:36:12 -0800

Dear Vittorio,

I've read the draft. I don't think it provides a useful guide to
improvements in the threat model. There's too much hypothetical
language, too little actual examples of privacy being harmed by
encryption and helped by spying ISPs. I take particular exception to
two or three sentences from it:

"It is now expected that a sense of social and corporate
responsibility, and policy objectives defined outside of the technical
community, contribute to shaping the choices that will determine the
future evolution of the Internet."

Was this ever not true? And who expects it of whom? This has the
implication that technical expertise means not having the same right
to have views of social issues and to make decisions on that basis.
There have been many times: crypto export controls, crypto backdoors,
.xxx, etc. where activism from the Internet community informed by its
technical expertise has been vital.
"

Under this extended threat model, no claim should be made over the
   privacy, security or any other property of Internet communications
   from the end-user's perspective, unless all parties different from
   the user(s) that take part in the communication, and all their
   possible motivations, have been considered: hence the "holistic"
   threat model.
"

This is completely unrealistic and means an inordinate amount of work
for RFC authors. How the heck does TLS even get done with this, given
the definition of parties includes every software vendor in the world?
I think there will be problems.

This document would be a lot stronger if it had cases studies to back
up its sweeping assertions.

Sincerely,
Watson Ladd

--
Astra mortemque praestare gradatim

---

From: Dominique Lazanski <[email-masked]>
Date: Thu, 6 Jan 2022 09:49:43 +0100

Hi -

My older draft for Model-t takes a stab at giving some examples. It’s not comprehensive yet but goes part of the way:

https://datatracker.ietf.org/doc/draft-lazanski-protocol-sec-design-model-t/

Dominique 

> On 4 Jan 2022, at 20:36, Watson Ladd <[email-masked]> wrote:
> 
> Dear Vittorio,
> 
> Model-t mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/model-t