Subject: [Modern] protocols for number management?

From: "PFAUTZ, PENN L" <[email-masked]>
Date: Wed, 28 Jan 2015 17:12:03 +0000

ATIS has a landscape testbed activity assembling various use cases that might be examined in a testbed.
One of them involves inventory-less just-in-time number assignment within the framework of the kind of unfied numbering lifecycle management platform discussed at the FCC Numbering Testbed Workshop back in March of 2014.

The question came up as to what sort of protocols might be appropriate for service providers to interact with the registry provider(s), to find available resources, request assignments, and provision appropriate information for distribution to other SPs once the assignment is made. Mechanisms to accommodate this a distributed registry architecture are also of interest (how to make sure the same number isn't assigned by two different  registry providers in a race condition)

It occurred to me folks on this list might have some suggestions.

Thanks,
Penn Pfautz
AT&T Global Connection Management
+1-732-420-4962

---

From: Erik Chuss <[email-masked]>
Date: Thu, 29 Jan 2015 15:32:05 +0000

Penn,

In thinking about this, in order to help facilitate the discussion and identify potential test bed solutions, what do you envision the appropriate provisioning information to be used for?  As you know the Toll Free system has supported, what we have called 'line-level number allocation', since the early 1900's.  The number administration of the system piece allows for centralized access to numbering resources and equal access to the resources on a 'first in/first out' basis. It keeps track of the numbering lifecycle by storing the status of each number (Spare, Reserved, Working, Transitional, Disconnect, etc.).  It is also used to identify the Responsible Organization (Resp Org) of a number and ensures only updates to provisioning be made by the Resp Org of the number (i.e. provisioning security).  There are, of course, more functions of the number admin piece but I just wanted to mention a few high-level topics.  A distributed solution may present special challenges for these items that would need to be addressed.  The key piece though is the provisioning piece.  How do you or the others foresee the system be used for in terms of provisioning appropriate information in the network?  Would it just be used for validation on a 'push' basis where the information is distributed to the service providers automatically who can then use it as they see fit or opening the system up for query on an as needed basis?  Is there some other functionality that could be included?

I hope this helps with the initial discussion and facilities expanded discussion.

Erik J. Chuss
North America Toll Free Number Administrator
DSMI/Ericsson, Inc.
RRC-4A1142
1 Ericsson Drive
Piscataway, NJ 08854
Phone: 1-732-699-3422

From: Modern [mailto:[email-masked]] On Behalf Of PFAUTZ, PENN L
Sent: Wednesday, January 28, 2015 12:12 PM
To: [email-masked]
Subject: [Modern] protocols for number management?

Thanks,
Penn Pfautz

---

From: "PFAUTZ, PENN L" <[email-masked]>
Date: Thu, 29 Jan 2015 15:46:09 +0000

Erik:
I would expect much of the functionality to be similar to SMS/800 with some tweaks
The numbering space would be more segmented, e.g. by geography and assignment rules would differ. The users would be SPs not RespOrgs.
Don't know whether direct query would be supported or not  but the info provided in either case would not include service logic.
I would expect the protocol to differ just because technology has become more sophisticated

Thanks,
Penn

From: Erik Chuss [mailto:[email-masked]]
Sent: Thursday, January 29, 2015 10:32 AM
To: PFAUTZ, PENN L; [email-masked]
Cc: Erik Chuss
Subject: RE: protocols for number management?

Penn,

Erik J. Chuss

From: Modern [mailto:[email-masked]] On Behalf Of PFAUTZ, PENN L
Sent: Wednesday, January 28, 2015 12:12 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Modern] protocols for number management?

Thanks,
Penn Pfautz

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 29 Jan 2015 17:00:57 +0000

I'm curious to hear more about the likely numbering states. I'm comparing EPP (domain name) and 800 states, but a good reference to the formal definitions and transitions for 800# would be helpful. (Some of it can be deduced from the CFR rules, but they were obviously not written by protocol designers.)

________________________________
From: Modern [[email-masked]] on behalf of Erik Chuss [[email-masked]]
Sent: Thursday, January 29, 2015 10:32 AM
To: PFAUTZ, PENN L; [email-masked]
Cc: Erik Chuss
Subject: Re: [Modern] protocols for number management?

Penn,

In thinking about this, in order to help facilitate the discussion and identify potential test bed solutions, what do you envision the appropriate provisioning information to be used for?  As you know the Toll Free system has supported, what we have called ‘line-level number allocation’, since the early 1900’s.  The number administration of the system piece allows for centralized access to numbering resources and equal access to the resources on a ‘first in/first out’ basis. It keeps track of the numbering lifecycle by storing the status of each number (Spare, Reserved, Working, Transitional, Disconnect, etc.).  It is also used to identify the Responsible Organization (Resp Org) of a number and ensures only updates to provisioning be made by the Resp Org of the number (i.e. provisioning security).  There are, of course, more functions of the number admin piece but I just wanted to mention a few high-level topics.  A distributed solution may present special challenges for these items that would need to be addressed.  The key piece though is the provisioning piece.  How do you or the others foresee the system be used for in terms of provisioning appropriate information in the network?  Would it just be used for validation on a ‘push’ basis where the information is distributed to the service providers automatically who can then use it as they see fit or opening the system up for query on an as needed basis?  Is there some other functionality that could be included?

Erik J. Chuss

The question came up as to what sort of protocols might be appropriate for service providers to interact with the registry provider(s), to find available resources, request assignments, and provision appropriate information for distribution to other SPs once the assignment is made. Mechanisms to accommodate this a distributed registry architecture are also of interest (how to make sure the same number isn’t assigned by two different  registry providers in a race condition)

Thanks,
Penn Pfautz

---

From: "PFAUTZ, PENN L" <[email-masked]>
Date: Thu, 29 Jan 2015 18:07:03 +0000

Here's a link to the CFR 47 part defining states for toll free numbers:
http://www.gpo.gov/fdsys/pkg/CFR-2013-title47-vol3/pdf/CFR-2013-title47-vol3-part52-subpartD.pdf

-----Original Message-----
From: Henning Schulzrinne [mailto:[email-masked]] 
Sent: Thursday, January 29, 2015 12:01 PM
To: Erik Chuss; PFAUTZ, PENN L; [email-masked]
Subject: RE: protocols for number management?

Penn,

Erik J. Chuss

Thanks,
Penn Pfautz

---

From: Brian Rosen <[email-masked]>
Date: Thu, 29 Jan 2015 13:29:47 -0500

Penn

Suppose there was an entity that more or less appeared to be a carrier or authorized holder of numbers.

All unallocated numbers appear in the database and are marked as being held by that entity (SPID).

Then any other authorized entity could “port” a number from that entity to themselves, using the porting mechanism.   This effectively means the entire inventory is held by that entity and numbers are “allocated” out one at a time (or a short range, when that’s what is allocated to a customer).

Since we expect ports to be able to be completed in seconds, that would be a suitable mechanism.

Brian

> On Jan 28, 2015, at 12:12 PM, PFAUTZ, PENN L <[email-masked]> wrote:
> 
> _______________________________________________
> Modern mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/modern <https://www.ietf.org/mailman/listinfo/modern>