Subject: Re: [Modern] Services

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 27 Jan 2015 02:47:48 +0000

David,

picking up an old discussion thread. Do you have any pointers to relevant documents that we can collect? I'm particularly looking for documents that describe information associated with phone numbers. The domain name world is reasonably well documented (see, for example, Section 3 of https://www.icann.org/resources/pages/approved-with-specs-2013-09-17-en#information)

Henning

________________________________________
From: Holmes, David W [CTO] [[email-masked]]
Sent: Monday, October 27, 2014 7:18 PM
To: Henning Schulzrinne; McGarry, Tom; [email-masked]
Subject: RE: [Modern] Services

This is a great discussion & continues to follow the common IETF principles of proposing a solution & then finding what patches it needs to meet some implicit requirement(s).

However, in this case, given the huge legacy coming in from both the IP & PSTN worlds, I suspect that perhaps we should consider modifying the process somewhat, & first generate some kind of statement of requirements / problem statement.  A large amount of the required information has already been aired, as we see below, so potentially this could be done without the expenditure of much effort.

Maybe what we need to start the process is an informational RFC that list out all the identifiers in common use in this field, & how they are used, translated for routing, etc.?  Based on that it should be easy to rationally derive a set of requirements & (hopefully) figure which identifier(s) & supporting mechanisms can be minimally modified to produce a reasonable solution.

David Holmes
Sprint

---

From: "Holmes, David W [CTO]" <[email-masked]>
Date: Wed, 28 Jan 2015 18:53:47 +0000

Hi Henning,

I suspect that "information associated with E.164 phone numbers" is highly inconsistent in nature, as, once the "country"-level information is allocated to the per-"country" administrators, I do not believe that there is any requirement to have a standard set of information collected for the entities to whom those administrators allocate numbers; I suspect we can only presume entity name & potentially business address; & similar for the end customers to whom the carriers allocate individual numbers from the blocks they are given by their national number administrators.  So while we may have local stores of more associated data sets (like LIDB), these are not universal.

What is your interest in the information associated with a particular identifier type?  I was suggesting that a first step would be to generate a list of identifiers & their technical characteristics.

BR/David

-----Original Message-----
From: Henning Schulzrinne [mailto:[email-masked]]
Sent: Monday, January 26, 2015 9:48 PM
To: Holmes, David W [CTO]; McGarry, Tom; [email-masked]
Subject: RE: [Modern] Services

David,

Henning

David Holmes
Sprint

________________________________

This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 28 Jan 2015 20:44:06 +0000

Thanks for the reminder and pointer. Here’s the list for convenience:

TN ownership;
 Authoritative Calling Name (CNAM);  [16 character text now; more elaborate for CNAM++]
 Bill Number Screening, for collect calling and calls billed to third parties; [boolean]
 Originating Line Number Screening for prison lines (already the subject of
another FCC proceeding) and hotel rooms, as well as for optional services
billed to the originating line; [Boolean]
 Service and Equipment Indicator, used to determine treatment of calls
originated by the TN; [?]
 ZIP+4, used in “311” information services routing; [9 digits]
 Line-based calling card PINs, (to the extent these are retained in the all-IP
network); and [seems likely to disappear, but possibly a hash]
 PIC and LPIC, interexchange carrier designations (to the extent these are
retained in the all-IP network). [integers]

I suspect we’ll want a system that makes it relatively easy to add fields to each number record, without more than a registration (IANA-style) mechanism, but I want to get a sense of the range of data types we may find. I [annotated] the list above with my guess and welcome corrections.

From: Ken Pogran [mailto:[email-masked]]
Sent: Wednesday, January 28, 2015 1:41 PM
To: Henning Schulzrinne
Cc: Holmes, David W [CTO]; [email-masked]
Subject: Re: [Modern] Services

Henning,

When this thread was active back in October, I sent an email (See http://www.ietf.org/mail-archive/web/modern/current/msg00077.html) that may have been missed, as it somehow got marked "SPAM" (at least, in the Archive).   In that email I commented on "information associated with phone numbers" in the PSTN Line Information Database (LIDB), and pointed to comments my company submitted to the FCC in the 13-5 proceeding, and earlier, discussing the range of TN data elements in LIDB and the post-transition relevance of a subset of them (such as Calling Name).

One question is where those surviving TN data elements will be stored, post-transition, and how they will be provisioned. Since most LIDB data elements are PSTN-specific, or pertain to subscriber services that are likely to be discontinued, it is unlikely that LIDB itself will continue to exist, once the PSTN transition is complete.

Provisioning systems used today, that sit between business/ordering systems and LIDB, typically hold a complete record of TN data elements. They are well positioned to provide a convenient point of leverage, as new network databases are introduced and old ones retired.

Ken Pogran

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 28 Jan 2015 20:58:30 +0000

I agree that we'll see a fair amount of variation.

But I'm confused by your last paragraph: What kind of identifiers did you have in mind? I thought we'd be talking about E.164 numbers?

________________________________________
From: Modern [[email-masked]] on behalf of Holmes, David W [CTO] [[email-masked]]
Sent: Wednesday, January 28, 2015 1:53 PM
To: Henning Schulzrinne; McGarry, Tom; [email-masked]
Cc: Gorman, Pierce A [NTK]
Subject: Re: [Modern] Services

Hi Henning,

---

From: "Holmes, David W [CTO]" <[email-masked]>
Date: Wed, 28 Jan 2015 22:36:52 +0000

Hi Henning,

Going back to my mail from last October, my strong suggestion was that if the desire is to create some kind of optimum solution for service delivery identifiers, requirements should be defined first (i.e. both optimum behavior & issues with current solutions) & use that as a basis for defining/selecting solutions, per (e.g.) the techniques described in ITU I.130.  The email threads from that period contain many of the needed requirements, but I suggested that a good starting point would be to look at the properties of a few of the current options, maybe focusing on E.164; properties like who allocates them, how they are allocated, how they are used for routing, how they are discovered, etc.

BR/David

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of Henning Schulzrinne
Sent: Wednesday, January 28, 2015 3:59 PM
To: Holmes, David W [CTO]; McGarry, Tom; [email-masked]
Cc: Gorman, Pierce A [NTK]
Subject: Re: [Modern] Services

Hi Henning,

_______________________________________________
Modern mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/modern

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 29 Jan 2015 04:01:48 +0000

I suspect we may be talking about two different problems. My sense is that MODERN is discussing allocation of E.164 identifiers, probably within a national or similar (+1) scope. Service identifiers may be added as a feature (facet, field, ...) of the database, possibly including as a (part of the) primary key, as in 

+12025551234/telephony 

(to follow I.240)

One generic model is to allow for a two-part primary key consisting of an E.164 number and a modifier (opaque string) that is then defined by (say) ATIS or other, more operationally-oriented, bodies.

I wonder if others have a different perception.

Henning

Sent: Wednesday, January 28, 2015 5:36 PM

Hi Henning,

BR/David

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of Henning Schulzrinne
Sent: Wednesday, January 28, 2015 3:59 PM
To: Holmes, David W [CTO]; McGarry, Tom; [email-masked]
Cc: Gorman, Pierce A [NTK]
Subject: Re: [Modern] Services

Hi Henning,

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 29 Jan 2015 17:01:21 +0000

Forgot one.

TN ownership; [OCN today; some reference to an entity record in the future]