Subject: Re: [Modern] Problem statement draft as working group document

From: Steve Donovan <[email-masked]>
Date: Thu, 10 Dec 2015 12:40:01 -0600

There has been no response to this so I'm going to suggest we put a 
deadline on opinions.

Please express your opinion on making draft-peterson-modern-problems-02 
a working group document before Thursday, December 17th.

It is important that anyone who supports the promotion of the document 
also express their opinion.

Thanks,

Steve

On 11/13/15 3:53 PM, Steve Donovan wrote:
> All,
>
> During the IETF94 MODERN WG meeting there was consensus that 
> draft-peterson-modern-problems-02 be accepted as a working group 
> document.  This would be to address the architecture Architecture 
> Overview milestone.
>
> It was recognized that it is not in final form but would be a good 
> starting point for the architecture overview.
>
> Please comment on whether or not this should become a working group 
> document.
>
> Regards,
>
> Steve
>
> _______________________________________________
> Modern mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/modern

---

From: Eric Burger <[email-masked]>
Date: Thu, 10 Dec 2015 20:05:02 -0500

Nah. :-)

> On Dec 10, 2015, at 1:40 PM, Steve Donovan <[email-masked]> wrote:
> 
> There has been no response to this so I'm going to suggest we put a deadline on opinions.
> 
> Please express your opinion on making draft-peterson-modern-problems-02 a working group document before Thursday, December 17th.
> 
> It is important that anyone who supports the promotion of the document also express their opinion.
> 
> Thanks,
> 
> Steve
> 
>> During the IETF94 MODERN WG meeting there was consensus that draft-peterson-modern-problems-02 be accepted as a working group document.  This would be to address the architecture Architecture Overview milestone.
>> 
>> It was recognized that it is not in final form but would be a good starting point for the architecture overview.
>> 
>> Please comment on whether or not this should become a working group document.
>> 
>> Regards,
>> 
>> Steve
>>

---

From: Richard Shockey <[email-masked]>
Date: Sat, 12 Dec 2015 15:34:02 -0500

+1 <yawn>  

It still seems to be “end world hunger week”…

Steve I don’t know how you define consensus ..but it still strikes me that consensus on what is the real problem is very weak.

---

From: Steve Donovan <[email-masked]>
Date: Mon, 14 Dec 2015 08:44:01 -0600

inline...

> It still seems to be “end world hunger week”…
SRD> I would hope we could advance this discussion without sarcasm and 
snarkiness.  I interpret your response and Eric's response as an 
indication that you do not think that draft-peterson-modern-problems-02 
should not become a working group draft.  I'm sure both of you will let 
me know if I have interpreted your responses incorrectly.
> Steve I don’t know how you define consensus ..but it still strikes me that consensus on what is the real problem is very weak.
SRD> I am not at liberty to define consensus, that is in the preview of 
the ADs.  I am simply asking the working group if a document should 
become a working group item.  There were no objections expressed during 
the meeting in Yokohama, which is an indication of consensus.  The next 
step is to verify that consensus on the list.  That is what we are in 
the process of doing.

SRD> It would be very helpful if you could elaborate on why you think 
the document should not become a working group item.

---

From: Steve Donovan <[email-masked]>
Date: Mon, 14 Dec 2015 08:44:51 -0600

Eric,

Could you elaborate on why you think the document should not become a 
working group item.
Thanks,

Steve

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Mon, 14 Dec 2015 15:52:04 +0000

If an actual reason is not required I would like to add my vote of dissension on principal without having to actually read the "draft-peterson-modern-problems-02".  You might recall I argued with the language in the charter but I and others were over-ruled by the Area Directors.

Pierce Gorman

From: Modern [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: December 14, 2015 8:45 AM
To: [email-masked]
Subject: Re: [Modern] Problem statement draft as working group document

Eric,

Could you elaborate on why you think the document should not become a working group item.

Thanks,

Steve

Nah. :-)

On Dec 10, 2015, at 1:40 PM, Steve Donovan <[email-masked]><mailto:[email-masked]> wrote:

Thanks,

Steve

All,

Regards,

Steve

Modern mailing list

[email-masked]<mailto:[email-masked]>

Modern mailing list

[email-masked]<mailto:[email-masked]>

Modern mailing list

[email-masked]<mailto:[email-masked]>

________________________________

This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Mon, 14 Dec 2015 17:51:30 +0000

I agree with Pierce

From: Modern [mailto:[email-masked]] On Behalf Of Gorman, Pierce A [CTO]
Sent: Monday, December 14, 2015 10:52 AM
To: Steve Donovan <[email-masked]>; [email-masked]
Subject: Re: [Modern] Problem statement draft as working group document

Pierce Gorman

From: Modern [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: December 14, 2015 8:45 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Modern] Problem statement draft as working group document

Eric,

Steve

Nah. :-)

Thanks,

Steve

All,

Regards,

Steve

Modern mailing list

Modern mailing list

Modern mailing list

---

From: "PFAUTZ, PENN L" <[email-masked]>
Date: Mon, 14 Dec 2015 17:57:42 +0000

I find that I need to object as well. It is not numbering that drives interconnection so much as interconnection drives numbering. As the evolution of interconnection even as the PSTN migrates to an IP backbone is by no means settled I'm concerned that we are getting the cart before the horse. I also object to the conclusory statements about user and service provider roles; I think the picture is more complicated.
I remain sympathetic to the goal of modernizing number administration and routing but the document is problematic for me.

Penn Pfautz
AT&T Global Connection Management

From: Gorman, Pierce A [CTO] [mailto:[email-masked]]
Sent: Monday, December 14, 2015 10:52 AM
To: Steve Donovan; [email-masked]
Subject: Re: [Modern] Problem statement draft as working group document

Pierce Gorman

Eric,

Steve

Nah. :-)

Thanks,

Steve

All,

Regards,

Steve

Modern mailing list

Modern mailing list

Modern mailing list

---

From: Richard Shockey <[email-masked]>
Date: Mon, 14 Dec 2015 13:05:02 -0500

>snarkiness.  

RS>  You can certainly hope.

>I interpret your response and Eric's response as an 

RS>  You have correctly interpreted my position. And BTW I’m in total agreement with the sentiments of both Martin Dolly and Pierce Gorman. Our issue was the charter itself which in due course has lead to a over reaching problem and I do not support either.  

>step is to verify that consensus on the list.  That is what we are in 

RS> Agreed. I’m not concerned about what happened in Yokohama.  It is irrelevant to what this discussion is about.

---

From: "McGarry, Tom" <[email-masked]>
Date: Mon, 14 Dec 2015 18:31:01 +0000

Thanks Penn.

I don't understand your point about numbering vs interconnection.  Is there something in the document you can point to?

Also can you point me to the statements about user and SP roles?

From: <PFAUTZ>, PENN L <[email-masked]<mailto:[email-masked]>>
Date: Monday, December 14, 2015 12:57 PM
To: Pierce Gorman <[email-masked]<mailto:[email-masked]>>, Steve Donovan <[email-masked]<mailto:[email-masked]>>, Modern List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Modern] Problem statement draft as working group document

I find that I need to object as well. It is not numbering that drives interconnection so much as interconnection drives numbering. As the evolution of interconnection even as the PSTN migrates to an IP backbone is by no means settled I’m concerned that we are getting the cart before the horse. I also object to the conclusory statements about user and service provider roles; I think the picture is more complicated.
I remain sympathetic to the goal of modernizing number administration and routing but the document is problematic for me.

Penn Pfautz

From: Gorman, Pierce A [CTO] [mailto:[email-masked]]
Sent: Monday, December 14, 2015 10:52 AM
To: Steve Donovan; [email-masked]<mailto:[email-masked]>
Subject: Re: [Modern] Problem statement draft as working group document

If an actual reason is not required I would like to add my vote of dissension on principal without having to actually read the “draft-peterson-modern-problems-02”.  You might recall I argued with the language in the charter but I and others were over-ruled by the Area Directors.

Pierce Gorman

Eric,

Steve

Nah. :-)

Thanks,

Steve

All,

Regards,

Steve

Modern mailing list

https://www.ietf.org/mailman/listinfo/modern<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_modern&d=CwMFAg&c=MOptNlVtIETeDALC_lULrw&r=4Klm32iB7HufveeIDcLextZ1ooNcfp01IYIaVqsORjI&m=VoOj5l8qS_slWFPQFyFGHcwCy5IpNAua33eYtYDOYgw&s=L7HtO_ci3KGlrlZPQbTUPkKpDn5fARTZE7PYD-WeWPM&e=>

Modern mailing list

https://www.ietf.org/mailman/listinfo/modern<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_modern&d=CwMFAg&c=MOptNlVtIETeDALC_lULrw&r=4Klm32iB7HufveeIDcLextZ1ooNcfp01IYIaVqsORjI&m=VoOj5l8qS_slWFPQFyFGHcwCy5IpNAua33eYtYDOYgw&s=L7HtO_ci3KGlrlZPQbTUPkKpDn5fARTZE7PYD-WeWPM&e=>

Modern mailing list

https://www.ietf.org/mailman/listinfo/modern<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_modern&d=CwMFAg&c=MOptNlVtIETeDALC_lULrw&r=4Klm32iB7HufveeIDcLextZ1ooNcfp01IYIaVqsORjI&m=VoOj5l8qS_slWFPQFyFGHcwCy5IpNAua33eYtYDOYgw&s=L7HtO_ci3KGlrlZPQbTUPkKpDn5fARTZE7PYD-WeWPM&e=>

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Mon, 14 Dec 2015 18:44:31 +0000

Number assignment to users has been an is from day 1.
If there was no Interconnection, none of this would be relevant

Martin C Dolly
Lead Member of Technical Staff
Core & Government/Regulatory Standards
AT&T
Cell: 609-903-3360
Email: [email-masked]<mailto:[email-masked]>

On Dec 14, 2015, at 1:31 PM, McGarry, Tom <[email-masked]<mailto:[email-masked]>> wrote:

Thanks Penn.

Penn Pfautz

Pierce Gorman

Eric,

Steve

Nah. :-)

Thanks,

Steve

All,

Regards,

Steve

Modern mailing list

Modern mailing list

Modern mailing list

---

From: "McGarry, Tom" <[email-masked]>
Date: Mon, 14 Dec 2015 18:49:31 +0000

Ok, I'm aware that some people do not like the concept of number assignment to users.

But there is interconnection, does that mean this is relevant?

From: <DOLLY>, Martin Dolly <[email-masked]<mailto:[email-masked]>>
Date: Monday, December 14, 2015 1:44 PM
To: Tom Mcgarry <[email-masked]<mailto:[email-masked]>>
Cc: "PFAUTZ, PENN L" <[email-masked]<mailto:[email-masked]>>, Modern List <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Modern] Problem statement draft as working group document

Martin C Dolly

Thanks Penn.

Penn Pfautz

Pierce Gorman

Eric,

Steve

Nah. :-)

Thanks,

Steve

All,

Regards,

Steve

Modern mailing list

Modern mailing list

Modern mailing list

This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.
_______________________________________________
Modern mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/modern<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_modern&d=CwMF-g&c=MOptNlVtIETeDALC_lULrw&r=4Klm32iB7HufveeIDcLextZ1ooNcfp01IYIaVqsORjI&m=eRmkVzuj48-fMcpNigepuQXuCTlLU0hbSvzfkIqVJX0&s=aF3mX9wEsw6sKhTbhme4nM4MtaD-NMoVy0wcjZ3m2DI&e=>

---

From: Richard Shockey <[email-masked]>
Date: Mon, 14 Dec 2015 13:32:00 -0500

From:  Modern <[email-masked]> on behalf of "PFAUTZ, PENN L" <[email-masked]>
Date:  Monday, December 14, 2015 at 12:57 PM
To:  "[email-masked]" <[email-masked]>, Steve Donovan <[email-masked]>, "[email-masked]" <[email-masked]>
Subject:  Re: [Modern] Problem statement draft as working group document

RS> +1  Very well said

Penn Pfautz

 

Pierce Gorman

Eric,

Thanks,

Steve

 

 
Thanks,
 
Steve

 

Regards,
 
Steve

 

This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.
_______________________________________________ Modern mailing list [email-masked] https://www.ietf.org/mailman/listinfo/modern

---

From: Adam Roach <[email-masked]>
Date: Mon, 14 Dec 2015 12:52:53 -0600

On 12/10/15 12:40, Steve Donovan wrote:
> Please express your opinion on making 
> draft-peterson-modern-problems-02 a working group document before 
> Thursday, December 17th.
>

I think this document is a good starting point for outlining the basic 
shape of the problem and the use cases MODERN is intended to address.

I'll note that on-list objections so far seem to be attempting to 
re-litigate the formation of the working group rather than making 
progress towards its milestones. As has been long established (at least 
since the 2002 formation of XMPP), the decision to work on a problem in 
the IETF is based on the following criteria: "is it technically 
credible, are people willing to work on it, are people willing to use 
it?" And, in particular: "we should be deciding things based on the 
number of folks who want to do things, not the number opposed."

In terms of considering adoption of this specific document, I think we 
need to be careful to parse out objections to its contents versus 
objections to MODERN's very existence. So far, I have seen no on-list 
objections that fall in the first category.

/a

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Mon, 14 Dec 2015 18:59:59 +0000

It would be nice to hear a regulator point of view.
The FCC assigns numbers to entities (eg. SP) that they can regulate and if there is misbehavior punish. This point has been made over and over again

Martin C Dolly

On Dec 14, 2015, at 1:49 PM, McGarry, Tom <[email-masked]<mailto:[email-masked]>> wrote:

Martin C Dolly

Thanks Penn.

Penn Pfautz

Pierce Gorman

Eric,

Steve

Nah. :-)

Thanks,

Steve

All,

Regards,

Steve

Modern mailing list

Modern mailing list

Modern mailing list

---

From: "Richard Hill" <[email-masked]>
Date: Mon, 14 Dec 2015 20:16:05 +0100

Please see below.

Thanks and best,
Richard

> -----Original Message-----
> From: Modern [mailto:[email-masked]] On Behalf Of Adam Roach
> Sent: Monday, December 14, 2015 19:53

SNIP

> shape of the problem and the use cases MODERN is intended to address.

Yes, but it seems to me to be placing the cart before the horse. The draft
is outlining technical solutions for things that aren't, as far as I know,
yet possible from a regulatory point of view.

That was to some extent also an issue with ENUM.

Wouldn't it be better to develop first the new desired regulatory framework,
and then to work out the technical solutions to implement number assignment,
etc., under the new regulatory framework?

> 
> I'll note that on-list objections so far seem to be attempting to re-
> litigate the formation of the working group rather than making progress
> towards its milestones. As has been long established (at least since
> the 2002 formation of XMPP), the decision to work on a problem in the
> IETF is based on the following criteria: "is it technically credible,
> are people willing to work on it, are people willing to use it?" 

Yes, and some of the objections do relate to credibility and to whether the
solution would be used in practice.

SNIP

---

From: "PFAUTZ, PENN L" <[email-masked]>
Date: Mon, 14 Dec 2015 19:26:33 +0000

All,
It's statements like 
" Ideally the user would have full control of their TN and
   would drive the porting process on their own rather than rely on
   complex and time consuming back office processes among multiple
   service providers."

that make a policy statement which concern me. 

As to Tom's question, it was the statement
" Most TNs today are assigned to specific geographies, at both an
   international level and within national numbering plans.  This has
   shaped the way that service providers interconnect"

I think it was the reverse - numbering followed interconnection - and the mechanisms I need for numbering will depend on the types of interconnection I have to support.

So, yes I do object to specifics in the document as opposed to the enterprise as a whole.  

Penn Pfautz

-----Original Message-----
From: Adam Roach [mailto:[email-masked]] 
Sent: Monday, December 14, 2015 1:53 PM
To: Steve Donovan; [email-masked]
Subject: Re: [Modern] Problem statement draft as working group document

/a

---

From: Adam Roach <[email-masked]>
Date: Mon, 14 Dec 2015 13:36:20 -0600

> yet possible from a regulatory point of view.

Where you see a cart and a horse, I see a chicken and an egg. Someone 
has to go first. If taken in the opposite order, your objection could 
easily be reversed to read "the proposed regulations are outlining 
requirements for solutions that aren't, as far as I know, yet 
technically possible."

In any case, what we say on the topic in *this* forum is largely 
academic, since it's not the WG participants or even the chairs that 
decide to start and end WGs. If you'd like to debate the existence of 
MODERN -- which seems to be your implied intent -- that's a broader 
conversation that you need to take up with the ADs and the IESG. I'll 
note that the question of existence has already been asked and answered 
based on earlier discussions, so you'll need to show up with previously 
unmade arguments.

But that conversation doesn't have bearing on whether this document is a 
good match for the WG charter.

/a

---

From: Richard Shockey <[email-masked]>
Date: Mon, 14 Dec 2015 14:16:42 -0500

Well I’m not a regulator nor do I play on on television, but I am a member of the North American Numbering Council [NANC] which is the Federal Advisory Committee to the US FCC on numbering issues.

https://www.fcc.gov/about-fcc/advisory-committees/north-american-numbering-council/general/nanc-membership

I’m not aware that issuing numbering resources directly to consumers or enterprises is on the agenda.

From:  Modern <[email-masked]> on behalf of "DOLLY, MARTIN C" <[email-masked]>
Date:  Monday, December 14, 2015 at 1:59 PM
To:  "McGarry, Tom" <[email-masked]>
Cc:  "[email-masked]" <[email-masked]>
Subject:  Re: [Modern] Problem statement draft as working group document

Martin C Dolly 
Email: [email-masked]

On Dec 14, 2015, at 1:49 PM, McGarry, Tom <[email-masked]> wrote:

From: <DOLLY>, Martin Dolly <[email-masked]>
Date: Monday, December 14, 2015 1:44 PM
To: Tom Mcgarry <[email-masked]>
Cc: "PFAUTZ, PENN L" <[email-masked]>, Modern List <[email-masked]>
Subject: Re: [Modern] Problem statement draft as working group document

Martin C Dolly 
Email: [email-masked]

On Dec 14, 2015, at 1:31 PM, McGarry, Tom <[email-masked]> wrote:

Thanks Penn.  

From: <PFAUTZ>, PENN L <[email-masked]>
Date: Monday, December 14, 2015 12:57 PM
To: Pierce Gorman <[email-masked]>, Steve Donovan <[email-masked]>, Modern List <[email-masked]>
Subject: Re: [Modern] Problem statement draft as working group document

Penn Pfautz

 

Pierce Gorman

Eric,

Thanks,

Steve

 

 
Thanks,
 
Steve

 

Regards,
 
Steve

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Mon, 14 Dec 2015 19:41:28 +0000

Not sure where I'm allowed to start listing objections and which would be considered substantive and which would be considered irrelevant nits, but I'll offer a few now and add as time and interest permits.

In Section 1 Problem Statement I object to the assertion, "The original ENUM concept of a single root, e164.arpa, proved to be politically challenging, and less centralized models have thus flourished."  The fundamental problem was not that ENUM was "politically challenging".  ENUM was also practically challenging, on multiple levels.

First and foremost, ENUM in e164.arpa had no concept that route selection could not simply be made based on where a terminating number was being served from.  Route selection had to almost always also be based on the type of number that was being called and where a call was originating from.  The original DNS-only ENUM approach failed to accomodate those requirements.

The less-centralized models didn't flourish because of a lack of political challenges.  They flourished because proprietary non-DNS database implementations which used the DNS resource record query/response protocols overcame fundamental limitations of a strictly e164.arpa implementation.

Another assertion I find objectionable is, "Telephone numbering, however, has long been transitioning away from a provider-centric model towards a user-centric model."  The example of number portability overlooks the fact that the ported number is assigned a pointer back into a provider-centric model of routing information domestically known as the LERG.

It goes on to say, "Thanks to the increasing sophistication of consumer mobile devices, users now associate TNs with many applications other than telephony." So the assertion is made that (mobile) users (of smart phones) can easily associate services with their telephone numbers.  No argument.  How is this a problem?

Next the argument is made that, "Ideally the user would have full control of their TN and would drive the porting process on their own rather than rely on complex and time consuming back office processes among multiple service providers."  This is interesting.  Who has control over a TN being ported if not the end user?

Is the thought that the user no longer would require the services of a service provider?

Or is it that service providers will constantly troll the MODERN database looking for users who've selected them to be their service provider?

How would the losing SP (if there is one), learn they've been de-selected?

How does the commercial relationship between the new SP and the user get established?  Careful, it might look like an awful lot like a "complex and time consuming back office" process.

Will this new method of self-registration and de-registration, and commercial relationship establishment somehow gain material benefit over the existing "complex and time consuming back office processes among multiple service providers"?

What was the problem or problems that were solved?  Do users really care about the complexity of a change between service provider back-office systems? How could they?  They have no visibility to it other than the caveat that it might take a few hours before the port was complete.  What is the average time for port completion?  Is there really a problem here to solve?  What will that port time look like after the conversion from the current NP provider (domestically) and the new NP provider?  Is porting a problem internationally?  Is MODERN going to fix international  porting problems?

And, I can't let it go unsaid that the claim end users are harmed by "complex and time consuming back office processes among multiple service providers" ignores the fact that the service providers are forced to rely on systems developed and managed through a regulated back-office provider which frankly seems somewhat disingenuous given who is advancing the arguments.

Pierce Gorman
From: Modern [mailto:[email-masked]] On Behalf Of DOLLY, MARTIN C
Sent: December 14, 2015 12:45 PM
To: McGarry, Tom <[email-masked]>
Cc: [email-masked]; PFAUTZ, PENN L <[email-masked]>
Subject: Re: [Modern] Problem statement draft as working group document

Martin C Dolly

Penn Pfautz

Pierce Gorman

Eric,

Steve

Nah. :-)

Thanks,

Steve

All,

Regards,

Steve

Modern mailing list

Modern mailing list

Modern mailing list

---

From: "McGarry, Tom" <[email-masked]>
Date: Mon, 14 Dec 2015 19:54:11 +0000

WRT porting process:
This doesn't address policy.  There is no way for a user to prove to a
service provider that they do indeed have authority over the number.  It
suggests that there be a technical solution, a verifiable credential, that
a user can submit to a service provider to prove they have authority.
They have authority today, there's just no way to prove it.

WRT interconnection:
The point of that paragraph is that current numbering is highly dependent
on geography, whereas in an IP environment it would be independent of
geography.  In an IP environment it should be different.  How about
replacing the second sentence with:
"Numbering, interconnection and routing are highly dependent on geography:
the PSTN was carefully designed to delegate switching intelligence
geographically."   

On 12/14/15 2:26 PM, "PFAUTZ, PENN L" <[email-masked]> wrote:

>I think it was the reverse - numbering followed interconnection - and the
>mechanisms I need for numbering will depend on the types of
>interconnection I have to support.
>
>https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_
>listinfo_modern&d=CwICAg&c=MOptNlVtIETeDALC_lULrw&r=4Klm32iB7HufveeIDcLext
>Z1ooNcfp01IYIaVqsORjI&m=b8Du8PEdrEZo_LLqNvw5JrZtUM64muibjcmAAkrALxM&s=EJyT
>AVbeKglij7G7DiYeWWywwrHAbKhJQYMH8snPpFg&e=

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Mon, 14 Dec 2015 19:58:36 +0000

Replace "Numbering, interconnection and routing are highly dependent on geography: the PSTN was carefully designed to delegate switching intelligence geographically."

With " Numbering, interconnection and routing are CURRENTLY highly dependent on geography:  the PSTN NUMBERING AUTHORITY was carefully designed to delegate NUMBERING AUTHORITY geographically.

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of McGarry, Tom
Sent: December 14, 2015 1:54 PM
To: PFAUTZ, PENN L <[email-masked]>; [email-masked]
Subject: Re: [Modern] Problem statement draft as working group document

WRT porting process:
This doesn't address policy.  There is no way for a user to prove to a service provider that they do indeed have authority over the number.  It suggests that there be a technical solution, a verifiable credential, that a user can submit to a service provider to prove they have authority.
They have authority today, there's just no way to prove it.

WRT interconnection:
The point of that paragraph is that current numbering is highly dependent on geography, whereas in an IP environment it would be independent of geography.  In an IP environment it should be different.  How about replacing the second sentence with:
"Numbering, interconnection and routing are highly dependent on geography:
the PSTN was carefully designed to delegate switching intelligence
geographically."

On 12/14/15 2:26 PM, "PFAUTZ, PENN L" <[email-masked]> wrote:

>As to Tom's question, it was the statement " Most TNs today are
>assigned to specific geographies, at both an
>I think it was the reverse - numbering followed interconnection - and
>the mechanisms I need for numbering will depend on the types of
>Z1ooNcfp01IYIaVqsORjI&m=b8Du8PEdrEZo_LLqNvw5JrZtUM64muibjcmAAkrALxM&s=E
>JyT AVbeKglij7G7DiYeWWywwrHAbKhJQYMH8snPpFg&e=

---

From: "McGarry, Tom" <[email-masked]>
Date: Mon, 14 Dec 2015 20:08:42 +0000

See comments inline.

From: <Gorman>, Pierce Gorman <[email-masked]<mailto:[email-masked]>>
Date: Monday, December 14, 2015 2:41 PM
To: Martin Dolly <[email-masked]<mailto:[email-masked]>>, Tom Mcgarry <[email-masked]<mailto:[email-masked]>>
Cc: Modern List <[email-masked]<mailto:[email-masked]>>, "PFAUTZ, PENN L" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Modern] Problem statement draft as working group document

Not sure where I’m allowed to start listing objections and which would be considered substantive and which would be considered irrelevant nits, but I’ll offer a few now and add as time and interest permits.

In Section 1 Problem Statement I object to the assertion, “The original ENUM concept of a single root, e164.arpa, proved to be politically challenging, and less centralized models have thus flourished.”  The fundamental problem was not that ENUM was “politically challenging“.  ENUM was also practically challenging, on multiple levels.

TOM: How about "politically and practically challenging"

The less-centralized models didn’t flourish because of a lack of political challenges.  They flourished because proprietary non-DNS database implementations which used the DNS resource record query/response protocols overcame fundamental limitations of a strictly e164.arpa implementation.

Another assertion I find objectionable is, “Telephone numbering, however, has long been transitioning away from a provider-centric model towards a user-centric model.”  The example of number portability overlooks the fact that the ported number is assigned a pointer back into a provider-centric model of routing information domestically known as the LERG.

It goes on to say, “Thanks to the increasing sophistication of consumer mobile devices, users now associate TNs with many applications other than telephony.” So the assertion is made that (mobile) users (of smart phones) can easily associate services with their telephone numbers.  No argument.  How is this a problem?

TOM:  No problem.

Next the argument is made that, “Ideally the user would have full control of their TN and would drive the porting process on their own rather than rely on complex and time consuming back office processes among multiple service providers.“  This is interesting.  Who has control over a TN being ported if not the end user?

TOM:  See my response to Penn's email.

Or is it that service providers will constantly troll the MODERN database looking for users who’ve selected them to be their service provider?

How would the losing SP (if there is one), learn they’ve been de-selected?

How does the commercial relationship between the new SP and the user get established?  Careful, it might look like an awful lot like a “complex and time consuming back office” process.

Will this new method of self-registration and de-registration, and commercial relationship establishment somehow gain material benefit over the existing “complex and time consuming back office processes among multiple service providers“?

And, I can’t let it go unsaid that the claim end users are harmed by “complex and time consuming back office processes among multiple service providers” ignores the fact that the service providers are forced to rely on systems developed and managed through a regulated back-office provider which frankly seems somewhat disingenuous given who is advancing the arguments.

Pierce Gorman
From: Modern [mailto:[email-masked]] On Behalf Of DOLLY, MARTIN C
Sent: December 14, 2015 12:45 PM
To: McGarry, Tom <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; PFAUTZ, PENN L <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Modern] Problem statement draft as working group document

Martin C Dolly

Penn Pfautz

Pierce Gorman

Eric,

Steve

Nah. :-)

Thanks,

Steve

All,

Regards,

Steve

Modern mailing list

Modern mailing list

Modern mailing list

This e-mail may contain Sprint proprietary information intended for the sole use of the recipient(s). Any use by others is prohibited. If you are not the intended recipient, please contact the sender and delete all copies of the message.
_______________________________________________
Modern mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/modern<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_modern&d=CwMFAg&c=MOptNlVtIETeDALC_lULrw&r=4Klm32iB7HufveeIDcLextZ1ooNcfp01IYIaVqsORjI&m=qP4OPHl6lv_-KtpKRGiQCu0XZndx-6pvgYm2MGNqUds&s=fIzceIoXpbGvd5SuSstqymGsL3qvTT4PbZ7CKUAU43c&e=>

---

From: "McGarry, Tom" <[email-masked]>
Date: Mon, 14 Dec 2015 20:10:09 +0000

You seem to be trying to make a different point - one about numbering
authorities.  The original point is about network architecture.

On 12/14/15 2:58 PM, "Gorman, Pierce A [CTO]" <[email-masked]>
wrote:

>Replace "Numbering, interconnection and routing are highly dependent on
>geography: the PSTN was carefully designed to delegate switching
>intelligence geographically."
>
>With " Numbering, interconnection and routing are CURRENTLY highly
>dependent on geography:  the PSTN NUMBERING AUTHORITY was carefully
>designed to delegate NUMBERING AUTHORITY geographically.
>
>
>suggests that there be a technical solution, a verifiable credential,
>that a user can submit to a service provider to prove they have authority.
>listinfo_modern&d=CwIFAg&c=MOptNlVtIETeDALC_lULrw&r=4Klm32iB7HufveeIDcLext
>Z1ooNcfp01IYIaVqsORjI&m=wX7NaCp4TR1we4d444AWJk4h5Znti2aqix5Cr5-fxCY&s=ol3y
>MdIchtzVnkdtU27FYlKIZ0SFMiXd-GbOP0BEn08&e=
>
>This e-mail may contain Sprint proprietary information intended for the
>sole use of the recipient(s). Any use by others is prohibited. If you are
>not the intended recipient, please contact the sender and delete all
>copies of the message.

---

From: "Dwight, Timothy M (Tim)" <[email-masked]>
Date: Mon, 14 Dec 2015 15:46:15 -0500

Tom,

What I think you're saying is that the function of a telephone number in an "all IP world" is expected to be different than in the PSTN.  

Telephone numbers are used for routing in the PSTN, which is the fundamental reason their assignment generally reflects the topology of the network.   The PSTN routes on number prefixes, as does the Internet.  There are differences in the details, but the fundamental need for address summarization is common.  This results in address assignments that reflect network topology.

I *think* the reason for the assumption that telephone number assignment in an all-IP world need not reflect geography is that it's assumed that telephone numbers in that environment are no longer treated as addresses.   Instead they are generally expected to be identifiers, mapped to network addresses through some sort of translation process.  Right?

If so I would buy that the rationale for embedding geography into telephone numbers, in an "all IP world", is different than it has been in the PSTN.  I don't think it's gone though.  As a simple example, we will probably need to maintain the notion of a "country code", because telephone numbers are national resources and subject to national laws and regulation.  It might also be that within a country, number assignment is performed by agencies responsible for certain geographic areas.  It seems technically possible that they all share a single pool of numbers, but some countries might elect not to.  They might prefer instead to partition the address space.  Such partitioning would be reflected in the addresses they assign.   So I think it's plausible we could see some amount of geography reflected in the telephone number, just due to the way they're assigned.  That's how I interpreted Pierce's comments earlier.

Cheers,

tim

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of McGarry, Tom
Sent: Monday, December 14, 2015 2:10 PM
To: Gorman, Pierce A [CTO]; [email-masked]
Subject: [E] Re: [Modern] Problem statement draft as working group document

You seem to be trying to make a different point - one about numbering authorities.  The original point is about network architecture.

On 12/14/15 2:58 PM, "Gorman, Pierce A [CTO]" <[email-masked]>
wrote:

>service provider that they do indeed have authority over the number.  
>It suggests that there be a technical solution, a verifiable 
>credential, that a user can submit to a service provider to prove they have authority.
>The point of that paragraph is that current numbering is highly 
>dependent on geography, whereas in an IP environment it would be 
>independent of geography.  In an IP environment it should be different.  
>How about replacing the second sentence with:
>>progress towards its milestones. As has been long established (at 
>>least since the 2002 formation of XMPP), the decision to work on a 
>>problem in the IETF is based on the following criteria: "is it 
>>technically credible, are people willing to work on it, are people 
>>willing to use it?" And, in particular: "we should be deciding things 
>>based on the number of folks who want to do things, not the number opposed."
>>
>>https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mail
>>m
>>an_
>>listinfo_modern&d=CwICAg&c=MOptNlVtIETeDALC_lULrw&r=4Klm32iB7HufveeIDc
>>L
>>ext
>>Z1ooNcfp01IYIaVqsORjI&m=b8Du8PEdrEZo_LLqNvw5JrZtUM64muibjcmAAkrALxM&s=
>>E JyT AVbeKglij7G7DiYeWWywwrHAbKhJQYMH8snPpFg&e=
>
>Z1ooNcfp01IYIaVqsORjI&m=wX7NaCp4TR1we4d444AWJk4h5Znti2aqix5Cr5-fxCY&s=o
>l3y MdIchtzVnkdtU27FYlKIZ0SFMiXd-GbOP0BEn08&e=
>
>sole use of the recipient(s). Any use by others is prohibited. If you 
>are not the intended recipient, please contact the sender and delete 
>all copies of the message.

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Mon, 14 Dec 2015 21:17:29 +0000

My point was numbering was delegated by the FCC to the states which are necessarily constrained by geography and therefore so was number assignment and therefore so was network architecture which routed based on the numbering.  (There are also services such as OS/DA and n11 which are geographically constrained by regulation and/or by needs.)

How to migrate (wrest?) authority for numbering from the states and place it in a MODERN "solution" is an actual set of problems that could be documented for MODERN to solve that I wouldn't argue with.  Since the PSTN will not evaporate, MODERN can only be successful as an evolution, not a green field approach which supplants the existing numbering and routing processes and infrastructure.

In North America real problems (requirements really) related to geographic number administration in the state PUCs that MODERN must address are area code relief, reclamation, and rate center consolidation approvals.

Pierce Gorman

---

From: Richard Shockey <[email-masked]>
Date: Mon, 14 Dec 2015 18:50:45 -0500

>In North America real problems (requirements really) related to geographic number administration in the state PUCs that MODERN must address are area code relief, reclamation, and rate center consoli…

RS> Which is the argument that the issues some want to address in the Problem Statement here are not global but North American specific and properly should be addressed in North American SDO’s that deal with these things.  

Penn was right.  Sure there is an argument that we need a new way of looking at issues involving number allocation but frankly there is no stomach in the North American industry for tackling those issues now or anytime in the intermediate future.  None of you can possibly imagine the cost involved in dealing with telephone number administration.  

Of all the things carriers have to deal with this is about number 164.  We need a better solution for interconnection data but again that problem set for the time being is centered on North America.  Why does anyone want to try to work on problems that have no possible chance of deployment in the reasonable future.  This is not STIR.  The consensus on STIR is in fact global and it it clear the progress of the work can have a real and demonstrable impact.

---

From: Richard Shockey <[email-masked]>
Date: Mon, 14 Dec 2015 19:02:27 -0500

On 12/14/15, 2:36 PM, "Modern on behalf of Adam Roach" <[email-masked] on behalf of [email-masked]> wrote:

>conversation that you need to take up with the ADs and the IESG.

RS> Adam our objections were NOT considered during the charter phase here.  This was the worst chartering process I’ve ever witnessed in the IETF. And I personally blame the IESG here for ignoring our concerns. And the sponsoring AD in particular..the record on that is clear. 

> I'll 

RS> The conversation is this a proper WG item .. We say NO.

---

From: Richard Shockey <[email-masked]>
Date: Mon, 14 Dec 2015 19:12:23 -0500

WELL Pierce for the time being North American Numbering is actually dependent on geography.  However having sat through X hours or more of the last NANC meeting,  a workshop for NARUC in Austin and having read the letters from Congress, the industry and the Wireline Competition bureau.  The day may actually come that we can actually have National Geographic Number Portability NG/NP and national 10 digit dialing .. Of course I will probably be dead before its fully implemented but that is a side issue. 

Again a North Americian specific issue.

---

From: "Richard Hill" <[email-masked]>
Date: Tue, 15 Dec 2015 07:31:37 +0100

Please see embedded comments below.

Thanks and best,
Richard

> From: Modern [mailto:[email-masked]] On Behalf Of Dwight,
> Timothy M (Tim)
> Sent: Monday, December 14, 2015 21:46
> To: McGarry, Tom; Gorman, Pierce A [CTO]; [email-masked]
> What I think you're saying is that the function of a telephone number
> in an "all IP world" is expected to be different than in the PSTN.
> 
> Telephone numbers are used for routing in the PSTN,

That was true back in the old days of rotary dialing, but it is to a large
extent no longer the case at the national level with SS7. Many countries
have full fixed number portability, so the E.164 number no longer has any
geographical significance.

> which is the
> fundamental reason their assignment generally reflects the topology of
> the network.   The PSTN routes on number prefixes, as does the
> Internet.  There are differences in the details, but the fundamental
> need for address summarization is common.  This results in address
> assignments that reflect network topology.

Actually in today's telephone network, the E.164 number is a name, analogous
to Internet domain names.  The telephony equivalent of an IP address is the
IMSI (E.212) for mobile and ISPC/SANC (Q.709) for fixed.

The situation that you describe may be valid for some countries, but not
others.

> 
> I *think* the reason for the assumption that telephone number
> assignment in an all-IP world need not reflect geography is that it's
> assumed that telephone numbers in that environment are no longer
> treated as addresses.   Instead they are generally expected to be
> identifiers, mapped to network addresses through some sort of
> translation process.  Right?

Yes, see above. And it is not just in an all-IP environment. As I said
above, this has been the case for some years in some countries, even in a
non-all-IP-world.

SNIP

---

From: Adam Roach <[email-masked]>
Date: Tue, 15 Dec 2015 09:53:05 -0600

> RS> Adam our objections were NOT considered during the charter phase here.  This was the worst chartering process I’ve ever witnessed in the IETF. And I personally blame the IESG here for ignoring…

If you earnestly believe this, there is a process for dealing with your 
concerns. Disrupting efforts to get work done on the working group 
mailing list is not part of that process. If you honestly don't know how 
to proceed, please contact me directly, and I'll give you pointers. I 
think you have my cell phone number -- feel free to use it.

> RS> The conversation is this a proper WG item .. We say NO.

The conversation on this list is: given the charter of MODERN, and given 
a milestone of "Submit Architecture Overview Draft to IESG," is this 
document a reasonable starting point?

If your answer is "no," *and* there is some document for which you would 
say "yes," then the useful thing to do here is outline what such a 
document would say.

If there is no document for which your answer is "yes," then your 
objection is to the givens, not the question. If that's the case, your 
objections amount to an attempt to disrupt the consensus process through 
a "denial-of-service"-style attack.

In the former case, I implore you to usefully describe what the document 
should say. In the latter, I request -- both as a personal favor and as 
a professional courtesy -- that you please work within accepted IETF 
process to have your grievance heard rather than disrupting the mailing 
list discussion.

/a

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Tue, 15 Dec 2015 17:05:27 +0000

Comments in-line.

Pierce

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of Richard Hill
Sent: December 15, 2015 12:32 AM
To: 'Dwight, Timothy M (Tim)' <[email-masked]>; 'McGarry, Tom' <[email-masked]>; Gorman, Pierce A [CTO] <[email-masked]>; [email-masked]
Subject: Re: [Modern] Problem statement draft as working group document

Thanks and best,
Richard

> Telephone numbers are used for routing in the PSTN,

That was true back in the old days of rotary dialing, but it is to a large extent no longer the case at the national level with SS7. Many countries have full fixed number portability, so the E.164 number no longer has any geographical significance.

PG-> SS7 is irrelevant to the number assignment question/issue.  I'll agree Non-geographic portability (NGP) will soon be required per regulation and supported.  NGP does not inherently remove the geographical-ness of previously assigned numbers, or their state PUC regulated assignment process (for the NANP at least).  i.e., all new numbers assigned would still have a geographic relationship by default per the existing regulatory and commercial processes.  Over time NGP will erode the strongly-typed relationship between assigned numbers and geography up to the point of balance between newly assigned numbers and the nomadic nature of the new number during their user's' lifetimes.  Regardless, what is it about NGP and eroding the relationship between numbers and their geography that is a problem for MODERN to address?

> assignments that reflect network topology.

Actually in today's telephone network, the E.164 number is a name, analogous to Internet domain names.  The telephony equivalent of an IP address is the IMSI (E.212) for mobile and ISPC/SANC (Q.709) for fixed.

PG-> I would use the example of portability as an example exactly opposite to your assertion that E.164 numbers are analagous to Internet domain names which are clearly not portable (as I was reminded by my ISP e-mail service recently).  In fact, if MODERN were to propose a mechanism to address the lack of domain name portability, I would be heartily in favor of that.  Perhaps we can force e-mail addresses to be reachable only via a resolution to phone numbers?

The situation that you describe may be valid for some countries, but not others.

> translation process.  Right?

Yes, see above. And it is not just in an all-IP environment. As I said above, this has been the case for some years in some countries, even in a non-all-IP-world.

SNIP

---

From: "McGarry, Tom" <[email-masked]>
Date: Tue, 15 Dec 2015 17:18:21 +0000

Yes, on IP networks TNs are identifiers and not addresses (as they are on
TDM networks). 

I also agree that there can still be a linkage between TNs and geography
in an all-IP environment.  The draft does not say that there will be no
linkage whatsoever.

On 12/14/15 3:46 PM, "Dwight, Timothy M (Tim)"
<[email-masked]> wrote:

>Tom,
>
>What I think you're saying is that the function of a telephone number in
>an "all IP world" is expected to be different than in the PSTN.
>
>Telephone numbers are used for routing in the PSTN, which is the
>the network.   The PSTN routes on number prefixes, as does the Internet.
>There are differences in the details, but the fundamental need for
>address summarization is common.  This results in address assignments
>that reflect network topology.
>
>I *think* the reason for the assumption that telephone number assignment
>in an all-IP world need not reflect geography is that it's assumed that
>telephone numbers in that environment are no longer treated as addresses.
>  Instead they are generally expected to be identifiers, mapped to
>network addresses through some sort of translation process.  Right?
>
>If so I would buy that the rationale for embedding geography into
>telephone numbers, in an "all IP world", is different than it has been in
>the PSTN.  I don't think it's gone though.  As a simple example, we will
>probably need to maintain the notion of a "country code", because
>telephone numbers are national resources and subject to national laws and
>regulation.  It might also be that within a country, number assignment is
>performed by agencies responsible for certain geographic areas.  It seems
>technically possible that they all share a single pool of numbers, but
>some countries might elect not to.  They might prefer instead to
>partition the address space.  Such partitioning would be reflected in the
>addresses they assign.   So I think it's plausible we could see some
>amount of geography reflected in the telephone number, just due to the
>way they're assigned.  That's how I interpreted Pierce's comments earlier.
>
>Cheers,
>
>tim
>
>Z1ooNcfp01IYIaVqsORjI&m=Rdx7-8i3VcWIAoyjuHY8EWVXuyy7X_qcJD7BhgwEVnc&s=MGrx
>_Tru6e5kJ2dcMHx09Rs9oXDUyD3XY9_sUuna0l4&e=

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Tue, 15 Dec 2015 17:39:37 +0000

Part of this problem is the use of this "TN" or its expansion to "telephone number", because it has no formal definition.

As an E.164 number, it identifies the subscriber, not the line termination of the subscriber, and not the routeing. Because telephone number has no definition, I do not think it is possible to be so emphatic. If one insists on using TN, then either someone has to invent a definition that says it identifies the subscriber, or always qualify the term with this information.

Regards

Keith

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of McGarry, Tom
Sent: 15 December 2015 17:18
To: Dwight, Timothy M (Tim); [email-masked]
Subject: Re: [Modern] Problem statement draft as working group document

Yes, on IP networks TNs are identifiers and not addresses (as they are on TDM networks). 

I also agree that there can still be a linkage between TNs and geography in an all-IP environment.  The draft does not say that there will be no linkage whatsoever.

On 12/14/15 3:46 PM, "Dwight, Timothy M (Tim)"
<[email-masked]> wrote:

>assumed that telephone numbers in that environment are no longer treated as addresses.
>telephone numbers, in an "all IP world", is different than it has been 
>in the PSTN.  I don't think it's gone though.  As a simple example, we 
>will probably need to maintain the notion of a "country code", because 
>telephone numbers are national resources and subject to national laws 
>and regulation.  It might also be that within a country, number 
>assignment is performed by agencies responsible for certain geographic 
>areas.  It seems technically possible that they all share a single pool 
>of numbers, but some countries might elect not to.  They might prefer 
>instead to partition the address space.  Such partitioning would be reflected in the
>>>I think this document is a good starting point for outlining the 
>>>basic shape of the problem and the use cases MODERN is intended to address.
>>>
>>>In terms of considering adoption of this specific document, I think 
>>>we need to be careful to parse out objections to its contents versus 
>>>Z1ooNcfp01IYIaVqsORjI&m=b8Du8PEdrEZo_LLqNvw5JrZtUM64muibjcmAAkrALxM&s
>>>= E JyT AVbeKglij7G7DiYeWWywwrHAbKhJQYMH8snPpFg&e=
>>
>>listinfo_modern&d=CwIFAg&c=MOptNlVtIETeDALC_lULrw&r=4Klm32iB7HufveeIDc
>>L
>>ext
>>Z1ooNcfp01IYIaVqsORjI&m=wX7NaCp4TR1we4d444AWJk4h5Znti2aqix5Cr5-fxCY&s=
>>o l3y MdIchtzVnkdtU27FYlKIZ0SFMiXd-GbOP0BEn08&e=
>>
>>This e-mail may contain Sprint proprietary information intended for 
>>the sole use of the recipient(s). Any use by others is prohibited. If 
>>you are not the intended recipient, please contact the sender and 
>>delete all copies of the message.
>
>Z1ooNcfp01IYIaVqsORjI&m=Rdx7-8i3VcWIAoyjuHY8EWVXuyy7X_qcJD7BhgwEVnc&s=M
>Grx _Tru6e5kJ2dcMHx09Rs9oXDUyD3XY9_sUuna0l4&e=

---

From: "Richard Hill" <[email-masked]>
Date: Tue, 15 Dec 2015 18:55:08 +0100

Please see below.

Thanks and best,
Richard

> Sent: mardi, 15. décembre 2015 18:18

As I already said in a previous E-Mail, E.164 numbers are names
(identifiers) in general, even on non-IP networks, provided that SS7 is
used, which is usually the case.

SNIP

---

From: "Richard Hill" <[email-masked]>
Date: Tue, 15 Dec 2015 19:04:01 +0100

Please see below.

Thanks and best,
Richard

> Sent: mardi, 15. décembre 2015 18:05
> To: Richard Hill; 'Dwight, Timothy M (Tim)'; 'McGarry, Tom';
> [email-masked]
> To: 'Dwight, Timothy M (Tim)' <[email-masked]>; 'McGarry,
> Tom' <[email-masked]>; Gorman, Pierce A [CTO]
> <[email-masked]>; [email-masked]
> That was true back in the old days of rotary dialing, but it is to a
> large extent no longer the case at the national level with SS7. Many
> countries have full fixed number portability, so the E.164 number no
> longer has any geographical significance.
> 
> PG-> SS7 is irrelevant to the number assignment question/issue. 

Let's agree to disagree on that.

> I'll
> agree Non-geographic portability (NGP) will soon be required per
> regulation and supported.  NGP does not inherently remove the
> geographical-ness of previously assigned numbers, or their state PUC
> regulated assignment process (for the NANP at least). 

I'm snipping what follows because it appears to me to focus on the NANP.  I
thought that the work of this group was supposed to apply to telephone
numbers in general, not just to the NANP. If it is meant to apply
specifically to the NANP, then perhaps that should be stated explicitly.

SNIP

> 
> Actually in today's telephone network, the E.164 number is a name,
> analogous to Internet domain names.  The telephony equivalent of an IP
> address is the IMSI (E.212) for mobile and ISPC/SANC (Q.709) for fixed.
> 
> PG-> I would use the example of portability as an example exactly
> opposite to your assertion that E.164 numbers are analagous to Internet
> domain names which are clearly not portable (as I was reminded by my
> ISP e-mail service recently).  

??? Is that some US specificity? I can move any of my ".ch" domain names to
any ISP at any time. And, for all I know, my ISP has moved them around its
servers, so that that IP addresses corresponding to my domain names have
changed over time.

Or are you referring to a domain name that you don't own, such as
"hotmail.com"?Obviously you cannot move that, but its owner can move it.

SNIP

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Tue, 15 Dec 2015 18:43:49 +0000

Rejoinders in-line.

-----Original Message-----
From: Richard Hill [mailto:[email-masked]]
Sent: December 15, 2015 12:04 PM
To: Gorman, Pierce A [CTO] <[email-masked]>; 'Dwight, Timothy M (Tim)' <[email-masked]>; 'McGarry, Tom' <[email-masked]>; [email-masked]
Subject: RE: [Modern] Problem statement draft as working group document

Please see below.

Thanks and best,
Richard

> > What I think you're saying is that the function of a telephone
> > number in an "all IP world" is expected to be different than in the PSTN.
> >

PG-> I'd prefer to see your argument as to why you feel it is relevant, but as you wish.

> regulated assignment process (for the NANP at least).

I'm snipping what follows because it appears to me to focus on the NANP.  I thought that the work of this group was supposed to apply to telephone numbers in general, not just to the NANP. If it is meant to apply specifically to the NANP, then perhaps that should be stated explicitly.

PG->  I would argue you shouldn't have SNIPped my question, "what is it about NGP [Non-Geographic Portability] and eroding the relationship between numbers and their geography that is a problem for MODERN to address?"

SNIP

> opposite to your assertion that E.164 numbers are analagous to
> Internet domain names which are clearly not portable (as I was
> reminded by my ISP e-mail service recently).

??? Is that some US specificity? I can move any of my ".ch" domain names to any ISP at any time. And, for all I know, my ISP has moved them around its servers, so that that IP addresses corresponding to my domain names have changed over time.

Or are you referring to a domain name that you don't own, such as "hotmail.com"?Obviously you cannot move that, but its owner can move it.

PG-> While it's true you can port the user portion (as long as there isn't a conflict) of the URI which comprises your e-mail address, the FQDN portion of your name is about as portable as the Empire State Building.  So, no, I would prefer telephone numbers remained more usefully differentiated in their portability as compared to e-mail addresses based on fully-qualified domain names.  If MODERN proposed to make domain name addresses of the Internet as portable as telephone numbers (even as portable as telephone numbers in the US without NGP), many millions of e-mail users would be grateful; me amongst them.  That IS a REAL problem that consumers could benefit from being solved.

SNIP

---

From: Eric Burger <[email-masked]>
Date: Tue, 15 Dec 2015 21:00:32 -0500

Simple. In over six months, there have been precisely zero substantive messages on the MODERN list, save your message last month asking if the silence means everyone thinks this is a good idea or if silence means no one cares.

I am glad to see my brief response just five days ago generated close to 10% of the total number of messages on the list since the list started, which was close to six months before the work group was chartered. I.e., including all of the charter discussion.

What response did my one word email elucidate? One person saying the document should be adopted, one work group chair valiantly trying to say the document should be adopted, and a ton of folks saying it should not be adopted.

We neither vote nor allow mob rule. However, given no one cared literally one peep for over six months and only one person thinks the document is ready to be a work group item, we are a long, long, long way from adopting the document.

You do have consensus, but it is not the consensus you are looking for.

> On Dec 14, 2015, at 9:44 AM, Steve Donovan <[email-masked]> wrote:
> 
> Eric,
> 
>>> On Dec 10, 2015, at 1:40 PM, Steve Donovan <[email-masked]> <mailto:[email-masked]> wrote:
>>> 
>>>> [email-masked] <mailto:[email-masked]>
>>>> https://www.ietf.org/mailman/listinfo/modern <https://www.ietf.org/mailman/listinfo/modern>
>>> [email-masked] <mailto:[email-masked]>
>>> https://www.ietf.org/mailman/listinfo/modern <https://www.ietf.org/mailman/listinfo/modern>
>> 
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/modern <https://www.ietf.org/mailman/listinfo/modern>
>

---

From: "Peterson, Jon" <[email-masked]>
Date: Wed, 16 Dec 2015 02:48:45 +0000

I'd write a long mail explaining why I think the work here is important and tractable, but then I'd lose my place in line for Star Wars. This isn't really the right time of year to scare up participant energy or consensus.

But seriously, I'm not going to argue the group isn't sleepy. Other than me, and Tom, and Chris, there hasn't been much editorial energy. And of course the people who think this group should not have been chartered in the first place will naturally fill that vacuum. We do need to find a way to breathe some life into this, maybe with an interim or something. Agreed that there's no consensus for this expressed here now. But at some point, we will need a path to make a decision about adoption.

Jon Peterson
Neustar, Inc.

From: Modern <[email-masked]<mailto:[email-masked]>> on behalf of Eric Burger <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, December 15, 2015 at 6:00 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Modern] Problem statement draft as working group document

On Dec 14, 2015, at 9:44 AM, Steve Donovan <[email-masked]<mailto:[email-masked]>> wrote:

Eric,

Steve

Nah. :-)

Thanks,

Steve

All,

Regards,

Steve

_______________________________________________
Modern mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/modern

_______________________________________________
Modern mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/modern

_______________________________________________
Modern mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/modern

---

From: Eric Burger <[email-masked]>
Date: Tue, 15 Dec 2015 21:58:44 -0500

Happy New Year to all!

> On Dec 15, 2015, at 9:48 PM, Peterson, Jon <[email-masked]> wrote:
> 
> 
> From: Modern <[email-masked] <mailto:[email-masked]>> on behalf of Eric Burger <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>> On Dec 14, 2015, at 9:44 AM, Steve Donovan <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Eric,
>> 
>>>>> [email-masked] <mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/modern <https://www.ietf.org/mailman/listinfo/modern>_______________________________________________
>>>> Modern mailing list
>>>> [email-masked] <mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/modern <https://www.ietf.org/mailman/listinfo/modern>
>>> 
>>> [email-masked] <mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/modern <https://www.ietf.org/mailman/listinfo/modern>

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 16 Dec 2015 16:27:41 -0500

Hi Richard,

> On Dec 14, 2015, at 7:02 PM, Richard Shockey <[email-masked]> wrote:
> 
> 
> 

I’m sorry that you feel that way. There was an extended amount of discussion about the charter with substantial revisions made in response to points raised by you and others. As per usual in the IETF, I think we landed in a place where no one got quite what they wanted.

This WG will be held to the same standard as all others. At chartering time, we had interest from multiple parties in seeing the chartered work through to completion, and we’ve seen some individual contributions in the meantime beyond the problem statement. But if motivation wanes and can’t be rekindled through efforts by the chairs and interested participants, we always have the option of closing the group. 

Folks who object to the problem statement because they do not believe there is a problem here the IETF can solve have been heard, I think. 

Alissa

---

From: Richard Shockey <[email-masked]>
Date: Wed, 16 Dec 2015 17:21:06 -0500

>I’m sorry that you feel that way. There was an extended amount of discussion about the charter with substantial revisions made in response to points raised by you and others. As per usual in the IET…

RS> Well we are going to have to disagree. This process has made a fair number of people  angry. The email record is quite clear that the legitimate concern of some of us about Charter/WG overreach was not considered or flatly ignored in the final decision to charter this work.  Its the worst chartering excersise I’ve experienced in a long time.  

>This WG will be held to the same standard as all others. At chartering time, we had interest from multiple parties in seeing the chartered work through to completion, and we’ve seen some individual…

RS> It serves no purpose to debate this further this year.  Peterson is right, for once, … we should not disturb the needs of the many to get their Star Wars tickets on time  

>Folks who object to the problem statement because they do not believe there is a problem here the IETF can solve have been heard, I think.

RS> I’m afraid, once again you really don’t understand,  

One, the charter is so overreaching as to be functionally useless. It violates every rational way the IETF works. Instead of choosing descrete definable problems and building on success it proports to nearly redefine the way the telecom industry works and redesign how its numbering and addressing works. 

Second, the concept of E.164 numbering administration is a sovereign responsibility of nation states as we have no requirements from NRA’s on what there requirements actually are, or if they really care.   And is not clear that that expertise is in the IETF.  Some of us have been to this Rodeo before and it did not necessarily turn out well.  Oh and the gratuitous ENUM bashing gets old after a while. 

Third.. The concept of highly distributed synchronized databases is in fact useful. White Spaces proved that but the operational experience in that application is still thin. I echo Penn Pfautz comments something like this could, maybe, possibly, be useful, but certainly not for the number allocation application the proposed problem statement. Right now that application is too set in concrete. I do not know one NA based service provider that is prepared to look at something new for this.   There ARE examples of de novo metadata for telephone numbers where this might be useful but a rational standardization strategy would not to define a protocol through the Open Standards process but engage in a Open Source project. Prove the solution via running code FIRST and then consider standardizing the solution set…

And some of us can’t afford to engage in the Internet Engineering Travel Club..tm  especially when the block is 300 rooms.

Same time next year.. Happy New Year  :-)  See you in Berlin… :-)

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Thu, 17 Dec 2015 17:03:29 +0000

I'm a newbie at IETF processes.  I've thought of RFCs as documents intended to solve new problems or older problems but in some better more useful way then was possible with existing standards.

Many RFCs have been issued which never enjoyed a real-live material implementation.  I've sometimes wondered if the authors and administrators had known in advance that their efforts would be fruitless (perhaps even mocked), would they have pursued the effort anyway?

I think I have my answer.

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of Richard Shockey
Sent: December 16, 2015 4:21 PM
To: Alissa Cooper <[email-masked]>
Cc: [email-masked]; Steve Donovan <[email-masked]>; Richard Hill <[email-masked]>; Adam Roach <[email-masked]>
Subject: Re: [Modern] Problem statement draft as working group document

>>>> Yes, but it seems to me to be placing the cart before the horse.
>>>> The draft is outlining technical solutions for things that aren't,
>>>> as far as I know, yet possible from a regulatory point of view.
>>>
>>> Where you see a cart and a horse, I see a chicken and an egg.
>>> Someone has to go first. If taken in the opposite order, your
>>> objection could easily be reversed to read "the proposed regulations
>>> are outlining requirements for solutions that aren't, as far as I
>>> know, yet technically possible."
>>>
>>> decide to start and end WGs. If you'd like to debate the existence
>>> of MODERN -- which seems to be your implied intent -- that's a
>>> broader conversation that you need to take up with the ADs and the IESG.
>>
>>

>This WG will be held to the same standard as all others. At chartering time, we had interest from multiple parties in seeing the chartered work through to completion, and we’ve seen some individual…

RS> It serves no purpose to debate this further this year.  Peterson is
RS> right, for once, … we should not disturb the needs of the many to
RS> get their Star Wars tickets on time

>
>
>Alissa
>
>>
>>
>>> I'll
>>> note that the question of existence has already been asked and
>>> answered based on earlier discussions, so you'll need to show up
>>> with previously unmade arguments.
>>>
>>> But that conversation doesn't have bearing on whether this document
>>> is a good match for the WG charter.
>>
>>

________________________________
Switch to Sprint and save 50% on Verizon, AT&T or T-Mobile rates. Your savings are guaranteed until 2018! Available on most plans. Limited time offer. Exclusions and restrictions apply. See sprint.com/save50<http://sprint.com/50off> for details.

---

From: Adam Roach <[email-masked]>
Date: Thu, 17 Dec 2015 11:14:48 -0600

> I think I have my answer.

If you don't think the work MODERN is doing will produce useful output, 
then I encourage you to find other ways to spend your time than trying 
to stop work. If your analysis is correct, the impact on you or anything 
you care about is approximately zero.

/a

---

From: Brian Rosen <[email-masked]>
Date: Thu, 17 Dec 2015 12:17:28 -0500

It happens.

It also happens that there is great skepticism that some new work will in fact actually be deployed, and yet it does get deployed, so I wouldn’t take your observation too far.

One of the great truisms of IETF, among other standards organizations is that it’s really hard to stop work where there is a sufficiently large group of people interested in pursuing, as long as it falls within the expertise of the organization.  That’s what is happening here.  It doesn’t matter that there is a large (even larger) group of people who want the work stopped.

There are enough of us who believe this work is important, will be implemented, and will likely supplant current ways of doing things.  You may not, that’s your privilege.  But we’re going to do the work.  It may be a waste of time.  We’re willing to take that chance.

Brian

> On Dec 17, 2015, at 12:03 PM, Gorman, Pierce A [CTO] <[email-masked]> wrote:
> 
> From: Modern [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Richard Shockey
> To: Alissa Cooper <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; Steve Donovan <[email-masked] <mailto:[email-masked]>>; Richard Hill <[email-masked] <mailto:[email-masked]>>; Adam Roach <[email-masked] <mailto:[email-masked]>>
> Switch to Sprint and save 50% on Verizon, AT&T or T-Mobile rates. Your savings are guaranteed until 2018! Available on most plans. Limited time offer. Exclusions and restrictions apply. See sprint.com/save50 <http://sprint.com/save50><http://sprint.com/50off <http://sprint.com/50off>> for details.
>

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Thu, 17 Dec 2015 17:26:05 +0000

Adam

There are practical aspects of Modern, but a lot of theory too.  Be honest. 

Martin C Dolly

> On Dec 17, 2015, at 12:15 PM, Adam Roach <[email-masked]> wrote:
> 
> If you don't think the work MODERN is doing will produce useful output, then I encourage you to find other ways to spend your time than trying to stop work. If your analysis is correct, the impact on you or anything you care about is approximately zero.
> 
> /a
>

---

From: Adam Roach <[email-masked]>
Date: Thu, 17 Dec 2015 12:02:11 -0600

On 12/16/15 16:21, Richard Shockey wrote:
> Well we are going to have to disagree. This process has made a fair number of people  angry. The email record is quite clear that the legitimate concern of some of us about Charter/WG overreach was not considered or flatly ignored in the final decision to charter this work.  Its the worst chartering excersise I’ve experienced in a long time.

If you believed these assertions in earnest, there was a well-known way 
to deal with it; see BCP 9, section 6.5 (and its subsections). I use the 
past tense because your objection is to the chartering of the MODERN WG, 
which puts you pretty well outside the two-month appeals window. I 
suspect that makes effectively no difference, because I think you'd have 
a remarkably hard time putting together a set of facts that that the 
IESG or IAB would find compelling.

At this point, how things proceed are in the purview of the WG chairs 
and the responsible AD. The chairs have attempted to steer you towards 
productive participation, which you actively declined (cf. "You can 
certainly hope"), and the responsible AD has weighed in with an 
indication that the IESG has heard, considered, and acted upon the 
objections you mention.

Sometimes us old-timers lose track of the process here, or possibly even 
forget that these things have been formalized. In this case, the 
applicable processes are described in BCPs 9, 25, and 83. I encourage 
you to take some time over the holidays to review all three. Take 
careful note that BCP 25 consists of two concatenated RFCs, the second 
of which you may find particularly interesting.

I look forward to your positive contributions -- or, if you can't find 
it in yourself to be useful, benign non-participation -- in the new year.

/a

---

From: "Richard Hill" <[email-masked]>
Date: Thu, 17 Dec 2015 19:07:53 +0100

Please see embedded comment below.

Thanks and best,
Richard

>From: Brian Rosen [mailto:[email-masked]] 
>Sent: Thursday, December 17, 2015 18:17
>To: Gorman, Pierce A [CTO]
>Cc: Richard Shockey; Alissa Cooper; Steve Donovan; Richard Hill; [email-masked]; Adam Roach

SNIP

>One of the great truisms of IETF, among other standards organizations is that it’s really hard
> to stop work where there is a sufficiently large group of people interested in pursuing,
> as long as it falls within the expertise of the organization.  

Can you (or somebody else) explain to me how processes (which might have regulatory implications) regarding assignment of E.164 numbers fall within the expertise of the IETF?

Or have I misunderstood the scope of the work of this group?

SNIP

---

From: Adam Roach <[email-masked]>
Date: Thu, 17 Dec 2015 12:12:11 -0600

> Or have I misunderstood the scope of the work of this group?

You have misunderstood the scope of the entire IETF. We design network 
protocols. We are not part of any regulatory bodies. What those bodies 
choose to do is entirely in their purview.

/a

---

From: Richard Shockey <[email-masked]>
Date: Thu, 17 Dec 2015 12:57:25 -0500

From:  Brian Rosen <[email-masked]>
Date:  Thursday, December 17, 2015 at 12:17 PM
To:  "[email-masked]" <[email-masked]>
Cc:  Richard Shockey <[email-masked]>, Alissa Cooper <[email-masked]>, Steve Donovan <[email-masked]>, Richard Hill <[email-masked]>, "[email-masked]" <[email-masked]>, Adam Roach <[email-masked]>
Subject:  Re: [Modern] Problem statement draft as working group document

It happens.

One of the great truisms of IETF, among other standards organizations is that it’s really hard to stop work where there is a sufficiently large group of people interested in pursuing, as long as it falls within the expertise of the organization.  

RS> Which some of us dispute. I really really believe that E.164 numbering allocation is not within the Expertise of the IETF.  

That’s what is happening here.  It doesn’t matter that there is a large (even larger) group of people who want the work stopped.

RS>  Yes it does matter.  That is not what I was taught consensus was.  Maybe Donald Trump’s idea of consensus.  
"My way or the highway.”  
“My protocol …right or wrong!!”
“Lets make the IETF great again! “   sorry couldn’t resist that one. 

There are enough of us who believe this work is important, will be implemented, and will likely supplant current ways of doing things. 

RS> So what is actually your agenda here? If your agenda is really to overthrow the existing national E.164 numbering administration model then just say so. 

 “We think the FCC, CRTC, OFCOM etc guys are are a bunch of <fill in the blank>."   “The E.164 Liberation Front”  There is a T-Shirt for you. 

 You may not, that’s your privilege.  But we’re going to do the work.  It may be a waste of time.  We’re willing to take that chance.

Brian

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of Richard Shockey
Sent: December 16, 2015 4:21 PM
To: Alissa Cooper <[email-masked]>
Cc: [email-masked]; Steve Donovan <[email-masked]>; Richard Hill <[email-masked]>; Adam Roach <[email-masked]>
Subject: Re: [Modern] Problem statement draft as working group document

Hi Richard,

On 12/14/15 13:16, Richard Hill wrote:
From: Modern [mailto:[email-masked]] On Behalf Of Adam
Roach

Alissa

I'll

/a

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Thu, 17 Dec 2015 18:18:56 +0000

Adam,

The problem here though is that these capabilities are driven by regulatory body (singular), as in the FCC. 

They have not officially provided their requirements, thereby I go back to my folksy comment that, "how does a carpenter know what tools to bring to a job if he does not know what he is building?"

As I stated previously, there is a practical aspect to this work, but a lot of theory is being thrown around.

Regards,

Martin 

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of Adam Roach
Sent: Thursday, December 17, 2015 1:12 PM
To: Richard Hill <[email-masked]>; 'Brian Rosen' <[email-masked]>; 'Gorman, Pierce A [CTO]' <[email-masked]>
Cc: [email-masked]; 'Steve Donovan' <[email-masked]>; 'Alissa Cooper' <[email-masked]>; 'Richard Shockey' <[email-masked]>
Subject: Re: [Modern] Problem statement draft as working group document

> Or have I misunderstood the scope of the work of this group?

You have misunderstood the scope of the entire IETF. We design network protocols. We are not part of any regulatory bodies. What those bodies choose to do is entirely in their purview.

/a

---

From: Adam Roach <[email-masked]>
Date: Thu, 17 Dec 2015 12:19:56 -0600

Yes, and I think it's safe to say that your evaluation of the potential 
deployment of the protocols designed by MODERN differs from Mr. 
Gorman's. Based on that, your evaluation about whether and how to 
participate is different. I would offer that the calculus from your 
perspective would point to positive WG contributions, to assist in 
producing protocols that are well-designed and incorporate your 
expertise in the area.

/a

---

From: Adam Roach <[email-masked]>
Date: Thu, 17 Dec 2015 12:23:23 -0600

On 12/17/15 11:57, Richard Shockey wrote:
> RS> Which some of us dispute. I really really believe that E.164 
> numbering allocation is not within the Expertise of the IETF.

An incredibly congruent objection was raised by several parties in the 
chartering of CODEC. The result of proceeding anyway was objectively and 
subjectively the best audio codec ever produced.

/a

---

From: "Richard Hill" <[email-masked]>
Date: Thu, 17 Dec 2015 19:27:06 +0100

> Sent: Thursday, December 17, 2015 19:12
> To: Richard Hill; 'Brian Rosen'; 'Gorman, Pierce A [CTO]'
> Cc: 'Richard Shockey'; 'Alissa Cooper'; 'Steve Donovan';
> [email-masked]
> > Can you (or somebody else) explain to me how processes (which might
> have regulatory implications) regarding assignment of E.164 numbers
> fall within the expertise of the IETF?
> >

Are you implying that the IETF can design a protocol without any reference whatsoever to whether it might violate existing laws and regulations?

---

From: Richard Shockey <[email-masked]>
Date: Thu, 17 Dec 2015 14:03:00 -0500

I remember that objection well. And Yes the outcome was outstanding but the analogy is not applicable to the problem statement.  CODEC was actually an engineering effort ..this is objectively and subjectively political.

---

From: Adam Roach <[email-masked]>
Date: Thu, 17 Dec 2015 13:24:07 -0600

> Are you implying that the IETF can design a protocol without any reference whatsoever to whether it might violate existing laws and regulations?

Many of the people on this mailing list have spent time over the past 18 
years working on VoIP technologies in the IETF. During this development, 
VoIP was at one time or another illegal or effectively forbidden by 
regulation in China, India, Pakistan, Nepal, Uzbekistan, Nicaragua, 
Colombia, Bolivia, Guyana, Paraguay, Costa Rica, Belize, many Caribbean 
nations, and most of the middle east. In fact, until mid-2008, somewhere 
around 40% of the world's population lived in a country that effectively 
outlawed VoIP.

There's good precedent for the IETF developing protocols whose 
deployment at the moment of development would be subject to legal or 
regulatory restrictions in some jurisdictions.

/a

---

From: "Richard Hill" <[email-masked]>
Date: Thu, 17 Dec 2015 20:42:47 +0100

> Sent: Thursday, December 17, 2015 20:24
> Cc: [email-masked]; 'Steve Donovan'; 'Alissa Cooper'; 'Richard
> Shockey'

SNIP

> regulatory restrictions in some jurisdictions.

Of course. There is nothing wrong with developing a protocol that that is
legal in some place and not legal elsewhere, because it can be used in the
countries in which it is legal.

Would the protocols proposed to be developed in this group conform to
current legal and regulatory requirements in at least one jurisdiction?  Or
is that question not relevant?

---

From: "McGarry, Tom" <[email-masked]>
Date: Thu, 17 Dec 2015 19:48:59 +0000

What's being designed are tools.  It is up to others, e.g., regulators,
authorities, to decide how or whether to use those tools.  That's where
the policy gets created.

I know it has been controversial to suggest a tool (process) that would
allow a consumer to acquire a telephone number directly, rather than thru
a service provider.  The most common identifier on the Internet, domain
names, uses this model.  We're discussing identifiers, telephone numbers,
on IP networks.  It would be irresponsible and backward looking not to
account for this possibility.
 
The WG also includes the current process for number allocation, where
service providers acquire the numbers and they then in turn allocate
numbers to consumers.

Entities that decide numbering policies can choose which tools they do and
do not want to use.  That is where policies and regulations are created.

I know some people on this list refuse to believe this, not matter how
often it is said.  But those are the facts.

On 12/17/15 1:27 PM, "Richard Hill" <[email-masked]> wrote:

>Are you implying that the IETF can design a protocol without any
>reference whatsoever to whether it might violate existing laws and
>regulations?
>
>> 
>> /a
>
>Z1ooNcfp01IYIaVqsORjI&m=ozfZfjKsWcLVXeIljVVsmxlsctjUYK9cpOGjPZWtBkw&s=LPGP
>t7cTP8zbe-1ZBrkEgho_MZXUC-S7QX5pGaOvL0U&e=

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Thu, 17 Dec 2015 20:00:05 +0000

Tom 

That is the point and frustration, shouldn't we have an understanding of the regulatory requirements before blindly defining protocol?

Martin C Dolly

> On Dec 17, 2015, at 2:49 PM, McGarry, Tom <[email-masked]> wrote:
>

---

From: "Richard Hill" <[email-masked]>
Date: Thu, 17 Dec 2015 21:04:39 +0100

Thank you for clarifying.

Best,
Richard

> Sent: Thursday, December 17, 2015 20:49
> To: [email-masked]
> allow a consumer to acquire a telephone number directly, rather than
> thru a service provider.  The most common identifier on the Internet,
> domain names, uses this model.  We're discussing identifiers, telephone
> numbers, on IP networks.  It would be irresponsible and backward
> looking not to account for this possibility.
> 
> Entities that decide numbering policies can choose which tools they do
> and do not want to use.  That is where policies and regulations are
> created.
> 
> >> You have misunderstood the scope of the entire IETF. We design
> >> network protocols. We are not part of any regulatory bodies. What
> >> those bodies choose to do is entirely in their purview.
> >
> >
> >https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailm
> >an_
> >Z1ooNcfp01IYIaVqsORjI&m=ozfZfjKsWcLVXeIljVVsmxlsctjUYK9cpOGjPZWtBkw&s=
> L
> >PGP t7cTP8zbe-1ZBrkEgho_MZXUC-S7QX5pGaOvL0U&e=
>

---

From: "McGarry, Tom" <[email-masked]>
Date: Thu, 17 Dec 2015 20:20:33 +0000

No, that would get us involved with regulations and policies.  Our role is
to understand the environment from a technology and process perspective,
anticipate needs (e.g., perhaps including a more Internet-like model) and
create solutions.  It's up to others to choose what they will and will not
use.  

On 12/17/15 3:00 PM, "DOLLY, MARTIN C" <[email-masked]> wrote:

>Tom 
>
>That is the point and frustration, shouldn't we have an understanding of
>the regulatory requirements before blindly defining protocol?
>
>Martin C Dolly
>>thru
>>and
>>https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman
>>_listinfo_modern&d=CwIFAg&c=MOptNlVtIETeDALC_lULrw&r=4Klm32iB7HufveeIDcLe
>>xtZ1ooNcfp01IYIaVqsORjI&m=6k6xBxpm7dn7KBeEKiMOttP4N0RYgrEx_jL-ZEio3tc&s=R
>>wfQDsbB7PHQvmP4WR0eqfXpetHM9q0n4Pr5CuIXEVU&e=

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 17 Dec 2015 15:34:23 -0500

> That is the point and frustration, shouldn't we have an understanding of the regulatory requirements before blindly defining protocol?

ISTM there is a chicken/egg problem here.

Too often legislators and regulators make up regulations that can't be 
implemented. (Especially right now.) At the same time, they are likely 
not to realize what used to be infeasible would now would be feasible if 
regulations allowed.

It seems like it ought to be easier to get good regulations if you can 
show something concrete to the regulators.

After all, they are now bought in to moving to an all-IP telephone 
system. We didn't wait for that regulation before developing SIP.

	Thanks,
	Paul

---

From: Richard Shockey <[email-masked]>
Date: Thu, 17 Dec 2015 15:57:33 -0500

>not to realize what used to be infeasible would now would be feasible if 

RS>  Paul the regulators know what is technically feasible.  Its just in the universe of problems I’m personally aware of this is still #164.  Compared to dealing with caller ID spoofing robocalls or implementing national geographic number portability this is beyond trivial. No one has proved there is a problem here.  Far from it the proponents of this proposition are entering the political arena that I and others still have the scars from. At some point in time it is an obligation for adults to keep children from wildly running amuck in the store. 

There are two propositions here.  First the concept of restructuring number administration and two the use of highly distributed and synchronized databases.  My strong objections here is the idea pf putting the cart before the horse. We might not be having this conversation if the use case were some other form of metadata surrounding E.164 numbers which actually might deploy and then building on success migrate to other types of numbering administration. 

>show something concrete to the regulators.

RS> Depends on the administration.  In any event that is what open source projects are for. 

>system. We didn't wait for that regulation before developing SIP.

RS > Again a false tautology.

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Thu, 17 Dec 2015 21:49:54 +0000

That is the problem my friend. And note this is USA issue, so those that ask why IETF are involved are correct. 

I believe the IETF is good for parts but not the whole solution.

Let us stop dancing around the naked emperor...

-----Original Message-----
From: McGarry, Tom [mailto:[email-masked]] 
Sent: Thursday, December 17, 2015 3:21 PM
To: DOLLY, MARTIN C <[email-masked]>
Cc: [email-masked]
Subject: Re: [Modern] Problem statement draft as working group document

No, that would get us involved with regulations and policies.  Our role is to understand the environment from a technology and process perspective, anticipate needs (e.g., perhaps including a more Internet-like model) and create solutions.  It's up to others to choose what they will and will not use.  

On 12/17/15 3:00 PM, "DOLLY, MARTIN C" <[email-masked]> wrote:

>Tom
>
>That is the point and frustration, shouldn't we have an understanding 
>of the regulatory requirements before blindly defining protocol?
>
>Martin C Dolly
>> What's being designed are tools.  It is up to others, e.g., 
>> regulators, authorities, to decide how or whether to use those tools.  
>> That's where the policy gets created.
>> 
>> I know it has been controversial to suggest a tool (process) that 
>>would  allow a consumer to acquire a telephone number directly, rather 
>>than thru  a service provider.  The most common identifier on the 
>>Internet, domain  names, uses this model.  We're discussing 
>>identifiers, telephone numbers,  on IP networks.  It would be 
>>irresponsible and backward looking not to  account for this 
>>possibility.
>> 
>> Entities that decide numbering policies can choose which tools they 
>>do and  do not want to use.  That is where policies and regulations 
>>are created.
>> 
>> I know some people on this list refuse to believe this, not matter 
>> how often it is said.  But those are the facts.
>> 
>> 
>> 
>> 
>>>https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mai
>>>lma
>>>n_
>>> 
>>>listinfo_modern&d=CwICAg&c=MOptNlVtIETeDALC_lULrw&r=4Klm32iB7HufveeID
>>>cLe
>>>xt
>>> 
>>>Z1ooNcfp01IYIaVqsORjI&m=ozfZfjKsWcLVXeIljVVsmxlsctjUYK9cpOGjPZWtBkw&s
>>>=LP
>>>GP
>>man 
>>xtZ1ooNcfp01IYIaVqsORjI&m=6k6xBxpm7dn7KBeEKiMOttP4N0RYgrEx_jL-ZEio3tc&
>>s=R wfQDsbB7PHQvmP4WR0eqfXpetHM9q0n4Pr5CuIXEVU&e=

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 17 Dec 2015 18:04:46 -0500

The IETF is an open organization with global participation. Any mechanisms defined in this or any other WG need to be flexible enough to accommodate requirements that exist or may be established in a variety of jurisdictions. Individual participants may concern themselves only with their home jurisdictions, but that does not eliminate the need to produce tools that can be used across jurisdictions. 

Alissa

> On Dec 17, 2015, at 4:49 PM, DOLLY, MARTIN C <[email-masked]> wrote:
>

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Thu, 17 Dec 2015 23:27:45 +0000

Alissa

Please explain which country outside the USA this is being driven by?

I asked all my 3GPP colleagues, and the answer is none. 

Look at the carrier participation on the list 

If it looks like a duck, maybe it is a duck

Martin C Dolly

> On Dec 17, 2015, at 6:05 PM, Alissa Cooper <[email-masked]> wrote:
>

---

From: Brian Rosen <[email-masked]>
Date: Thu, 17 Dec 2015 19:15:06 -0500

I’ve talked to a couple of regulators beyond the U.S. ones.  Some EU, some smaller nations.  As you know, a number of regulators send folks to IETF meetings.  They are VERY interested.  I wouldn’t say anyone is committed, just interested.

Brian

> On Dec 17, 2015, at 6:27 PM, DOLLY, MARTIN C <[email-masked]> wrote:
> 
> Alissa
>

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Fri, 18 Dec 2015 01:22:21 +0000

And my conversation with large EU and Asian was they were not, interesting 

Martin C Dolly

> On Dec 17, 2015, at 7:15 PM, Brian Rosen <[email-masked]> wrote:
>

---

From: "Mark Delany" <[email-masked]>
Date: 18 Dec 2015 01:42:49 +0000

The Australian environment for one is likely to have growing interest
given the forced migration of practically all PSTN to VOIP as a
consequence of their National Broadband Network (NBN).

I don't know of the NZ experience first-hand, but given they are
making a similar transition many of the same issues will arise there.

Maybe not today, but given the life-cycle of the IETF processes, it's
entirely reasonable to think that WG product should keep these
regional trends in mind.

Mark.

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Fri, 18 Dec 2015 02:00:27 +0000

Please explain what exactly their interest is in? 

Thanks

Martin C Dolly

> On Dec 17, 2015, at 8:42 PM, Mark Delany <[email-masked]> wrote:
>

---

From: Steve Donovan <[email-masked]>
Date: Thu, 17 Dec 2015 20:13:14 -0600

All,

We need to move this discussion off of the "should MODERN exist" thread 
to "should the existing problem statement draft become a working group 
draft."

MODERN is a working group in the IETF.  We need to work toward doing the 
work as outlined in the charter.

I would ask that everyone refrain from posting emails that repeat the 
discussions we had in the forming of the working group.  That ship has 
sailed.

So far the majority of the objections to promoting the problem statement 
draft have been in the vein of "MODERN shouldn't exist, thus the draft 
shouldn't exist".  This is not fruitful as MODERN does exist (see above).

There has been some discussions on the actual content of the draft, 
which is what we need and this is what needs to continue.

Note that promoting the draft does not mean that work is finished. 
Rather it means that the working group thinks it is a good starting 
point.  Those discussions on the actual content of the draft can and 
will continue if it becomes a working group draft.

So, I will repeat my original question -- Should the problem statement 
draft become a working group draft?

And I will add the following -- If your opinion is that it should not be 
a working group draft, please elaborate as to why you hold that 
opinion.  Or better yet, submit a draft that you think better addresses 
the architecture draft milestone in the charter.

Thanks,

Steve

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Fri, 18 Dec 2015 03:33:29 +0000

In between reading the comments back and forth and starting and stopping comments of my own, I've begun reading your problem statement.  It is difficult for me because I find myself loudly disagreeing (in my head) with nearly every assertion and statement.  And I am unlikely to propose an alternative because of the fundamental problems many have raised and nearly as many have ignored.

Richard Shockey is right when he says that MODERN at least implies replacing existing numbering administrative processes and systems.

Proposing a system (NOT a protocol) capable of replacing the world-wide set of numbering authorities' administrative processes when you consider the quantity of countries, and impacted regulatory authorities within the countries (e.g., 51 at least in the US at the federal and state levels) and/or union of countries or regions or states, let alone the impacted carriers within each country, and add in the variations in uses of numbers such as toll free numbers, emergency services numbers, temporary location directory numbers, and layer in variations in national and regional dialing plans, casual calling, et cetera ad nauseum, what's been discussed so far as a problem statement is mostly not credible.

The folks that are dissatisfied with the chartering of MODERN, and in disagreement with the problem statement as it exists, are not against change.  Most of us have important roles as agents of change within our respective domains.

In developing database systems there are two basic methods.  Either a developer can envision a set of problems and devise a way to solve them and the users adapt to the vision of the developer, or the developers can learn and develop to user specifications.

DNS is an example of the first methodology.   The most active contributors on this list are telling you MODERN needs to be the second.

I suspect it's possible the IETF may lack the expertise to understand the telephone number problem space that the commercial carriers eat, live, and breathe and have for decades.  MODERN can partner with the users (regulatory authorities, carriers, alternative service providers, businesses, and consumers) to learn their requirements, or it can persist down the path it's been traveling so far.  The list of RFCs is very long and littered with DOA protocols and systems.  If you continue to ignore the considerable input you've been receiving, my opinion is you will most likely add to the litter.

Now, all that being said, I will resume my reading of the problem statement and if I can convince myself that I can make a contribution that would be acceptable (which at the moment feels doubtful) then I will do so.

Sent from my iPad

> On Dec 17, 2015, at 8:13 PM, Steve Donovan <[email-masked]> wrote:
>
> All,
>
> We need to move this discussion off of the "should MODERN exist" thread to "should the existing problem statement draft become a working group draft."
>
> MODERN is a working group in the IETF.  We need to work toward doing the work as outlined in the charter.
>
> I would ask that everyone refrain from posting emails that repeat the discussions we had in the forming of the working group.  That ship has sailed.
>
> So far the majority of the objections to promoting the problem statement draft have been in the vein of "MODERN shouldn't exist, thus the draft shouldn't exist".  This is not fruitful as MODERN does exist (see above).
>
> There has been some discussions on the actual content of the draft, which is what we need and this is what needs to continue.
>
> Note that promoting the draft does not mean that work is finished. Rather it means that the working group thinks it is a good starting point.  Those discussions on the actual content of the draft can and will continue if it becomes a working group draft.
>
> So, I will repeat my original question -- Should the problem statement draft become a working group draft?
>
> And I will add the following -- If your opinion is that it should not be a working group draft, please elaborate as to why you hold that opinion.  Or better yet, submit a draft that you think better addresses the architecture draft milestone in the charter.
>
> Thanks,
>
> Steve
>
>

---

From: "Richard Hill" <[email-masked]>
Date: Fri, 18 Dec 2015 07:51:30 +0100

Thanks and best,
Richard

> From: Modern [mailto:[email-masked]] On Behalf Of Alissa
> Cooper
> Sent: Friday, December 18, 2015 00:05
> To: DOLLY, MARTIN C
> Cc: [email-masked]; McGarry, Tom
> The IETF is an open organization with global participation. Any
> mechanisms defined in this or any other WG need to be flexible enough
> to accommodate requirements that exist or may be established in a
> variety of jurisdictions. Individual participants may concern
> themselves only with their home jurisdictions, but that does not
> eliminate the need to produce tools that can be used across
> jurisdictions.

In that case, would it make sense to seek to obtain input from regulators
outside the US? One way of doing that would be to transmit the current
working group document as a liaison to ITU-T Study Group 2, asking for
comments.

> > That is the problem my friend. And note this is USA issue, so those
> that ask why IETF are involved are correct.
> >
> > No, that would get us involved with regulations and policies.  Our
> role is to understand the environment from a technology and process
> perspective, anticipate needs (e.g., perhaps including a more Internet-
> like model) and create solutions.  It's up to others to choose what
> they will and will not use.
> >
> >> Core & Government/Regulatory Standards AT&T
> >> Cell: 609-903-3360
> >> Email: [email-masked]
> >>
> >>> would  allow a consumer to acquire a telephone number directly,
> >>> rather than thru  a service provider.  The most common identifier
> on
> >>> the Internet, domain  names, uses this model.  We're discussing
> >>> The WG also includes the current process for number allocation,
> >>> where service providers acquire the numbers and they then in turn
> >>> allocate numbers to consumers.
> >>>
> >>>>> have regulatory implications) regarding assignment of E.164
> >>>>> numbers fall within the expertise of the IETF?
> >>>>>>
> 3A__www.ietf.org_m
> >>>> ai
> 3A__www.ietf.org_ma
> >>> il
> _listinfo_modern&d=CwIFAg&c=MOptNlVtIETeDALC_lULrw&r=4Klm32iB7Hufvee
> >>> ID
> >>> cLe
> >>> xtZ1ooNcfp01IYIaVqsORjI&m=6k6xBxpm7dn7KBeEKiMOttP4N0RYgrEx_jL-
> ZEio3t
> >>> c& s=R wfQDsbB7PHQvmP4WR0eqfXpetHM9q0n4Pr5CuIXEVU&e=
> >

---

From: "Richard Hill" <[email-masked]>
Date: Fri, 18 Dec 2015 07:53:05 +0100

Please see below.

Thanks and best,
Richard

> From: Modern [mailto:[email-masked]] On Behalf Of Brian Rosen
> Sent: Friday, December 18, 2015 01:15
> To: DOLLY, MARTIN C
> Cc: [email-masked]; Alissa Cooper; Tom McGarry
> I’ve talked to a couple of regulators beyond the U.S. ones.  Some EU,
> some smaller nations.  As you know, a number of regulators send folks
> to IETF meetings.  They are VERY interested.  

Interest would probably be broadened and deepened if the group's charter and the draft working group document were submitted as a liaison statement to ITU-T Study Group 2.

> I wouldn’t say anyone is
> committed, just interested.
> 
> Brian
> 
> >>>> That is the point and frustration, shouldn't we have an
> >>>> understanding of the regulatory requirements before blindly
> defining protocol?
> >>>>
> >>>> Martin C Dolly
> >>>>> On Dec 17, 2015, at 2:49 PM, McGarry, Tom
> >>>>> <[email-masked]>
> >>>>> wrote:
> >>>>>
> >>>>> on the Internet, domain  names, uses this model.  We're
> discussing
> >>>>> Entities that decide numbering policies can choose which tools
> >>>>> they do and  do not want to use.  That is where policies and
> >>>>> regulations are created.
> >>>>>
> >>>>>>> network protocols. We are not part of any regulatory bodies.
> >>>>>>> What those bodies choose to do is entirely in their purview.
> >>>>>>
> >>>>>>
> >>>>>> reference whatsoever to whether it might violate existing laws
> >>>>>> and regulations?
> >>>>>>
> >>>>>>>
> >>>>>>> /a
> >>>>>>
> 3A__www.ietf.org
> >>>>>> _mai
> 3A__www.ietf.org_
> >>>>> mail
> _listinfo_modern&d=CwIFAg&c=MOptNlVtIETeDALC_lULrw&r=4Klm32iB7Hufv
> >>>>> eeID
> >>>>> cLe
> ZEio
> >>>>> 3tc& s=R wfQDsbB7PHQvmP4WR0eqfXpetHM9q0n4Pr5CuIXEVU&e=
> >>>

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Fri, 18 Dec 2015 10:45:58 +0000

I am not aware that VOIP transition is requires the MODERN work as a precondition.

It is just a tool that some people think might be used (and that is potentially independent of VOIP usage).

Regards

Keith

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of Mark Delany
Sent: 18 December 2015 01:43
To: [email-masked]
Subject: Re: [Modern] Problem statement draft as working group document

The Australian environment for one is likely to have growing interest given the forced migration of practically all PSTN to VOIP as a consequence of their National Broadband Network (NBN).

I don't know of the NZ experience first-hand, but given they are making a similar transition many of the same issues will arise there.

Maybe not today, but given the life-cycle of the IETF processes, it's entirely reasonable to think that WG product should keep these regional trends in mind.

Mark.

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Fri, 18 Dec 2015 12:50:02 +0000

Beyond persevering regardless of input and feedback, were there other lessons learned in CODEC that could be applied in this working group?

Rich Hill's suggestion that learning requirements through an ITU study group could be beneficial seems logical.

I'm not suggesting this as a stall tactic.  I'm suggesting that MODERN is taking on a global challenge and could benefit from Rich's suggestion.  Are there good reasons to ignore it?

Sent from my iPad

> On Dec 17, 2015, at 12:23 PM, Adam Roach <[email-masked]> wrote:
>
> An incredibly congruent objection was raised by several parties in the chartering of CODEC. The result of proceeding anyway was objectively and subjectively the best audio codec ever produced.
>
> /a
>

---

From: "Richard Hill" <[email-masked]>
Date: Fri, 18 Dec 2015 13:53:07 +0100

To be clear, I'm not suggesting that this group pause its work or wait for
inputs from ITU-T. I'm suggesting that it inform ITU-T of where it stands
and continue its work. If ITU-T replies, then the group could take that
input into account in due course.

Best,
Richard

> Sent: Friday, December 18, 2015 13:50
> To: Adam Roach
> Cc: Richard Shockey; Brian Rosen; Steve Donovan; Richard Hill;
> [email-masked]; Alissa Cooper
> Beyond persevering regardless of input and feedback, were there other
> lessons learned in CODEC that could be applied in this working group?
> 
> I'm not suggesting this as a stall tactic.  I'm suggesting that MODERN
> is taking on a global challenge and could benefit from Rich's
> suggestion.  Are there good reasons to ignore it?
> 
> Sent from my iPad
> 
> > An incredibly congruent objection was raised by several parties in
> the chartering of CODEC. The result of proceeding anyway was
> objectively and subjectively the best audio codec ever produced.
> >
> > /a
> >
> Switch to Sprint and save 50% on Verizon, AT&T or T-Mobile rates. Your
> savings are guaranteed until 2018! Available on most plans. Limited
> time offer. Exclusions and restrictions apply. See
> sprint.com/save50<http://sprint.com/50off> for details.
>

---

From: "DOLLY, MARTIN C" <[email-masked]>
Date: Fri, 18 Dec 2015 13:57:55 +0000

I do not think this work impacts beyond NANP

Martin C Dolly

> On Dec 18, 2015, at 7:53 AM, Richard Hill <[email-masked]> wrote:
>

---

From: "Richard Hill" <[email-masked]>
Date: Fri, 18 Dec 2015 15:02:17 +0100

NANP involves several countries other than the USA.  Should they be
encouraged to participate in the work?

Best,
Richard

> From: DOLLY, MARTIN C [mailto:[email-masked]]
> Sent: Friday, December 18, 2015 14:58
> To: Richard Hill
> Cc: Gorman, Pierce A [CTO]; Adam Roach; Steve Donovan; Brian Rosen;
> [email-masked]; Alissa Cooper; Richard Shockey
> > To be clear, I'm not suggesting that this group pause its work or
> wait
> > for inputs from ITU-T. I'm suggesting that it inform ITU-T of where
> it
> > stands and continue its work. If ITU-T replies, then the group could
> > take that input into account in due course.
> >
> > Best,
> > Richard
> >
> >> Rich Hill's suggestion that learning requirements through an ITU
> >> study group could be beneficial seems logical.
> >>
> >> I'm not suggesting this as a stall tactic.  I'm suggesting that
> >> MODERN is taking on a global challenge and could benefit from Rich's
> >> Switch to Sprint and save 50% on Verizon, AT&T or T-Mobile rates.
> >> Your savings are guaranteed until 2018! Available on most plans.
> >> Limited time offer. Exclusions and restrictions apply. See

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Fri, 18 Dec 2015 22:56:41 +0000

You bring up something I wondered about.

I'm new to how things proceed in standards development but was hopeful your comment about an ITU-T Study Group could provide some things I thought would be of special value to the work in MODERN.

First, a dictionary or other compendium of all of the impacted regulatory numbering authority bodies and some high-level assessment and/or overview of their assignment and management processes would be very helpful.

Second, a similar comprehensive work identifying all of the variations in types of numbers, any assignment-specific requirements (e.g., toll free should be instructive) by country would be good.

Finally, a list of points of contact for number administration and routing information management for each of the registered carriers in the world.  (MODERN will enjoy more help than it has now.)

For the first two, there will be a lot of commonalities, but there will very likely be numerous requirements and challenges (and opportunities) identified which should greatly benefit the development of the MODERN problem statement(s).

While this seems prudent to me, it might also be outside of the scope of the IETF or any SDO to use this approach.  One of my job responsibilities almost 30 years ago was database development for routing translations and premise-based user-defined systems succeeded where visionary approaches failed, so I am offering my view of long-ago hard-won experience.

Pierce

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of Richard Hill
Sent: December 18, 2015 8:02 AM
To: 'DOLLY, MARTIN C' <[email-masked]>
Cc: 'Steve Donovan' <[email-masked]>; 'Adam Roach' <[email-masked]>; 'Alissa Cooper' <[email-masked]>; [email-masked]; 'Richard Shockey' <[email-masked]>; Gorman, Pierce A [CTO] <[email-masked]>; 'Brian Rosen' <[email-masked]>
Subject: Re: [Modern] Problem statement draft as working group document

NANP involves several countries other than the USA.  Should they be encouraged to participate in the work?

Best,
Richard

> >> MODERN is taking on a global challenge and could benefit from
> >> Rich's suggestion.  Are there good reasons to ignore it?
> >>
> >> Sent from my iPad
> >>

---

From: "Richard Hill" <[email-masked]>
Date: Sat, 19 Dec 2015 11:23:29 +0100

Please see below.

Thanks and best,
Richard

> Sent: Friday, December 18, 2015 23:57
> To: Richard Hill; 'DOLLY, MARTIN C'
> Cc: 'Steve Donovan'; 'Adam Roach'; 'Alissa Cooper'; [email-masked];
> 'Richard Shockey'; 'Brian Rosen'
> I'm new to how things proceed in standards development but was hopeful
> your comment about an ITU-T Study Group could provide some things I
> thought would be of special value to the work in MODERN.
> 
> First, a dictionary or other compendium of all of the impacted
> regulatory numbering authority bodies

As others have pointed out, a numbering authority would only be impacted if
it agreed to use the protocols developed in this group. Almost all of the
world's numbering authorities are represented in ITU-T. You can find the
coordinates of the regulator by going to the individual country page from
the overall country listing at:

https://www.itu.int/online/mm/scripts/mm.list?_search=ITUstates&_languageid=
1 

A variety of information on international numbering resources (including
E.164 numbers and national numbering plans) is available at:

  http://www.itu.int/en/ITU-T/inr/Pages/default.aspx 

ITU-D publishes a "regulatory tracker" that includes information such as
whether VoIP is allowed, see:

  http://www.itu.int/en/ITU-D/Regulatory-Market/tracker/Pages/default.aspx 

An overview of the regulatory policies in each country is published at:

  http://www.itu.int/net4/itu-d/icteye/CountryProfile.aspx 

However, I don't see anything specific there about number allocation
policies or regulations.

> and some high-level assessment
> and/or overview of their assignment and management processes would be
> very helpful.

Maybe somebody has done an overall synthesis, but if so I'm not aware of it.

The EU Framework Directive has an article on Numbering, Naming and
Addressing (Art. 10). Although it does not explicitly say so, to me it seems
to imply that numbers can be assigned only to providers, not to end-users.
The directive is at:

http://eur-lex.europa.eu/LexUriServ/LexUriServ.do?uri=OJ:L:2002:108:0033:005
0:EN:PDF 

> 
> Second, a similar comprehensive work identifying all of the variations
> in types of numbers, any assignment-specific requirements (e.g., toll
> free should be instructive) by country would be good.

You will find much of that in the ITU's compilation of national numbering
plans, at:

  http://www.itu.int/oth/T0202.aspx?parent=T0202 

There is a specific page for emergency numbers, at:

 http://www.itu.int/net/itu-t/inrdb/e129_important_numbers.aspx 

> 
> Finally, a list of points of contact for number administration

You will find that in the listing of ITU members referenced above.

> and
> routing information management for each of the registered carriers in
> the world.  

The concept of "registered carriers" no longer exists in many countries. A
list of carriers that are considered to be in that category is published at:

  http://www.itu.int/en/ITU-T/inr/Pages/roa.aspx 

However, I'm not aware of any publicly available compilation of routing
information for telephony. As far as I know, operators maintain their own
proprietary routing tables.

>(MODERN will enjoy more help than it has now.)
> 
> For the first two, there will be a lot of commonalities, but there will
> very likely be numerous requirements and challenges (and opportunities)
> identified which should greatly benefit the development of the MODERN
> problem statement(s).
> 
> While this seems prudent to me, it might also be outside of the scope
> of the IETF or any SDO to use this approach.  One of my job
> responsibilities almost 30 years ago was database development for
> routing translations and premise-based user-defined systems succeeded
> where visionary approaches failed, so I am offering my view of long-ago
> hard-won experience.
> 
> Pierce
> 
> Cc: 'Steve Donovan' <[email-masked]>; 'Adam Roach'
> <[email-masked]>; 'Alissa Cooper' <[email-masked]>;
> [email-masked]; 'Richard Shockey' <[email-masked]>; Gorman, Pierce
> A [CTO] <[email-masked]>; 'Brian Rosen' <[email-masked]>

---

From: "Mark R Lindsey, ECG" <[email-masked]>
Date: Sat, 19 Dec 2015 06:56:58 -0500

I hear consensus! Proposed alternative problem statement capturing the
mood:

WE DON'T KNOW WHAT WE DON'T KNOW (So let's find out how to find out)

1. We'd like to have Internet protocol support for management, allocation,
assignment etc., of "telephone numbers" worldwide ("The Domain")

2. We know The Domain has existed for 100 years, and takes enormous number
of shapes in Real Networks, some regulatory, some commercial, some technical

3. We don't yet which of these are important enough to bake into a protocol

4. If we make a protocol that's not a good fit for The Domain, we're making
the problem worse because a bad protocol further obfuscates The Domain and
distracts from working protocols of the future

5. Thus the REAL PROBLEM TO BE SOLVED is how to understand enough of
The Domain to have a reasonable chance of making a relevant protocol,
likely to be achieved by actively collecting information from the parties
involved in The Domain

---
Mark R Lindsey, mailto:[email-masked], tel:+1-229-316-0013,
http://ecg.co/lindsey

On Saturday, December 19, 2015, Richard Hill <[email-masked]> wrote:

> > From: Gorman, Pierce A [CTO] [mailto:[email-masked]
> <javascript:;>]
> > Cc: 'Steve Donovan'; 'Adam Roach'; 'Alissa Cooper'; [email-masked]
> <javascript:;>;
> > From: Modern [mailto:[email-masked] <javascript:;>] On Behalf
> Of Richard Hill
> > To: 'DOLLY, MARTIN C' <[email-masked] <javascript:;>>
> > Cc: 'Steve Donovan' <[email-masked] <javascript:;>>; 'Adam
> Roach'
> > <[email-masked] <javascript:;>>; 'Alissa Cooper' <[email-masked]
> <javascript:;>>;
> > [email-masked] <javascript:;>; 'Richard Shockey' <[email-masked]
> <javascript:;>>; Gorman, Pierce
> > A [CTO] <[email-masked] <javascript:;>>; 'Brian Rosen' <
> [email-masked] <javascript:;>>
> > > From: DOLLY, MARTIN C [mailto:[email-masked] <javascript:;>]
> > > [email-masked] <javascript:;>; Alissa Cooper; Richard Shockey
> > > Email: [email-masked] <javascript:;>
> > >
> > > > On Dec 18, 2015, at 7:53 AM, Richard Hill <[email-masked]
> <javascript:;>> wrote:
> > > >
> > > >> From: Gorman, Pierce A [CTO] [mailto:[email-masked]
> <javascript:;>]
> > > >> [email-masked] <javascript:;>; Alissa Cooper
> > > >>>> On Dec 17, 2015, at 12:23 PM, Adam Roach <[email-masked]
> <javascript:;>>
> > wrote:
> > > >>>>
> > > >>> [email-masked] <javascript:;>
> > > > [email-masked] <javascript:;>
> > [email-masked] <javascript:;>
> [email-masked] <javascript:;>

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 22 Dec 2015 14:22:05 -0700

I and a lot of other people provided input at IETF94 so I did not see any need to say more here. 

However, there has been nothing new raised on the thread here that had not been brought prior to IETF94. I think it is very clear the list discussion has not changed the census from the meeting and thus I think this needs to be adopted now. What timeline do you have in mind for adopting this?

Thanks, Cullen

PS - yes the draft-peterson-modern-problems-02 draft looks more than fine for an WG -00 doc, in fact it looks close to ready for WGLC 

> On Nov 13, 2015, at 2:53 PM, Steve Donovan <[email-masked]> wrote:
> 
> All,
>

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Wed, 23 Dec 2015 04:54:33 +0000

Cullen,

What's your hurry?  Was there no useful discussion whatsoever since November?

Sent from my iPad

> On Dec 22, 2015, at 3:22 PM, Cullen Jennings <[email-masked]> wrote:
>
>

---

From: Richard Shockey <[email-masked]>
Date: Tue, 29 Dec 2015 18:09:29 -0500

Keith you are correct it does not .. Some of this might be useful some of it may not.  Certainly our experience with ENUM tells us to be cautious about playing around with matters under NRA authority. 

VOIP transition is already in place in multiple jurisdictions.  It is a matter of national policy in the US UK Canada etc.  The All IP transition is a matter of strategic concern to every supplier serving the industry. The carriers have made the decision. Its not just US Carriers this is DTAG as well.  You know this.

http://www.lightreading.com/nfv/nfv-strategies/dts-journey-to-a-new-ip-world/v/d-id/720033?

There is some concern about the underlying databases. Particularly those involving LNP.  I have no objection to offering tools to SP’s but target the application that makes sense. Interconnection metadata.  What do we do with carrier CERTS in STIR.  Something that is practial deployable. Not this numbering administration BS.

---

From: Steve Donovan <[email-masked]>
Date: Wed, 30 Dec 2015 09:21:27 -0600

Pierce,

There is no hurry or reason to delay in advancing a draft to becoming a 
working group draft.  Doing so does not say that the contents of the 
draft are finished.  Rather it says that the draft is a good starting 
point for addressing a working group milestone. Despite Cullen's opinion 
that the document is close to ready for WGLC, that is not what we are 
discussing at this point.  The hurdle for a document being ready for 
WGLC is much higher than it becoming a working group document.  In fact, 
not all drafts that become working group documents make it to WGLC, much 
less RFC status.

We had consensus in the working group meeting at IETF 94.  So far I 
haven't seen arguments saying that the document isn't suitable to become 
a working group document.  There is good discussion on the content of 
the draft, but that discussion can continue independent of the status of 
the draft.

I will wait until after the holiday's to renew this discussion but it 
appears to me that we can make the document a working group item.

Regards,

Steve

---

From: Steve Donovan <[email-masked]>
Date: Wed, 30 Dec 2015 09:24:19 -0600

Richard,

We have a working group formed to address what you refer to as 
"numbering administration BS".  This is what the working group will be 
working on.  If there is additional work needed around interconnection 
metadata or other tools for handling other types of data then you are 
free to propose a new working group.

Regards,

Steve

---

From: "Gorman, Pierce A [CTO]" <[email-masked]>
Date: Wed, 30 Dec 2015 15:33:43 +0000

Thanks Steve.  I've been combing through the document and writing questions and editorial suggestions (in good faith).  I've decided that rather than pepper everybody with notes at the end of each day as I generate them, I'll instead try to complete them and send them as a whole.

So far as I've gotten the document looks more like a hand wave in the direction of particular (but perhaps unimportant?) problems in North America specifically, and jumps directly to suggesting the framework of a solution.  But, this is an admittedly premature and biased view based on previous browsing of the problem statement and my experience with the WG charter and the generous definition of consensus allowed by the ADs.

It is possible that I will "see the light" and recognize it as an on-coming train (with respect to the problems outlined in the problem statement - not the IETF processes).  If so, my edit suggestions will benefit from some modification and should improve the result you'll see.

I'm trying to have my input completed and ready this week.

Pierce

-----Original Message-----
From: Modern [mailto:[email-masked]] On Behalf Of Steve Donovan
Sent: December 30, 2015 9:21 AM
To: [email-masked]
Subject: Re: [Modern] Problem statement draft as working group document

Pierce,

There is no hurry or reason to delay in advancing a draft to becoming a working group draft.  Doing so does not say that the contents of the draft are finished.  Rather it says that the draft is a good starting point for addressing a working group milestone. Despite Cullen's opinion that the document is close to ready for WGLC, that is not what we are discussing at this point.  The hurdle for a document being ready for WGLC is much higher than it becoming a working group document.  In fact, not all drafts that become working group documents make it to WGLC, much less RFC status.

We had consensus in the working group meeting at IETF 94.  So far I haven't seen arguments saying that the document isn't suitable to become a working group document.  There is good discussion on the content of the draft, but that discussion can continue independent of the status of the draft.

I will wait until after the holiday's to renew this discussion but it appears to me that we can make the document a working group item.

Regards,

Steve

On 12/22/15 10:54 PM, Gorman, Pierce A [CTO] wrote:
>> PS - yes the draft-peterson-modern-problems-02 draft looks more than
>> fine for an WG -00 doc, in fact it looks close to ready for WGLC
>>
>>

________________________________
Learn more on how to switch to Sprint and save 50% on most Verizon, AT&T or T-Mobile rates. See sprint.com/50off<http://sprint.com/50off> for details.