Subject: RE: [Monami6] a question about Analysis of Multihoming in Mobile IPv6

From: "Soliman, Hesham" <[email-masked]>
Date: Wed, 19 Apr 2006 11:30:57 -0700

> 
 > In my opinion, i think it's to say that some/all interfaces 
 > of a MN may have
 > the same HA and HoA. For instance, you can image a MN have 
 > both WLAN and
 > WCDMA interface, and the WLAN and WCDMA access services are 
 > both provided by
 > the same Operator. Thus the MN's interface on the WLAN and 
 > interface on the
 > WCDMA network may use the same HA and HoA provided by the 
 > same Operator. 

=> Correction, there is no link between the operator and the HoA
or the HA. whether different access networks belong to the same operator
or not, is not relevant to the number of HoAs that a MN might have. 

To answer the original question, IPv6 allows any node to have multiple
addresses and associate them with the same interface. So whether the MN
has one HoA or several makes no statement about the number of interfaces

that it has. 

Hesham

An
 > other scenario is that no matter how many access 
 > capabilities the MN has,
 > the Mobile IP, as a service, is provided by one operator.
 > Any way, the key point is that multiple interfaces only 
 > imply that the MN
 > has multiple CoA on each interface( if the interface is 
 > active), not the
 > HoA.
 > 
 > 
 > -----Original Message-----
 > From: Sam Xia [mailto:[email-masked]] 
 > Sent: Friday, April 14, 2006 3:42 PM
 > To: [email-masked]
 > Subject: [Monami6] a question about Analysis of Multihoming 
 > in Mobile IPv6
 > 
 > 
 > Hello, everyone,
 >           I am confused about a sentence in Analysis of 
 > Multihoming in
 > Mobile IPv6. 
 > The sentence is "The fact that a mobile node has multiple 
 > interfaces does
 > not 
 > imply that it has multiple HoAs and vice-versa" and located 
 > at the last
 > paragragh on page 10.
 >           I think one interface should have a corresponding 
 > address or more.
 > So, if a mobile node is in its home, each of its interfaces 
 > has a address at
 > least.
 > 
 > Anyone can give me the detailed explaination or a scenario? Thanks.
 > 
 > 
 > 
 > _______________________________________________
 > Monami6 mailing list
 > [email-masked]
 > https://www1.ietf.org/mailman/listinfo/monami6
 > 
 > 
 > _______________________________________________
 > Monami6 mailing list
 > [email-masked]
 > https://www1.ietf.org/mailman/listinfo/monami6
 > 

_______________________________________________
Monami6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/monami6

---

From: marcelo bagnulo braun <[email-masked]>
Date: Wed, 19 Apr 2006 23:27:11 +0300

Hi Hesham,

> or not, is not relevant to the number of HoAs that a MN might have.

agree, multiple operators in the access network don't affect the number 
of hoas

but, if a MN has multiple HAs served by different ISPs, then it must 
have multiple HoAs, right?

(this would be so, because since it would have different HAs, in 
different Home Networks and since they are served by differetn ISPs, 
they need to use differetn PA blocks)

In other words, the operator of the access netwrok has no influence in 
the number of Hoas, but the ISPs of the HAs/Home networks has a direct 
impact in the number of HoAs, agree?

> has one HoA or several makes no statement about the number of 

indeed, there are other combinations, where there is a single ISP 
serving all the HAs, that may result in multiple HoAs for other 
reasons...

regards, marcelo

---

From: <[email-masked]>
Date: Thu, 20 Apr 2006 06:04:31 +0300

Marcelo,

>impact in the number of HoAs, agree?

I essentially agree with this, with one small comment.  There probably
be some aggregators who provide a HA, aggregating a number of ISPs.

John

---

From: marcelo bagnulo braun <[email-masked]>
Date: Fri, 21 Apr 2006 11:14:20 +0300

> be some aggregators who provide a HA, aggregating a number of ISPs.

I am not sure how this would work...
Are you assuming that there is an address blosk assigned to the 
aggregators?
or the HoAs belong to one of the ISPs address blocks?

regards, marcelo