Subject: Re: [Monami6] a question about Analysis of Multihoming in Mobile IPv6

From: Sam Xia <[email-masked]>
Date: Thu, 20 Apr 2006 10:02:23 +0800

Hi, all,
     Unitl now, I understand the meaning of the sentence for "The fact that
a mobile node has multiple interfaces does not imply that it has multiple
HoAs and vice-versa". But I have some other questions about this.
     In general, it is universal that multiple interfaces share the same one
address or more. But IMHO, the prerequisite is that the multiple interfaces
have the same the attributes about L1 and  L2. For example, as to ethernet
switch (including Cisco, 3Com, Huawei), multiple ethernet interfaces in the
same VLAN share the same IP address(s). I have not seen the fact that
different types of interfaces share the same IP address (I don't think it is
a good idea to have POS interface and ATM interface, or T1/C1 interface and
ethernet interface, or WCDMA interface and WLAN interface share the same IP
address). Can anyone give me the example for this? 
     As a matter of fact, if we do so like this, we will face many issues of
implementing aspect. For example, if different interfaces share the ip
address, then upper layer application will find it difficult to determine
the specific interface from which the packet should be sent. It is because
upper layer application can not specify the outbound interface based on the
service access points(i.e., socket) provided by TCP/UDP. 
    That's all. Thank you for your kind reply.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Thursday, April 20, 2006 12:00 AM
> To: [email-masked]
> Subject: Monami6 Digest, Vol 14, Issue 17
> 
> 
> Send Monami6 mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
> 	https://www1.ietf.org/mailman/listinfo/monami6
> or, via email, send a message with subject or body 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it is more 
> specific than "Re: Contents of Monami6 digest..."
> 
> 
> Today's Topics:
> 
>    1. RE: a question about Analysis of Multihoming in Mobile IPv6
>       (Starry.Lin)
>    2. Re: a question about Analysis of Multihoming in Mobile IPv6
>       (Nicolas Montavont)
>    3. Re: a question about Analysis of Multihoming in Mobile IPv6
>       (Tero Kauppinen (JO/LMF))
>    4. Re: a question about Analysis of Multihoming in Mobile IPv6
>       (Nicolas Montavont)
>    5. Re: a question about Analysis of Multihoming in Mobile IPv6
>       (Tero Kauppinen (JO/LMF))
>    6. RE: a question about Analysis of Multihoming in Mobile IPv6
>       (Starry.Lin)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Wed, 19 Apr 2006 10:12:27 +0800
> From: "Starry.Lin" <[email-masked]>
> Subject: RE: [Monami6] a question about Analysis of Multihoming in
> 	Mobile IPv6
> To: [email-masked]
> Cc: 'Monami6 WG' <[email-masked]>
> Message-ID:
> 	
> <!~!UENERkVCMDkAAQACAAAAAAAAAAAAAAAAABgAAAAAAAAArhqnyUIk+02Spx
> AuJMgAAMKAAAAQAAAAUQYzbGaAUEOh/[email-masked]>
> 	
> Content-Type: text/plain; charset=us-ascii
> 
> In my opinion, i think it's to say that some/all interfaces 
> of a MN may have the same HA and HoA. For instance, you can 
> image a MN have both WLAN and WCDMA interface, and the WLAN 
> and WCDMA access services are both provided by the same 
> Operator. Thus the MN's interface on the WLAN and interface 
> on the WCDMA network may use the same HA and HoA provided by 
> the same Operator. An other scenario is that no matter how 
> many access capabilities the MN has, the Mobile IP, as a 
> service, is provided by one operator. Any way, the key point 
> is that multiple interfaces only imply that the MN has 
> multiple CoA on each interface( if the interface is active), 
> not the HoA.
> 
> 
> -----Original Message-----
> From: Sam Xia [mailto:[email-masked]] 
> Sent: Friday, April 14, 2006 3:42 PM
> To: [email-masked]
> Subject: [Monami6] a question about Analysis of Multihoming 
> in Mobile IPv6
> 
> 
> Hello, everyone,
>           I am confused about a sentence in Analysis of 
> Multihoming in Mobile IPv6. 
> The sentence is "The fact that a mobile node has multiple 
> interfaces does not 
> imply that it has multiple HoAs and vice-versa" and located 
> at the last paragragh on page 10.
>           I think one interface should have a corresponding 
> address or more. So, if a mobile node is in its home, each of 
> its interfaces has a address at least.
> 
> Anyone can give me the detailed explaination or a scenario? Thanks.
> 
> 
> 
> _______________________________________________
> Monami6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/monami6
> 
> 
> 
> 
> ------------------------------
> 
> Message: 2
> Date: Wed, 19 Apr 2006 10:04:19 +0200
> From: Nicolas Montavont <[email-masked]>
> Subject: Re: [Monami6] a question about Analysis of Multihoming in
> 	Mobile IPv6
> To: Monami6 WG <[email-masked]>
> Cc: [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> 
> Hi,
> 
> Starry.Lin wrote:
> 
> >In my opinion, i think it's to say that some/all interfaces 
> of a MN may 
> >have the same HA and HoA. For instance, you can image a MN have both 
> >WLAN and WCDMA interface, and the WLAN and WCDMA access services are 
> >both provided by the same Operator. Thus the MN's interface 
> on the WLAN 
> >and interface on the WCDMA network may use the same HA and 
> HoA provided 
> >by the same Operator. An other scenario is that no matter how many 
> >access capabilities the MN has, the Mobile IP, as a service, is 
> >provided by one operator. Any way, the key point is that multiple 
> >interfaces only imply that the MN has multiple CoA on each 
> interface( 
> >if the interface is active), not the HoA.
> >  
> >
> This is a good interpretation of the sentence.
> A MN may have multiple interfaces (possibly bound to multiple 
> CoAs), and 
> ony one HoA.
> 
> Nicolas
> 
> >
> >-----Original Message-----
> >From: Sam Xia [mailto:[email-masked]]
> >Sent: Friday, April 14, 2006 3:42 PM
> >To: [email-masked]
> >Subject: [Monami6] a question about Analysis of Multihoming 
> in Mobile IPv6
> >
> >
> >Hello, everyone,
> >          I am confused about a sentence in Analysis of 
> Multihoming in 
> >Mobile IPv6. The sentence is "The fact that a mobile node 
> has multiple 
> >interfaces does not
> >imply that it has multiple HoAs and vice-versa" and located 
> at the last
> >paragragh on page 10.
> >          I think one interface should have a corresponding 
> address or more.
> >So, if a mobile node is in its home, each of its interfaces 
> has a address at
> >least.
> >
> >Anyone can give me the detailed explaination or a scenario? Thanks.
> >
> >
> >
> >_______________________________________________
> >Monami6 mailing list
> >[email-masked] https://www1.ietf.org/mailman/listinfo/monami6
> >
> >
> >_______________________________________________
> >Monami6 mailing list
> >[email-masked] https://www1.ietf.org/mailman/listinfo/monami6
> >  
> >
> 
> 
> 
> 
> ------------------------------
> 
> Message: 3
> Date: Wed, 19 Apr 2006 11:08:12 +0300
> From: "Tero Kauppinen (JO/LMF)" <[email-masked]>
> Subject: Re: [Monami6] a question about Analysis of Multihoming in
> 	Mobile IPv6
> To: Monami6 WG <[email-masked]>
> Cc: [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> 
> Starry.Lin wrote:
> 
> > Any way, the key point is that multiple interfaces only 
> imply that the 
> > MN has multiple CoA on each interface( if the interface is active), 
> > not the HoA.
> >
> 
> I don't understand the part "multiple interfaces only imply 
> that the MN 
> has multiple CoAs on each interface". I think it should say "multiple 
> (active) interfaces only imply that the MN has multiple CoAs. Each 
> interface can have one or more CoAs (if the interface is active)." 
> Moreover, the MN can have more than one HoA despite the number of 
> interfaces (i.e. multihomed).
> 
> -- 
> Tero
> 
> 
> 
> ------------------------------
> 
> Message: 4
> Date: Wed, 19 Apr 2006 10:16:45 +0200
> From: Nicolas Montavont <[email-masked]>
> Subject: Re: [Monami6] a question about Analysis of Multihoming in
> 	Mobile IPv6
> To: Monami6 WG <[email-masked]>
> Cc: [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> 
> Tero Kauppinen (JO/LMF) wrote:
> 
> > Starry.Lin wrote:
> >
> >> Any way, the key point is that multiple interfaces only imply that
> >> the MN
> >> has multiple CoA on each interface( if the interface is 
> active), not the
> >> HoA.
> >>
> >
> > I don't understand the part "multiple interfaces only imply that the
> > MN has multiple CoAs on each interface". I think it should say 
> > "multiple (active) interfaces only imply that the MN has 
> multiple CoAs.
> 
> Agree, but this is the text of Starry. Did you find something 
> like this 
> in the draft?
> 
> > Each interface can have one or more CoAs (if the interface is
> > active)." Moreover, the MN can have more than one HoA despite the 
> > number of interfaces (i.e. multihomed).
> 
> This is what we wanted to say with the sentence mentioned in 
> an earlier 
> email:
> 
> "The fact that a mobile node has multiple interfaces does not 
> imply that 
> it has multiple HoAs and vice-versa"
> 
> Nicolas
> 
> 
> 
> ------------------------------
> 
> Message: 5
> Date: Wed, 19 Apr 2006 11:26:35 +0300
> From: "Tero Kauppinen (JO/LMF)" <[email-masked]>
> Subject: Re: [Monami6] a question about Analysis of Multihoming in
> 	Mobile IPv6
> To: Monami6 WG <[email-masked]>
> Cc: [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> 
> Nicolas Montavont wrote:
> >> I don't understand the part "multiple interfaces only 
> imply that the
> >> MN has multiple CoAs on each interface". I think it should say 
> >> "multiple (active) interfaces only imply that the MN has 
> multiple CoAs.
> > 
> > Agree, but this is the text of Starry. Did you find something like 
> > this
> > in the draft?
> 
> Nope, I was just referring to Starry's sentence.
> 
> > This is what we wanted to say with the sentence mentioned in an 
> > earlier
> > email:
> > 
> > "The fact that a mobile node has multiple interfaces does not imply 
> > that
> > it has multiple HoAs and vice-versa"
> > 
> 
> Sure, I don't have problems in understanding the sentence, 
> but maybe it 
> should be written a little bit differently if some people find it 
> confusing.
> 
> Cowardly escaping without posting a proposal...
> Tero
> 
> 
> 
> ------------------------------
> 
> Message: 6
> Date: Wed, 19 Apr 2006 17:08:26 +0800
> From: "Starry.Lin" <[email-masked]>
> Subject: RE: [Monami6] a question about Analysis of Multihoming in
> 	Mobile IPv6
> To: 'Monami6 WG' <[email-masked]>
> Cc: [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=ISO-8859-1
> 
> Thanks Tero's comments. I agree that his expression is more 
> exactly. Each interface can have more than one CoA(also in 
> most condition, there is one). And what's more, the MN can 
> have more than one HoA if there are more than one prefix on 
> the link, even if the MN is not multihoming.
> 
> 
> 
> -----Original Message-----
> From: Tero Kauppinen (JO/LMF) [mailto:[email-masked]] 
> Sent: Wednesday, April 19, 2006 4:08 PM
> To: Monami6 WG
> Cc: [email-masked]
> Subject: Re: [Monami6] a question about Analysis of 
> Multihoming in Mobile IPv6
> 
> 
> Starry.Lin wrote:
> 
> > Any way, the key point is that multiple interfaces only 
> imply that the 
> > MN has multiple CoA on each interface( if the interface is active), 
> > not the HoA.
> >
> 
> I don't understand the part "multiple interfaces only imply 
> that the MN 
> has multiple CoAs on each interface". I think it should say "multiple 
> (active) interfaces only imply that the MN has multiple CoAs. Each 
> interface can have one or more CoAs (if the interface is active)." 
> Moreover, the MN can have more than one HoA despite the number of 
> interfaces (i.e. multihomed).
> 
> -- 
> Tero
> 
> _______________________________________________
> Monami6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/monami6
> 
> 
> 
> 
> ------------------------------
> 
> _______________________________________________
> Monami6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/monami6
> 
> 
> End of Monami6 Digest, Vol 14, Issue 17
> ***************************************
> 

_______________________________________________
Monami6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/monami6

---

From: marcelo bagnulo braun <[email-masked]>
Date: Fri, 21 Apr 2006 11:13:10 +0300

Hi Sam,

> address,

but you seem to imply from the fact that a node has a single HoA and 
multiple interfaces that the HoA is associated with the multiple 
interfaces, as if the Hoa was idrectly assigned to the multiple 
interfaces, but i am not sure this is the case...

i mean the HoA is both a identifier and a locator. As a locator, the 
HoA is assigned to a single interface i guess, to the interface that is 
used to connect to the home network ( i am assuming that in the common 
case, the multohomed node will have differetn technologies that it uses 
to obtain connectivity through different access technologies, but only 
one technology is used to connect to the home network)

However, as an identifier the HoA is associated to the MN as a whole, 
so it can be bound to CoAs that belong to different interfaces.

So, in this case, is not the HoA that is assigned to the differetn 
interfaces, but the HoA is associated with CoAs of different 
interfaces.

Regards, marcelo

> then upper layer application will find it difficult to determine