Subject: RE: [Monami6] Accept draft-wakikawa-mobileip-multiplecoa-04.txtas Monami6 WG Document

From: "KLAMM Frederic RD-CORE-CAE" <[email-masked]>
Date: Mon, 10 Apr 2006 09:59:34 +0200

Hi Ryuji,
I understand that having only one CoA per interface is an implementation choice, and that the MCoA draft is to allow several CoA per interface.
Therefore, wouldn't it be worth enlarging formally the scope of the spec by adding in 5.1 :
 
"  There are two cases when a mobile node has several Care-of Addresses:

   1.  A mobile node uses several physical network interfaces and
       acquires a Care-of Address on each of its interfaces.

   2.  A mobile node uses a single physical network interface, but
       multiple prefixes are announced on the link the interface is
       attached to.  Several global addresses are configured on this
       interface for each of the announced prefixes.	"

A third case, combination of the 2 previous cases, something like :
   
   3.  A mobile node uses several physical network interfaces and 
	several global adresses are configured on at least one of these interfaces.	"

Fred 

> -----Message d'origine-----
> De : [email-masked] 
> [mailto:[email-masked]] De la part de Nicolas Montavont
> Envoyé : lundi 31 octobre 2005 17:54
> À : Ryuji Wakikawa
> Cc : Monami6 WG
> Objet : Re: [Monami6] Accept 
> draft-wakikawa-mobileip-multiplecoa-04.txtas Monami6 WG Document
> 
> Ryuji,
> 
> On 31 oct. 05, at 16:08, Ryuji Wakikawa wrote:
> 
> > Hi NIcolas
> >
> > On 2005/10/31, at 19:15, Nicolas Montavont wrote:
> >
> >
> >> Hi Ryuji,
> >>
> >> ...
> >>
> >>
> >>
> >>>> 3. I dont understand the need for a BID. the draft says
> >>>>
> >>>>
> >>>>
> >>>>
> >>>>>          The BID is an identification number used to distinguish
> >>>>>          multiple bindings registered by the mobile node.   
> >>>>> Assignment of
> >>>>>          distinct BID allows a mobile node to register 
> multiple  
> >>>>> binding
> >>>>>          cache entries for a given home address.
> >>>>>
> >>>>>
> >>>>>
> >>>>
> >>>> doesnt the HoA/CoA pair uniquely identify a binding?
> >>>> do you want a unique identifier for a particular
> >>>> binding even when the CoA changes? in that case why
> >>>> not associate the interface with a particular binding?
> >>>> maybe I am missing something.
> >>>>
> >>>>
> >>>>
> >>>
> >>> How do you express interface in MIP6 stack? Do you suggest the  
> >>> use of
> >>> name like "en0"?:-)
> >>> BID can be an interface index which most of 
> implementation uses for
> >>> interface management.  That's why we use 16bits length for
> >>> BID. (interface index is mostly 16bits)
> >>>
> >>> In our system, we bind BID with network interface. We define
> >>> well-known BID which express intereface like wifi, 
> ethernet, Ev-Do,
> >>> etc. (This is not in the draft though).
> >>>
> >>>
> >>
> >> I am not sure I follow you here. Do you mean that you consider to  
> >> have only one binding HoA/CoA per interface?
> >>
> >
> > Do you consider the case when multiple CoAs are assigned to an  
> > interface?
> > Sure. That's possible with the current MCOA draft.
> 
> Yes, that's what I meant.
> 
> >
> > The above example is just example of our system.
> > In our system, the interface only has one CoA per interface.
> 
> Ok if it's an implementation choice.
> However, I think we should allow several CoAs per interface 
> in the spec.
> 
> Nicolas
> 
> >
> > ryuji
> >
> >
> >> Thanks,
> >>
> >> Nicolas
> >>
> >>
> >>
> >>>
> >>>
> >>> ryuji
> >>>
> >>> _______________________________________________
> >>> Monami6 mailing list
> >>> [email-masked]
> >>> https://www1.ietf.org/mailman/listinfo/monami6
> >>>
> >>>
> >>>
> >>
> >>
> >
> 
> 
> _______________________________________________
> Monami6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/monami6
> 

_______________________________________________
Monami6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/monami6

---

From: Vincent Jardin <[email-masked]>
Date: Mon, 10 Apr 2006 14:22:27 +0200

Hi,

When you have many addresses (prefixes) on the same interface, you need 
to define an heuristic to select the source address of the packets.

Regards,
   Vincent