Subject: RE: [Monami6] using MH is not a magic "re-use"

From: "Tsirtsis, George" <[email-masked]>
Date: Tue, 14 Nov 2006 06:57:41 -0800

Alex,

Static configuration of prefixes is only one way. Routing protocols,
Prefix Delegation and other mechanisms are also possible, in which case
the HA does not have prior knowledge of such things.

In any case, what is it that you are proposing exactly?

George

> -----Original Message-----
> From: Alexandru Petrescu [mailto:[email-masked]]
> Sent: Tuesday, November 14, 2006 9:45 AM
> To: Monami6 WG
> Cc: Soliman, Hesham
> Subject: Re: [Monami6] using MH is not a magic "re-use"
> 
> Tsirtsis, George wrote:
> > Having missed the MONAMIv6 meeting I am trying to decipher the
> > discussion on the mailing list only so I might be missing some
> > context.
> >
> > The MR already does work on behalf of the LFN and other nodes in
> > the mobile network. If this work is done based on static
> > configuration then, the same can be done for moving flows.
> 
> How would HA statically configure information about applications
> running on LFNs?  HA does statically configure 'authorization'
> information about MR's HoA and MNP.
> 
> > It is obvious that if the MR does not know what to do, it will not
> > do anything.
> 
> MR shouldn't do anything about LFN's IP address (shouldn't include it
> in flow bindings) unless LFN or HA auhtorized MR to do so.
> 
> Alex
> 
> 
> _______________________________________________
> Monami6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/monami6

_______________________________________________
Monami6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/monami6

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 14 Nov 2006 16:27:20 +0100

Tsirtsis, George wrote:
> Alex,
> 
> Static configuration of prefixes is only one way. Routing
> protocols, Prefix Delegation and other mechanisms are also
> possible, in which case the HA does not have prior knowledge of
> such things.

(Routing protocols do not distribute in any way prefixes to be
assigned, while DHCP does.)

How do you see DHCP assign addresses and flow preferences to LFN such
that MR is authorized to do flow bindings for LFN's IP address?  MR
snooping the DHCP allocation?  MR allocating to LFN?  These are
unknowns.  HEsham seemed to say out of scope - but without it flow
bindings on MR about LFN's IP address are not possible.

> In any case, what is it that you are proposing exactly?

Without a proper mechanism for LFN to delegate authorization to MR
about its preferences MR has no possibility to do flow bindings for an
LFN - in which case one can't say that flow bindings are for MR,
they're only for MH, no NEMO.

I don't think I'm proposing any other thing than keep flow bindings in
the context of MH only, not for MR.

I certainly don't want the MR to make a decision on its own about
which apps on which interfaces to use, when those apps run on LFNs.
Its LFN who's in charge of its apps.

Alex