Subject: [Mpls-interop] mpls oam channels

From: Loa Andersson <[email-masked]>
Date: Mon, 31 Mar 2008 10:26:46 +0200

All,

since the OAM communication MEP to MIP and MEP to MEP is
discussed in the solutions space anyway, I couldn't refrain
from presenting how it would be done within the existing
MPLS architecture. The strength of this model is that it
leaves the forwarding (silicon) unchanged.

The included slides are a bit "raw" since I didn't have to
much time to complete them. I've used a model to describe
MPLS forwarding that focuses on between hops rather than
the LSRs, hope that is not to confusing. Basically the
idea here is that the OAM channel is carried within in the
transport tunnel.

I'm happy to have comments and questions.

/Loa

-- 
Loa Andersson

Principal Networking Architect
Acreo AB                           phone:  +46 8 632 77 14
Isafjordsgatan 22                  mobile: +46 739 81 21 64
Kista, Sweden                      email:  [email-masked]
                                            [email-masked]
_______________________________________________
Mpls-interop mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-interop

---

From: David Ward <[email-masked]>
Date: Mon, 31 Mar 2008 10:50:16 -0500

Loa -

in your slide #2

In -05 you see a label stack proposal for PHP, do you agree with it?

in your slides 3-11

do you think the TTL explanation in -05  needs improvement? I've  
added a MEP-MIP lblstack example soon to be in a -06

-DWard

On Mar 31, 2008, at 3:26 AM, Loa Andersson wrote:

> [email-masked]<oam.ppt>_______________________________________________

---

From: Loa Andersson <[email-masked]>
Date: Mon, 31 Mar 2008 18:07:42 +0200

David,

> In -05 you see a label stack proposal for PHP, do you agree with it?

well - for what is there for L3 and multi-service I mostly agree

I don't agree with the statement on page 55 that we can't use PHP
in the transport profile, I guess that the reverse is true, if we
want a reliable mechanism we need to use it

> 
> in your slides 3-11
> 
> do you think the TTL explanation in -05  needs improvement?

well - I don't think it is the explanation that needs improvement,
it is more that the method is a hack and should be avoided

> I've added a 
> MEP-MIP lblstack example soon to be in a -06

PHP? or TTL?

/Loa

-- 
Loa Andersson