Subject: Re: [Mpls-interop] [Jwt] RE: Draft report of the ad hoc on T-MPLS - put on hold vs. terminate

From: Loa Andersson <[email-masked]>
Date: Fri, 28 Nov 2008 17:23:38 +0100

All,

a front post only!

English is not my native language (as sometimes is obvious),

However *terminate* mean "cause something to stop"!
*On hold* means "taking a pause".

I don't understand why we want muddle the water. I'd
like to keep the text as it was.

We agreed to terminate *the work* on T-MPLS!

We didn't in detail discuss the status of the existing *in force*
Recommendations, if people now want to put these documents *on hold*.
I assume that there is such a possibility, since the proposal
seems to come from people from the ITU-T side of the house, this
would be fine with me. How do we do it? I assume that we need to
add some text to the Recommendations in such a way that it is
obvious to any reader.

I hope that there is no one that want to *put the T-MPLS work
on hold* since this would definitively  negate the jwt agreement.

/Loa

Malcolm Betts wrote:
> Huub, thank you for your comments please see in line below - my
> responses are marked with <MB> <MB end>. 
> 
> 
> Malcolm Betts
> Nortel Networks
> Phone: +1 613 763 7860 (ESN 393)
> email: [email-masked]
> 
> 
> -----Original Message-----
> From: Huub van Helvoort [mailto:[email-masked]] 
> Sent: Thursday, November 27, 2008 1:43 PM
> To: Betts, Malcolm (CAR:X632)
> Cc: [email-masked]; [email-masked]; David Ward;
> [email-masked]; [email-masked]
> Subject: Re: Draft report of the ad hoc on T-MPLS
> 
> Hi Malcolm,
> 
> You replied:
> 
>> Huub, just to clarify the reason for the late arrival and version 
>> number.
>>
>> I delayed preparing this until after IETF 73 (last week) so that we 
>> could provide the latest status. v01 - v03 were exchanged only between
> 
>> myself and Dave (as the co chairs/authors).  I did not produce v01 
>> until Tuesday afternoon so the turn round was quite rapid.
> 
> Thank you for the clarification.
> I had already assumed that you were busy, as we all are.
> 
>> Please note that the final section is proposals from the co chairs - 
>> it is not conclusions - or the opinion of the whole ad hoc/JWT, its 
>> just the opinion of the co chairs.
> 
> OK, please mention this explicitly during the presentation.
> <MB>
> OK no problem
> <MB end>
> 
> So here are my concerns:
> ------------------------
> Under the item *Recommendation* in the draft the bullet:
> @ Terminate the work on current T-MPLS
> 
> The word *terminate* is interpreted in different ways by different
> experts. It is interpreted as *depreciated* i.e.
> totally discarded, and also as *put-on-hold* meaning further development
> will be part of the integration process and includes the alignment with
> MPLS-TP work.
> 
> I support the latter interpretation and suggest that if there is
> agreement it should be documented.
> 
> <MB>
> See my response to Italo - I have added after "terminate" (i.e. put on
> hold) I hope this avoids any possible mis interpretation and makes it
> clear that this is not a change from the agreement in the JWT.
> <MB end> 
> 
> ----------------------
> Under the item *Proposal from the co chairs*
> 
> The first bullet looks like a summary of the JWT agreement, but as may
> happen with summaries some information may be lost and when the summary
> is summarised by others more information may disappear, depending on the
> interpretation of the copier.
> It would have been better to copy the original or only reference it.
> <MB>
> I did not want to copy 3-4 pages - I hope the modification that I
> proposed in my response to Italo covers this point.
> <MB end>
> 
> The second bullet *rename the ad hoc*.
> Are you proposing to rename the name of the team and use that name from
> now on?
> Or do we have to trace back all references to the team and rename,
> including mailing lists?
> Why not align the renaming (in time) with the agreed renaming of all
> ITU-T documents.
> <MB>
> The intention is that the new name (if agreed) will be used as of the
> start of the SG 15 meeting (December 1st) since we are now working on
> MPLS-TP.
> <MB end>
> 
> The third bullet *change question text*.
> This can again be aligned in time with the the renaming of all ITU-T
> documents.
> <MB>
> Please see my response to Italo.
> <MB end>
> 
> The fourth bullet *terminate work*.
> As I propose in my first concern replace *terminate* by *put-on-hold*.
> All rapporteurs in SG15 are aware of the agreement and will take care
> that no changes take place until the alignment process starts.
> <MB>
> See above I have added (i.e. put on hold) to make it clear that this is
> no change to the agreement in the JWT.
> <MB end> 
> 
> The fifth bullet *add note or implementers guide*.
> This will require time from ITU-T experts, time that would be spend
> better to develop MPLS-TP and start aligning ASAP.
> Once the alignment starts the note or mplementors guide have to be
> removed again anyway so the time spent on these is really wasted. And
> due to the current budget situation time is precious these days.
> <MB>
> I fully agree with the response from Stewart Bryant:
> "Time is indeed precious, but this note will fortunately only need to be
> very short.
> 
> Better that we give up a lunchtime to craft it, than others use their
> time carefully reading, or much worse implementing, a specification that
> we failed to inform them was in a state of flux."
> 
> <MB end>
> 
> Best regards, Huub.
> 
>> I will wait a few hours for additional comments before responding to 
>> the detailed comments from Italo.
>>
>> Malcolm Betts
>> Nortel Networks
>> Phone: +1 613 763 7860 (ESN 393)
>> email: [email-masked]
>>
>> -----Original Message-----
>> From: Huub van Helvoort [mailto:[email-masked]]
>> Sent: Thursday, November 27, 2008 4:43 AM
>> To: Betts, Malcolm (CAR:X632)
>> Cc: [email-masked]; [email-masked]; David Ward; 
>> [email-masked]; [email-masked]
>> Subject: Re: Draft report of the ad hoc on T-MPLS
>>
>> Hello Malcolm,
>>
>> You wrote:
>>
>>> All attached is a draft of the co-chairs report on the work of the 
>>> JWT
>>> and the ad hoc on T-MPLS.  The bulk of the material is an overview of
> 
>>> the work to date.
>> It is important to show the ITU-T experts the status of the work.
>>
>>> The TD also includes some proposals (from the co
>>> chairs) on the future direction of work in the ITU-T and the ad hoc 
>>> group.
>> Even though this is already v004 of the document, it is the first time
> 
>> I see it even though I am member of the JWT.
>>
>> I am aware that we all have a very busy schedule preparing for the 
>> SG15 meeting and some of us were very busy during the
>> IETF73 meeting last week.
>> At a first glance I am concerned with some of the conclusions and hope
> 
>> I can find time to respond properly.
>>
>> Regards, Huub.
>>
>>> The current plan is to introduce this document during the WP 3 
>>> plenary
>>> on Monday December 1st.  If you have any comments or concerns please 
>>> contact myself and Dave, I plan to submit the final version of the TD
> 
>>> on Sunday afternoon.
>>>
>>> <<T-MPLS ad hoc report-v004.doc>>
>>>
>>> Malcolm Betts
>>> Nortel Networks
>>> Phone: +1 613 763 7860 (ESN 393)
>>> email: [email-masked]
> 
> --
> ================================================================
> Always remember that you are unique...just like everyone else...
> _______________________________________________
> Jwt mailing list
> [email-masked]
> http://mail.testbed.se/mailman/listinfo/jwt

-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Redback Networks                      phone: +46 8 632 77 14
An Ericsson Company
_______________________________________________
Mpls-interop mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-interop

---

From: "BUSI ITALO" <[email-masked]>
Date: Fri, 28 Nov 2008 19:44:33 +0100

Loa,

We agreed to terminate *the work* on *current* T-MPLS!

Terminate means not to move forward. It does not mean to move backward.

Italo

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Loa Andersson
> Sent: Friday, November 28, 2008 5:24 PM
> To: Malcolm Betts
> Cc: [email-masked]; TROWBRIDGE Steve; 
> [email-masked]; [email-masked]; MEAD team
> Subject: Re: [Mpls-interop] [Jwt] RE: Draft report of the ad 
> hoc on T-MPLS - put on hold vs. terminate
> 
> All,
> 
> a front post only!
>

---

From: Thomas Walsh <[email-masked]>
Date: Fri, 28 Nov 2008 13:51:27 -0500

Loa,

As I mentioned we need to clearly identify the status of the "in force"
Recommendations to the industry because they are incompatible today with
IETF MPLS specifications.  Putting them on hold, which I have no idea
what that means, doesn't do that.

Since we are being constantly reminded these are "in force"
recommendations, let's understand their status and what guidance ITU-T
is giving the industry-at-large on these (not just to ITU-T
participants).  

Tom

> From: [email-masked]
[mailto:[email-masked]]
> On Behalf Of Loa Andersson
> Sent: Friday, November 28, 2008 11:24 AM
> To: Malcolm Betts
> Cc: [email-masked]; [email-masked]; yoichi.maeda@ntt-
> at.co.jp; [email-masked]; MEAD team
> Subject: Re: [Mpls-interop] [Jwt] RE: Draft report of the ad hoc on
T-MPLS
> - put on hold vs. terminate
> 
> All,
> 
> a front post only!
>

---

From: Huub van Helvoort <[email-masked]>
Date: Fri, 28 Nov 2008 20:37:23 +0100

Hej Loa,

> English is not my native language (as sometimes is obvious),

English is also not my native language (as I have been told
already in the past).

> *On hold* means "taking a pause".

How would you describe the situation when a development is
halted (put in the freezer as we say in the Netherlands, to
avoid any movement) and after some time when development can
continue based on conclusions/agreements reached in the meantime?

The "terminator" (even though he is also not native english)
also claimed *I'll be back*.

> like to keep the text as it was.

And leave it open to misinterpretation as is clearly
demonstrated.

> We agreed to terminate *the work* on T-MPLS!

My understanding was that development of T-MPLS is halted
and will continue when it can be aligned with MPLS-TP.

> add some text to the Recommendations in such a way that it is

It can be achieved by *NOT accepting* any revisions, amendments
or corrigenda until this is mutually agreed.

> on hold* since this would definitively  negate the jwt agreement.

 From my POTS background: an operator can put a call "on-hold"
until she/he has been able to make the requested connection.

Regards, Huub.

                   http://www.van-helvoort.eu/

---

From: Loa Andersson <[email-masked]>
Date: Fri, 28 Nov 2008 22:05:11 +0100

> continue based on conclusions/agreements reached in the meantime?

I would very likely use the term "on hold", and certainly not
"terminate". Please note that the JWT report uses "terminate"
for the very reason that it don't describe the situation you are
outlining!
> also claimed *I'll be back*.

Is this a statement that you plan to bring T-MPLS back?

/Loa

--

---

From: Loa Andersson <[email-masked]>
Date: Fri, 28 Nov 2008 22:19:57 +0100

Italo,

> We agreed to terminate *the work* on *current* T-MPLS!

so you are actully saying that you will be back and do work
on next gen T-MPLS???

> 
> Terminate means not to move forward.

no - that is incorrect not moving forward is "halt", "terminate" means
end.

It does not mean to move backward.

Who talked about moving backwards!

/Loa

--

---

From: Huub van Helvoort <[email-masked]>
Date: Fri, 28 Nov 2008 23:06:14 +0100

Hi Loa,

You replied:

> "terminate". 

Great, than we understand each other.

> Please note that the JWT report uses "terminate"

I am still convinced that it should be *on-hold* in the  meaning
I described above. And other ITU-T experts have the same opinion.

> Is this a statement that you plan to bring T-MPLS back?

Didn't he come back as governator? So he changed his name
and some of his features and behaviour.

Regards, Huub.

======================

---

From: Loa Andersson <[email-masked]>
Date: Sat, 29 Nov 2008 01:18:02 +0100

Tom,

this is ITU-T processes - I take that what you are saying is there is
no such thing as "on hold" in the ITU-T processes, regardless of that
Huub and Italo been talking very broadly about this "on hold" thing,
my thought was as long as we can do that with a note:
Beware this Recommendation has b e put on hold waiting for the output
from the MPLS-TP work in the IETF.
But if you say there is not such thing as a defined "hold action" where
the status of the document will be captured, then that idea is a no go.

/Loa

--