Subject: [mpls-tp] OPINIONS PLEASE: Preparing MPLS-TP Requirements for last call

From: Ben Niven-Jenkins <[email-masked]>
Date: Thu, 29 Jan 2009 20:28:24 +0000

Colleagues,

In draft-ietf-mpls-tp-requirements-03 I included some definitions for the
following terms: bidirectional path, associated bidirectional path and
unidirectional path.

Follow a comment from Neil and suggestion from Adrian I changed the terms to
bidirectional path, co-routed bidirectional path and unidirectional path (I
have included the definitions I am currently using at the end of this mail).

I saw no further comment on this on the list so wanted to poll people for
opinions before I include them in the draft.

So does anyone object to using the following terms with the associated
definitions and if so could you propose alternative terms, definitions or
text as appropriate to your objection?

Bidirectional path: A path that supports traffic flow in both directions.
The forward and backward directions may or may not follow the same path
(links and nodes) across the network.

Co-routed bidirectional path: A bidirectional path where the forward and
backward directions follow the same path (links and nodes) across the
network.

Unidirectional path: A path that supports traffic flow in only one
direction.

Thanks
Ben

_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 29 Jan 2009 20:32:18 -0000

wfm
A
----- Original Message ----- 
From: "Ben Niven-Jenkins" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, January 29, 2009 8:28 PM
Subject: [mpls-tp] OPINIONS PLEASE: Preparing MPLS-TP Requirements for 
lastcall

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 29 Jan 2009 16:52:04 -0500

And me.

On Thu, Jan 29, 2009 at 3:32 PM, Adrian Farrel <[email-masked]> wrote:
> wfm
> A
> ----- Original Message ----- From: "Ben Niven-Jenkins"
> <[email-masked]>
> To: <[email-masked]>

---

From: Sami Boutros <[email-masked]>
Date: Thu, 29 Jan 2009 13:59:17 -0800

me too.

Sami

---

From: George Swallow <[email-masked]>
Date: Thu, 29 Jan 2009 16:59:43 -0500

Ben -

Looks good.  One small suggestion on Bidirectional path.  You use path to
mean two different things in the definition.  I suggest using route instead
for the second occurrence, i.e...

Bidirectional path: A path that supports traffic flow in both directions.
The forward and backward directions may or may not follow the same route
(links and nodes) across the network.

...George

---

From: "Luyuan Fang (lufang)" <[email-masked]>
Date: Thu, 29 Jan 2009 17:03:13 -0500

Better.
Luyuan 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of George Swallow (swallow)
Sent: 29 January 2009 17:00
To: Ben Niven-Jenkins; [email-masked]
Subject: Re: [mpls-tp] OPINIONS PLEASE: Preparing MPLS-TP Requirements
for last call

Ben -

Looks good.  One small suggestion on Bidirectional path.  You use path
to mean two different things in the definition.  I suggest using route
instead for the second occurrence, i.e...

Bidirectional path: A path that supports traffic flow in both
directions.
The forward and backward directions may or may not follow the same route
(links and nodes) across the network.

...George

On 1/29/09 3:28 PM, "Ben Niven-Jenkins" <[email-masked]>
wrote:

> Colleagues,
> 
> In draft-ietf-mpls-tp-requirements-03 I included some definitions for 
> the following terms: bidirectional path, associated bidirectional path

> and unidirectional path.
> 
> Follow a comment from Neil and suggestion from Adrian I changed the 
> terms to bidirectional path, co-routed bidirectional path and 
> unidirectional path (I have included the definitions I am currently
using at the end of this mail).
> 
> I saw no further comment on this on the list so wanted to poll people 
> for opinions before I include them in the draft.
> 

> definitions and if so could you propose alternative terms, definitions

> or text as appropriate to your objection?
> 
> The forward and backward directions may or may not follow the same 
> path (links and nodes) across the network.
> 
> Co-routed bidirectional path: A bidirectional path where the forward 
> and backward directions follow the same path (links and nodes) across 
> the network.
>

---

From: <[email-masked]>
Date: Fri, 30 Jan 2009 09:03:24 -0000

Looks fine Ben....one minor change we could make if we want to be more
accurate would be to refer to 'this layer network' rather than 'the
network'....that is:

Bidirectional path: A path that supports traffic flow in both
directions.  The forward and backward directions may or may not follow
the same path (links and nodes) across this layer network.
 
Co-routed bidirectional path: A bidirectional path where the forward and
backward directions follow the same path (links 
and nodes) across this layer network.

regards, Neil
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Ben Niven-Jenkins
> Sent: 29 January 2009 20:28
> To: [email-masked]
> Subject: [mpls-tp] OPINIONS PLEASE: Preparing MPLS-TP 
> Requirements for lastcall
> 
> Colleagues,
> 
> In draft-ietf-mpls-tp-requirements-03 I included some 
> definitions for the following terms: bidirectional path, 
> associated bidirectional path and unidirectional path.
> 
> Follow a comment from Neil and suggestion from Adrian I 
> changed the terms to bidirectional path, co-routed 
> bidirectional path and unidirectional path (I have included 
> the definitions I am currently using at the end of this mail).
> 
> I saw no further comment on this on the list so wanted to 
> poll people for opinions before I include them in the draft.
> 
> So does anyone object to using the following terms with the 
> associated definitions and if so could you propose 
> alternative terms, definitions or text as appropriate to your 
> objection?
> 
> The forward and backward directions may or may not follow the 
> same path (links and nodes) across the network.
> 
> Co-routed bidirectional path: A bidirectional path where the 
> forward and backward directions follow the same path (links 
> and nodes) across the network.
> 
> Unidirectional path: A path that supports traffic flow in 
> only one direction.
> 
> Thanks
> Ben
>

---

From: "Annamaria Fulignoli" <[email-masked]>
Date: Fri, 30 Jan 2009 10:15:45 +0100

Hi Ben,
I prefer the definition we agreed at Ipswich last week and reported in ver 03 of the draft. 
Reasons are in Req 31. 

Kind Regards
Annamaria

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ben Niven-Jenkins
Sent: giovedì 29 gennaio 2009 21.28
To: [email-masked]
Subject: [mpls-tp] OPINIONS PLEASE: Preparing MPLS-TP Requirements for lastcall

Colleagues,

In draft-ietf-mpls-tp-requirements-03 I included some definitions for the following terms: bidirectional path, associated bidirectional path and unidirectional path.

Follow a comment from Neil and suggestion from Adrian I changed the terms to bidirectional path, co-routed bidirectional path and unidirectional path (I have included the definitions I am currently using at the end of this mail).

I saw no further comment on this on the list so wanted to poll people for opinions before I include them in the draft.

So does anyone object to using the following terms with the associated definitions and if so could you propose alternative terms, definitions or text as appropriate to your objection?

Bidirectional path: A path that supports traffic flow in both directions.
The forward and backward directions may or may not follow the same path (links and nodes) across the network.

Co-routed bidirectional path: A bidirectional path where the forward and backward directions follow the same path (links and nodes) across the network.

Unidirectional path: A path that supports traffic flow in only one direction.

Thanks
Ben

---

From: "Rolf Winter" <[email-masked]>
Date: Fri, 30 Jan 2009 10:20:49 +0100

Will bidirectional in the case of req 31 not simply be replaced by co-routed bidirectional? (As well as in all the other places where the meaning of the terms changed)

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> Behalf Of Annamaria Fulignoli
> Sent: Freitag, 30. Januar 2009 10:16
> forlastcall
> Behalf Of Ben Niven-Jenkins

---

From: "BUSI ITALO" <[email-masked]>
Date: Fri, 30 Jan 2009 10:39:20 +0100

I agree.

The terminology in -03 version of the draft is more aligned with the behavior of bidirectional and associated unidirectional paths.

A bidirectional path is managed as a single entity: co-routing is implicit by that.

Associated unidirectional paths are two entities, routed independently and associated at the two end-points.

Italo

> [mailto:[email-masked]] On Behalf Of Annamaria Fulignoli
> Sent: Friday, January 30, 2009 10:16 AM
> Subject: Re: [mpls-tp] OPINIONS PLEASE: Preparing MPLS-TP 
> Requirements forlastcall
> 
> Hi Ben,

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Fri, 30 Jan 2009 09:39:34 +0000

Rolf,

You are correct. If we agree to the new terms/definitions I proposed I will
change the wording of requirement 31 and other affected requirements to
reflect the new terms.

Ben

On 30/01/2009 09:20, "Rolf Winter" <[email-masked]> wrote:

> Will bidirectional in the case of req 31 not simply be replaced by co-routed
> bidirectional? (As well as in all the other places where the meaning of the
> terms changed)
>

---

From: Huub van Helvoort <[email-masked]>
Date: Fri, 30 Jan 2009 12:33:29 +0100

All,

I agree with the comments of Annamaria and Italo.

A bidirectional path is intuitively a co-routed path, i.e. passing the
same links and nodes in the network and shares fate.

The addition *associated* makes it bidirectional by associating two
unidirectional paths.

Cheers, Huub.

=====================

-- 
================================================================
                   http://www.van-helvoort.eu/
================================================================
Always remember that you are unique...just like everyone else...
_______________________________________________
mpls-tp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mpls-tp