Subject: [mpls-tp] poll on making draft-sprecher-mpls-tp-oam-analysis-07.txt a working group draft

From: Loa Andersson <[email-masked]>
Date: Sun, 18 Oct 2009 19:49:03 +0200

Working Group,

the authors of draft-sprecher-mpls-tp-oam-analysis-07.txt have
asked that the draft is adopted as an mpls working group document.

This mail starts a two week poll on making the draft a working group
document. Send a mail to the [email-masked] mailing list, indicating
"yes/support" or "no/do not support".

Comments on the content should be sent to the same mailing list with
a different subject line.

The poll ends Fri Oct 30.

Loa and George
MPLS working group co-chairs

-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sun, 18 Oct 2009 13:55:26 -0400

yes/support

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Sun, 18 Oct 2009 22:54:01 +0200

Yes, support

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of ext Loa Andersson
Sent: Sunday, October 18, 2009 7:49 PM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [CCAMP] poll on making
draft-sprecher-mpls-tp-oam-analysis-07.txt a working group draft

Working Group,

Loa and George

-- 

Loa Andersson                         email: [email-masked]
Sr Strategy and Standards Manager            [email-masked]
Ericsson Inc                          phone: +46 10 717 52 13
                                              +46 767 72 92 13
_______________________________________________
CCAMP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ccamp

---

From: Greg Mirsky <[email-masked]>
Date: Sun, 18 Oct 2009 15:34:27 -0700

support

---

From: Yuji Tochio <[email-masked]>
Date: Mon, 19 Oct 2009 08:35:59 +0900

Hi Nurit

One general comment before support:

I ask for adding the clarification of "session" in the analysis draft
-- i.e. what & how "session" is reprensented in mpls-tp architecure
and/or mpls-tp language. since no "session" is defined/described in
mpls-tp-req, fwk, oam-req and oam-fwk.

Good example is in clause 3.1. It says as:
"CC-V can identify misconnections from cross-connections it is
necessary that the tool use network-wide unique
identifiers for the path that is being checked in the session."

Reading at oam-fwk, clause 6.1 says "On-demand CV is based upon
generation of on-demand CV packets that should uniquely identify
the ME that is being checked. The on-demand functionality may be
used to check either an entire ME (end-to-end) or between a MEP to
a specific MIP." (And analysis draft uses "maintenance end-points"
in 3.2 that confuses me more...)

I would like to ask for the clarification if the clause 3.1 in analysis
draft is saying same as in 6.1 of fwk(, for example)

Thanks,
Yuji

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Sun, 18 Oct 2009 20:27:00 -0400

As I said earlier, I do not see the point in bringing this document
forward. I viewed it more as a set of meeting minutes/notes that were held
by the MEAD team, and as such has served its purpose.

    --Tom

-- 
Principal Architect - 21CN Networks

---

From: Greg Mirsky <[email-masked]>
Date: Sun, 18 Oct 2009 18:38:07 -0700

I think that it would be useful and helpful to progress this document as
Informational.

Regards,
greg

On Sun, Oct 18, 2009 at 5:27 PM, Thomas D. Nadeau <[email-masked]> wrote:

> mpls-tp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls-tp
>

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 19 Oct 2009 07:49:52 +0100

Support

- Stewart

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Mon, 19 Oct 2009 09:25:09 +0200

Hi Yuji,
Thanks for reviewing the document. I really appreciate it.
We have been analyzing the requirements draft. We will clarify/change
the term "session" in the next version of the document. Thanks for
bringing this in.
Best regards,
Nurit

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Yuji Tochio
Sent: Monday, October 19, 2009 1:36 AM
To: [email-masked]
Subject: Re: [mpls-tp] poll on making
draft-sprecher-mpls-tp-oam-analysis-07.txt a working group draft

Hi Nurit

Thanks,
Yuji

---

From: Loa Andersson <[email-masked]>
Date: Mon, 19 Oct 2009 12:27:30 +0200

Greg, Tom, (following my own instruction I removed all lists, but
             the mpls-tp mailing list :) ).

The very reason I want to accept this draft as a wg doc is that it
documents a number of decisions that is important for the mpls-tp
work.

I intend to make sure that the authors keeps the draft updated and'
refreshed as things develop, I've currently no intention of
progressing the draft to RFC until (most of) the first wave of the
OAM mpls-tp documents are published as RFCs.

Whether we want to progress it (as Informational) at that time is still
an open issue because of the character of the document, but I see now
harm in documenting why we did certain things.

/Loa

Greg Mirsky wrote:
> On Sun, Oct 18, 2009 at 5:27 PM, Thomas D. Nadeau <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
> 
>     On 10/18/09 1:49 PM, "Loa Andersson" <[email-masked] <mailto:[email-masked]>>
>     wrote:
> 
>      > Working Group,
>      >
>      > document. Send a mail to the [email-masked]
>     <mailto:[email-masked]> mailing list, indicating
>     [email-masked] <mailto:[email-masked]>

--

---

From: Dan Frost <[email-masked]>
Date: Mon, 19 Oct 2009 12:49:32 +0100

Thanks for the clarification, Loa.  However, if this is to be an
evolving working group document, the text (particularly Abstract/Scope
and introductory matter) should be reworked to reflect that, rather than
suggesting it only reports previous conclusions.  Support, provided this
is done.

Cheers,

-d

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 19 Oct 2009 07:51:35 -0400

So then I will ask my question again: Is there an intent by the WG  
chairs to progress this to RFC status? Or is this just a placeholder  
for notes/decisions that could easily be attached to the WG web page  
as a FAQ or something?  We don't publish WG meeting minutes as RFCs  
every meeting, do we?

	--Tom

>> I think that it would be useful and helpful to progress this  
>> document as Informational.
>> Regards,
>> greg
>> On Sun, Oct 18, 2009 at 5:27 PM, Thomas D. Nadeau  
>> <[email-masked] <mailto:[email-masked]>> wrote:

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 19 Oct 2009 07:54:31 -0400

Jonathan,

The question isn't if the document is ready for publication, but
whether the contents should now reflect WG consensus. It's very much
open for any text that you would like to contribute on inter-layer
interactions.

Cheers,
Andy

On Mon, Oct 19, 2009 at 6:22 AM, Sadler, Jonathan B.
<[email-masked]> wrote:
> I agree with Tom that this document seems to be more of a set of meeting minutes/notes.  I don't see any reasoned analysis - just a statement of what is different between the two mechanisms and the requirements along with a recommendation.
>
> The fact no discussion of inter-layer interactions is shown in this document really concerns me as I believe its missing a key difference between the approaches catalogued.
>
> If the document contained reasoned analysis and delt with all issues, I would be able to support it.  But in its current form it is lacking the required substance.
>
> Jonathan Sadler
>
> ________________________________________
> From: [email-masked] [[email-masked]] On Behalf Of Thomas D. Nadeau [[email-masked]]
> Sent: Sunday, October 18, 2009 7:27 PM
> To: Loa Andersson; [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [CCAMP] poll on making draft-sprecher-mpls-tp-oam-analysis-07.txt a working group draft
>
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>

---

From: "Weingarten, Yaacov (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Mon, 19 Oct 2009 13:56:04 +0200

Yes/Support

BR,
Yaacov Weingarten 

-----Original Message-----
Sent: Sunday, October 18, 2009 19:49

Working Group,

Loa and George

--

---

From: Satoru Matsushima <[email-masked]>
Date: Mon, 19 Oct 2009 21:47:18 +0900

I'm trying to understand what the purpose of this poll.

Does this poll to make decision of MPLS-TP OAM solution, or
to make sure a current status of mpls-tp oam considerations?

If it is latter one, first question comes up again what the purpose of  
this poll,
do we need a snapshot of oam consideration as wg document?

--
Satoru Matsushima

---

From: Adrian Farrel <[email-masked]>
Date: Mon, 19 Oct 2009 16:09:10 +0100

Hi Satoru,

I didn't see anyone else answer, so I'll jump in.

> to make sure a current status of mpls-tp oam considerations?

Neither of these.

This poll is to decide whether the MPLS working group wants to adopt this 
draft as a work in progress to be developed further under the care of the 
MPLS working group.

The material questions are:
- is this within the scope of the MPLS working group?
- is there sufficient interest in the broader topic (MPLS-TP)?
- does the working group want to work on a draft that covers
   this subject material?
- is this draft a good starting point for further work?

Thanks,
Adrian

---

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 19 Oct 2009 18:03:57 +0200

Adrian,
I fully agree with you  regarding "four questions" that should be answered when we decide whether an individual draft 
should - or should not - be adopted as a WG draft.

And I do not have any problem with answering "yes" to the first two:
- the draft belongs to MPLS-TP and, as such, is within the scope of the MPLS WG
- MPLS-TP is of some interest to the MPLS WG (or at least to me). BTW, I've added [email-masked] to the CC list.

My problems start with the  remaining two questions:

- Does the WG to work on a draft that covers the  subject material?

  The answer is far from obvious, since the specific subject of the draft is analysis (sometimes inaccurate) of existing OAM tools vs.
  documented MPLS-TP OAM requirements, with some recommendations as to how to develop specific OAM tools.
  We may, of course, continue to work on the analysis (e.g., by fixing the errors in the document) and update some recommendations.
  However, this would not replace actual work on the new OAM tools or extension of the existing ones.

- Is this draft a good enough starting point for further work?
  
  This question assumes that we understand which "further work" we have in mind.
  And this is completely not clear to me, especially when looking at Loa's explanation.
  At least, the usual understanding of "further work" at IETF - to deliver an RFC - seems to be not applicable.
  We have examples of work items that have been adopted as WG documents and eventually published as 
  Informational RFCs while documenting certain status rather than defining some protocols (e.g., 5037 and 5038),
  but I am not sure if  this analogy really holds.
  
  If the objective is to preserve the design team notes, this can be done in many other ways. Just to remind you
  that the "Martini drafts" have never been adopted as WG drafts. This did not prevent Luca from periodically updating
  them in parallel with working on the PWE3 WG documents... And eventually they have been published as Historical RFCs.

I will provide my analysis of specific issues with the draft later in a separate email.

Regards,
     Sasha

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Monday, October 19, 2009 5:09 PM
> To: Satoru Matsushima; Loa Andersson
> Cc: [email-masked]
> Subject: Re: [mpls-tp] poll on 
> makingdraft-sprecher-mpls-tp-oam-analysis-07.txt a working group draft
> 
> Hi Satoru,
>

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Mon, 19 Oct 2009 18:38:16 +0200

Dear Sasha,
I'll appreciate if you can refer to what you believe are errors in the
document. We of course would like to fix them. That is the reason we
solicited many times the group to review and comment. 
The draft gives an overview on the existing mechanisms and tries to
analyze whether they can apply to the requirements, or can be enhanced
to apply to the requirements. It also summarizes the agreements we
reached in the discussions in the design team and the considerations. 
We also know that there are further requirements on the table that are
under discussions and if agreed we will need to extend the document and
analyze them as well.
I hope you can support the adoption of the draft as a WG document/. 
Best regards,
Nurit.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of ext Alexander Vainshtein
Sent: Monday, October 19, 2009 6:04 PM
To: Adrian Farrel
Cc: [email-masked]; [email-masked]
Subject: Re: [mpls-tp] poll on making
draft-sprecher-mpls-tp-oam-analysis-07.txt a working group draft

Adrian,
I fully agree with you  regarding "four questions" that should be
answered when we decide whether an individual draft 
should - or should not - be adopted as a WG draft.

And I do not have any problem with answering "yes" to the first two:
- the draft belongs to MPLS-TP and, as such, is within the scope of the
MPLS WG
- MPLS-TP is of some interest to the MPLS WG (or at least to me). BTW,
I've added [email-masked] to the CC list.

  The answer is far from obvious, since the specific subject of the
draft is analysis (sometimes inaccurate) of existing OAM tools vs.
  documented MPLS-TP OAM requirements, with some recommendations as to
how to develop specific OAM tools.
  We may, of course, continue to work on the analysis (e.g., by fixing
the errors in the document) and update some recommendations.
  However, this would not replace actual work on the new OAM tools or
extension of the existing ones.

  This question assumes that we understand which "further work" we have
in mind.
  And this is completely not clear to me, especially when looking at
Loa's explanation.
  At least, the usual understanding of "further work" at IETF - to
deliver an RFC - seems to be not applicable.
  We have examples of work items that have been adopted as WG documents
and eventually published as 
  Informational RFCs while documenting certain status rather than
defining some protocols (e.g., 5037 and 5038),
  but I am not sure if  this analogy really holds.
  
  If the objective is to preserve the design team notes, this can be
done in many other ways. Just to remind you
  that the "Martini drafts" have never been adopted as WG drafts. This
did not prevent Luca from periodically updating
  them in parallel with working on the PWE3 WG documents... And
eventually they have been published as Historical RFCs.

I will provide my analysis of specific issues with the draft later in a
separate email.

Regards,
     Sasha

---

From: Huub van Helvoort <[email-masked]>
Date: Mon, 19 Oct 2009 23:57:29 +0200

Hello Jonathan,

You wrote:

> I agree with Tom that this document seems to be more of a set of
 > meeting minutes/notes.  I don't see any reasoned analysis - just
 > a statement of what is different between the two mechanisms and
 > the requirements along with a recommendation.

I agree that the draft is not complete and requires more work.

> The fact no discussion of inter-layer interactions is shown in
 > this document really concerns me as I believe its missing a key
 > difference between the approaches catalogued.

The inter-layer interactions have indeed to be added, there were
also comments on the lack of these in the oam-requirements draft,
in this draft they can be addressed before WG last call.

> If the document contained reasoned analysis and delt with all
 > issues, I would be able to support it.  But in its current form it
 > is lacking the required substance.

I appreciate your comments. Regards, Huub.

-- 
================================================================
                   http://www.van-helvoort.eu/
================================================================
Always remember that you are unique...just like everyone else...

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 20 Oct 2009 10:51:18 +0100

I disagree. I believe that it is useful to document the OAM design
decision and that this document is a good starting point.

Remember that the poll is not whether to publish this document
at any particular time, but to accept it as a starting point for
the work of the WG.

As such I think the document is useful, and a good staring point,
which is why I expressed the view that it should become a WG doc.

Stewart

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 20 Oct 2009 10:52:03 +0100

+1

Stewart

Loa Andersson wrote:
>> I think that it would be useful and helpful to progress this document 
>> as Informational.
>>
>> Regards,
>> greg
>>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 20 Oct 2009 08:07:13 -0400

On 10/20/09 5:51 AM, "Stewart Bryant" <[email-masked]> wrote:

> TOM: I do not think anyone was saying it was useless per se.  The issue is
> whether or not it is useful in its current state as a WG document, or even as
> a starting point and being modified later.  The document currently reads as a
> mish-mash of notes on OAM techniques, which surely cannot be a useful starting
> point.  As a starting point, I¹d say it could become a survey on OAM
> techniques going forward, but I¹d ask the WG if it is a) unavailable elsewhere
> in another form and b) if its truly worth spending the WG¹s editorial and
> charter resources on?
> 
>     --Tom
> 
> 
> 
>> I agree with Tom that this document seems to be more of a set of meeting
>> minutes/notes.  I don't see any reasoned analysis - just a statement of what
>> is different between the two mechanisms and the requirements along with a
>> recommendation.
>> 
>> The fact no discussion of inter-layer interactions is shown in this document
>> really concerns me as I believe its missing a key difference between the
>> approaches catalogued.
>> 
>> If the document contained reasoned analysis and delt with all issues, I would
>> be able to support it.  But in its current form it is lacking the required
>> substance.
>> 
>> Jonathan Sadler
>> 
>> Subject: Re: [CCAMP] poll on making
>> On 10/18/09 1:49 PM, "Loa Andersson" <[email-masked]> <mailto:[email-masked]>  wrote:
>> 
>>   
>>  
>>>  
>>> Working Group,
>>>

---

From: <[email-masked]>
Date: Tue, 20 Oct 2009 15:35:06 +0100

Loa, Tom,

It would seem to me that the intended use of the draft is to document
document decisions made and rationale related to MPLS-TP OAM and any new OAM
mechanisms for MPLS-TP are developed. This could be useful to reference back
to if someone (ITU) questions why something was done the way it was. It may
also add some additional transparency and aid with ITU/WG last call comments
etc.

If that's the case then the document could be useful and having it under the
change control of the WG would seem appropriate.

I'm not convinced whether it should actually ever be published but it could
be a helpful tool (I don't know whether a wiki or something is an even
better tool though)

Ben

---

From: Loa Andersson <[email-masked]>
Date: Tue, 20 Oct 2009 17:55:02 +0200

Ben,

thanks you capture very well what I tried to say earlier.

For me it is the important to give the working group the change
control, the only thing that the wg has change control over is
wg drafts and to a lesser extent the charter page (ADs and WG
chairs can take independent actions to the charter page), we
normally have wikis and other web pages to capture more fluid
information.

Whether to publish as a RC or not is still an open issue, but
I guess that we will have a much better understanding for that
when we getting closer to the end of the mpls-tp effort.

Ass a side note, we are not guaranteeing that a document accepted
as a wg document ever will be published as a wg document (though
it admittedly very often is so), we often merge or split documents,
the latest example of that is that we did split the p2mp functionality
out of the mpls-tp framework, into a framework of its own.

/Loa

--

---

From: David Ward <[email-masked]>
Date: Wed, 21 Oct 2009 11:53:10 -0500

Note that if we decide not to take the document in it's current form  
(history of decision making), the data could be incorporated into the  
OAM architecture draft under construction. We don't want to lose the  
information.

-DWard

On Oct 20, 2009, at 4:51 AM, Stewart Bryant wrote:

>> meeting minutes/notes.  I don't see any reasoned analysis - just a  
>> statement of what is different between the two mechanisms and the  
>> requirements along with a recommendation.
>>
>> The fact no discussion of inter-layer interactions is shown in this  
>> document really concerns me as I believe its missing a key

---

From: Satoru Matsushima <[email-masked]>
Date: Thu, 22 Oct 2009 02:11:02 +0900

Hi,

> the data could be incorporated into the OAM
> architecture draft under construction.

I support this.
I think that the analysis document is a supplement to make decision,
it does not
make decision itself. If the analysis document become wg document, I hope
to set the date of completion the analysis.

--
Satoru Matsushima

2009/10/22 David Ward <[email-masked]>:
> (history of decision making), the data could be incorporated into the OAM
> architecture draft under construction. We don't want to lose the
> information.
> -DWard
> If the document contained reasoned analysis and delt with all issues, I
> would be able to support it.  But in its current form it is lacking the
> required substance.
> Jonathan Sadler

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 21 Oct 2009 16:04:07 -0400

I like this idea.

On Oct 21, 2009, at 12:53 PM, David Ward <[email-masked]> wrote:

> (history of decision making), the data could be incorporated into  
> the OAM architecture draft under construction. We don't want to lose  
> the information.
>
> -DWard
>

---

From: Rui Costa <[email-masked]>
Date: Fri, 30 Oct 2009 15:30:20 +0000

"yes/support"	

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Loa Andersson
Sent: domingo, 18 de Outubro de 2009 18:49
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [mpls-tp] poll on making
draft-sprecher-mpls-tp-oam-analysis-07.txt a working group draft

Working Group,

Loa and George

--