Subject: RE: MPLS/BGP routing question

From: Chris Flores <[email-masked]>
Date: Thu, 28 Sep 2000 13:52:04 -0500

that was my point. in this scenario, you would not want to turn BGP off :)

-----Original Message-----
From: Eric Osborne [mailto:[email-masked]]
Sent: Thursday, September 28, 2000 1:32 PM
To: Chris Flores
Cc: 'Javier Antich'; Michel Redondo Ferrero; [email-masked]
Subject: Re: MPLS/BGP routing question

If MPLS breaks, and routing isn't available, then routing wouldn't
occur. :)

Having IP available as a backup path to MPLS is a nice
belt-and-suspenders idea, but there are some services (MPLS VPNs,
circuit transport, etc) that have no way to fall back to a non-MPLS
path.  

eric

On Thu, Sep 28, 2000 at 01:18:27PM -0500, Chris Flores wrote:
> Interesting, then I have the following question. Let's say the transit
> backbone consists of a 3 level hierarchy - core, distribution and access.
> BGP is configured such that the access (or edge) routers are route
reflector
> clients of the distribution routers. Furthermore, the distribution routers
> are route reflector clients of the core routers. As Michel Redondo Ferrero
> has stated, MPLS VPNs originate and terminate on the access or edge of the
> network (in his scenario). Why would you turn off BGP on the core routers?
> What if MPLS breaks or fails for any reason (i.e. software bug). Then, how
> would routing occur?
> 
> Regards.
> 
> chris
> 
> -----Original Message-----
> From: Javier Antich [mailto:[email-masked]]
> Sent: Thursday, September 28, 2000 11:28 AM
> To: Michel Redondo Ferrero
> Cc: [email-masked]
> Subject: RE: MPLS/BGP routing question
> 
> 
> Core Routers do not need to run BGP because they, in practice don't take
> routing decisions with user traffic (I mean traffic comming or going to
> Internet), they just switch frames based on their MPLS label. BGP
decissions
> are made at the edge and packets sent to the BGP next hop through the
> corresponding MPLS LSP.
> 
> 
> 
> 
> 
> Visite nuestro web: http://www.kerndatanet.com/
> <http://www.kerndatanet.com/> 
>                                http://www.telindus.es
> _________________________________________________________________________
> Javier Antich Romaguera.                          KERN DATANET -TELINDUS
> ESPAÑA
> Dpto Pre-Venta.	                                       Torre
Metropolitana
>                                                               Plaza Ciudad
> de Viena, 6 -2º 
>                                                               28040
MADRID.
> (ESPAÑA).
> e-mail: [email-masked] <mailto:[email-masked]>
> TF:  (+34) 91 4560008
> 
> 
> 
> 
> 	-----Mensaje original-----
> 	De:	Michel Redondo Ferrero [SMTP:[email-masked]]
> 	Enviado el:	jueves 28 de septiembre de 2000 8:26
> 	Para:	[email-masked]
> 	Asunto:	MPLS/BGP routing question
> 
> 	Hi,
> 
> 	Considering the next scenario:
> 
> 	-Core and Border routers running IS-IS, MPLS
> 	-VPNs configured in Border routers using BGP/MPLS
> 	-Border routers running BGP with full-routing
> 
> 	The question:
> 	Do Core routers need to run BGP? Is IS-IS enough?
> 
> 	Thanks in advance for your answers.
> 
> 	Michel Redondo Ferrero

---

From: Eric Rosen <[email-masked]>
Date: Thu, 28 Sep 2000 16:11:27 -0400

Chris> that was my  point. in this scenario, you would not  want to turn BGP
Chris> off :) 

I'm afraid you've missed the point.   In the VPN scenario, it doesn't do any
good to  run BGP in the  core, because the IP  header of the  packets do not
contain the information you need to match the packet to its route. 

Besides which you could never hope to hold all routes from all VPNs in every
core router anyway.