Subject: MPLS implementation on Linux

From: Vikas Yadav <[email-masked]>
Date: Tue, 19 Sep 2000 16:43:31 +0530 (IST)

Hi,
Can  someone tell me whether any Linux/ Unix is available and how can one 
go about implementing mpls on Linux box.
thanx in advance

Vikas

---

From: "James R. Leu" <[email-masked]>
Date: Tue, 19 Sep 2000 08:06:20 -0400

There are two MPLS forwarding plane implementations for Linux:
http://www.cl.cam.ac.uk/Research/SRG/netos/netx/code/
http://nero.doit.wisc.edu/mpls-linux/

There is also a portable version of LDP:
http://nero.doit.wisc.edu/mpls-linux/

If your interested in MPLS on FreeBSD check out:
http://www.antd.nist.gov/itg/nistswitch/

-- 
James R. Leu
Software Engineer
Laurel Networks, Inc
[email-masked]

---

From: primus <[email-masked]>
Date: Tue, 19 Sep 2000 13:07:17 +0100

Tue Sep 19 13:06:02 BST 2000

Keir Fraser has provided code which can be found
at:
http://www.cl.cam.ac.uk/Research/SRG/netos/netx/code/mpls-current.tar.gz

His email address is:
	[email-masked]

--
-primus

On Tue, Sep 19, 2000 at 04:43:31PM +0530, Vikas Yadav wrote:
| Hi,
| Can  someone tell me whether any Linux/ Unix is available and how can one 
| go about implementing mpls on Linux box.
| thanx in advance
| 
| Vikas

-- 
primus
IP Network Engineering
Global Crossing

---

From: Rob Jaeger <[email-masked]>
Date: Tue, 19 Sep 2000 11:02:30 -0400 (EDT)

NIST has an MPLS implementation on bsd and i believe soon on Linux.
NISTswitch is multiprotocol label switching (MPLS) research platform.  The
Switch implements quality of service and explicit routing through label
switching. It uses proposed extensions to RSVP to signal QoS requests and
distribute labels.

www.antd.nist.gov

Rob