Subject: RSVP-TE -- TIME_VALUES is optional or mandatory

From: "Hong Liao" <[email-masked]>
Date: Fri, 29 Sep 2000 18:13:13 -0400

Hello,

Can anyone answer my question?

I have question for the latest RSVP-TE 07.txt,

3.1 Path message

<path message>    --     ....
                                            <TIME_VALUES>-------->   This object
is optional in RSVP-TE 06.txt issued   July 2000
But this object is mandatory in RSVP-TE 07.txt issued August 2000

I want to know it is a typing mistakes or not, because only one month, the
structure is changed.

Thanks  in advance.

Julia

---

From: "Sanford, Bill" <[email-masked]>
Date: Fri, 29 Sep 2000 18:39:38 -0400

That is why they are drafts.  The time field is mandatory.

3.1. Path Message

   The format of the Path message is as follows:

      <Path Message> ::=       <Common Header> [ <INTEGRITY> ]
                               <SESSION> <RSVP_HOP>
                               <TIME_VALUES>
                               [ <EXPLICIT_ROUTE> ]
                               <LABEL_REQUEST>
                               [ <SESSION_ATTRIBUTE> ]
                               [ <POLICY_DATA> ... ]
                               <sender descriptor>

-----Original Message-----
From: Hong Liao [mailto:[email-masked]]
Sent: Friday, September 29, 2000 6:13 PM
To: [email-masked]
Subject: RSVP-TE -- TIME_VALUES is optional or mandatory

Hello,

3.1 Path message

<path message>    --     ....
                                            <TIME_VALUES>-------->   This
object
is optional in RSVP-TE 06.txt issued   July 2000
But this object is mandatory in RSVP-TE 07.txt issued August 2000

Thanks  in advance.

Julia