Subject: MPLS/BGP routing question

From: Michel Redondo Ferrero <[email-masked]>
Date: Thu, 28 Sep 2000 07:26:27 +0100

Hi,

Considering the next scenario:

-Core and Border routers running IS-IS, MPLS
-VPNs configured in Border routers using BGP/MPLS
-Border routers running BGP with full-routing

The question:
Do Core routers need to run BGP? Is IS-IS enough?

Thanks in advance for your answers.

Michel Redondo Ferrero

---

From: Curtis Villamizar <[email-masked]>
Date: Fri, 29 Sep 2000 09:23:03 -0400

> Thanks in advance for your answers.

Core routers do not need to run IBGP as long as all external traffic
through them goes through MPLS tunnels.  If there is a full mesh of
MPLS tunnels among routers with EBGP peers then this is the case.  The
only routers that must run IBGP are those that have EBGP peers.  In
rfc2547 speak these are the PE routers.

For example, optical switches will definitely NOT run IBGP with the
Internet routers.  They run an IGP and MPLS (plus LMP) but not BGP.
(In any reasonably sane network).

Curtis

---

From: Bala Rajagopalan <[email-masked]>
Date: Fri, 29 Sep 2000 11:36:22 -0400

Hello,

> (In any reasonably sane network).

Why not E-BGP between OXCs and routers?

Bala
--

Bala Rajagopalan
Tellium, Inc.
2 Crescent Place
P.O. Box 901
Oceanport, NJ 07757-0901
Tel: (732) 923-4237
Fax: (732) 923-9804
Email: [email-masked]