Subject: LDP - Unsupported Address Family

From: [email-masked]
Date: Sat, 23 Sep 2000 20:18:06 +0900

Hi,

I have the following doubt on Address family.
Can any one  pls clarify it.

In draft-ietf-mpls-ldp-11

	2.5.2. Transport Connection Establishment
		 "      - If A1 and A2 are not in the same address family, they are   incomparable, and no session can be established. "

what I understood from the above is , if address families won't match there won't be any session. Am I correct?

But, the status TLV "Unsupported Address Family TLV" says that it is an advisory notification.

What exactly the peer is supposed to do after receing a notifification with Unsupported Address Family status TLV.

thanks in advance

regards
seenu

---

From: Wushao Wen <[email-masked]>
Date: Sat, 23 Sep 2000 09:19:09 -0700 (PDT)

> what I understood from the above is , if address families won't match there won't be any session. Am I correct?
  Yes. LDP sessions can only exist between two match address families LSR.
  
> What exactly the peer is supposed to do after receing a notifification with Unsupported Address Family status TLV.
Since the section has not been set-up yet, so the "unsupported Address
Family TLV" should be regarded as advisory information since it will not
cause any packet forwarding error. After receiving the message, the peer
should just give up the attempt to setup a connection. Correct me if I am
wrong. 

Thanks!

Wushao

---

From: Bob Thomas <[email-masked]>
Date: Sat, 23 Sep 2000 17:27:55 -0400

> 		 "      - If A1 and A2 are not in the same address family,
>                         they are incomparable, and no session can be
>                         established. "
> 
> what I understood from the above is , if address families won't
> match there won't be any session. Am I correct?

Yes.

> What exactly the peer is supposed to do after receing a
> notifification with Unsupported Address Family status TLV.

A number of messages used after a session is established specify an
Address Family; e.g., Address, Address Withdraw, Label Request, Label
Mapping, etc.).

If the receiver of such a message does not support the Address Family
specified by the message it should respond with a Notification message
carrying the Unsupported Address Family Status Code.

Please see Sections "FEC Procedures" and "Address Message Procedures".

Bob