Subject: RE: draft-kompella-mpls-te-mib-00.txt

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 07 Sep 2000 17:15:22 -0400

>I think Tom extended the MIB to support its use at transit LSRs one (or
>two?) versions ago.

         Yes, correct.

         --Tom

---

From: Adrian Farrel <[email-masked]>
Date: Thu, 7 Sep 2000 18:42:22 +0100

Sudhanshu,

As far as I can see there are a few extensions still needed (possibly to the
signaling protocol!) to make this work really smoothly, but it is almost
there.

Adrian
--
Adrian Farrel  mailto:[email-masked]
Network Convergence Group
Data Connection Ltd., Chester, UK
http://www.datcon.co.uk/
Tel: +44 (0) 1244 313440  Fax: +44 (0) 1244 312422

>-----Original Message-----
>From: Sudhanshu Jain [mailto:[email-masked]]
>Sent: Thursday, September 07, 2000 6:34 PM
>To: Arun Viswanathan; [email-masked]; [email-masked]; Thomas D. Nadeau
>Subject: draft-kompella-mpls-te-mib-00.txt
>
>
>Hi Arun,
>
>I am changing the subject line to avoid any confusion with current hot
>discussion on MIB merging. This mail also address the same 
>issue, but to
>avoid any confusion with the other mail.
>
>Please see my inline comments.
>
>----- Original Message -----
>From: "Arun Viswanathan" <[email-masked]>
>To: "'Sudhanshu Jain'" <[email-masked]>; <[email-masked]>;
><[email-masked]>; "Thomas D. Nadeau" <[email-masked]>
>Sent: Wednesday, September 06, 2000 8:28 PM
>Subject: RE: Consensus for draft-kompella-mpls-te-mib-00.txt
>
>
>>
>> Sudhanshu,
>>
>> > I agree with your approach and here are my views to this effort.
>> >
>> > I would like to see single MIB addressing all related issue
>> > as it help to
>> > clear the confusion.
>> >
>> > IMHO, LSP info ( in this draft) is not specific to tunnel
>> > only and so there
>> > is no point them merging it with TE-MIB. Instead, it should
>> > be get augmented
>> > to mplsXCEntry in LSR MIB.
>>
>> I think the confusion is arising out of the use of the term LSP in
>> Kireeti's MIB to actually mean tunnels as defined in 
>RSVP/CRLDP drafts
>> or as in MPLS-TE-MIB. So there are no objects in Kireeti's MIB that
>> need to go into the LSR MIB.
>>
>
>I think, tunnel MIB objects are present only on ingress LSR and to some
>extent to egress LSR. Please correct me, if I am wrong.
>
>As far the MPLS TE (Traffic Engineering) is concerned, it need to be
>performed at each hop not just at ingress and egress. So if this is the
>case, I think current MPLS-TE MIB is not the correct mib 
>representing MPLS
>Traffic Engineering, as it address some TE aspects like 
>session attribute
>etc for the configuration purpose at the head end of the tunnel only.
>
>On the other hand, objects like mplsLspAge, mplsLspTimeUp,
>mplsLspPrimaryTimeUp, mplsLspTransition, mplsPathPropertis 
>etc. in Kireeti's
>mib need to be monitor at each hop.
>
>May be these objects should be addresses based on different 
>index as oppose
>to mplsLspName as specified in Kireeti's MIB.
>
>Any comments ?
>
>> >
>> > Also, why do we have named draft-ietf-mpls-te-mib.txt as
>> > "TE-MIB"? IMHO, it
>> > should be Tunnel-MIB :))
>>
>> We could have, but I doubt if that would have changed anything
>> with regard to this debate :-)
>>
>
>I think it will make the difference. Tunnel MIB is to address 
>objects only
>at ingress (and egress) LSRs only. While TE-MIB should address 
>issues for
>the whole path.
>
>Also, current subject of traffic engineering is very 
>pre-mature in MPLS and
>it is better separate tunnel configuration from MPLS traffic 
>engineering.
>Tunnel is a configurable entity while traffic engineering in 
>MPLS domain
>should work on path not on tunnel.
>
>-Sudhanshu
>
>
>