Subject: Re: question: DiffServ versus RSVP



Hi,
   In fact the importance difference between the Differential Service with
Integrated Service is that the Differential Service is a Per-Hop basis QoS
mechanism where the Integrated Service is a end-to-end QoS mechanism. RSVP
is used as a resource reservation protocol for the integrated service. In
MPLS, there is some extension for the function of RSVP, but it is still
limited as a signalling protocol only. DiffSer don't need the RSVP at all.
  Hope this can be helpful.

Wushao

On Thu, 14 Sep 2000, Robben Paul wrote:

> Hi,
> 
> I'm currently making a thesis regarding IP-based VPN's, paying special attention to traffic engineering and QoS.
> Something isn't clear to me. I read a couple of articles regarding the use of explicit routes with CR-LDP and the extended RSVP.
> Apparently, some companies prefer the former, others the latter, but there doesn't seem to be an official statement yet of which one's the best. But however, RSVP still is a "hot topic".
> On the other hand, I also read some articles about DiffServ, mentionning that DiffServ evolved from Intserv, which is based on RSVP, and that, within some time, DiffServ will eliminate the need to use RSVP in WAN area's. 
> 
> I think I must be missing something here...
> 1. Some time ago, a reader from the MPLS-list described DiffServ as a traffic light with reserved lanes for taxi's and busses. Its job is to help prioritize things once congestion starts, and to penalize some flows to allow others to get less delay or loss. So, I guess DiffServ doesn't operate on the level of 1 LSP, but on a whole bunch of them?
> 2. On the other hand, the extended RSVP is a way to set up explicit routes. So RSVP is important for each LSP separately?
> 
> So, I don't really understand how DiffServ could eliminate the use of RSVP??? It seems to me that, although they both serve QoS, they are working on a complete different scale...
> 
> Can anybody make me see the light in the darkness?
> :)
> Thanks in advance,
> 
> Françoise Beckers
> (Global One)
> 

----- End Included Message -----

---



Diffserv allows traffic to be broken up into different classes of
service - which are queued and prioritized separately.

It does not, however, provide a mechanism to define (in each router)
what specific QoS should be provided for each class.

These can be ignored (making Diffserv merely a priority scheme), they
can be hand-configured, they can be configured through network
management, or they can be signalled.

RSVP is one means by which these can be signalled.

RSVP and Diffserv solve two different problems.  There are situations
where it makes sense to use one, or the other, or both.

-- David