Subject: RE: draft-kompella-mpls-te-mib-00.txt

From: Arun Viswanathan <[email-masked]>
Date: Thu, 7 Sep 2000 11:17:45 -0700

Sudhanshu,

> I think, tunnel MIB objects are present only on ingress LSR 
> and to some
> extent to egress LSR. Please correct me, if I am wrong.

When you say tunnel MIB, I am assuming you mean the current MPLS-TE-MIB.
The initial intent of the MIB was to have the objects only at 
head-end and tail-end of the tunnel. But its scope got extended in the
last few revs so that the objects may be optionally maintained at the
intermediate nodes.

> 
> As far the MPLS TE (Traffic Engineering) is concerned, it need to be
> performed at each hop not just at ingress and egress. So if 
> this is the

See above. The MPLS-TE-MIB objects are mainly for the head-end and
may optionally be maintained at subsequent nodes.

> case, I think current MPLS-TE MIB is not the correct mib 
> representing MPLS
> Traffic Engineering, as it address some TE aspects like 
> session attribute
> etc for the configuration purpose at the head end of the tunnel only.
> 
> On the other hand, objects like mplsLspAge, mplsLspTimeUp,
> mplsLspPrimaryTimeUp, mplsLspTransition, mplsPathPropertis 
> etc. in Kireeti's
> mib need to be monitor at each hop.

Objects in Kireeti's MIB are for the head-end of a tunnel only.
This is my understanding from my discussions with Kireeti.

> 
> May be these objects should be addresses based on different 
> index as oppose
> to mplsLspName as specified in Kireeti's MIB.
> 
> Any comments ?
> 
> > >
> > > Also, why do we have named draft-ietf-mpls-te-mib.txt as
> > > "TE-MIB"? IMHO, it
> > > should be Tunnel-MIB :))
> >
> > We could have, but I doubt if that would have changed anything
> > with regard to this debate :-)
> >
> 
> I think it will make the difference. Tunnel MIB is to address 
> objects only
> at ingress (and egress) LSRs only. While TE-MIB should 
> address issues for
> the whole path.

See above.

-arun

---

From: "Sudhanshu Jain" <[email-masked]>
Date: Thu, 7 Sep 2000 12:05:52 -0700

Hi Arun,

Please see my inline comments too.

----- Original Message -----
From: "Arun Viswanathan" <[email-masked]>
To: "'Sudhanshu Jain'" <[email-masked]>; "Arun Viswanathan"
<[email-masked]>; <[email-masked]>; <[email-masked]>; "Thomas D.
Nadeau" <[email-masked]>
Sent: Thursday, September 07, 2000 11:17 AM
Subject: RE: draft-kompella-mpls-te-mib-00.txt

> last few revs so that the objects may be optionally maintained at the

So you mean to say, for traffic engineering, each LSR on a path, need to
manage Tunnel as oppose to the LSP.

BTW, what are the benefits to club the traffic engineering issue with the
Tunnel objects?

And, how are we going to address TE for LSP's for which there is no tunnel
have been configured e.g. ATM LSP?

> This is my understanding from my discussions with Kireeti.

If this is the case, I think we need to address some of these issue at each
hop like, mplsLspTimeUp, mplsLspPrimaryTimeUp, mplsLspTransition etc. As
these objects are specific to hop as oppose to path.

-Sudhanshu