Subject: label allocation on shared media

From: [email-masked]
Date: 9 Apr 2001 04:04:24 -0700

Hi all,
   
    I have a queastion on label allocation on shared (ethernet) media. If u have already discussed pls provide pointers to mail archives.

 There is chance to have more than 1 same outgoing label at LSR 'A', which are genearted by LSR B and LSR C in the following situation. 

	   A			    B
	|-------|		|-------|         
	|	|		|	|
	|	|---------------|	|
	|     	|     |		|	|
        ---------     |		---------
 		      |			
 		      |---------|-------|
 				|	|
				|	|
				|	|
				---------	
				    C	

  If outgoing labels are diffrentiated on interface basic, this ambiguty is not resloved.  How to resolve this amibguty?. 

Regards
YTR

______________________________________________________
123India.com - India's Premier Portal 
Get your Free Email Account at http://www.123india.com

---

From: Wojciech Dec <[email-masked]>
Date: Mon, 09 Apr 2001 16:45:52 +0200

Ytr,

Label's are only local in significance - there is no ambiguity in the 
scenario you show.  Although B and C can pass to A the same numerical value 
for a label and it might even be for the same FEC, it's A that checks for 
the FECs next hop(s) (in it's routing table) on the segment and from there 
determines the LSR(s) (B, C) that has  that address bound to it (advertised 
in TDP/LDP).
Following that, A selects for use the label advertised by the chosen LSR(s).

Rgds,
Woj.

At 04:04 09/04/2001 -0700, [email-masked] wrote:
>Hi all,
>
>     I have a queastion on label allocation on shared (ethernet) media. If 
> u have already discussed pls provide pointers to mail archives.
>
>  There is chance to have more than 1 same outgoing label at LSR 'A', 
> which are genearted by LSR B and LSR C in the following situation.
>
>
>
>            A                        B
>         |-------|               |-------|
>         |       |               |       |
>         |       |---------------|       |
>         |       |     |         |       |
>         ---------     |         ---------
>                       |
>                       |---------|-------|
>                                 |       |
>                                 |       |
>                                 |       |
>                                 ---------
>                                     C
>
>
>   If outgoing labels are diffrentiated on interface basic, this ambiguty 
> is not resloved.  How to resolve this amibguty?.
>
>Regards
>YTR
>
>

_________________________________________________________
Wojciech Dec   CCIE# 5563      Phone:  +31 (0)20 342 3034
Network Consulting Engineer

---

From: Soumen Sarkar <[email-masked]>
Date: Tue, 10 Apr 2001 17:37:47 +0530 (IST)

Hi All,
	I need small favour from the experts in this list.
	I am sure representatives of almost all the vendors
	are present here. I am looking for inputs on what
	the vendors are finding lacking in present MPLS
	framework. I agree this varies from vendor to vendor,
	but I guess we can expect a pattern on the features
	most sought. Possibly we might be able to identify
	the uncharted territories of MPLS which are important
	but somehow not addressed so far in MPLS forum.
	  I will be grateful to all of you if you can find
	some time to complete this exercise by this week.
-best regards,
Soumen