Subject: Re: Re: question about Trigger Control Block?

From: Wang Yu <[email-masked]>
Date: Thu, 26 Apr 2001 10:4:40 +0800

Eric Gray,
    Hello, thank you very much!
    But the third question is still not clear.

   Next Hop Control Block = Next Hop Trigger Control Block ? 

    Could you explain it?
    Thank you again.

            Wang Yu
            [email-masked]

-----------------
01-4-25 10:14:00 You wrote:
>Yu,
>
>    Hello.  Please see my earlier answer on this subject at:
>
>    http://cell.onecall.net/mhonarc/mpls/2001-Mar/msg00009.html
>
>    If this does not clear up your questions below, let me know.
>
>Thanks!
>--
>Eric Gray
>
>You wrote:
>
>> Hi, everybody,
>>
>> Here are some questions about MPLS LDP State Machine.
>> Can someone give me explanation?
>> Thanks in advance.
>>
>> 1. Trigger Control Block is discribed unclearly in "LDP State Machine"(draft-ietf-mpls-ldp-state-04.txt).
>> (1)what is it on earth?
>> (2)what is its function?
>> (3)what information does it contain?
>> (4)how does it operation?
>> (5)how does it interwork with LSP control block?
>>
>> 2.Next Hop Control Block is discribed unclearly in "LDP State Machine"(draft-ietf-mpls-ldp-state-04.txt).
>>    I have the same questions about Next Hop Control Block as 1.
>>
>> 3.Next Hop Control Block = Next Hop Trigger Control Block ?
>>
>> In draft-ietf-mpls-ldp-state-04.txt,
>> -------------------------------------------
>> 3.2.1 LSP Control Block
>>
>>    For each LSP, an LSP Control Block is defined which may contain the
>>    following information:
>>      - Upstream Label Request ID (assigned by the upstream LSR),
>>                 which is the 'Message Id' in the Label Request Message
>>                 received from the upstream LSR.
>>      - Downstream Label Request ID (assigned by this LSR itself),
>>                 which is 'Message Id' in the Label Request Message sent to
>>                 the     downstream LSR.
>>      - Upstream LDP Identifier
>>      - Downstream LDP Identifier
>>      - State
>>      - FEC
>>      - Upstream Label (assigned by this LSR)
>>      - Downstream Label (assigned by the downstream LSR)
>>      - Trigger Control Block Pointer, (Only used at the ingress LSR
>>                 of a LSP) that points to the control block that triggers
>>                 setting up this LSP or tearing down this LSP.
>>      - Next Hop Control Block Pointer, which points to the control
>>        **********************
>>                 block which is used for switching over to a better LSP.
>> ---------------------------------------------------------------------
>>   Is Next Hop Control Block = Next Hop Trigger Control Block?
>>
>>             Yu Wang
>>             [email-masked]

---

From: Eric Gray <[email-masked]>
Date: Thu, 26 Apr 2001 10:37:10 -0400

Yu,

    In this answer, I will use the following shorthand:

        NHCB = Next Hop Control Block
        NHCBP = Next Hop Control Block Pointer
        NHTCB = Next Hop Trigger Control Block
        NHTCBP = Next Hop Trigger Control Block Pointer
        JPLIG = Just Plain Lazy I Guess

    On page 6, you should see a statement that the NHCBP
"points to the control block which is used for switching over
to a better LSP."

    In section 3.2.6.1 Next Hop Trigger Control Block, on page
24, you should find that the NHTCB contains two pointers -
one to the original downstream LSP control block and one to a
new Next Hop LSP Control Block.  I confess that - in at least
this case - I'm guilty of not quite catching every inconsistency
in the terminology used.  In this definition,

         NHCB also equals Next Hop LSP Control Block, and
         NHCBP also equals Next Hop LSP Control Block Pointer

I believe this is vestigial since LSP is redundant and should
have been removed.

    Does this help?

--
Eric Gray