Subject: MPLS Diffserv

From: N S S Kishore Kankipati <[email-masked]>
Date: Mon, 9 Apr 2001 08:46:21 -0700 (PDT)

hi all

DSCP contains 6 bits. Therefore number of PHBs
possible
is 64 (including default PHB). If an LSR has to
support all PHBs it requires at least 8 E-LSPs. If
only L-LSPs are used, it requires more than this. If
we use both the types of LSPs, the number of LSPs
required may be intermediate to the previous two
cases. 
From this we can infer that for every FEC it requires
at least 8 LSPs. A LSR may contain more number of FECs
and in that case number of LSPs (and labels)required
is very large. 
Isn't there any way to reduce number of LSPs and
conserve label space in that case(LSR has to support
all PHBs possible)?

regards
kk

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/

---

From: "Xipeng Xiao" <[email-masked]>
Date: Mon, 9 Apr 2001 12:54:52 -0700

Comments in line.

> required may be intermediate to the previous two

But not all 64 PHBs are needed.  In fact, 8 PHBs are likely
to be more than sufficient in most cases. In that case, 
n<8 lsps (e-lsps and/or l-lsps) are enough.

> conserve label space in that case(LSR has to support

See above.

Regards,

XiPeng

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 09 Apr 2001 16:40:57 -0400

In message <[email-masked]>, N S S Kishore 
> conserve label space in that case(LSR has to support

If a network uses a subset of the possible 64 DSCP values, all
unrecognized values are mapped to best effort service.  In practice, a
small set of DSCP values are used (often just one, BE).  If all 64
values were in use there would be a need for lots of MPLS LSPs.

Curtis