Subject: RE: Two signalling protocols (LDP & RSVP)

From: "Peter Ashwood-Smith" <[email-masked]>
Date: Sat, 21 Apr 2001 22:03:27 -0400

Yes & Yes.

Peter Ashwood-Smith

	-----Original Message-----
	From:	Anil Gunturu [SMTP:[email-masked]]
	Sent:	Friday, April 20, 2001 2:12 PM
	To:	mpls
	Subject:	Two signalling protocols (LDP & RSVP)

	Hi,
	Is it possible to run both LDP and RSVP on the same interface? If it
is
	possible can they be using the same label space?
	-Anil

---

From: "Gang Luo" <[email-masked]>
Date: Fri, 27 Apr 2001 08:56:26 -0400

Hi Kireeti,

I agree with you. If some feature is required, but missing, 
it looks that we just build the feature as an option into the existing
protocol.

That will be less implementation overhead than supporting two protocols.

Best regards.
Gang.

-----Original Message-----
From: Kireeti Kompella [mailto:[email-masked]]
Sent: Friday, April 27, 2001 5:57 AM
To: [email-masked]; [email-masked]
Cc: Luo, Gang [SKY:1H91:EXCH]; [email-masked]
Subject: Re: Two signalling protocols (LDP & RSVP)

> Although both CR-LDP and RSVP-TE provides similar functionalities, but one
> significant reason why we would like to run both the protocols on the same
> interface can be that TE-RSVP supports IP record route option using its
record
> route objects.But CR-LDP doesn't support IP record route option.

The above seems to be an excellent argument for running RSVP-TE.
It is not (as it stands) a justification for running *both* RSVP
and CR-LDP.

Kireeti.

---

From: "Peter Ashwood-Smith" <[email-masked]>
Date: Fri, 27 Apr 2001 09:25:44 -0400

http://search.ietf.org/internet-drafts/draft-ietf-mpls-lsp-query-01.txt
<http://search.ietf.org/internet-drafts/draft-ietf-mpls-lsp-query-01.txt> 

Allows you to query the route with CR-LDP. It also allows you to query the
exact labels used at every hop and in the case of a SONET/SDH trail will
give you down to the timeslot level. You can also query available bandwidth
on the traversed interfaces.

Cheers,

Peter Ashwood-Smith

	> Hi,
	>
	> Is there any practical reason that the signalling protocols (LDP &
RSVP) is
	> supported on the same interface?
	>

	Although both CR-LDP and RSVP-TE provides similar functionalities,
but one
	significant reason why we would like to run both the protocols on
the same
	interface can be that TE-RSVP supports IP record route option using
its record
	route objects.But CR-LDP doesn't support IP record route option.

	Regards
	Mohit Goel

---

From: "Sanford, Bill" <[email-masked]>
Date: Fri, 27 Apr 2001 10:30:10 -0400

Mohit,

What document has path "reoptimization" in it? How are you defining it?

In 4.7.2. Format with resource affinities
(draft-ietf-mpls-rsvp-lsp-tunnel-08.txt), doesn't it state that "A transit
router can reroute traffic for fast service restoration"? 

Bill

> >>Mohit
> CR-LDP supports path reoptimization which means that it has 
> the capability to
> repath loosely routed LSPs based on traffic pattern changes. 
> But RSVP-TE does
> not support the feature of path reoptimization.
> 
> Mohit
> 
> 
> 
>

---

From: "Loa Andersson" <[email-masked]>
Date: Mon, 30 Apr 2001 18:25:52 +0200

----- Original Message -----
From: David Charlap <[email-masked]>
Date: Monday, April 30, 2001 5:02 pm
Subject: Re: Two signalling protocols (LDP & RSVP)

> [email-masked] wrote:
> > but one significant reason why we would like to run both the
> > protocols on the same interface can be that TE-RSVP supports IP
> > record route option using its record route objects.But CR-LDP
> > doesn't support IP record route option.
> 
> CR-LDP has the Path-Vector TLV, which works almost identically to the
> RSVP RECORD_ROUTE object.

The path vector comes from LDP , it is intended to be use to
detect loops. 
proper working of the path vector  requires that all the 
nodes are configured for loop detection.

Yes, the path vector and RSVP RECORD_ROUTE works "almost" the 
same, but not quite enough the same, not to require changes in 
the current specs.

Admittedly these changes are small and easy to make, but how many 
small changes ióf this nature do we need before it really becomes a
pain?

/Loa
> -- David