Subject: Constraint-based Shortest path algorithm

From: wushao wen <[email-masked]>
Date: Fri, 20 Apr 2001 09:58:46 -0700

Hello,
        In the traffic engineering, we need to calculate the 
constraint-based shortest path for a FEC. Is there any mature and efficient 
algorithm to do the calculation? Let's said that we have two parameter for 
each link (cost, and delay), how can we calculate the shortest path under 
end-to-end delay constraint (As I know, this is NP hard problem, right)?
       If anybody have implemented some  algorithms on this, please let me 
know.
       Thanks!

Wushao

---

From: "Dmitri Krioukov" <[email-masked]>
Date: Wed, 25 Apr 2001 23:17:02 -0400

My understanding is that the TE path computation draft
is now expired, but the old version is still available
from
http://www.watersprings.org/links/mlr/id/draft-kompella-te-pathcomp-00.txt,
for example.
--
dima.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of wushao
> wen
> Sent: Friday, April 20, 2001 12:59 PM
> To: [email-masked]
> Subject: Constraint-based Shortest path algorithm
>
>
> Hello,