Subject: question about Trigger Control Block?

From: Íõè¤ <[email-masked]>
Date: Wed, 25 Apr 2001 11:32:35 +0800

Hi, everybody,

Here are some questions about MPLS LDP State Machine.
Can someone give me explanation?
Thanks in advance.

1. Trigger Control Block is discribed unclearly in "LDP State Machine"(draft-ietf-mpls-ldp-state-04.txt). 
(1)what is it on earth?
(2)what is its function?
(3)what information does it contain?
(4)how does it operation?
(5)how does it interwork with LSP control block?

2.Next Hop Control Block is discribed unclearly in "LDP State Machine"(draft-ietf-mpls-ldp-state-04.txt).
   I have the same questions about Next Hop Control Block as 1.

3.Next Hop Control Block = Next Hop Trigger Control Block ?

In draft-ietf-mpls-ldp-state-04.txt,
-------------------------------------------
3.2.1 LSP Control Block

   For each LSP, an LSP Control Block is defined which may contain the
   following information:
     - Upstream Label Request ID (assigned by the upstream LSR),
		which is the 'Message Id' in the Label Request Message 
		received from the upstream LSR.
     - Downstream Label Request ID (assigned by this LSR itself), 
		which is 'Message Id' in the Label Request Message sent to 
		the	downstream LSR.
     - Upstream LDP Identifier
     - Downstream LDP Identifier
     - State
     - FEC
     - Upstream Label (assigned by this LSR)
     - Downstream Label (assigned by the downstream LSR)
     - Trigger Control Block Pointer, (Only used at the ingress LSR
		of a LSP) that points to the control block that triggers 
		setting	up this LSP or tearing down this LSP.
     - Next Hop Control Block Pointer, which points to the control
       ********************** 
		block which is used for switching over to a better LSP.
---------------------------------------------------------------------
  Is Next Hop Control Block = Next Hop Trigger Control Block?

            Yu Wang
            [email-masked]

---

From: Eric Gray <[email-masked]>
Date: Wed, 25 Apr 2001 10:14:56 -0400

Yu,

    Hello.  Please see my earlier answer on this subject at:

    http://cell.onecall.net/mhonarc/mpls/2001-Mar/msg00009.html

    If this does not clear up your questions below, let me know.

Thanks!
--
Eric Gray