Subject: doubt in RFC 2547bis-03 route-refresh mechanism

From: Rameshbabu Prabagaran <[email-masked]>
Date: Thu, 5 Apr 2001 14:54:08 -0500 (CDT)

I have a doubt regarding the route-refresh mechanisms to be 
used as per 2547bis-03. 

Consider the following transition from a fully meshed CUG to
a hub and spoke type of VPN. 

            CEred1           CEred2 
              |               |
              |               | 
   CEblue1----PE1------------PE2----CEblue2 
               \              / 
                \            /
                 \          /
                  \        /
          I        \      /
                    \    /
                     PE3
                      |
                      | 
                    CEred3

            CEspoke1        CEspoke2 
              |               |
              |               |
 CEspoke3----PE1-------------PE2----CEspoke4
               \              /
                \            /
                 \          /
                  \        /
         II        \      /
                    \    /
                     PE3 
                      | 
                      |
                    CEhub

In the above case, assuming that customers do not withdraw their
routes, is a smooth transition possible from the CUG scenario to the
Hub and spoke scenario.

My question actually is, if PE1, PE2 and PE3 are configured with the
new import and export targets, then, unless they are configured at
_exactly_ the same time, they cannot have proper route dissemination
with the new targets in place i.e. by using BGP route-refresh
mechanism. To elaborate, if red RD is 100:1, blue RD is 100:2,
spoke RD is 100:1 and hub RD is 100:2, and if PE1 is configured for
the change prior to PE2, then there is a possibility that the
routes that were earlier belonging to the blue VPN (CEblue2's routes)
can be installed in the VRF belonging to RD 'spoke' (atleast
temporarily) when a route-refresh message is sent from PE1.

Is this a desired behavior or am I missing something here ?
Thanks in advance for any inputs.

regards,
Ramesh.

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 05 Apr 2001 13:40:38 -0700

Rameshbabu,

Yr msg is so confusing that I am not even sure how to start. 

First let me asnswer your question. If you want to transition from full
mesh vpn to hub and spoke the simple steps would be:

1. Leave the RDs alone. 
2. Inject default route from a future Hub site into all other site for a
given VPN.
3. Adjust RT (route targets) to eliminate not needed routes at spoke
(and spoke PEs).

Done. I don't really see any issue with route-refresh here. 

The issue you are trying to descibe is the RD misconfiguration caused by
operator.

R.

> Rameshbabu Prabagaran wrote:
>