Subject: doubt in RFC 3031

From: "Bhupesh Bajaj" <[email-masked]>
Date: Mon, 30 Apr 2001 15:42:10 +0530

hi all.
while going thru RFC 3031 , in Page 18 , second paragraph says...

" This technique allows the egress to do a single lookup, and also requires only a single lookup by the penultimate node "

isnt the penultimate node going to do a single lookup anyway...? or i have got it all wrong..?

according to what i perceived...the penultimate node is going to look into the label which it received and then sends the packet to the next hop according to the information in the label it received with packet...which means ...single lookup....

when would it do a second lookup..?

is it referring to the second lookup that the penultimate node will have to do when it wouldnt find the label in the stack which it is expecting ...and it will go for network layer information...?

kindly let me know.
thanks and regards,

bhupesh.
Get Your Private, Free E-mail from Indiatimes at http://email.indiatimes.com

---

From: "Bhupesh Bajaj" <[email-masked]>
Date: Mon, 30 Apr 2001 16:11:37 +0530

thanks asheesh and sumit ,
but my douubt was that in RFC they have mentioned that...

".. This technique allows the egress to do a single lookup, and also requires only a single lookup by the penultimate node.."

to be noticed.." and also requires only a single lookup by penultimate..."

which anyways is the case...

so as far as penultimate hop is concerned ..it in both cases will be operating in same way i.e looking for the labbel and if not found looking for network information and sending the packet ...

so as far as this technique is concerned the benifit one gets is from egress side and penultimate hop will still be having to do the same number of lookups in both cases with / without this technique..

thats all the confusion was , as in the RFC they have mentioned in a way that one gets benifit on penultimate hop lookups also..

anyways..thanks for prompt reply

regards
bhupesh

---

From: "Bhupesh Bajaj" <[email-masked]>
Date: Mon, 30 Apr 2001 16:11:37 +0530

regards
bhupesh

-------
The MPLS-OPS Mailing List
Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
Archive: http://www.mplsrc.com/mpls-ops_archive.shtml