Subject: Address message ?

From: "Hari Kishan" <[email-masked]>
Date: Thu, 26 Apr 2001 09:16:57 -0700

Hi,

  What exactly are the addresses a LDP peer
  advertises in it's Address message before
  sending label advertisements?

  Is it a list of addresses configured on a
  particular interface or can it be any arbitrary 
  list of addresses the peer is configured to
  advertise.

thanks,
Kishan

---------------------------------
Hari Kishan Desineni,
Ericsson Inc,
Data Backbone & Optical Division,
Santabarbara,
California - 93117
Office:(805) 562 6419
Home:(805) 968 1894

---

From: Ajay Simha <[email-masked]>
Date: Thu, 26 Apr 2001 14:25:13 -0400 (Eastern Daylight Time)

>   list of addresses the peer is configured to

I would think it should be the addresses that are configured on interfaces
not arbitrary list of addresses.  Because these addresses could be used
later to dip into the LIB if for example one of the links to that neighbor
goes away and we continue to have a session.  We still want to use the
label bindings this neighbor sent us earlier.

-ajay

-- 
Ajay Simha
MPLS Deployment Engineer
IOS Technology Division
(919) 392-3141

"Study as if you were to live forever
 Live as if you were to die tomorrow"

 - Mahatma Gandhi

---

From: Ajay Simha <[email-masked]>
Date: Fri, 27 Apr 2001 09:35:06 -0400 (Eastern Daylight Time)

On Thu, 26 Apr 2001, Hari Kishan wrote:

>
> To be more specific,
> can it be only the list of all MPLS enabled/capable interface
> addresses on that LSR? or can it have something more ?

I think it should be the list of all MPLS enabled/capable interfaces and
nothing more.  These interfaces as I mentioned in my last email get used
when the route to a prefix changes.  Look at example:

 10.0.1
+-------+
A       B
+-------+
 10.0.2

A=.1
B=.2

RIB On A:
Dest prefix: 200.1.1.1
Next hop   : 10.0.1.2

LIB on A:
Remote lbl : 25, LSR-ID=B
Addresses bound to B: 10.0.1.2, 10.0.2.2

LFIB on A:
Dest prefix :200.1.1.1
Out label   :25
Out Intf    :Pos 2/1

Then 10.0.1 link goes down and the routing entry now looks like:
Dest prefix: 200.1.1.1
Next hop   : 10.0.2.2

Now since the session is up (due to 10.0.2 link), A tries to use same
label binding it received from B.  Since it is going to send a labeled
packet, 10.0.2.2 interface on B better be MPLS enabled.

Assumption here is that B is doing per-platform label space.

-ajay

 >
> --kishan
>
> -----Original Message-----
> From: Ajay Simha [mailto:[email-masked]]
> Sent: Thursday, April 26, 2001 11:25 AM
> To: Hari Kishan
> Cc: [email-masked]
> Subject: Re: Address message ?
>
>

-- 
Ajay Simha
MPLS Deployment Engineer
IOS Technology Division
(919) 392-3141

 - Mahatma Gandhi

---

From: "Hari Kishan" <[email-masked]>
Date: Thu, 26 Apr 2001 13:53:22 -0700

To be more specific,

--kishan

-----Original Message-----
From: Ajay Simha [mailto:[email-masked]]
Sent: Thursday, April 26, 2001 11:25 AM
To: Hari Kishan
Cc: [email-masked]
Subject: Re: Address message ?

>   list of addresses the peer is configured to

I would think it should be the addresses that are configured on
interfaces
not arbitrary list of addresses.  Because these addresses could be
used
later to dip into the LIB if for example one of the links to that
neighbor
goes away and we continue to have a session.  We still want to use the
label bindings this neighbor sent us earlier.

-ajay

--
Ajay Simha
MPLS Deployment Engineer
IOS Technology Division
(919) 392-3141

 - Mahatma Gandhi

---

From: Bob Thomas <[email-masked]>
Date: Fri, 27 Apr 2001 13:12:25 -0400

> addresses on that LSR? or can it have something more ?

The addresses advertised should be any which can appear as a
next hop address in the neighbor's routing table.

Bob