Subject: 2 LSRs over normal ATM using VCID notification RFC 3038

From: "MP LS" <[email-masked]>
Date: Fri, 13 Apr 2001 16:02:28 +0200

Hello all

I have some questions about 2 MPLS LSR's between a normal ATM network.
Is this possible with VCID notification RFC 3038? They describe a mechanism 
to connect a VC identifier to vci/vpi. With the meaning when that the upper 
label which normaly is encoded in vpi/vci will arive at the other LSR 
clearly (without being switched) when there are some other ATM switches 
between it. Could anyone explain me some more about this??

Thanks for anwsering my question.

With kind regards,

Niels Sitters
_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

---

From: "Naidu, Venkata" <[email-masked]>
Date: Fri, 13 Apr 2001 10:52:30 -0400

Hi Niel
  It is very much possible to negotiate MPLS ATM label when
2 ATM LSRs/LERs are connected (RFC3038 explains) in different 
scenarios:

* If MPLS capable ATM LSRs are connected directly then
  you don't need VCID. Because local significant VPI/VCI are 
  same at both ends of PVC/SVC.

* If MPLS capable ATM LSRs are not connected directly (i.e.,
  to a pure ATM cloud):
   - If VP switching is used, then VCI is used as MPLS label.
     Because intermediate ATM switches won't look at/modify 
     VCI field. 
       - VCID exchange is not required. VCI may be used as VCID.
         This is a common scenario used by most of the current
         implementers. 
       - You can negotiate/configure VPID.

   - If VC switching is used, then VPI/VCI may not be same
     at both ends of LSRs. So you need to map VCID to a VC
     in both LSRs.

Of course, we can use inband/outband notification of VPID/VCID.

Thanks & Regards
Venkata Subbaiah Naidu
--
http://www.geocities.com/kvsnaidu