Subject: RE: Regarding Label stack

From: Prabhugouda <[email-masked]>
Date: Thu, 19 Apr 2001 12:01:49 +0500

> Dear All,
> 
> I have the following questions:
> 1. Does any one supports hierarchy in MPLS, label stacking?
> 2. How does the ILM looks in case of label stacking?
> 
> Prabhu
> 
> ----------------------------------------------------------------
> Prabhugouda Biradar,
> Huawei Technology India Pvt. Ltd.
> Unit 10/11, Level 2, Innovator Block,
> Whitefield Road,
> Bangalore - 560 066.
> 
> Office Tel. +91-80-8410061/753/755/1651.
> Mobile : +91-98440-84691.
> Res. Tel : +91-80-3520909.
> 
> 
> 
>

---

From: [email-masked]
Date: 19 Apr 2001 20:55:34 -0700

> > 1. Does any one supports hierarchy in MPLS, label stacking?

pls refer linux implemenation for this. U can get sources at 
http://sourceforge.net/projects/mpls-linux/
This supports Hierachical forwarding.

> > 2. How does the ILM looks in case of label stacking?

ILM is supposed to look on ILM table for top label. If operation of the top label is POP, Stack depth is >1 , then ILM look up is required for next label. This is recursive process till the operation of label is not POP or end of stack. 

Cheers,
YTR

> > Prabhu

______________________________________________________
123India.com - India's Premier Portal 
Get your Free Email Account at http://www.123india.com