Subject: MPLS Support of E-LSPs

From: "Sudhakar Ganti" <[email-masked]>
Date: Mon, 30 Apr 2001 12:38:49 -0400

Hello,

The following draft is available in the IETF draft
repository that extends E-LSP signaling:

Title: MPLS Support of Differentiated Services using E-LSP
Authors: S.Ganti, N.Seddigh, B.Nandy
URL:
http://www.ietf.org/internet-drafts/draft-ganti-mpls-diffserv-elsp-00.txt

The current E-LSP approach allows multiple Ordered
Aggregates  (OAs)  to  be carried  by  a  single
LSP. The  existing  E-LSP specification only supports
collective bandwidth signalling for all the OAs in
an E-LSP. However, there exist uses of the E-LSP
approach where it is desirable to support bandwidth
signalling on a per-OA or per-PSC  basis.
This draft extends the original E-LSP approach by
defining extensions to support per-OA signalling.
The extensions are proposed  for  both RSVP and CR-LDP.

Please comment on the same. Thanks

-Sudhakar
------------
Dr. Sudhakar Ganti
Technical Specialist
Tropic Networks Inc,
Kanata, Ontario, Canada

---

From: Dimitry Haskin <[email-masked]>
Date: Mon, 30 Apr 2001 15:51:06 -0400

Sudhakar,

Thanks for the draft. The proposed extensions will provide a needed
signaling support for the Diff-Serv's Uniform Tunneling model described in
draft-ietf-mpls-diff-ext-09.txt.

To make your proposal consistent with the Class-Type concept of
draft-ietf-mpls-diff-te-reqts-00.txt, I would suggest to replace the PSC
field of the proposed Traffic Profile with a 4-bit Class-Type (CT) field. In
addition if your allow the ELSP Object to carry resource requirements for
L-LSP also (you'd need to rename the object) there would be no need for the
CLASSTYPE Object defined in draft-ietf-mpls-diff-te-ext-01.txt.

Dimitry

-----Original Message-----
From: Sudhakar Ganti [mailto:[email-masked]]
Sent: Monday, April 30, 2001 12:39 PM
To: [email-masked]
Cc: Nabil Seddigh; Biswajit Nandy
Subject: MPLS Support of E-LSPs

Hello,

-Sudhakar
------------
Dr. Sudhakar Ganti
Technical Specialist
Tropic Networks Inc,
Kanata, Ontario, Canada

---

From: "Choudhury, Sanjaya" <[email-masked]>
Date: Mon, 30 Apr 2001 18:48:40 -0400

Hi! I agree that this draft brings a much needed clarity to the
E-LSP support (
        specifically from a CAC point of view). However, I differ from your
suggestion 
        to replace the PSC field with the Class-Type field. Here are the
reasons:
 
            1. Platforms that do not support the class-type extensions
proposed
                in the diff-te-reqts-00.txt draft, can still take advantage
of this 
                draft.
 
                Platforms that do implement the class-type extensions, can
still
                determine the class-type from the signaled PSC, 
 
            2. In my opinion Class-Type concept proposed in the
diff-te-reqts-00.txt, 
                is a good optimization of the IGPs, but not very useful for
signaled
                LSPs. Since PSC-->Class-Type information is locally
configured anyway,
                one can easily determine the class-type from the associated
PSC.
 
                Infact, in my opinion the idea proposed in this draft, is a
cleaner 
                approach to signal bandwidth for OAs, than the one specified
in the 
                draft-ietf-mpls-diff-te-ext-01.txt.
 
         Thanks,
         sanjay

-----Original Message-----
From: Dimitry Haskin [mailto:[email-masked]]
Sent: Monday, April 30, 2001 3:51 PM
To: 'Sudhakar Ganti'; [email-masked]
Cc: Nabil Seddigh; Biswajit Nandy
Subject: RE: MPLS Support of E-LSPs

Sudhakar, 

Dimitry 

-----Original Message----- 
From: Sudhakar Ganti [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Monday, April 30, 2001 12:39 PM 
To: [email-masked] 
Cc: Nabil Seddigh; Biswajit Nandy 
Subject: MPLS Support of E-LSPs 

Hello, 

Title: MPLS Support of Differentiated Services using E-LSP 
Authors: S.Ganti, N.Seddigh, B.Nandy 
URL: 
http://www.ietf.org/internet-drafts/draft-ganti-mpls-diffserv-elsp-00.txt
<http://www.ietf.org/internet-drafts/draft-ganti-mpls-diffserv-elsp-00.txt>

-Sudhakar 
------------ 
Dr. Sudhakar Ganti 
Technical Specialist 
Tropic Networks Inc, 
Kanata, Ontario, Canada