Subject: RE: Does MPLS Require L3 Routing Table ?

From: "Naidu, Venkata" <[email-masked]>
Date: Fri, 13 Apr 2001 15:33:00 -0400

All,
I got a doubt (and to extend it more)...

* Can we manually configure MPLS labels, just like
  PVCs in ATM, for any Layer 2. (call it Permanent LSPs)
  In that sense I hope we don't need any control plane
  (Signaling - LDP/RSVP or Routing OSPF/IS-IS etc)

* Is it allowed or used in MPLS (forwarding plane) 
  terminology? Because, in ATM, SVCs are expensive and 
  rarely used where as PVC are feasible/preferable.

Thanks & Regards
Venkata Subbaiah Naidu
--
http://www.geocities.com/kvsnaidu 

> -----Original Message-----
> From: Mark Seery [mailto:[email-masked]]
> Sent: Friday, April 13, 2001 3:07 PM
> To: Abhijit Gadgil; Rajesh P Jain
> Cc: Bharti Batra; [email-masked]
> Subject: RE: Does MPLS Require L3 Routing Table ?
> 
> 
> To make the statement that the only way to program an MPLS 
> FIB is via an IP
> control plane is not strictly speaking true, though the intent of the
> statement is understood. It is true however to say that there 
> will be many
> capabilities not achieved if a network layer control plane is 
> not used, such
> as the ones stated below.
> 
> On the issue of performance, it is true that it is possible to use
> technology that does longest prefix match at wire rate. It is 
> also true that
> there are issues not related to performance in using such 
> technology, and
> that these issues may or may not make a difference depending 
> on the overall
> design goals and application of the system. It is also true 
> that due to the
> continued evolution of silicon, even these differences may 
> not exist at some
> point in the future.
> 
> -mark.s.
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of Abhijit
> Gadgil
> Sent: Friday, April 13, 2001 5:30 AM
> To: Rajesh P Jain
> Cc: Bharti Batra; [email-masked]
> Subject: Re: Does MPLS Require L3 Routing Table ?
> 
> 
> 
> MPLS does require layer 3 routing information. It works together with
> Layer 3 routing information like OSPF / BGP etc. However the 
> advantage of
> MPLS is in terms of being able to label switch after it has formed the
> LSPs. This is useful in case of hardware that cannot look 
> into IP header
> like ATM switches. Another advantage of MPLS is in terms of creating
> explicitely routed label switched paths, which is useful in Traffic
> Engineering. The original motivation for MPLS of being able 
> to outperform
> IP lookup is not the motivation for MPLS these days. Another 
> advantage of
> MPLS is its better than IP over ATM. Thus the advantages of 
> MPLS can be
> listed as follows.
> 1. Making use of network layer routing to create label switched paths.
> 2. No need to maintain 2 networks as in IP over ATM case.
> 3. Alleviating N^2 mesh problem common with ATM switches
> 
> hope that helps
> 
> -abhijit
> 
> On Fri, 13 Apr 2001, Rajesh P Jain wrote:
> 
>  >"Hello",
>  >                        Thanks for the response.
>  >
>  >                        Well, if it requires L3 Routing 
> table to build up
> the Label information, then what is the advantage of MPLS??? 
> Well, Anyhow,
> it will require the building of L3 Routing Table (May be through
> RIP/OSPF/BGP etc), then Lable info can be formed by using only L3. So,
> Anyhow, MPLS is dependent on L3, please explain me what is 
> the advantage of
> using MPLS (in terms of efficiency and speed switching of the 
> packets).
>  >
>  >With Regards
>  >                    Rajesh P Jain
>  >  ----- Original Message -----
>  >  From: Bharti Batra
>  >  To: Rajesh P Jain ; [email-masked]
>  >  Sent: Friday, April 13, 2001 1:09 PM
>  >  Subject: Re: Does MPLS Require L3 Routing Table ?
>  >
>  >
>  >  Hi !
>  >
>  >  Yes. LDP needs IP routing table to find out the route 
> towards the egress
> router to setup the LSP. LDP sends the LSP setup request 
> message along this
> path.
>  >
>  >  Regds,
>  >  Bharti
>  >    ----- Original Message -----
>  >    From: Rajesh P Jain
>  >    To: [email-masked]
>  >    Sent: Friday, April 13, 2001 12:52 PM
>  >    Subject: Does MPLS Require L3 Routing Table ?
>  >
>  >
>  >    "Hello", List,
>  >                        Well, I am very new to Jthe MPLS domain. I
>  >just
> wanted to check out whether MPLS domain neccesarily require 
> the L3 Routing
> Table (Maybe IP Routing Table) to build up it's label (using the LDP
> Protocol). Or the LDP will take care of building the label information
> automatically without the L3 Routing information?
>  >
>  >    TIA
>  >            Rajesh P Jain
>  >
> 
>

---

From: "Mark Seery" <[email-masked]>
Date: Fri, 13 Apr 2001 12:44:32 -0700

Venkata,

>>  (Signaling - LDP/RSVP or Routing OSPF/IS-IS etc)

There is no technological barrier to manual configuration. There are layer 2
VPN approaches that could work this way. There have been various discussions
on a variety of emailers regarding which vendors do or do not support static
LSPs. I would refer you to individual vendors for their own comments.

So even given that static LSPs might be supported by your vendor of choice,
there are still considerations about whether that approach is most suited to
a) the application b) the operational mode of the network operator.

-mark