Subject: Label Aborting..

From: "chetan kumar s" <[email-masked]>
Date: Thu, 19 Apr 2001 10:59:28 +0530 (IST)

Hi,
	I was looking thro' the rfc 3036. 

At section 3.5.10 (page 73) it is mentioned 

   If an LSR receives a Label Abort Request Message after it has
   responded to the Label Request in question with a Label Mapping
   message or a Notification message, it ignores the abort request.

And in thge Appendix at Page 106 it is mentioned.
      
      LAbR.6  Generate Event: Received Label Release Message for FEC
      from MsgSource.  (See Note 2.)
      Goto LAbR.11.

I feel that we have to follow what is mentioned in the section  3.5.10,
since it makes sense for the upstream(MsgSource) to release the Label
explicitly based on its retention mode. Let me know how do U think ??

Thanks
Chetan S

___________
The reasonable man adapts himself to the world; the unreasonable one
persists in trying to adapt the world to himself.  Therefore all
progress depends on the unreasonable man.
                -- George Bernard Shaw

---

From: Eric Gray <[email-masked]>
Date: Thu, 19 Apr 2001 09:43:15 -0400

Chetan S,

A careful read of the procedures for receiving a
label abort

results in the realization that - to get to LAbR.6 - the following

circumstances must apply:

the message must match a
previously received label

request (LAbR.1)

the
LSR must not have responded to this request

(LAbR.2)

the
LSR will have at least queued a notify message

to the LSR that previously requested the label (and

subsequently aborted the request) (LAbR.3)

the
LSR must itself not have an outstanding label

request (that would be to a downstream next hop

LSR) (LAbR.4) and

the
LSR must have a label mapping (again from a

downstream next hop) (LAbR.5)

Otherwise, the step at LAbR.6 is skipped.
From this, you

can see that this step has nothing to do with
the text you

point out in section 3.5.10.  The purpose
of this step (as

indicated in note 2) is to ensure that any label
mapping

the local LSR has received that is made irrelevant
by the

label request abort message it has just received
will be

correctly dealt with.

Step LAbR.2 (highlighted above) ensures that
- in the

event that a label mapping crossed the label
request

abort (in the mail, so to speak) - the local
LSR ignores

the label request abort.  This is done -
as you may know

- because the procedures for the receipt of the
label

mapping at the upstream LSR will ensure that
a label

release is subsequently sent - if that is what
that LSR

wants to do at that time.

The procedures for dealing with the downstream
label

mapping in this case just happen to be exactly
the same

as they would be if a label mapping had been
sent to the

upstream LSR - based on the prior label request
and the

existing label mapping from the downstream LSR
- and

subsequently released.

Does this clarify the issue for you?

--

Eric Gray

You wrote:

Hi,

I was looking thro' the
rfc 3036.

If an LSR receives a Label Abort Request Message after
it has

responded to the Label Request in question with a Label
Mapping

message or a Notification message, it ignores the abort
request.

LAbR.6  Generate Event: Received
Label Release Message for FEC

Goto LAbR.11.

I feel that we have to follow what is mentioned in the section
3.5.10,

explicitly based on its retention mode. Let me know how do U think
??

Thanks

Chetan S

___________

-- George Bernard Shaw

---

From: Bob Thomas <[email-masked]>
Date: Thu, 19 Apr 2001 09:18:16 -0400

Chetan,

> explicitly based on its retention mode. Let me know how do U think ??

LAbR.6 handles the following situation:

   MsgSource ------ LSR ------ R ...

where:

- LSR has received a label mapping for FEC from R;
- LSR has not yet sent a label mapping for FEC to MsgSource;

In this case LSR may need to release the label mapping it
received from R.

So far as LSR is concerned this situation is identical to one where it
had sent a label mapping for FEC to MsgSource and subsequently
received a label release for FEC from MsgSource.  Therefore, this
situation can be handled by LSR by behaving as if it has received a
label release for FEC from MsgSource.

Bob

---

From: "chetan kumar s" <[email-masked]>
Date: Fri, 20 Apr 2001 10:45:52 +0530 (IST)

> - LSR has not yet sent a label mapping for FEC to MsgSource;

Hi,
hmm.. makes sense.. Thanks for clarifying..

Chetan S