Subject: Does MPLS Require L3 Routing Table ?

From: "Rajesh P Jain" <[email-masked]>
Date: Fri, 13 Apr 2001 12:52:55 +0530

"Hello", List,
                    Well, I am very new to the MPLS domain. I just wanted to check out whether MPLS domain neccesarily require the L3 Routing Table (Maybe IP Routing Table) to build up it's label (using the LDP Protocol). Or the LDP will take care of building the label information automatically without the L3 Routing information?

TIA
        Rajesh P Jain

---

From: "Bharti Batra" <[email-masked]>
Date: Fri, 13 Apr 2001 13:09:49 +0530

Hi !

Yes. LDP needs IP routing table to find out the route towards the egress router to setup the LSP. LDP sends the LSP setup request message along this path.

Regds,
Bharti
  ----- Original Message ----- 
  From: Rajesh P Jain 
  To: [email-masked] 
  Sent: Friday, April 13, 2001 12:52 PM
  Subject: Does MPLS Require L3 Routing Table ?

  "Hello", List,

  TIA
          Rajesh P Jain

---

From: "Rajesh P Jain" <[email-masked]>
Date: Fri, 13 Apr 2001 13:46:18 +0530

"Hello",
                        Thanks for the response.

                        Well, if it requires L3 Routing table to build up the Label information, then what is the advantage of MPLS??? Well, Anyhow, it will require the building of L3 Routing Table (May be through RIP/OSPF/BGP etc), then Lable info can be formed by using only L3. So, Anyhow, MPLS is dependent on L3, please explain me what is the advantage of using MPLS (in terms of efficiency and speed switching of the packets).

With Regards
                    Rajesh P Jain
  ----- Original Message ----- 
  From: Bharti Batra 
  To: Rajesh P Jain ; [email-masked] 
  Sent: Friday, April 13, 2001 1:09 PM
  Subject: Re: Does MPLS Require L3 Routing Table ?

  Hi !

  Regds,
  Bharti
    ----- Original Message ----- 
    From: Rajesh P Jain 
    To: [email-masked] 
    Sent: Friday, April 13, 2001 12:52 PM
    Subject: Does MPLS Require L3 Routing Table ?

    "Hello", List,

    TIA
            Rajesh P Jain

---

From: "JsDeng" <[email-masked]>
Date: Fri, 13 Apr 2001 16:50:42 +0800

Hello,

    From the internet drafts of MPLS fundamental ideas, you can find out the most exact answer. 

    In short, MPLS can do speedy switching functions by a cheap hardware and MPLS is easy to build up structured and scalable networks in global scope with its label stacking and label swapping mechanisms.

    Regards.

Deng Jisheng
  ----- Original Message ----- 
  From: Rajesh P Jain 
  To: Bharti Batra ; [email-masked] 
  Sent: Friday, April 13, 2001 4:16 PM
  Subject: Re: Does MPLS Require L3 Routing Table ?

  "Hello",
                          Thanks for the response.

  With Regards
                      Rajesh P Jain
    ----- Original Message ----- 
    From: Bharti Batra 
    To: Rajesh P Jain ; [email-masked] 
    Sent: Friday, April 13, 2001 1:09 PM
    Subject: Re: Does MPLS Require L3 Routing Table ?

    Hi !

    Regds,
    Bharti
      ----- Original Message ----- 
      From: Rajesh P Jain 
      To: [email-masked] 
      Sent: Friday, April 13, 2001 12:52 PM
      Subject: Does MPLS Require L3 Routing Table ?

      "Hello", List,

      TIA
              Rajesh P Jain

---

From: Abhijit Gadgil <[email-masked]>
Date: Fri, 13 Apr 2001 18:00:19 +0530 (IST)

MPLS does require layer 3 routing information. It works together with
Layer 3 routing information like OSPF / BGP etc. However the advantage of
MPLS is in terms of being able to label switch after it has formed the
LSPs. This is useful in case of hardware that cannot look into IP header
like ATM switches. Another advantage of MPLS is in terms of creating
explicitely routed label switched paths, which is useful in Traffic
Engineering. The original motivation for MPLS of being able to outperform
IP lookup is not the motivation for MPLS these days. Another advantage of
MPLS is its better than IP over ATM. Thus the advantages of MPLS can be
listed as follows.
1. Making use of network layer routing to create label switched paths.
2. No need to maintain 2 networks as in IP over ATM case.
3. Alleviating N^2 mesh problem common with ATM switches

hope that helps

-abhijit

On Fri, 13 Apr 2001, Rajesh P Jain wrote:

 >                        Well, I am very new to Jthe MPLS domain. I
 >just
wanted to check out whether MPLS domain neccesarily require the L3 Routing
Table (Maybe IP Routing Table) to build up it's label (using the LDP
Protocol). Or the LDP will take care of building the label information
automatically without the L3 Routing information?

---

From: David Charlap <[email-masked]>
Date: Fri, 13 Apr 2001 15:06:15 -0400

Rajesh P Jain wrote:

> Well, if it requires L3 Routing table to build up the Label
> information, then what is the advantage of MPLS??? Well, Anyhow, it
> will require the building of L3 Routing Table (May be through
> RIP/OSPF/BGP etc), then Lable info can be formed by using only L3. So,
> Anyhow, MPLS is dependent on L3, please explain me what is the
> advantage of using MPLS (in terms of efficiency and speed switching of
> the packets).

There are two reasons.

One is that label-switched forwarding engines may be simpler.  It is
easier to look at a single fixed-size label to determine next-hop than
it is to do a best-match against an IP destination.  While there are
forwarding chips that will do best-match forwarding at very high speeds
(even line-rate OC-192), the algorithm is still more complicated than a
label lookup.  A simpler algorithm means (all other things being equal,
which they rarely are) that simpler forwarding chips may be used,
resulting in several potential savings (including smaller chips, fewer
chips per board, lower power consumption, etc.)

The second reason for MPLS is traffic engineering.  If explicit routes
are used (in CR-LDP or RSVP-TE), then a transit/egress router does not
require the entire routing table.  It only needs to know the addresses
of its immediately-attached neighbors.  The only router that needs the
entire table is the ingress router, and even it doesn't need the whole
table if the explicit routes are not automatically generated.

---

From: "Mark Seery" <[email-masked]>
Date: Fri, 13 Apr 2001 12:07:00 -0700

To make the statement that the only way to program an MPLS FIB is via an IP
control plane is not strictly speaking true, though the intent of the
statement is understood. It is true however to say that there will be many
capabilities not achieved if a network layer control plane is not used, such
as the ones stated below.

On the issue of performance, it is true that it is possible to use
technology that does longest prefix match at wire rate. It is also true that
there are issues not related to performance in using such technology, and
that these issues may or may not make a difference depending on the overall
design goals and application of the system. It is also true that due to the
continued evolution of silicon, even these differences may not exist at some
point in the future.

-mark.s.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Abhijit
Gadgil
Sent: Friday, April 13, 2001 5:30 AM
To: Rajesh P Jain
Cc: Bharti Batra; [email-masked]
Subject: Re: Does MPLS Require L3 Routing Table ?

hope that helps

-abhijit

On Fri, 13 Apr 2001, Rajesh P Jain wrote:

 >"Hello",
 >                        Thanks for the response.
 >
 >                        Well, if it requires L3 Routing table to build up
the Label information, then what is the advantage of MPLS??? Well, Anyhow,
it will require the building of L3 Routing Table (May be through
RIP/OSPF/BGP etc), then Lable info can be formed by using only L3. So,
Anyhow, MPLS is dependent on L3, please explain me what is the advantage of
using MPLS (in terms of efficiency and speed switching of the packets).
 >  Yes. LDP needs IP routing table to find out the route towards the egress
router to setup the LSP. LDP sends the LSP setup request message along this
path.