Subject: RE: draft-gan-fast-reroute-00.txt

From: "Metz, Eduard" <[email-masked]>
Date: Fri, 13 Apr 2001 08:48:22 +0200

Hi,

haven't read the draft in detail yet, but adding support for SRLG to avoid
detours to be routed over links that share the same risk seems very
useful.Sometimes even a plain requirement to deploy fast re-route in a
usefull way. As an example consider the situation described in section 2,
when link 1-2 and link 1-3 run in the same cable both the main LSP and the
potential detour are affected by a single cable-cut. Leaving you with
regular re-route.

Some other questions:
- What will happen if the detour from Node1 to Node3 (picture section 2)
passes Node4? Will the detour terminate at Node4, or will the traffic will
pass link 3-4 two times?
- Similar to the above, but now for the case where the detour passes the
Egress?

Thanks.

cheers,
	Eduard

> -----Original Message-----
> From: Ping Pan [mailto:[email-masked]]
> Sent: 13 April 2001 01:41
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Re: draft-gan-fast-reroute-00.txt
> 
> 
> Curtis Villamizar wrote:
> > 
> > > > It should be fine to provide a object that names a 
> specific node as a
> > > > special case of the detour object, and may be (is) needed to
> > > > accommodate existing code.  It might be useful to have 
> a form of the
> > > > detour object that covered the link disjoint special 
> case.  There
> > > > should also be a form of the detour object that allows the more
> > > > general list of SRLG.
> > > >
> > > > SRLG should also be considered in the "Detour Path Computation
> > > > Algorithm" section.
> > >
> > > Sure. Thanks!
> > 
> > So you'll add one or two Objects to cover SRLG, and 
> possible the link
> > disjoint special case.
> > 
> 
> Let me check with other folks here. We have shipped the restoration
> feature for a while, and providers have deployed it. So we have to be
> careful. Please understand.
> 
> Thanks again!
> 
> - Ping
>

---

From: Ping Pan <[email-masked]>
Date: Fri, 13 Apr 2001 00:11:42 -0700

> potential detour are affected by a single cable-cut. Leaving you with

Thanks for the input. Will get back to you asap.

> passes Node4? Will the detour terminate at Node4, or will the traffic will

I think that it is OK to have detour paths traversing through the same
nodes that the main LSP goes through. This type of loops does not
present problems in packet forwarding... except perhaps inefficient use
of network resources. But we need to be careful with the loop detection
mechanism described in the RSVP-TE draft.

> - Similar to the above, but now for the case where the detour passes the

No sure this can happen after CSPF computation.

Thanks!

- Ping