Subject: RV: Does MPLS Require L3 Routing Table ?

From: Javier Antich <[email-masked]>
Date: Thu, 19 Apr 2001 10:56:47 +0200

> > How would you get the LSPs  to be setup "automatically between
all your edge
	> > routers" without having any L3 routing information in the core?

	>i'm not an ldp expert, but i assume that using the du mode, each
egress
	>router can advertise an lsp to itself to all its neighbors and so
on.
	>thus eventually every router in the system would have a path to
every
	>egress router.  this assumes that each router adds itself to the
	>advertisement in order to cut the loops.

Yes, that is true, but how would the core router choose the right label
towards the right next hop if it receives a label assignment from two or
more neighbours for the same route? That might happen, and the core router
must use its IGP routing table to select the right label and right
nexthop/outgoing interface.

                                          ^   ^
==============ooo====(.)v(.)====ooo=====
Javier Antich Romaguera
Network Consultant
---------------------------------------------------------------------------
TELINDUS 
Pza. Ciudad de Viena, 6-2º
28040 Madrid 
---------------------------------------------------------------------------
[email-masked]
tel: +34 91 456 00 08
fax: +34 91 536 10 74
---------------------------------------------------------------------------
For more information about our products and services,
please visit our website http://www.telindus.com
---------------------------------------------------------------------------
Full connectivity & mobility
==================ooo0===0ooo========

> -----Mensaje original-----
> De:	Juha Heinanen [SMTP:[email-masked]]
> Enviado el:	jueves 19 de abril de 2001 4:31
> Para:	[email-masked]
> CC:	[email-masked]; [email-masked]
> Asunto:	Re: Does MPLS Require L3 Routing Table ? 
> 
> 
>  > How would you get the LSPs  to be setup "automatically between all your
> edge
>  > routers" without having any L3 routing information in the core?
> 
> i'm not an ldp expert, but i assume that using the du mode, each egress
> router can advertise an lsp to itself to all its neighbors and so on.
> thus eventually every router in the system would have a path to every
> egress router.  this assumes that each router adds itself to the
> advertisement in order to cut the loops.
> 
> -- juha

---

From: Zhi Hao Hong <[email-masked]>
Date: Thu, 19 Apr 2001 17:15:26 +0800

I am just curious if any real SP network implemented MPLS network without BGP enabled in the core, even we all know this "BIG" benefits for mpls. I ever was involved in engineering several SP MPLS networks.  Interesting, nobody talk about this, so I just keep this curiosity in my mind.

Regards. 

At 10:55 2001-4-19 +0200, Javier Antich wrote:
>Well, I have been following the thread and I have not seen one basic thing.
>Of course you need IP routing table if you run MPLS in and IP network, but,
>you do not need to have the full Internet routing table in all the routers.
>You can remove BGP from the core so that BGP decisions and Next-hop BGP
>resolutions are done at the edge and the appropriate label is selected for
>reaching the right exit point from the cloud. Then, you need IP routing
>table, but if it is a core router and it is an Internet environment, the
>routing table can be much smaller than it would be if you were not running
>MPLS.
>
>Sorry if someone received the mail several times, I am having some problems
>with my subscription.
>                                          ^   ^
>>       De:     Rajesh P Jain [SMTP:[email-masked]]
>>       Enviado el:     viernes 13 de abril de 2001 10:16
>>       Para:   Bharti Batra; [email-masked]
>>       "Hello",
>>                               Thanks for the response.
>>                               Well, if it requires L3 Routing table to
>> build up the Label information, then what is the advantage of MPLS???
>> Well, Anyhow, it will require the building of L3 Routing Table (May be
>> through RIP/OSPF/BGP etc), then Lable info can be formed by using only L3.
>> So, Anyhow, MPLS is dependent on L3, please explain me what is the
>> advantage of using MPLS (in terms of efficiency and speed switching of the
>> packets).
>>       
>>       With Regards
>>                           Rajesh P Jain
>> 
>>               ----- Original Message ----- 
>>               From: Bharti Batra <mailto:[email-masked]> 
>>               To: Rajesh P Jain <mailto:[email-masked]> ; [email-masked]
>> <mailto:[email-masked]> 
>>               Sent: Friday, April 13, 2001 1:09 PM
>>               Subject: Re: Does MPLS Require L3 Routing Table ?
>> 
>>               Hi !
>>               
>>               Yes. LDP needs IP routing table to find out the route
>> towards the egress router to setup the LSP. LDP sends the LSP setup
>> request message along this path.
>>               
>>               Regds,
>>               Bharti
>> 
>>                       ----- Original Message ----- 
>>                       From: Rajesh P Jain <mailto:[email-masked]> 
>>                       To: [email-masked] <mailto:[email-masked]> 
>>                       Sent: Friday, April 13, 2001 12:52 PM
>>                       Subject: Does MPLS Require L3 Routing Table ?
>> 
>>                       "Hello", List,
>>                                           Well, I am very new to the MPLS
>> domain. I just wanted to check out whether MPLS domain neccesarily require
>> the L3 Routing Table (Maybe IP Routing Table) to build up it's label
>> (using the LDP Protocol). Or the LDP will take care of building the label
>> information automatically without the L3 Routing information?
>>                       
>>                       TIA
>>                               Rajesh P Jain
>>

---

From: Javier Antich <[email-masked]>
Date: Thu, 19 Apr 2001 11:20:19 +0200

I have seen it. This was a completely new network, but probably an operator
which already has BGP implemented in the core will leave it running "just in
case".

                                          ^   ^

> De:	Zhi Hao Hong [SMTP:[email-masked]]
> Enviado el:	jueves 19 de abril de 2001 11:15
> Para:	Javier Antich; [email-masked]
> Asunto:	Re: RV: Does MPLS Require L3 Routing Table ?
> 
> 
> I am just curious if any real SP network implemented MPLS network without
> BGP enabled in the core, even we all know this "BIG" benefits for mpls. I
> ever was involved in engineering several SP MPLS networks.  Interesting,
> nobody talk about this, so I just keep this curiosity in my mind.
> 
> Regards. 
>