Subject: AW: MPLS Trafficdriven

From: Hummel Heinrich <[email-masked]>
Date: Wed, 25 Apr 2001 14:34:58 +0200

What you are looking for is a MPLS UNI, where a user may request the establishment of an LSP all by signalling.
Some work is going on in the MPLS Forum to specify such capability.

Regards,
Heinrich Hummel
Siemens AG

> -----Urspr> üngliche Nachricht-----
> Von:	MP LS [SMTP:[email-masked]]
> Gesendet am:	Mittwoch, 25. April 2001 14:29
> An:	[email-masked]; [email-masked]
> Betreff:	MPLS Trafficdriven
> 
> Hello all,
> 
> I have a question. Is there any possibile way to create a fully dynamical 
> Traffic driven MPLS network. So that when any packet arives at an LSR it 
> will analyse the IP pakket ads a label in front of it with it combines to a 
> FEC and then just sent it to the Destination LSR?  Just till now i only 
> found that you have to ask for an LSP manualy and then the data can be 
> transported over it.
> 
> I hope someone can make this clear for me.
> 
> Kind regards,
> 
> Niels Sitters
> _________________________________________________________________________
> Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

---

From: "Metz, Eduard" <[email-masked]>
Date: Wed, 25 Apr 2001 14:47:26 +0200

Most current MPLS implement either:
- topology driven LSP setup, based on the IP routing table;
- request driven LSP setup, typically this is used for TE purposes.

As far as I know traffic driven has been used only in e.g. Ipsilon's IP
switching which can be seen as a pre-decessor of what currently is known as
MPLS.

By the way: traffic-driven would mean, the LSP is setup based on the arrival
of traffic. This is slightly different from what you described below. An
edge LSR will always inspect the IP header and then place the packet in the
appropriate LSP (independent of the LSP is setup).

cheers,
	Eduard

> -----Original Message-----
> From: Hummel Heinrich [mailto:[email-masked]]
> Sent: 25 April 2001 14:35
> To: 'MP LS'; [email-masked]; [email-masked]
> Subject: AW: MPLS Trafficdriven
> 
> 
> What you are looking for is a MPLS UNI, where a user may 
> request the establishment of an LSP all by signalling.

---

From: Ashwin Moranganti <[email-masked]>
Date: Wed, 25 Apr 2001 09:33:33 -0400

I have seen this as one of the feature in Lucent's IP Navigator MPLS
product.
The ports are configurable for this feature, and when a certain traffic flow
is detected LSPs are signalled for and the data is transmitted and then LSPs
are destroyed. Though this is not useful for all applications. The key here
is the signalling rate. If the rate is satisfactory, it is useful for some
applications

thankyou
Ashwin

-----Original Message-----
From: MP LS [mailto:[email-masked]]
Sent: Wednesday, April 25, 2001 8:29 AM
To: [email-masked]; [email-masked]
Subject: MPLS Trafficdriven

Hello all,

Kind regards,

Niels Sitters

-------
The MPLS-OPS Mailing List
Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
Archive: http://www.mplsrc.com/mpls-ops_archive.shtml

---

From: Javier Antich <[email-masked]>
Date: Wed, 25 Apr 2001 20:29:29 +0200

Well, that "on demand" does not mean usually "when traffic arrives", but
"when I get an entry in my routing table for that destination". However it
could be the first meaning. I am not sure whether traffic driven models
would scale in the core of Internet. 

Javier.
                                          ^   ^
==============ooo====(.)v(.)====ooo=====
Javier Antich Romaguera
Network Consultant
---------------------------------------------------------------------------
TELINDUS 
Pza. Ciudad de Viena, 6-2º
28040 Madrid 
---------------------------------------------------------------------------
[email-masked]
tel: +34 91 456 00 08
fax: +34 91 536 10 74
---------------------------------------------------------------------------
For more information about our products and services,
please visit our website http://www.telindus.com
---------------------------------------------------------------------------
Full connectivity & mobility
==================ooo0===0ooo========

> -----Mensaje original-----
> De:	Marinzulich, Matias [SMTP:[email-masked]]
> Enviado el:	miércoles 25 de abril de 2001 19:58
> Para:	'Ashwin Moranganti'; 'MP LS'; [email-masked]; [email-masked]
> Asunto:	RE: MPLS Trafficdriven
> 
> Hello all, as far I can see, all cell-mode MPLS implementations (that is,
> MPLS network constructed with ATM switches) use 'on demand' label
> allocation. Since you have a very small place for save the label, the
> allocation and distribution must be highly conservative. For stay this
> minimal, all LSP are created 'on demand' in this kind of networks.
> In the other hand, MPLS networks based in routers can use 'on demand' or
> unsolicited label distribution.
> 
> Matias.-
> 
> > -----Mensaje original-----
> > De:	Ashwin Moranganti [SMTP:[email-masked]]
> > Enviado el:	Miércoles, 25 de Abril de 2001 10:34 a.m.
> > Para:	'MP LS'; [email-masked]; [email-masked]
> > Asunto:	RE: MPLS Trafficdriven
> > 
> > The ports are configurable for this feature, and when a certain traffic
> > flow is detected LSPs are signalled for and the data is transmitted and
> > then LSPs are destroyed. Though this is not useful for all applications.
> > The key here is the signalling rate. If the rate is satisfactory, it is
> > useful for some applications
> > 
> > thankyou 
> > Ashwin 
> > 
> > From: MP LS [ <mailto:[email-masked]>] 
> > will analyse the IP pakket ads a label in front of it with it combines
> to
> > a 
> > Get Your Private, Free E-mail from MSN Hotmail at
> > <http://www.hotmail.com>. 
> > 
> > ------- 
> > Subscribe/Unsubscribe:  <http://www.mplsrc.com/mplsops.shtml> 
> > Archive: <http://www.mplsrc.com/mpls-ops_archive.shtml> 
> >

---

From: "Kent Yu" <[email-masked]>
Date: Wed, 25 Apr 2001 14:34:02 -0400

Niels,

 If you are asking traffic driven LSP, there are many docs you could find
 from the web.
 Some vendors, as Ashwin mentioned Lucent IP Navigator in his reply, already
 integrated this feature.
 It is hard to imagine a instantly traffic-driven network can be useful in
 the real world, one of  the solutions probably is the LSR keeps track the
taffic state of the whole network, we give it a configurable time syntax so
 it will compute and setup LSPs upon each calculation periodically. The
network could be unstable and unpredictable, especially when you add the
 bypass and backup links. Probably we could get a decent optimization on the
 fly to some extend at some time, but this needs to verified and justified
in
 the real world.

 As for the MPLS to the desktop, I am not sure it is necessary, IMHO,
current
 IGPs are sufficient for enterprise users.

 Kent Yu
 Lucent Technologies Worldwide Services

> ----- Original Message -----
> From: "MP LS" <[email-masked]>
> To: <[email-masked]>; <[email-masked]>
to
> > Get Your Private, Free E-mail from MSN Hotmail at
http://www.hotmail.com.

---

From: Ashwin Moranganti <[email-masked]>
Date: Wed, 25 Apr 2001 15:19:07 -0400

"traffic driven" models are not for the core internet.
But there are some applications in the VOIP networks which can use this
feature.

Ashwin

-----Original Message-----
From: Javier Antich [mailto:[email-masked]]
Sent: Wednesday, April 25, 2001 2:29 PM
To: Marinzulich, Matias; 'Ashwin Moranganti'; 'MP LS'; [email-masked];
[email-masked]
Subject: RE: MPLS Trafficdriven

Javier.
                                          ^   ^

---

From: "Hass, Barry" <[email-masked]>
Date: Wed, 25 Apr 2001 17:14:58 -0400

Hi Geoff,

Would it make sense to use the DSCP field for flow aggregation, perhaps
in combination with the IP destination address?

Barry

> It makes sense to pursue the idea of data driven LSP setup, but it's
> essential to combine this approach with a flow aggregation mechanism if we
> expect to deploy such a technology in "large networks" (eg. a Service
> Provider).  In theory the Ingress LSR could be given the capability to
> aggregate flows of information into a single LSP, but the details of how
> this could be done are generally clouded in marketing smoke and mirrors
> today.  The issue is that IPv4 lacks either a flow label (which IPv6 has),
> or a session identifier (that ISO TP4 has) to provide an easy
> classification mechanism.  The current "edge LSR" implementations are
> handicapped by these limitations.  So how can they assign or aggregate
> traffic?  They are normally limited to assignment on the basis of
> destination IP address (essentially useless in most cases), or by the use
> of the Port ID, or by some combination of these two.  In other words,
> whatever criteria you can use to build a filter or ACL, you can use to
> assign individual packets to an existing LSP (or as a trigger mechanism to
> create a new LSP). 
>

---

From: "Hass, Barry" <[email-masked]>
Date: Thu, 26 Apr 2001 09:16:47 -0400

Hi Geoff,

I agree completely with everything you say here. I think that a policy
server (perhaps located in the LSR, perhaps in a separate box) has to
do the classification. And I imagine that classification policies would be
based on fields in the L3 and higher layer headers.

Barry

> From:	Geoff Bennett [SMTP:[email-masked]]
> Sent:	Thursday, April 26, 2001 2:32 AM
> To:	Hass, Barry; Marinzulich, Matias; 'Ashwin Moranganti'; 'MP LS';
> [email-masked]; [email-masked]
> Hi Barry,
> Yes it would make sense.  But who sets the DSCP field?
> 
> The "end user" can't be allowed to do this because DSCP is used to
> prioritise traffic, and everyone would set their traffic to high priority.
> 
> The ideal thing would be to build proxy devices to insert the appropriate
> value according to a policy.  IMHO the obvious location for such a proxy
> is
> the Ingress LSR.  But the problem is how do you recognise the appropriate
> traffic types.
> 
> Cheers,
> Geoff
> 
> 
> 
> 
> At 17:14 25/04/01 -0400, Hass, Barry wrote:
> >Hi Geoff,
> >
> ================================================================
> Geoff Bennett
> Tel: (33) 497 21 43 62
> Director of Technology, OCTO
> Fax: (33) 497 21 43 50
> Marconi
> Gaia - Bat. E
> email: [email-masked]
> BP 123
> 06903 SOPHIA ANTIPOLIS
> FRANCE
> ================================================================

---

From: "Kent Yu" <[email-masked]>
Date: Wed, 25 Apr 2001 14:34:02 -0400

Niels,

 Kent Yu

to
http://www.hotmail.com.

-------

---

From: Ruyter Hill <[email-masked]>
Date: Fri, 27 Apr 2001 10:01:09 +0100

Geoff 

It may be worth mentioning here that in MPLS we have the option 
to completely ignore the TOS bits in the IP packet and write our own
COS into the EXP field of the MPLS shim header 
this can be done either by trusting the settings from the customer or by
filtering 
on TCP/UDP port number to define the traffic type before assigning a class
and writing the EXP 

MPLS traffic is prioritised through the network by the EXP field so if you
neglect to configure 
a copy into or fresh write of the exp field I am not sure what the default
behaviour is 

Can any one answer that question for me 
Hill 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of [email-masked]
Sent: 26 April 2001 08:18
To: Geoff Bennett; Hass, Barry; Marinzulich, Matias; 'Ashwin
Moranganti'; 'MP LS'; [email-masked]; [email-masked]
Subject: RE: MPLS Trafficdriven

geoff,
As U mentioned.....
"But the problem is how do you recognise the appropriate
 traffic types."
Well we can solve this Problem:
In the Ingress Router the ASIC device is already Configured
to handle respective Packet types based on Profiles/Policies.
End user can set the DSCP field in the transmitted IP packet 
to the Ingress Router. Now after receiving the IP Packet, 
Router checks the IP address and the DSCP field then validates 
via looking into the Port number and other stuff. By the way
ASIC must be configured with such stuff to process such Traffic.
Hence if somebody is sending email but prtending this is a VoIP
packet it can be easily detected and either packet can be dropped
or DSCP field changed accordingly. This is completely a configuration
issue as to how to set up the ASIC for what type of traffic.
SNMP or CLI can be used to configure such things.
Hope, this helps........
vola 

is
> the Ingress LSR.  But the problem is how do you recognise the appropriate

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - buy the things you want at great prices
http://auctions.yahoo.com/

-------