Subject: RE: Explicit Null Label

From: Eyad Saheb <[email-masked]>
Date: Tue, 17 Apr 2001 08:37:27 -0400

Hi,

	Forgive my ignorance, but Explicit Null can still be used for its
initial purpose: identifying the L3 protocol type.
	Also, and I'm not too versed in ATM, but it might be useful for
switches which cannot pop the stack.  Thus the edges would send an Explicit
Null mapping  if they are the egress for an LSP.

Eyad

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Eric Gray
Sent: April 17, 2001 8:16 a
To: [email-masked]
Cc: [email-masked]
Subject: Re: Explicit Null Label

Anil,

    It is not necessary to preserve the value of the EXP bits
using the explicit NULL label if the penultimate hop is able
to map the bits to a corresponding DSCP in the IP header.
But this is just one example of what the penultimate hop
might not be able to do, thus creating a need for explicit
NULL labels...

--
Eric Gray

You wrote:

> Is there any other purpose for an explicit null label other than
preserving
> the Exp field for QoS purposes?
> Thanks,
> -Anil
>
> Anil Gunturu, Software Engineer
> Ericsson, Inc                           phone: (805) 562 6431
> Datacom & IP Services                   email: [email-masked]
> 70 Castilian Dr, Santa Barbara, CA-93117

---

From: Eric Gray <[email-masked]>
Date: Tue, 17 Apr 2001 09:01:29 -0400

Eyad,

Forgiven. :-)

There is no need to identify the L3 protocol if the
penultimate hop

has already done so.  Also, with the pointed exception of explicit

NULL labels, no label may be used that was not explicitly issued

by the LSR that receives them.  Therefore, only a very lame LSR

would issue a label which it will have to pop without knowing what

L3 will be underneath it.  In that sense, every LSR may create
as

many 'explicit NULL' labels for as many underlying encapsulation

protocol/formats as it is capable of supporting.

The inability of the penultimate hop to 'pop the
stack' is exactly

one of the other examples implied in my earlier reply.  I believe
in

trying the short answer first.

--

Eric Gray

You wrote:

Hi,

Forgive my
ignorance, but Explicit Null can still be used for its initial purpose:
identifying the L3 protocol type.

Also, and I'm
not too versed in ATM, but it might be useful for switches which cannot
pop the stack.  Thus the edges would send an Explicit Null mapping
if they are the egress for an LSP.

Eyad

-----Original Message-----

From: [email-masked] [mailto:[email-masked]]On
Behalf Of Eric Gray

Cc: [email-masked]

Anil,

It is not necessary to preserve the
value of the EXP bits

using the explicit NULL label if the penultimate hop
is able

But this is just one example of what the penultimate
hop

NULL labels...

--

Eric Gray

You wrote:

> Is there any other purpose for an explicit null label
other than preserving