Subject: MPLS TE question

From: Dirk Maeckelberghe <[email-masked]>
Date: Mon, 30 Apr 2001 14:52:45 +0200

Hello,

Can you point me to the right references or help answer underneath questions.

I need to know if I can use the TE extensions to setup an LSP using RSVP-TE ( cross area )  in case my IGP is  hierarchical IS-IS (
L1 and L2 ).
Can I assume that summarization happens at area boundaries and that the detailed TE info does not get propagated inside the area ?

This is case A to B where A,B LER and L2A and L2B LSR

A - area 1 - L2A ---- L2X --- L2B - area 2 - B

If now I am only extending my MPLS cloud to the L2 routers ( L2A - L2B are now LER ), A and B are NON-MPLS routers,
can I then use the TE extensions of IS-IS to do TE between the L2A and L2B.
I understand that the L2 routers only  form L2 adjacencies, are the TE extensions communicated between them ?

A - area 1 - L2A ---- L2X --- L2B - area 2 - B

Thanks,

Dirk

---

From: Giles Heron <[email-masked]>
Date: Mon, 30 Apr 2001 15:56:24 +0100

> Can I assume that summarization happens at area boundaries and that the detailed TE info does not get propagated inside the area ?

TE information doesn't cross area boundaries.

You can't use CSPF to set up RSVP-TE LSPs across area boundaries (or at
least not yet - there is work in progress on multi-area TE.)  However
you can set up RSVP-TE LSPs across areas by specifying an explicit path.

> can I then use the TE extensions of IS-IS to do TE between the L2A and L2B.

Yes.

> I understand that the L2 routers only  form L2 adjacencies, are the TE extensions communicated between them ?

The L2 routers will communicate TE information to each other.  Each will
set up a Traffic Engineering Database containing this information (which
can then be used for CSPF.)

Just out of interest - are you sure you need to build a hierarchical
IS-IS network?  AFAIK most large ISPs run IS-IS using level 2 only?

Giles

-- 
============================================================
Giles Heron      Principal Network Architect      Gone2 Inc.
ph: +44 7880 506185         "if you build it they will yawn"
============================================================