Subject: Re: RE: doubt in RFC 3031

From: "Bhupesh Bajaj" <[email-masked]>
Date: Mon, 30 Apr 2001 16:22:57 +0530

hello,

as far as i believe the penultimate hop is going to behave in same way ( as far as number of lookups is concerned )in both cases with / without using this technique.."penultimate hop popping"..

so i believe it needn't be mentioned in RFC that with PNP one gets the benifit of just one lookup from penultimate hop side also as they have mentioned in RFC

waiting for comments,

thanks and regards,
bhupesh

Get Your Private, Free E-mail from Indiatimes at http://email.indiatimes.com

---

From: Eric Osborne <[email-masked]>
Date: Mon, 30 Apr 2001 10:57:43 -0400

> so i believe it needn't be mentioned in RFC that with PNP one gets the benifit of just one lookup from penultimate hop side also as they have mentioned in RFC

The statement may be extraneous, but it's certainly true.  THe idea
was (I think) to point out that implicit-null causes no extra work on
the penultimate router.  Is there major objection to pointing this
out?

eric

---

From: Eric Gray <[email-masked]>
Date: Mon, 30 Apr 2001 13:13:25 -0400

Eric,

    If you mean that the use of penultimate hop pop reduces the
'look-up' requirement at the egress without increasing the
'look-up' requirements at the penultimate hop, then you are
correct.

    But it does incur some extra work for the penultimate hop -
particularly in the case where the last label (bottom of stack)
is being removed.  Without penultimate hop pop, the penultimate
hop doesn't even have to look to see if the current label is the
last one.  With PHP it has to do this and use different encap-
sulation depending on the result.  There is also implicit state
requirements associated with accepting the implicit NULL
label.  This is cheap, but it isn't free.

    The current wording in the RFC, states that there is no
new lookup required at the penultimate hop and - as you
point out below - it is correct.  It is not extraneous because
the statement is needed in order to demonstrate that the
desirability of the PHP optimization is justified.

--
Eric Gray

---

From: Eric Osborne <[email-masked]>
Date: Mon, 30 Apr 2001 10:57:43 -0400

eric
 
> Get Your Private, Free E-mail from Indiatimes at http://email.indiatimes.com

-------
The MPLS-OPS Mailing List
Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
Archive: http://www.mplsrc.com/mpls-ops_archive.shtml

---

From: "Kent Yu" <[email-masked]>
Date: Mon, 30 Apr 2001 23:07:20 -0700

bhupesh,

Seems to me the phrase here emphasizes the PHP does not require either the
egress or the penultimate router do more than one lookup. The authors, IMHO,
believe it is necessary to clarify the PHP does not transfer the two lookups
from the edge to either the penultimate hop or any other LSRs along the LSP.

HTH

Kent Yu

----- Original Message -----
From: "Bhupesh Bajaj" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Monday, April 30, 2001 3:52 AM
Subject: Re: RE: doubt in RFC 3031

> hello,
>
> as far as i believe the penultimate hop is going to behave in same way
 as far as number of lookups is concerned )in both cases with / without
using this technique.."penultimate hop popping"..
>
> so i believe it needn't be mentioned in RFC that with PNP one gets the
benifit of just one lookup from penultimate hop side also as they have
mentioned in RFC