Subject: RE: Control Channel Doubt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Fri, 22 Jun 2001 22:35:55 +0200

Please DO NOT cross post to multiple mailing lists with largely
overlapping audiences. Choose one list and discuss it there.

Thanks, Bert

> ----------
> From: 	manoj juneja[SMTP:[email-masked]]
> Sent: 	Friday, June 22, 2001 9:37 PM
> To: 	[email-masked]; [email-masked]
> Subject: 	Control Channel Doubt
> 
> Hi All,
>           Consider the following scenario :
> 
>    If I have 2 nodes A and B connected by 3 links (viz. OC-3, OC-192 and 
> OC-48). Furthermore, I have a out-of-fiber control channel running on 
> ethernet between these two nodes. Here, I am considering the case of one 
> control channel for all the three data plane interfaces. When an incoming 
> path message is received, how to identify for which incoming data plane 
> interface this is for ? or Do I have to configure three control channels 
> correspondng to each of the data plane interfaces ?
> 
> Please clarify my doubt.
> 
> Regards,
> manoj.
> 
> 
> 
> _________________________________________________________________
> Get your FREE download of MSN Explorer at http://explorer.msn.com
> 
>

---

From: Suresh Katukam <[email-masked]>
Date: Fri, 22 Jun 2001 13:51:30 -0700

Saurabh,

Consider two nodes: A ---- B (There are 3 links as
Manoj pointed out).

1. How does A indicate to B on which link the node
B should make reservation on?

Your message to Manoj only indicates that B should copy
the LIH value from PATH to RESV message. This does not
provide information to B which link to choose from.
It works fine for IF/IB case but not for OF/OB.

For this, LMP has been proposed to discover each other's
port ids. For OIF point of view, LIH value in the HOP
object of the PATH message should indicate A's local
port ID on which A wants to allocate resources on.
Since B knows using LMP or manual configuration,
A's internal port id, it can figure out what link
that it needs to make reservations on.

There are other proposals (new HOP object) that can
be used by node A to indicate to B about the link that
it wants to make reservations on.

Hope this clarifies,
-- Suresh Katukam

Saurabh Shrivastava wrote:
> 
> manoj,
> there is something called a LIH (logical interface
> handle) in the HOP Object in the PATH message - this
> shd be copied into the RESV, so that the receiver
> can know on which interface it shd make reservations
> even if it receives RESV on some other interface.
> -saurabh
> 
> ~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~
> Saurabh Shrivastava          [email-masked]
> 
> TiMetra Networks, Inc.       408.245.8796 (residence)
> http://www.timetra.com/      650.237.5154 (office)
> ~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~
> 
> # -----Original Message-----
> # From: [email-masked] [mailto:[email-masked]]On Behalf Of manoj
> # juneja
> # Sent: Friday, June 22, 2001 12:37 PM
> # To: [email-masked]; [email-masked]
> # Subject: Control Channel Doubt
> #
> #
> # Hi All,
> #           Consider the following scenario :
> #
> #    If I have 2 nodes A and B connected by 3 links (viz. OC-3,
> # OC-192 and
> # OC-48). Furthermore, I have a out-of-fiber control channel running on
> # ethernet between these two nodes. Here, I am considering the
> # case of one
> # control channel for all the three data plane interfaces. When
> # an incoming
> # path message is received, how to identify for which incoming
> # data plane
> # interface this is for ? or Do I have to configure three
> # control channels
> # correspondng to each of the data plane interfaces ?
> #
> # Please clarify my doubt.
> #
> # Regards,
> # manoj.
> #
> #
> #
> # _________________________________________________________________
> # Get your FREE download of MSN Explorer at http://explorer.msn.com
> #

---

From: "Karmakar, Soumen" <[email-masked]>
Date: Fri, 22 Jun 2001 15:16:44 -0700

IMHO , each of the supported link will have an interface id. For out of
fiber IPCC the nodes may exchange LMP messages : BeginVerify, BeginVerifyAck
and then  Test messages over the infiber link (each link) . The
TestStatusSuccess message informs node A of its own and remote interface id.
Hence node A will have the mapping of the local and remote interface ID (of
node B). This information has to be manually configured for non automated
neighbour discovery.
Now when the PATH message is initiated , the RSVP Hop object will include
the LIH (the interface id or the port ID , which can be IP address for
numberd link or 32 bit identifier for unnumbered link) and on which the
connection is established 
As pointed out earlier , the node receiving the LIH in PATH message will
record the LIH and return it in the RESV message.
The second question , one IPCC can be associated with multiple component
links , hence configuring three control channels is not necessary. Of course
more than one can be done , in that case the RSVP Hop object will contain
the correct IP address of the control channel and the LIH.

Rgds,
Soumen

-----Original Message-----
From: Suresh Katukam [mailto:[email-masked]]
Sent: Friday, June 22, 2001 1:52 PM
To: mpls-wg
Subject: Re: Control Channel Doubt

Saurabh,

Hope this clarifies,
-- Suresh Katukam