Subject: Re: Any disadvantage about MPLS?

From: "Irfan Lateef" <[email-masked]>
Date: Tue, 05 Jun 2001 19:27:19 -0400

Eric,

>
>We cannot do much with 5 or more words worth of binary options
>that we cannot also do with the one-word label stack entry.  Do
>we truly need to differentiate more than 8 million (or so) flows in
>every network box, and at every network interface?
>
With the current experience with MPLS, and the need to design
high speed MPLS routers, I would like take your suggestion to
the extreme of saying that we should have only 16-bit labels.
This would allow faster label lookups. Hence it brings me to saying that 
32-bit MPLS label itself is actually a disadvantage in taking the designs to 
the next levels.

Irfan Lateef

>From: Eric Gray <[email-masked]>
>To: "Naidu, Venkata" <[email-masked]>
>CC: "[email-masked]'" <[email-masked]>, [email-masked],        
>[email-masked]
>Subject: Re: Any disadvantage about MPLS?
>Date: Tue, 05 Jun 2001 18:58:25 -0400
>
>Venkata,
>
>     Sigh.  Why do we let ourselves be dragged down this path?
>
>You wrote:
>
> > Another minor but worth mentioning disadvantage(s) are:
> >
> > (1) There is no protection for shim header:
> >     Both L2 and L3 have their own checksum/CRC
> >     for respective headers/PDUs. But won't cover shim
> >     header specifically. For example some L2s like ATM
> >     has checksum only for header (first label) not for
> >     their payload.
> >    (shim header + IP header + data are in ATM payloads)
> >
> >     It is difficult to rely on L1/L2 CRCs,
> >     even a single bit corruption in shim header
> >     may lead the LSP to different destinations
> >     not destined to!?!
>
>Most people tend to feel that L1/L2 error detection is sufficient.
>
> >
> >
> > (2) When many "bits" are available in hand (IPv4 IPv6 headers)
> >     to control the flow we can provide many features
> >     (ranging from diff-serv, TOS, encryption, precedence,
> >     fragmentation, control & many more options etc.)
> >     but expecting the same functionality with small number
> >     of bits in hand (shim header) is always difficult
> >     and disadvantages follow.
>
>We cannot do much with 5 or more words worth of binary options
>that we cannot also do with the one-word label stack entry.  Do
>we truly need to differentiate more than 8 million (or so) flows in
>every network box, and at every network interface?
>
> >
> >
> > (3) Remember there are always some pros-and-cons for
> >     hope-by-hope forwarding and switching (in theory)
> >     (mean to say connection-less vs connection-oriented also)
> >     We have to weigh them both for our needs, in what expense?
>
>I like your (Freudian?) description of routing as hope-by-hope
>forwarding and switching.  Cute.  :-)
>
> >
> >
> >  I am not going against MPLS, just to mention a few.
> >  If we start mentioning advantages, we can write a book
> >  challenging Yakov ;-)
>
>That might be a good idea.
>
> >
> >
> > --Venkata Naidu
> >
> > -> Hi ewliu!
> > ->
> > -> one disadvantage of mpls is that a four byte shim header is
> > -> inserted to every
> > -> network layer packet before being forwarded to data link layer, which
> > -> effectively increases the payload for data link layer.
> > ->
> > -> Regards
> > -> Mohit
> > ->
> > ->
> > ->
> > ->
> > -> [email-masked] on 06/05/2001 02:56:17 AM
> > ->
> > -> To:   [email-masked]
> > -> cc:   [email-masked] (bcc: Mohit Goel/HSS)
> > ->
> > -> Subject:  Any disadvantage about MPLS?
> > ->
> > ->
> > ->
> > ->
> > -> It seems that MPLS is good for almost everything,from QoS to
> > -> traffic engineering
> > -> and VPN.
> > ->
> > -> I want to get some information about its disadvantages,any
> > -> information will be
> > -> appreciated.
> > ->
> > -> _____________________________________________
> > -> ??????????????????   http://shopping.263.net/hotsale/summer/
> > -> [???????? ????????] ????????????95963????????/??????263
> > ->
> > ->
> > ->
> > ->
> > ->
>

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com

---

From: David Charlap <[email-masked]>
Date: Tue, 05 Jun 2001 20:32:25 -0400

Irfan Lateef wrote:
> This would allow faster label lookups. Hence it brings me to saying
> that 32-bit MPLS label itself is actually a disadvantage in taking
> the designs to the next levels.

MPLS labels are not 32-bit values.  They are stored in 32-bit integers
for the convenience of signaling protocols.

An MPLS label on an interface that uses shim headers (like POS) is 20
bits wide.

An MPLS label on an ATM interface may be 8, 12, 24 or 28 bits, depending
on the encoding scheme (SVC or SVP) and whether the cell structure is
UNI or NNI.  In general, I think most implementations use 24-bit labels
(SVC encoding with UNI-format cell structures.)

An MPLS label on a Frame Relay interface may be 10 or 23 bits, depending
on the DLCI width that the interface uses.

See also RFCs 3031, 3032 and 3034

-- David