Subject: Q RE N-POPS Value in LSR MIB

From: Paul Mannion <[email-masked]>
Date: Wed, 27 Jun 2001 14:26:12 +0100

Hi,
    Sorry if this has been answered already.

    I'm a little confused as to how the N-POP value in the LSR
    MIB is used in practice.

    i.e. if the N-POPS is > 1, say 2, which of the following is the
    correct behaviour assuming an incoming label stack size of 3.

    1] Pop 2 labels and lookup and forward according to the remaining
         label.

    2] Perform a lookup using each label before it is "popped", if this
        is the case i'm not sure what use the N-POP value is as the
action
        is specified by the lookup result in each case.

        thanks in advance
Paul

---

From: Shahram Davari <[email-masked]>
Date: Wed, 27 Jun 2001 06:52:06 -0700

Hi,

This question has been asked a number of times. If you read the LSR-MIB carefully it seems that a swap is modeled as a pop followed by a push. Therefore if you want to terminate an LSP and you know for sure that all the traffics inside that LSP are MPLS traffic, then setting N-POPs =2 and mplsOutSegmentPushTopLabel= true(1), will pop the top label and swap the lower ones.

However, it seems that there is no use for N-POPs >2, because as you said, an LSR needs to look at the lower labels to decide whether to terminate them or not.

Yours,
-Shahram 

> -----Original Message-----
> From: Paul Mannion [mailto:[email-masked]]
> Sent: Wednesday, June 27, 2001 9:26 AM
> To: [email-masked]; [email-masked]
> Subject: Q RE N-POPS Value in LSR MIB
> 
> 
> Hi,