Subject: RE: What we do if the LSP is preempted

From: <[email-masked]>
Date: Thu, 21 Jun 2001 17:03:11 -0700

Hello lei

  D____________________F
 /                                       \
A---------------B---------------------C
                   \_____E______/

Suppose i have a LSP ABEC of priority 3
And a LSP ADF with priority 4

Now i want to setup ABC with priority 2.
As the resources are not available on link AB i will preempt LSP ABEC
But there is a LSP ADF with priority 4 less than that of ABEC so if i
preempt
ABEC then won't it be fair to establish the LSP through ADFC and preempt ADF

if enough resources are not available ?

Thanks
Ashwin

-----Original Message-----
From: Lei Yao [mailto:[email-masked]]
Sent: Tuesday, June 12, 2001 6:38 PM
To: [email-masked]
Subject: RE: What we do if the LSP is preempted

A LSP is preempted because of the lack of network resource. In other words,
there is network congestion. Therefore, you should not try to re-build the
preempted LSP.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Tuesday, June 12, 2001 10:12 AM
To: [email-masked]; [email-masked]
Subject: What we do if the LSP is preempted

Dear all
 Can you please tell me what if the LSP is preempted ? Do we try to
reestablish the LSP
 with some other path or we will just preempt it ?
 If we just preempt the LSP then it will be unfare with that LSP. And when
should we try to
 reestablish that LSP ?
Do anybody has any ionformation regarding this ?
Thanks in advance
Ashwin

---

From: abhay <[email-masked]>
Date: Fri, 22 Jun 2001 13:55:47 +0800

Ashwin,

       You can re-route and re-establish the pre-empted LSP,but the newly re-routed LSP may

       pre-empt others,which may cause a cascade effect.

       The network topology has to stabilize generally,there needs to be a latency period,before

       you retry.

       Regards,

       Abhay

[email-masked] wrote:

>  Hello lei   D____________________F
> /
> \A---------------B---------------------C
> \_____E______/Suppose i have a LSP ABEC of priority 3And a LSP ADF
> with priority 4Now i want to setup ABC with priority 2.As the
> resources are not available on link AB i will preempt LSP ABECBut
> there is a LSP ADF with priority 4 less than that of ABEC so if i
> preemptABEC then won't it be fair to establish the LSP through ADFC
> and preempt ADF if enough resources are not available ?
> Thanks
> Ashwin
>
>      A LSP is preempted because of the lack of network resource.
>      In other words, there is network congestion. Therefore, you
>      should not try to re-build the preempted LSP.
>
>      From: [email-masked] [mailto:[email-masked]]On Behalf
>      Of [email-masked]
>      Can you please tell me what if the LSP is preempted ? Do we
>      try to reestablish the LSP
>      If we just preempt the LSP then it will be unfare with that
>      LSP. And when should we try to
>      reestablish that LSP ?
>