Subject: MAX rsvp-te message size

From: "Hong Liao" <[email-masked]>
Date: Wed, 13 Jun 2001 19:17:37 -0400

Hi,

Can anyone tell me the max size of RSVP-TE message sent out?

I saw cr-ldp spec, the max size for cr-ldp is 4096 bytes.

Thanks in an advance.

Julia

---

From: David Charlap <[email-masked]>
Date: Wed, 13 Jun 2001 21:12:16 -0400

> I saw cr-ldp spec, the max size for cr-ldp is 4096 bytes.

The maximum size for most RSVP messges is the interface's MTU size,
since an RSVP message must fit entirely into a single non-fragmented IP
datagram.

The one exception is a bundle message (one of the RSVP extensions in RFC
2961).  Bundle messages may be as large as an IP datagram, since they
may be fragmented.  This means a maximum size of 64K.

-- David

---

From: Rajiv Papneja <[email-masked]>
Date: Wed, 13 Jun 2001 21:24:03 -0400 (EDT)

Julia,

 I think a single RSVP message may not exceed the
maximum IP datagram size, approx. 64k bytes.

 -Rajiv

---

From: "Hari Kishan" <[email-masked]>
Date: Thu, 14 Jun 2001 14:42:08 -0700

Why is it a MUST to use LLC/SNAP encapsulation
for non-mpls connection between two LDP peers
connected via an LC-ATM interface??

what kind of problems does the LDP peers may run into 
if the non-mpls connection uses NULL encapsulations??

thanks,
Kishan

---------------------------------
Hari Kishan Desineni,
Ericsson Inc,
Data Backbone & Optical Division,
Santabarbara,
California - 93117
Office:(805) 562 6419
Home:(805) 968 1894