Subject: Label Mapping !!

From: Manoj Dutta <[email-masked]>
Date: Mon, 11 Jun 2001 18:34:15 -0700

Hi,

I had some doubts in RFC 3036. In section A.1.2, LMp.17 and A.1.6
FEC.1,  an LSR seems to send mappings for a given FEC to the next hop
for the same FEC.  If so, why ?

Thanks in advance
manoj

---

From: zze-PELLE Thierry StagiaireFTRD/DAC/ISS <[email-masked]>
Date: Tue, 12 Jun 2001 08:32:39 +0200

Hi,
> for the same FEC.  If so, why ?

As I understand it, this is due to the existance of liberal mode : in case
of LDP reconstuction, the former Next Hop (downstrem located) may become a 
LSR upstream located.

Rigth?

Thierry

---

From: <[email-masked]>
Date: Thu, 21 Jun 2001 17:03:08 -0700

hi!
     IMHO this is not correct as the LSR from which the label mapping has beeen
learnt can never be the upstream LSR for the same mapping - liberal or
conservative mode notwithstanding.

regards
sumit

"zze-PELLE Thierry StagiaireFTRD/DAC/ISS" <[email-masked]> on
06/12/2001 12:02:39 PM

To:   "'Manoj Dutta'" <[email-masked]>, [email-masked]
cc:    (bcc: Sumit Chauhan/HSS)

Subject:  RE: Label Mapping !!

Hi,

Rigth?

Thierry

---

From: "zze-PELLE Thierry StagiaireFTRD/DAC/ISS" <[email-masked]>
Date: Thu, 21 Jun 2001 17:03:07 -0700

HI,
> conservative mode notwithstanding.

Even if the IGP completely change the route for the FEC?

e.g.

If the network is           -------
                           /       \
                     A----B----C----D
				       |    |
                               \----E

First, the Path from A to E may be A B C D E. In this case,
                            -------
                           /       \
                     A-->-B-->-C-->-D
				       |   \|/
                               \----E
hence, C is upstream with respect to D : C uses the label distributed by D.

If the path from A to E changed to A B D C E. In this case,
                            --->---
                           /       \
                     A-->-B----C--<-D
				       \|/  |
                               \----E
here, D is upstream with respect to C : D uses the label distributed by C.

Finally, in liberal mode, if C has distributed a label to D (in the first
case, where D was the Next Hop for C), it can use it directly.

This is a quite strange case but it seems to be ok.

Thierry