Subject: LSR-MIB Question

From: "S. Davari" <[email-masked]>
Date: Mon, 11 Jun 2001 18:41:51 -0400 (EDT)

Hi All,

A few questions regarding LSR-MIB: 

1) If TTL expires in an MPLS packet is the packet
counted in 
mplsInSegmentErrors" or not?

2) If we receive a labeled packet and swap the label
and then push a new label
do we keep 2 sets of statistics on the outgoing
segment, one for the swapped
label and one for the pushed label or only one?

BTW, I also noticed that in LSR-MIB a swap consists of
a pop on incoming segment followed
by a push on outgoing segment, this is odd !! The
odder thing is that the incoming segment has
a parameter called InSegmentNpop in which "N"
identifies the number of pops to be performed on the 
insegment. How does one know in advance how many pops
to perform? If you know that, then it means
that all those labels that you pop are not used at
all.

Thanks,
-Shahram

_______________________________________________________
Do You Yahoo!?
Get your free @yahoo.ca address at http://mail.yahoo.ca

---

From: "Vipul Sharma" <[email-masked]>
Date: Tue, 12 Jun 2001 14:28:50 -0400

Shahram,
	I had run into similar question a while ago...Attached is the info. which
will help you for 1.
My feeling is that since there is no error conditions maybe they need to be
collected in mplsInSegmentDiscards. But that is just what I beleive maybe
the gurus have a differing opinion.
For 2, I believe that we are reqd. to keep 2 sets of stats one for the
swapped label and one for the pushed label
	Thanx,
Vip
[email-masked]

Attached message
=================================================================

>         In the MPLS MIBs (MPLS TE , MPLS LSR MIBs)I see stats for errored
> packets.
>For e.g. in the MPLS LSR MIB there is mplsInSegmentErrors which is "The
>number of errored packets received on this segment."
>         My question is what type of errors make these packets errored
packets
>because most errored packets are dropped at the physical interface iteself
>by the chips (my understanding). So does this stats put a req. to run the
>phy. interface device in promiscous mode?

         Basically any case where a labeled packet is received and
cannot be forwarded by the MPLS software. There are many cases:
out of bandwidth in the switching fabric, illegal labels in the
packet, etc...

         --Tom

>Vip

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of S. Davari
Sent: Monday, June 11, 2001 6:42 PM
To: [email-masked]
Subject: LSR-MIB Question

Hi All,

Thanks,
-Shahram

Subject: RE: LSR MIB question
From: "Vipul Sharma" <[email-masked]>
To: "'Shahram Davari'" <[email-masked]>, "[email-masked]'" <[email-masked]>
Date: Fri, 4 May 2001 11:36:58 -0400

It is my understanding that both stats are to be collected to satisfy the
LSR MIB.
Each LSR is reqd. to collect stats for in-segments and out-segments on a per
LSP basis. In case of a tunnel, it should collect stats on per LSP (which
may be agg. in a tunnel) as well as the tunnel (which is a new LSP)from a
LSR point of view.
Atleast, this is my understanding....

Vip

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Shahram
Davari
Sent: Friday, May 04, 2001 11:03 AM
To: [email-masked]'
Subject: LSR MIB question

Hi All,

If an LSR is the origin point of an MPLS tunnel, and it receives an MPLS
packet, it first swaps the top label and pushes a new label on top of that.
Which performance statistics are required to be collected by LSR-MIB: The
swapped label or the pushed label or both?

Yours,
Shahram Davari

---

From: "Vijayanand C" <[email-masked]>
Date: Wed, 13 Jun 2001 10:34:25 +0530

Hello,
Regarding the LSR MIB, the use of InSegmentNpop is not clear to me and I
raised this issue earlier, but have not got a reply. If for a particular
label 'N' pop operations are always done then what is the significance of
the N-1 labels beneath it. Which scenario is this useful and how is the 'N'
value set,especially when it is greater than 1.

Regards,
Vijay

-----Original Message-----
From: Vipul Sharma [mailto:[email-masked]]
Sent: Tuesday, June 12, 2001 11:59 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: LSR-MIB Question

Shahram,
	I had run into similar question a while ago...Attached is the
info. which
will help you for 1.
My feeling is that since there is no error conditions maybe they need to
be
collected in mplsInSegmentDiscards. But that is just what I beleive
maybe
the gurus have a differing opinion.
For 2, I believe that we are reqd. to keep 2 sets of stats one for the
swapped label and one for the pushed label
	Thanx,
Vip
[email-masked]

Attached message

packets

         --Tom

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of S. Davari
Sent: Monday, June 11, 2001 6:42 PM
To: [email-masked]
Subject: LSR-MIB Question

Hi All,

Thanks,
-Shahram

---

From: "Heqing Zhu" <[email-masked]>
Date: Wed, 13 Jun 2001 17:48:12 +0800

When using the label stack, if there are several layers, 
and egress router is the same router.
So I think you need pop these labels.
If I am wrong, please correct me.

---

From: "Vipul Sharma" <[email-masked]>
Date: Thu, 21 Jun 2001 17:03:17 -0700

Shahram,

Attached message

packets

         --Tom

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of S. Davari
Sent: Monday, June 11, 2001 6:42 PM
To: [email-masked]
Subject: LSR-MIB Question

Hi All,

Thanks,
-Shahram

Vip

-----Original Message-----

Hi All,

Yours,
Shahram Davari

---

From: "Heqing Zhu" <[email-masked]>
Date: Thu, 21 Jun 2001 17:03:24 -0700

---

From: "Vijayanand C" <[email-masked]>
Date: Thu, 21 Jun 2001 17:03:22 -0700

Hello,

Regards,
Vijay

-----Original Message-----
From: Vipul Sharma [mailto:[email-masked]]
Sent: Tuesday, June 12, 2001 11:59 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: LSR-MIB Question

Shahram,

Attached message

packets

         --Tom

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of S. Davari
Sent: Monday, June 11, 2001 6:42 PM
To: [email-masked]
Subject: LSR-MIB Question

Hi All,

Thanks,
-Shahram

---

From: "Vincent Hamrick" <[email-masked]>
Date: Fri, 22 Jun 2001 11:39:27 -0400

What if you replace the top label and then push another label?  Against
which label would you store the outSegment counts?  Or would you store them
against both labels?

Thanks,
-V

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Vipul
Sharma
Sent: Thursday, June 21, 2001 8:03 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: LSR-MIB Question

Shahram,

Attached message

packets

         --Tom

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of S. Davari
Sent: Monday, June 11, 2001 6:42 PM
To: [email-masked]
Subject: LSR-MIB Question

Hi All,

Thanks,
-Shahram

---

From: Eric Gray <[email-masked]>
Date: Fri, 22 Jun 2001 12:28:47 -0400

Vincent,

    Think about it this way: a (set of) label(s) on an inSegment map
reliably to a specific label stack manipulation (pop, swap, push,
shake, rattle and/or roll) for any given LSP.

--
Eric Gray