Subject: 1+1 protection switching

From: "Pour, Mort" <[email-masked]>
Date: Thu, 28 Jun 2001 09:56:35 -0500

I have a question regarding the 1+1 protection switching in MPLS. 
Draft <draft-ietf-mpls-recovery-frmwrk-02.txt>
states that the path merge LSR can select the backup path when the primary
path fails.
What about the issues of duplicate (or missing) packets on the backup path
due
to variations in delay between the two path. Or if the two path are
synchronized, how is that achieved?

Thanks
Mort Pour

---

From: "Pour, Mort" <[email-masked]>
Date: Thu, 28 Jun 2001 10:38:46 -0500

Thanks,
But this may also cause the connection to be dropped by TCP?

Regards,
Mort

-----Original Message-----
From: Shahram Davari [mailto:[email-masked]]
Sent: Thursday, June 28, 2001 10:36 AM
To: 'Pour, Mort'; [email-masked]'
Subject: RE: 1+1 protection switching

Hi,

I think it is understood/accepted that a number of packets may be dropped or
deliver out of order for a short period of time. The receiver should
re-order the packets and/or request retransmission.  

Yours,
-Shahram

> -----Original Message-----
> From: Pour, Mort [mailto:[email-masked]]
> Sent: Thursday, June 28, 2001 10:57 AM
> To: [email-masked]'
> Subject: 1+1 protection switching
> 
> 
>

---

From: Shahram Davari <[email-masked]>
Date: Thu, 28 Jun 2001 08:35:49 -0700

Hi,

I think it is understood/accepted that a number of packets may be dropped or deliver out of order for a short period of time. The receiver should re-order the packets and/or request retransmission.  

Yours,
-Shahram

---

From: Shahram Davari <[email-masked]>
Date: Thu, 28 Jun 2001 08:48:58 -0700

Could you please explain more, why do you think that TCP connection may be dropped.

> Sent: Thursday, June 28, 2001 11:39 AM
> To: [email-masked]'

---

From: "Pour, Mort" <[email-masked]>
Date: Thu, 28 Jun 2001 13:22:27 -0500

As far as I know there are no explicit requirements on reordering.

-----Original Message-----
From: Saurabh Shrivastava [mailto:[email-masked]]
Sent: Thursday, June 28, 2001 1:18 PM
To: 'Pour, Mort'; [email-masked]'
Subject: RE: 1+1 protection switching

but isnt there a requirement that in an LSP, there
should be no packet reordering.

~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~
Saurabh Shrivastava          [email-masked]        

TiMetra, Inc.                408.245.8796 (residence)
http://www.timetra.com/      650.237.5154 (office)
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~

*  -----Original Message-----
*  From: [email-masked] [mailto:[email-masked]]On Behalf Of Pour,
*  Mort
*  Sent: Thursday, June 28, 2001 11:13 AM
*  To: [email-masked]'
*  Subject: RE: 1+1 protection switching
*  
*  
*  On second thought I agree. I don't think there will any 
*  problem except for
*  some
*  retransmissions or some duplicate packets being dropped.
*  
*  
*  -----Original Message-----
*  From: Shahram Davari [mailto:[email-masked]]
*  Sent: Thursday, June 28, 2001 10:49 AM
*  To: 'Pour, Mort'; [email-masked]'
*  Subject: RE: 1+1 protection switching
*  
*  
*  Could you please explain more, why do you think that TCP 
*  connection may be
*  dropped.
*  
*  > -----Original Message-----
*  > From: Pour, Mort [mailto:[email-masked]]
*  > Sent: Thursday, June 28, 2001 11:39 AM
*  > To: [email-masked]'
*  > Subject: RE: 1+1 protection switching
*  > 
*  > 
*  > Thanks,
*  > But this may also cause the connection to be dropped by TCP?
*  > 
*  > Regards,
*  > Mort
*  > 
*  > 
*  > -----Original Message-----
*  > From: Shahram Davari [mailto:[email-masked]]
*  > Sent: Thursday, June 28, 2001 10:36 AM
*  > To: 'Pour, Mort'; [email-masked]'
*  > Subject: RE: 1+1 protection switching
*  > 
*  > 
*  > Hi,
*  > 
*  > I think it is understood/accepted that a number of packets 
*  > may be dropped or
*  > deliver out of order for a short period of time. The 
*  receiver should
*  > re-order the packets and/or request retransmission.  
*  > 
*  > Yours,
*  > -Shahram
*  > 
*  > > -----Original Message-----
*  > > From: Pour, Mort [mailto:[email-masked]]
*  > > Sent: Thursday, June 28, 2001 10:57 AM
*  > > To: [email-masked]'
*  > > Subject: 1+1 protection switching
*  > > 
*  > > 
*  > > 
*  > > I have a question regarding the 1+1 protection switching 
*  in MPLS. 
*  > > Draft <draft-ietf-mpls-recovery-frmwrk-02.txt>
*  > > states that the path merge LSR can select the backup path 
*  > > when the primary
*  > > path fails.
*  > > What about the issues of duplicate (or missing) packets on 
*  > > the backup path
*  > > due
*  > > to variations in delay between the two path. Or if the 
*  two path are
*  > > synchronized, how is that achieved?
*  > > 
*  > > Thanks
*  > > Mort Pour
*  > > 
*  >

---

From: [email-masked]
Date: Fri, 29 Jun 2001 00:12:37 +0100

If you change a path then you change its delay.  In all cases except 1+1 (eg
1:1 or 1:N) you will get a hit on the restored path.....that's just a fact.
In 1+1 you have the ability, should you choose, to delay/phase align the
working and protection.  Clearly the working and protection path must be
buffered such that the 'faster' path has the same delay as the 'slower'
path......otherwise hitless changeover will not be posssible.

But you also have to ask yourself if a hit such a big deal?  This depends on
the applications tolerance to the hit it gets.........and this can vary and
is not simply a function of the transport delay, but what
framing/realignment process (if any) the application is using.

neil

> Sent: 28 June 2001 19:22