Subject: RE: Label Mapping !!

From: zze-PELLE Thierry StagiaireFTRD/DAC/ISS <[email-masked]>
Date: Tue, 12 Jun 2001 09:06:20 +0200

HI,
> hi!
>      IMHO this is not correct as the LSR from which the label 
> mapping has beeen
> learnt can never be the upstream LSR for the same mapping - liberal or
> conservative mode notwithstanding.

Even if the IGP completely change the route for the FEC?

e.g.

If the network is           -------   
                           /       \
                     A----B----C----D
				       |    |
                               \----E

First, the Path from A to E may be A B C D E. In this case, 
                            -------   
                           /       \
                     A-->-B-->-C-->-D
				       |   \|/
                               \----E
hence, C is upstream with respect to D : C uses the label distributed by D.

If the path from A to E changed to A B D C E. In this case, 
                            --->---   
                           /       \
                     A-->-B----C--<-D
				       \|/  |
                               \----E
here, D is upstream with respect to C : D uses the label distributed by C.

Finally, in liberal mode, if C has distributed a label to D (in the first
case, where D was the Next Hop for C), it can use it directly.

This is a quite strange case but it seems to be ok.

Thierry

---

From: Eric Gray <[email-masked]>
Date: Tue, 12 Jun 2001 10:40:48 -0400

Thierry/Sumit/Manoj,

    Consider the following simple analysis:

o    assume that a router has N interfaces for routing in a
        given routing domain
o    assume (for simplicity) it is not multipathing on any of
        these interfaces
o    then - for any specific FEC -
    o    it has exactly one output interface to a nexthop for
            that FEC
    o    it has N-1 interfaces over which it might receive a
            packet destined for that nexthop and FEC
o    and, if there is a route change that changes the nexthop,
        then one of the N-1 previously upstream peers MUST
        be the new nexthop.

Therefore, it does not take a strange case to produce a scenario
in which a router that was forwarding packets to another becomes
the next hop for those same packets.

--
Eric Gray

---

From: "Eric Gray" <[email-masked]>
Date: Thu, 21 Jun 2001 17:03:12 -0700

Thierry/Sumit/Manoj,

--
Eric Gray