Subject: How LDP know the LSP?

From: zze-PELLE Thierry StagiaireFTRD/DAC/ISS <[email-masked]>
Date: Fri, 8 Jun 2001 16:33:27 +0200

Hello,
	In RFC 3036, p. 101, it is written
			"Does LSR have a previously received label mapping
for FEC from MsgSource for the LSP in question?".
      I can't figure how the LSR is able to link the FEC to a LSP (in
non-merging case of course).

Hope you can help,
Thierry

---

From: zze-PELLE Thierry StagiaireFTRD/DAC/ISS <[email-masked]>
Date: Mon, 11 Jun 2001 11:02:23 +0200

Somes remarks to know if I understand well.

> When I receive a mapping it fits one of the following:
> -this is the first mapping I have seen, either requested or 
> unsolicited

In this case, as you say, there is no LSP for this FEC, the LSP is created
and propaged upstream or downstream depending if the mapping is requested or
unsolicited.

> -this is NOT the first and I should have a pending requested for it,
>  but if if don't ...
> -this is a duplicate unsolicited mapping

So you mean that in Non Merging case, an LSP cannot be setup from downstream
to upstream
by unsolicited messaged. If an LSP exists, the next ones MUST be requested.
 
> So the only case you run into problems is if you receive multiple
> unsolicited mappings from your peer.  In which case you fall 
> through to LMp.11.
????? LMp.11 ??????

> PS you can look at the ldp-portable package at 
> http://mpls-linux.sf.net/
> to see how I have implemented it.

I will.

Ta