Subject: RE: What we do if the LSP is preempted

From: "Haim, Robert" <[email-masked]>
Date: Wed, 13 Jun 2001 14:08:05 -0700

Lei,
 
If an LSP is pre-empted the assumption is that its priority was lower than
the one which replaced it. Attempting to reestablish the LSP would make
sense if the Service Level Agreement with the customer warrants it. If it
does, the network operator would have to make sure and reserve enough
resources to accommodate its SLAs. Otherwise, for "best effort" traffic, you
wouldn't re-establish the LSP.
--robert
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, June 12, 2001 7:45 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: What we do if the LSP is preempted

Hello lei
 
  D____________________F
 /                                       \
A---------------B---------------------C
                   \_____E______/
 
Suppose i have a LSP ABEC of priority 3
And a LSP ADF with priority 4
 
Now i want to setup ABC with priority 2.
As the resources are not available on link AB i will preempt LSP ABEC
But there is a LSP ADF with priority 4 less than that of ABEC so if i
preempt
ABEC then won't it be fair to establish the LSP through ADFC and preempt ADF

if enough resources are not available ?
Thanks
Ashwin
 
-----Original Message-----
From: Lei Yao [mailto:[email-masked]]
Sent: Tuesday, June 12, 2001 6:38 PM
To: [email-masked]
Subject: RE: What we do if the LSP is preempted
A LSP is preempted because of the lack of network resource. In other words,
there is network congestion. Therefore, you should not try to re-build the
preempted LSP.
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: Tuesday, June 12, 2001 10:12 AM
To: [email-masked]; [email-masked]
Subject: What we do if the LSP is preempted

Dear all 
 Can you please tell me what if the LSP is preempted ? Do we try to
reestablish the LSP 
 with some other path or we will just preempt it ? 
 If we just preempt the LSP then it will be unfare with that LSP. And when
should we try to 
 reestablish that LSP ? 
Do anybody has any ionformation regarding this ? 
Thanks in advance 
Ashwin

---

From: "Rajeev Manur" <[email-masked]>
Date: Wed, 13 Jun 2001 14:42:43 -0700

A related question. Pre-emption can be attempted on either ingress-LER or
any other LSR hop wrt the LSP being setup. Also any hop that is attempting
to preempt an LSP can preempt an LSP regardless of whether it is the
ingress/core wrt to the LSP being pre-empted right ?

with regards,
Rajeev
-----Original Message-----
From: Haim, Robert [mailto:[email-masked]]
Sent: Wednesday, June 13, 2001 2:08 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: What we do if the LSP is preempted

Lei,

If an LSP is pre-empted the assumption is that its priority was lower than
the one which replaced it. Attempting to reestablish the LSP would make
sense if the Service Level Agreement with the customer warrants it. If it
does, the network operator would have to make sure and reserve enough
resources to accommodate its SLAs. Otherwise, for “best effort” traffic, you
wouldn’t re-establish the LSP.
--robert
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, June 12, 2001 7:45 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: What we do if the LSP is preempted

Hello lei

  D____________________F
 /                                       \

-----Original Message-----

Dear all