Subject: RE: 1+1 protection switching

From: "Pour, Mort" <[email-masked]>
Date: Thu, 28 Jun 2001 13:12:37 -0500

On second thought I agree. I don't think there will any problem except for
some
retransmissions or some duplicate packets being dropped.

-----Original Message-----
From: Shahram Davari [mailto:[email-masked]]
Sent: Thursday, June 28, 2001 10:49 AM
To: 'Pour, Mort'; [email-masked]'
Subject: RE: 1+1 protection switching

Could you please explain more, why do you think that TCP connection may be
dropped.

> -----Original Message-----
> From: Pour, Mort [mailto:[email-masked]]
> Sent: Thursday, June 28, 2001 11:39 AM
> To: [email-masked]'
> Subject: RE: 1+1 protection switching
> 
> 
> Thanks,
> But this may also cause the connection to be dropped by TCP?
> 
> Regards,
> Mort
> 
> 
> -----Original Message-----
> From: Shahram Davari [mailto:[email-masked]]
> Sent: Thursday, June 28, 2001 10:36 AM
> To: 'Pour, Mort'; [email-masked]'
> Subject: RE: 1+1 protection switching
> 
> 
> Hi,
> 
> I think it is understood/accepted that a number of packets 
> may be dropped or
> deliver out of order for a short period of time. The receiver should
> re-order the packets and/or request retransmission.  
> 
> Yours,
> -Shahram
> 
> > -----Original Message-----
> > From: Pour, Mort [mailto:[email-masked]]
> > Sent: Thursday, June 28, 2001 10:57 AM
> > To: [email-masked]'
> > Subject: 1+1 protection switching
> > 
> > 
> > 
> > I have a question regarding the 1+1 protection switching in MPLS. 
> > Draft <draft-ietf-mpls-recovery-frmwrk-02.txt>
> > states that the path merge LSR can select the backup path 
> > when the primary
> > path fails.
> > What about the issues of duplicate (or missing) packets on 
> > the backup path
> > due
> > to variations in delay between the two path. Or if the two path are
> > synchronized, how is that achieved?
> > 
> > Thanks
> > Mort Pour
> > 
>

---

From: "Saurabh Shrivastava" <[email-masked]>
Date: Thu, 28 Jun 2001 11:18:26 -0700

but isnt there a requirement that in an LSP, there
should be no packet reordering.

~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~
Saurabh Shrivastava          [email-masked]        

TiMetra, Inc.                408.245.8796 (residence)
http://www.timetra.com/      650.237.5154 (office)
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~

*  -----Original Message-----
*  From: [email-masked] [mailto:[email-masked]]On Behalf Of Pour,
*  Mort
*  Sent: Thursday, June 28, 2001 11:13 AM
*  To: [email-masked]'
*  Subject: RE: 1+1 protection switching
*  
*  
*  On second thought I agree. I don't think there will any 
*  problem except for
*  some
*  retransmissions or some duplicate packets being dropped.
*  
*  
*  -----Original Message-----
*  From: Shahram Davari [mailto:[email-masked]]
*  Sent: Thursday, June 28, 2001 10:49 AM
*  To: 'Pour, Mort'; [email-masked]'
*  Subject: RE: 1+1 protection switching
*  
*  
*  Could you please explain more, why do you think that TCP 
*  connection may be
*  dropped.
*  
*  > -----Original Message-----
*  > From: Pour, Mort [mailto:[email-masked]]
*  > Sent: Thursday, June 28, 2001 11:39 AM
*  > To: [email-masked]'
*  > Subject: RE: 1+1 protection switching
*  > 
*  > 
*  > Thanks,
*  > But this may also cause the connection to be dropped by TCP?
*  > 
*  > Regards,
*  > Mort
*  > 
*  > 
*  > -----Original Message-----
*  > From: Shahram Davari [mailto:[email-masked]]
*  > Sent: Thursday, June 28, 2001 10:36 AM
*  > To: 'Pour, Mort'; [email-masked]'
*  > Subject: RE: 1+1 protection switching
*  > 
*  > 
*  > Hi,
*  > 
*  > I think it is understood/accepted that a number of packets 
*  > may be dropped or
*  > deliver out of order for a short period of time. The 
*  receiver should
*  > re-order the packets and/or request retransmission.  
*  > 
*  > Yours,
*  > -Shahram
*  > 
*  > > -----Original Message-----
*  > > From: Pour, Mort [mailto:[email-masked]]
*  > > Sent: Thursday, June 28, 2001 10:57 AM
*  > > To: [email-masked]'
*  > > Subject: 1+1 protection switching
*  > > 
*  > > 
*  > > 
*  > > I have a question regarding the 1+1 protection switching 
*  in MPLS. 
*  > > Draft <draft-ietf-mpls-recovery-frmwrk-02.txt>
*  > > states that the path merge LSR can select the backup path 
*  > > when the primary
*  > > path fails.
*  > > What about the issues of duplicate (or missing) packets on 
*  > > the backup path
*  > > due
*  > > to variations in delay between the two path. Or if the 
*  two path are
*  > > synchronized, how is that achieved?
*  > > 
*  > > Thanks
*  > > Mort Pour
*  > > 
*  >