Subject: RE: LSR-MIB Question

From: Shahram Davari <[email-masked]>
Date: Fri, 22 Jun 2001 10:50:48 -0700

Eric,

Does this mean that a transmitted MPLS packet will update only one outsegment? (no multicast)

-Shahram

> -----Original Message-----
> From: Eric Gray [mailto:[email-masked]]
> Sent: Friday, June 22, 2001 12:29 PM
> To: Vincent Hamrick
> Cc: 'Vipul Sharma'; [email-masked]; [email-masked]
> Subject: Re: LSR-MIB Question
> 
> 
> Vincent,
> 
>     Think about it this way: a (set of) label(s) on an inSegment map
> reliably to a specific label stack manipulation (pop, swap, push,
> shake, rattle and/or roll) for any given LSP.
> 
> --
> Eric Gray
> 
> You wrote:
> 
> > What if you replace the top label and then push another 
> label?  Against
> > which label would you store the outSegment counts?  Or 
> would you store them
> > against both labels?
> >
> > Thanks,
> > -V
> >
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On Behalf Of Vipul
> > Sharma
> > Sent: Thursday, June 21, 2001 8:03 PM
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: RE: LSR-MIB Question
> >
> > Shahram,
> >         I had run into similar question a while 
> ago...Attached is the info. which
> > will help you for 1.
> > My feeling is that since there is no error conditions maybe 
> they need to be
> > collected in mplsInSegmentDiscards. But that is just what I 
> beleive maybe
> > the gurus have a differing opinion.
> > For 2, I believe that we are reqd. to keep 2 sets of stats 
> one for the
> > swapped label and one for the pushed label
> >         Thanx,
> > Vip
> > [email-masked]
> >
> > Attached message
> > =================================================================
> >
> > >         In the MPLS MIBs (MPLS TE , MPLS LSR MIBs)I see 
> stats for errored
> > > packets.
> > >For e.g. in the MPLS LSR MIB there is mplsInSegmentErrors 
> which is "The
> > >number of errored packets received on this segment."
> > >         My question is what type of errors make these 
> packets errored
> > packets
> > >because most errored packets are dropped at the physical 
> interface iteself
> > >by the chips (my understanding). So does this stats put a 
> req. to run the
> > >phy. interface device in promiscous mode?
> >
> >          Basically any case where a labeled packet is received and
> > cannot be forwarded by the MPLS software. There are many cases:
> > out of bandwidth in the switching fabric, illegal labels in the
> > packet, etc...
> >
> >          --Tom
> >
> > >Vip
> > >
> >
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On Behalf 
> Of S. Davari
> > Sent: Monday, June 11, 2001 6:42 PM
> > To: [email-masked]
> > Subject: LSR-MIB Question
> >
> > Hi All,
> >
> > A few questions regarding LSR-MIB:
> >
> > 1) If TTL expires in an MPLS packet is the packet
> > counted in
> > mplsInSegmentErrors" or not?
> >
> > 2) If we receive a labeled packet and swap the label
> > and then push a new label
> > do we keep 2 sets of statistics on the outgoing
> > segment, one for the swapped
> > label and one for the pushed label or only one?
> >
> > BTW, I also noticed that in LSR-MIB a swap consists of
> > a pop on incoming segment followed
> > by a push on outgoing segment, this is odd !! The
> > odder thing is that the incoming segment has
> > a parameter called InSegmentNpop in which "N"
> > identifies the number of pops to be performed on the
> > insegment. How does one know in advance how many pops
> > to perform? If you know that, then it means
> > that all those labels that you pop are not used at
> > all.
> >
> > Thanks,
> > -Shahram
> >
> > _______________________________________________________
> > Do You Yahoo!?
> > Get your free @yahoo.ca address at http://mail.yahoo.ca
>

---

From: Eric Gray <[email-masked]>
Date: Fri, 22 Jun 2001 14:27:38 -0400

Shahram,

    In terms of the MIB, no that is not what this means.

--
Eric Gray