Subject: rsvp-te opaque object

From: [email-masked]
Date: Mon, 4 Jun 2001 16:41:50 -0400

Andria,

Thanks for your reply.  I understand that there may have an object with new
c-type or class which may be defined for the future.  Does it mean an extra
field in any rsvp-te defined messages in spec?  For example, Path message
has

<Path Message> ::=       <Common Header> [ <INTEGRITY> ]
                               <SESSION> <RSVP_HOP>
                               <TIME_VALUES>
                               [ <EXPLICIT_ROUTE> ]
                               <LABEL_REQUEST>
                               [ <SESSION_ATTRIBUTE> ]
                               [ <POLICY_DATA> ... ]
                               <sender descriptor>

                   ???  ******* add extra Opaque object *******????

      <sender descriptor> ::=  <SENDER_TEMPLATE> <SENDER_TSPEC>
                               [ <ADSPEC> ]
                               [ <RECORD_ROUTE> ]

Thanks in advance.

Julia

>Hi,

>Is it possible for RSVP message with proprietary objects that are not
defined in the spec like Opaque object?
>L do not think so.   Can anyone tell me whether I am right.

>Thanks in advance.

>Julia

---

From: "Hong Liao" <[email-masked]>
Date: Tue, 5 Jun 2001 11:04:48 -0400

Adrian,

So you mean there is no need to add extra field into the PDU message for
the Opaque object.
But as I know, there is one switches which is implemented by this way with
extra opaque(unrecognized) field inside the Path pdu message.
Do you think they implement the switch with this way correctly or not?

Thanks,

Julia

                    "Adrian                                                                                   
                    Farrel"              To:     "Hong Liao" <[email-masked]>                            
                    <afarrel@mova        cc:     (bcc: Hong Liao/Telcordia)                                   
                    z.com>               Subject:     Re: rsvp-te opaque object                               
                                                                                                              
                    06/04/01                                                                                  
                    05:06 PM                                                                                  

Julia,

My point is that all undefined objects are opaque and there is no need to
define
a specific value to encode an opaque object.

You might ask that there are some values that are reserved for
implementation
usage so that future objects don't clash.  This would be a matter for IANA
(and
for all I know, it has been resolved there already).

You might want to define a specific use of opaque objects (that they be
delivered to a specific non-RSVP component).  This is similar to what
happens
with Policy objects.  The need for this function would drive the allocation
of
the value.

Adrian
--
Adrian Farrel
Movaz Networks Inc.
[email-masked]

---

From: "Hong Liao" <[email-masked]>
Date: Tue, 5 Jun 2001 15:52:20 -0400

Adrian,

Thanks,

Julia

                    "Adrian                                                                                   
                                                                                                              
                    06/04/01                                                                                  
                    05:06 PM                                                                                  

Julia,

Adrian
--
Adrian Farrel
Movaz Networks Inc.
[email-masked]