Subject: RE: Tag-switching -vs- MPLS !!!

From: Ruyter Hill <[email-masked]>
Date: Thu, 14 Jun 2001 14:47:47 +0100

Hi 
 
To further clarify this 
 
Tag switching was the CISCO proprietary predecessor to MPLS 
 
You may find in some versions of IOS, commands which still use the term "tag
switch"  
these are effectively MPLS commands  
 
one must be careful however as tag switching used TDP  ( Cisco's version of
LDP )  
so if you have different IOS versions across your network you may find
things don't work as the two 
protocols are very slightly different 
 
Perhaps Robert or someone can say if there is backwards compatibility for
TDP in the later versions of IOS ? 

So in summary TDP and MPLS are really the same thing when dealing with CISCO
equipment 

Kind Regards
 
Hill Ruyter
IP Solutions Specialist 
Carrier1, London 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: 13 June 2001 08:19
To: Unlisted-recipients 
Cc: [email-masked]; [email-masked]
Subject: RE: Tag-switching -vs- MPLS !!!
Importance: High

tag switching is the general term used to notify a methodology 

MPLS uses that methodology ...of tag switching. 
dont confuse the terms technology and methodology ... 

MPLs is a technology which uses a kind of methodology of tag - switching
which might be in use by some other protocols or technologies too....

regards 
bhupesh 

-----Original Message----- 
From: Sivaramakrishna Iyer Krishnan 
[ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Monday, June 11, 2001 11:44 PM 
To: [email-masked] 
Subject: Tag-switching -vs- MPLS !!! 

Hi All, 

I am not sure what is the difference between tag-switching and MPLS 
????????.... 

Also, are all mpls commands backward compatible to tag-switching ???... 

Thanks, 
Krishnan. 

------- 
The MPLS-OPS Mailing List 
Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
<http://www.mplsrc.com/mplsops.shtml>  
Archive: http://www.mplsrc.com/mpls-ops_archive.shtml
<http://www.mplsrc.com/mpls-ops_archive.shtml>

---

From: Rahul Bhushan <[email-masked]>
Date: Mon, 18 Jun 2001 16:30:30 -0400

Hi,

    You can check out Rekhtor/Davie/Doolan's book :

Switching in IP-Networks

It gives a good background on Toshiba's CSR,
Ipsilon's IP-Switching, IBM's ARIS and Cisco's
Tag-Switching architectures.

All these architectures have evolved in some
parts into MPLS.

URL to the book (Price in CDN $):
http://chapters.indigo.ca/books/details/default.asp?mscssid=0Q482TPG4VJ08P5RMF66W8RXJS9LB69E&WSID=1606023A308A1E0D41A3A4CDB2DE767BB6DE2418&ISBN=1558605053

>      [mailto:[email-masked]]

---

From: "Dennis Hartmann" <[email-masked]>
Date: Mon, 18 Jun 2001 18:03:18 -0400

The biggest difference is the fact that Tag-Switching uses TDP, while
standardized MPLS uses LDP as a distribution protocol.  TDP is a subset of
LDP.  TDP uses TCP and UDP ports 711, while LDP uses TCP and UDP ports 646.
LDP has added functionality that is not available in TDP (MD5
authentication, etc.), and it is an IETF standard (TDP is Cisco
proprietary).  The MLSTE class has a whole chapter devoted to TDP and LDP,
as well as distribution protocol migration.  Some Cisco IOS images do not
support LDP.  Use the IOS Feature Navigator to get information on what
features are supported for your particular hardware.  I am currently working
with 12.2(2T) which is the first 3640 image to support LDP.  Anyone know of
any caveats for this code (Service Provider Feature Set) with the 3640?

Sincerely,

Dennis J. Hartmann
White Pine Consulting
[email-masked]
(914) 980-0316 (cellular)
(845) 896-4777 (home)
AOL IM: dennisjhartmann
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of Rahul
Bhushan
  Sent: Monday, June 18, 2001 4:31 PM
  To: [email-masked]
  Subject: Re: Tag-switching -vs- MPLS !!!

  Hi,

  Switching in IP-Networks

http://chapters.indigo.ca/books/details/default.asp?mscssid=0Q482TPG4VJ08P5R
MF66W8RXJS9LB69E&WSID=1606023A308A1E0D41A3A4CDB2DE767BB6DE2418&ISBN=15586050
53

-----Original Message-----

Hi All,

Thanks,
Krishnan.

-------

      -----Original Message-----
      From: Sivaramakrishna Iyer Krishnan
      [mailto:[email-masked]]
      Sent: Monday, June 11, 2001 11:44 PM
      To: [email-masked]
      Subject: Tag-switching -vs- MPLS !!!

      Hi All,

      Also, are all mpls commands backward compatible to tag-switching
???...

      Thanks,
      Krishnan.

      -------