Subject: Re: Error in RFC 3036??

From: Nagendra Singh Tomar <[email-masked]>
Date: Tue, 12 Jun 2001 08:55:44 +0530 (IST)

Bob!
     I am sorry if I did'nt put it correctly, but by saying that the
Loop Detected Notification might in turn Loop, I meant that since a loop
was detected on the label request received, there is a very  high
possibility that the return path (from the receiver of the label request
to the sender of the Label request) for the notification message might as
well loop so its better to silently discard it.

Is'nt it because of this Bob ?

regards
tomar

On Mon, 11 Jun 2001, Bob Thomas wrote:

> Tomar,
> 
> > If the node detects a loop in the label request message, the  its wise not
> > to send the loop detected notification, because that might in turn loop
> 
> Note that the Loop Detected Notification is not propagated by the
> receiver, and therefore will not loop.
> 
> Bob
> 
> 
> > and make the network conditions worse. In the LRq.2 case the loop is not
> > detected in the label request message so we are sure that the return path
> > for the notification message has no loop, so it is safe to send a
> > notification in that case.
> > 
> > --tomar
> > 
> > On Mon, 11 Jun 2001 [email-masked] wrote:
> > 
> > > 
> > > 
> > > yup sorry! LRq.4 it is. typo ;o)
> > > 
> > > 
> > > 
> > > 
> > > "zze-PELLE Thierry StagiaireFTRD/DAC/ISS" <[email-masked]> on
> > > 06/11/2001 03:27:43 PM
> > > 
> > > To:   Sumit Chauhan/HSS@HSS, [email-masked]
> > > cc:
> > > 
> > > Subject:  RE: Error in RFC 3036??
> > > 
> > > 
> > > 
> > > 
> > > > IMHO, should it not be
> > > >      If Loop Detected , got to LRq.5
> > > 
> > > LRq.4 and not LRq.5 I think....
> > > 
> > > 
> > > 
> > 
> > -- 
> > 
> > 
> > ------------------------------------------------------------------------------
> >  Nagendra Singh Tomar
> >  
> >  Residence:
> >  369 KHB Colony
> >  5th Block Koramangala
> >  Bangalore 95
> >  INDIA
> >  Phone : 5524839
> >  email : [email-masked]
> > 
> > 
> > "Sometimes quantity becomes quality"                                          
> >                             --Gary Kasparov,                                  
> >  When he played against Deep Blue. He said this after looking at a           
> >  computer which found a forced mate in 249 in an endgame, after calculating   
> >  all the possible moves with only 5 pieces left on the board.                 
> > ------------------------------------------------------------------------------
> > 
> 

-- 

------------------------------------------------------------------------------
 Nagendra Singh Tomar
 
 Residence:
 369 KHB Colony
 5th Block Koramangala
 Bangalore 95
 INDIA
 Phone : 5524839
 email : [email-masked]

"Sometimes quantity becomes quality"                                          
                            --Gary Kasparov,                                  
 When he played against Deep Blue. He said this after looking at a           
 computer which found a forced mate in 249 in an endgame, after calculating   
 all the possible moves with only 5 pieces left on the board.                 
------------------------------------------------------------------------------

---

From: "Nagendra Singh Tomar" <[email-masked]>
Date: Thu, 21 Jun 2001 17:03:05 -0700

Bob!

regards
tomar

--

 Residence:
 369 KHB Colony
 5th Block Koramangala
 Bangalore 95
 INDIA
 Phone : 5524839

---

From: Bob Thomas <[email-masked]>
Date: Sat, 23 Jun 2001 21:33:51 -0400

Tomar,

> possibility that the return path (from the receiver of the label request

I think the probability is quite low since unless the LDP session is a
targeted session the sender and receiver of the Label Request message
are directly connected.

Bob