Subject: Per-Connection policing vs Aggregate policing -In the L-LSP/E-LSP context

From: "Choudhury, Sanjaya" <[email-masked]>
Date: Wed, 27 Jun 2001 12:19:29 -0400

Hi! I have few questions related to policing L-LSPs 
	and E-LSPs. Your help will be appreciated.

	Q1. For L-LSP one has multiple options for policing the 
	incoming traffic.
		a) per-connection policing based on the signaled
		traffic parameters.
		b) aggregate policing control by the PSC it is 
		carrying (based on the parameters configured
		for the PSC)
		c) both

	Although the choice depends on the hardware capability,
	is there a typical standard ? typical user requirement ?
	are any of these choices violate any existing drafts/standards?

	Q2. The case for E-LSP is more confusing. 
	      
	       Class-Type Model: As mentioned in the diff-te related
	       drafts, only one set of traffic parameters is signaled
	       during the connection setup. In such a case, 
		a) per-connection policing based on the signaled
		parameter 
		b) aggregate policing based on the configured per
		PSC parameters -different flows might get policed
		differently based on the EXP.
		c) both -?
		
	       Traffic Parameters for each PSC: This is based on the 
	       E-LSP draft that was posted few months back (I am
	       not sure of the current status of the draft).
		a) per-connection policing -not possible ?
		b) aggregate policing 
			-either based on the configured per-PSC
			parameters
			-or based on the signaled per-PSC 
			traffic parameters
		c)both -?
	Although the choice depends on the hardware capability,
	is there a typical standard ? typical user requirement ?
	are any of these choices violate any existing drafts/standards?

	Thanks,
	sanjay

---

From: Nabil Seddigh <[email-masked]>
Date: Wed, 27 Jun 2001 13:16:46 -0400

Two thoughts on per-connection vs per-aggregate policing:

1. I would assume that the reason anyone would use E-LSP would
   be to take advantage of the Diffserv architecture - this 
   implies no per-connection policing or scheduling 
   treatment at the LSRs. Otherwise, you might as well use L-LSP.

2. Though each LSR may treat E-LSPs as Diffserv aggregates, 
   it is still possible to perform per-connection admission 
   control on each aggregate within an E-LSP. 

>         and E-LSPs. Your help will be appreciated.

---
Best, 
Nabil Seddigh
[email-masked]