Subject: swap & push operation

From: Sajith Kizhikkepurayil <[email-masked]>
Date: Mon, 11 Jun 2001 11:22:29 -0700

hi

      from rfc 3031:
      ----
      c) replace the label at the top of the label stack with a
         specified new label, and then push one or more specified new
         labels onto the label stack.
      ----

      could somebody give me an application scenario ?

      i understand that this is useful in ingress of an LSP
      i would like to know how exactly it works with respect to deciding
      the next hop, and how is the label that swaped&pushed being 
      is decided
    
      if this is already being discussed, please give me the pointers.

thanks
sajith

---

From: Sajith Kizhikkepurayil <[email-masked]>
Date: Tue, 12 Jun 2001 09:30:40 -0700

hi robert

   thanks for the clarification, the slide had it clearly explained
 
so if i want to establish an explicit path between 2 LSRs do I need
to use swap&push always, or is it only in special case like this ?

thanks
sajith

>One example can be the CSC (Carrier of Carriers) case. When the packet
>from ISP CE router is received to the carrier network it is a labeled
>packet. The label is ahead of time distributed from Carrier's PE to the
>CE. 
>
>At the PE based on the incomming label value the label is being swapped
>+ new IGP label is being pushed on top of stack to get packets to the
>other side PE of the carrier (the one which faces the other ISP). 
>
>For more graphical picture of this take a look at page from the below
>ppt url (sorry for this but I hate draw ascii pictures :).
>ftp://ftp-eng.cisco.com/rraszuk/interas_csc/RR_CSC_InterAS.ppt
>
>R.
>
>> Sajith Kizhikkepurayil wrote:
>> 
>> hi
>> 
>>       from rfc 3031:
>>       ----

---

From: "Sajith Kizhikkepurayil" <[email-masked]>
Date: Thu, 21 Jun 2001 17:03:14 -0700

hi robert

thanks
sajith