Subject: RE: Do Control packes use LSP?

From: "Alexander Marhold" <[email-masked]>
Date: Tue, 19 Jun 2001 09:52:25 +0200

----> see inline answers

Do the control packets originated by an LSP ingress,
directed toward the LSP egress router use MPLS
forwarding?  By control packets, I mean any protocol
packets originated by layer 3 on the ingress.

---> Yes, details seee below

Consider the following scenario:-

    Router A -----[ IP/MPLS cloud ]----- Router B

Assume that the above network is one AS.  Routers A,
B and all routers in the cloud run OSPF.  An LSP is
setup between A and B and another one is setup in the
reverse direction.  Traffic engineering is enabled at
A as well as at B.

Now, I found no reference in any MPLS draft/RFC which
talks about forwarding packets originated at router A,
destined for router B.  Are these packets forwarded
using MPLS or using "normal" IP routing?

---> they are treated like any packet with a given destination address and
in that they will use the LSP

I assume (because it sounds logical - though I did not
see any mention of it in documents), that the
signaling packets for the LSP itself (say refresh
messages in RSVP) shall not be sent over the LSP.

---> RSVP is sent HOP-by-HOP so the destination address is always the
physical next-hop
so in a typicall framebased implementation using PHP (penultimate hop
popping) they are sent unlabelled

I am not sure about sending other protocol packets.
Say, A and B also run I-BGP with each other as the
peer.  Do the BGP (or any other application) packets
use LSP?

---> YES, they are treated like any L3 packet and are using by default the
same FORWARDING engine like other packets

I say "by default", as there maybe could be vendor implementations treating
local packets differently, even though I am currently not aware of such
implementation

with best regards

Alexander

__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/
     __/
    __/   Dipl.Ing. Alexander Marhold MBA
   __/   CCIE #3324, CCNP, CCDP, CCSI #20642
  __/   Core & IP Services <Senior Consultant>
 __/   Mobile: ++43-(0)664-16 28 234
__/    PRO IN http://www.proin.com

---

From: Vikas D <[email-masked]>
Date: Mon, 18 Jun 2001 20:29:14 -0700 (PDT)

Hi All,

 

Thanks
- Vikas

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/

---

From: Changhoon Kim <[email-masked]>
Date: Wed, 20 Jun 2001 11:49:28 +0900

Vikas,

I have some inline comments below.

> using MPLS or using "normal" IP routing?

Ideally, we should be able to define traffic trunks on the basis of FECs
(at any granularities), traffic profiles, and other TE requirements. But
practically, ISPs might prefer to let traditional IGP SPF define proper
sets of traffic trunks for given LSPs, by advertising (FA) LSPs as
unidirectional p2p links and making use of them.
Anyway even in that case, IGP peering over (FA) LSPs should be avoided,
and of course as far as I know, is not supported by any implementation.

Anyway, I also want to know others' opinion about having a standard that
deals with "rules to map data & control packets to proper LSPs." Is this
still skeptical as a topic for standard? Then, are there anybody who got
a decent "best-practices and their rationale" on this?

> messages in RSVP) shall not be sent over the LSP.

Right, as others replied.

> peer.  Do the BGP (or any other application) packets

It depends upon the IP addresses; the egress address of the LSP and the
IBGP peer address. If they are identical, IBGP route updates should use
the LSP. But if not, they won't even though the egress and the IBGP peer
are the same. Thus, in that case, utilizaing loopback to indicate its
IBGP peer and its egress is preferred.

Cheers,

Chang

--
Changhoon Kim

Dept. of Internet Technologies
Electronics and Telecommunications Research Institute (ETRI)
Taejon, KOREA
Tel) +82-42-860-5801
Fax) +82-42-860-5440

***
Man usually avoids attributing cleverness to somebody else, unless it is
an enemy.
 -- Albert Einstein