Subject: Re: Use of RSVP in MPLS

From: [email-masked]
Date: Thu, 14 Jun 2001 17:39:43 +0200

See below.

     Francis.

>> Now my question are:
>> - who instructed the ingress LSR to send the
>>  RESV message ?

The RESV message is not sent by the ingress LSR. Rather the RESV message is sent (hop-by-hop) from the egress LSR towards the ingress LSR.

>> - would be it possible for the setup process to
>> be initiated by a end system wishing to establish
>> a new LSP through the MPLS network (a la IntServ) ?

The protocol allows the setup to be initiated from an end system. However, the question is whether or not the service provider policy accepts LSP establishment requests from a host end system.

"Roberto Canonico" <[email-masked]> on 14/06/2001 13:34:30

 To:      [email-masked]                                         
                                                              
 cc:      (bcc: Francis ARTS/BE/ALCATEL)                      

 Subject: Use of RSVP in MPLS                                 

Hi all.
After reading several documents and
IDs related to RSVP-TE and its use in MPLS
to setup new LSPs, it is clear that the setup
process is initiated by the ingress LSR
which sends an RSVP PATH message downstream
to the egress LSR.
Now my question are:
- who instructed the ingress LSR to send the
  RESV message ?
- would be it possible for the setup process to
be initiated by a end system wishing to establish
a new LSP through the MPLS network (a la IntServ) ?
Thanks in advance for your clarifications.
Regards,
    Roberto Canonico

---

From: "Roberto Canonico" <[email-masked]>
Date: Thu, 14 Jun 2001 18:09:23 +0200

Francis, thanks for your reply.
A few more questions for all ...

> The protocol allows the setup to be initiated from an end system.
> However, the question is whether or not the service provider policy
accepts LSP establishment requests from a host end system.

Q1 - Has such a scenario any chance to be implemented in "real" MPLS
networks ?

Q2 - I remember in RSVP for IntServ, the resource
        reservation process was originated by a request
        issued by an application through a special API.
        In the case of RSVP-TE, what is the event that triggers
        this signalling phase ?
        In different words, what entities are in charge of
        deciding if a new LSP is to be created in an MPLS network ?

Thanks again for your attention.
Regards,
    Roberto Canonico

 To:      [email-masked]

Hi all.