Subject: RE: Do Control packes use LSP?

From: [email-masked]
Date: Tue, 19 Jun 2001 20:32:20 +0530

hi all!
     Just to add here I think we use a dedicated VCI/VPI pair between ATM LSRs
to run LDP and hence it is kind of out-of-band siganlling. Same is the case with
FR (using specific DLCI). So I guess its not strictly correct to say that the
control packets follow the same LSP as the data packets(in ATM and FR LSRs).

best regards
-s

"Alexander Marhold" <[email-masked]> on 06/19/2001 01:22:25 PM

To:   "Vikas D" <[email-masked]>
cc:   [email-masked], [email-masked] (bcc: Sumit Chauhan/HSS)

Subject:  RE: Do Control packes use  LSP?

----> see inline answers

Do the control packets originated by an LSP ingress,
directed toward the LSP egress router use MPLS
forwarding?  By control packets, I mean any protocol
packets originated by layer 3 on the ingress.

---> Yes, details seee below

Consider the following scenario:-

    Router A -----[ IP/MPLS cloud ]----- Router B

Assume that the above network is one AS.  Routers A,
B and all routers in the cloud run OSPF.  An LSP is
setup between A and B and another one is setup in the
reverse direction.  Traffic engineering is enabled at
A as well as at B.

Now, I found no reference in any MPLS draft/RFC which
talks about forwarding packets originated at router A,
destined for router B.  Are these packets forwarded
using MPLS or using "normal" IP routing?

---> they are treated like any packet with a given destination address and
in that they will use the LSP

I assume (because it sounds logical - though I did not
see any mention of it in documents), that the
signaling packets for the LSP itself (say refresh
messages in RSVP) shall not be sent over the LSP.

---> RSVP is sent HOP-by-HOP so the destination address is always the
physical next-hop
so in a typicall framebased implementation using PHP (penultimate hop
popping) they are sent unlabelled

I am not sure about sending other protocol packets.
Say, A and B also run I-BGP with each other as the
peer.  Do the BGP (or any other application) packets
use LSP?

---> YES, they are treated like any L3 packet and are using by default the
same FORWARDING engine like other packets

I say "by default", as there maybe could be vendor implementations treating
local packets differently, even though I am currently not aware of such
implementation

with best regards

Alexander

__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/__/
     __/
    __/   Dipl.Ing. Alexander Marhold MBA
   __/   CCIE #3324, CCNP, CCDP, CCSI #20642
  __/   Core & IP Services <Senior Consultant>
 __/   Mobile: ++43-(0)664-16 28 234
__/    PRO IN http://www.proin.com

-------
The MPLS-OPS Mailing List
Subscribe/Unsubscribe:  http://www.mplsrc.com/mplsops.shtml
Archive: http://www.mplsrc.com/mpls-ops_archive.shtml

---

From: Vikas D <[email-masked]>
Date: Tue, 19 Jun 2001 11:40:41 -0700 (PDT)

I agree that there is no reason in theory not to be able
to send control packets over LSP.  But do MPLS capable
routers use LSP for control packets?  Or is there a way
in them to send all data but no control packets over LSP?

And most importantly, do the service providers use LSPs
for control data (if at all they have a choice)?

- VD

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/

---

From: "Irfan Lateef" <[email-masked]>
Date: Tue, 19 Jun 2001 19:38:26 -0400

To further add, the ingress node FEC can be mapped to
three level of granularity,a subnet mask, or IP adress
or IP address and port number.
And if an IP and address and port number is chosen to be mapped in
the FEC then the traffic to that destination will go on the
LSP and every thing else will be IP hop-by-hop.

Hope this helps!

Irfan Lateef

>From: Shahram Davari <[email-masked]>
>To: "'Alexander Marhold'" <[email-masked]>, Vikas D <[email-masked]>
>CC: [email-masked], [email-masked]
>Date: Tue, 19 Jun 2001 06:05:54 -0700
>
>Hi,
>
>In MPLS you could select to send any traffic that you wish
>over an LSP. This is accomplished by packet classification to FECs, and
>possibly local policy, and therefore is configurable at the ingress LSR.
>
>-Shahram
>
> > -----Original Message-----
> > From: Alexander Marhold [mailto:[email-masked]]
> > Sent: Tuesday, June 19, 2001 3:52 AM
> > To: Vikas D
> > Cc: [email-masked]; [email-masked]

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com