Subject: Any disadvantage about MPLS?

From: [email-masked]
Date: Tue, 5 Jun 2001 05:26:17 +0800 (CST)

It seems that MPLS is good for almost everything,from QoS to traffic engineering and VPN.

I want to get some information about its disadvantages,any information will be appreciated.

_____________________________________________
������������������   http://shopping.263.net/hotsale/summer/
[�㲻���� ��������] ����ר�úţ�95963���û���/���룺263

---

From: Sunil Ramachandran <[email-masked]>
Date: Tue, 5 Jun 2001 15:21:58 -0700

Let us say, an MPLS shim is required for Ethernet [Layer2].
What would be the ideal mechanism to negotiate MTU entirely within Layer2?

- Sunil.

-----Original Message-----
From: Akshat Kapoor [mailto:[email-masked]]
Sent: Tuesday, June 05, 2001 7:18 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: Any disadvantage about MPLS?

Hi Mohit,
    That case would only hold true
- if the native Layer 2 header doesn't have a field for label (like ATM has
VPI-VCI fields, FR has DLCI), or
- the label stack (if present) can't be adjusted in the layer 2 header.

Akshat
----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Tuesday, June 05, 2001 6:03 PM
Subject: Re: Any disadvantage about MPLS?

>
>
> Hi ewliu!
>
> one disadvantage of mpls is that a four byte shim header is inserted to
every
> network layer packet before being forwarded to data link layer, which
> effectively increases the payload for data link layer.
>
> Regards
> Mohit
>
>
>
>
> [email-masked] on 06/05/2001 02:56:17 AM
>
> To:   [email-masked]
> cc:   [email-masked] (bcc: Mohit Goel/HSS)
>
> Subject:  Any disadvantage about MPLS?
>
>
>
>
> It seems that MPLS is good for almost everything,from QoS to traffic
engineering
> and VPN.
>
> I want to get some information about its disadvantages,any information
will be
> appreciated.
> ??????????????????   http://shopping.263.net/hotsale/summer/
> [???????? ????????] ????????????95963????????/??????263
>
>
>
>
>
>

---

From: "Islam, Aziz (Thinkpath)" <[email-masked]>
Date: Tue, 5 Jun 2001 13:17:28 -0400

Hi All,
To debate the advantages and disadvantages of MPLS, one needs to clearly
understand where it fits in into the realm of data communications. MPLS
complements routing and takes it to the next level. 

The obvious disadvantage is that being the "bleeding-edge" technology, some
hiccups might be expected in its implementation. 

Also, the learning curve may be steep for some organizations and
individuals. 

Interoperability and inter-provider issues, as always, take some time to get
resolved, for which work is going on in full swing in many IETF working
groups.

So I would sum up by saying that the advantages of MPLS may far outweigh its
disadvantages.

Aziz S. Islam
Senior Infrastructure Specialist
Cisco CCIE R/S
Network Engineering
EDS Canada Inc.
33 Yonge Street, Suite 400
Toronto, Ontario M5E 1G4
Ph: (416)814-1696
http://www.eds.com

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: June 4, 2001 5:26 PM
To: [email-masked]
Cc: [email-masked]
Subject: Any disadvantage about MPLS?
Importance: High

This message uses a character set that is not supported by the Internet
Service.  To view the original message content,  open the attached message.
If the text doesn't display correctly, save the attachment to disk, and then
open it using a viewer that can display the original character set.

---

From: "Irfan Lateef" <[email-masked]>
Date: Wed, 06 Jun 2001 11:49:15 -0400

David,

I mis-wrote 20-bit as 32-bit, thanks for correcting me.
But the point I was trying to make is the sanctity of 20-bits
versus 16-bits. I have been through all RFCs and even Yakov's
book does not talk about it. I was only refering to the case
where shim headers are used as you mentioned in POS.
Can you enlighten us with the rationale for the 20-bits for
label versus why not 16-bits.

Thanks,
Irfan

>From: David Charlap <[email-masked]>
>To: [email-masked]
>Date: Tue, 05 Jun 2001 20:32:25 -0400
>
>Irfan Lateef wrote:
> >
> > With the current experience with MPLS, and the need to design
> > high speed MPLS routers, I would like take your suggestion to
> > the extreme of saying that we should have only 16-bit labels.
> > This would allow faster label lookups. Hence it brings me to saying
> > that 32-bit MPLS label itself is actually a disadvantage in taking
> > the designs to the next levels.
>
>MPLS labels are not 32-bit values.  They are stored in 32-bit integers
>for the convenience of signaling protocols.
>
>An MPLS label on an interface that uses shim headers (like POS) is 20
>bits wide.
>
>An MPLS label on an ATM interface may be 8, 12, 24 or 28 bits, depending
>on the encoding scheme (SVC or SVP) and whether the cell structure is
>UNI or NNI.  In general, I think most implementations use 24-bit labels
>(SVC encoding with UNI-format cell structures.)
>
>An MPLS label on a Frame Relay interface may be 10 or 23 bits, depending
>on the DLCI width that the interface uses.
>
>See also RFCs 3031, 3032 and 3034
>
>-- David

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com