Subject: RE: doubt on diff-serv

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 25 Jun 2001 13:59:36 +0200

Murali,
This is a good and valid question. IMHO the answer is like following:
1. Router B operates in accordance with preconfigured EXP-->PHB mappings 
2. Preconfigured mappings in any DiffServ-aware LSR MUST include 
    mapping of  000 (EXP) --> Default Forwarding PHB. May be this should
    be explicitly added to the draft
3. Router A (which is not Diff-Serv-aware) MUST set EXP bits to 000.
This would result in consistent LSP behavior.
------------------------------------------
With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> -----Original Message-----
> From: murali tallapudi [mailto:[email-masked]]
> Sent: Monday, June 25, 2001 7:10 AM
> To: [email-masked]
> Subject: doubt on diff-serv
> 
> 
>  hi,
> 
>    i got one doubt on diff-serv. can u see the attachment  
> and clear my doubt?..
> 
> 
>  regards
> 
>  murali
> -- 
> 
> _______________________________________________
> FREE Personalized E-mail at Mail.com
> http://www.mail.com/?sr=signup
> 
> FREE PC-to-Phone calls with Net2Phone
> http://www.net2phone.com/cgi-bin/link.cgi?121
> 
> 
> 
> 
> 
> -- 
> 
> _______________________________________________
> FREE Personalized E-mail at Mail.com
> http://www.mail.com/?sr=signup
> 
> FREE PC-to-Phone calls with Net2Phone
> http://www.net2phone.com/cgi-bin/link.cgi?121
> 
> 
> 
> 
> 
>

---

From: [email-masked]
Date: Mon, 25 Jun 2001 14:25:41 +0200

Murali,

Section 5.3 of <draft-ietf-mpls-diff-ext-09>  indicates the expected behavior in the situation described in your mail:

"If a DIFFSERV object is not present in the Path message, the LSR
   SHOULD interpret this as a request for an E-LSP using the
   Preconfigured EXP<-->PHB Mapping. However, for backward
   compatibility purposes with other non-Diff-Serv Quality of Service
   options allowed by [RSVP_MPLS_TE] such as Integrated Services
   Controlled Load or Guaranteed Services, the LSR MAY support a
   configurable "override option". When this "override option" is
   configured, the LSR interprets a path message without a Diff-Serv
   object as a request for an LSP with such non-Diff-Serv Quality of
   Service."

     Francis.

Sasha Vainshtein <[email-masked]> on 25/06/2001 13:59:36

 To:      "'murali tallapudi'" <[email-masked]>           
                                                              
 cc:      "[email-masked]'" <[email-masked]>(bcc: Francis          
          ARTS/BE/ALCATEL)                                    

 Subject: RE: doubt on diff-serv                              

Murali,