Subject: RE: Question on T.E. MIB mplsTunnelTable indices.

From: [email-masked]
Date: Thu, 13 Sep 2001 08:59:28 +0100

Hi Tom,  I  noted this comment in your response 12 September 2001 21:45
>
>          This is not the case. The TunnelTotalUpTime
> indicates the total time that the tunnel head or instance
> (i.e.: LSP) has been active. Different tunnels can
> (and probably have been) up for different amounts of
> time.
NH=> Is there any way that you can currently measure Tunnel downtime, ie
periods of unavailability due to failures say?  If so, what are the
entry/exit criteria and consequent actions here?

Thanks, Neil

---

From: Thomas Nadeau <[email-masked]>
Date: Thu, 13 Sep 2001 08:52:35 -0400

>entry/exit criteria and consequent actions here?

         You can measure downtime by knowing when
the tunnel last went down and subtracting the current
time from that. If the tunnel has no signaled LSPs
(check to make sure that all instances of a tunnel
have operStatus = down), then you can calculate the
current downtime as:

current down time = (currTime - mplsTunnelLastPathChange)

         --Tom

---

From: Eric Verhoen <[email-masked]>
Date: Fri, 14 Sep 2001 12:22:19 -0700 (PDT)

I don't think I am on the same page as you are. Let us
take a specific example of 3 (head) tunnel instances
with the following indices and instance priorities:
T1 = (TunIx1,InstIx1,Src1,Dst1),instance priority = 5
T2 = (TunIx1,InstIx2,Src1,Dst1),instance priority = 5
T3 = (TunIx1,InstIx3,Src1,Dst1),instance priority = 4

T1, T2 and T3 have different instance index but the
other three indices are the same. Instance priority of
T3 is less than that of T1 and T2.
Assuming T1, T2 and T3 are up, T1 and T2 would be the
active tunnels carrying traffic (given that they have
the highest instance priorities). T3 can be regarded
as a standby tunnel because of its lower priority.
In this scenario I suppose T1 and T2 are the "primary
instances". In any case, what would be the (read-only)
mplsTunnelPrimaryInstance value for each of the rows
(of T1, T2 and T3) ?

Thanks
-ev-

--- Thomas Nadeau <[email-masked]> wrote:
> 
>          Sorry, missed the last question.
> 
> >Also, I don't think you answered my other question:
> > >What is a "primary" instance ?. It cannot
> possibly be
> > >the tunnel instance with the highest
> > >mplsTunnelInstancePriority because you can have
> > >multiple tunnel instances with the same instance
> > >priority (for load sharing).
> 
>          The primary instance is whatever the
> operator/implementation specifies it as. The
> actual instance id is irrelevant in this regard.
> It is the tunnel instance(s) that is/are being used
> to actively forward traffic for that tunnel.
> I used plural because there are some
> implementations where parallel LSPs
> can be created for the same tunnel head.
> 
>          --Tom
> 
> 
> 
> 
> >I appreciate your responses.
> >-ev-
> >
> >
> >--- Thomas Nadeau <[email-masked]> wrote:
> > > At 03:51 PM 9/12/2001 -0700, Eric Verhoen wrote:
> > > >I think I misinterpreted the usage of the word
> > > >"instance" for the mplsTunnelTotalUpTime
> object.
> > > >So when it says "This value represents the
> > > aggregate
> > > >up time for all instances of this tunnel..."
> the
> > > >"instance" is not really the
> mplsTunnelInstance.
> > > >My mistake.
> > > >
> > > >Based on your comments, am I correct in saying
> that
> > > >all the objects in the mplsTunnelTable can have
> > > unique
> > > >values for each tunnel (identified by the 4
> > > indices).
> > > >This would include things like the description,
> > > name,
> > > >isIf, ifIndex, signallingProtocol etc.
> > >
> > >          Yes.
> > >
> > > >The exception to this would be the following
> two
> > > >objects:
> > > >1. mplsTunnelPrimaryInstance
> > > >2. mplsTunnelPrimaryTimeUp
> > > >these two objects will have the same value for
> all
> > > the
> > > >tunnel instances with the same set of (3)
> indices
> > > not
> > > >including the mplsTunnelInstance.
> > >
> > >          Only for mplsTunnelPrimaryTimeUp.
> > > The four indexes in combination will UNIQUELY
> > > identify a particular tunnel instance. For
> example,
> > > the tunnel table might look like:
> > >
> > >          1,1,1,0
> > >          1,1,1,1
> > >          2,1,1,0
> > >          2,1,1,4
> > >
> > >          This would represent two tunnel heads
> > > (instance
> > > of 0) and two signaled instances of the tunnels:
> for
> > > tunnel 1, instance 1, and for tunnel 2, instance
> 4.
> > > So, to answer your question about uptime, tunnel
> > > 1 would have two uptimes, one for each instance,
> > > and the same would be true for tunnel 2. In both
> > > cases, the upTime value *could* be different
> > > depending
> > > on when each was signaled. The same is true for
> > > tunnelPrimaryTimeUp. It depends on how long the
> > > primary
> > > instance of the tunnel was up. In the example
> above,
> > > lets say that instance 0 corresponds to the
> primary
> > > instance of both tunnels. Then primaryTimeUp
> would
> > > correspond to these tunnels' upTimes. The
> > > value of that variable on the secondary
> > > (non-primary)
> > > instances of the tunnels should also reflect
> this
> > > same value, but I believe that support for this
> > > value on instances is not mandatory.
> > >
> > >          Hope this helps.
> > >
> > >          --Tom
> > >
> > >
> > > >Please correct me if this is not an accurate
> > > >statement.
> > > >
> > > >Now, to the next question:
> > > >What is a "primary" instance ?. It cannot
> possibly
> > > be
> > > >the tunnel instance with the highest
> > > >mplsTunnelInstancePriority because you can have
> > > >multiple tunnel instances with the same
> instance
> > > >priority (for load sharing).
> > > >
> > > >-ev-
> > > >
> > > >
> > > >--- Thomas Nadeau <[email-masked]> wrote:
> > > > >
> > > > > >What is the exact usage of the 4 indices of
> the
> > > > > >mplsTunnelTable ?
> > > > > >My understanding of SNMP tables is that all
> the
> > > > > fields
> > > > > >of a table are uniquely applicable to all
> the
> > > rows.
> > > > > >That does not seem to be the case with this
> > > table,
> > > > > >there are some entries for example
> > > > > >mplsTunnelTotalUpTime which is going to be
> the
> > > same
> > > > > >for all instances of a tunnel (meaning this
> > > value
> > > > > will
> > > > > >be repeated for all the rows for which the
> > > three
> > > > > >indices not including the instance index
> are
> > > the
> > > > > >same).
> > > > >
> > > > > indicates the total time that the tunnel
> head or
> > > > > instance
> > > > > (i.e.: LSP) has been active. Different
> tunnels
> > > can
> > > > > >I suppose that is OK because the  MIB
> > > > > >description for mplsTunnelTotalUpTime is
> very
> > > > > >unambiguous in stating the usage.
> > > > > >However, it is not very clear on reading
> the
> > > MIB
> > > > > table
> > > > > >what ojects are applicable to what row/s.
> For
> > > > > example,
> > > > > >does mplsTunnelDescr uniqely apply to all
> rows
> > > in
> > > > > the
> > > > > >the mplsTunnelTable ? meaning for every
> > > possible
> > > > > >combination of the indices
> (mplsTunnelIndex,
> > > > > >mplsTunnelInstance, mplsTunnelIngressLSRId,
> > > > > >mplsTunnelEgressLSRId).
> > > > >
> > > > >          I think that you are a bit confused
> > > about
> > > > > how
> > > > > SNMP tables are indexed. The 4 indexes
> provide
> > > > > a unique key to a specific (column, row) of
> the
> > > > > table,
> > > > > thus the description for that is probably
> going
> > > to
> > > > > be
> > > > > unique. I certainly wouldn't name every
> entry 
=== message truncated ===

__________________________________________________
Terrorist Attacks on U.S. - How can you help?
Donate cash, emergency relief information
http://dailynews.yahoo.com/fc/US/Emergency_Information/