Subject: mpls encapsulations

From: "Hemant P. Kelkar" <[email-masked]>
Date: Wed, 19 Sep 2001 06:51:41 -0400 (EDT)

Hi Everybody !

I have some doubt regarding the MPLS encapsulation inside IP and other
protocols.
What is the aim behind the following encapsulations:
#1. MPLS in IP (reasons other than tunneling MPLS via IP networks)
#2. MPLS in ATM and FR (reasons other than heterogeneous n/w interface)
#3. MPLS in IP in Ethernet (MPLS/IP/Ethernet)

Regards,
Hemant

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 19 Sep 2001 07:35:45 -0700

> -----Original Message-----
> From: Shahram Davari [mailto:[email-masked]]
> Sent: Wednesday, September 19, 2001 6:55 AM
> To: 'Hemant P. Kelkar'; [email-masked]
> Cc: [email-masked]
> Subject: RE: mpls encapsulations
> 
> 
> Hi,
> 
> > -----Original Message-----
> > From: Hemant P. Kelkar [mailto:[email-masked]]
> > Sent: Wednesday, September 19, 2001 6:52 AM
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: mpls encapsulations
> > 
> > 
> > Hi Everybody !
> > 
> I don't think there is any other reason. 
> 
> To reduce the number of control planes to one (i.e., MPLS).
> 
> This is not a good architecture. There is no reason to have 
> IP, you could easily do MPLS/Ethernet.

You would need this for the same reason you need #1.

-Anoop

---

From: Shahram Davari <[email-masked]>
Date: Wed, 19 Sep 2001 08:42:16 -0700

Good point.

-Shahram

> From: Anoop Ghanwani [mailto:[email-masked]]
> Sent: Wednesday, September 19, 2001 10:36 AM
> To: Shahram Davari; 'Hemant P. Kelkar'; [email-masked]
> Cc: [email-masked]