Subject: whether RSVP-TE can establish LSP without any reservation

From: "George Thomas" <[email-masked]>
Date: 5 Sep 2001 10:47:11 -0000

Hi,

In RSVP-TE, if the reservation cannot be done for a LSP, due to some reason like resource unavailable, then whether it is possible to establish a LSP with no resource reservation like BES with LSP, or we have to add LDP in the router to establish a Label switched path without reservation and CR-LDP with reservations, in this way we can avoid RSVP-TE.

I think RSVP is mainly for reservation and it won't allow for establishing the LSP, without BW reservation,
like filling the trafiic parameters as 0.

If we can do that without LDP, then is there any scenario where both LDP/CR-LDP and RSVP-TE co-exist?

Regards,
George

---

From: David Charlap <[email-masked]>
Date: Wed, 05 Sep 2001 10:54:49 -0400

George Thomas wrote:
> 
> In RSVP-TE, if the reservation cannot be done for a LSP, due to
> some reason like resource unavailable, then whether it is possible
> to establish a LSP with no resource reservation like BES with LSP,
> or we have to add LDP in the router to establish a Label switched
> path without reservation and CR-LDP with reservations, in this
> way we can avoid RSVP-TE.
> 
> I think RSVP is mainly for reservation and it won't allow for
> establishing the LSP, without BW reservation, like filling the
> trafiic parameters as 0.

Best-effort LSPs can be signaled with RSVP-TE.  You shoud use the
IntServ Null Service for this.  See RFC 2997.

If you use the Controlled Load or Guaranteed Service parameters with
zeros, you will get something similar, but not identical.  You may get
best effort.  You may also get a reservation for a value you didn't
expect.  Zeros in IntServ parameters are interpreted as "don't care"
values, and may be processed in unexpected ways if you really do care
about their interpretation.

-- David