Subject: RE: A question on mpls-te-mib: mplsTunnelHopEntryPathComp

From: Ling Li <[email-masked]>
Date: Mon, 10 Sep 2001 16:28:03 -0400

Hi Abhay,

Thanks for your answer for the question. I agree with you that
include/exclude 
a hop should have nothing to do with the mplsTunnelHopEntryPathComp field. 
However, this understanding may be wrong if you read the description of the
field carefully:
"If this value is set to dynamic, then the user 
should only specify the source and destination of 
the path and expect that the CSPF will calculate 
the remainder of the path. "

The second answer I got from Ravikumar Kota (Thanks!) also suggests that I
am not the only one confused by the description:
"So if u want to mention other location along with sourse and destination, u
can not use 
dynamic option . U have to use "explicit" path option with sub option
"loose"."

Could any of the authors cast a light on it?

Thanks, 
Ling Li 
Axiowave Networks, Inc. 
Email: [email-masked] 
======================== 
-----Original Message-----
From: abhay [mailto:[email-masked]]
Sent: Wednesday, August 29, 2001 2:58 AM
To: Ling Li
Cc: [email-masked]'
Subject: Re: A question on mpls-te-mib: mplsTunnelHopEntryPathComp
Importance: High

Hello Ling Li,
             What we have on our hands here is:
             1)A dynamic CSPF path can be requested from the source(Boston)
to San Francisco
             Also,
             2)An Offline CSPF path can be requested on the source router
             In both the above cases one can request one router(Chicago) to
be included as a rule.
             Altough the user has requested deliberate inclusion,the path is
still dynamic
             with the INCLUDED router as a Constraint.
             In such cases,the constraint may not be satisfied.
             Only,when the user has requested a complete explicit path,then
we can consider it to
             be a explicit hop
             else
             The hops are all dynamic.
             Hope this helps,
             Regards,
             Abhay

Ling Li wrote: 
I was confused by the description of mplsTunnelHopEntryPathComp as bellow: 
mplsTunnelHopEntryPathComp OBJECT-TYPE 
SYNTAX INTEGER { 
        dynamic(1), -- CSPF computed 
        explicit(2) -- strict hop 
} 
MAX-ACCESS read-create 
STATUS current 
DESCRIPTION 
"If this value is set to dynamic, then the user 
should only specify the source and destination of 
the path and expect that the CSPF will calculate 
the remainder of the path. If this value is set to 
explicit, the user should specify the entire path 
for the tunnel to take. This path may contain 
strict or loose hops. Each hop along a specific 
path should have this object set to the same value" 
::= { mplsTunnelHopEntry 14 } 
My question is: what if a user want to use CSPF to find a route from Boston 
to San Francisco, but specifically he/she wants the route to go through 
Chicago. 
The description seems suggesting that this operation is not allowed, because

1. The user specified not only the source and destination, but an extra 
loose hop (Chicago). Therefore mplsTunnelHopEntryPathComp  cannot be dynamic

2. The user wanted to enable CSPF to calculate the path, so explicit is not 
appropriate for mplsTunnelHopEntryPathComp. 
Could anyone clarify on this doubt? 
Thanks, 
Ling Li 
Axiowave Networks, Inc. 
Email: [email-masked] 
========================

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 10 Sep 2001 16:57:00 -0400

Hi,

         Let me give you some of my thoughts inline.

>include/exclude a hop should have nothing to do with the 
>mplsTunnelHopEntryPathComp
>field.

         That is correct. The purpose of the Hop table is to specify the
DESIRED hops the tunnel is to traverse, loose/strict, dynamic/strict,
and include/exclude. The path comp table shows the path as
computed by the CSPF algorithm. If the path options used are
explicit (strict), then the path comp table will be the same as the
hop table. If the path options are loose/dynamic, then the CSPF
will compute a full path (if it can), which will be displayed in
the path comp table. Hops that are specified as "strict" cannot
be pruned from the CSPF calculation, while those with "loose"
can. Finally, if the path is signaled, the path signaled will be
displayed in the AHop (actual hop) table.

>dynamic option . U have to use "explicit" path option with sub option

         I think that the confusion here may be in the understanding of
whether or not you want the CSPF to do any of the work of path
computation or not. If mplsTunnelHopEntryPathComp is set to dynamic(1),
then the CSPF computes the path given the hops (included/excluded) in the
hop table. If mplsTunnelHopEntryPathComp is set to strict(2), then
the path is signaled as-is (explicitly) without CSPF intervention. As I 
mentioned,
hops that are tagged as "strict" must be signaled explicitly (or not
if they are excluded), even if the CSPF is run to "fill in the hops". Part
of the confusion in your understanding may also be in the fact
that existing implementations allow some combination of dynamic
with end-points specified,  fully-explicit paths, or partially-explicit paths
where you specify a partial path and CSPF fills-in the rest.

         Hope that helps,

         --Tom