Subject: Control and Forwarding functions

From: David Escobar <[email-masked]>
Date: Sun, 02 Sep 2001 12:32:00 -0500

Hi:
It is said that MPLS makes a good separation between the Control and the Forwarding functions. It is also said that MPLS may use extensions of existing IP protocols to piggyback label distribution (MPLS-BGP, MPLS-RSVP-TUNNELS).
What is the meaning of good separation between the Control and the Forwarding functions? MPLS still uses the same Control protocols, just a little altered to provide label distribution by piggybacking and the Forwarding function still needs to make table look up to find the next hop. Even worse, it needs to make label swapping. Conventional IP also makes table look up but with the advantage of not requiring label swapping. Why can be inferred that conventional IP does not make a good separation of the Control and Forwarding function while MPLS does?

---

From: "Hongwei" <[email-masked]>
Date: Sun, 2 Sep 2001 20:59:42 +0100

Hi David,

As much as I understand, MPLS technology is connection-oriented, and is
below or at the same level of IP. Like all connection-oriented protocols,
MPLS needs a set-up procedure before traffic begins. PVC or SVC is
established then. So called Control is the setup procedure(label requesting
and label mapping in LDP and CR-LDP). It establishes the forwarding
table,and it is before the traffic begins. So called Forwarding is in the
traffic stage. The outgoing port is easily got from the forwarding table
just because the setup procedure has established an explicit VC. So the
traffic becomes easy. Label swapping is needed because the labels in the
MPLS shim are locally significant, not globally(IP address is globally
important). The locally important label can be dynamically allocated and
released by the router. This adds flexibility. ATM also needs VCI/VPI
swapping. If globally important identifiers such as (source IP, destination
IP) pair are used as label of VC, multiple traffic between different
processes in the source machine and different processes in the destination
machine can't be distinguished.

While IP has no setup procedure because it is a connectionless technology.
So I just see its Forwarding function. At every hop, every IP packet has to
find next hop's IP address and its corresponding MAC address by ARP.

It is true that both IP and MPLS need consult the table, so MPLS forwarding
is not necessarily faster than IP if packet's destination IP address can
always match an entry in IP routing table. And now it is more apparent that
MPLS is intended to combine the advantages of ATM and IP. MPLS can help to
realize traffic engineering over IP networks, such as explicit routing can
help allocate traffic evenly, and turn to alternative route quickly in case
of network failure.

I am just brave(rash?) enough to make above comments. I will appreciate any
correction of my mistakes. THX in advance:)

--Hongwei

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of David
Escobar
  Sent: 02 September 2001 18:32
  To: [email-masked]
  Subject: Control and Forwarding functions

  Hi:
  It is said that MPLS makes a good separation between the Control and the
Forwarding functions. It is also said that MPLS may use extensions of
existing IP protocols to piggyback label distribution (MPLS-BGP,
MPLS-RSVP-TUNNELS).
  What is the meaning of good separation between the Control and the
Forwarding functions? MPLS still uses the same Control protocols, just a
little altered to provide label distribution by piggybacking and the
Forwarding function still needs to make table look up to find the next hop.
Even worse, it needs to make label swapping. Conventional IP also makes
table look up but with the advantage of not requiring label swapping. Why
can be inferred that conventional IP does not make a good separation of the
Control and Forwarding function while MPLS does?

---

From: "Mareline Sheldon" <[email-masked]>
Date: Mon, 3 Sep 2001 11:00:57 +0530

Also what I'd like to add is that MPLS uses a single forwarding algorithm unlike that in IP where different functionalites provided by the control component (unicast, multicast, unicast routing with TOS) requires multiple forwarding algorithms. To cite an example, consider forwarding of unicast packets, which requires longest match based on the network layer destination address, forwarding of unicast with TOS requires longest match on the destination IP adress plus the exact match on the TOS bits carried in the IP header, multicast routing etc.

MPLS consists of just one forwarding algorithm , aka label swapping.

This is also one important distinction between label switching and the conventional routing architectures.

I hope i am correct in my understanding !

Mary
  ----- Original Message ----- 
  From: Hongwei 
  To: David Escobar 
  Cc: [email-masked] 
  Sent: Monday, September 03, 2001 1:29 AM
  Subject: RE: Control and Forwarding functions

  Hi David,
   
  As much as I understand, MPLS technology is connection-oriented, and is below or at the same level of IP. Like all connection-oriented protocols, MPLS needs a set-up procedure before traffic begins. PVC or SVC is established then. So called Control is the setup procedure(label requesting and label mapping in LDP and CR-LDP). It establishes the forwarding table,and it is before the traffic begins. So called Forwarding is in the traffic stage. The outgoing port is easily got from the forwarding table just because the setup procedure has established an explicit VC. So the traffic becomes easy. Label swapping is needed because the labels in the MPLS shim are locally significant, not globally(IP address is globally important). The locally important label can be dynamically allocated and released by the router. This adds flexibility. ATM also needs VCI/VPI swapping. If globally important identifiers such as (source IP, destination IP) pair are used as label of VC, multiple traffic between different processes in the source machine and different processes in the destination machine can't be distinguished.
   
  While IP has no setup procedure because it is a connectionless technology. So I just see its Forwarding function. At every hop, every IP packet has to find next hop's IP address and its corresponding MAC address by ARP. 
   
  It is true that both IP and MPLS need consult the table, so MPLS forwarding is not necessarily faster than IP if packet's destination IP address can always match an entry in IP routing table. And now it is more apparent that MPLS is intended to combine the advantages of ATM and IP. MPLS can help to realize traffic engineering over IP networks, such as explicit routing can help allocate traffic evenly, and turn to alternative route quickly in case of network failure.
   
  I am just brave(rash?) enough to make above comments. I will appreciate any correction of my mistakes. THX in advance:)
   
  --Hongwei

    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]On Behalf Of David Escobar
    Sent: 02 September 2001 18:32
    To: [email-masked]
    Subject: Control and Forwarding functions

    Hi:

---

From: "Sukanta Ganguly" <[email-masked]>
Date: Mon, 03 Sep 2001 02:25:24 -0700

Hi,
  Also, with the labels it is possible to group traffic and applying the FEC to traffic from different source and different destination, thus a better traffic engineering aspect can be implied and respected.
  In the IP world source and destination are the only defined way to attach behaviour to the packet. (I know the TOS has also used at some places but it not a definate approach)
  Labels attach better behaviour markers that can be utilized in a pre-planned manner. 
  Labels can be stacked and hence different paths can be attributed with different logic and operating philosophies which is not possible with just IP source and destination.
 
Thanx
SG
*********** REPLY SEPARATOR ***********

On 9/2/2001 at 8:59 PM Hongwei wrote:
Hi David,

--Hongwei

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of David Escobar
Sent: 02 September 2001 18:32
To: [email-masked]
Subject: Control and Forwarding functions

Hi:

---

From: Ajay Simha <[email-masked]>
Date: Mon, 3 Sep 2001 10:30:55 -0400 (Eastern Daylight Time)

> below or at the same level of IP. Like all connection-oriented protocols,

I feel better using the term you used below and call it a "control driven"
process.  When we use LDP I'm not sure if we are "establishing a connection"
in the classic sense (of creating an end to end PVC).

-ajay

 > MPLS needs a set-up
procedure before traffic begins. PVC or SVC is

-- 
Ajay Simha
MPLS Deployment Engineer
IOS Technology Division
(919) 392-3141

"Study as if you were to live forever
 Live as if you were to die tomorrow"

 - Mahatma Gandhi

---

From: "Ding Aijun" <[email-masked]>
Date: Mon, 3 Sep 2001 13:19:36 +0800

Hi,

MPLS is a connection-oriented. So, it needs a data plane, a control plane. ATM network architecture is a good reference. 

Forwarding lies in the data plane, while signaling in the control plane. Signaling, as well as call admission control, helps to set up the virtual link. And then, data forwarding happens on the pre-established link. This is a rough procedure. I hope it helps to explain the seperation between the control and forwarding function.

regards,
aijun

  ----- Original Message ----- 
  From: Hongwei 
  To: David Escobar 
  Cc: [email-masked] 
  Sent: Monday, September 03, 2001 3:59 AM
  Subject: RE: Control and Forwarding functions

  Hi David,

  --Hongwei

    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]On Behalf Of David Escobar
    Sent: 02 September 2001 18:32
    To: [email-masked]
    Subject: Control and Forwarding functions

    Hi:

---

From: David Escobar <[email-masked]>
Date: Tue, 04 Sep 2001 10:20:12 -0500

Hi Hongwei:
I though that a router's Control function was the distribution of information among routers to build the routing tables and that the Forwarding function was the routing table look up to find the output port, output label, etc. I think that the control function in your definition is the signaling proccess to establish an SVC, so I think we are talking about different things
Thanks for answering.
  ----- Original Message ----- 
  From: Hongwei 
  To: David Escobar 
  Cc: [email-masked] 
  Sent: Sunday, September 02, 2001 2:59 PM
  Subject: RE: Control and Forwarding functions

  Hi David,

  --Hongwei

    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]On Behalf Of David Escobar
    Sent: 02 September 2001 18:32
    To: [email-masked]
    Subject: Control and Forwarding functions

    Hi:

---

From: "Sukanta Ganguly" <[email-masked]>
Date: Tue, 04 Sep 2001 08:40:39 -0700

To some extent the function is the same. In case of a standard IP router the routing protocol does the job of route updates, which is the control paths responsibility. The control paths learn about the routes via the OSPF, BGP etc... and then keep an updated lookup table so that the data path can perform the lookup and figure out the outgoing port.
With MPLS, there are the control portion which is handled via the LDP, CR-LDP etc... After learning the labels the data path uses them for its lookup process and does the swapping.
 Only thing that is worth noting is that this done over the IP network (atleast in the Internet), so we can say MPLS overlays on top of an IP network and hence creates a tunnel over IP routing.

SG

On 9/4/2001 at 10:20 AM David Escobar wrote:
Hi Hongwei:
I though that a router's Control function was the distribution of information among routers to build the routing tables and that the Forwarding function was the routing table look up to find the output port, output label, etc. I think that the control function in your definition is the signaling proccess to establish an SVC, so I think we are talking about different things
Thanks for answering.
----- Original Message ----- 
From: Hongwei 
To: David Escobar 
Cc: [email-masked] 
Sent: Sunday, September 02, 2001 2:59 PM
Subject: RE: Control and Forwarding functions

Hi David,

--Hongwei

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of David Escobar
Sent: 02 September 2001 18:32
To: [email-masked]
Subject: Control and Forwarding functions

Hi:

---

From: David Escobar <[email-masked]>
Date: Tue, 04 Sep 2001 10:28:45 -0500

Hi Aijun:
Again, I think we are talking about different things. Some books mention that routers have two functions: The Control and the Forwarding. I understand that the Control function is the distribution of information among routers to build the routing tables while the forwarding function is using those tables to find the output port, etc. Books also say that MPLS makes a good separation between those two functions. What I would like to understand is how is that different to IP. How this separation is not well done in IP while it is very well done in MPLS.
Thanks for answering.
  ----- Original Message ----- 
  From: Ding Aijun 
  To: Hongwei ; David Escobar 
  Cc: [email-masked] 
  Sent: Monday, September 03, 2001 12:19 AM
  Subject: Re: Control and Forwarding functions

  Hi,

  regards,
  aijun

    ----- Original Message ----- 
    From: Hongwei 
    To: David Escobar 
    Cc: [email-masked] 
    Sent: Monday, September 03, 2001 3:59 AM
    Subject: RE: Control and Forwarding functions

    Hi David,

    --Hongwei

      -----Original Message-----
      From: [email-masked] [mailto:[email-masked]]On Behalf Of David Escobar
      Sent: 02 September 2001 18:32
      To: [email-masked]
      Subject: Control and Forwarding functions

      Hi:

---

From: "Ding Aijun" <[email-masked]>
Date: Tue, 11 Sep 2001 13:31:45 +0800

Hi,

MPLS seperates control and forwarding in the sense that packet forwarding in MPLS network uses only one mechanism, i.e. label swapping. Furthermore, in GMPLS network, control and data planes can be physically seperated. I would like to recommend you two articles describing the Generalized MPLS, which also helps you understand your question:

1. A. Banerjee, et al., Generalized Multiprotocol Label Switching: An Overview of Routing and managment Enhancements, IEEE Communications magazine, Jan. 2001
2. A. Banerjee, et al., Generalized Multiprotocol Label Switching: An Overview of Signaling Enhancements and Recovery Techniques, IEEE Communications magazine, July 2001

regards,
aijun

  ----- Original Message ----- 
  From: David Escobar 
  To: Ding Aijun ; Hongwei 
  Cc: [email-masked] 
  Sent: Tuesday, 04 September, 2001 11:28 PM
  Subject: Re: Control and Forwarding functions

  Hi Aijun:
    ----- Original Message ----- 
    From: Ding Aijun 
    To: Hongwei ; David Escobar 
    Cc: [email-masked] 
    Sent: Monday, September 03, 2001 12:19 AM
    Subject: Re: Control and Forwarding functions

    Hi,

    regards,
    aijun

      ----- Original Message ----- 
      From: Hongwei 
      To: David Escobar 
      Cc: [email-masked] 
      Sent: Monday, September 03, 2001 3:59 AM
      Subject: RE: Control and Forwarding functions

      Hi David,

      --Hongwei

        -----Original Message-----
        From: [email-masked] [mailto:[email-masked]]On Behalf Of David Escobar
        Sent: 02 September 2001 18:32
        To: [email-masked]
        Subject: Control and Forwarding functions

        Hi: