Subject: Re: Control and Forwarding functions

From: "Ding Aijun" <[email-masked]>
Date: Wed, 5 Sep 2001 13:41:55 +0800

Guys, this is a fight!

At first, MPLS was introduced to realize so-called L3 switching. At that
time, MPLS is definitely a connection-oriented technology (At least, it
tried to be one). Well! MPLS is actually a technique to glue L3 routing with
L2 switching functionality. It is hard to say MPLS lies on which layer.
Someone says it lies on layer 2.5. I think this is acceptable.

But, will some guys give a clear answer to the original question raised by
David Escobar. We are departing from that. The question is listed below. I
am also very interested, but not able to answer it.

=========
Some books mention that routers have two functions: The Control and the
Forwarding. I understand that the Control function is the distribution of
information among routers to build the routing tables while the forwarding
function is using those tables to find the output port, etc. Books also say
that MPLS makes a good separation between those two functions. What I would
like to understand is how is that different to IP. How this separation is
not well done in IP while it is very well done in MPLS.
=========

regards,
aijun

----- Original Message -----
From: "Loa Andersson" <[email-masked]>
To: <[email-masked]>
Cc: "David Allan" <[email-masked]>; "Ding Aijun"
<[email-masked]>; "Hongwei" <[email-masked]>; "David
Escobar" <[email-masked]>; "mpls" <[email-masked]>
Sent: Wednesday, September 05, 2001 5:04 AM
Subject: Re: Control and Forwarding functions

>
> So you make your definiton of "connection oriented" then it is
> possible
> to discuss whether MPLS is connection oriented according to that
> definition. Fair, but changing rules during discussion don't bring
> you anywhere.
>
> According to the OSI model L2 has a common mac, does MPLS?
> According to the OSI model L3 as a common addressing scheme, does
> MPLS?
>
> /Loa
>
> -------------------
> >
> > I don't know why some people will not accept that MPLS
> > is mainly a connection oriented technology. The main
> > characteristic of a Connection Oriented service is the
> > long term association required between two end points.
> > The process of how such association is established is
> > not important. It is also not important if the
> > connection doesn't begin or end at some hosts (why we
> > need to use ISDN or X.25 definitions of connections?).
> >
> > It is quite obvious that there is very clearly
> > established permanent association between two end points
> > of LSPs. All LSRs also maintain the necessary states
> > about particular paths (similar to circuit switched
> > network).
> >
> > From all this, MPLS clearly is the connection oriented
> > layer at layer 2. Of course, I have also seen comments
> > that MPLS doesn't fit in ISO model. Oh Really, !.
> >
> >
> > Cheers,
> >
> > --brijesh
> > Corona Networks
> > > OK, here we go again....
> > >
> > > To its nature MPLS is not "connection oriented"! I also depends
> quite a
> > > bit on the definition of "connection oriented", but if we e.g. let
> an
> > > ISDN
> > > phone call be the model of a connection oriented technology, then
> you
> > > immediately see that MPLS misses the most important part of what a
>
> > > connection oriented technology is all about.
> > > ISDN is separated into two parts "call control" and "connection
> > > handling",
> > > together they form the connection orientation.
> > >
> > > So the "call control" handle e-2-2 compatibility and ability to
> take the
> > > call. This does not exist in MPLS. The call control also OK's the
> set
> > > up of the call and is once it is established dependent of the
> e-2-e
> > > connectivity, if the connectivity is broken the call is released.
> > > Nothing
> > > of this is present in MPLS.
> > >
> > > Sometimes one hear that MPLS is connection oriented because there
> is
> > > a mapping from node to node over the network, strictly this is not
> true,
> > > the only thing that is mapped incoming label to outgoing label and
> > > interface.
> > > The rest is routing in the standard IP connections way.
> > >
> > > As for the arguments that "most of the" LSP setup is connection
> > > oriented,
> > > usually meaning end-to-end (which really is edge-to-edge, there is
> not
> > > much idea to establish a connection edge-to-edge. But even so
> > >
> > > LDP DU independent liberal is not connection oriented
> > > LDP DU independent conservative is not connection oriented
> > > LDP DU ordered liberal is not connection oriented
> > > LDP DU ordered conservative is not connection oriented
> > >
> > > LDP DoD independent liberal is not connection oriented
> > > LDP DoD independent conservative is not connection oriented
> > > LDP DoD ordered liberal is not connection oriented
> > > LDP DoD ordered conservative could at best emulate part of a
> connection
> > >         oriented technology (signaling)
> > >
> > > RSV-TE mostly strictly follows IP routing and is not connection
> oriented
> > >        and if there are explicit routes it falls into the same
> category
> > >        as LDP DoD ordered conservative
> > >
> > > We are left with a technology where it is required to have an
> > > MPLS-external
> > > application that do the call control part of connection
> orientation. Why
> > > we would like to do that is beyond me, as we loses all the
> benefits of
> > > the
> > > IP and MPLS combination.
> > >
> > > /Loa
> > >
> > > --
> > > Loa Andersson
> > > Chief Architect,
> > > Utfors Research, Architecture and Future Lab (URAX)
> > > Utfors AB
> > > Råsundavägen 12
> > > Box 525, 169 29 Solna
> > > Office          +46 8 5270 2000
> > > Office direct   +46 8 5270 5038
> > > Mobile          +46 70 848 5038
> > > Email           [email-masked]
> > > WWW             www.utfors.se
> >
> Loa Andersson
> Chief Architect,
> Utfors Research, Architecture and Future Lab (URAX)
> Utfors AB
> R?ndav?n 12
> Box 525, 169 29 Solna
> Office          +46 8 5270 2000
> Office direct   +46 8 5270 5038
> Mobile          +46 70 848 5038
> Email           [email-masked]
> WWW             www.utfors.se
>
>

---

From: "Mareline Sheldon" <[email-masked]>
Date: Wed, 5 Sep 2001 12:06:37 +0530

Let me attempt to answer what was originally asked by David Escobar.
Routing functionality in IP is notoriously difficult to evolve because of
the close coupling between the routing and forwarding planes. To cite an
example, consider the process of deploying CIDR. The effect of CIDR is to
say that IP network prefixes, which had previously been 8,16, or 24 bits
long, could now be of any length. This helped in enabling more scalable
aggregation of addressing and routing information but, making this change
also required a change in the forwarding algorithm of virtually *all* IP
routers, because prefixes could now be of any length. Thus making changes to
the forwarding algorithms is typically an expensive and time-consuming
proposition.

One of the attractions of MPLS (or any label switching technology for that
matter!) is that the forwarding algo is fixed and that new control paradigms
can be deployed without making any changes to it. A wide variety of control
modules can be used to control the label switching process, and they all use
the same forwarding algo!

Thus, it is entirely feasible to put the forwarding algo in hardware or to
tune the fast path software once without the concern that it will need to be
re-optimized every time a new piece of routing functionality is required.

Hope it clears.
Any doubts/queries/discussions are most welcome !

----- Original Message -----
From: "Ding Aijun" <[email-masked]>
To: "Loa Andersson" <[email-masked]>; <[email-masked]>
Cc: "David Allan" <[email-masked]>; "Hongwei"
<[email-masked]>; "David Escobar" <[email-masked]>;
"mpls" <[email-masked]>
Sent: Wednesday, September 05, 2001 11:11 AM
Subject: Re: Control and Forwarding functions

> > Email           [email-masked]

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com