Subject: re: Re: label values

From: "Hemant P. Kelkar" <[email-masked]>
Date: Thu, 27 Sep 2001 12:32:51 -0400 (EDT)

Hi Aditya,

Before classification, the 5 tuple Source IP + Destination IP + Service +
Source Port + Destination Port or  the tuple Source IP + Destination IP
determines the flow.
After classification since the flow is denoted by the label assigned,
there is no further need of classification.

--
Hemant

Date: Thu, 27 Sep 2001 21:41:24 +0530
From: Adithya Bhat <[email-masked]>
To: Hemant P. Kelkar <[email-masked]>
Cc: [email-masked], [email-masked],
[email-masked]
Subject: Re: label values

Hi Hemant,

Once a label is assigned to a set of packets, the label effectively
defines
the "flow" through the LSP,
So will it not be better to say that, packets will be classified based on
the
Labels ??

-Adithya

"Hemant P. Kelkar" wrote:

> Hi Krishnakanth,
> Label values are of local significance only , limited significance
between
> the neighbour routers (LSRs). Hence, there may be same label values on
two
> different LSPs in the MPLS Domain.
> Packets are classified into different FECs using a flow classifier e.g.
> same source/destination IP addresses, and service types. (TCP port
> numbers).
>
> --
> Hemant

---

From: Adithya Bhat <[email-masked]>
Date: Thu, 27 Sep 2001 22:18:15 +0530

Hemant,

This IP true in case of IP,  were 5 tuple u mentioned can be used.
But if specific to RSVP-TE ( lsp-tunnel draft ) section 2.1 says

" when   RSVP and MPLS are combined, a flow or session  can  be  defined
with
greater  flexibility  and generality.  The ingress node of an LSP can use a
variety
of means to determine  which  packets  are  assigned  a  particular  label. "

" Variety of means " = 5 Tuples.

Once the label has been allocated to this LSP,  label value
( which is meore general ) can be used to classify the packets ????
( may it be either ingress or core ).

-Adithya

--
=========================================================
Adithya S Bhat                                     Tel : 080-5355501
Software Engineer,                                Ext : 8251
CTG Datacom,                                       Fax : 5351133
Sasken Communication Technologies.  http://www.sasken.com/
==========================================================