Subject: Question on ERO

From: Krish K P <[email-masked]>
Date: Thu, 13 Sep 2001 06:02:46 -0700 (PDT)

RSVP-LSP draft says on ERO.,

2) If there is no second subobject, this indicates the
end of the
   explicit route.  The EXPLICIT_ROUTE object SHOULD
be removed from the
   Path message.  This node may or may not be the end
of the path.
   Processing continues with section 4.3.4.2, where a
new EXPLICIT_ROUTE
   object MAY be added to the Path message.

q1.Certain implementations omit the tunnel end node
address in the ERO., if that is the case what should
be the action of the penultimate node ??

q2.Also can someone explain me in simple terms on how
the processing continues with section 4.3.4.2 ??

q3. Certain implementations at the penultimate node
send path-err (routing problem) when the end node is
omitted in the ERO of the PATH message...is it legal
??

with regards
Krish

__________________________________________________
Terrorist Attacks on U.S. - How can you help?
Donate cash, emergency relief information
http://dailynews.yahoo.com/fc/US/Emergency_Information/

---

From: Arthi Ayyangar <[email-masked]>
Date: Thu, 13 Sep 2001 14:23:46 -0400 (EDT)

See comments inline.

> omitted in the ERO of the PATH message...is it legal
--------> If you don't have an ERO at the end of ERO processing, you would
still need to send the message; route it based  on the session
destination. Isn't this what a node would do if there was no ERO to start
with ? The draft does say that the node 'MAY' choose to add an ERO at this
point.

-arthi