Subject: MPLS based VPN

From: Sam Ford <[email-masked]>
Date: Wed, 26 Sep 2001 13:09:24 -0700 (PDT)

Hello,

I have the following questions on MPLS based VPN:
- One of the advantage over traditional VPN
  is cited as elimination of full mesh overlay
  when connecting multiple sites.
  Then, when does LSP setup in MPLS domain
  supporting a particular VPN?
  If it needs to be set up statically when configuring
  VPN, it doesn't seem to be different from
traditional
  mesh overlay.
  Is it set up when traffic is generated?
- Does MPLS based VPN require the same level
  of encryption as with traditional IP VPN?
  If not, how is it protected from unathorized
  access to data or tapping?

Thanks in advance,
-SF

-----Original Message-----
From:	Irwin Lazar [SMTP:[email-masked]]
Sent:	Tuesday, September 25, 2001 10:35 AM
To:	[email-masked]
Subject:	RE: MPLS:what is the industry people's
reaction!!

Here are a couple of scenarios where MPLS-based VPN
services offer
tremendous advantage (IMHO):

- An enterprise wishing to connect their sites via any
L2 mechanism with
guaranteed performance levels.  For example, take a
site with a 100MB
Ethernet connection to a service provider, and allow
it to establish a
private link to another site that has an ATM OC-3 to
the same provider.  For
further complexity, assume both sites are using
private IP addressing.

- A medium size enterprise wishing to build a fully
meshed network without
having to configure dozens of PVCs at each end point.

- An ISP that wants to offer private line transport
services over its
existing infrastructure as a value-ad service.  They
want to be able to
offer this private line option over a variety of L2
transport mechanisms so
that they aren't reliant on ATM.

Irwin

__________________________________________________
Do You Yahoo!?
Get email alerts & NEW webcam video instant messaging with Yahoo! Messenger. http://im.yahoo.com

---

From: Ajay Simha <[email-masked]>
Date: Wed, 26 Sep 2001 22:35:31 -0400 (Eastern Daylight Time)

>   Is it set up when traffic is generated?

You have to remember MPLS is a control driven mechanism.  Nothing gets setup
*when* there is traffic.  It is setup ahead of time.

Does the LSP need to be setup statically when configuring VPNs?

Depends on the implementation.  I have seen several implementations where LSPs
are setup automatically for all the IGP derived routes - this would include
the PEs and thus nothing special has to be done when you configure a VPN.

 > -
>Does MPLS based
>VPN require the same level

Now you are asking religious question :-)
Of course the answer is always depends :-)

When you say IP VPNs do you mean IPSEC based VPNs?  If yes, IPSEC based VPNs
have a different purpose in life.  Right now as I type this email, I'm using
an IPSEC based VPN model and that is because I'm going over the public
Internet.

If I got a dedicated ISDN/DSL or any other type of access into my company's
network without going over the public Internet I may not need encryption.

If I still feel I need encryption, just as folks did in frame relay and atm
networks they can encrypt their data.

-ajay

-- 
Ajay Simha
MPLS Deployment Engineer
IOS Technology Division
(919) 392-3141

"Study as if you were to live forever
 Live as if you were to die tomorrow"

 - Mahatma Gandhi