Subject: QoS and TE?

From: "Zhu Heqing" <[email-masked]>
Date: Tue, 18 Sep 2001 20:23:43 +0800

Hi,All:

Can you tell me what's the relationship between QoS and Traffic Engineering ?
It seems that Traffic Engineering is bigger because it has traffic oriented objective. :-)
I know it doesn't make sense to say who include who.
But whether  the concept can be interpreted like that ?

Please comments

Zhu Heqing, Graduate Student
University of Electronic Science and Technology of China

---

From: Yousuf Hasan <[email-masked]>
Date: Tue, 18 Sep 2001 08:08:00 -0700

>Can you tell me what's the relationship between QoS and Traffic Engineering ?

At a high-level:
-TE allows Constraint Based Routing (based on bandwidth, affinities, etc) for traffic aggregate trunks. Idea is to conserve bandwidth for a service provider
-QoS is the classification/dropping/scheduling of traffic based on some criteria like the EXP value of MPLS Shim

Where TE ties in with QoS is that
-TE allows the traffic via a tunnel to be treated with some QoS criteria based on the EXP of a packet.
Now you could have a tunnel with different kinds of traffic based on EXP 
or 
you could have different tunnels, each with the same kind of EXP traffic

Pls. see draft-ietf-mpls-diff-ext-09.txt 
Thanks

-Yousuf