Subject: Questions / Comments on MPLS-TE MIB

From: "Choudhury, Sanjaya" <[email-masked]>
Date: Mon, 24 Sep 2001 12:10:58 -0400

Hi! Here are few questions/comments related to MPLS-TE MIB.
	Your help will be appreciated.
	
	Thanks,
	sanjay

	1. mplsTunnelInstancePriority, is significant only in the context
	of a Tunnel (group of tunnel instances). 

	Therefore, according to the MPLS-TE model,load sharing and 
	failover(primay-backup) mechanisms are valid ONLY within a 
	Tunnel and not across Tunnels.

	Is this the correct interpretation of the MIB ?

	2. Currently, the MPLS-TE MIB does not allow the user to 
	specify the traffic class (ex. DiffServ class) associated with 
	the Tunnel Instances.

	Although, one can define new MIBs to add the above mentioned
	feature, in my opinion, extending the existing (pre-RFC) MPLS-TE
	BIB, will significantly enhance the usability of the MIB. 
	
	Can/Should this be done?

	3. If you add the traffic class support to the mplsTunnelTable, 
	should this trafficClass be an (additional) index to the tunnel
table ?
	
	i.e. Should all the instances of a traffic tunnel have the same 
	traffic class ?

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 24 Sep 2001 13:21:46 -0400

>         Is this the correct interpretation of the MIB ?

         Yes, the tunnelInstancePriority is significant only
within the tunnel instances using the same first index of
the tunnelEntry.

>         BIB, will significantly enhance the usability of the MIB.

         This has already been done. The DiffServ Packet
Classifier MIB can be used to handle the DiffServ
marking/matching operation. Once this operation is
done, a packet is ultimately dropped or forwarded. If
it is forwarded, it should arrive at the MPLS FTN MIB.
The MPLS-FTN-MIB allows one to associate incoming traffic
with a tunnel interface.

>         i.e. Should all the instances of a traffic tunnel have the same

         I think that is implementation dependent. However, I would
think that which ever LSP (instance) of that tunnel is used to carry
that traffic should probably be specified in such a way as to satisfy
the needs of the traffic, but I am not sure that is a hard
requirement.

         --Tom

---

From: "Choudhury, Sanjaya" <[email-masked]>
Date: Mon, 24 Sep 2001 13:52:43 -0400

one follow-up question inline ...

-----Original Message-----
From: Thomas Nadeau [mailto:[email-masked]]
Sent: Monday, September 24, 2001 1:22 PM
To: Choudhury, Sanjaya
Cc: [email-masked]
Subject: Re: Questions / Comments on MPLS-TE MIB

	
	I am assuming that by 'DiffServ Packet Classifier MIB'
	you referring to the DiffServ MIB defined by the DiffServ
	working group.

	Besides mapping the traffic to the tunnels (/tunnel
	instances), one need the know the traffic class associated
	with traffic tunnels for the following purposes:
		1) To signal the PSC associated with the 
		   tunnelInstance (L-LSPs)

		2) To do a sensible interpretation of 
		tunnelInstancePriority for load sharing 
		and failover (primary - backup) mechanism.
		[Example: 
			Two tunnel instances, one EF and
			another AF, having same tunnelInstance
			Priority, supported ???
		] 

	How can these be handled by the DiffServ MIB ? 

	Thanks,
	sanjay

         --Tom