Subject: MPLS Unicast/Multicast

From: Shahram Davari <[email-masked]>
Date: Wed, 19 Sep 2001 12:54:32 -0700

Hi,

Can a multicast MPLS packet use the Unicast Protocol ID or it MUST use Multicast protocol ID? 

Yours,
Shahram

---

From: "Naidu, Venkata" <[email-masked]>
Date: Wed, 19 Sep 2001 16:25:48 -0400

-> Can a multicast MPLS packet use the Unicast Protocol ID or 
-> it MUST use Multicast protocol ID? 

   Shahram, distribution of unicast/multicast must be made
   at lower layers. So a multicast MPLS packet (i.e.,
   which has MPLS label from multicast label space) must
   use multicast protocol ID.

--Venkata Naidu

---

From: Shahram Davari <[email-masked]>
Date: Wed, 19 Sep 2001 14:02:53 -0700

Hi Venkata,

What if there is only one label space?

Yours,
-Shahram

> -----Original Message-----
> From: Naidu, Venkata [mailto:[email-masked]]
> Sent: Wednesday, September 19, 2001 4:26 PM
> To: Shahram Davari; [email-masked]'
> Subject: RE: MPLS Unicast/Multicast
> 
>

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 19 Sep 2001 14:28:22 -0700

Sharam,

If you care about interoperability, you must.  The distinction
between unicast and multicast labels is important because the 
label allocation process is different for each.

See the following message from the MPLS archives:
http://cell.onecall.net/mhonarc/mpls/2000-Nov/msg00224.html
for more information about this.

-Anoop

> From: Shahram Davari [mailto:[email-masked]]
> Sent: Wednesday, September 19, 2001 12:55 PM
> To: [email-masked]'
> Subject: MPLS Unicast/Multicast
> 
> 
> Hi,
>

---

From: "Naidu, Venkata" <[email-masked]>
Date: Wed, 19 Sep 2001 18:20:56 -0400

Shahram,

   I haven't seen any draft (even Multicast Framework 
   draft-ietf-mpls-multicast-05.txt) which has restriction 
   to use same label space for Unicast/Multicast.

   But, label spaces are scarce and as the procedures for 
   distributing labels for unicast/multicast differ, it is
   recommended to use different label spaces.

   Even if you consider theoretical possibility of same
   label space, the "label" still signifies multiple 
   destinations (i.e., should be duplicated to multiple ports), 
   so you still need to use multicast protocol ID.

   Things will get complicated in "mixed L2/L3 forwarding"
   and platform/interface label space combined with 
   multicast label spaces!

--Venkata Naidu

-> What if there is only one label space?
->
-> > -> Can a multicast MPLS packet use the Unicast Protocol ID or 
-> > -> it MUST use Multicast protocol ID? 
-> > 
-> >    Shahram, distribution of unicast/multicast must be made
-> >    at lower layers. So a multicast MPLS packet (i.e.,
-> >    which has MPLS label from multicast label space) must
-> >    use multicast protocol ID.
-> > 
-> > --Venkata Naidu