Subject: MPLS and QoS

From: "krishnakanth.rao" <[email-masked]>
Date: Thu, 27 Sep 2001 06:28:04 -0400

1.How can MPLS be used in providing Quality of Service, i,e. can the label values help in providing Quality of Service to a particular packet

2. Can policies be formulated and deployed in a router(MPLS node) which can look into the packet labels and provide the necessary Quality of Service in the network.

Thanks in advance

Krishnakanth

---

From: Ibrahim Okumus <[email-masked]>
Date: Thu, 27 Sep 2001 09:31:07 -0400 (EDT)

MPLS can support QoS in IP networks by using 3 exp bits as QoS indicator
and used in a diff-serv domain. There are basically 2 different ways to do
this. Either you can use the exp bits to determine the level of QoS ( EF,
AF, etc.) or you can use the whole label and relate that to one of the
PHBs in a diffserv network ( there approaches are E_LSP and L-LSP)

 _______________________________
 Ibrahim Taner OKUMUS           
 Electrical&Computer Eng. Dept. 
 Syracuse University            
 Syracuse New York                       
 _______________________________

---

From: David Charlap <[email-masked]>
Date: Fri, 28 Sep 2001 10:29:21 -0400

Ibrahim Okumus wrote:
> 
> MPLS can support QoS in IP networks by using 3 exp bits as QoS
> indicator and used in a diff-serv domain. There are basically 2
> different ways to do this. Either you can use the exp bits to
> determine the level of QoS ( EF, AF, etc.) or you can use the whole
> label and relate that to one of the PHBs in a diffserv network (
> there approaches are E_LSP and L-LSP)

This is the DiffServ draft.

It is also possible to do QoS with MPLS without DiffServ, by simply
choosing a particular level of QoS for each LSP.  The CR-LDP and RSVP-TE
protocols both allow this.  LDP does not.

-- David