Subject: Re: Several questions

From: "Zhu Heqing" <[email-masked]>
Date: Fri, 7 Sep 2001 14:02:47 +0800

See some comments inlines.
if I am wrong, please correct me. ;-)

----- Original Message ----- 
From: Navid Yazdani <[email-masked]>
To: <[email-masked]>
Sent: Friday, September 07, 2001 1:05 AM
Subject: several questions

> I have a few questions regarding using MPLS with CR-LDP to DYNAMICALLY
> setup LSPs.
> 
> 1) Do I have to use CSPF (a constraint-based shortest path first algorithm)
> rather than just normal OSPF?

if you don't have CSPF, how can satify the needs of the CR-LSP ;-)

> 2) Does that mean that I can't use the concept of areas in OSPF to
> summarize routes?  How would a summary advertise the CR-LDP traffic
> constraints?

So far as I know, the information flooding is limited in one area, But I am not sure.
Can another people throw light on it?

> 3) If I can't use route summaries, is MPLS with dynamically setting up LSP
> not scalable?

Maybe!

> 
> 4) When an Edge LSR wants to setup an LSP using CR-LDP, does it look at the
> traffic requirements, choose a path, and then mark that path as an explicit
> route?  I want to know if the entire path is choosen by the Edge LSR and
> the other LSRs just reserve the requested resources and forward the label
> request message along the explicit route.

At the LER, the next hop should be choosed based on ER-Hop TLV. I don't see where 
say the entire path of the CR-LSP should be decided on the LER. From the latest draft of
CR-LDP, you can decide the next hop at the intermediate node when setup the CR-LSP.

> 5) If the resources have changed for whatever reason at an intermediate LSR
> and there are not enough resources to setup the LSP, is there any mechanism
> for the intermediate LSR to find a new path from that point on that meets
> the constraints and forward the label request message along that path?  Or
> is that LSP setup completely abandoned and the edge LSR must try to setup
> another LSP?

It's decided by the different implementation, I guess. You can refer the implementaion of Cisco, Juniper or other vendors. 
 
> Thanks in advance
> -Navid

Zhu Heqing, Graduate Student
University of Electronic Science and Technology of China.

---

From: "Zhu Heqing" <[email-masked]>
Date: Fri, 7 Sep 2001 14:02:47 +0800

----- Original Message ----- 
From: Navid Yazdani <[email-masked]>
To: <[email-masked]>
Sent: Friday, September 07, 2001 1:05 AM
Subject: several questions

Maybe!