Subject: RE: A question on mpls-te-mib: mplsTunnelHopEntryPathComp

From: Ling Li <[email-masked]>
Date: Tue, 11 Sep 2001 10:58:16 -0400

Hi Tom,

Thanks for your quick response. Your answer helps a lot.
A further question on your comments:

> Hops that are specified as "strict" cannot
> be pruned from the CSPF calculation, while those with "loose"
> can. 
Can you give some details on why/how a "loose" hop can be pruned? 
An example,  if possible, would be appreciated.

A specific question in my mind on how to process a "loose" hop is as
follows:

                    1
            |-------------------|  
      10    |     1	    10  |
(N1)------(N2)------(  N3 )------(N4)
 |                 ^IP1 | 
 |         1            | 
 |----------------------|

For the above topology, N1, N2, N3, and N4 are routerIDs of each node. 
TE metric of each link is shown above the link. A path from N1 to N2 is
requested.
A loose hop, "IP1" that is one of the interface IPAddresses at N3, is
configured 
in the hop table. 

My question is how to handle this loose hop? Specifically, should IP1 be
treated as 
ingress interface (in this case the only loop-free path is N1->N2->N3->N4), 
or egress interface (in this case the shortest path is N1->N3->N2->N4)? 

Thanks again, 

Ling Li 

Axiowave Networks, Inc. 
200 Nickerson Road 
Marlborough, MA 01752 
Email: [email-masked] 
========================

---

From: Thomas Nadeau <[email-masked]>
Date: Tue, 11 Sep 2001 11:45:27 -0400

>Can you give some details on why/how a "loose" hop can be pruned?

         In some implementations, if you specify 'dynamic' as
the type of path option (i.e.: the CSPF will be run), then only
specifying the end-points is allowed. In this case, other
hops (loose or strict) might be ignored depending on how
it is implemented. Also, if you specify a loose hop that causes
a loop in the tunnel's path, it may be pruned by the CSPF as
well (or an error returned).

>configured in the hop table.

         How is this configured? It appears to me that you just
set up 3 entries in the HOP table: N1, N3 and N3(loose).

>treated as ingress interface (in this case the only loop-free path is 
>N1->N2->N3->N4),

         Since your hop table only includes N1, N2 and N3 (loose),
I think that this case would appear to the CSPF as requesting
a path from N1->N3, which is possible so it would be signaled.

         --Tom