Subject: MPLS compressed Protocol ID

From: Shahram Davari <[email-masked]>
Date: Tue, 11 Sep 2001 13:46:43 -0700

Hi,

We know from RFC3032 that the PPP protocol ID (PID) for MPLS Unicast and multicast are 0x0281 and 0x0283 respectively. If PID compression is used, do we use "0x81" and "0x83" respectively?

Yours,
Shahram Davari
Product Research Engineer
Internet Routing Division
PMC-Sierra, Inc. (Ottawa)
Phone: (613) 271-4018
Fax:   (613) 271-3138

---

From: [email-masked]
Date: Wed, 12 Sep 2001 10:52:00 +0200

Hi Shahram,

it seems prolematic because the two PID are both larger than 256.
It would make a clean compression much easier if these PID had been
directly defined as "0x0081" and "0x0083".

regards,

Xiaoning Nie

-----Ursprüngliche Nachricht-----
Von: Shahram Davari [mailto:[email-masked]]
Gesendet am: Dienstag, 11. September 2001 22:47
An: [email-masked]'
Betreff: MPLS compressed Protocol ID

Hi,

Yours,
Shahram Davari

---

From: [email-masked]
Date: Wed, 12 Sep 2001 11:03:23 +0200

Hi Shahram,

regards,

Xiaoning Nie

-----Ursprüngliche Nachricht-----
Von: Shahram Davari [mailto:[email-masked]]
Gesendet am: Dienstag, 11. September 2001 22:47
An: [email-masked]'
Betreff: MPLS compressed Protocol ID

Hi,

Yours,
Shahram Davari

---

From: [email-masked]
Date: Wed, 12 Sep 2001 11:13:55 +0200

Hi Shahram,

regards,

Xiaoning Nie

-----Ursprüngliche Nachricht-----
Von: Shahram Davari [mailto:[email-masked]]
Gesendet am: Dienstag, 11. September 2001 22:47
An: [email-masked]'
Betreff: MPLS compressed Protocol ID

Hi,

Yours,
Shahram Davari

---

From: Shahram Davari <[email-masked]>
Date: Wed, 12 Sep 2001 06:30:45 -0700

Hi,

I got my answer from PPPext WG. It seems that in order to compress the protocol ID, the first two bytes MUST be zero. So we can't compress the MPLS PIDs.

Yours,
-Shahram

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, September 12, 2001 5:14 AM
> To: [email-masked]
> Subject: RE: MPLS compressed Protocol ID
> 
> 
> Hi Shahram,
> 
> We know from RFC3032 that the PPP protocol ID (PID) for MPLS 
> Unicast and multicast are 0x0281 and 0x0283 respectively. If 
> PID compression is used, do we use "0x81" and "0x83" respectively?
> 
> Yours,
> Shahram Davari