Subject: ldp discovery over ATM-LC

From: Kapil Vuthoo <[email-masked]>
Date: Fri, 14 Sep 2001 10:55:03 +0530

hi all,

In LDP discovery section of LDP specification(RFC 3036) , suggests that LSR should periodically  send LDP link hellos on each interface to multicast address.
And for non-directly connected LSRs, targetted hellos should be sent.

ATM being a point to point link, do we have to send hellos on multicast address 
(224.0.0.2), if yes then do we bind a vpi/vci to this address ? 
or targetted hellos be sent on 0/32 bound to an IP address ?

regds,
 \kapil

---

From: Bob Thomas <[email-masked]>
Date: Fri, 14 Sep 2001 06:07:17 -0400

Kapil,

> In LDP discovery section of LDP specification(RFC 3036) , suggests
> that LSR should periodically send LDP link hellos on each interface
> to multicast address.
> ATM being a point to point link, do we have to send hellos on
> multicast address (224.0.0.2), if yes then do we bind a vpi/vci to
> this address ?  or targetted hellos be sent on 0/32 bound to an IP
> address ?

Send hellos to the multicast address on 0/32.

Bob

---

From: Kapil Vuthoo <[email-masked]>
Date: Tue, 18 Sep 2001 14:32:13 +0530

thankx bob, 

but in atm on linux one cannot bind two IPs to one VC. I have resolved 
this problem by sending targetted hellos to directly connected ATM-LC
interfaces also. Will this be an introp problem ?? 
so, what should i do , hack the linux code , will that be a standard way of 
doing it ? 
one more clarification - what is the significance of sending a multicast 
packet over a point to point connection.

regds
\kapil

On Fri, 14 Sep 2001 06:07:17 -0400