Subject: RE: Control and Forwarding functions

From: [email-masked]
Date: Tue, 4 Sep 2001 15:45:47 -0700

Not to add unnecessary fuel to the fire here, but....
 
Loa, I don't understand your response below stipulating that "This makes IP
a connection oriented technology!". The fact of the matter is that IP, in
and of itself, is not connection oriented. Transport protocols like TCP,
however, are connection-oriented, as are, I would argue, signaling protocols
like RSVP. That being said, I disagree with the statement from Brijesh that
"MPLS is mainly a connection oriented technology". Like IP, MPLS, in and of
itself, is not connection oriented. An MPLS node (LSR, LER, whatever)
processes MPLS frames based on label bindings that are of local significance
(I suppose that label distribution between peers may be considered a
'connection' by some, but not by me). Once the MPLS node has established a
set of rules for processing certain frames/cells (i.e. receive label 'a'
push label 'b') then it is no longer concerned with the state of its label
distribution peer, hence, there is no connection. This of course is wholly
different from the signaling protocol which may indeed be
connection-oriented. Consider RSVP. An RSVP Session is not active unless all
RSVP nodes comprising the Path have acknowledged the Path with Resv. The
Path signaled by the ingress node always depends on all other nodes, egress
or otherwise, that comprise the path. This, I would argue, represents a
connection - dependent state. This is the point that you and I would again
disagree, Loa.

The original question put forth by David was "What is the meaning of good
separation between the Control and the Forwarding functions?". The answer to
this is relatively straight forward and, through all of the other noise, I'm
not sure it was clearly indicated. I would argue that the 'good' separation
is a direct result of the fact that the forwarding function in MPLS does not
depend on the control function. In the strictly IP world, however,
forwarding decisions are closely tied to the control functions. Consider the
situation in the strictly IP network where a router is running multiple
control protocols (i.e. OSPF, BGP, RIP, etc.). It has received prefix 'p'
twice via BGP, twice via OSPF, and once via RIP. When it receives a packet
destined to prefix 'p' where does it send it? It cannot merely choose the
first advertisement. It must consider the source of the advertisement, the
control protocol.

Tim

-----Original Message-----
From: Loa Andersson [mailto:[email-masked]]
Sent: Tuesday, September 04, 2001 2:23 PM
To: [email-masked]
Cc: "David Allan"; "Ding Aijun"; "Hongwei"; "David Escobar"; "mpls"
Subject: Re: Control and Forwarding functions

Further, see comments in line.

/Loa
-------------------
> 
> I don't know why some people will not accept that MPLS 
> is mainly a connection oriented technology. 

Basically because we need the dynamics of a connectiion less
technology. There are things in the old style connection 
oriented technologies that we don't want in modern networks.

> The main 
> characteristic of a Connection Oriented service is the 
> long term association required between two end points.

This makes IP a connection oriented technology! 

> The process of how such association is established is 
> not important. It is also not important if the 
> connection doesn't begin or end at some hosts (why we 
> need to use ISDN or X.25 definitions of connections?).

If you say that anything that even remotely could be forced into a
e-2-e signalling scheme is connection oriented technology, well 
then the definition loses all content. It is the e-2-e compatibility
negotioation and the dependency on the continous operation
of the connectivity that constitutes the connection orientation. 
y
> 
> It is quite obvious that there is very clearly 
> established permanent association between two end points 
> of LSPs. 

As a matter of fact an LSP might have any number of upstream
end points,  but these association is not any more pernanent than
an IP route.

So either you have a difference between connection less and conenction
oriented, or you declare everything connection oriented, in which case
I could with equal justification claim that everything is connection
less.

I maintain that there is an important difference, that have impacts on
the
performance of the network. Would be good if we could understand this
difference and use it to the benefit of networking.

> All LSRs also maintain the necessary states 
> about particular paths (similar to circuit switched 
> network). 

So does a router
> 
> From all this, MPLS clearly is the connection oriented 
> layer at layer 2. 

So you clain that the link layer supply network wide connection???

Of course, I have also seen comments 
> that MPLS doesn't fit in ISO model. Oh Really, !.

/Loa

>  
> 
> Cheers,
> 
> --brijesh
> Corona Networks
> > OK, here we go again....
> > 
> > To its nature MPLS is not "connection oriented"! I also depends
quite a
> > bit on the definition of "connection oriented", but if we e.g. let
an
> > ISDN
> > phone call be the model of a connection oriented technology, then
you 
> > immediately see that MPLS misses the most important part of what a

> > connection oriented technology is all about.
> > ISDN is separated into two parts "call control" and "connection
> > handling",
> > together they form the connection orientation.
> > 
> > So the "call control" handle e-2-2 compatibility and ability to
take the 
> > call. This does not exist in MPLS. The call control also OK's the
set
> > up of the call and is once it is established dependent of the
e-2-e 
> > connectivity, if the connectivity is broken the call is released.
> > Nothing
> > of this is present in MPLS.
> > 
> > Sometimes one hear that MPLS is connection oriented because there
is 
> > a mapping from node to node over the network, strictly this is not
true,
> > the only thing that is mapped incoming label to outgoing label and
> > interface.
> > The rest is routing in the standard IP connections way.
> > 
> > As for the arguments that "most of the" LSP setup is connection
> > oriented,
> > usually meaning end-to-end (which really is edge-to-edge, there is
not 
> > much idea to establish a connection edge-to-edge. But even so
> > 
> > LDP DU independent liberal is not connection oriented
> > LDP DU independent conservative is not connection oriented
> > LDP DU ordered liberal is not connection oriented
> > LDP DU ordered conservative is not connection oriented
> > 
> > LDP DoD independent liberal is not connection oriented
> > LDP DoD independent conservative is not connection oriented
> > LDP DoD ordered liberal is not connection oriented
> > LDP DoD ordered conservative could at best emulate part of a
connection
> >         oriented technology (signaling)
> > 
> > RSV-TE mostly strictly follows IP routing and is not connection
oriented
> >        and if there are explicit routes it falls into the same
category
> >        as LDP DoD ordered conservative
> > 
> > We are left with a technology where it is required to have an
> > MPLS-external
> > application that do the call control part of connection
orientation. Why
> > we would like to do that is beyond me, as we loses all the
benefits of
> > the
> > IP and MPLS combination.
> > 
> > /Loa
> > 
> > -- 
> > Loa Andersson
> > Chief Architect,
> > Utfors Research, Architecture and Future Lab (URAX)
> > Utfors AB
> > Råsundavägen 12
> > Box 525, 169 29 Solna
> > Office          +46 8 5270 2000
> > Office direct   +46 8 5270 5038
> > Mobile          +46 70 848 5038
> > Email           [email-masked]
> > WWW             www.utfors.se
> 
Loa Andersson
Chief Architect,
Utfors Research, Architecture and Future Lab (URAX)
Utfors AB
R?ndav?n 12
Box 525, 169 29 Solna
Office          +46 8 5270 2000
Office direct   +46 8 5270 5038
Mobile          +46 70 848 5038
Email           [email-masked]
WWW             www.utfors.se

---

From: "Sukanta Ganguly" <[email-masked]>
Date: Tue, 04 Sep 2001 22:19:53 -0700

Wow. This is a really hot topic, I guess.

I did not understand what Tim was trying to explain with the prefix example and I really did not understand its relationship to the seperation of control and forwading plane.

Any router once it has the lookup table completely populated in the sense that once the packet comes in, it is next hop can be resolved, then it has no reason to understand anything about its control plane. Isn't that correct? Then what dependencies are we talking about in the IP routing world?

SG
*********** REPLY SEPARATOR ***********

On 9/4/2001 at 3:45 PM [email-masked] wrote:
Not to add unnecessary fuel to the fire here, but.... 
  
Loa, I don't understand your response below stipulating that "This makes IP a connection oriented technology!". The fact of the matter is that IP, in and of itself, is not connection oriented. Transport protocols like TCP, however, are connection-oriented, as are, I would argue, signaling protocols like RSVP. That being said, I disagree with the statement from Brijesh that "MPLS is mainly a connection oriented technology". Like IP, MPLS, in and of itself, is not connection oriented. An MPLS node (LSR, LER, whatever) processes MPLS frames based on label bindings that are of local significance (I suppose that label distribution between peers may be considered a 'connection' by some, but not by me). Once the MPLS node has established a set of rules for processing certain frames/cells (i.e. receive label 'a' push label 'b') then it is no longer concerned with the state of its label distribution peer, hence, there is no connection. This of course is wholly different from the signaling protocol which may indeed be connection-oriented. Consider RSVP. An RSVP Session is not active unless all RSVP nodes comprising the Path have acknowledged the Path with Resv. The Path signaled by the ingress node always depends on all other nodes, egress or otherwise, that comprise the path. This, I would argue, represents a connection - dependent state. This is the point that you and I would again disagree, Loa.
The original question put forth by David was "What is the meaning of good separation between the Control and the Forwarding functions?". The answer to this is relatively straight forward and, through all of the other noise, I'm not sure it was clearly indicated. I would argue that the 'good' separation is a direct result of the fact that the forwarding function in MPLS does not depend on the control function. In the strictly IP world, however, forwarding decisions are closely tied to the control functions. Consider the situation in the strictly IP network where a router is running multiple control protocols (i.e. OSPF, BGP, RIP, etc.). It has received prefix 'p' twice via BGP, twice via OSPF, and once via RIP. When it receives a packet destined to prefix 'p' where does it send it? It cannot merely choose the first advertisement. It must consider the source of the advertisement, the control protocol.
Tim 

-----Original Message----- 
From: Loa Andersson [mailto:[email-masked]] 
Sent: Tuesday, September 04, 2001 2:23 PM 
To: [email-masked] 
Cc: "David Allan"; "Ding Aijun"; "Hongwei"; "David Escobar"; "mpls" 
Subject: Re: Control and Forwarding functions 

So does a router 
/Loa 
quite a 
an 
you 
take the 
set 
e-2-e 
is 
true, 
not 
connection 
oriented 
category 
orientation. Why 
benefits of 
Loa Andersson 
Chief Architect,

---

From: "Mareline Sheldon" <[email-masked]>
Date: Wed, 5 Sep 2001 10:52:14 +0530

RE: Control and Forwarding functionsTim is talking of a routing table whereas you are referring to a forwarding table. A routing table can have multiple routes to a destination learnt via different sources (read as routing protocols) and associated with each protocol is a priority/preference/metric. The protocol with the lower metric/higer preference (this is implementation specific) is selected and that route is taken and put forth in the "forwarding" table. 

Now it works as you just explained.
  ----- Original Message ----- 
  From: Sukanta Ganguly 
  To: [email-masked] ; [email-masked] ; [email-masked] 
  Cc: [email-masked] ; [email-masked] ; [email-masked] ; [email-masked] ; [email-masked] 
  Sent: Wednesday, September 05, 2001 10:49 AM
  Subject: RE: Control and Forwarding functions

  SG

    Tim 

    -----Original Message----- 
    From: Loa Andersson [mailto:[email-masked]] 
    Sent: Tuesday, September 04, 2001 2:23 PM 
    To: [email-masked] 
    Cc: "David Allan"; "Ding Aijun"; "Hongwei"; "David Escobar"; "mpls" 
    Subject: Re: Control and Forwarding functions 

    /Loa 
    ------------------- 

    So does a router 

    /Loa 

    quite a 
    an 
    you 

    take the 
    set 
    e-2-e 
    is 
    true, 
    not 
    connection 
    oriented 
    category 
    orientation. Why 
    benefits of 
    Loa Andersson 
    Chief Architect,

---

From: Loa Andersson <[email-masked]>
Date: Wed, 05 Sep 2001 18:50:33 +0200

Tim,

I agree that IP is connection less, I hope that was at least clear!
But if I use the simple definition of a "a mapping end to end in the
nodes", which was what was proposed, then IP is  conenction oriented. 
This mapping business in itself is not in itself sufficient criteria to 
make thing connection oriented.

Also,

I might have to reconsider the statement on RSVP, as you say it is a
requirement that all nodes in the path is alive and kicking, this brings
it really close to the "old" connection oriented technologies, yeah
maybe...
However RSVP still has the dynamics of an connection less technology, so
it is still arguable.

Otherwise I think we agree...

/Loa

> [email-masked] wrote:
> 
> Loa, I don't understand your response below stipulating that "This
> makes IP a connection oriented technology!". The fact of the matter is
> that IP, in and of itself, is not connection oriented. Transport
> protocols like TCP, however, are connection-oriented, as are, I would
> argue, signaling protocols like RSVP. That being said, I disagree with
> the statement from Brijesh that "MPLS is mainly a connection oriented
> technology". Like IP, MPLS, in and of itself, is not connection
> oriented. An MPLS node (LSR, LER, whatever) processes MPLS frames
> based on label bindings that are of local significance (I suppose that
> label distribution between peers may be considered a 'connection' by
> some, but not by me). Once the MPLS node has established a set of
> rules for processing certain frames/cells (i.e. receive label 'a' push
> label 'b') then it is no longer concerned with the state of its label
> distribution peer, hence, there is no connection. This of course is
> wholly different from the signaling protocol which may indeed be
> connection-oriented. Consider RSVP. An RSVP Session is not active
> unless all RSVP nodes comprising the Path have acknowledged the Path
> with Resv. The Path signaled by the ingress node always depends on all
> other nodes, egress or otherwise, that comprise the path. This, I
> would argue, represents a connection - dependent state. This is the
> point that you and I would again disagree, Loa.
> 
> The original question put forth by David was "What is the meaning of
> good separation between the Control and the Forwarding functions?".
> The answer to this is relatively straight forward and, through all of
> the other noise, I'm not sure it was clearly indicated. I would argue
> that the 'good' separation is a direct result of the fact that the
> forwarding function in MPLS does not depend on the control function.
> In the strictly IP world, however, forwarding decisions are closely
> tied to the control functions. Consider the situation in the strictly
> IP network where a router is running multiple control protocols (i.e.
> OSPF, BGP, RIP, etc.). It has received prefix 'p' twice via BGP, twice
> via OSPF, and once via RIP. When it receives a packet destined to
> prefix 'p' where does it send it? It cannot merely choose the first
> advertisement. It must consider the source of the advertisement, the
> control protocol.
> 
> Tim
>