Subject: label assignment

From: "Krishnakanth Rao" <[email-masked]>
Date: Mon, 24 Sep 2001 12:19:08 +0530

I have the following doubts regarding label assignment

1. where are the labels first given to the packets in an MPLS enabled network.
2. who decides on the label values, do the LSR themselves decide the label values
3. is the ingress router same as the LER's(label edge routers)

Thanks in advance

Krishnakanth

---

From: Moiz Moizuddin <[email-masked]>
Date: Mon, 24 Sep 2001 10:08:50 -0700

Krishnakanth
LER router would be first imposing the label. Downstream LSR advertises the 
labels to be used by upstream LSR while sending label packets to them. If 
the router is ingress to an MPLS network then its an LER too. Please also 
see rfc 3031

Thx
Moiz