Subject: RE: Comments on Fast Reroute draft

From: Shahram Davari <[email-masked]>
Date: Fri, 9 Aug 2002 11:16:03 -0700

Ping,

draft-vasseur-mpls-backup-computation-00.txt is also proposing
non-local bypass tunnel computation. Has this draft also been rejected?

-Shahram

> -----Original Message-----
> From: Ping Pan [mailto:[email-masked]]
> Sent: Friday, August 09, 2002 2:12 PM
> To: Shahram Davari
> Cc: [email-masked]'
> Subject: Re: Comments on Fast Reroute draft
> 
> 
> Shahram Davari wrote:
> 
> > Ping,
> > 
> >>The ingress does not need to compute the bypass tunnel. 
> Bypass tunnel 
> >>computation could be a local decision.
> >>
> >>http://www.ietf.org/internet-drafts/draft-ietf-mpls-fastrerout
> >>
> > e-mib-00.txt
> > 
> > 
> > But it may also be a non-local decision.
> > 
> > -Shahram
> > 
> 
> 
> I think MPLS WG had gone through this argument before (there 
> was a draft 
> on this). I recall nobody wanted it. The question was why. 
> Also are we 
> going to design a RSVP fragmentation extension to support large 
> messages? ;-)
> 
> - Ping
> 
> 
> 
>

---

From: Jean Philippe Vasseur <[email-masked]>
Date: Fri, 23 Aug 2002 11:01:26 -0400

Hi Shahram,

At 06:21 23/08/2002 -0700, Shahram Davari wrote:
>Jean,
>I meant central.

right, the bypass LSP paths could be calculated:
- in a distributed manner by the PLRs
         o without bw protection (just easy, as the only constraint is to 
be diversely routed from the protected section),
         o with bandwidth protection (one method being described in 
draft-vasseur-mpls-backup-computation-00.txt)
- by a central PCS (one method being described in 
draft-vasseur-mpls-backup-computation-00.txt)

Thanks for your comments on both drafts.

JP.

> > From: Jean Philippe Vasseur [mailto:[email-masked]]
> > Sent: Thursday, August 22, 2002 6:16 PM
> > To: Shahram Davari
> > Cc: 'Ping Pan'; [email-masked]'
> > Subject: RE: Comments on Fast Reroute draft
> >
> >
> > Hi Sharam,
> >
> > Sorry for the late reply ....
> >
> > At 11:16 09/08/2002 -0700, Shahram Davari wrote:
> > >Ping,
> > >
> > could you clarify what was your original point regarding non
> > local bypass
> > tunnel path computation ?
> > JP.
> >
> > >-Shahram
> > >
> > >
> > >

---

From: Shahram Davari <[email-masked]>
Date: Fri, 23 Aug 2002 08:06:02 -0700

Jean,

My question was basically why not compute the bypass LSPs at the ingress
LSRs?

Yours,
-Shahram

> Sent: Friday, August 23, 2002 11:01 AM
> To: Shahram Davari