Subject: can lsp's be terminated within an atm core ????

From: "Mayank Kumar" <[email-masked]>
Date: Tue, 6 Aug 2002 10:47:51 +0530

hi
following my previous question?? i wanted to know that can lsp's be
originated and terminated within an atm backbone or is the concept itself
totally wrong.

thanks
and  regards
Mayank

---

From: [email-masked]
Date: Tue, 6 Aug 2002 12:04:13 +0530

Hmmmm I guess you saved the best for last! ;o)

If all the assumptions that were clarified and confirmed in David's earlier mail
regarding MPLS enabled ATM routers are accepted by you then the answer to your
question is "yes" else its "no" cos' without those assumptions the ATM nodes are
not in the MPLS cloud at all.

sumit
PS - ofcourse you could still configure a static ATM tunnel to tranparently
carry labeled packets between two MPLS clouds.

"Mayank Kumar" <[email-masked]> on 08/06/2002 10:47:51 AM

Please respond to [email-masked]

To:   "Mpls \(E-mail\)" <[email-masked]>
cc:    (bcc: Sumit Chauhan/HSS)

Subject:  can lsp's be terminated within an atm core ????

hi

thanks
and  regards
Mayank

---

From: "Gray, Eric" <[email-masked]>
Date: Wed, 7 Aug 2002 08:49:05 -0400

Mayank,

	:-)

	It looks as if you are still blurring the distinction 
between ATM Switch and ATM LSR.  You seem to be using the
terms interchangeably in your comment below.  An ATM switch
might be used to provide L2 forwarding between ATM routers
(or LSRs).  In this capacity, that ATM switch is part of a 
link in a routing topology, but otherwise is not relevant 
in discussing behavior of ATM routers and LSRs.

	As I said earlier, an LSR is by definition an MPLS
node that is able to do L3 forwarding.  An ATM LSR is not
an exception.

	So, while you are correct in saying that an ATM switch
that has no IP forwarding capability cannot be a point where
aggregates change, this is not a surprise.  Such an ATM
switch cannot be a router and should not actively participate 
in routing protocol exchanges.  Such an ATM switch would be
transparent to routing and thus could not be a point where
aggregates change.  Since such an ATM switch cannot be a
router, it cannot be an ATM LSR.

	For network resource efficiency reasons, ATM LSRs may
be part of an ATM core.  In fact, it is likely that many ATM 
switches in an ATM core will be ATM LSRs (if MPLS is being 
used at all, that is).  Since each LSR is a router, route
aggregates may change at each LSR.  Hence, each ATM LSR in 
an ATM core may need to terminate and originate LSPs.

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

-----Original Message-----
From: Mayank Kumar [mailto:[email-masked]] 
Sent: Wednesday, August 07, 2002 12:36 AM
To: 'Gray, Eric'
Cc: Mpls (E-mail)
Subject: RE: can lsp's be terminated within an atm core ????

hi eric
thanks for the comments !
ur point regarding the termination of lsp's in the atm core does not seem
valid in a few scenarios.
Lets say the aggregation point for some summary route is x which is an atm
core lsr or an atm swicth supporting mpls.
in that case if an lsp using a summary route terminates at this lsr , then
either this lsr has to perform a second level label lookup to decide the
next lsp tunnnel it should enter or  do a ip lookup and forward traffic
accordingly on the destination field . So this means that the aggregation
point should never be an atm switch as they are not capable for ip
forwarding in the data plane.
What do u say regarding this???
if i am correct then please give another example of lsp's terminating in the
atm core.

thanks
and regards
mayank

-----Original Message-----
From: Gray, Eric [mailto:[email-masked]]
Sent: Tuesday, August 06, 2002 7:17 PM
To: [email-masked]'
Cc: Mpls (E-mail)
Subject: RE: can lsp's be terminated within an atm core ????

Mayank,

	The concept itself is _not_ wrong.

	For example, if management traffic is carried to a
core ATM LSR, the LSP on which it arrives must terminate
at the ATM LSR.  This is one reason for David's comment
to the effect that the term 'edge' may be somewhat fuzzy.

	Also, a core-ward ATM LSR (or any LSR) may be at a
place where the aggregate of IP destinations changes.  In
this case, an LSP carrying IP traffic to which this applies
would terminate at that LSR (ATM or otherwise) and the IP
traffic may be injected into another LSP for forwarding
further toward the destination network.  If you map out a
few likely topologies, you will likely find that this is
going to be the case for a significant amount of IP traffic
on many LSPs at nearly every LSR.  Core-ward ATM switches
will only be an exception if they are not LSRs.  This is
another reason why edges are fuzzy.

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

-----Original Message-----
From: Mayank Kumar [mailto:[email-masked]]
Sent: Tuesday, August 06, 2002 1:18 AM
To: Mpls (E-mail)
Subject: can lsp's be terminated within an atm core ????

hi

thanks
and  regards
Mayank