Subject: RE: Layer 3 Lookup in ATM LSR's

From: "Gray, Eric" <[email-masked]>
Date: Mon, 5 Aug 2002 14:35:53 -0400

Eric O.

	You're interpreting confusion into existence.  :-)

	L3 lookup should mean the ability to make a 
determination on how to forward packets _without_
necessarily implying capability to forward packets 
with any particular capacity.  L3 forwarding, on 
the other hand, might encompass what you refer to,
but not necessarily.  Lookup and forwarding functions 
are distinct, even if clearly not orthogonal.

	The ability to look something up in no way 
implies the ability to do anything in particular 
with the results.

	However, Mayank's question implies that - by 
L3 lookup - Mayank meant the ability to determine how
to forward packets.  Otherwise, the question of how
to determine which downstream to request a label of
would have been unnecessary since the ability to 
determine how to forward packets would be used in
determining how to forward requests.

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

-----Original Message-----
From: Eric Osborne [mailto:[email-masked]] 
Sent: Monday, August 05, 2002 2:19 PM
To: Gray, Eric
Cc: [email-masked]'; Mpls (E-mail)
Subject: Re: Layer 3 Lookup in ATM LSR's

On Mon, Aug 05, 2002 at 01:59:06PM -0400, Gray, Eric wrote:
> Mayank,
> 
> 	The standards say that an ATM LSR does have L3
> lookup capability.  Specifically, RFC 3035 says about
> ATM LSRs: 
> 
> " ... ATM switches run network layer routing algorithms 
>   (such as Open Shortest Path First (OSPF), Intermediate
>   System to Intermediate System (IS-IS), etc.), and their 
>   data forwarding is based on the results of these routing 
>   algorithms.  No ATM-specific routing or addressing is 
>   needed.  ATM switches used in this way are known as 
>   ATM-LSRs (Label Switching Routers)."

To me, that doesn't say L3 lookup capability.  I could certainly see
an ATM LSR implementation that used L3 for two things:
- maintaining IGP adjacencies
- deciding which interfaces to signal on-demand labels

...but none of that implies that an ATM LSR should be prepared to
forward received data packets.

> 
> I am not sure what standards you were referring to.
> 
> If an ATM Switch is to participate in label switching, it
> must be able to unambiguously determine how to forward 
> labeled packets.  It is possible to implement ATM switches
> that participates in label switching without themselves
> participating in routing by ensuring that the determination
> on how to forward labeled packets is made for them.  As an
> example, this might be done by always using strict explicit 
> routing relative to the ATM switch in question and immediate 
> downstream neighbors.  Such ATM switches are not ATM LSRs.

I disagree; I think there's a difference between "L3 lookup" (which to
me implies forwarding) and simply running a local IP stack for things
which originate/terminate on that router.

eric

> 
> Eric W. Gray
> Systems Architect
> Celox Networks, Inc.
> [email-masked]
> 508 305 7214
> 
> 
> -----Original Message-----
> From: Mayank Kumar [mailto:[email-masked]] 
> Sent: Monday, August 05, 2002 1:32 PM
> To: Mpls (E-mail)
> Subject: Layer 3 Lookup in ATM LSR's
> 
> hi
> i have a query which , you all might be able to answer:-
> 
> it is said that atm switches in the core atm networks do not have layer 3
> lookup capability.
> Now the standards say that when atm lsr's do not have a layer 3 lookup
> capability then they operate in Ordered control with down stream on demand
> mode of label distribution.
> 
> lets say that i have the following mpls domain :-
> 
> a--------b---------c-------d
>           |
>           |-------k
> 
> 'b' and 'c' are atm switches with no layer 3 lookup capabilities and are
> operating in Ordered Control with DownStream on Demand Label Distribution
> method.
> Suppose a lsp has to travel the path 'a'----'b'---'c'---'d'
> 
> 'a' requests a mapping for a particular fec from 'b'. 'b' upon receving a
> label request for a particular fec , sees that it has no downstream
mapping
> for that fec. Since 'b' is operating in ordered control , it further sends
a
> label request to c (and not to k) since it cannot allocate a label for the
> requested fec . 'c' would also further send the label request to 'd' and
> then 'd' would reply with a label mapping message.
> 
> I hope that it's correct till this point.
> 
> My question is, how does 'b' know , that in order to send a label request
> for a particular fec, what is the next hop for that fec when it does not
> have a layer 3 capability.
> why would 'b' send a label request to 'c' and not to 'k' ????
> 
> 
> i hope i have made my point  clear
> 
> 
> Please tell me where am i wrong
> 
> thanks and regards
> mayank
> 
> 
>

---

From: Eric Osborne <[email-masked]>
Date: Mon, 5 Aug 2002 14:51:56 -0400

On Mon, Aug 05, 2002 at 02:35:53PM -0400, Gray, Eric wrote:
> with any particular capacity.  

But L3 lookup doesn't have to have anything to do with *forwarding*
packets.  It is entirely possible that a device may have a L3
forwarding table used _only_ for locally originated packets
(incl. RSVP), and no such thing even at the software level at the
receiving side of 0/32. 

However, this is semantics, and moreover, it's semantics I'm not
particularly opinionated about one way or the other, so it's not like
I'm looking to get into a big argument here. :)

> L3 forwarding, on 

An ATM LSR combines 2 control plane protocols (LDP/RSVP +
ISIS/OSPF/etc) to build both a routing topology (via IGP) and a
forwarding path (via LDP/RSVP).  Having either one is not good enough,
and I think that an ATM LSR is under no obligation to have to
forward *anything* as an IP packet, except control traffic.  And the
only control traffic I can think of that works like this is RSVP.

eric