Subject: Question on MPLS-TE and MPLS-LSR MIB

From: "Sathappan, Senthilkumar" <[email-masked]>
Date: Tue, 6 Aug 2002 11:46:21 -0400

If a Tunnel Instance is created in MPLS-TE mib with Owner set to admin and
SignallingProto set to rsvp. 
Please let me know what should be MPLS-LSR mib's XCOwner
Thanks,
Senthil.

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 6 Aug 2002 14:54:17 -0400

Slight feeling that this may be a trick question!

> Please let me know what should be MPLS-LSR mib's XCOwner

Answer: rsvp or unknown depending on your implementation.

mplsXCOwner OBJECT-TYPE
   SYNTAX    MplsInitialCreationSource
   MAX-ACCESS    read-create
   STATUS        current
   DESCRIPTION
       "Denotes the entity that created and is responsible
        for managing this cross-connect. This object cannot
        be modified if mplsXCRowStatus is active(1)."
   ::= { mplsXCEntry 5 }

MplsInitialCreationSource ::= TEXTUAL-CONVENTION
   STATUS      current
   DESCRIPTION
        "The entity that originally created the object in
          question. The values of this enumeration are
          defined as follows:

         other(1) - This is used when an entity which has not
          been enumerated in this textual convention but
          which is known by the agent.

         snmp(2) - The Simple Network Management Protocol was
          used to configure this object initially.

         ldp(3 - The Label Distribution Protocol was used to
          configure this object initially.

         rsvp(4) - The Resource Reservation Protocol was used
          to configure this object initially.

         crldp(5) - The Constraint-Based Label Distribution
          Protocol was used to configure this object
          initially.

         policyAgent(6) - A policy agent (perhaps in
          combination with one of the above protocols) was
          used to configure this object initially.

         unknown(7) - the agent cannot discern which
          component created the object."
   SYNTAX  INTEGER {
             other(1),
             snmp(2),
             ldp(3),
             rsvp(4),
             crldp(5),
             policyAgent(6),
             unknown (7)
         }

Adrian

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 06 Aug 2002 15:27:50 -0400

I agree with Adrian's assertion that the value
should be set to 'rsvp' or 'unknown'. The entity that
created the tunnel head actually did not create its
underlying LSP, which is what is represented in
the MPSL-LSR MIB's XCEntry.

         --Tom

>           component created the object."

------------------------------------------------------------------------
Mathematics is the supreme nostalgia of our time.