Subject: RE: Comments on Fast Reroute draft

From: Shahram Davari <[email-masked]>
Date: Fri, 9 Aug 2002 11:03:54 -0700

Ping,

> -----Original Message-----
> From: Ping Pan [mailto:[email-masked]]
> Sent: Friday, August 09, 2002 2:00 PM
> To: Shahram Davari
> Cc: [email-masked]'
> Subject: Re: Comments on Fast Reroute draft
> 
> 
> Shahram Davari wrote:
> 
> >>What's been described in SAO is a user's desire. The routers 
> >>may not be 
> >>able to support it. For example, when a user asks for 
> >>local-protection-desired and node-protection-desried, if a 
> backup LSP 
> >>cannot be established to skip the node, well, tough! ;-) 
> Depending on 
> >>the implementation, link protection may be used only instead.
> >>
> > 
> > 
> > Sure, but what I meant was, which one is desired by the user.
> > Therefore I think it needs to be clarified.
> > 
> 
> 
> OK.
> 
> 
> >>Path_Error messages are reference messages to the ingress. In other 
> >>words, they are not that important. So a router can take 
> its time to 
> >>send the error messages. BTW, when a link/node goes down, it 
> >>is possible 
> >>that a router shoots out multiple error messages. One is to 
> >>inform the 
> >>ingress that the link/node is found to be dead. After the 
> >>local repair, 
> >>the node will tell the ingress "the LSP has been locally repaired".
> >>
> > 
> > 
> > My question was, does the PLR send the Error message 
> periodically or only once?
> > 
> 
> 
> Hmmmm.... I see what you mean. The RSVP RFC didn't say how many error 
> messages to be sent per error condition. In case of node/link 
> failure, 
> if the code was written in such a way to check the link/node 
> status at 
> every Path refresh cycle, an Path error may be generated every time. 
> However, I don't think this is harmful. Of course you can coded it 
> differently.

OK.

> 
> 
> > 
> > 
> >>
> >>>12) Section 9.2 permits having both types of protection 
> >>>
> >>(1-to-1 and facility) for the same PLR. 
> >>
> >>
> >>>In that case how can it inform the ingress LSR that both
> >>>protections are available?
> >>>
> >>>
> >>
> >>RRO tells the ingress that the traffic has been protected. Is 
> >>it enough? 
> >>  If not, there is a MIB draft on fast-reroute. ;-)
> >>
> > 
> > I think it depends on which procedure is used to compute the
> > Bypass tunnels. If the ingress computes the bypass tunnel, then
> > it may need this info. And BTW, what is the relevance of MIB here?
> > 
> 
> 
> The ingress does not need to compute the bypass tunnel. Bypass tunnel 
> computation could be a local decision.
> 
> http://www.ietf.org/internet-drafts/draft-ietf-mpls-fastrerout
e-mib-00.txt

But it may also be a non-local decision.

-Shahram

---

From: Ping Pan <[email-masked]>
Date: Fri, 09 Aug 2002 11:12:18 -0700

> But it may also be a non-local decision.

I think MPLS WG had gone through this argument before (there was a draft 
on this). I recall nobody wanted it. The question was why. Also are we 
going to design a RSVP fragmentation extension to support large 
messages? ;-)

- Ping