Subject: TE MIB - LSR MIB integration

From: [email-masked]
Date: Mon, 25 Nov 2002 12:18:49 +0100

Hello everybody,
I have a doubt about interactions between LSR MIB and TE MIB for what 
concerning LSPs nested in TE tunnels.
Consider the following scenario:

R1 -------- R2 -------- R3

and suppose, for example, I have three incoming flows. I want to insert 
each flow in one LSP and tunnel the three LSPs in one TE tunnel.
My questions are:

1) How are the three LSPs mapped on the same TE tunnel?

2) Is there only one entry in the mplsTunnelTable pointing to one entry 
in the mplsXCTable?

3) Does this entry in the mplsXCTable have a not-null mplsLabelStackTable?

4) How many entries are there in the mplsXCTable? And what LSP/TE tunnel 
do they refer to?

5) Are there four different entries in the mplsXCTable and in the 
mplsOutSegmentTable referring to a TE tunnel interface in the ifTable 
(by mplsOutSegmentIfIndex)?
   If not, how are,  in the LSR MIB, the LSP entries correlated to the 
TE tunnel entry?

Thanks in advance for your help.
Regards Roberto.

---

From: "Yuan Gu" <[email-masked]>
Date: Mon, 25 Nov 2002 12:11:46 -0800

Hello, Roberto:

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Monday, November 25, 2002 3:19 AM
> To: [email-masked]
> Subject: TE MIB - LSR MIB integration
>
>
> Hello everybody,

There will be 3 entries in mplsTunnelTable. Each entry has different
mplsTuunnelInstance.

The mplsTunnelInstance "Uniquely identifies an instance of a tunnel. It is
useful to identify multiple instances of tunnels for the purposes of backup
and parallel tunnels."
You may want to put your LSPID into this field.

> 2) Is there only one entry in the mplsTunnelTable pointing to one entry

There will be 3 corresponding entries in mplsXCTable. Each entry has
different mplsXCLspId (RSVP-TE or CR-LDP).

---

From: [email-masked]
Date: Tue, 26 Nov 2002 09:36:57 +0100

Hi Yuan,
Thanks for your help. See my question at the end please.

>different mplsXCLspId (RSVP-TE or CR-LDP).
Suppose I have three incoming Ethernet TLS flows on R1. Following Martini's draft, I should encapsulate Ethernet frames with a stack of two labels: the bottom label being the VC label, while the top label being the tunnel label. In other words, R1 has to push two labels on every incoming frame where the one at the top is always the same.
I suppose each entry in mplsXCTable should point to a not null mplsLabelStackTable containing the corresponding VC label. If the tunnel label is set up by means of RSVP-TE and the VC label by means of LDP, how does R1 decides that the VC label has to be put in the mplsLabelStackTable and not in a new separate entry in mplsXCTable? What information of the RSVP messages are used to accomplish this?

Regards Roberto

---

From: "Yuan Gu" <[email-masked]>
Date: Tue, 26 Nov 2002 11:52:21 -0800

> Suppose I have three incoming Ethernet TLS flows on R1. Following
> Martini's draft, I should encapsulate Ethernet frames with a
> stack of two labels: the bottom label being the VC label, while
> the top label being the tunnel label. In other words, R1 has to
> push two labels on every incoming frame where the one at the top
> is always the same.
> I suppose each entry in mplsXCTable should point to a not null
> mplsLabelStackTable containing the corresponding VC label. If the
> tunnel label is set up by means of RSVP-TE and the VC label by
> means of LDP, how does R1 decides that the VC label has to be put
> in the mplsLabelStackTable and not in a new separate entry in
> mplsXCTable? What information of the RSVP messages are used to
> accomplish this?
>
> Regards Roberto
>

I don't think the LSR MIB take L2VPN into account at all. You may want to
implement your propertory MIB for supporting L2VPN.

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 26 Nov 2002 15:36:21 -0500

>implement your propertory MIB for supporting L2VPN.

         The LSR MIB shows the LFIB and MPLS-enabled
interfaces of an LSR.  If you can represent labels (or label stacks)
in an LFIB, you can see it there.  If you want to attach application-
specific things to entries in the TFIB, you need application-specific
MIBs such as the PWE-MPLS MIB that joins pwe3 vcs of
any service type to MPLS LSPs (or TE tunnels).

         --Tom