Subject: Vpns vs explicit null label

From: "Sandeep B" <[email-masked]>
Date: Sat, 01 Feb 2003 02:04:11 +0000

What should be the behaviour in following case -

node1---- node2-----node3

all links are ethernet.

VPN is setup between node1 and node3 (BGP or LDP). RSVP-TE is used to setup 
transport LSP between 2 sites. node3 gives either '0' or '3' as transport 
label to node2 and label 100 as VPN label to node1.

Node2 gets a packet with 2 label stack from node1. removes the first label 
and forwards it to node3. how would node2 figure out what sort of ethertype 
marking it is suppose to mark on ethernet frame. cuz now it is suppose to be 
MPLS instead of IP.

_________________________________________________________________
Add photos to your messages with MSN 8. Get 2 months FREE*.  
http://join.msn.com/?page=features/featuredemail

---

From: Anoop Ghanwani <[email-masked]>
Date: Mon, 3 Feb 2003 07:40:00 -0800

If the bottom of stack bit of the the label that it
popped is 1, node 2 would use the Ethertype for IP.  
Since the bottom of stack bit would be 0 in this case, 
it will continue to use the Ethertype for MPLS.

-----Original Message-----
From: Sandeep B
To: [email-masked]
Sent: 1/31/03 6:04 PM
Subject: Vpns vs explicit null label

all links are ethernet.

VPN is setup between node1 and node3 (BGP or LDP). RSVP-TE is used to
setup 
transport LSP between 2 sites. node3 gives either '0' or '3' as
transport 
label to node2 and label 100 as VPN label to node1.

Node2 gets a packet with 2 label stack from node1. removes the first
label 
and forwards it to node3. how would node2 figure out what sort of
ethertype 
marking it is suppose to mark on ethernet frame. cuz now it is suppose
to be 
MPLS instead of IP.