Subject: RE: I-D ACTION:draft-andersson-mpls-g-chng-proc-00.txt

From: "Brungard, Deborah A, ALABS" <[email-masked]>
Date: Thu, 27 Feb 2003 11:14:28 -0500

Maybe lets go back to my hopefully simple question, will the liaison process be included in this draft or not? I (thought) the answer was no. Maybe best to clarify. And not that it is not important, all the mail agrees it is important. Then we can work from this draft with comments, recognizing the liaison process will be separate, e.g. where the draft discusses other sdos, we can add text to clarify.

One comment on all of this from an ITU/T1X1 history, it is difficult to say apriori how a liaison will be processed. We do not have such a process either. Several ways exist to respond:
1. simple thank you for the information
2. here's the answer/clarification based on current work
3. for a quick answer, at the meeting, have a breakout group to address a proposal
4. for new work, send a response saying we invite contributions to our future meetings to progress
   - if no contributions, not anything is done (yes we have done this too)
   - at the next meeting, send several proposals to the other group for their review

I had understood this draft as including option 4. Other mails are raising the concern, as in the past, if no response to the other sdo, the other sdo can not determine the status of the work. That can be part of the liaison process.

Let's first clarify, do we want this draft to include the liaison process or should we do it separate (in parallel?)?

Deborah

-----Original Message-----
From: Wijnen, Bert (Bert) [mailto:[email-masked]]
Sent: Thursday, February 27, 2003 10:47 AM
To: Kireeti Kompella; Wijnen, Bert (Bert)
Cc: Scott W Brim; [email-masked]; [email-masked]
Subject: RE: I-D ACTION:draft-andersson-mpls-g-chng-proc-00.txt

Inline

> -----Original Message-----
> From: Kireeti Kompella [mailto:[email-masked]]
> Sent: donderdag 27 februari 2003 10:09
> To: Wijnen, Bert (Bert)
> Cc: Scott W Brim; [email-masked]; [email-masked]
> Subject: RE: I-D ACTION:draft-andersson-mpls-g-chng-proc-00.txt
> 
> 
> Hi Bert,
> 
> On Thu, 27 Feb 2003, Wijnen, Bert (Bert) wrote:
> 
> > No of course NOT. Many Liasons will want an answer.
> > So we need a process to follow up and to track if a timely
> > response has been (or will be) send.
> 
> Is the IETF process for replying to liaison statements (and of
> generating them) written down, say in some RFC?  If so, could you
> send me a pointer?
> 
Unfortunately, I don't think the process for that has been defined.
That is why I said that "we need a process..."
We do not have it yet (I think... at least I do not know it either).
I think we were all just hoping people would take responsibility and
do the right things... but as we know that is how things fall through
the cracks.

> > But the Liasons communication between ITU and CCAMP/MPLS has not
> > been going smoothly so far (even though we had good intentions).
> > Responses have not gone out in time (or in some cases at all).
> 
> I'll take full responsibility for that.
> 
W.r.t. CCAMP I will share some of the responsibility too. I should 
also have kept a better eye on it.

Bert
> Thanks,
> Kireeti.

---

From: Loa Andersson <[email-masked]>
Date: Thu, 27 Feb 2003 17:58:40 +0100

Deborah,

I suggested earlier that we describe (short) in the draft how we will 
handle liasions
comeing into the IETF with request for changes or requirments related to 
the (g)mpls
protocols. It needs to be understood that the internal IETF process is 
specified for
IDs, and in some way we need bridge that gap. IETF and its working 
groups modifies IDs,
and I don't think it is good idea to start modifying liasions from other 
SDOs.

That we define the liasion process so it becoes crips and clear, and if 
when we are doing
find that it has an impact on the change process, we updte or 
re-organize the the
documents at that time.

Would that work? I guess that the answer is - yes, but only as much 
(little) as needed.

/Loa

---

From: Scott W Brim <[email-masked]>
Date: Thu, 27 Feb 2003 12:25:16 -0500

Loa,

On Thu, Feb 27, 2003 05:58:40PM +0100, Loa Andersson allegedly wrote:
> It needs to be understood that the internal IETF process is specified
> for IDs, and in some way we need bridge that gap. IETF and its working
> groups modifies IDs, and I don't think it is good idea to start
> modifying liasions from other SDOs.

But

> >One comment on all of this from an ITU/T1X1 history, it is difficult
> >to say apriori how a liaison will be processed. We do not have such a
> >process either. Several ways exist to respond:

There is no incompatibility.  Among a rich set of possible responses,
bullet 4 covers what you were looking for above.