Subject: AW: draft-kawakami-mpls-lsp-vlan-00.txt

From: Heiles Juergen <[email-masked]>
Date: Fri, 28 Feb 2003 12:16:46 +0100

Genadi,

the draft proposes to use the MPLS control plane protocols for a different transport plane (Ethernet VLAN).
This is excatly what GMPLS is about. So I think it would be better to have the ID and dicussion in ccamp under the GMPLS work.

Regards

Juergen

> -----Ursprüngliche Nachricht-----
> Von: Genadi Velev [mailto:[email-masked]]
> Gesendet: Donnerstag, 27. Februar 2003 17:53
> An: [email-masked]
> Cc: [email-masked]
> Betreff: draft-kawakami-mpls-lsp-vlan-00.txt
> 
> 
> [ Mail was delivered through VPN PEL->MEI/AVCDC! ]
> [ Mail was delivered through VPN PEL->MEI/AVCDC! ]
> [ Mail was delivered through VPN PEL->MEI/AVCDC! ]
> [ Mail was delivered through VPN PEL->MEI/AVCDC! ]
> 
> Hi all,
> 
> A new draft was published today (please see below).
> 
> Any feedback and comments are welcome, especially from those 
> of you who are
> dealing with packet transport over wide area Ethernet networks.
> 
> thanks,
> Genadi
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On Behalf Of
> > [email-masked]
> > Sent: Thursday, February 27, 2003 1:44 PM
> > To: IETF-Announce:
> > Cc: [email-masked]
> > Subject: I-D ACTION:draft-kawakami-mpls-lsp-vlan-00.txt
> >
> >
> > A New Internet-Draft is available from the on-line
> > Internet-Drafts directories.
> >
> >
> > 	Title		: Method to Setup LSP using VLAN Tag Switching
> > 	Author(s)	: T. Kawakami et al.
> > 	Filename	: draft-kawakami-mpls-lsp-vlan-00.txt
> > 	Pages		: 15
> > 	Date		: 2003-2-26
> >
> > This document describes a method to setup a Layer 2 tunnel over
> > networks based on Ethernet technology. For this purpose, 
> the ports of
> > an Ethernet switch are configured to forward VLAN 
> tag-labeled packets
> > incoming from a certain port to another unambiguous port by using
> > VLAN tag information. The Ethernet switches themselves are a part of
> > the Label Switching Routers (LSRs), which distribute the VLAN tags
> > using Label Distribution Protocol (LDP). To enable LDP to 
> fulfil this
> > function, an LDP extension is proposed. The introduced method
> > simplifies the transport of Ethernet frames over wide area Ethernet
> > networks.
> >
> > A URL for this Internet-Draft is:
> > 
http://www.ietf.org/internet-drafts/draft-kawakami-mpls-lsp-vlan-00.txt
>
> To remove yourself from the IETF Announcement list, send a message to
> ietf-announce-request with the word unsubscribe in the body of
> the message.
>
> Internet-Drafts are also available by anonymous FTP. Login with
> the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-kawakami-mpls-lsp-vlan-00.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-kawakami-mpls-lsp-vlan-00.txt".
>
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
>
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

---

From: Genadi Velev <[email-masked]>
Date: Fri, 28 Feb 2003 14:25:04 +0100

Hi Juergen,

thanks for the feedback! This was (and seems to be still) a hot topic. The
decision where to present the draft has been already a subject of
discussions with the chairmen of MPLS, PWE3 and PPVPN WGs. The reason to let
this draft for submission in the MPLS WG was that the basic intention is to
propose a new LDP extension ("VLAN label TLV") and MPLS WG is in charge of
the LDP protocol.

It's true that the transport plane in our proposal is based on VLAN-aware
Ethernet switches. Compared to the GMPLS classification of interfaces
(RFC3471), VLAN tag switching belongs (I'd say so) to the Packet-Switch
Capable (PSC) interfaces, and thus, extensions regarding these interfaces
should be a subject of the MPLS WG.

This is my personal opinion. However, since I'm not a long-experienced
person in the IETF's MPLS related work, I'd like to hear also another
opinions on this issue.

regards,
Genadi

> From: [email-masked] [mailto:[email-masked]]On Behalf Of Heiles
> Juergen
> Sent: Friday, February 28, 2003 12:17 PM
> To: [email-masked]'; [email-masked]; [email-masked]
> Subject: AW: draft-kawakami-mpls-lsp-vlan-00.txt
>
>
> Genadi,
>
> the draft proposes to use the MPLS control plane protocols for a
> different transport plane (Ethernet VLAN).
> This is excatly what GMPLS is about. So I think it would be
> better to have the ID and dicussion in ccamp under the GMPLS work.
>
> Regards
>
> Juergen
>
>

---

From: [email-masked]
Date: Fri, 28 Feb 2003 21:18:25 +0100

hi,

per gmpls, Layer-2 Switch Capable (L2SC) interfaces are
defined:

   Interfaces that recognize frame/cell boundaries and can forward data
   based on the content of the frame/cell header. Examples include
   interfaces on Ethernet bridges that forward data based on the
   content of the MAC header and interfaces on ATM-LSRs that forward
   data based on the ATM VPI/VCI.

i agree with juergen, this i-d should be discussed at
the ccamp working group

thanks,
- dimitri.

-- 
Papadimitriou Dimitri 
E-mail : [email-masked] 
Private: http://www.rc.bel.alcatel.be/~papadimd/index.html
E-mail : [email-masked]
Public : http://psg.com/~dpapadimitriou/
Address: Fr. Wellesplein 1, B-2018 Antwerpen, Belgium
Phone  : +32 3 240-8491