Subject: RE: Distributing Labels for PWs within an LSP TE Tunnel

From: Nurit Sprecher <[email-masked]>
Date: Mon, 24 Mar 2003 10:25:30 +0200

Thanks for your responses.
I do look for a way to bind the (LDP) signaled PWs to the (RSVP-TE) signaled
transport tunnel LSP, in a way that both PEs know about it. 
As I understand from your response, I should signal that the PWs within the
TE tunnel LSP.
Is there a way to signal 'TE' PWs?

-----Original Message-----
From: Shahram Davari [mailto:[email-masked]]
Sent: Friday, March 21, 2003 7:06 PM
To: 'Alia Atlas'; Nurit Sprecher
Cc: [email-masked]; Mustapha Aissaoui (E-mail)
Subject: RE: Distributing Labels for PWs within an LSP TE Tunnel 

Alia,

I think Nurit's question was how can we bind a PW to a transport LSP, in a
way that both PE's know about it? This would be useful if LDP uses
per-interface label space.

An extension to PW signaling may be needed. Or a DoD label request that is
pushed inside
the tunnel LSP could be used.

-Shahram

>-----Original Message-----
>From: Alia Atlas [mailto:[email-masked]]
>Sent: Thursday, March 20, 2003 2:08 PM
>To: Nurit Sprecher
>Cc: [email-masked]
>Subject: Re: Distributing Labels for PWs within an LSP TE Tunnel
>
>
>At 11:42 AM 3/20/2003 +0200, Nurit Sprecher wrote:
>
>>Hi all,
>>
>>I am looking for a method for distributing PWs' labels of PWs
>within a TE
>>LSP tunnel.
>>The TE tunnel is signaled using the RSVP-TE signaling
>protocol. Is there a
>>method for distributing labels for PWs that should run within
>TE LSP tunnel?
>>I am aware of the IETF draft for signaling the PWs' labels
>using the LDP
>>protocol, but I would like to attach a certain PW with a
>certain TE LSP
>>tunnel. How can I gain it? Maybe I should activate the LDP
>for a certain PW
>>within the required tunnel (inband)? Is there another way to
>do it but not a
>>static one (by configuration)?
>
>Hi,
>
>You can use a targeted LDP session to distribute the labels for a PW
>between the two PEs.  How that PW travels across the PSN is
>independent of
>how the labels for the PW were distributed.  Thus, the PW
>could use either
>an LDP LSP or a RSVP-TE LSP to reach the egress PE.  Which one
>to use and
>how the PW is mapped to it is an internal issue on the ingress PE.
>
>Alia
>
>
>>I wonder also if there is a way to signal a TE PW?
>>
>>I'll appreciate your response.
>>Thanks in advance, Nurit.
>
>

---

From: Eric Rosen <[email-masked]>
Date: Tue, 25 Mar 2003 10:04:08 -0500

Nurit> I do look for  a way to bind the (LDP) signaled  PWs to the (RSVP-TE)
Nurit> signaled transport tunnel LSP, in a way that both PEs know about it. 

There is no way to do this using the protocols as currently defined.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 25 Mar 2003 20:48:54 -0500

>There is no way to do this using the protocols as currently defined.

I agree with Eric, and it's the way it is for a very good reason - as a 
result of requiring PW labels in the platform label space, deciding which 
RSVP-TE tunnel to use for the LDP-signaled PWs is purely a local matter at 
the PE that's encapsulating the L2 frames.  This allows a number of nice 
properties, such as the ability to very easily switch to a backup tunnel if 
there's a primary tunnel failure and the network isn't using FRR in the 
core, or to load-share over multiple tunnels if the PW doesn't have 
sequentiality requirements (or has partial sequentiality 
requirements).  Using end-to-end signaling to bind a PW to a particular 
tunnel removes these properties.

Cheers,
Andy

---

From: "Vach Kompella" <[email-masked]>
Date: Tue, 25 Mar 2003 18:52:37 -0800

One of the problems with the new version of the pwe3-control draft is that the
line that says that the platform label space must be used has been dropped from
the text.  I assume that this was unintentional because it doesn't make sense to
use interface-specific labels.  However, it became apparent at the ISOCORE
interop that one vendor didn't realize this.

Could it please be re-inserted, right after where it says liberal label
retention should be used?

  "VC labels MUST be allocated from the per-platform label space."

Thanks.

-Vach

> From: [email-masked] [mailto:[email-masked]]On Behalf Of Andrew G.
> Malis
> Sent: Tuesday, March 25, 2003 5:49 PM
> To: [email-masked]
> Cc: [email-masked]

---

From: "Rajiv Papneja" <[email-masked]>
Date: Wed, 26 Mar 2003 09:52:20 -0500

Section 3 in draft-ietf-pwe3-control-protocol-01.txt.

Due to this ambiguity, we were never able to bring up the VC tunnels because
one of the vendor followed pwe3-control draft and other followed
draft-martini-l2circuit-trans-mpls-10.txt.

Thanks Vach for pointing out this issue.

 -Rajiv

---

From: "himanshu shah" <[email-masked]>
Date: Thu, 27 Mar 2003 21:40:32 -0500

Not sure If I have the whole question (because I don't have
the original email).

However, guessing on the question below, I would say that
one can use LDP signaled PW as control plane and use
RSVP-TE signaled tunnel for data plane.

It is a local matter though. As long as both PEs have
established RSVP-TE tunnel based on (LDP) Peer's IP address,
each PE can map the PW on the RSVP-TE tunnel whose endpoint
is remote PE peer (tunnel must be PHP though).
There is no need to notify the other what type of tunnel
he should use, either.

Note that I am not advocating running LDP within RSVP-TE
tunnel. And in this respect, control plane and data plane
could very well be disjoint.

You may want to look at draft-shah-pwe3-control-protocol-extension-00.txt
where I have defined QOS TLV where each PE can optionally
signal what tunnel type other should use.

/himanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Eric
Rosen
Sent: Tuesday, March 25, 2003 10:04 AM
To: Nurit Sprecher
Cc: 'Shahram Davari'; 'Alia Atlas'; [email-masked]; Mustapha Aissaoui
(E-mail)
Subject: Re: Distributing Labels for PWs within an LSP TE Tunnel