Subject: Re: Question for the RFC2961--Refresh reduction--trigger msg

From: "Hong Liao" <[email-masked]>
Date: Tue, 11 Mar 2003 09:54:31 -0500

>>If the message ID is greater, or if the epoch is different, then you
have to compare the rest of the message's content against your saved
state to determine if the message is a trigger or not.

So If the message ID is greater, or if the epoch is different, ,and the
LSPID is different from the previous one, then the msg is trigger msg,
right/

Thanks,
Julia

                    David Charlap                                                                               
                    <David.Charlap@ma        To:     IETF MPLS List <[email-masked]>                               
                    rconi.com>               cc:     (bcc: Hong Liao/Telcordia)                                 
                                             Subject:     Re: Question for the RFC2961--Refresh                 
                    03/10/2003 07:24         reduction--trigger msg                                             
                    PM                                                                                          

Hong Liao wrote:
> So you tried to say that as  far as the msgid is  greater than the
previous
> one with the same epoch, it does not  matter if the other content is the
> same  as the one before, it is considered  to be a trigger msg.
>
> or as far as the epoch value is different,  it does not matter if the
other
> contents in the message are the same  as the  one before, it is
considered
> as  a  trigger msg, right?

No.  Quite the opposite.

If the epoch is the same, and the message ID is lower than the most
recent one received for the LSP, then it the message is out of order and
should be ignored - meaning it is definitely not a trigger.

If the message ID is greater, or if the epoch is different, then you
have to compare the rest of the message's content against your saved
state to determine if the message is a trigger or not.

-- David

---

From: David Charlap <[email-masked]>
Date: Tue, 11 Mar 2003 10:12:40 -0500

> LSPID is different from the previous one, then the msg is trigger msg,

If the message ID is greater, or the epoch is different, then the 
message MIGHT be a trigger.  You still have to look up the LSP and 
compare its state against the rest of the message in order to see if 
anything significant has changed.

If the LSPID is different, then the message applies to some other LSP 
and the entire argument is moot.

-- David