Subject: RE: I-D ACTION:draft-andersson-mpls-g-chng-proc-00.txt

From: Shahram Davari <[email-masked]>
Date: Thu, 6 Mar 2003 07:10:19 -0800

>> 1) Is the decision on how to deal with extension requests, an IESG
>> decision or an IETF consensus is required?
>
>If it is published as an informational recommendation by the IESG,
>then no.  The IESG does have veto power over internet-drafts that are
>on the standards track, therefore it might be worth paying attention
>to their recommendations.

Using their veto power against IETF community's consensus, seems "a complete breakdown of relationship" between IETF community and IESG.

>
>btw- I should also point out that Scott Bradner does not make this
>stuff up without talking to the other members of the IESG.

I know. but IESG != IETF

>
>> 2) No one can stop other SDOs from extending any IETF protocol
>
>True.
>
>> 3) The draft says:
>> 
>>    "No individual, vendor, SDO or forum should be able 
>create what is viewed
>>    to be a major extension to an IETF protocol on its own and
>>    legitimately be able to claim that implementations that 
>implement the
>>    extension are compliant to the IETF specification."
>> 
>> So if the other SDOs don't claim IETF compliance, rather 
>they claim their
>> respective organizations compliance, there should not be any 
>problem. And if 
>> they mess up nobody would blame IETF for that.
>
>This would represent a complete breakdown of relationships.  I'm not
>making any value judgement, just an observation.

Why? are you saying that if an SDO wants to define a brand new protocol (let's say MPLSv2),
but to reuse some parts of an existing IETF protocol, then they shouldn't do it because
IETF will get mad at them?

-Shahram

>
>> -Shahram
>
>Curtis
>
>
>> >-----Original Message-----
>> >From: Curtis Villamizar [mailto:[email-masked]]
>> >Sent: Wednesday, March 05, 2003 5:34 PM
>> >To: Shahram Davari
>> >Cc: [email-masked]'; Alex Zinin; 
>[email-masked]';
>> >[email-masked]; [email-masked]
>> >Subject: Re: I-D ACTION:draft-andersson-mpls-g-chng-proc-00.txt 
>> >
>> >
>> >
>> >In message 
>> ><[email-masked]
>> >>, Shahram Davari writes:
>> >> Is IESG=Curtis?
>> >> 
>> >> -Shahram
>> >
>> >
>> >That looks like a cheap shot of some kind.
>> >
>> >IESG == draft-iesg-vendor-extensions-00.txt
>> >
>> >  3.  Recommendation
>> >
>> >   The following principles are the main guiding principles 
>concerning
>> >   extensions to IETF protocol:
>> >
>> >    o All major extensions to IETF protocols should be done 
>with direct
>> >      involvement of the IETF.
>> >
>> >    o The decision on whether an extension is major or 
>minor should be
>> >      done with the direct involvement of the IETF.
>> >
>> >Those words are from the IESG draft.  They are not my words.
>> >
>> >I thought that was obvious enough in my prior reply, but apparently
>> >not.
>> >
>> >Curtis
>> >
>> >
>> >> >-----Original Message-----
>> >> >From: Curtis Villamizar [mailto:[email-masked]]
>> >> >Sent: Wednesday, March 05, 2003 4:53 PM
>> >> >To: Alex Zinin
>> >> >Cc: Shahram Davari; [email-masked]'; 
>> >[email-masked];
>> >> >[email-masked]
>> >> >Subject: Re: I-D ACTION:draft-andersson-mpls-g-chng-proc-00.txt 
>> >> >
>> >> >
>> >> >
>> >> >In message <[email-masked]>, Alex 
>Zinin writes:
>> >> >> Wednesday, March 5, 2003, 11:12:10 AM, Shahram Davari wrote:
>> >> >> [...]
>> >> >> > It might be a good idea to require that all IETF 
>> >protocols support
>> >> >> > vendor-specific extensions, so that they could be used by 
>> >> >other SDOs
>> >> >> > and for experiments.
>> >> >> 
>> >> >> Ouch... draft-iesg-vendor-extensions-00.txt
>> >> >> 
>> >> >> Alex
>> >> >
>> >> >
>> >> >Looks like the IESG doesn't agree with Shahram on this.
>> >> >
>> >> >Curtis
>> >> >
>> >> 
>> >
>> 
>

---

From: Scott Bradner <[email-masked]>
Date: Thu, 6 Mar 2003 10:48:34 -0500 (EST)

> Using their veto power against IETF community's consensus, seems 
> "a complete breakdown of relationship" between IETF community and IESG.

see the message I posted

Scott