Subject: RE: I-D ACTION:draft-andersson-mpls-g-chng-proc-00.txt

From: John Drake <[email-masked]>
Date: Thu, 6 Mar 2003 09:47:24 -0800

I think the point was that one would not be able to establish an LSP on a
path containing both ASON and GMPLS networks

> -----Original Message-----
> From: Zhi-Wei Lin [mailto:[email-masked]]
> Sent: Wednesday, March 05, 2003 6:43 PM
> To: [email-masked]
> Subject: Re: I-D ACTION:draft-andersson-mpls-g-chng-proc-00.txt
> 
> 
> Hi John, Dimitri,
> 
> I guess this is another misconception? How an operator will 
> use this, the
> operator already knows. This means that if an operator is 
> going to offer
> ASON service then they will be expecting their customers to 
> come in with
> ASON capable requests. However, if operator is also at the same time
> offering GMPLS service, that's fine as well because they will 
> be expecting
> to see a GMPLS request.
> 
> There is nowhere that says that an operator must only support ASON and
> nothing else. What is said is that if an operator is offering 
> ASON service
> and not GMPLS, then the request has to come in with an ASON 
> request. I think
> this makes sense since the operator has chosen only to 
> support that model.
> Alternatively the operator can choose to support both models, 
> or only GMPLS
> models.
> 
> Hope this explains...
> 
> Zhi
> 
> 
> 
> ----- Original Message -----
> From: "John Drake" <[email-masked]>
> To: <[email-masked]>; "Zhi-Wei Lin" 
> <[email-masked]>
> Cc: <[email-masked]>
> Sent: Wednesday, March 05, 2003 5:28 PM
> Subject: RE: I-D ACTION:draft-andersson-mpls-g-chng-proc-00.txt
> 
> 
> > Snipped...
> >
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]]
> > > Sent: Wednesday, March 05, 2003 1:39 PM
> > > To: Zhi-Wei Lin
> > > Cc: [email-masked]
> > > Subject: Re: I-D ACTION:draft-andersson-mpls-g-chng-proc-00.txt
> > > 3) you say in this "Note that although the CALL_ID object 
> is optional
> > > for GMPLS
> > >    signaling, this object is mandatory for ASON-compliant 
> networks,
> > >    i.e., the Resv message MUST include the CALL_ID object."
> > >    so if you mandate it's usage at edges, following this 
> an operator
> > >    that doesn't implement these extensions is not capable 
> to setup an
> > >    lsp through an ason network... this is a major problem 
> in case edge
> > >    devices are lsr's that will be for most of them gmpls compliant
> > >
> >
> > JD:  There is the same issue wrt Generalized UNI
>

---

From: Curtis Villamizar <[email-masked]>
Date: Thu, 06 Mar 2003 15:00:37 -0500

> path containing both ASON and GMPLS networks

And you cannot send a packet on a path that contains bot OSI and IP
networks.  Such is the nature of standards.

In a situation like this one of them typically withers and dies.  But
this doesn't happen until after a great deal of arguing and dead end
standards documents from one SDO, typically the one that emphasizes
generating grandeous standards as opposed to carefully considering
real requirements and requiring code and implementations along with
the standards process.

Curtis