Subject: RE: [PWE3] MPLS PID

From: Shahram Davari <[email-masked]>
Date: Wed, 26 Mar 2003 14:42:49 -0800

>A PID is not non-standard and proprietary if it is standardized and
>that is what we are discussing.

That is exactly what I said. You want to standardize a proprietary PID that
uses the first 4 bits. If it is approved by IETF then off course it won't be
proprietary any more.

>
>> Do you think that all hashing key selection algorithms by 
>all vendors should 
>> be supported
>> by all IETF standards? What if one decides to use CRC to 
>distinguish IP packe
>> ts? should IETF
>> standards be backward compatible with that too?
>> 
>> -Shahram
>
>RFC2991 is fine as is.  Load balancing algorithms exist.  There is no
>need to standardize them.  Some are based on hashing.
>

You didn't answer my question. I asked what if a vendor wants to use CRC as IP PID. 
Should IETF protocols support them too by requiring that all other protocols that
get transported over MPLS not to produce a valid CRC?

BTW I never said we need to standardize load balancing algorithms. Where did you get
that from?

-Shahram

-Shahram

---

From: Curtis Villamizar <[email-masked]>
Date: Wed, 26 Mar 2003 18:24:20 -0500

In message <[email-masked].
> BTW I never said we need to standardize load balancing algorithms. Where did 

I don't feel obligated to answer nonsense questions.  No one has
proposed putting a CRC in the PID.

Curtis

ps - "requiring [..] not to produce a valid CRC" doesn't even parse in
english so your question is complete nonsense.