Subject: RE: I-D ACTION:draft-andersson-mpls-g-chng-proc-00.txt

From: Shahram Davari <[email-masked]>
Date: Wed, 5 Mar 2003 14:45:05 -0800

Thanks for your clarification. A couple of points:

1) Is the decision on how to deal with extension requests, an IESG
decision or an IETF consensus is required?

2) No one can stop other SDOs from extending any IETF protocol

3) The draft says:

   "No individual, vendor, SDO or forum should be able create what is viewed
   to be a major extension to an IETF protocol on its own and
   legitimately be able to claim that implementations that implement the
   extension are compliant to the IETF specification."

So if the other SDOs don't claim IETF compliance, rather they claim their
respective organizations compliance, there should not be any problem. And if 
they mess up nobody would blame IETF for that.

-Shahram

>-----Original Message-----
>From: Curtis Villamizar [mailto:[email-masked]]
>Sent: Wednesday, March 05, 2003 5:34 PM
>To: Shahram Davari
>Cc: [email-masked]'; Alex Zinin; [email-masked]';
>[email-masked]; [email-masked]
>Subject: Re: I-D ACTION:draft-andersson-mpls-g-chng-proc-00.txt 
>
>
>
>In message 
><[email-masked]
>>, Shahram Davari writes:
>> Is IESG=Curtis?
>> 
>> -Shahram
>
>
>That looks like a cheap shot of some kind.
>
>IESG == draft-iesg-vendor-extensions-00.txt
>
>  3.  Recommendation
>
>   The following principles are the main guiding principles concerning
>   extensions to IETF protocol:
>
>    o All major extensions to IETF protocols should be done with direct
>      involvement of the IETF.
>
>    o The decision on whether an extension is major or minor should be
>      done with the direct involvement of the IETF.
>
>Those words are from the IESG draft.  They are not my words.
>
>I thought that was obvious enough in my prior reply, but apparently
>not.
>
>Curtis
>
>
>> >-----Original Message-----
>> >From: Curtis Villamizar [mailto:[email-masked]]
>> >Sent: Wednesday, March 05, 2003 4:53 PM
>> >To: Alex Zinin
>> >Cc: Shahram Davari; [email-masked]'; 
>[email-masked];
>> >[email-masked]
>> >Subject: Re: I-D ACTION:draft-andersson-mpls-g-chng-proc-00.txt 
>> >
>> >
>> >
>> >In message <[email-masked]>, Alex Zinin writes:
>> >> Wednesday, March 5, 2003, 11:12:10 AM, Shahram Davari wrote:
>> >> [...]
>> >> > It might be a good idea to require that all IETF 
>protocols support
>> >> > vendor-specific extensions, so that they could be used by 
>> >other SDOs
>> >> > and for experiments.
>> >> 
>> >> Ouch... draft-iesg-vendor-extensions-00.txt
>> >> 
>> >> Alex
>> >
>> >
>> >Looks like the IESG doesn't agree with Shahram on this.
>> >
>> >Curtis
>> >
>> 
>

---

From: Curtis Villamizar <[email-masked]>
Date: Wed, 05 Mar 2003 18:10:15 -0500

In message <[email-masked]
> decision or an IETF consensus is required?

If it is published as an informational recommendation by the IESG,
then no.  The IESG does have veto power over internet-drafts that are
on the standards track, therefore it might be worth paying attention
to their recommendations.

btw- I should also point out that Scott Bradner does not make this
stuff up without talking to the other members of the IESG.

> 2) No one can stop other SDOs from extending any IETF protocol

True.

> they mess up nobody would blame IETF for that.

This would represent a complete breakdown of relationships.  I'm not
making any value judgement, just an observation.

Curtis

---

From: Scott Bradner <[email-masked]>
Date: Wed, 5 Mar 2003 20:50:31 -0500 (EST)

> stuff up without talking to the other members of the IESG.

this text was well discussed in the IESG before it was turned into
an ID

I expect that the IESG will do a IETF Last-Call on the ID before
publishing it as an RFC to verify if the IETF community concensus
supports the statement that this ID makes

Scott