Subject: Clarification on draft-yasukawa-mpls-rsvp-p2mp-01.txt

From: Edward Harrison <[email-masked]>
Date: Tue, 8 Apr 2003 16:20:15 +0100

Hi,

I have one small question on draft-yasukawa-mpls-rsvp-p2mp-01.txt.

Can you confirm whether the Original and Modified TEROs in section 6.3
(sender initiated pruning) are correct?

From section 4.6.1.1, I would expect the original TERO
{A(0,1),B(1,1),C(1,1),D(1,1),E(2,1),F(3,1),G(3,1),H(3,1)} to correspond to
the following tree:

       A
       |
    +--+--+
    |  |  |
    B  C  D
          |
          E
          |
       +--+--+
       |  |  |
       F  G  H

However, from the example in 6.1, I would expect the modified TERO
{A(0,2),B(1,2),C(1,1),D(1,1),E(2,2),H(3,1)} to correspond to:

       A
       |
    +--+--+
    |  |  |
    B  C  D
    |
    E
    |
    H

Have I missed something, or should the original TERO for this example
actually be {A(0,1),B(1,1),E(2,1),F(3,1),G(3,1),H(3,1),C(1,1),D(1,1)},
corresponding to:

       A
       |
    +--+--+
    |  |  |
    B  C  D
    |
    E
    |
 +--+--+
 |  |  |
 F  G  H

Regards,

Ed

---

From: "Kullberg, Alan" <[email-masked]>
Date: Tue, 8 Apr 2003 13:34:09 -0400

Ed,

I believe that the TEROs as shown in the document are correct.
In the modified TERO {A(0,2),B(1,2),C(1,1),D(1,1),E(2,2),H(3,1)},
notice that E is at level 2 and is subordinate to D at level 1
since D is the most recent node at level 1 encountered when
parsing the TERO from left to right.

Hope this helps.

Alan

> -----Original Message-----
> From: Edward Harrison [mailto:[email-masked]]
> Sent: Tuesday, April 08, 2003 11:20 AM
> To: Nippon - Seisho Yasukawa
> Cc: [email-masked]
> Subject: Clarification on draft-yasukawa-mpls-rsvp-p2mp-01.txt
> 
> 
> Hi,
>

---

From: Edward Harrison <[email-masked]>
Date: Tue, 8 Apr 2003 18:45:59 +0100

Thanks Alan,

I'm still a bit confused, though.

The message flow in figure 8 seems to show that node E is subordinate to
node B (as the signaling for the pruning flows from B to E and not D to E).
Moreover, I thought that as the nodes A, B and D all have the subtree-id of
2 in the TERO, they were part of the same sub-tree.  If E is subordinate to
D, shouldn't D have a subtree-ID of 2 and B have a subtree-id of 1?

Answering my confusion another way, maybe you could clarify what the tree
looks like for the modified TERO in example 6.1
{A(0,2),B(1,2),C(1,1),D(1,1),E(2,2),F(3,2),G(3,2)}?

Does the new

     E
     |
   +---+
   |   |
   F   G

subtree hang from node D (as this is where it appears in the TERO) or node B
(as this is the node with the same subtree ID and is where the signaling
flow seems to go in figure 6)?

Thanks,

Ed

-----Original Message-----
From: Kullberg, Alan [mailto:[email-masked]]
Sent: 08 April 2003 18:34
To: Edward Harrison; Nippon - Seisho Yasukawa
Cc: [email-masked]
Subject: RE: Clarification on draft-yasukawa-mpls-rsvp-p2mp-01.txt

Ed,

Hope this helps.

Alan

---

From: "Kullberg, Alan" <[email-masked]>
Date: Tue, 8 Apr 2003 14:02:59 -0400

Ed,

I see the problem now.  The figure doesn't match the TERO.

The original TERO should be:
   {A(0,1),B(1,1),E(2,1),F(3,1),G(3,1),H(3,1),C(1,1),D(1,1)}
for tree
        A
        |
     +--+--+
     |  |  |
     B  C  D
     |
     E
     |
  +--+--+
  |  |  |
  F  G  H

as you stated in your original email and the modified TERO
used for pruning should be:
   {A(0,2),B(1,2),E(2,2),H(3,1),C(1,1),D(1,1)}
for (eventual) tree
        A
        |
     +--+--+
     |  |  |
     B  C  D
     |
     E
     |
     +--+
        |
        H

Thanks for pointing this out.

Alan

> Sent: Tuesday, April 08, 2003 1:46 PM
> To: 'Kullberg, Alan'; Nippon - Seisho Yasukawa
> Cc: [email-masked]
> > actually be 
> {A(0,1),B(1,1),E(2,1),F(3,1),G(3,1),H(3,1),C(1,1),D(1,1)},
> > corresponding to:
> > 
> >        A
> >        |
> >     +--+--+
> >     |  |  |
> >     B  C  D
> >     |
> >     E
> >     |
> >  +--+--+
> >  |  |  |
> >  F  G  H
> > 
> > Regards,
> > 
> > Ed
> > 
>