Subject: RE: Last Call MPLS-TC-MIB #6

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Mon, 7 Apr 2003 23:04:43 +0200

Tom wrote:
> At 01:40 PM 4/7/2003 -0700, Mike MacFaden wrote:
> >On Sat, Apr 05, 2003 at 04:23:12PM +0200, Wijnen, Bert (Bert) wrote:
> > >Mike, the problem is that they want to use the TeHopAddressAS
> > >in the TeHopAddress objects, and those are of type OCTET STRING,
> > >so the one from RFC3291 cannot be used.
> > >
> > >Maybe 3291bis should also add a OCTET-STRING based AsNumber?
> >
> >I see. Then I suggest it would be best if all the different
> >TCs that represent an AS number (integer, string, ...)
> >were in one place with the same semantic definition then
> >spread out among various technology specific mib modules.
> >
> >If that can't be done for whatever reason, then this TC should
> >reference the more formal definition in 3291.
> 
>          I like the reference option.
> 
Not sure how much sense it makes if the OCTET-STRING version REFERENCEs
a doc that has a Integer based version.

RFC3291 is in the process of being updated. We can add an OCTET STRING 
version there, and if (by the time PLS-TC) goes to RFC the otehr one
is also ready for RFC, then we can switch at that point.
Otherwise we can switch at some later point (assuming both base types
and semantics will be the same).

Bert
>          --tom
> 
> 
> > >>
> > >>   TeHopAddressAS ::= TEXTUAL-CONVENTION
> > >>              STATUS      current
> > >>              DESCRIPTION
> > >>                 "Represents a two or four octet AS number.
> > >>                  The AS number is represented in network byte
> > >>                  order (MSB first).  A two-octet AS number has
> > >>                  the two MSB octets set to zero."
> > >>              SYNTAX      OCTET STRING (SIZE (4))
> >
> >
> >Regards
> >Mike MacFaden
> 
> 
> http://www.elsevier-international.com/catalogue/title.cfm?ISBN
=155860751X

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 07 Apr 2003 17:28:46 -0400

>and semantics will be the same).

         Switching at a later time is cool too.

         --Tom

> > http://www.elsevier-international.com/catalogue/title.cfm?ISBN

http://www.elsevier-international.com/catalogue/title.cfm?ISBN=155860751X