Subject: RE: [PWE3] MPLS PID

From: Lloyd Wood <[email-masked]>
Date: Tue, 1 Apr 2003 17:03:11 +0100 (BST)

On Mon, 31 Mar 2003, Shahram Davari wrote:

> for all ECMP
> implementations such as the one that I described
> in earlier emails in which both the first nibble
> and the CRC are used to detect IP.

IPv6 doesn't _have_ a header checksum.
IPv4's header checksum is a pain to work with.

Are you describing an existing implementation? It sounds broken.

If you know from context you're carrying IP, then the intended
identification in the first nibble is enough to identify 4 or 6 or
something else, and you don't need to sniff the packet contents.

L.

<http://www.ee.surrey.ac.uk/Personal/L.Wood/><[email-masked]>

---

From: Luca Martini <[email-masked]>
Date: Tue, 01 Apr 2003 14:31:46 -0700

Shahram Davari wrote:
> I agree with Lloyd. Sniffing IP packets in the middle of an MPLS network is fundamentally wrong, and is impossible to do for all ECMP implementations such as the one that I described
> in earlier emails in which both the first nibble and the CRC are used to detect IP.
> 
Shahram,
It might be fundamentally wrong but this is deployed today , and we run our 
hole network based on this little point. It seems to work fine for a network 
that transport 90gb/s to 100Gb/s of actual traffic.

So if we put the theory, and layer arguments aside , what is the issue with 
determining that a particular flow is not IP ( assuming IP = 99% of traffic ) ?

Luca

It might be fundamentally wrong

> The best way to solve this problem is to do ECMP only based on label stack. Doing so should be
> easier than introducing new standard.
> 
> -Shahram
> 
> 
> 
>>-----Original Message-----
>>From: Lloyd Wood [mailto:[email-masked]]
>>Sent: Sunday, March 30, 2003 6:11 PM
>>To: Eric Rosen
>>Cc: [email-masked]; David Allan; 'Scott W Brim';
>>[email-masked]; [email-masked]
>>Subject: Re: [PWE3] MPLS PID 
>>
>>
>>On Thu, 27 Mar 2003, Eric Rosen wrote:
>>
>>
>>>1. The  only  reason for  a  PID  field in  MPLS  and/or  
>>
>>PWE3  is to  allow
>>
>>>   intermediate routers to determine whether a particular 
>>
>>MPLS payload is an
>>
>>>   IP packet or not.
>>
>>which is a layer violation, and shouldn't be done.
>>
>>
>>>   There are a number  of reasons why this is useful, and  
>>
>>no one has argued
>>
>>>   that this is not useful.
>>
>>not appropriate, more like.
>>
>>if you're going to sniff for an IP packet (so you can sniff TCP/UDP or
>>higher) you might want to ask why you even have any form of mpls
>>label stack in there in the first place.
>>
>>if you're not separating out your ip flows via explicit mpls label,
>>why not?
>>
>>L.
>>
>>_______________________________________________
>>pwe3 mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/pwe3
>>
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: Curtis Villamizar <[email-masked]>
Date: Wed, 02 Apr 2003 09:34:06 -0500

In message <[email-masked]>, Luca Martini writes:
> 
> 
> Shahram Davari wrote:
> > I agree with Lloyd. Sniffing IP packets in the middle of an MPLS network is
>  fundamentally wrong, and is impossible to do for all ECMP implementations su
> ch as the one that I described

Solving real world problems is never fundamentally wrong.  If all
traffic is know to be either IP or contain a control word then there
is no chance of reorder so its not wrong at all.

Curtis