Subject: Nodeid (was Re: Check MPLS WG Consensus)

From: [email-masked]
Date: Tue, 01 Apr 2003 17:37:08 +0200

Hi,

Why does the PLR have to know whether it is an interface
address or a node-id? If the PLR has to select a backup
tunnel, it scans the IP addresses in the RRO and compares
the IP address in the RRO subobject with the tail-end of the
backup tunnel if that IP address in the RRO cannot be
converted to a node-id. If the IP address does not match,
then the next RRO subobject is taken and then that one will
match in case the MP includes an RRO subobject containing
the node-id. So I do not see a reason to have to have a flag
to indicate that it is a node-id or not.

I would also like to see a precise definition of "the backup
tunnel's tail-end". Is it the destination address of the
bypass tunnel, ...

regards,

Stefaan

George Swallow wrote:
> 
> In San Francisco the workgroup showed support for making
> 
>   Definition of an RRO node-id subobject
>     draft-vasseur-mpls-nodeid-subobject-00.txt
> 
> an MPLS WG Document.  This message is to solicit any further comments
> prior to making a final determination.
> 
> Please reply by 4/7 24:00 GMT.
> 
> ...George
> 
> ======================================================================
> George Swallow          Cisco Systems                   (978) 936-1398
>                         250 Apollo Drive
>                         Chelmsford, Ma 01824

---

From: Jean Philippe Vasseur <[email-masked]>
Date: Tue, 01 Apr 2003 20:18:33 -0500

Hi Stefaan,

At 17:37 01/04/2003 +0200, [email-masked] wrote:

>the node-id.

That does not work since the bypass tunnel may terminate on an interface 
non recorded in the RRO of the protected TE LSP. So what we propose here is 
just to add the node-id subobject on both TE LSPs, that's as simple as 
that. If an LSR cannot use the IGP DB, just look at the RRO IPv4 subobjects 
having the flag set.

>So I do not see a reason to have to have a flag

Yes.

JP.

---

From: Kenji Kumaki <[email-masked]>
Date: Thu, 03 Apr 2003 10:15:11 +0900

Hi all,

I agree for support of this draft.

Regards,
Kenji

On Mon, 31 Mar 2003 14:05:13 -0500
George Swallow <[email-masked]> wrote:

> ..George

-- 
Kenji Kumaki <[email-masked]>