Subject: FW: Label Set question

From: Michael Mandelberg <[email-masked]>
Date: Wed, 6 Aug 2003 22:46:11 -0400

How does the label set work with waveband labels? For the list form, are the
subobjects waveband ids, or are the start and stop values listed as well?
For the range form, again is it just ids? If not, then how is ordering
defined to deterimine whether another band laebl is within the range?
 
Thanks
 
Michael Mandelberg

---

From: Michael Mandelberg <[email-masked]>
Date: Wed, 6 Aug 2003 22:46:11 -0400

Thanks
 
Michael Mandelberg

---

From: Michael Mandelberg <[email-masked]>
Date: Wed, 6 Aug 2003 22:46:11 -0400

Thanks
 
Michael Mandelberg

---

From: Michael Mandelberg <[email-masked]>
Date: Thu, 7 Aug 2003 17:37:39 -0400

I'm afraid this does not answer the question. When using Label Set for
wavebands, the subchannels are labels. The label for a waveband has three
fields:
        a waveband id
        start label
        end label
 
How is the subchannel specified? There are three possibilities:
 
1) It is just the waveband
2) It is the waveband, start/stop label triple
3) It is a single wavelength label
 
If it is possibility three, this means that for each waveband label,
multiple wavelength labels are listed. If it is one or two, then how is
ordering defined in the case where the action field is set to inclusive or
exclusive range? In other words, what procedure is to be used to decide if a
given waveband label is in a given range? As an example, consider the
following waveband labels:
 
waveband label #1:
waveband id = 1
start label = 12
stop label = 17

waveband label #2:
waveband id = 1
start label = 14
stop label = 19
 
I'm assuming that both of these make sense, otherwise, if the start and stop
values were implied by the wavband id, why include the start and stop labels
at all?
 
Now suppose a Label Set Object, with action = inclusive range, is specified.
First, how is it specified? This is the same question stated above. Assume
it is the lower and upper bounds are specifed by the two labels above. The
question is, is the following label allowed by this range:
 
waveband id = 1
start label = 13
stop label = 18

 
-----Original Message-----
From: Naga Srinivas V [mailto:[email-masked]]
Sent: Wednesday, August 06, 2003 10:53 PM
To: Michael Mandelberg; [email-masked]
Subject: Re: Label Set question

I think, in rfc 3472  section 2.5.1. Procedures is explaning about the Label
set procedures, will help you.

http://community.roxen.com/developers/idocs/rfc/rfc3472.html
<http://community.roxen.com/developers/idocs/rfc/rfc3472.html>  

Thanks,
srinivas.
 
----- Original Message ----- 
From: Michael  <mailto:[email-masked]> Mandelberg 
To: [email-masked] <mailto:[email-masked]>  
Sent: Thursday, August 07, 2003 8:16 AM
Subject: FW: Label Set question

Thanks
 
Michael Mandelberg

***************************************************************************
This message is proprietary to Future Software Limited (FSL)
and is intended solely for the use of the individual to whom it
is addressed. It may contain privileged or confidential information
and should not be circulated or used for any purpose other than for
what it is intended.

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message.
FSL accepts no responsibility for loss or damage arising from
the use of the information transmitted by this email including
damage from virus.
***************************************************************************