Subject: RE: [mpls] MPLS over L2TPv3 as WG item

From: [email-masked]
Date: Mon, 7 Feb 2005 08:52:01 -0000

If an operator already has L2TP deployed, why not just continue to use L2TP VPNs? Why go to the trouble of upgrading the edge to support MPLS and leave L2TP in the core? Surely the real advantages of using MPLS are for CAC, FRR, and TE across the core. This isn't analogous to the IP/GRE case as these don't have their own muxing capabilities and therefore MPLS is used for this purpose. So in the MPLS over L2TP case, what advantages does swapping one muxing field at the edge for another have? 

If its a greenfield network, again why would an operator choose to deploy a mesh of PE-PE L2TP tunnels in the core with MPLS just at the edge? The operator would have all the downsides of using MPLS (i.e. an extra protocol to manage/troubleshoot) with none of the benefits.

The only scenarios I can think of where L2TP would make sense are:

i)   Migration: If an operator is migrating from L2TP over to MPLS (short term solution)
ii)  Support for multiple PSN types: If an operator had deployed (or acquired) IP/L2TP and MPLS PSNs (probably short term solution if the operator is looking for convergence)
iii) Inter-provider: a) Where an operator with an L2TP network wants to offer peer-to-peer inter-provider VPNs with another operator that uses MPLS (avoids PW demux/signalling interworking), or b) where an operator with an L2TP network wants to offer MPLS transit services, or c) where two MPLS VPN providers want to use IP ASBR-ASBR instead of MPLS and want use the L2TP cookie for increased security over IP/GRE. 

Are these the types of scenarios that those supporting the draft need it for? If so perhaps it would be worth adding them to the applicability statement.

Regards,
Richard

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On
> Behalf Of Loa Andersson
> Sent: 04 February 2005 09:43
> To: W. Mark Townsley
> Cc: [email-masked]
> Subject: Re: [mpls] MPLS over L2TPv3 as WG item
> 
> 
> Working Group,
> 
> the reception of the draft was a wee bit ambigious (some no, some no
> need and some yes), with some service providers strongly in favor.
> We would like to poll the working group on whether we want to make
> draft-townsley-mpls-over-l2tpv3-00.txt a wg doc.
> 
> To make it possible to publish a working group document, given a rough
> consensus in the wg, we need to have comments Feb 11.
> 
> Send comments to the mailing list or wg chairs. We are looking for
> both positive and negative comments.
> 
> /Loa and George
> 
> W. Mark Townsley wrote:
> 
> > 
> > As requested by Loa at the last MPLS WG meeting, I have 
> renamed the MPLS 
> > over L2TPv3 draft as follows:
> > 
> > draft-townsley-mpls-over-l2tpv3-00.txt
> > 
> > With consensus confirmation from this list, I would like to 
> resubmit 
> > this version as a WG item (preferably before the upcoming 
> deadline for 
> > the next meeting).
> > 
> > Thanks,
> > 
> > - Mark
> > 
> > 
> > _______________________________________________
> > mpls mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mpls
> > 
> 
> -- 
> Loa Andersson
> 
> Principal Networking Architect
> Acreo AB                           phone:  +46 8 632 77 14
> Isafjordsgatan 22                  mobile: +46 739 81 21 64
> Kista, Sweden                      email:  [email-masked]
>                                             [email-masked]
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mpls
> 

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: "W. Mark Townsley" <[email-masked]>
Date: Mon, 07 Feb 2005 12:04:01 -0500

Richard,

Thanks for the comments. A few replies inline.

[email-masked] wrote:

> If an operator already has L2TP deployed, why not just continue to use L2TP
> VPNs? Why go to the trouble of upgrading the edge to support MPLS and leave
> L2TP in the core? 

L2TP(v3) is an edge-based service carried over IP, and thus is not "in" the core 
any more than any other protocol running over IP that the core happens to be 
carrying. P routers should not have a clue that L2TP exists.

 > Surely the real advantages of using MPLS are for CAC, FRR,
> and TE across the core. 

These are features of MPLS that L2TP does not aim to provide. But, L2TP does not 
inhibit one from using MPLS within a portion of, or the entirety of, the IP 
network that L2TP is passing over.

 > This isn't analogous to the IP/GRE case as these
> don't have their own muxing capabilities and therefore MPLS is used for this
> purpose. 

Just to be clear, GRE has a muxing capability via its 32-bit Key.

 > So in the MPLS over L2TP case, what advantages does swapping one
> muxing field at the edge for another have?

For example, if an "MPLS VPN" (as its own named service) is being muxed along 
with other services already being provided by L2TPv3 - FR, ATM, etc.

> 
> If its a greenfield network, again why would an operator choose to deploy a
> mesh of PE-PE L2TP tunnels in the core with MPLS just at the edge? 

Note that the actual application may include point to multipoint L2TPv3 Session 
IDs (not a mesh of L2TP tunnels in the RFC2661 sense of the term). But, that is 
to some degree outside the boundaries of this document which has been scoped to 
just define the encapsulation format.

 > The
> operator would have all the downsides of using MPLS (i.e. an extra protocol
> to manage/troubleshoot) with none of the benefits.
> 
> i)   Migration: If an operator is migrating from L2TP over to MPLS (short
> term solution) ii)  Support for multiple PSN types: If an operator had
> deployed (or acquired) IP/L2TP and MPLS PSNs (probably short term solution if
> the operator is looking for convergence) iii) Inter-provider: a) Where an
> operator with an L2TP network wants to offer peer-to-peer inter-provider VPNs
> with another operator that uses MPLS (avoids PW demux/signalling
> interworking), or b) where an operator with an L2TP network wants to offer
> MPLS transit services, or c) where two MPLS VPN providers want to use IP
> ASBR-ASBR instead of MPLS and want use the L2TP cookie for increased security
> over IP/GRE.
> 
> Are these the types of scenarios that those supporting the draft need it for?
> If so perhaps it would be worth adding them to the applicability statement.

I believe some of these statements are on target, though I would rather pry them 
open in a separate thread - and perhaps on a different list (e.g., L2VPN or 
L3VPN). In any case, I would be happy to see these captured and worked on in 
more detail if the draft emerges as a WG document.

Thanks,

- Mark

> 
> Regards, Richard
> 
> 
>> -----Original Message----- From: [email-masked] 
>> [mailto:[email-masked]]On Behalf Of Loa Andersson Sent: 04
>> February 2005 09:43 To: W. Mark Townsley Cc: [email-masked] Subject: Re:
>> [mpls] MPLS over L2TPv3 as WG item
>> 
>> 
>> Working Group,
>> 
>> the reception of the draft was a wee bit ambigious (some no, some no need
>> and some yes), with some service providers strongly in favor. We would like
>> to poll the working group on whether we want to make 
>> Send comments to the mailing list or wg chairs. We are looking for both
>> positive and negative comments.
>> 
>> /Loa and George
>> 
>> W. Mark Townsley wrote:
>> 
>> 
>>> _______________________________________________ mpls mailing list 
>>> [email-masked] https://www1.ietf.org/mailman/listinfo/mpls
>>> 
>> 
>> -- Loa Andersson
>> 
>> Principal Networking Architect Acreo AB                           phone:
>> +46 8 632 77 14 Isafjordsgatan 22                  mobile: +46 739 81 21 64
>> _______________________________________________ mpls mailing list 
>> [email-masked] https://www1.ietf.org/mailman/listinfo/mpls
>> 
> 
> 
> _______________________________________________ mpls mailing list 
> [email-masked] https://www1.ietf.org/mailman/listinfo/mpls
>