Subject: [mpls] Last Call on BCP on ECMP

From: George Swallow <[email-masked]>
Date: Sun, 13 Feb 2005 13:16:47 -0500

This begins a two week last call on 

   Avoiding Equal Cost Multipath Treatment in MPLS Networks

      <draft-ietf-mpls-ecmp-bcp-00.txt>

   The last call ends Feb 27 24:00 UTC.

...George

========================================================================
George Swallow             Cisco Systems                  (978) 936-1398
                           1414 Massachusetts Avenue
                           Boxborough, MA 01719

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: Erblichs <[email-masked]>
Date: Sun, 13 Feb 2005 14:19:47 -0800

Deorge Swallow,

	Sorry, I have a few minor NITs.. The long and
	short possible changes are suggested within..

	All are contained within Current ECMP Practices.

	1) Where we are in a IP environment, it is the
	re-ordering of individual flows where the segments
	in a TCP/IP flows can and do force false fast
	retransmits when multiple duplicate acks are
	recieved. This is due to the fact that one or
	more segments were lost or followed a different
	path that had a longer latency.

	Mis-ordering presumes that out-of-order segments
	can not be corrected at the destination addresses.
	This is not the case in a normal TCP/IP environment.

	Thus a simple change vs the longer one here, is
	to specify the "mis-ordering of flow between" to
	re-ordering of individual flows.

	2) ECMP can only occur when multiple paths exist,
	thus I would suggest "splitting aggregated flows" to
	splitting aggregated flows where multiple paths
	exist.

	3) Due to security purposes, some administrators
	are using intermediate systems that either aggregate
	or modify source addresses. This effectively hides
	the original source addresses and allows the
	intermediate systems to filter incoming non-solicited
	data flows to the original sources.

	Thus, as a FYI. I would possibly suggest ADDING
	something like.

	One should also be aware that some intermediate
	systems are intercepting flows between a source and
	destination and then modifing source
	addresses for security purposes. These modifications
	may alter the effectiveness of of removing ECMP
	routing behaviour. Of course, on the return to the
	modified source address, if the return flow is not
	modified, the flow is then re-directed back to the
	original source.

	Mitchell Erblich

---

From: Alia Atlas <[email-masked]>
Date: Sun, 13 Feb 2005 20:07:55 -0500

The draft doesn't discuss at all the case where packets may be distributed 
to different paths based upon the MPLS label stack.   This can occur for 
some equipment when either the packet is not identified as IPv4 or IPv6 or 
when the equipment cannot examine the header underneath the MPLS label 
stack, presumably due to its depth.

This doesn't cause concerns for the PWE3 cases, but it was a definite issue 
when we were discussing LSP ping and other OAM issues.  For instance, this 
was part of the concern for adding an OAM label into the label stack.

If this is really to be a BCP describing how ECMP and MPLS interact, then 
I'd really like to see a very short section describing the possibility that 
packets may be load-balanced based on the label stack as well.

At the time of the OAM label discussion, it was suggested that future 
implementations shouldn't include the reserved labels in any processing of 
the label stack done for load balancing.   Perhaps we don't want to capture 
that here - the idea seemed a bit sensitive at the time - though I'd be in 
favor of it.

Alia