Subject: RE: [mpls] MPLS over L2TPv3 as WG item

From: Mark Lewis <[email-masked]>
Date: Sat, 5 Feb 2005 21:36:44 GMT

I also support making it a working group item.

Mark

>
>>From: "Dean Cheng (dcheng)" <[email-masked]>
>>Reply-To: [email-masked]
>>To: "'Loa Andersson'" <[email-masked]>, "'W. Mark Townsley'" 
>><[email-masked]>
>>CC: [email-masked]
>>Subject: RE: [mpls] MPLS over L2TPv3 as WG item
>>Date: Fri, 4 Feb 2005 13:50:53 -0800
>>
>>Support to make it a WG item.
>>
>>Dean
>> >-----Original Message-----
>> >From: [email-masked]
>> >[mailto:[email-masked]] On Behalf Of Loa
Andersson
>> >Sent: Friday, February 04, 2005 1:43 AM
>> >To: W. Mark Townsley
>> >Cc: [email-masked]
>> >Subject: Re: [mpls] MPLS over L2TPv3 as WG item
>> >
>> >Working Group,
>> >
>> >the reception of the draft was a wee bit ambigious (some no,
>> >some no need and some yes), with some service providers
>> >strongly in favor.
>> >We would like to poll the working group on whether we want to
>> >make draft-townsley-mpls-over-l2tpv3-00.txt a wg doc.
>> >
>> >To make it possible to publish a working group document, given
>> >a rough consensus in the wg, we need to have comments Feb 11.
>> >
>> >Send comments to the mailing list or wg chairs. We are looking
>> >for both positive and negative comments.
>> >
>> >/Loa and George
>> >
>> >W. Mark Townsley wrote:
>> >
>> >>
>> >> As requested by Loa at the last MPLS WG meeting, I have
renamed the
>> >> MPLS over L2TPv3 draft as follows:
>> >>
>> >> draft-townsley-mpls-over-l2tpv3-00.txt
>> >>
>> >> With consensus confirmation from this list, I would like
to resubmit
>> >> this version as a WG item (preferably before the upcoming
>> >deadline for
>> >> the next meeting).
>> >>
>> >> Thanks,
>> >>
>> >> - Mark
>> >>
>> >>
>> >> _______________________________________________
>> >> mpls mailing list
>> >> [email-masked]
>> >> https://www1.ietf.org/mailman/listinfo/mpls
>> >>
>> >
>> >--
>> >Loa Andersson
>> >
>> >Principal Networking Architect
>> >Acreo AB                           phone:  +46 8 632 77 14
>> >Isafjordsgatan 22                  mobile: +46 739 81 21 64
>> >Kista, Sweden                      email: 
[email-masked]
>> >                                            [email-masked]
>> >
>> >_______________________________________________
>> >mpls mailing list
>> >[email-masked]
>> >https://www1.ietf.org/mailman/listinfo/mpls
>> >
>>
>>_______________________________________________
>>mpls mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/mpls
>
>

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: "David Allan" <[email-masked]>
Date: Fri, 4 Feb 2005 10:38:04 -0500

Hi:

I could support it if there was a stated intention to deprecate PWs over
L2TPv3 as done today (aka not really interoperable in any simple sense with
PWs over MPLS or MPLSinIP) which IMO would be a useful simplification...

Otherwise it is simply one MORE way to do the same thing and I for one don't
have the cycles for that...

rgds
Dave

---

From: "Monique Morrow \(mmorrow\)" <[email-masked]>
Date: Mon, 7 Feb 2005 02:57:39 +0100

Support this draft as WG.

/m

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Loa Andersson
Sent: 04 February 2005 10:43
To: Mark Townsley (townsley)
Cc: [email-masked]
Subject: Re: [mpls] MPLS over L2TPv3 as WG item

Working Group,

the reception of the draft was a wee bit ambigious (some no, some no
need and some yes), with some service providers strongly in favor.
We would like to poll the working group on whether we want to make
draft-townsley-mpls-over-l2tpv3-00.txt a wg doc.

To make it possible to publish a working group document, given a rough
consensus in the wg, we need to have comments Feb 11.

Send comments to the mailing list or wg chairs. We are looking for
both positive and negative comments.

/Loa and George

W. Mark Townsley wrote:

> 
> As requested by Loa at the last MPLS WG meeting, I have renamed the
MPLS 
> over L2TPv3 draft as follows:
> 
> With consensus confirmation from this list, I would like to resubmit 
> this version as a WG item (preferably before the upcoming deadline for

-- 
Loa Andersson

Principal Networking Architect
Acreo AB                           phone:  +46 8 632 77 14
Isafjordsgatan 22                  mobile: +46 739 81 21 64
Kista, Sweden                      email:  [email-masked]
                                            [email-masked]

---

From: [email-masked]
Date: Mon, 7 Feb 2005 17:46:33 -0000

Mark,

Thanks for your response, a few replies inline to provide clarification.

> > If an operator already has L2TP deployed, why not just 
> > continue to use L2TP VPNs? Why go to the trouble of 
> > upgrading the edge to support MPLS and leave L2TP
> > in the core? 
>
> L2TP(v3) is an edge-based service carried over IP, and thus 
> is not "in" the core any more than any other protocol running 
> over IP that the core happens to be carrying. P routers should 
> not have a clue that L2TP exists.

When I say leave L2TP in the core, I mean continue to use L2TP on the PE core facing interfaces to provide PE-PE tunnels across the core, as opposed to using MPLS PE-PE tunnels across the core.

> > This isn't analogous to the IP/GRE case as these don't have
> > their own muxing capabilities and therefore MPLS is used for 
> > this purpose. 
> 
> Just to be clear, GRE has a muxing capability via its 32-bit Key.

And IP has a muxing capability via its UDP/TCP port numbers. I was referring here to the use of muxing fields as defined by the IETF PWE3 WG for VPN muxing. These are currently MPLS or L2TP session IDs (and maybe IP UDP port numbers, I've lost track of whether on not this has been accepted by PWE3 as a valid approach). The point being that PWE/L2VPN L2TP based solutions exist today that do not require MPLS for muxing, whereas I am not aware of any PWE3/L2VPN IP/GRE solutions that do not require MPLS labels for muxing.

Regards,
Richard

---

From: "Don Fedyk" <[email-masked]>
Date: Mon, 7 Feb 2005 14:46:05 -0500

Very well put. I'll second that opinion.

Regards,
Don 

> [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Saturday, February 05, 2005 4:41 AM
> To: Loa Andersson; W. Mark Townsley
> Cc: [email-masked]
> Well, I suppose it does not harm. But does it do any good?
> 
> Looking at the current draft, there are no protocol 
> specifications and no code point definitions. The draft boils 
> down to a statement that the payload of an L2TP packet may be 
> an MPLS packet, some restatements from L2TPv3 about how the 
> L2TP fields should be set, and an applicability statement.
> 
> I would suggest that this should be simply recast as an 
> informational draft making an applicability statement for 
> MPLS over L2TP.
> 
> Regards,
> Adrian
> ----- Original Message ----- 
> From: "Loa Andersson" <[email-masked]>
> To: "W. Mark Townsley" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Friday, February 04, 2005 9:43 AM
> > need and some yes), with some service providers strongly in 
> favor. We 
> > would like to poll the working group on whether we want to make 
> deadline 
> > > for the next meeting).
> > > [email-masked] https://www1.ietf.org/mailman/listinfo/mpls
> > >
> >
> > --
> > Loa Andersson
> >
> > [email-masked] https://www1.ietf.org/mailman/listinfo/mpls
> >
> >
> 
>