Subject: Re: [mpls] Last Call on BCP on ECMP

From: George Swallow <[email-masked]>
Date: Wed, 02 Mar 2005 19:31:36 -0500

Dave -

> I agree with Alia that fate sharing between LSPs and reserved labels would
> be a useful propery to at least START to get back (and IMO it goes beyond
> OAM/router alert, it should have remained a design intent). 
> 
> I would like to see that included in this BCP. Text to the effect that "the
> NHLFE selection criteria should be unaffected by the presence of reserved
> labels (0-15)..."

I don't think this belongs in a BCP.  The document is intended to let
people know what the current practice is so that they can figure out how
to deal (cope if you like) with it.  

...George

========================================================================
George Swallow             Cisco Systems                  (978) 936-1398
                           1414 Massachusetts Avenue
                           Boxborough, MA 01719

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: "David Allan" <[email-masked]>
Date: Thu, 3 Mar 2005 09:24:50 -0500

Understood,

Simply seemed to be a good place to document IMO a reasonable direction to
go in, (irrespective of the existence of RFC 3429)

cheers
Dave

> -----Original Message-----
> From: George Swallow [mailto:[email-masked]] 
> Sent: Wednesday, March 02, 2005 7:32 PM
> To: Allan, David [CAR:NS00:EXCH]
> Cc: [email-masked]'; [email-masked]
> Subject: Re: [mpls] Last Call on BCP on ECMP 
> 
> 
> Dave -
> 
> > I agree with Alia that fate sharing between LSPs and 
> reserved labels 
> > would be a useful propery to at least START to get back (and IMO it 
> > goes beyond OAM/router alert, it should have remained a design 
> > intent).
> > 
> > I would like to see that included in this BCP. Text to the 
> effect that 
> > "the NHLFE selection criteria should be unaffected by the 
> presence of 
> > reserved labels (0-15)..."
> 
> I don't think this belongs in a BCP.  The document is 
> intended to let people know what the current practice is so 
> that they can figure out how to deal (cope if you like) with it.  
> 
> ...George
>

---

From: "David Allan" <[email-masked]>
Date: Thu, 3 Mar 2005 11:53:00 -0500

Hi Neil:

IMO if a reserved label defines a function and not forwarding, then it is
likely that we can envision future functions whereby they should fate share
with the LSP of interest, a far more useful behavior than not fate sharing.
Frequently they would be either bottom label or nested beneath the bottom
label...but I would not cast that in stone (witness explicit null ;-)

Fate sharing is not the case today....

Dave

> From: [email-masked] [mailto:[email-masked]] 
> Sent: Thursday, March 03, 2005 10:39 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [mpls] Last Call on BCP on ECMP 
> 
> 
> According to rfc3032 labels 0-15 are reserved...so its seems 
> there is a more general point here.  Further, there seem to 
> be proposals for some of these to occur at arbitrary 
> positions in the stack, eg draft-ietf-mpls-explicit-null-02.txt.
> 
> So how does this play here?
> 
> regards, Neil
>  
> > We may want another or a different example of a reserved
> > label (such as the 
> > Router Alert or even Explicit Null)
> > 
> > Alia
> > 
> > At 08:07 PM 3/2/2005, George Swallow wrote:
> > > > "The processing of the label stack for load balancing 
> may include
> > > > all MPLS labels, including those that are reserved; in 
> > such a case,
> > > > the addition of a reserved label, such as the OAM label,
> > may result
> > > > in a different path being taken."
> > >
> > >I'll probably word-smith it a bit, but I'm happy to capture the
> > >thought.
> > >
> > >...George
> > >
> > [email-masked] https://www1.ietf.org/mailman/listinfo/mpls
> > 
> 
>

---

From: Alia Atlas <[email-masked]>
Date: Thu, 03 Mar 2005 13:41:39 -0500

Hi Neil,

The BCP is trying to describe what (generally) currently happens and the 
ramifications for ECMP.

Any reserved label, no matter where it is located in the stack, may be 
included in the computation for load balancing based on the stack.  This 
causes traffic using such reserved labels to not necessarily fate share 
with traffic that doesn't.  Examples are traffic with a router alert label 
or with an OAM label.

In this BCP, I think we just want to capture the implications of this 
behavior and not, explicitly, say how to do it better - because most 
current practices do not.

Alia

At 11:53 AM 3/3/2005, Allan, David [CAR:NS00:EXCH] wrote:

>likely that we can envision future functions whereby they should fate 
>share with the LSP of interest, a far more useful behavior than not fate 
>sharing. Frequently they would be either bottom label or nested beneath 
>the bottom label...but I would not cast that in stone (witness explicit 
>null ;-)
>
> > From: [email-masked] 
> [<mailto:[email-masked]>mailto:[email-masked]]
> <https://www1.ietf.org/mailman/listinfo/mpls>https://www1.ietf.org/mailman/listinfo/mpls 
>
> > >
> >
> >