Subject: Re: [mpls] Last Call on BCP on ECMP

From: George Swallow <[email-masked]>
Date: Wed, 02 Mar 2005 19:22:22 -0500

Hi -

Thanks for the comments:

> 	Thus a simple change vs the longer one here, is
> 	to specify the "mis-ordering of flow between" to
> 	re-ordering of individual flows.

point taken.

> 	2) ECMP can only occur when multiple paths exist,
> 	thus I would suggest "splitting aggregated flows" to
> 	splitting aggregated flows where multiple paths
> 	exist.

A nit, but I can add it.

> 
> 	One should also be aware that some intermediate
> 	systems are intercepting flows between a source and
> 	destination and then modifing source
> 	addresses for security purposes. These modifications
> 	may alter the effectiveness of of removing ECMP
> 	routing behaviour. Of course, on the return to the
> 	modified source address, if the return flow is not
> 	modified, the flow is then re-directed back to the
> 	original source.

This one is a bit off topic and I think it could add more confusion than
light.  I'm not planning on adding it.

...George

========================================================================
George Swallow             Cisco Systems                  (978) 936-1398
                           1414 Massachusetts Avenue
                           Boxborough, MA 01719

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: Erblichs <[email-masked]>
Date: Thu, 03 Mar 2005 14:42:39 -0800

George Swallow,

	Firewalls (intermediate systems) seem to be showing
	up alot to hide IP address for a number of
	reasons, thus...

	The third item was added due to some firewall
	(intermediate systems) work that I have seen 
	which seems to effect MPLS hop by hop routing.

	If I understand the interactions correctly Explicit
	MPLS source routing would not be effected.
	
	However, I thought separating the two would be
	a bit wordy..

	Mitchell Erblich
	-------------------