Subject: RE: [mpls] MPLS multicasts

From: "Vijayanand C - CTD, Chennai." <[email-masked]>
Date: Tue, 14 Jun 2005 18:30:23 +0530

I have the following question/comment on the upstram label allocation
methodology.

So far, when LSRs use downstream allocation policy the LSR which interprets
the received label in the MPLS packet would be the one which allocated that
label.The downsteam could allocate labels based on some methodology to
optimise its lookup/ interpretation of labels. 

 For upstream allocation, since the label is allocated by the upstream LSR,
should there be some means of negotiating the label space for upstream
allocation between the upstream and the one/many downstream neighbors to
arrive at a mutually agreeable label space/allocation policy.

Regards,
Vijay

> -----Original Message-----
> From: Eric Rosen [mailto:[email-masked]]
> Sent: Thursday, June 09, 2005 7:45 PM
> To: [email-masked]
> Subject: [mpls] MPLS multicasts
> 
> 
> We'd  like to  call your  attention to  a two  recent drafts  
> regarding MPLS
> multicast: 
> 
> draft-rosen-mpls-multicast-encaps-00.txt
> draft-raggarwa-mpls-upstream-label-00.txt
> 
> These drafts  update RFCs  3031, 3032, and  4023 with  regard 
> to the  way in
> which  MPLS multicasts  are encapsulated,  and the  way MPLS  
> labels  may be
> assigned to multicast  traffic.  Some significant changes to  
> those RFCs are
> proposed,  though  we  do  not  believe that  the  changes  
> affect  existing
> deployments.  
> 
> Naturally, we think these should be WG documents, so we hope 
> that members of
> the WG will read the documents (they're short!) and comment on them. 
> 
> Eric and Rahul
> 
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mpls
> 
DISCLAIMER 
This message and any attachment(s) contained here are information that is confidential, proprietary to HCL Technologies 
and its customers. Contents may be privileged or otherwise protected by law. The information is solely intended for the 
individual or the entity it is addressed to. If you are not the intended recipient of this message, you are not authorized to 
read, forward, print, retain, copy or disseminate this message or any part of it. If you have received this e-mail in error, 
please notify the sender immediately by return e-mail and delete it from your computer

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: Eric Rosen <[email-masked]>
Date: Fri, 17 Jun 2005 11:28:38 -0400

Vijay> So  far, when  LSRs use  downstream allocation  policy the  LSR which
Vijay> interprets the  received label  in the MPLS  packet would be  the one
Vijay> which allocated that label.The  downsteam could allocate labels based
Vijay> on some methodology to optimise its lookup/ interpretation of labels.

Vijay> For upstream allocation, since the label is allocated by the upstream
Vijay> LSR, should  there be some means  of negotiating the  label space for
Vijay> upstream allocation between the  upstream and the one/many downstream
Vijay> neighbors to  arrive at  a mutually agreeable  label space/allocation
Vijay> policy.

This is a  valid problem; there needs  to be some means of  ensuring that an
upstream-assigned label is interpretable by all the downstream systems.