Subject: Re: [mpls] Comments for fastreroute-mib-04

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 7 Dec 2005 09:17:23 -0500

On Nov 29, 2005, at 9:06 PM, Ken Nagami wrote:

> Dear authors and all,
>
> I have a following comment for the FRR MIB (draft-ietf-mpls- 
> fastreroute-mib-04).
> Could you reflect this comment in the document?
>
> Comment:
> I would like to get a 2nd label of a bypass tunnel at a PLR in the  
> facility backup.
> I think a pointer of 1st (top) label of the bypass tunnel at a PLR  
> can be get from the FRR MIB.
> But the 2nd label can not be get.
>
> Because I would like to check a 2nd label of a bypass tunnel and an  
> incoming label at the MP.
> In the case of the node protection, two label values are normally  
> the same.
> But if a router has a bug, the value might be different.
> So, we would like to check those values before local repair from a  
> network management box.

	The MPLS-FRR-MIB provides a reference back to the TE tunnel
in the MPLS-TE-STD-MIB which can be used to find the LSP that
is in use for that tunnel head. From the tunnelEntry in the MPLS-TE- 
STD-MIB
you can get the Cross-Connect (XCindex) of the LSP that is in use for  
that
tunnel head from the MPLS-LSR-STD-MIB, which will have a corresponding
mplsLabelStackTable entry that should have the extra label
shown under the top label shown in the mplsInSegmentTable.

	--Tom

> Regards,
>
> Ken Nagami
>
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mpls

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: Ken Nagami <[email-masked]>
Date: Thu, 08 Dec 2005 00:15:42 +0900

Hi Tom,

Thnak you for your reply.

I agree that your method can get a 2nd label during a local repair in use.
However, before using a local repair, I do not understand why your
method can get a 2nd label.
A Cross-Connect in the MPLS-LSR-STD-MIB for the 2nd label
is only created during the local repair in use.
So, before using a local repair, I think I can not get the 2nd label.
Is this correct?

Regards,

Ken Nagami

At 23:17 05/12/07, Thomas D. Nadeau wrote:

>is in use for that tunnel head. From the tunnelEntry in the MPLS-TE- STD-MIB

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 7 Dec 2005 11:11:05 -0500

> So, before using a local repair, I think I can not get the 2nd label.

	That is correct. However, since the backup/protection
tunnel is signaled at the time you configure protection,
the LSP (i.e.: label) should be active. The LFIB should
just not be moving any traffic onto that tunnel at the PLR.

	--Tom

---

From: Ken Nagami <[email-masked]>
Date: Fri, 09 Dec 2005 12:09:18 +0900

>just not be moving any traffic onto that tunnel at the PLR.

I understand that the bypass LSP is active when I configure protection.
Before using a local repair, we can not get the 2nd label on the bypass LSP,
because the protected LSP is not on the bypass LSP. This is an issue.

It is important to check whether the 2nd label of the bypass LSP and 
the top label
of the protected LSP are the same BEFORE a local repair is working.

We can check the above label values when the local repair is working.
But this check is too late. If the check is fail, the customer traffic goes
to wrong direction.

I think the FRR-MIB is better place to get the 2nd label of the bypass LSP before
a local repair is working.

Regards,

Ken Nagami

>>>is in use for that tunnel head. From the tunnelEntry in the MPLS- TE- STD-MIB