Subject: RE: [mpls] Reg: One clarification needed reg RFC 3209 on the scope ofTunnel ID

From: "Zafar Ali \(zali\)" <[email-masked]>
Date: Wed, 21 Jun 2006 02:24:41 -0400

________________________________

	From: Dutta, Pranjal [mailto:[email-masked]] 
	Sent: Tuesday, June 20, 2006 3:00 AM
	To: [email-masked]
	Subject: [mpls] Reg: One clarification needed reg RFC 3209 on
the scope ofTunnel ID 

	Hi All,

	           RFC 3209 states regarding uniquely identifying a LSP
Tunnel as follows:

	"A tunnel ID is part of the SESSION object.
	   The SESSION object uniquely defines a traffic engineered
tunnel.  The

	Awduche, et al.             Standards Track
[Page 7]
	 
	RFC 3209           Extensions to RSVP for LSP Tunnels
December 2001

	   SENDER_TEMPLATE and FILTER_SPEC objects carry an LSP ID.  The
	   SENDER_TEMPLATE (or FILTER_SPEC) object together with the
SESSION
	   object uniquely identifies an LSP tunnel"
	 
	So at the ingress LSR, a Session Object is identified with
Tunnel ID, Dst IPV4/IPV6 Address of the Tunnel and Ext Tunnel ID (which
can be set to source address). That means both tunnel_id and dst_addr
uniquely identifies a LSP tunnel. 

You also need LSP ID; specifically (source IP address, Destination IP
address, LSP ID, tunnel ID and ext tunnel ID) uniquely identify an LSP. 
Also note that a tunnel "can" have multiple LSP-es (e.g., during reopt).

	With respect to an ingress LSR does that mean that tunnel_id is
specific to one particular destination  

	 and the same tunnel_id may be used for
	another tunnel (originating at the same LSR) that goes to diff.
destination?

 No,  and I don't see any reason why you would like to reuse the tunnel
ID field (bit space is not an issue in any deployment). 

	Info on this would be of great help.
	 
	Thanks in advance,
	Pranjal

	 

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: "Dutta, Pranjal" <[email-masked]>
Date: Wed, 21 Jun 2006 13:04:03 +0530

Hi Zafar,

               Thanks for the clarification. Please refer inline my
answers.

From: Zafar Ali (zali) [mailto:[email-masked]] 
Sent: Wednesday, 21 June, 2006 11:55 AM
To: Dutta, Pranjal; [email-masked]
Subject: RE: [mpls] Reg: One clarification needed reg RFC 3209 on the
scope ofTunnel ID 

	

	Hi All,

	 

	 

Yes, LSP ID can change during Reopt. /MBB or after restart. I understand
that it's also part of the key that identifies a LSP.

	 

No, and I don't see any reason why you would like to reuse the tunnel ID
field (bit space is not an issue in any deployment). 
Practically I won't reuse the tunnel ID on a different LSP going to
another destination, because in that case we need to account for more
info in LSP identification.
Since the RFC doesn't say strictly that tunnel id has to be unique at an
ingress LSR irrespective of destination of the LSPs, so I had some
confusion over this.
 
Thanks once again,
 
Pranjal 

	Thanks in advance,
	Pranjal