Subject: [MPLS]Suggestion to discover and distribute multicast membership for P2MP automatically and dynamically

From: Zheng Hewen <[email-masked]>
Date: Sat, 10 Jun 2006 17:49:37 +0800

Hi,

The signaling solution for the construction of P2MP MPLS-TE LSPs defined in draft-ietf-mpls-rsvp-te-p2mp-05.txt assumes that 
the ingress node for any P2MP LSP knows the identities of all of the receivers. No mechanism in that document is provided by 
which it can discover the identities of those receivers.

In multicast LDP (mLDP) defined in draft-ietf-mpls-ldp-p2mp-00.txt it is assumed that each receiver knows the identity of 
the source of the distribution tree, but no mechanism is provided whereby the receivers can discover that information.

In order to successfully operate P2MP MPLS, and to consider extending MPLS to support MP2MP it is necessary to examine
the requirements for exchanging and learning the identities of P2MP roots and leaves. One mechanism is desired to discover 
and distribute multicast membership information dynamically.

Currently some work is in progress. For L3VPN applications, it is one choice to carry and distribute multicast membership 
information through auto-discovery mechanism based on extended BGP defined in the 
draft-raggarwa-l3vpn-2547bis-mcast-bgp-01.txt. For P2MP MPLS-TE applications, one effort is to extend IGP-TE for such 
purpose using one analogous mechanism defined in draft-ietf-ccamp-te-node-cap-01.txt. For connection-oriented transport 
network basing on MPLS, one mechanism defined in RFC2022 may be referred. Extension to MSDP is another choice to satisfy 
those requirements directly if possible.

It is desired to clear the requirements for that mechanism. Is there any interest for this? I want to do something about it 
and hope to receive advices.

Best Regards,
Heaven

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: "S.Matsushima" <[email-masked]>
Date: Tue, 27 Jun 2006 12:37:18 +0900

Hi,

Agreed.
I think that it is good point.
Dynamic discover and membership distribution of p2mp LSP will be needed
to operate p2mp LSP in real networks.

Also, I would say that policy-based mechanism to establish p2mp LSP in per
LSP basis is needed.

In BGP P2MP solution, you can see some ideas to achieve
above requirements. Your interest and comment are welcome.

http://www3.ietf.org/proceedings/05nov/slides/mpls-3/sld1.htm

-03 version of this draft will appear soon.

--
Satoru Matsushima

---

From: Zheng Hewen <[email-masked]>
Date: Tue, 27 Jun 2006 11:53:36 +0800

Hi,

I wrote one draft about those requirements, your comments are appreciated.
 http://tools.ietf.org/wg/mpls/draft-zheng-mpls-p2mp-topology-agent-reqs-00.txt

To Extend BGP to achieve those requirements is one good choice, especially for policy-based mechanism.
There is also another choice to extend IGP to achieve those requirements from J.L. Le Roux.
http://tools.ietf.org/wg/mpls/draft-leroux-mpls-p2mp-te-autoleaf-00.txt

-----Original Message-----
From: S.Matsushima [mailto:[email-masked]]
Sent: 2006年6月27日 11:37
To: Zheng Hewen
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [MPLS]Suggestion to discover and distribute multicast membership for P2MP automatically and dynamically

Hi,

Agreed.
I think that it is good point.
Dynamic discover and membership distribution of p2mp LSP will be needed to operate p2mp LSP in real networks.

Also, I would say that policy-based mechanism to establish p2mp LSP in per LSP basis is needed.

In BGP P2MP solution, you can see some ideas to achieve above requirements. Your interest and comment are welcome.

--
Satoru Matsushima

Zheng Hewen wrote:
> Hi,
>
> The signaling solution for the construction of P2MP MPLS-TE LSPs
> defined in draft-ietf-mpls-rsvp-te-p2mp-05.txt assumes that the
> ingress node for any P2MP LSP knows the identities of all of the receivers. No mechanism in that document is provided by
>
> In multicast LDP (mLDP) defined in draft-ietf-mpls-ldp-p2mp-00.txt it
> is assumed that each receiver knows the identity of the source of the distribution tree, but no mechanism is provided
whereby the receivers can discover that information.
>
> In order to successfully operate P2MP MPLS, and to consider extending
> MPLS to support MP2MP it is necessary to examine the requirements for
> exchanging and learning the identities of P2MP roots and leaves. One mechanism is desired to discover and distribute
multicast membership information dynamically.
>
> Currently some work is in progress. For L3VPN applications, it is one
> choice to carry and distribute multicast membership information
> through auto-discovery mechanism based on extended BGP defined in the
> draft-raggarwa-l3vpn-2547bis-mcast-bgp-01.txt. For P2MP MPLS-TE
> applications, one effort is to extend IGP-TE for such purpose using
> one analogous mechanism defined in draft-ietf-ccamp-te-node-cap-01.txt. For connection-oriented transport network basing
on MPLS, one mechanism defined in RFC2022 may be referred. Extension to MSDP is another choice to satisfy those requirements
directly if possible.
>
> It is desired to clear the requirements for that mechanism. Is there
> any interest for this? I want to do something about it and hope to receive advices.
>
>
> Best Regards,
> Heaven
>
>
>
>
>
>
>

---

From: Zheng Hewen <[email-masked]>
Date: Thu, 29 Jun 2006 17:22:15 +0800

Hi,

   Is your solution inside draft-satoru-mpls-bgp-multipoint-01.txt?
   If so, it is applicable for inter-area/domain applications.

Best regards,
Hewen

-----Original Message-----
From: S.Matsushima [mailto:[email-masked]]
Sent: 2006年6月27日 11:37
To: Zheng Hewen
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [MPLS]Suggestion to discover and distribute multicast membership for P2MP automatically and dynamically

Hi,

Agreed.

--
Satoru Matsushima