Subject: Re: Rahul Aggarwal: [mpls] Identifier Semantics [Re: working group last call on draft-ietf-mpls-rsvp-te-p2mp-05.txt]

From: George Swallow <[email-masked]>
Date: Wed, 28 Jun 2006 16:57:27 -0400

The text below should not be changed (at least not to what has been
proposed!)

 > 
 > 19.2.1
 > 
 > " IPv4 tunnel sender address
 >             See [RFC3209]"
 > 
 > to"
 > 
 > "IPv4 tunnel sender address. This address MUST be the same as the address
 > in the Extended Tunnel ID field of the SESSION object."
 > 
 > 8.
 > 
 > 19.2.2
 > 
 > "IPv6 tunnel sender address
 >            See [RFC3209]"
 > 
 > to
 > 
 > "IPv6 tunnel sender address. This address MUST be the same as the address
 > in the Extended Tunnel ID field of the SESSION object."

These changes bill break bypass FRR.  When a node want to establish a
fast reroute LSP that merges back in over a bypass tunnel, the Sender
address is set to its own IP address (which in most cases would be some
midpoint node).

Further i think that we should only RECOMMEND that the Extended tunnel
ID be used to carry the tunnel headend address.  So we couldn't say MUST
here anyway.

...George

========================================================================
George Swallow             Cisco Systems                  (978) 936-1398
                           1414 Massachusetts Avenue
                           Boxborough, MA 01719

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: Rahul Aggarwal <[email-masked]>
Date: Wed, 28 Jun 2006 14:00:25 -0700 (PDT)

Hi George,

> address is set to its own IP address (which in most cases would be some

Agreed.

rahul