Subject: [MPLS] LDP GR query

From: [email-masked]
Date: Mon, 16 Oct 2006 15:07:12 +0800

空白
Hi 

I have query related to LDP Graceful Restart. 

RFC 3478 say

When an LSR detects that its LDP session with a neighbor went down,

   and the LSR knows that the neighbor is capable of preserving its MPLS

   forwarding state across the restart (as was indicated by the FT

   Session TLV in the Initialization message received from the

   neighbor), the LSR retains the label-FEC bindings received via that

   session (rather than discarding the bindings), but marks them as

   "stale".

  RFC 3478 say that a router will implement GR flow when it detect that its LDP session with a neighbor went down.

 But there are many cases which can cause the LDP session went down ,and it’s neighbor don’t restart actually.

Consider this scenario: 

 

Suppose that the link between RTB and LAN-SWITCH is broken down, then RTA will detects that its LDP session with RTB went down, then RTA will implement GR flow, even the LDP session between RTA and RTB is re-established after the link between RTB and LAN-SWITCH  is resumed. Because the FT TLV in the initialization message of RTB don’t indicate that RTB whether reboot or not, so RTA is still implement GR flow.

Now RTA is in GR flow , but RTB isn’t in GR flow.

But what will happen if RTA is in GR flow , at the same time RTB isn’t in GR flow? I think it will fall into confusion.

Another example that the LDP session will be down is that the LSR’s neighbor can’t send out it’s packet, including hello packet or keepalive packet, if the control plane of it’s neighbor is very busy or occurs some error ,then the LDP session will be down. In this case the LSR will conclude that it’s neighbor restart and the LSR will implement GR flow.

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: "Yu Yi" <[email-masked]>
Date: Mon, 16 Oct 2006 19:21:33 +1000

For your case it is fine. RTB should be in normal case(normal session down)(no any GR flow) and delete all LSPs which are established on the port.  After session up again RTA will re-send the same label mapping which are sent before session down. But as you know during this period the MPLS traffic are lost. So this is not a complete GR case. 
  GR is applicable only if the forwarding plane is fine.
 
________________________________

From: [email-masked] [mailto:[email-masked]] 
Sent: 2006年10月16日 3:07 PM
To: [email-masked]
Subject: [MPLS] LDP GR query

Hi 

RFC 3478 say

   "stale".

Consider this scenario: 

 

Suppose that the link between RTB and LAN-SWITCH is broken down, then RTA will detects that its LDP sessFrom [email-masked] Mon Oct 16 05:39:47 2006
Content-class: urn:content-classes:message
Subject: RE: [MPLS] LDP GR query
Date: Mon, 16 Oct 2006 19:21:33 +1000
From: "Yu Yi" <[email-masked]>
To: <[email-masked]>, <[email-masked]>
Cc: 

This is a multi-part message in MIME format.
  For your case it is fine. RTB should be in normal case(normal session down)(no any GR flow) and delete all LSPs which are established on the port.  After session up again RTA will re-send the same label mapping which are sent before session down. But as you know during this period the MPLS traffic are lost. So this is not a complete GR case. 
  GR is applicable only if the forwarding plane is fine.
 
________________________________

From: [email-masked] [mailto:[email-masked]] 
Sent: 2006年10月16日 3:07 PM
To: [email-masked]
Subject: [MPLS] LDP GR query

Hi 

RFC 3478 say

   "stale".

Consider this scenario: