Subject: [mpls] Fw: I-D ACTION:draft-swallow-rsvp-user-error-spec-00.txt

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 14 Oct 2006 22:56:57 +0100

Heads up on this I-D.

We are proposing a backward-compatible way of conveying additional error 
information in RSVP.
This will make it a lot easier for user-defined error codes to be signalled, 
and is extensible for the inclusion of error-specific details.

Your comments would be welcomed.

Thanks,
Adrian
----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Friday, October 13, 2006 8:50 PM
Subject: I-D ACTION:draft-swallow-rsvp-user-error-spec-00.txt

>A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
> Title : User Defined Errors for RSVP
> Author(s) : G. Swallow, A. Farrel
> Filename : draft-swallow-rsvp-user-error-spec-00.txt
> Pages : 8
> Date : 2006-10-13
>
>
>   The Resource ReserVation Protocol (RSVP) defines an ERROR_SPEC object
>   for communicating errors.  That object has a defined format that
>   permits the definition of 256 error codes.  As RSVP has been
>   developed and extended, the convention has been to be conservative in
>   communicating errors.  Further, no provision for user defined errors
>   exists in RSVP.
>
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-swallow-rsvp-user-error-spec-00.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of
> the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
> Internet-Drafts are also available by anonymous FTP. Login with the
> username "anonymous" and a password of your e-mail address. After
> logging in, type "cd internet-drafts" and then
> "get draft-swallow-rsvp-user-error-spec-00.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> [email-masked].
> In the body type:
> "FILE /internet-drafts/draft-swallow-rsvp-user-error-spec-00.txt".
>
> NOTE: The mail server at ietf.org can return the document in
> MIME-encoded form by using the "mpack" utility.  To use this
> feature, insert the command "ENCODING mime" before the "FILE"
> command.  To decode the response(s), you will need "munpack" or
> a MIME-compliant mail reader.  Different MIME-compliant mail readers
> exhibit different behavior, especially when dealing with
> "multipart" MIME messages (i.e. documents which have been split
> up into multiple messages), so check your local documentation on
> how to manipulate these messages.
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>

--------------------------------------------------------------------------------

> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce
> 

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: "Tom Petch" <[email-masked]>
Date: Mon, 16 Oct 2006 19:00:02 +0200

I wonder why the IEEE-controlled OUI is used to identify an organisation.  In
other WG, I see the IANA-controlled private.enterprises branch of the ISO naming
tree used.  Either would do but I would like to see an explanation.

Tom Petch

---

From: George Swallow <[email-masked]>
Date: Mon, 16 Oct 2006 17:55:24 -0400

> tree used.  Either would do but I would like to see an explanation.

I have no religion on this topic.  If the consensus is IANA, that's fine
by me.  I just want a convenient way to dis-ambiguate!

...george

========================================================================
George Swallow             Cisco Systems                  (978) 936-1398
                           1414 Massachusetts Avenue
                           Boxborough, MA 01719

---

From: "Tom Petch" <[email-masked]>
Date: Wed, 18 Oct 2006 09:53:20 +0200

---- Original Message -----
From: "George Swallow" <[email-masked]>
To: "Tom Petch" <[email-masked]>
Cc: "Adrian Farrel" <[email-masked]>; <[email-masked]>;
<[email-masked]>; <[email-masked]>
Sent: Monday, October 16, 2006 11:55 PM
Subject: Re: [mpls] Fw: I-D ACTION:draft-swallow-rsvp-user-error-spec-00.txt

> by me.  I just want a convenient way to dis-ambiguate!
I too have no religion but ...

The two marketplaces are different.  Although positioned as User extensions, I
see this as a place for the IETF to expand into when (not if) the original octet
is used up.

For those working in the IEEE 802.1 bridge/switch marketplace, OUI will be a
commonplace; for a Xerox or Cisco, it would be, which of our dozens of OUI shall
we use today?  Other organisations do not have them (like the IETF, I believe)
and the bar to getting one is higher than for an enterprise number in the ISO
space.

OUI is a nice fixed length binary number, an enterprise number is (strictly) an
ordered sequence of positive integers of indeterminate length (altough we could
use just the assigned enterprise number), whose encoding needs to be determined
(especially if the whole sequence is used).

Mmmm... I don't know which is right for this application.

That apart, I think the I-D an excellent idea.

Tom Petch

PS Apologies for any posting problems with this; I am subscribed with different
e-mail addresses to ccamp and mpls and am using the latter for this.