Subject: [mpls] Re: comments on draft-ietf-mpls-ldp-p2mp-01

From: Ina Minei <[email-masked]>
Date: Thu, 19 Oct 2006 10:46:45 -0700 (PDT)

Please see answers below, marked ###.

 				Ina

On Thu, 19 Oct 2006 [email-masked] wrote:

> Hi, all
>
> I read the draft-ietf-mpls-ldp-p2mp-01 and have some questions.
>
> In section 2.1
> In which situation will the opaque value contains more than one LDP MP
> Opaque Value Elements?
>

### This depends on what is the information carried in the opaque value 
element. This is outside the scope of this document. This document 
is only concerned with how the information is encoded. Allowing multiple 
of them ensures maximum flexibility.

> In section 4.1
> Does such a wildcard MP2MP FEC exist with only Opaque length set to 0,
> which is for matching root node address.
>
> In this draft, why wildcard P2MP FEC is not mentioned.

### It is defined in 2.1.

>
> In section 5
> "P2MP and MP2MP Downstream wildcard FEC may appear only in Label Request,
> Label Withdraw and Label Release messages."
> I do not think Label Request will be used with P2MP and MP2MP Downstream
> wildcard FEC, for P2MP/MP2MP LSP is initialized by
> leaf node. And when will the upstream node send Label Request to the
> downstream node?
>
> "MP2MP Upstream wildcard FEC may appear only in Label Withdraw and Label
> Release messages."
> When the leaf node initialized the MP2MP LSP, it may or may not send Label
> Request Message with MP2MP Upstream wildcard FEC.
> However it is reasonable to send Label Request Message with MP2MP Upstream
> wildcard FEC, for it is issued by the leaf node.
> Then MP2MP Upstream wildcard FEC may appear in Label Request.
>
> Maybe I have missed some key point. Thanks!

### You may want to look at the wildcard FEC draft
draft-thomas-mpls-ldp-typed-wildcard-00.txt

>
> Best Regards
> Jin.lizhong
> ZTE
>
>
> --------------------------------------------------------
> ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
> This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
> This message has been scanned for viruses and Spam by ZTE Anti-Spam system.
>

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: [email-masked]
Date: Thu, 19 Oct 2006 10:17:18 +0800

Hi, all

In section 2.1

In section 4.1

In section 5

Best Regards
Jin.lizhong
ZTE