Subject: Re: [MPLS] LDP GR query

From: Ramesh Huliyar <[email-masked]>
Date: Mon, 16 Oct 2006 18:06:12 +0530 (IST)

Hello,

I feel that RTB LDP session will go down with RTA immidietly when the link goes down. After the re-establishment of the LDP session, RTB will be sending FT session TLV with Recovery Time 0. This will cause the RTA to remove the stale FEC-to-label mapping. But until this happens, traffic will be black holed.

To overcome this, other methods of identifying link failures in RTA have to be employed, such as BFD, this will help RTA to use alternate FEC-to-Label mapping, because link failure does not start LDP GR but it will bring down LDP session in case of link level LDP.

Regards
Ramesh Huliyar

----- Original Message ----
From: Yu Yi <[email-masked]>
To: [email-masked]; [email-masked]
Sent: Monday, 16 October, 2006 2:51:33 PM
Subject: RE: [MPLS] LDP GR query

空白

BODY {
MARGIN-TOP:25px;FONT-SIZE:10pt;MARGIN-LEFT:25px;COLOR:#000000;}
P.msoNormal {
MARGIN-TOP:0px;FONT-SIZE:10pt;MARGIN-LEFT:0px;COLOR:#ffffcc;}
LI.msoNormal {
MARGIN-TOP:0px;FONT-SIZE:10pt;MARGIN-LEFT:0px;COLOR:#ffffcc;}

  For your case it is fine. RTB should be in normal 
case(normal session down)(no any GR flow) and delete all LSPs which 
are established on the port.  After session up again RTA will re-send 
the same label mapping which are sent before session down. But as you know 
during this period the MPLS traffic are lost. So this is not a complete GR 
case. 

  GR is applicable only if the forwarding plane is 
fine.

From: [email-masked] 
[mailto:[email-masked]] 
Sent: 2006年10月16日 3:07 
PM
To: [email-masked]
Subject: [MPLS] LDP GR 
query

Hi 

I 
have query related to LDP Graceful Restart. 
 
RFC 
3478 say
 
When an 
LSR detects that its LDP session with a neighbor went 
down,
 
   and the LSR knows that the 
neighbor is capable of preserving its MPLS
 
   forwarding state across the 
restart (as was indicated by the FT
 
   Session TLV in the Initialization 
message received from the
 
   neighbor), the LSR retains the 
label-FEC bindings received via that
 
   session (rather than discarding 
the bindings), but marks them as

"stale".

  RFC 3478 say that a 
router will implement GR flow when it detect that its LDP session with a 
neighbor went down.
 
 But there are many cases which can cause 
the LDP session went down ,and it’s neighbor don’t restart 
actually.

Consider 
this scenario: 

 

Suppose that the link between RTB and LAN-SWITCH is 
broken down, then RTA will detects that its LDP session with RTB went down, then 
RTA will implement GR flow, even the LDP session between RTA and RTB is 
re-established after the link between RTB and LAN-SWITCH  is resumed. Because the FT TLV in the 
initialization message of RTB don’t indicate that RTB whether reboot or not, so 
RTA is still implement GR flow.
 
Now RTA is in GR flow , but RTB isn’t in GR 
flow.
 
But what will happen if RTA is in GR flow , at the 
same time RTB isn’t in GR flow? I think it will fall into 
confusion.

Another example that the 
LDP 
session will be down is 
that the LSR’s neighbor can’t send out it’s packet, including hello packet or 
keepalive packet, if the control plane of it’s neighbor is very busy or occurs 
some error ,then the LDP 
session will be down. In this case the LSR will conclude that it’s neighbor 
restart and the LSR will implement GR flow.

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

__________________________________________________________
Yahoo! India Answers: Share what you know. Learn something new
http://in.answers.yahoo.com/

_______________________________________________
mpls mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mpls

---

From: [email-masked]
Date: Tue, 17 Oct 2006 08:50:05 +0800

空白Hello,

Then how about another scenario?

Another example that the LDP session will be down when the LSR’s neighbor can’t send out it’s packet, including hello packet or keepalive packet, if the control plane of it’s neighbor is very busy or occurs some error ,then the LDP session will be down. In this case this two LSR will conclude that it’s neighbor restart and the LSR will implement GR flow.

I mean the LDP protocol has some problem.In this case the link is ok,so the BFD can't be used.

When they re-establish the session,they will perform GR flow together.

  ----- Original Message ----- 
  From: Ramesh Huliyar 
  To: Yu Yi ; [email-masked] ; [email-masked] 
  Sent: Monday, October 16, 2006 8:36 PM
  Subject: Re: [MPLS] LDP GR query

  Hello,

  Regards
  Ramesh Huliyar

  ----- Original Message ----
  From: Yu Yi <[email-masked]>
  To: [email-masked]; [email-masked]
  Sent: Monday, 16 October, 2006 2:51:33 PM
  Subject: RE: [MPLS] LDP GR query

    For your case it is fine. RTB should be in normal case(normal session down)(no any GR flow) and delete all LSPs which are established on the port.  After session up again RTA will re-send the same label mapping which are sent before session down. But as you know during this period the MPLS traffic are lost. So this is not a complete GR case. 
    GR is applicable only if the forwarding plane is fine.

------------------------------------------------------------------------------

  From: [email-masked] [mailto:[email-masked]] 
  Sent: 2006年10月16日 3:07 PM
  To: [email-masked]
  Subject: [MPLS] LDP GR query

  Hi 

  I have query related to LDP Graceful Restart. 

  RFC 3478 say

  When an LSR detects that its LDP session with a neighbor went down,

     and the LSR knows that the neighbor is capable of preserving its MPLS

     forwarding state across the restart (as was indicated by the FT

     Session TLV in the Initialization message received from the

     neighbor), the LSR retains the label-FEC bindings received via that

     session (rather than discarding the bindings), but marks them as

     "stale".

    RFC 3478 say that a router will implement GR flow when it detect that its LDP session with a neighbor went down.

   But there are many cases which can cause the LDP session went down ,and it’s neighbor don’t restart actually.

  Consider this scenario: 

  Suppose that the link between RTB and LAN-SWITCH is broken down, then RTA will detects that its LDP session with RTB went down, then RTA will implement GR flow, even the LDP session between RTA and RTB is re-established after the link between RTB and LAN-SWITCH  is resumed. Because the FT TLV in the initialization message of RTB don’t indicate that RTB whether reboot or not, so RTA is still implement GR flow.

  Now RTA is in GR flow , but RTB isn’t in GR flow.

  But what will happen if RTA is in GR flow , at the same time RTB isn’t in GR flow? I think it will fall into confusion.

  Another example that the LDP session will be down is that the LSR’s neighbor can’t send out it’s packet, including hello packet or keepalive packet, if the control plane of it’s neighbor is very busy or occurs some error ,then the LDP session will be down. In this case the LSR will conclude that it’s neighbor restart and the LSR will implement GR flow.

---

From: "Yu Yi" <[email-masked]>
Date: Tue, 17 Oct 2006 11:33:27 +1000

I think for this scenario RTA and RTB both consider the peer restart and perform the GR process. So RTA will re-send all mapping and RTB also do so. and then after receiving mapping all the LSP's stale flag are cleared and a perfect GR is finished.
  The traffic won't be lost if the forwarding plane is ok.  

________________________________

From: [email-masked] [mailto:[email-masked]] 
Sent: 2006年10月17日 8:50 AM
To: Ramesh Huliyar; Yi, Yu (SUNP:1G11); [email-masked]
Subject: Re: [MPLS] LDP GR query

Hello,

 

	----- Original Message ----- 
	From: Ramesh Huliyar <mailto:[email-masked]>  
	To: Yu Yi <mailto:[email-masked]>  ; [email-masked] ; [email-masked] 
	Sent: Monday, October 16, 2006 8:36 PM
	Subject: Re: [MPLS] LDP GR query

	Hello,

	
	Regards
	Ramesh Huliyar

	----- Original Message ----
	From: Yu Yi <[email-masked]>
	To: [email-masked]; [email-masked]
	Sent: Monday, 16 October, 2006 2:51:33 PM
	Subject: RE: [MPLS] LDP GR query

________________________________

	 

	Hi 

	RFC 3478 say

	   "stale".

	Consider this scenario:

---

From: [email-masked]
Date: Tue, 17 Oct 2006 10:43:00 +0800

空白Hi Yu Yi,
When two LSR fall into GR flow,then some LSP will be updated only after GR,such as the lsp which should be deleted.
I think GR flow will delay the updating of LSP,so it's better don't perform GR flow in mistake.

Lixing Wang

  ----- Original Message ----- 
  From: Yu Yi 
  To: [email-masked] ; Ramesh Huliyar ; [email-masked] 
  Sent: Tuesday, October 17, 2006 9:33 AM
  Subject: RE: [MPLS] LDP GR query

  Hello,

    ----- Original Message ----- 
    From: Ramesh Huliyar 
    To: Yu Yi ; [email-masked] ; [email-masked] 
    Sent: Monday, October 16, 2006 8:36 PM
    Subject: Re: [MPLS] LDP GR query

    Hello,

    Regards
    Ramesh Huliyar

    ----- Original Message ----
    From: Yu Yi <[email-masked]>
    To: [email-masked]; [email-masked]
    Sent: Monday, 16 October, 2006 2:51:33 PM
    Subject: RE: [MPLS] LDP GR query

----------------------------------------------------------------------------

    Hi 

    RFC 3478 say

       "stale".

    Consider this scenario:

---

From: "Yu Yi" <[email-masked]>
Date: Tue, 17 Oct 2006 13:01:33 +1000

GR process has 2 case: The first is the process of the restart router. The second is the process of the peer router of the restart router.
 
I guess you are thinking "GR flow" you mentioned in you mail is the first case. But I feel in your scenario both RTA and RTB are in process of the second process. In this process LDP should update LSP once the route are changed.

From: [email-masked] [mailto:[email-masked]] 
Sent: 2006年10月17日 10:43 AM
To: Yi, Yu (SUNP:1G11); Ramesh Huliyar; [email-masked]
Subject: Re: [MPLS] LDP GR query

Hi Yu Yi,
 
Lixing Wang

	----- Original Message ----- 
	From: Yu Yi <mailto:[email-masked]>  
	To: [email-masked] ; Ramesh Huliyar <mailto:[email-masked]>  ; [email-masked] 
	Sent: Tuesday, October 17, 2006 9:33 AM
	Subject: RE: [MPLS] LDP GR query

	Hello,

	 

		----- Original Message ----- 
		From: Ramesh Huliyar <mailto:[email-masked]>  
		To: Yu Yi <mailto:[email-masked]>  ; [email-masked] ; [email-masked] 
		Sent: Monday, October 16, 2006 8:36 PM
		Subject: Re: [MPLS] LDP GR query

		Hello,

		
		Regards
		Ramesh Huliyar

		----- Original Message ----
		From: Yu Yi <[email-masked]>
		To: [email-masked]; [email-masked]
		Sent: Monday, 16 October, 2006 2:51:33 PM
		Subject: RE: [MPLS] LDP GR query

		 

		Hi 

		RFC 3478 say

		   "stale".

		Consider this scenario:

---

From: [email-masked]
Date: Tue, 17 Oct 2006 11:18:24 +0800

空白Hi Yu Yi,
I mean the second case, helper router.
The LSP which can't be update is the LSP that the router advertise when establish old session ,but it's invalid after establishing new session.

Lixing Wang
  ----- Original Message ----- 
  From: Yu Yi 
  To: [email-masked] ; Ramesh Huliyar ; [email-masked] 
  Sent: Tuesday, October 17, 2006 11:01 AM
  Subject: RE: [MPLS] LDP GR query

  Hi Yu Yi,

  Lixing Wang

    ----- Original Message ----- 
    From: Yu Yi 
    To: [email-masked] ; Ramesh Huliyar ; [email-masked] 
    Sent: Tuesday, October 17, 2006 9:33 AM
    Subject: RE: [MPLS] LDP GR query

    Hello,

      ----- Original Message ----- 
      From: Ramesh Huliyar 
      To: Yu Yi ; [email-masked] ; [email-masked] 
      Sent: Monday, October 16, 2006 8:36 PM
      Subject: Re: [MPLS] LDP GR query

      Hello,

      Regards
      Ramesh Huliyar

      ----- Original Message ----
      From: Yu Yi <[email-masked]>
      To: [email-masked]; [email-masked]
      Sent: Monday, 16 October, 2006 2:51:33 PM
      Subject: RE: [MPLS] LDP GR query

--------------------------------------------------------------------------

      Hi 

      RFC 3478 say

         "stale".

      Consider this scenario: